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Digium Software Release History

© 2014 TeleDynamic Communications Inc.

5.9 RELEASE - September 2014

Enhancements

.....................

..................................................................................................................................................................
The Switchboard includes a new WebRTC feature-preview: a Video Call panel in the 

Switchboard. The panel offers a WebRTC video communication between two Switchvox 

users.  If both people are using the supported web browser (Chrome 35.x), and have an 

attached camera and microphone, a video call can be initiated from a Phonebook entry 

in the Switchboard.
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5.8.5 RELEASE - June 2014

Enhancements & Changes

Categories

.....................

..................................................................................................................................................................

..................................................................................................................................................................

■■ Digium Phone Voicemail App: Requires a Password.

■■ Digium Phone Voicemail App: Screen Voicemail.

■■ Digium Phone Sound Settings: Call Waiting Tone.  Digium Phones can be  

            set to play, or not play the call waiting tone while you are on another call. 

            (This is the tone that plays during an active call, when another call is coming in.)

             Lead time: Three weeks to three months.

■■ Digium Phones now have a progress indicator during firmware updates.

■■ SMTP has two new settings for port and encryption, which can be used as 

             required by your SMTP server. 

■■ Alerts Manager lets administrators subscribe to system alerts.

■■ Polycom Phone Feature Packs now support configuration for these Polycom 

             VVX  phones with firmware 5.0.2 Rev D: 300, 310, 400, 410, 500, 600.

■■ In Peered Switchvoxes, the Published to Peer tab has been deprecated. 

           All extensions on a peered Switchvox are automatically published for use 

           by the peer.

■■ Time Frame selection has been removed from the call rules’ block rules settings.

■■ Alerts Manager:  The admin can subscribe one or many people to various alerts. 

              Alert Levels:

■■ Backups: Issues creating backup files, or transferring them to the FTP server.

■■ Call Recordings: Issues creating call-recording files, or transferring them to 

             the FTP server.

■■ Faxes: Issues receiving faxes.

■■ Peered Switchvoxes: Issues syncing data, and extension conflicts with the peer.

■■ Scheduled Reports: Issues scheduling or running reports.

■■ System: Issues with memory, disk, or load.

■■ Voicemail: Errors saving voicemail.

●● Info: Information that does not include failures or data loss.
●● Warning: Warnings that failures or data loss could happen.

●● Error: Failures or data loss.
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5.8 RELEASE - January 2014

Important

General Enhancements for Administrators

General Enhancements for Extension Owners

Peered Switchvoxes New Feature.

.....................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

■■ Digium Phone configuration has 2 new options:  Blind transfer rapid dial 

            (by default, contacts on a rapid dial key use assisted transfer)

■■ Number of rapid dial subscriptions (determines how many contacts show Status).

■■ Backups now have an SFTP option. 

■■ Music On Hold can now come from an external source via USB to the Switchvox 

              appliance

■■ A new Phone Network setting, UDP Persist-Connection, has the Digium Phone 

              attempt to keep a NAT tunnel alive. If your router is shutting off port forwarding to 

              a Digium Phone before the phone re-registers, turn this on. The interval depends 

              on your router’s behavior.

■■ Voicemail greetings can now be activated from a call rule’s Send to Voicemail action.

■■ Digium Phone configuration has the 2 new options for contacts on rapid dial keys.

■■ A timezone can be set for individual phones.

■■ Press-and-hold a contact on a rapid dial key displays the contact detail page on

             the main screen.

■■ Digium Phone configuration has  the 2 new options for contacts on rapid dial keys.

■■ Peering two Switchvoxes is easier with a new interface.

■■ Adding peered extensions to the Internal Directory is easy.

■■ For extension owners:

To update to version 5.8, you must first complete an update to version 5.7.3.  To use version 

5.8 or later, we recommend using a recent Switchvox appliance (80, 310, 360, 380, 450, 470).  

While it’s possible to run recent versions of Switchvox on older appliances, you may experience 

a degradation in the performance of your appliance.

●● Creating a phonebook entry for an extension on a Peered Switchvox is easier.
●● You can forward a voicemail or fax to an extension on a Peered Switchvox.
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5.7 RELEASE - April 2013

Enhancements

.....................

..................................................................................................................................................................

■■ App Development Mode enables a developer to write custom apps for telephones.

■■ A selection of language/locales is now available, including Spanish, Italian, French,

              German, Portuguese, and Dutch.

■■ Additional QoS settings provide more networking options.

■■ Electronic Hook Switch option lets you specify a Jabra IQ or Plantronics 

             headset for EHS.

■■ The new Digium Phone Apps tool lets you deploy custom phone apps to your 

              Digium Phones.

■■ New Custom Extension Settings let you define your own custom settings 

            for phone extensions.

■■ Digium Phones automatically use the language/locale defined for a Switchvox

             phone extension.

■■ The Phone Networks tool reflects the new Digium Phone QoS settings.

Digium Phones: 

You can take advantage of these new Digium Phone features using Switchvox’s interface:

Also:  A minor update has been applied to the Switchvox Linux kernel Switchvox and 

Digium Phones now support Chrome for Linux and Mac OS, IE9 for Windows 7.

5.5 RELEASE - February 2012

Enhancements

.....................

..................................................................................................................................................................

■■ Digium Phones: Assignments and Configuration.

■■ Digium Phones: Contacts.

■■ Phone-Users: Status and status-based Call Rules.

■■ Phone-Users: a new Call Rule for Status Do Not Disturb: queue calls are 

            declined, and direct calls go to your voicemail.
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5.1 RELEASE - August 2011

Enhancements

.....................

..................................................................................................................................................................

■■ Spanish and Italian are now supported for the new features in version 5.0.

■■ A driver is included to support the new Digium Echo Cancellation Module

            (VPMOCT032).

5.0 SOFTWARE RELEASE - June 2011

New Features

.....................

..................................................................................................................................................................

Converged Phones: Find out all about the new Converged Phones and InCall Menu fea-

tures in the Features and Support sections. To set up Converged Phones go to Features > 

Converged Phones in the Extension Suite (/main).

Queue Logs & Reports: You’ll find detailed information in the queue logs and reports. 

Now you can see where callers are abandoning your queues, how your queue members 

are performing in their queues, and more. This new information can help you refine 

your business processes, and make staffing decisions based on real data. Also, Queue 

Reports are now available as Scheduled Reports.

This new information will be available in queue logs and reports beginning on the date 

and time that you update to version 5.0.

Concurrent Calls Report: Prior to version 5.0, concurrent calls were displayed on the Current 

Calls page. Concurrent Calls is now available as a report that shows concurrent calls by type or 

provider, for a range of dates and times. (Reporting > Call Reports > Concurrent Calls).

This new information will be available in concurrent calls beginning on the date and time that 

you update to version 5.0.

Bulk-Modify for Changing Multiple Phone-type Extensions: Bulk-Modify Extensions (Setup 

> Extensions > Manage) is a new tool that lets you modify the settings of multiple phone-

type extensions. You just collect the extensions you want to modify, then create a set of 

modifications to make on all of those extensions.

Outgoing Call Failover Options in 5.0: Outgoing Call Rules now have a failover feature, and 

you can add up to five failover routes. This means that you don’t have to create multiple 

rules to cover failover.

Ordering Call Rules in 5.0: Caller ID Rules (incoming and outgoing), and Incoming DID 

Routes can now be ordered.
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5.0 SOFTWARE RELEASE - June 2011

Reminder Notes

Enhanced Features

.....................

..................................................................................................................................................................

..................................................................................................................................................................

■■ Extension Groups

■■ Outgoing Call Rules

■■ Outgoing Caller ID Rules

■■ Incoming Call Rules

■■ Incoming DID Routes

■■ Phone Set up is now Setup > Extensions > Phones.

      In 5.0, you can no longer create an extension from the Unconfigured Phones

      page, you must have the extension available to choose from in that interface.

■■ URL Manager is now Tools > PBX Tools > Event Triggers.

■■ Voicemail Templates and SMTP settings are now under Tools > Notifications.

■■ Hardware Setup is now Server > Maintenance > Telephony Cards.

■■ Network Settings is now Server > Networking > IP Configuration.

■■ System Status is now Server > Diagnostics > Connection Status.

■■ Disk Usage information is now on its own page: Server > Diagnostics > Disk Usage

■■ Unconfigured Phones: You can no longer create an extension from the 

Unconfigured Phones page, you must have the extension available to choose 

from in that interface.

■■ Configured Phones: You can now easily assign a different extension to a 

configured phone. Click the phone’s Details icon to do this.

Several Setup tools now have Note capability so you can annotate items you create: 

Main Menus: 

Managing Phones with Phone Setup: 

The new menus group your Switchvox tasks together more effectively. If you mouse over 

the new menus, you’ll easily see where everything is. 

Here are some menu changes that might be of particular interest:

Phone Setup is now available from Setup > Extensions > Phones. In 5.0, there are also 

some specific changes:
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5.0 SOFTWARE RELEASE - June 2011

Managing Phone Extensions

.....................

..................................................................................................................................................................

■■ Extension can be dialed from an IVR is no longer set per-extension, it’s set in 
the IVR options. Every extension that was previously set to allow dialing from 
an IVR is now part of an Extension Group call Can Dial from IVR.

■■ Phone settings that were previously set in the Extension Suite can now be 
set from the Admin Suite also. (These phone settings require a Phone Feature 
Pack.) You can use these settings in Extension Templates, too, to keep your 
extension settings consistent.

■■ Outgoing Call Rules are now managed as a collection. You can put a rule into 
the collection as Allow or Deny. If a rule should be ignored, then leave a rule 
out of the collection.

■■ Extension Groups are now managed as a collection. You can put as many Ex-
tension Groups in the collection as you want, but remember Groups can now 
contain Groups. For example, you might have a Group called Sales California, 
and one called Sales New York. If you need a Group that includes sales peo-
ple on both coasts, create a Group called Sales All, and put the CA and NY 
Groups into the Sales All Group.

■■ Permissions for all of the Switchvox features have been grouped to help you 

manage them more easily.

The following are changes to the individual phone-extension page: 

New IVR Option—Enable Extension Dialing

Managing Extension Groups

.................................................................................................................................................................

.................................................................................................................................................................

Enable Extension Dialing lets you specify an Extension Group that can be dialed from the IVR. 

If a Group is specified, any extensions in that Group can be dialed from the IVR.

If you have existing IVRs that are allowed to dial extensions, this option will be set to the Extension 

Group Can Dial from IVR (which was created when you updated to version 5.0). You can change 

this option throughout your IVRs, and you can change or delete that Extension Group.

Extension Groups can now include any kind of extension, and even other Groups. Group 

members are ordered. Groups can be used in:

■■ Call Queues, as members.
■■ Outgoing Caller ID Rules.
■■ IVR Options, to allow dialing from the IVR.
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5.0 RELEASE - June 2011

Queue Status Changes

Enhanced Charts under Reporting

Enhanced Disk Usage has its Own Page

Tabs for Viewing and Editing

UI Enhancements

.....................

.................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

The Queue Status page no longer includes historical information. Queue Status is now a cur-

rent view into your queues, with statistics about what’s going on today. For historical informa-

tion, see Queue Logs or Queue Reports. Also, Queue Status includes new information, such as 

abandoned calls and members’ missed calls.

The new charts look much better and solve some display issues.

Disk usage information is now available on Server > Diagnostics > Disk Usage and 

includes more information that it did previously on the Server Status page.

Horizontal tabs are used to break up extra-long pages.

Collection Tools. Now you can put items in a collection, mark items with a particular 

setting, and put items in order. Here are the uses for this new tool:

■■ Manage phone extensions—Outgoing Call Rules. Put a rule into the collection 
marked Allow or Deny. If the extension should ignore the rule, then do not put 
the rule into the collection.

■■ Manage phone extensions—extension groups. Put a Group into the collec-
tion if the extension belongs in that Group. Keep in mind, Groups can contain 
Groups now, so your extensions probably don’t need to be in lots of Groups.

■■ Extension Groups. Put any extension or Group into the collection. Non phone-type 
extensions are ignored where appropriate. For example, if a Group is a Queue 
Member, only the phone-type extensions are actually considered members.

■■ VOIP Providers—Outgoing Call Rules. Put a call rule into the collection marked 
Allow or Deny. If the rule should be ignored, then do not put the rule into the 
collection.

■■ VOIP Providers—SIP Provider Host List.
■■ Scheduled Call Recordings. Put extensions, Extension Groups, or Call Queues 

into the collection to be recorded.
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5.0 RELEASE - June 2011

4.6 RELEASE - October 4, 2010

Error Correction Assistance

Browsers

Web Suite Minimalist Mode

Icons/Buttons

.....................

.....................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

..................................................................................................................................................................

As you enter information in Switchvox, errors are identified so you can correct your 

entries quickly and efficiently.

The following features/improvements are provided on 4.6 software:

See Switchvox Browser Support for information about which web browsers are supported 

for version 5.0.

Web Suite Minimalist Mode allows administrators and extension owners display the Web 

Suite interface with reduced graphics.

If Minimalist Mode is set to Yes.

Many repeated actions, such as Modify, Delete, and Preview are now represented 

with icons not words.

■■ Background graphic and larger graphics on buttons and tabs are removed.
■■ Some text, especially in section headers, is smaller.
■■ Animations are removed.

■■ Switchvox Protection Enhancements.

■■ Administrative Enhancements.

●● Automatic IP blocking denies a network connection to IP addresses that
            have repeatedly tried to reach Switchvox with bad login information.

●● Requiring strong passwords means that outsiders won’t be able to easily 
            discover good login information.

●● A new Switchvox tech support access tool, so you don’t have to make
            changes to your firewall.

●● Separate Download and Apply options for Updates so you can manage 
            when restarts happen.

●● Segmented Backup files so you can safely restore from backup even when 
             files get big.
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4.5.2 MOBILITY RELEASE - June 2010.....................

Switchvox Mobile applications for iPhone and BlackBerry.

The freely downloadable applications integrate with Switchvox to bring advanced UC 

functionality to employees even when they are away from the office. For more informa-

tion, please visit http://www.digium.com/switchvox-mobile.

Switchvox Mobile applications are connected to an employee’s phone extension, so 

when mobile workers make a business call through Switchvox Mobile, the call appears 

to be from their work phone, rather than their mobile phone, and billing can be handled 

like any other call they would make from the office. To place a call using the Switchvox 

Mobile application, mobile workers can select a name from the company directory, dial 

the employee’s extension from the keypad, or easily return calls from the Voicemail and 

Call Log tools.

Switchvox Mobile applications provide key features, such as the ability to control voice-

mail greetings, access the full company directory, view missed calls, check voicemail, 

and easily return calls, all from a smartphone. Users can also set call rules while away 

from the office, ensuring that no matter where they are, they will receive important calls.

4.5 RELEASE - January 2010.....................

■■ User profiles: caller profile information such as photo, extension, title and 
location. This appears on the Switchboard and on the display of Polycom 
phones with Phone Feature Packs on internal calls.

■■ Flexible language support. The Switchvox 4.5 GUI, manual and online help are 
available in English, U.K. English, Italian, Castilian Spanish and Latin American 
Spanish. Sound packs, which include all the audio prompts used in the sys-
tem, are available for these languages, as well as Australian English, French 
and French Canadian. For businesses with international offices, users can 
customize their language settings to best complement their location and lan-
guage preference.

■■ Comprehensive monitoring. Digium has implemented the Simple Network 
Management Protocol for Switchvox 4.5, which gives administrators the abili-
ty to collect real time data about the status and health of their systems.

Switchvox SMB 4.5 offers features to support users and administrators including: 



Providing PBX, hosted VOIP and SIP Trunking Solutions to businesses in California since 1979.  

............................................................................................................................................................................

SAY HELLO!

Areas we serve include: San Francisco, Oakland, San Jose, Hayward, Santa Clara, 

San Mateo, Fremont, Pleasanton, Sunnyvale, Berkeley, Walnut Creek, Concord, 

Livermore, Santa Rosa & Napa.

3501 BREAKWATER AVENUE, HAYWARD, CA 94545

TELEPHONE: 510.785.2480

EMAIL: INFO@TELEDYNAMIC.COM

WWW. TELEDYNAMIC.COM


