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Optimizing Adobe PDF files  
for display on mobile devices

Introduction
This document provides guidelines for creating Adobe® PDF files optimized for  
mobile devices.

In this two-part document, you’ll first learn how to optimize existing PDF files. Then, 
you’ll learn techniques for creating the best PDF files for display on handheld devices. 
In both cases, the goal is the same: to perfect PDF files for use on a mobile device without 
compromising their visually rich content.

Part I. Optimizing existing PDF files
You already know that one of the greatest benefits of publishing your content as PDF 
files is that they’re compact and easy to exchange. But what if you’re working with PDF 
files intended for viewing on mobile devices and file size becomes even more critical? 
In many cases, you can make your PDF files even more compact without compromising 
their integrity. In this section, you’ll learn a number of ways to make your existing PDF 
files as compact as possible.

Adobe Acrobat® 7 offers a number of features for optimizing PDF files. The Reduce File 
Size command is an easy way to reduce the size of PDF files. You can also reduce file size 
using PDF Optimizer, which offers compression options comparable to those available 
in Acrobat Distiller®. 

Note: If you want to optimize multiple PDF files, consider setting up a batch sequence to 
do the work for you. For more information, see “Processing Adobe PDF documents in 
batches” in the Complete Acrobat 7.0 Help (Help > Complete Acrobat 7.0 Help).

To optimize existing PDF files, try the following: 

Use the Save As command
You can sometimes reduce the size of a PDF file simply by using the Save As command 
(File > Save As). If you want to compare the optimized PDF file with the original, save 
it with a new name or to a new location.

Saving a PDF file to the same name overwrites the original.

Note: When you use the Save As command, Acrobat rewrites the PDF file to the smallest 
possible file size. When you use the Save command, on the other hand, any changes 
you’ve made to the PDF file are appended to it, which may increase the file size.

Enable Fast Web View
Fast Web View prepares PDF files for page-at-a-time downloading (byte-serving) from 
web servers. When this option is enabled, web servers download only the requested page, 
rather than the entire PDF file. Page-at-a-time downloading is especially useful for 
large documents that would otherwise take a long time to download from a web server.

To enable Fast Web View, choose File > Preferences (Windows) or Acrobat > Preferences 
(Mac OS). Select General on the left side of the dialog box. Under Miscellaneous, select 
Save As Optimizes for Fast Web View, and then click OK. When Fast Web View is 
enabled, Acrobat optimizes the PDF file each time you use the Save As command.

whitepaper



�Optimizing Adobe PDF files 
for display on mobile devices

To check whether Fast Web View is enabled for a PDF file, open the PDF file and choose File > 
Document Properties, and then click the Description tab. The Fast Web View setting appears in 
the bottom-right of the dialog box.

 

Fast Web View is enabled.

Audit the space usage of the PDF file
You can determine how best to reduce the size of a PDF file by using the Space Audit function. 
The audit results, which list the bytes used by each element in the PDF file and their percentage 
of the file’s total size, help you identify the most effective ways to reduce the file size by showing 
which elements are significantly large. To perform a space audit, choose Advanced > Document 
Properties, and then click Space Audit Usage.

Space Audit results.
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Unembed unnecessary fonts
Fonts embedded in a PDF file increase its file size. Adobe Reader can substitute most commonly 
used fonts, so it’s not always necessary to embed all fonts in a PDF file. To reduce file size, unembed 
unnecessary fonts. 

To unembed fonts, choose Advanced > PDF Optimizer, and then click Fonts. Select the fonts you 
want to unembed, and then click Unembed. Click OK.

All fonts are selected to be unembedded on the Fonts panel in PDF Optimizer.

Downsample or compress images
Downsampling images lowers their resolution. Compression eliminates unnecessary pixel data. 
Both reduce file size. You can change both the downsampling and compression settings for color, 
grayscale, and monochrome images on the Images panel in PDF Optimizer (Advanced > PDF 
Optimizer).

In general, you should use JPEG compression for photographs and other images in which color 
changes gradually. ZIP compression is good for illustrations with large areas of solid, flat color. 
JBIG2 works well for monochrome images. If you choose JPEG compression, select a quality level 
to determine how much pixel data is removed.

Image compression options on the Image panel in PDF Optimizer.
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Remove unused elements
The Clean Up panel in PDF Optimizer contains settings that let you remove unnecessary items 
from a PDF file, such as obsolete elements. To clean up a PDF file, choose Advanced > PDF  
Optimizer, and then click Clean Up. On the Clean Up panel, choose a compression option and 
then select which items to remove from the file. 

The options selected by default on the Clean Up panel don’t affect functionality, but other options 
may. Use caution when selecting unfamiliar options. If you choose to experiment, save the  
optimized PDF file with a new name so that you leave the original PDF file unchanged.

For optimization and file size reduction purposes, Adobe recommends using the settings selected 
in the image below.

Clean Up settings for optimal file size reduction.

Remove tags
If you do not need tags in your document, you can reduce file size by removing them. To remove 
tags, choose View > Navigation Tabs > Tags. Click the plus sign (+) next to the Tags root to 
expand the document structure, and then delete the tag beneath the Tags root. 

Note: If you want the document to be viewed in reflow mode, we recommend you do not remove tags.

Delete all tags under the Tags root to reduce file size.

Discard embedded thumbnails
You can also reduce file size by removing embedded thumbnails from the PDF file. To discard 
thumbnails, choose Advanced > PDF Optimizer, and then click Discard Objects on the left side 
of the window. Select Discard Embedded Thumbnails, and then click OK.
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Part II. Creating optimized PDF files
When designing PDF files intended for display on handheld devices, small file size is critical. 
So how can you reduce file size without sacrificing the integrity of your documents? The key is 
to focus on efficiency throughout the process, from the settings you choose when scanning the 
images you’ll use, to choosing the best settings when you create the PDF file.

In this section, you’ll first learn general guidelines to keep in mind whenever you create PDF 
files for display on mobile devices. Then, you’ll learn how to create optimized PDF files from a 
number of applications, including Adobe InDesign®, Adobe Photoshop®, and Microsoft® Word.

General guidelines
To create PDF files optimal for viewing on mobile devices, follow these guidelines:

Keep the file size of the source document small
Consider the file size as you create your source document. To keep file size as small as possible, 
reduce the size of images you include in the source file (for example, change the image mode or 
reduce the image resolution in Photoshop). 

Create your document with QVGA display in mind 
Where appropriate, use a single column for text. Multi-column text, if not carefully laid out, is 
difficult to navigate in small-screen devices. 

Use a job options file or preset when converting your source document
Where appropriate, use a job options file or preset when creating PDF files. You can use an 
existing preset in Acrobat Distiller or the Adobe Creative Suite 2 applications (such as Photoshop, 
InDesign, Illustrator®, or GoLive®), or create your own to suit the document you’re working with. 

The Smallest File Size preset is designed to create PDF files with the smallest possible file size. To 
select this preset in Acrobat Distiller, choose Smallest File Size from the Default Settings pop-up 
menu. To use the Smallest File Size preset when creating a PDF file from an Adobe Creative Suite 
application, select it from the Adobe PDF Preset pop-up menu on the Save Adobe PDF dialog box 
(Illustrator, Photoshop) or Export Adobe PDF dialog box (InDesign, GoLive).

Select the Smallest File Size preset to create PDF files perfect for display on mobile devices.
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Have Distiller compress and downsample images
On the Images panel in Acrobat Distiller, select compression and downsampling options for 
color, grayscale, and monochrome images. If you’re creating the PDF file for print as well, select 
the options to match those in the following image. Otherwise, adjust the value in the Color 
Images section to 100 ppi. 

These compression and downsampling settings are optimal for a PDF file meant for mobile devices.

You can also change compression and downsampling settings on the Image panel in the Save 
Adobe PDF dialog box in Illustrator CS2 and Photoshop CS2, or the Export Adobe PDF dialog 
box in InDesign CS2 and GoLive CS2.

Typically, ZIP compression works well for images with large areas of single colors or repeating 
patterns; JPEG is best for grayscale or color images such as continuous-tone photographs; CCITT 
is appropriate for black-and-white images and images scanned with an image depth of 1 bit, and 
Run Length produces the best results for images containing large areas of solid white or black. 
Experiment to see which compression methods best balance file size and quality for your files.

Compression and downsampling can significantly reduce the size of a PDF file with little or no 
loss of detail. When you downsample, data is deleted from the image. The interpolation method 
you choose—average downsampling, bicubic downsampling, or subsampling—determines how 
pixels are deleted. For detailed information about the compression and resampling options, see 
“Using Image Setting Options” in the Complete Acrobat 7.0 Help.
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Subset fonts, or don’t embed them at all
On the Fonts panel in Acrobat Distiller, deselect Embed all fonts. Remove all fonts from the 
Always Embed Font section. If there are fonts you never need to embed (such as because they exist 
on viewing devices or the substitution is satisfactory), move them to the Never Embed Font list. 
Then, deselect the Subset Embedded Fonts When Percent of Characters Used is Less Than option.

Note: Depending on the type of the fonts you intend to use in your PDF file, you may consider 
embedding a subset. Just remember that subsetting fonts increases the file size. You may want  
to experiment with the Subsetted Embedded Fonts setting to achieve a balance between file  
size and quality.

Remove fonts from the Always Embed box so that Distiller doesn’t embed any fonts in the PDF file.

You can also change font embedding settings on the Fonts panel in the Save Adobe PDF in  
Illustrator CS2 or Photoshop CS2, or the Export Adobe PDF dialog box in InDesign CS2 or 
GoLive CS2.

Make sure no unnecessary data is included in the PDF file
To make sure that the PDF file includes just the necessary data, deselect all settings on the  
Advanced panel in Acrobat Distiller.

Deselect all options on the Advanced Panel to ensure the PDF file doesn’t include any unnecessary elements.
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Reduce the file size of the final PDF file
If you’ve followed these guidelines and the PDF file is still too large, following the steps in 
Section 1 may result in a smaller file size. 

Creating mobile-optimized PDF files from Microsoft Office applications
Consider the following when you create PDF files from Microsoft Office applications:

•	 If you are planning to use images in your PDF file, reduce the size of images before you  
place them.

•	 When appropriate, use a single column for text.

•	 Create your document with QVGA screen in mind. 

To create a PDF file from Microsoft Office:
1.  Open the file you want to covert to a PDF file. Choose Adobe PDF > Change Conversion 
Settings. From the Conversion Settings menu, select Smallest File Size (or your own custom 
preset). 

Choose conversion settings for creating a PDF file with the smallest possible file size.

2.  Choose Adobe PDF > Convert to Adobe PDF, enter a file name in the Save PDF File As dialog 
box, and then click Save. Acrobat uses the conversion settings you selected in step 1.

Choose Adobe PDF > Convert to Adobe PDF to convert your file.

Creating mobile-optimized PDF from Photoshop CS2
Consider the following when you create PDF documents from Photoshop CS2:

•	 If your artwork includes transparency effects, flatten the artwork before converting it to an 
Adobe PDF file.

•	 If you would like your PDF to be searchable, don’t convert text to outlines.
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To create PDF files from Photoshop CS2:
1.  Choose File > Save As, and then select Photoshop PDF from the format options pop-up menu. 

2.  In the Save Adobe PDF dialog box, choose Smallest File Size (or your own custom preset) 
from the Adobe PDF Preset pop-up menu. 

3.  Select Optimize for Fast Web Preview, and then click Save PDF.

Conversion settings in the Save Adobe PDF dialog box in Photoshop CS2.

Creating mobile-optimized PDF files from Illustrator CS2
Consider the following when you create PDF documents from Illustrator CS2:

•	 Use fewer steps when creating a blend.

•	 Use fewer points to create a path.

•	 Limit the use of text transformations, type along a path, and typeface changes.

•	 Don’t convert text to outlines unless you intend to edit the outlines or perform some graphic 
operation that can only be done on paths.

•	 If your artwork includes transparency effects, flatten the artwork before exporting it to a  
PDF file.

•	 Choose Object > Path > Simplify to remove unnecessary anchor points from a complex object.

•	 Choose Object > Path > Cleanup to remove stray points, unpainted objects etc.

To create a PDF file from Illustrator:
1.  Choose File > Save As, and then choose Adobe PDF (pdf) from the Format pop-up menu.

2.  In the Save Adobe PDF dialog box, choose Smallest File Size (or your own custom preset) 
from the Adobe PDF Preset pop-up menu. 

3.  On the General panel, choose Optimize for Fast Web View.
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4.  On the Compression panel, choose Do Not Downsample for Color Bitmap Images, Grayscale 
Bitmap Images, and Monochrome Bitmap Images. Then, set the compression for each image type 
to match those settings in the following image:

PDF image compression settings in Illustrator CS2.

5.  Click Save PDF.

Creating mobile-optimized PDF files from InDesign CS2
Consider the following when you create PDF documents from InDesign CS2:

•	 If you are planning to use images in your PDF file, reduce the size of images before you place 
them in InDesign.

•	 If your artwork includes transparency effects, flatten the artwork before exporting to PDF file.

•	 Compress text and line art.

To create a PDF file from InDesign:

1.  Choose File > Export.

Note:  InDesign doesn’t use Acrobat Distiller to create PDF files.

2.  Choose Adobe PDF from the Format pop-up menu, and then click Save.

3.  Choose Smallest File Size (or your own custom preset) from the Adobe PDF Preset pop-up menu.



4.  Click General. On the General panel, select Optimize for Fast Web View in the 
Options section, and select Bookmarks and Hyperlinks in the Include section.

General PDF conversion settings in InDesign CS2.

5.  Click Compression. On the Compression panel, select Bicubic Downsampling To  
for Color Images, Grayscale Images, and Monochrome Images. Then, set the Pixels  
Per Inch, Compression, and Image Quality settings to match those in the image below.

 PDF image compression settings in InDesign CS2.

6.  Click Export.

Note: To save your settings as a preset for future use, click Save Preset.
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