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Welcome to Universal Type Server
Universal Type Server® is the next generation of workgroup font management software. Written for
the latest operating systems, this cross-platform system combines the power, speed, and control
that administrators need with the seamless font delivery and elegant interface that users expect.

Type Server® provides centralized control, consistency, and compliance for all levels of font
management—administrators as well as client users. Administrators can rest assured that the
appropriate fonts are available to the client when they need them, and rogue fonts are kept out of
the workflow. Meanwhile, users are certain that they are using the correct, approved fonts for their
projects by using the Universal Type Client™.

If you have just installed Universal Type Server and want to get going quickly, you should do these
things:

Log in to the Server Administration application.
1. Open a new browser tab or window.
2. Enter the address of your Type Server, followed by the port number for the Server

Administration application. By default, this port is 18081.
Example: http://127.0.0.1:18081

3. Log in using the account name administrator and password password.

Enter your license numbers.
1. Click Licenses in the list on the left.
2. Enter your serial number and click the Add Serial Number button.
3. If you have a Core Client license, enter that serial number and click the Add Serial Number

button.

See the Server Administrator Help system for additional information.

After you configure your server, you should change the administrator account password. Do this in
the User Management application.

1. Open a new browser window or tab.
2. Enter the address of your Type Server, followed by the port number for the User

Management application. By default, this port is 8080.
Example: http://127.0.0.1:8080

3. Log in using the administrator account credentials listed above.
4. In the Workgroups pane, click All Users.
5. In the Users pane, select the Administrator user account.
6. In the Details pane, click the Account tab and enter a new password in the Password field,

then enter it again in the Confirm Password field.
Write your new password down; if you forget it, you will need to contact Extensis Technical
Support for assistance in resetting the password.

7. Click the Save button.

About this guide
After installing Universal Type Server and configuring any necessary networking settings in the
instructions in the Server Administration Guide, the next step is to prepare the Type Server for your
users. This guide covers all topics related to the configuration of workgroups, roles and users.

This guide covers typical strategies for workgroup configuration, worksheets, as well as detailed
instructions for all tasks that are completed through the User Management application.
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System Requirements
For the most up-to-date information about the latest release of Universal Type Server, please visit
the Product Support page (http://www.extensis.com/support/product-support/universal-type-
server-6/).

Macintosh Server
l macOS™ 10.8 through 10.12 (Sierra)
l 2.0 GHz or faster processor
l 2 GB RAM
l 2 GB available hard drive space for application files, plus additional space for fonts

Windows Server
l Windows® Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, or Windows Server
2016

l 2.0 GHz or faster multi-core processor
l 2 GB RAM
l 2 GB available hard drive space for application files, plus additional space for fonts

Enterprise Edition Database Requirements
Enterprise Edition users have the option of utilizing one of these external databases. Use of an
external database is required with a proxy failover configuration.

l MySQL 5.5 or newer (Macintosh or Windows)
l Microsoft SQL Server 2012 or 2014 (Windows)

Macintosh Universal Type Client
l macOS 10.8 through 10.12 (Sierra)
l 2.0 GHz or faster processor
l 1 GB available hard drive space for application files, plus additional space for fonts
l 100 Mbit/s or faster network connection
l An Internet connection and Safari® 7 or later or the current release of Firefox® or Chrome™ to
view Help

Windows Universal Type Client
l Windows 7, Windows 8, Windows 8.1, or Windows 10
l 2.0 GHz or faster processor
l 1 GB available hard drive space for application files, plus additional space for fonts
l 100 Mbit/s or faster network connection
l An Internet connection and Internet Explorer® 10, Microsoft Edge, or the current release of
Firefox or Chrome to view Help

You need to have Internet Explorer installed in order for QuickComp to work properly. It does not
need to be your default browser.

http://www.extensis.com/support/product-support/universal-type-server-6/
http://www.extensis.com/support/product-support/universal-type-server-6/
http://www.extensis.com/support/product-support/universal-type-server-6/
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Server Administration and User Management
Requirements for any computers that will be used for Server Administration or User Management.
These applications can be run remotely.

l Internet Explorer 10 or later or Microsoft Edge (for administering the server from Windows),
Safari 7 or later (for administering the server from a Macintosh), or the current release of
Firefox or Chrome.

l An Internet connection and one of the above browsers to view Help.
l The current release of Adobe Flash® Player.

Reports
Reports can be viewed from any supported desktop browser.

l Internet Explorer 10 or later (for viewing reports from Windows 7 or later), or
l Microsoft Edge (for viewing reports from Windows 10), or
l Safari 9 or later (for viewing reports from macOS), or
l The current release of Firefox, or
l The current release of Chrome.

Reports can also be viewed from a tablet on the same network as the Universal Type Server.
Minimum requirements are:

l iOS 9 or later, Android 4.4 or later, or Windows 10, and
l 1024×768 or larger display.

What’s New
New in 6.1
Universal Type Server

l Update to use Java 8 and JBoss 10 to ensure the highest level of security
l Secure server transmissions now utilize TLS v1.

Universal Type Client
l Added auto-activation plug-in and Extensis Font Panel support for Adobe InDesign, Illustrator,
and Photoshop CC 2015 (Summer 2016).

l Added auto-activation plug-in support for Adobe InCopy and After Effects CC 2015 (Summer
2016) and QuarkXPress 2016.

User Management
l New report: Font Usage

New in 6.0
Universal Type Server

l New report analytics engine that will help server administrators know everything about their
font environment at their fingertips

l Configurable server memory management
l Support for OS X El Capitan

Universal Type Client
l Auto-activation plug-in for Adobe After Effects

User Management
l Enhanced, extensible reporting module
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Recent updates
Universal Type Server

l FontLink for Adobe® InDesign® Server allows InDesign Server to connect to your Universal
Type Server to include managed fonts in your automated workflow.

l TurboSync™: Fonts and metadata replicate to clients up to 27 times faster.
l Failover configuration: Enterprise users can set up a second Universal Type Server to ensure
maximum up-time with minimum disruption.

l External SQL database: Enterprise users can add a high-performance database for user and
workgroup maintenance and font usage tracking.

l Fully 64-bit native for improved performance and better system resource utilization.

Universal Type Client
l Extensis Font Panel: The Extensis Font Panel allows you to access all of your workgroups
directly in Adobe InDesign, Illustrator, and Photoshop CS6 and later.

l “My Fonts” Workgroup: Users can now see the fonts in all their workgroups in one place.
l Font Favorites: Mark fonts as favorites and easily find them when you need them. Use them
to search fonts and create smart sets.

l Fontspiration: The Details Panel includes the new Fontspiration tab. Fontspiration displays
examples of WebINK fonts designed to inspire you to seek new and unique ways to use
typography in your own projects. Click an example to view that example in your Web
browser, and from there follow Fontspiration and view the thousands of typography
examples gleaned from around the Web.

l QuarkXPress 10: Universal Type Client includes an auto-activation plug-in for QuarkXPress 10
and 10.1, and can also clean font caches for the Macintosh version.

l QuickComp: QuickComp is a new Preview option that displays your font choices used in a
variety of document layouts. Multiple templates are available that mimic brochures,
newsletters, and other common design projects.

l Details Panel: The Details Panel has been enlarged and moved from the bottom left to the
right side of the main window. It displays more details about anything you select in the
Workgroups pane, provides shortcuts for QuickFind searches using many popular search
criteria, and allows you to directly edit some properties.

l Color Previews: You can now set the font and background colors used in the Previews pane.
Test color combinations, use them in floating previews, and grab a Font Snapshot.

l Support for Adobe Creative Cloud apps and Typekit fonts.

User Management
l Full Administrator users can now access the User Management application using their
standard LDAP credentials.

l Compliance model: Universal Type Server uses a “per-machine” licensing model, similar to
licenses purchased from most type foundries.

l Enfocement options: Enterprise users can choose between strict enforcement, in which fonts
are not allowed to be activated beyond the limits of your licenses, or notification, in which
you receive an alert whenever a font is used beyond the number of available licenses.

l Map Active Directory groups directly to Type Server workgroups.
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User Management Overview
After installing Universal Type Server and performing any necessary configuration in the Server
Administration application, the next step in the installation process is to plan your configuration,
then create workgroups and add users.

Workgroups are the containers in which fonts are stored. Administrators provide user access to
fonts by adding users to workgroups. All workgroup and user tasks are performed through the User
Management application. It is here that administrators create workgroups, user accounts as well as
manage associated settings and permissions.

The basic user and workgroup configuration steps include:
1. Plan your configuration (see Planning Your Configuration below)
2. Create workgroups (see Creating and Editing Workgroups on page 25)
3. Create new users (see Creating and Editing Users on page 30)
4. Add users to workgroups (see Adding Users to Workgroups on page 31)
5. Assign workgroup roles to users (see Assigning Roles on page 22)
6. Modify user settings as required (see Settings on page 34)

After completing the steps above, you are ready to add fonts to workgroups using the Universal
Type Client.

Most font-related tasks—such as adding and deleting fonts, tagging fonts with keywords, and font
activation—are accomplished using the Type Client. For detailed instructions, see the Universal
Type Client User Guide and help system.

Planning Your Configuration
The mechanics of setting up Universal Type Server are not difficult. Adding workgroups, roles, and
users are fairly simple matters. Yet, Universal Type Server can be configured in many different
ways. To best meet the workflow needs of your organization, we recommend that you take a
moment to plan how you’ll configure your installation.

To create the ideal solution in your environment, you need to think through all the fonts you have,
where they’re from, what they’re for, who’s using them, and how they’re using them. To help with
the setup, we describe several typical workflows along with detailed explanations of their
workgroups, user permissions, and roles. Once you identify the most logical configuration for your
environment, plan out your workgroups and users before creating your system. See the Workgroup
Worksheet on page 29 and the User Worksheet on page 45.

You may find that configuring a server for a small group of users helpful when determining the
appropriate workgroups, roles, permissions and settings for your environment.

Sample configurations
While you can structure your workflow in any way you want, you’ll probably end up working with
one of three common configurations: department based, project based, or full access.

Organizing Fonts on a Department Basis
If you have distinct groups of users that each require a different set of fonts, workgroups can be
created for each department or group. This configuration is typical for companies with large
numbers of users, such as magazines and book publishers.
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With this configuration, fonts are added to workgroups based on each group’s specific font needs.
For example, a publishing environment might contain workgroups for design, editorial, advertising,
and production. The fonts contained in each workgroup as well as the workgroup default roles can
vary according to the user’s font needs.

For example, the editorial department would likely have a well defined and locked down set of
fonts. Users in this workgroup just need to know that they have the correct fonts, and would not
likely need much additional font organization. With the fairly restrictive Regular User role (see
Predefined Roles on page 20) applied as the default workgroup role, the administrator can be sure
that all users in the editorial workgroup have what they need, and aren’t able to modify fonts.

Organizing Fonts on a Project Basis
With a project-based organization method you create workgroups for specific projects. This
configuration is typical for companies with a medium to a large number of users, who typically
work in teams, like design firms and ad agencies.

With this configuration you might have a workgroup for each division, client, campaign, or other
project. Type Server users are only added to workgroups to which they are required. This way each
project is contained within its own workgroup, and users can be certain that they have the fonts
required for a project.

Providing Full Access
This is the most basic way to set up Universal Type Server, yet works well in environments with
very few users such as small design groups and prepress shops. Basically, all fonts are added to a
single workgroup to which all users are members. Through the use of a fairly permissive default
workgroup role, each user is given the ability to perform most actions with all of the server fonts.

This method works great in situations where there isn’t a dedicated IT administrator, and all of
your users are fairly savvy. This workflow allows all users to have full access to all of the
organization’s fonts to complete their jobs. The downside of this method is that it doesn’t scale
well to fit larger workgroups, and has an inherent lack of control over keyword vocabulary as well
as lack of control over which users can add and remove fonts.

This method can work well if you’re installing Type Server on a trial basis.

Department Based Configuration
Organizations with fairly structured departments that each have specific font needs can benefit
from organizing fonts into department workgroups. This configuration is typical for companies with
large numbers of users, such as magazines and book publishers.

For example, a publishing company might have different workgroups for the editorial, layout, and
production departments. The editorial department doesn’t choose which fonts to use, yet for copy-
fitting needs, it is imperative that they have the correct fonts for the job. The layout team needs
access to all of the company’s fonts to have creative control over the design of each project. And
the production group needs access to most of the company’s fonts as well as the ability to collect
fonts for printing jobs. Using a department based configuration, each department has its own
workgroup and default role for users. This way administrators can easily control the fonts and
permissions available to each workgroup.

Choose or Create Default Roles
The first step is to write down a list of the required workgroups, and then create a list of default
roles for each workgroup. The default role for a workgroup controls a base set of permissions for all
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users added to the workgroup. The predefined roles that come with Type Server may work well for
you, yet if you require different default permissions it’s best to create a custom role at this point.

To display the permissions for each predefined role:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Roles panel, select each predefined role to examine the default permissions settings.
3. Write down a default role for each workgroup, or if required, create custom roles (see

Creating Roles on page 22) for your workgroups. Use the worksheet (see Workgroup
Worksheet on page 29) to help you define settings. For example, the Editorial workgroup
might have Regular User as its default role, the Layout workgroup might have Font
Administrator as the default role, and the Production workgroup might have a custom role
that grants permission to add and remove fonts as well as collect fonts for output.

Create Workgroups
Next, create the workgroups required for your projects or clients.

1. In the Workgroups pane, click the + button. This opens the New Workgroup details pane.
2. Enter a Workgroup Name for the workgroup.
3. Choose a Default Role from the drop-down menu. Choose the default role that you wrote

down in the workgroups worksheet.
4. Click the Save button to add the new workgroup.
5. Repeat this process to create all necessary workgroups.

Create Users
The next step is to create all of the users and add them to the workgroups.

To plan out each user’s permissions, you may want to use the included worksheet (see User
Worksheet on page 45). Most likely, all of the permissions listed on the worksheet will be set by the
user’s role in the workgroup. Yet, if necessary, administrators can set each permission for users on
an individual basis.

To create a new user:
1. In the Workgroups pane select your new workgroup. Selecting the workgroup ensures that

new users are automatically added to this workgroup.
2. In the Users pane, click the + button.
3. In the New User details pane, in the Account tab, enter the basic account information:

n Account Name: Each user account name must be unique. It’s best to use an account
name that is short, easy to remember and does not include spaces or letter case
variations.

n Full Name: Required field. For ease of alphabetization, you can enter names in a “Last
Name, First Name” format so that names can be easily sorted in the Users pane.

n Email Address: Optional field.
n Password: This case-sensitive field is optional. If left blank, a password is not required

for this user to log in.
If you enter a password, enter it again in the Confirm Password field.

n Notes: Enter any notes to appropriately identify the user.
4. Click the Save button to add the new user.
5. Repeat this process until all of your users are added.

Add Users to Workgroups
After adding users, users need to be assigned to each workgroup.

1. In the Workgroups pane, select the All Users workgroup.
2. To assign users to workgroups, from the Users pane, select the username and drag it to a

workgroup. Users can belong to one or more workgroups.
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Delegate Roles
After adding users to workgroups, you’ll need to delegate roles for each workgroup. Each user is
assigned the default role when added to the workgroup, yet each workgroup will likely need users
who have elevated permissions within the workgroup. It is best to assign these permissions with
user roles.

When working with departments, you will need to have at least one person who is able to add,
remove, and organize fonts within the workgroup. You can assign the Font Administrator role to
users who need this ability.

If you have teams that are continually changing, and require the addition and removal of users
from projects, you may need to consider having a Full or Workgroup Administrator for each
workgroup. Full and Workgroup Administrators are able to log in to the User Management
application and manage users. Having additional Administrators can be handy if your teams are
located in different time zones and you need to manage workgroups in a timely fashion.

To delegate roles:
1. In the Workgroups pane, select the workgroup name.
2. In the Users pane, select the user that you want to update.
3. In the Details pane, click the Workgroups tab.
4. Select the workgroup name from the Show permissions for Workgroup drop-down menu.
5. Choose a new role for this user in the selected workgroup from the Role in Workgroup

drop-down menu.
6. Click the Save button.

Configure User Settings
After adding users, you need to determine the most appropriate font replication mode,
synchronization and personal workgroup settings for each user. These settings control when fonts
are brought down from the server to the client, and how long those fonts remain on the user’s
system. Typically, the default settings will work for most users, but for certain users exceptions can
be made. These are configured on the Settings tab for each user.

l The default time between server syncs (see Synchronization on page 34) should work for most
installations. The exception may be a user who doesn’t often need new or updated fonts. For
these users, a longer synchronization interval can be set.

l The Font Replication mode controls when fonts are copied from the server down to the client
computer. The default mode is On-demand, which gives users fonts only when they need to
preview or activate them. The On-demand setting is typically the best choice for client
computers that stay in the office. For users who are working on laptops and may need to
work offline frequently, set the font replication mode to All (see Font Replication Mode on
page 35). This ensures that all fonts in the Type Server are downloaded to the client, and
always available for use offline.

l Enable personal workgroups (see Personal Workgroups on page 36) for users who need to add
and activate fonts that they won’t need to share with the rest of the workgroup. Server-based
personal workgroups can be very helpful for users who work on multiple computers and need
access to the same personal fonts on each computer. Otherwise, it’s a good idea to have all
users always add fonts to the main workgroup, and use sets to further organize fonts as
necessary.

Add and Organize Fonts
After configuring users, distribute account login settings to users. Those who have permission can
now begin adding fonts to workgroups using the Type Client.
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For more information about adding, organizing, and managing fonts, see the Universal Type Client
User Guide and help system.

Project Based Configuration
This configuration is typical for companies with a medium to a large number of users, who
typically work in teams, like design firms and ad agencies. If you have projects or clients that are
easily separated into groups, a project based configuration method might be best for you.

For example, an agency that assigns employees to specific clients would benefit from having a
workgroup for each client. Using this method, users who are working with a specific client are
added to the client workgroup and thus have access to all fonts necessary for that client’s projects.
Further font organization is available within each workgroup through the use of font sets. So, if you
create a workgroup for each client, you can organize fonts within each workgroup by creating a set
for each project you do for that client.

Create Workgroups
The first step is to create the basic workgroups required for your projects or clients.

1. Open your web browser and start the User Management application.
If it is already running, choose Window > Users and Workgroups.

2. In the Workgroups pane, click the + button. This opens the New Workgroup details pane.
3. Enter a Workgroup Name for the workgroup.
4. Choose a Default Role from the drop-down menu. For project-based workgroups, it is best

to choose the Regular User default role. Less restrictive permissions can be set later for
specific users by delegating user roles for each workgroup.

5. Click the Save button to add the new workgroup.
6. Repeat this process to create all necessary workgroups.

Create Users
The next step is to create all of your users and add them to the workgroups.

To create a new user:
1. In the Workgroups pane select your new workgroup. Selecting the workgroup ensures that

new users are automatically added to this workgroup.
2. In the Users pane, click the + button.
3. In the New User details pane, in the Account tab, enter the basic account information:

n Account Name: Each user account name must be unique. It’s best to use an account
name that is short, easy to remember and does not include spaces or letter case
variations.

n Full Name: Required field. For ease of alphabetization, you can enter names in a “Last
Name, First Name” format so that names can be easily sorted in the Users pane.

n Email Address: Optional field.
n Password: This case-sensitive field is optional. If left blank, a password is not required

for this user to log in.
If you enter a password, enter it again in the Confirm Password field.

n Notes: Enter any notes to appropriately identify the user.
4. Click the Save button to add the new user.
5. Repeat this process until all of your users are added.
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Add Users to Workgroups
After adding users, users need to be assigned to each workgroup.

1. In the Workgroups pane, select the All Users workgroup.
2. To assign users to workgroups, from the Users pane, select one or more user names and

drag them onto a workgroup name in the Workgroups pane. Users can belong to one or
more workgroups.

Delegate Roles to Users
After adding users to workgroups, you’ll need to delegate roles for users in each workgroup. Roles
give users the ability to perform extra functions within a workgroup and are set on a user-by-user
basis. Most users will do fine with the default role, while others will be assigned special abilities
through the use of a different role.

When working with projects, you will need to have at least one person who is able to add, remove
and organize fonts within the workgroup. You can assign the Font Administrator role to users in
each workgroup who need this ability.

If you have teams that are continually changing, and require the addition and removal of users
from projects, assign the Workgroup or Full Administrator setting to at least one user for each
workgroup. Administrators are able to log in to the User Management application and manage
users. Having an additional Administrator can also be handy if your teams are located in different
time zones and you need to manage workgroups in a timely fashion.

Before assigning roles, click each role name in the Roles pane. If these roles do not meet your
needs, you can create a custom role (see Creating Roles on page 22) to assign to users.

To delegate roles:
1. In the Workgroups pane, select the workgroup name.
2. In the Users pane, select the user that you want to update.
3. In the Details pane, click the Workgroups tab.
4. Select the workgroup name from the Show permissions for Workgroup drop-down menu.
5. Choose a new role for this user in the selected workgroup from the Role in Workgroup

drop-down menu.
6. Click the Save button.
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Configure User Settings
After adding users, you need to determine the most appropriate font replication mode,
synchronization and personal workgroup settings for each user. These settings control when fonts
are brought down from the server to the client, and how long those fonts remain on the user’s
system. Typically, the default settings will work for most users, but for certain users exceptions can
be made. These are configured on the Settings tab for each user.

l The default time between server syncs (see Synchronization on page 34) should work for most
installations. The exception may be a user who doesn’t often need new or updated fonts. For
these users, a longer synchronization interval can be set.

l The Font Replication mode controls when fonts are copied from the server down to the client
computer. The default mode is On-demand, which gives users fonts only when they need to
preview or activate them. The On-demand setting is typically the best choice for client
computers that stay in the office. For users who are working on laptops and may need to
work offline frequently, set the font replication mode to All (see Font Replication Mode on
page 35). This ensures that all fonts in the Type Server are downloaded to the client, and
always available for use offline.

l Enable personal workgroups (see Personal Workgroups on page 36) for users who need to add
and activate fonts that they won’t need to share with the rest of the workgroup. Server-based
personal workgroups can be very helpful for users who work on multiple computers and need
access to the same personal fonts on each computer. It can also be helpful for users who may
need to experiment with a few fonts for a project before purchasing a large number of
licenses and adding those fonts to a workgroup for other users. Otherwise, it’s a good idea to
have all users always add fonts to the main workgroup, and use sets to further organize fonts
as necessary.

Add and Organize Fonts
After configuring users, distribute account login settings to users. Those who have permission can
now begin adding fonts to each workgroup. Other client users are then able to activate and
deactivate fonts as required for each project with the Type Client.

For more information about adding, organizing, and managing fonts, see the Universal Type Client
User Guide and help system.

Full Access Sample Configuration
The most basic way to configure Universal Type Server is to place all of your fonts into a single
workgroup and allow all of your users a very permissive level of access to those fonts. This method
sacrifices some of the administration control available in Universal Type Server for the benefits
having users police their own actions with fonts on the server.

Typically workgroups such as small design houses or prepress shops will choose this method of
configuration.

The following setup instructions contain the recommended way to setup your Type Server to allow
full access for all users. Your process may vary based on your group’s needs.
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Create the Workgroup
The first step is to create the workgroup that will house all of your fonts.

1. Open your web browser and start the User Management application.
If it is already open, choose Window > Users and Workgroups.

2. In the Workgroups pane, click the + button. This opens the New Workgroup details pane.
3. Enter a name for the workgroup in the Workgroup Name field. This name is displayed in the

client, and is where workgroup members will add and activate fonts.
4. Choose a role to be the assigned to new workgroup members from the Default Role drop-

down menu. Since all of your users will have the same level of access, it’s a good idea to
set a default role that isn’t very restricting. If you choose Default Role > Font Administrator,
this will allow any user to perform necessary organization and maintenance tasks using the
Type Client and also gives your users a wide variety of abilities to add, organize and tag
fonts within workgroups.

5. Click the Save button to add the new workgroup.

Create Users
The next step is to create all of your users and add them to the workgroup.

To create a new user:
1. In the Workgroups pane select your new workgroup. Selecting the workgroup ensures that

new users are automatically added to this workgroup.
2. In the Users pane, click the + button.
3. In the New User details pane, in the Account tab, enter the basic account information:

n Account Name: Each user account name must be unique. It’s best to use an account
name that is short, easy to remember and does not include spaces or letter case
variations.

n Full Name: Required field. For ease of alphabetization, you can enter names in a “Last
Name, First Name” format so that names can be easily sorted in the Users pane.

n Email Address: Optional field.
n Password: This case-sensitive field is optional. If left blank, a password is not required

for this user to log in.
If you enter a password, enter it again in the Confirm Password field.

n Notes: Enter any notes to appropriately identify the user.
4. Click the Save button to add the new user.
5. Repeat this process until all of your users are added.

Configure Permissions
Since the Font Administrator default role is set for your only workgroup, all users will have the
permission to perform most actions with the Type Client. Notable exceptions include the ability to
access the Server Administration and User Management applications. Typically, these functions are
accessed only by an IT professional. If you don’t have a specific IT person, you may wish to enable
a user to have Full or Workgroup Administrator permissions.
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Configure User Settings
After adding users, you need to determine the most appropriate font replication mode,
synchronization and personal workgroup settings for each user. These settings control when fonts
are brought down from the server to the client, and how long those fonts remain on the user’s
system. Typically, the default settings will work for most users, but for certain users exceptions can
be made. These are configured on the Settings tab for each user.

l The default time between server syncs (see Synchronization on page 34) should work for most
installations. The exception may be a user who doesn’t often need new or updated fonts. For
these users, a longer synchronization interval can be set.

l The Font Replication mode controls when fonts are copied from the server down to the client
computer. The default mode is On-demand, which gives users fonts only when they need to
preview or activate them. The On-demand setting is typically the best choice for client
computers that stay in the office. For users who are working on laptops and may need to
work offline frequently, set the font replication mode to All (see Font Replication Mode on
page 35). This ensures that all fonts in the Type Server are downloaded to the client, and
always available for use offline.

l Enable personal workgroups (see Personal Workgroups on page 36) for users who need to add
and activate fonts that they won’t need to share with the rest of the workgroup. Server-based
personal workgroups can be very helpful for users who work on multiple computers and need
access to the same personal fonts on each computer. Otherwise, it’s a good idea to have all
users always add fonts to the main workgroup, and use sets to further organize fonts as
necessary.

Add and Organize Fonts
You can now provide users with their access infomation and have them add fonts to the
workgroup.

For the best organization within your workgroup, ask users to add fonts into sets that can then be
shared with all users to keep everyone in sync.

For more information about adding, organizing, and managing fonts see the Universal Type Client
User Guide and help system.

Opening User Management
Administrators manage users, workgroups, roles, and permissions using the User Management
application. This application can be accessed through any supported web browser.

To open the User Management application:
1. Open a supported web browser.
2. In the address bar, enter your Type Server’s IP address followed by a colon and the port

number.
The default User Management port is 8080.
Example: http://10.1.2.32:8080 or http://localhost:8080 if administering the server
locally.

3. Choose a display language from the menu.
4. Enter a user name and password and click Login.

Passwords are case-sensitive but user names are not.
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You can also start the User Management application from the Universal Type Client; choose
Server > Manage Users and Workgroups.

NOTE: If you log in using the Server Administrator account, for the most secure
configuration, change the password as soon after installation as possible. See Changing
the Server Administrator Account Password on page 44.

Changing the Display Language
The language of the User Management application is automatically set to the language your web
browser is set to use. The application supports administration in English, French, German, Italian,
Japanese, and Spanish. If your browser’s preferred language is not supported, the application is set
to use English.

Change the display language from the drop-down menu on the User Management login page.

It’s important to note that this only changes the language displayed in the User Management
application. The client’s user interface, as well as the Server Administration application remain in
the language currently selected for each application.

SSL Security
The Universal Type Server User Management application includes a secure connection option
through port 8443. See the Server Administration User Guide or help system for details about
implementing your own security certificate.
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Roles
Roles control the permissions in the Global and Workgroup permission tabs of each user. Roles are
basically a group of permission settings that can be applied simultaneously to a user that affects
their abilities in the workgroup.

Roles are dynamic in that when you change a role setting, all users who have that role in any
workgroup are immediately affected. So, if you add or remove permissions to a role, be aware that
everyone with that role setting will obtain updated permissions. User Roles are also quite powerful
because they allow you to change the abilities of a large number of users in many workgroups at
one time.

Defining a User Role Strategy
Roles and Workgroups
Roles allow administrators to quickly set up multiple users with a standard set of permissions.
Even more efficiency is gained by applying a Default Role to a workgroup. That way, every user
who is added to the workgroup receives that default role.

When organizing workgroups, you may want to organize fonts by what level of access that is
required for users. Using this method, you can create your workgroups and assign a custom default
role for each workgroup. This way, every user who is subsequently added to each workgroup is
automatically assigned the default role. Users become almost secondary in this configuration.

For example, if a newspaper editorial department needs a specific group of fonts, yet those fonts
are well-defined and these users won’t need to choose new fonts, you can create a fairly restrictive
role setting and set it as the default role for that workgroup. That way every user who is added to
the workgroup will be restricted to using fonts as the administrator intends.

Users, Roles, and Workgroups
A user’s role can vary from workgroup to workgroup. A user may have the Regular User role in one
workgroup and the Font Administrator role in another. After you add a user to a workgroup, you
can change that user’s role as needed.

If a workgroup’s default role is Regular User, and you need a user to be the Font Administrator, you
can change this in the user’s Workgroup permissions tab.

It’s also important to note that permissions set for a role can be overridden for individual users in a
workgroup. It is easy to give a user custom permissions in a workgroup without changing his role.

Roles and Fonts
It’s important to note that font information is stored on a server-wide basis. So, any changes to
attributes, such as keywords and foundry information, are applied across all workgroup. So, it is
important that you choose roles and permissions for your users appropriately.

For example, a user has the Font Administrator role in one workgroup, but only the Regular User
role in another. That user can make changes to font attributes in workgroup where he is a Font
Administrator. If a font exists in both workgroups, any changes to a font that the user makes as the
Font Administrator will also appear in the other workgroup.
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Custom Roles
In most instances, the predefined roles that come with Type Server should meet most needs. If you
need to set specific role settings, you can easily create a custom role.

For example, a production environment could require special settings for everyone in the
department. Those in the production department interact with outside clients, who supply fonts
with their documents. These users may need to add fonts to the database, as well as collect fonts
for use on other systems. In this case you could create a “production” workgroup and an associated
custom role for use with that workgroup. This custom role would have permissions that allow the
addition and deletion of fonts, as well as the ability to collect fonts for output. The default role for
the “production” workgroup would be set to use this new custom role. Now, all users who are
subsequently added to the workgroup have the appropriate permissions for that workgroup. The
administrator would never need to modify custom permissions for “production” workgroup users,
because anyone who is added to the workgroup automatically has the appropriate permissions.

Predefined Roles
Universal Type Server contains four predefined user roles. These roles are configured with
commonly used settings, and can be used as-is or as a starting place for your own custom roles.

REMEMBER: You can override role-based settings by granting or revoking permissions on a user-
by-user basis.

Predefined roles can be modified to meet your needs, but if you need different settings it is best to
create a custom role (see Creating Roles on page 22).

Font Administrator
The Font Administrator predefined role is configured for users who need a higher level of control
over fonts in a workgroup. Users who are required to add fonts, and perform other organizational
tasks such as assigning keywords and creating shared sets, should have the Font Administrator role.

Those with the Font Administrator role can do everything the Regular User role can do as well as:
l Add and remove fonts.
l Create and delete shared sets.
l Modify shared sets.
l Create, delete and apply keywords, styles, classifications, and foundries.
l Activate fonts across multiple workgroups.
l Modify font family groupings.

Since roles are set by workgroup, users may be members of multiple workgroups yet are assigned
the Font Administrator role in only a few workgroups.
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It’s important to note that if a font information is stored on a server-wide basis. So if a font exists
in multiple workgroups, and a user has the Font Administrator role in one workgroup, any changes
made to the font as the Font Administrator will also appear in every other workgroup.

Preview-only User
The Preview-only role is similar to the regular user, except that users with this role cannot activate
fonts, and cannot collect fonts for output.

A major use for the Preview-only user would be to create a workgroup where this is the default
role, add several users to the workgroup, and include a Workgroup Administrator. The
Administrator can then add fonts to the workgroup that the other members can preview.

This type of workgroup can act as a “font store” that allows your users to see the fonts that are
available on your Type Server without having to consume a license for each font. Users can identify
fonts they would like to have access to, then request that they be added to one of their other
workgroups.

Regular User
The Regular User predefined role is configured for users who are mostly interested in finding and
activating fonts. A regular user might not spend much time using the Type Client, and allow the
auto-activation plug-ins to activate and deactivate fonts as required for each document and project.

Regular users can activate and deactivate fonts in workgroups for which they are members, apply
keywords to fonts, and collect fonts for output.

The Regular User predefined role is the default role for workgroups in which a default role is not
assigned. This means that any user added to a workgroup that does not have a default role set will
automatically receive the Regular User role assigned for that workgroup.

Workgroup Administrator
The Workgroup Administrator role allows a Server Administrator to delegate the task of managing
users in a workgroup. Workgroup Administrators have the same capabilities as Font Administrators,
and can also create new users in the context of their workgroup, add existing user accounts to their
workgroup, and remove users from their workgroup.

In addition, Workgroup Administrators using the Universal Type Client will have access to a special
workgroup that shows all fonts in all workgroups that they administer. He can delete fonts from all
his workgroups by deleting them from this workgroup, and can create non-share sets in this
workgroup.

Resetting Predefined Roles
If you have modified the predefined settings of the Regular User and Font Administrator roles,
these settings can be reset back to the default factory settings. Users with unmodified predefined
role settings have their settings reset. Any specifically modified user permissions are kept.

To reset a predefined role:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Roles pane, click to select the predefined role to revert.
3. Click the Reset button.
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Creating Roles
If you require roles not met by the predefined roles, you can easily create custom roles.

To create a new role:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Roles pane, click the + button.

3. In the Details pane, enter a role name.
4. Enable or disable user permissions (Role-based Permissions on page 41) for the new role.
5. Click the Save button to save the new role.

Assigning Roles
There are two ways to assign user roles within a workgroup:

l Using a workgroup’s default role
l Changing the user’s workgroup permission setting

Setting a Workgroup’s Default Role
The easiest way to assign user roles is to have the workgroup do it for you. By setting a default role
for a workgroup, that role is automatically assigned to each user subsequently added to the
workgroup.

To set the default role for a workgroup:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Workgroups pane, select the workgroup.
3. In the Details pane, choose a role from the Default Role drop-down menu and click the

Save button.

Existing members of the workgroup are not affected by the workgroup’s default role change. Only
users who are subsequently added are assigned the new default role.

Assigning Roles by User
After users are added to a workgroup, you can update each user’s role on a workgroup-by-
workgroup basis. This is often necessary if a user was given the default role when added to a
workgroup, and you want to assign a different role.
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To update the role for a user in a workgroup:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Workgroups pane, select the workgroup.
3. In the Users pane, select the username.
4. In the Details pane, click the Workgroup tab.
5. Click the Show Permissions in Workgroup drop-down menu and choose the workgroup for

which you need to modify the role. (Only workgroups in which the user is a member are
displayed.)

6. Choose a new role from the Role in Workgroup drop-down menu.
7. Click the Save button.

Deleting a Custom Role
Depending upon your configuration, you may find that a custom role no longer suits your needs.
Unlike the four predefined roles, custom roles can be deleted as necessary.

If a custom role is currently assigned to a user when deleted, that user’s role in any relevant
workgroup is immediately set to the Regular User predefined role. Any custom user permissions
that are not role-based are retained by the user. This might cause a severe reduction in user
permissions, yet provides the most security. Deleting a custom role can also be used as an efficient
way to immediately revert a group of users to a more restrictive access level.

To delete a custom role:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Roles pane, click to select the custom role to delete.
3. Click - and click the OK button to confirm removal.



- 24 -

Workgroups
In Universal Type Server, fonts are organized into workgroups—collections of fonts intended for a
specific job description, division, publication, or other grouping. Workgroups are like separate
databases of fonts, each with its own group of users. The Server Administrator decides which users
belong to each workgroup, and has the ability to modify user permissions on a user-by-user basis
for each workgroup. To help facilitate setting user permissions, each workgroup has a default role,
which sets the initial permissions for users added to the workgroup.

Users can be members of one or more workgroups, and a user’s capabilities can vary from
workgroup to workgroup. So, a user could be able to add and remove fonts in one workgroup but
not in another.

To maintain any existing organization you have for fonts, you can add collections of fonts to
Universal Type Server as workgroups. For example, if your fonts are organized by department, you
can create department-based workgroups. Teams for each account, magazine division or publishing
team could have their own workgroups. You can also create new workgroups using fonts already in
existing workgroups and you can change which fonts are in which workgroups.

Not to be confused with font sets—subsets of fonts within a workgroup—workgroups go beyond
grouping fonts to controlling usage and access.

When you create users, you specify workgroups to which they belong. In many configurations,
users will belong to only one workgroup (although they can simultaneously belong to and activate
fonts in multiple workgroups).

For example, a magazine publisher may have three font workgroups: Editorial, Art, and Production.
l The Editorial workgroup contains fonts used in body copy. Writers and editors are members
of this workgroup, and are given the permission to activate fonts, but aren’t allowed to add,
delete, or collect them.

l The Art workgroup contains all of the fonts that the company owns; the graphic designers can
activate and add fonts, but they can’t delete or collect them.

l The Production workgroup encompasses all of the company’s fonts along with all of its
advertisers’ fonts. Users of this workgroup are given permission to add, delete, and collect
fonts.

Some environments choose a simpler approach and only create one workgroup to which all fonts
are added, and all required employees are added as users. In these environments, it’s a good idea
to create a custom role that allows users appropriate access to fonts, and set that role as the default
for the workgroup.
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Defining a Workgroup Strategy
Before you start creating workgroups of fonts, you need to decide how you want to structure them.
Unlike the way you probably have been managing fonts— by font name, foundry, etc.—think more
about who needs the fonts than about characteristics of the fonts.

For example, don’t create workgroups based on font characteristics such as foundries or classes. If
you do, most of the users will end up needing access to fonts in many workgroups, making access
difficult to manage. Users are able to sort fonts based on foundry and class in the Universal Type
Client, so there is little need to organize fonts by foundry in separate workgroups.

Another important consideration when planning workgroups is that, in general, each document you
design or output should use fonts from only one workgroup. So each workgroup should contain all
the fonts necessary to complete the projects its users are involved in. Since users can work in
multiple workgroups, it is important to configure workgroups so that users aren’t confused about
which workgroup they should be using.

It is easiest to select a sample configuration (Sample configurations on page 9) example and follow
the detailed instructions for setting up your workgroups using one of these models. If your
environment differs and requires a specialized configuration, spend a few minutes examining the
fonts required in your environment as well as your user’s font needs. Use the worksheet (see
Workgroup Worksheet on page 29) to help you plan and think through your configuration.

Creating and Editing Workgroups
New workgroups are created through the User Management application.

To create a workgroup:
1. Open your web browser and start the User Management application.

If it is already running, then choose Window > Users and Workgroups.
2. In the Workgroups pane, click the + button. This opens the New Workgroup details pane.
3. Enter a Workgroup Name. This is the name that is displayed to users who are members of

the workgroup.
4. Choose a Default Role from the drop-down menu.

The default role is set for users when they are added to the workgroup. When used
properly, the default role can make adding users and configuring permissions for a
workgroup a snap.

5. Enter any Notes to help you identify the fonts that will be contained in this workgroup.
Notes are only visible in the User Management application, and are not visible in the client.

After creating a workgroup, the next step is to add users to that workgroup. After adding users,
those who have the appropriate permissions can add fonts to the workgroup using the Universal
Type Client. It’s important to remember that anything to do with the physical manipulation of
fonts is performed using the Type Client.

After creating a workgroup, you may find that there’s another name that more accurately describes
the workgroup. You can easily change this as well as the default role after a workgroup is created.
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To edit an existing workgroup:
1. Open your web browser and start the User Management application.

If it is already running, then choose Window > Users and Workgroups.
2. In the Workgroups pane, select the existing workgroup.
3. In the Detail pane, change the workgroup name and/or default role and click the Save

button.

NOTE: Any changes to the default roles affect only users subsequently added to the
workgroup; these changes do not affect users who are currently members of the
workgroup.

Deleting a Workgroup
When a workgroup no longer serves a purpose, you can delete it. It’s important to understand what
happens to fonts contained within a workgroup when it is deleted.

l The users assigned to that workgroup remain in Universal Type Server.
l The workgroup is removed from the list in the Universal Type Client as well as from the User
Management application.

l If users have fonts from the workgroup active, the fonts stay active until the users shut down
their computers or choose Server > Forget Connection.

l If fonts in the deleted workgroup belong to other workgroups, they remain in the Type Server
datastore.

l If fonts in the deleted workgroup were exclusive to that workgroup, the fonts are deleted
from the server entirely.

l All font sets within the workgroup are deleted.

To delete a workgroup:
1. Open your web browser and start the User Management application.
2. In the Workgroups pane, select the workgroup name.
3. Click the - button.
4. Click the OK button to confirm.

The All Users Workgroup
As its name indicates, the All Users workgroup displays a list of all of the users who have access to
the Universal Type Server.

All users belong to this workgroup, even if they are not a member of any other workgroup.
However, to have access to server fonts, a user must be a member of a workgroup that contains
fonts. The All Users workgroup does not contain any fonts, and is never visible in the Type Client.

Most importantly, the All Users workgroup includes the Server Administrator account under the
name administrator. The All Users workgroup is the only location from which the Server
Administrator can change his or her password.

The All Users workgroup cannot be deleted.

NOTE: You must log in as the Server Administrator in order to change the password.

Creating a Preview-Only Workgroup
A Preview-Only workgroup is a workgroup where most of the users have the Preview-Only role
assigned. In this workgroup, users can preview available fonts but cannot activate or collect them.
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The purpose of the Preview-Only workgroup is to allow users to view fonts that are available on
your Type Server and if they find a need, request that a specific font be added to one of their
workgroups. This is, in effect, a “font store” for your users, where they can “shop” among the fonts
that you have available.

You can have several such workgroups; you can include different users and a different subset of
your available fonts in each one. You could instead have just one such workgroup, with all your
fonts and all your users assigned to it. (Note that at least one user should be a Workgroup Manager,
so he can add and remove fonts and users in the workgroup!)

To create a Preview-Only workgroup:
1. Open your browser and start the User and Workgroup Management application.
2. Click the + button at the bottom of the Workgroups list.
3. In the New Workgroup panel, give your workgroup an appropriate name.

Avoid generic names such as “Preview All Fonts” if your workgroup will not include all fonts
and all users.

4. Set the Default Role to Preview-only User.
5. Click the Save button to create the workgroup.
6. Click the All Users workgroup (or another workgroup), then drag users from the Users panel

onto the icon for your new workgroup.
You really only need to add one user to the workgroup: the user you will designate as the
Workgroup Administrator. He can then add the other users (who will have the Preview-only
role) to the workgroup.

7. Click your new workgroup in the Workgroups list, then select a user to be the Workgroup
Administrator.

8. Click the Workgroups tab in the user’s information panel.
9. Click the drop-down menu labeled Show permissions for Workgroup and choose your new

workgroup.
10. Click the drop-down menu labeled Role in Workgroup and choose Workgroup

Administrator.
11. Click the Save button.

The Workgroup Administrator can now use the Universal Type Client to add fonts to the
workgroup, and the User Management application to add or remove users.
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Special workgroups: “My Fonts” and “All
Server Fonts”
There are two special workgroups that are not displayed in the User Management application: My
Fonts and All Server Fonts.

These workgroups are displayed at the top of the Workgroups pane in Universal Type Client. My
Fonts is displayed for all users except those identified as Full Administrators; All Server Fonts is
only displayed for Full Administrators.

My Fonts
The My Fonts workgroup lists all the fonts in the user’s workgroups.

A user cannot add or remove fonts in this workgroup, but whenever a font is added to one of the
user’s workgroups, it will appear in My Fonts. (A font will only be removed from My Fonts if it no
longer belongs to any of the user’s workgroups.)

Users can create and delete sets (including Smart Sets) in My Fonts. Sets cannot be shared from My
Fonts, but can be copied to another workgroup. When a set is copied to another workgroup, any
fonts not already in that workgroup will be added to it.

All Server Fonts
All Server Fonts displays all the fonts available on the server, regardless of which platform the font
is designed for.

If a new font is added to a workgroup, it will automatically appear in All Server Fonts.

If a font is removed from All Server Fonts, it will be removed from the server and from all
workgroups.
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Workgroup Worksheet
Workgroup Information

Workgroup Name

Default Role

Workgroup Members

Member Name Role in Workgroup

Workgroup Fonts

Notes
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Users
A user is any individual who needs to connect to Universal Type Server to access fonts. Each user
will have his own unique account name, settings and permissions.

You can add as many users as required to the Type Server, regardless of how many user
connections you have purchased. Your license controls how many concurrent connections are
allowed to the server. Therefore, you can create a user for anyone who needs access to fonts—
every full-time employee, part-time employee, intern, client, etc.

When creating users, the administrator specifies all basic user login information: username, full
name, email address, and password.

After the user is created, users are then added to workgroups. When a user is added to a workgroup,
the user is automatically assigned the default role in that workgroup. The default workgroup role
sets a wide variety of user permissions, and is handy for quickly setting consistent permissions for
all users in a workgroup. If special user permissions are required, they can be set globally for that
user or on a workgroup-by-workgroup basis.

User logins can be used with the Universal Type Client on either macOS or Windows. The client is
only able to use font files that are compatible with the current operating system, so users who
work on both platforms may have different fonts available for use. For example, Windows-based
PostScript fonts are not compatible with the macOS, so these fonts cannot be activated or collected
by the macOS client.

NOTE: To prevent confusion, control access, and aid in troubleshooting, do not give
multiple users the same account name. For example, if you give all graphic designers the
account name “Creative,” it will be difficult to determine which user added a corrupt font.

Creating and Editing Users
Users can be added by Full Administrators and the Server Administrator.

To create a new user:
1. Open your web browser and start the User Management application

If you already have it open, then choose Window > Users and Workgroups.
2. In the Workgroups pane select a workgroup to which you would like to add a user. To add a

user without specifying a workgroup, select the All Users workgroup.
3. In the Users pane, click the + button.
4. In the New User details pane, click the Account tab and enter the basic account information:

n Account Name: Each user account name must be unique. It’s best to use an account
name that is short, easy to remember, and does not include spaces or letter case
variations.

n Full Name: Optional field.
n Email Address: Optional field.
n Password: Optional field. If left blank, a password is not required for this user to log

in.
If you enter a password, enter it again in the Confirm Password field.

n Notes: Enter any notes to appropriately identify the user. This information is only
visible in the User Management application.

5. Click the save button to add the new user.
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After creating a new user, add the user to workgroups as required.

Typically, default user settings are all that is required for most users. The appropriate user
permissions are configured by the default workgroup role when you add this user to a workgroup.
Although many settings and permissions options are available to modify on a user-by-user basis,
it’s likely that you will never need to do so.

NOTE: All font manipulation happens in the Universal Type Client. Add fonts, remove
fonts, add keywords, and organize fonts into sets using the Type Client.

You can edit the user account information, settings, and permissions after the user is created.

To edit an existing user:
1. Open your web browser and start the User Management application

If you already have it open, then choose Window > Users and Workgroups.
2. In the Workgroups pane select any workgroup to which the user belongs.
3. In the Users pane, select the user to edit.
4. In the Details pane, click the Edit button.
5. Update any of the user account information, settings, and permissions.
6. Click the Save button.

Adding Users to Workgroups
For a user to have access to fonts in a workgroup, you must first add the to the workgroup. You can
add a user into a workgroup when you create it, or you can drag an existing username into a
workgroup.

To add an existing user to a workgroup:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Workgroups pane, select the All Users workgroup, or any other workgroup to which

the user currently belongs.
3. Drag a user name from the Users pane into any other workgroup.

The user is automatically assigned the default role in the new workgroup.
4. You can now edit the user’s permissions for the new workgroup in the Workgroup tab.

To add multiple users to a workgroup:

Follow the steps above, but select multiple users and drag the selected group from the Users pane
into a workgroup.

(To select multiple users, hold down the COMMAND key (Macintosh) or CTRL key (Windows) and
click on each user.)
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To add users to multiple workgroups:
1. Select the users.
2. Right-click on one of the selected users.
3. Choose Add to Multiple Workgroups from the pop-up menu.
4. In the resulting dialog, check the box next to each workgroup that you want to add the users

to.

5. Click the OK button.

You can also choose Add to All Workgroups from the pop-up menu to add the selected users to all
workgroups.

Importing Users from a file
A fast way to create multiple user accounts at one time is to import a list of users from a tab-
delimited text (.TXT) file. This way administrators can quickly set up users before adding them to
workgroups.

The text file must be formatted to include tab-delimited information, in order, with line breaks
between users. To import properly, the .TXT file must be saved as ASCII text with UTF-8 encoding.

The only required field is User account name. All other fields may be left blank if desired.
l User account name
l User full name
l Email address
l Notes
l Password
l Role
l Workgroup

For example:
jsmith → Smith,John → jsmith@domain.com → MyNotesHere → johnspassword →

ContractorRole → DesignersWorkgroup¶
where→ represents the tab character and ¶ represents a line break.

To skip a field, but enter other information, put extra tabs between the fields. For example, to enter
a User account name and Password only:

jsmith → → → → jsmithpassword¶
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Multiple workgroups can be assigned by adding them at the end of each line, before the line break.
For example, to add two workgroups named Design and Production to the user in the example
above, the end of a new line would be:

...jsmithpassword → Font Administrator → Design → Production¶
In the example above, John Smith would be added to both the Design and Production workgroups
and given the Font Administrator role in both workgroups.

NOTE: To make it easy to create a properly formatted .TXT file, use the Export feature
from your spreadsheet program, such as Microsoft Excel.

To import a list of users:
1. Open your web browser and start the User Management application.
2. Choose Users and Workgroups > Import Users from Text File.
3. Click Import Users from File.
4. Navigate to the tab-delimited text file to import, select the file, and click Select (Mac) or

Open (Windows).

Configure default user settings
Two settings affect how and when fonts and other data are synchronized between the Universal
Type Server and client computers. Default settings can be applied at any time.

To configure default user settings:
1. Open your browser and start the User Management application.
2. Choose Options > Default User Settings.
3. Click the Time between server syncs drop-down menu and choose a synchronization

interval. This setting controls how frequently the client checks for updates from the server.
The default is every 5 minutes. If the fonts in your environment change infrequently, an
hourly or daily setting may be all you need. Less frequent synchronization uses fewer
server resources.

4. Click the Font Replication Mode drop-down menu and choose a replication mode.
n All: Automatically downloads all fonts for the workgroups in which the user is a

member.
n On-Demand: Only downloads fonts as they are needed.
n On-Demand Local Cache: Downloads fonts as they are needed and keeps them cached

locally for fast re-activation.
5. Click the Save button to apply the new default user settings.

NOTE: To apply user permissions to multiple users at once, create and apply a role (see Roles on
page 19) to users in a workgroup.
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Settings
User settings control a number of options about how users are given access to fonts, as well as
enabling administration privileges. This includes:

l The Is Full Administrator setting allows users to access the “All Fonts” workgroup as well as
access the User Management application.
See The Full Administrator Setting below for more information.

l The Time between server syncs setting controls how often fonts are downloaded, or
synchronized with the Type Server.
See Synchronization below for more information.

l How fonts are stored on the client’s system is controlled by the Font Replication Mode
setting.
See Font Replication Mode on the next page for more information.

l Personal font workgroups are enabled through user settings.
See Personal Workgroups on page 36 for more information.

l The ability to change the user’s own password is a user setting.
See Change Password on page 36 for more information.

l Disable Startup Sets so that the user is not subject to having all fonts in startup sets activated
upon login.

The Full Administrator Setting
The Is Full Administrator setting allows a user to perform most of the administration tasks
available through the User Management application.

For each Type Server, typically only one or two users will have the Is Full Administrator setting.
The Is Full Administrator setting can only be assigned by the Server Administrator (see The Server
Administrator on page 43).

Full Administrators are users who are primarily responsible for the high-level workgroup and user
organization, and are likely members of the IT department.

The Is Full Administrator setting allows a user to:
l Assign the Workgroup Administrator permission to a user.
l Create and delete users in any workgroup.
l Modify permissions and settings for any user in any workgroup.
l Rename and regroup font families.
l Delete any sets that have been shared by other users.
l Create and edit font licenses.
l Create and edit Directory Service mappings.

Synchronization
To keep all of the fonts, font attributes, and user permissions current in all Universal Type Clients,
the client synchronizes data with the server on a periodic basis.

How often each user account synchronizes with the Universal Type Server is controlled by the Time
between server syncs user setting. This setting is adjustable so that administrators can help
minimize network traffic while ensuring that all clients are kept up to date.

Synchronization takes place only while the client is connected and working online with the Type
Server. After working offline, the client automatically synchronizes with the server, downloading all
attribute changes and permissions. Fonts are downloaded to the client based on each user’s Font
Replication Mode (see Font Replication Mode on the next page).
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The synchronization interval for each user can vary based on that user’s needs. For example all
users of a production department may work on the same project at the same time. All of these
users will need the same fonts at the same time, so a very short synchronization interval would
benefit this environment. Alternately, a copy editor who works on just a few projects with a fairly
static group of fonts would not need to be constantly synchronizing with the server. A longer
interval, perhaps daily, would be more appropriate for this user.

A more frequent synchronization setting can create unnecessary network traffic and potentially
slow down your network. So, set your synchronization frequency to the a longer interval to keep
network traffic to a minimum.

Font Replication Mode
The Font replication mode setting controls when fonts are downloaded to the client system. Font
replication is important to understand to keep your network traffic to a minimum and to maintain
healthy server performance.

Depending upon the type of use that you expect, and to minimize network traffic, each user may
have a different replication mode.

l All: This replication mode automatically downloads all fonts from the workgroups to which
the user is a member. This is a good setting for users who will frequently be working offline,
and who need access to a wide variety of fonts.

l On-Demand: This mode downloads fonts as they are required. Previewing, activating and
collecting fonts initiates the download of selected fonts to the client computer. When fonts
are no longer required, they are removed and are not stored in the Type Client font cache.
Only fonts that are currently active or being previewed are available while working offline.

l On-Demand Local Cache: This replication mode downloads fonts to the client as they are
requested. Previewing, activating, and collecting fonts all initiate the download of a font.
After being downloaded from the server, fonts are not removed and remain in the Type
Client cache. Cached fonts are available for activation, preview, and collection while working
offline.

Font Replication and Licensing Issues
The font replication mode that you choose can be affected by how you expect to account for the
licenses for your purchased fonts. Fonts are each small pieces of software, each with their own
license. You may have purchased fonts as part of a large library or one at a time. Either way, you
need to be sure that you’re using fonts in a way that you aren’t compromising the font’s license.

l The All replication mode downloads all workgroup fonts to a user’s system. Each and every
font in workgroups to which the user is a member is always downloaded to the user’s
system, and thus may require a license for that font file.

l The On-Demand replication mode only downloads files to a user’s system when they are
required. When the font is no longer in use, it is removed from the system and no longer
consumes a font license.

l The On-Demand Local Cache mode only downloads fonts as requested. So, if a user has
previewed or activated a font, it is considered in-use by the system, and consumes a font
license at that point. Since fonts are not removed from the user’s system, all fonts remaining
on the user’s system continue to consume licenses.
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Personal Workgroups
At the discretion of the administrator, users can add fonts to their own personal workgroup.
Personal workgroups can be either server-based or client-based.

l Server-based personal workgroups are available on any computer that the user logs in to. This
is a good setting if you want to be sure that personal workgroups are available from any
computer where the user logs in, and to ensure that there is always a backup of personal
workgroup fonts on the server.

l Client-based personal workgroups are housed only on a single computer so the fonts
contained within these workgroups can vary from computer to computer for the same user
account. Client-based workgroups have the advantage that if a user attempts to add corrupt
fonts, the corrupt fonts are placed into a “corrupt fonts” set within the client-based personal
workgroup.

Personal workgroups are useful when experimenting with fonts for which you may only have a
single license. For example, say a graphic designer who is working on a new client’s identity is
experimenting with fonts that are not part of the company’s licensed font library. The designer
believes the fonts are ideally suited to the job and the administrator does not want to squelch the
designer’s creativity. But, since the company doesn’t yet own a large number of licenses for this
font, you don’t want to add them to the server for an entire workgroup to use. The solution is to
have the designer add the fonts to his or her personal workgroup. If the client approves the fonts,
you can purchase additional licenses and add the fonts to the appropriate workgroups.

Access to a personal workgroup is a user-based permission, so some users might have them while
others do not. For example, graphic designers are likely to need a personal workgroup, but editors
are not. Since the fonts are for private use, users can add, delete, activate, add attributes and collect
for output from their personal workgroup.

WARNING: Changing the personal workgroup setting after a user has already added fonts
and sets to that workgroup will result in the deletion of all existing fonts and sets in the
user’s personal workgroup. It is best to specify the personal workgroup setting when
adding a user and not modify it after a user has started to work with the personal
workgroup.

Change Password
The Change Password setting allows the user to update their password directly from the Universal
Type Client by choosing Server > Change Password.

Alternately, Full Administrators can change a user’s password directly through the User
Management application.

NOTE: If you are bound to a Directory Service and using Kerberos for single sign-on, the
Change Password command does not have any affect on domain passwords. This
command only affects Universal Type Server passwords.

Activate Fonts Across Workgroups
All users are able to simultaneously activate fonts in any workgroups to which they are a member.
The Activate Fonts Across Workgroups setting applies only to the auto-activation plug-ins installed
on the client’s system.
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The Universal Type Server plug-ins are typically limited to activating fonts from a single
workgroup. When the user launches an application for which the Type Server plug-in is enabled, the
user is prompted to select a workgroup of fonts to use for auto-activation. Enabling this permission
allows the plug-ins to activate fonts from workgroups to which the user has access and are enabled
in the plug-in.

Due to the fact that you can’t guarantee that all users will have access to all fonts, it is best to
design documents to only use fonts from a single workgroup. This way you can guarantee that all
users of that workgroup will have the fonts necessary for the document. The risk of enabling this
feature is that a user could unintentionally create a document that uses fonts from multiple
workgroups.

Enforce System Font Policy
System Font Policies are used to control which fonts can be added to the system font folder on a
user’s computer.

When a system font policy is enforced for a user, the Universal Type Client periodically checks
which fonts are in the system font folders and removes any unapproved fonts.

For complete details about System Font Policies, see Modifying the System Font Policy on page 47.

Disable Startup Sets
This permission disables the activation of startup sets for the selected user. You may want to do
this for users who may be part of a workgroup, but not need to activate fonts that are typically
activated for all users of the workgroup by startup sets.

Users will still see startup sets in their workgroup, but the fonts are not be automatically activated.
Fonts in these sets can be manually activated if desired.
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Updating user settings for multiple users
Settings can be updated for multiple users at the same time by selecting multiple users in the User
Management application.

TIP: You may also want to designate default server settings (see Configure default user settings on
page 33) that are automatically applied to users as they are created.

The following settings may be changed for multiple users at the same time:
l Change password
l Activate fonts across workgroups
l Time between server syncs
l Font replication mode
l Has Personal Workgroup (server-based or client-based)
l Enforce System Font Policy
l Disable Startup Sets

NOTE: The Full Administrator setting (see The Full Administrator Setting on page 34) and
other account settings such as password, full name, and notes cannot be updated for
multiple users at the same time. It is also important to note that users who are currently
Full Administrators cannot be updated in a group with other users, and must be updated
individually.

To edit the user settings for multiple users:
1. Open your web browser and start the User Management application.
2. In the Workgroup pane, select a workgroup.
3. In the Users pane, select multiple users by SHIFT-clicking the first and last users, or by

CTRL-clicking (Windows) or COMMAND-clicking (Mac) multiple users in the list.
4. In the Details pane, select the settings to apply or remove from all selected users and click

the Save button.

TIP: Use the Roles feature (see Roles on page 19) to quickly apply and update permissions for
multiple users.

Permissions
Permissions control what a user is allowed to do in workgroups. Permissions can be set globally, so
that they affect all workgroups for a user, or on a workgroup-by-workgroup basis.

Permissions control the ability to:
l Add and remove fonts
l Collect fonts for output
l Create, delete and modify shared sets
l Create and delete startup sets that are permanently active for all users
l The ability to create, delete and apply attributes to fonts

In most cases, it is best to allow permissions to be set by the user’s role within each workgroup.
Yet, for some users, you will need to specifically edit user permissions. Typically, you will need to
edit permissions for users who need extra abilities within a workgroup. For example, in a
workgroup where all users are given the Regular User default role, you may want to give one user
responsibility for creating keywords. To do so, for this user the administrator would grant the
Create and Delete permission for Keywords.
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Global Permissions
Global permissions grant users permission to perform actions across all workgroups to which the
user has access.

All global permissions are set by the user’s role within each workgroup, and using roles is the
recommended method for applying user permissions.

Though, there may be some instances where you want to globally grant a single user extra
responsibilities across all workgroups. For example if there is a user who will be primarily
responsible for collecting fonts from multiple projects for archiving, the administrator would
enable the Collect Fonts for Output global permission for that user.

Globally granted permissions override any permissions set by a user’s role in the workgroup, as
well as any custom workgroup permissions.

Global permissions include both font-based permissions and font attribute permissions.

Font-based permissions include the ability to:
l Collect Fonts for Output
l Add and Remove Fonts
l Create and Delete Startup Sets

Font attributes are only stored within Universal Type Server and never applied to the source font
file. Font attributes include all font licensing, keywords, styles, classifications, foundries and font
family information. Administrators can grant or deny the ability to create, delete, and apply:

l Licenses
l Keywords
l Styles, Classifications, Foundries, and Families
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Workgroup Permissions
Workgroup permissions are permissions that are restricted to a specific workgroup. Administrators
can use this tab to grant or deny permissions for each user on a workgroup-by-workgroup basis.

Permissions on the Workgroup tab are broken down for every workgroup to which the user
belongs. Use the Show permissions for Workgroup drop-down menu to change which workgroup
permissions are displayed.

All of the workgroup-based permissions can be set by the user’s role in the workgroup, although
custom permissions can be granted or denied.

NOTE: If a permission is granted or denied in the Global permissions tab, it cannot be
modified in the Workgroup tab.

Use the Role in Workgroup drop-down menu to select the user’s role for the workgroup displayed
in the Show permissions for Workgroup menu above.

A star * displayed next to the Role in Workgroup drop-down menu indicates that there have been
custom workgroup permissions applied in the Workgroups tab. This is an easy way to see if the
workgroup permissions are different than the default role permissions.

Font-based permissions can be granted or denied on a workgroup level. These include the ability
to:

l Collect Fonts for Output
l Add and Remove Fonts
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All users can create their own sets within a workgroup. For sets to be visible to other users, the set
must be shared within the workgroup. As an example, you may want to allow a user to create and
delete shared sets, for a workgroup, but restrict their ability to modify the shared sets from other
users. Shared set permissions include:

l Create and Delete Shared Sets
l Modify Shared Sets
l Create and Delete Startup Sets

Font attributes are only stored within Universal Type Server and never applied to the source font
file. Font attributes include all font licensing , keywords, styles, classifications, foundries, and font
family information. Administrators can grant or deny the ability to create, delete, and apply:

l Licenses
l Keywords
l Styles, Classifications, Foundries, and Families

Role-based Permissions
The following permissions can be granted or denied to each user on a workgroup-by-workgroup
basis. A user’s role for each workgroup is set in the Workgroup permissions tab of the User
Management application.

Role-based permissions can be overridden, allowing the administrator to grant or deny permissions
globally for a user, or on workgroup-by-workgroup basis for each user.

Each permission has a three-state check box that switches between the role permission and
whether the permission is custom granted or denied. If a permission is granted globally, it cannot
be modified in the Workgroup tab.
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Add and Remove Fonts
This permission allows the user to add font to and remove fonts from a workgroup. This is an
important responsibility, because if a font is removed from a workgroup, and if it doesn’t belong to
any other workgroup, it is immediately removed from the Type Server. Enable this permission for
users who are aware of this responsibility.

Collect Fonts for Output
This permission allows users to export fonts from the Type Server to a location outside of the
server. Users may need to do this when sending a project from one company location to another.

NOTE:Remember that fonts are individual pieces of software, and each font has specific font
licensing requirements. Only collect and provide fonts to others whom you know have purchased
the appropriate font licenses.

Create/Delete Shared Sets
All users can create and modify their own sets in all workgroups for which they are a member. The
sets are associated with each username and are therefore available only to that user.

To allow the user to share a sets with the entire workgroup, check the box labeled Create/Delete
Shared Sets. This can be helpful when users are creating a group of fonts to be used with a project.
When the user finalizes the set and wants to bring others onto the project they share the set with
the entire workgroup. So, in general, reserve this permission for project leaders.

Enabling this permission also allows the user to unshare any set that they have shared, making it
unavailable to others in the workgroup. The owner can also delete any sets that they have shared.

Modify Shared Sets
Check the box labeled Modify Shared Sets to allow the user to add and remove fonts from all
shared sets, as well as rename any shared set. The user can modify any shared set, including those
created by other users.

Create and Delete Startup Sets
Enabling this permission allows users to make any set permanently active for all users of the
workgroup. Fonts in startup sets cannot be overridden or deactivated by client users. This is handy
to activate a standard set of corporate fonts for all users in a workgroup.

The only way to deactivate or override fonts in startup sets is to remove the startup status of the
set. Only users who have this permission are to disable a startup set. Removing the startup set
status allows all users of the workgroup to deactivate and override fonts in the set.

Font attribute options
Font attributes are only stored within Universal Type Server and are never applied to the source
font file. Font attributes include all font licensing, keywords, styles, classifications, foundries and
font family information. Administrators can grant or deny the ability to create, delete, and apply:

l Licenses
l Keywords
l Styles, Classifications, Foundries, and Families

Font Attribute Options
Controlling font attributes helps organize fonts. Font attributes includes font licenses, keywords,
styles, classifications, foundries, and family information. Font attributes are stored only within
Universal Type Server and in no way affects your original font files, so attributes are helpful for
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organizing and finding files. For example, keywords can be added to all fonts used for a project,
client, or print job. Fonts can later be found using this information.

Administrators can set these permissions using three methods:
l Set by the user role
l Custom granted or denied in a user’s Global permissions
l Custom granted or denied in a user’s Workgroup permissions

All permissions can be set so that the user can create and delete attributes, or merely apply that
item to fonts. For example, you might have one person who creates your list of keywords, yet
everyone might have the ability to apply keywords to fonts.

Keywords: Keywords are a good way to track fonts. You can create a keywording strategy that helps
you track which fonts are used for specific projects or clients. As with the example used above, you
may only have a few users who can create and delete keywords, but many users who are able to
apply them to fonts.

Styles, Classifications, Foundries, and Families: Enable this permission for users who need to
modify Styles, Classifications, Foundries and Families. Typically these users create fonts or are
those who absolutely know which foundry fonts came from. Enabling this permission also allows
users to change how the Type Client displays font family information. For example, if you believe
that a font would better belong in another family group, you can drag that font file to another
family.

The Server Administrator
There is only one Server Administrator account per Universal Type Server installation. The Server
Administrator can perform any administrative task from the Server Administration and User
Management applications as well as any task in the Universal Type Client.

Most importantly, the Server Administrator is the only user account that is able to assign or
remove the Is Full Administrator setting (see The Full Administrator Setting on page 34), and cannot
be deleted from the server.

Typically, the only time you would use the Server Administrator account is during the initial
configuration of the Type Server, and when you need to add or remove users with the Is Full
Administrator setting.

The Server Administrator username is always set to administrator and the default password for the
account is password. For optimal security, change this password as soon as possible after
installation.

WARNING: Do not lose the Server Administrator password! This is the only username and
password that cannot be reset or recovered. If you do lose your Server Administrator
password, please contact Extensis technical support for assistance. See Technical Support
on page 76 for contact information.
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Changing the Server Administrator Account
Password
After installing the server, for security reasons, it is very important to change the password for the
Server Administrator account. This account has access to all of the functions of the Universal Type
Server and can delete and change all users and workgroups. It is important to keep this account
login secure.

Until other users are created, the Server Administrator account is the only account with access to
the User Management application.

To change the administrator password:
1. Open the User Management application (see Opening User Management on page 17).

The Server Administrator account username is administrator, and the default password for
this account is password.

2. In the Workgroups pane, click All Users.
3. In the Users pane, select the Administrator user account.
4. In the Details pane, click the Account tab and enter a new password in the Password field,

then enter it again in the Confirm Password field.
5. Click the Save button.

WARNING: Do not lose your Server Administrator password! This is the most important
password for your entire system and cannot be easily retrieved or reset.
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User Worksheet
Font Server Account Information

Account Name

Full Name

Email Address

Password

Account Settings

Is Full Administrator ❑   Yes      ❑   No

Can Change Password ❑   Yes      ❑   No

Activate Fonts Across Workgroups ❑   Yes      ❑   No

Time between server syncs

Font Replication Mode (Choose one) ❑   All   ❑   On Demand   ❑   On Demand Local Cache

Enforce System Font Policy for This User ❑   Yes      ❑   No

Disable Startup Sets for This User ❑   Yes      ❑   No

Personal Workgroup (Choose one) ❑   None   ❑   Server-based   ❑   Client-based

Global Permissions

Can Collect Fonts for Output ❑   Yes      ❑   No

Can Add and Remove Fonts ❑   Yes      ❑   No

Can Create and Delete Startup Sets ❑   Yes      ❑   No

Can Apply Licenses to Fonts ❑   Yes      ❑   No

Keywords ❑   Create and Delete      ❑   Apply to Fonts

Styles, Classifications, Foundries, Families ❑   Create and Delete      ❑   Apply to Fonts

Workgroup Membership

Workgroup Name Role in Workgroup

Notes
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Deleting Users
When a user no longer needs access to served fonts, you can safely delete their user account from
Universal Type Server.

If you think that the user will need access in the future, you may wish to leave their account active,
yet remove them from all workgroups. Removing a user from all workgroups prevents them from
getting any fonts from the server, yet the user will still be able to use any fonts in their personal
workgroup. Though, it is important to note that the user still consumes a license.

If you need an additional user license for others to access Type Server, you can force the user to
disconnect, and remove the user account. To force user disconnection, click Users in the Server
Administration application. For complete details, see Server Administration User Guide and help
system.

To remove a user account:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. Select the All Users workgroup.
3. Select the user account name and click the - button in the Users pane.
4. Click the OK button to confirm the account removal.

Searching Users
If you have a large number of Type Server users, to quickly locate a specific user you can use any
user data to search for the user.

To search for a user:
1. Open your web browser and start the User Management application.

If it is already running, choose Window > Users and Workgroups.
2. In the Workgroups pane, select a workgroup.
3. At the bottom of the Users pane, enter any part of a username, email address, or notes for

the user. For example, enter Joe to find all users that have the username, part of an email
address or notes that contain the text “Joe.” The Users pane automatically updates to
display only users who contain that data.
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The System Font Policy
A computer’s operating system keeps fonts that it requires for operation in specific folders.
Depending on his computer account permissions, a user may be able to add his own fonts to these
folders.

To avoid having users install unauthorized fonts on their computers, you can enable a System Font
Policy. The System Font Policy is a list of fonts that are allowed to exist in the computer’s system
font folders. If Universal Type Client “sees” a new font installed that is not on the System Font
Policy list, it will remove the font.

The default System Font Policy list includes all required system fonts for supported Windows and
Mac operating systems. It also includes a number of fonts required by certain common
applications.

You can add fonts to the list, and you can remove any fonts that are not required system fonts.

NOTE: Due to changes in OS X 10.8 (Mountain Lion) and later, the System Font Policy feature can
only remove fonts from the user font folder (~/Library/Fonts/). This is the folder where manually-
installed fonts are placed by the operating system. (For this reason, the System Font Policy list does
not include required system fonts for OS X 10.8 and later.)

Modifying the System Font Policy
Separate System Font Policy lists exist for Windows and OS X. Each list includes required system
fonts for all supported operating systems (Windows 7, Windows 8, and Windows 8.1; OS X 10.6–
10.10). You cannot remove any of these required fonts from the System Font Policy lists.

Each list also includes fonts required by some common applications. You can remove any of these
fonts if desired.

You can enable the System Font Policy using the default font lists, or you can modify the lists as
needed for your environment. You may especially want to add corporate branding fonts or fonts
required by specific applications.

To add a font to the System Font Policy:
1. Log in to the User Management application.
2. Choose Window > System Font Policy.
3. Click the Add + button below the list where you want to add a font.
4. Type the font’s file name and press ENTER.

IMPORTANT: You must type (or copy and paste) the font file's complete name, including its file
extension.

To remove a font from a list, select its name and click the Delete - button below the list.
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Enabling the System Font Policy
You can enforce the System Font Policy for any Universal Type Client user.

IMPORTANT: On Windows 7 and later versions, User Account Control policies may interfere with the
ability to enforce a System Font Policy. You may need to consider UAC configuration changes in
order to utilize the System Font Policy. See your Windows documentation for more information.

To enable the System Font Policy for a user:
1. Log in to the User Management application.
2. Choose Window > Users and Workgroups.
3. In the Workgroups pane, select a workgroup.
4. In the Users pane, select a user.
5. In the Details pane, click the Settings tab.
6. Check Enforce System Policy, then click Save.

TIP: To quickly enable the System Font Policy for all users, select the All Users workgroup, then
click the first user in the list, hold down the SHIFT key and click the last user, check Enforce System
Font Policy and click Save.

To enable the System Font Policy for new users by default:
1. Log in to the User Management application.
2. Choose Options > Default User Settings.
3. Check Enforce System Font Policy.
4. Click Update.
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Reports
The User Management application offers access to a variety of reports that provide details about
your system, fonts, users, and font usage.

To access reports, choose Window > Reports.

NOTE
If you are using a tablet running iOS 9 or later, Android 4.4 or later, or Windows 10, with a
display resolution of at least 1024×768 pixels, you can access User Management reports
from your device. You must be on the same network as your Type Server (or connected
through a VPN). Open a browser and enter <server_address>:8080/mobile_login.html
(or, if you are using a secure connection, enter <server_address>:8443/mobile_
login.html), where <server_address> is the IP address or fully-qualified hostname of the
computer running Universal Type Server.

Using reports
l You can filter a data list to only display entries that contain certain text. Type some text in
the field at the bottom right of the window and press RETURN or ENTER; the data list will be
updated to show only those entries where the text you typed appears in any column (except
the Account Type column, for reports that display this).

l Click a column head in a data list to sort the list on that columns; click again to reverse the
sort order.

l To resize a column, drag the right side of the column’s head.
l Click one of the Export buttons at the bottom right of the screen to export the report data to
use in other applications.

l Click Close at the top right to exit the Reports window and return to the User Management
application.

NOTE: If all of the individual reports are blank, there is probably a port conflict on your Universal
Type Server. Alert your server administrator.
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REPORT EDITIONS PURPOSE SEARCHING AND SORTING DATA DETAILS

Users All The list shows all users and their
account details so that you can ensure
that all font users are able to connect
to Universal Type Server.

Search and sort on name, date added
and account type.

This report displays all user accounts in
your Type Server as of the time that
you generate the report.

Fonts All The list shows all fonts available to
your Type Server so that you can see all
fonts quickly.

Search and sort by PostScript Name,
Foundry, Version, and Font Type.

The interactive pie chart offers one-
click filtering to view fonts by Font
Type.

This report displays all fonts served by
your Type Server as of the time that
you generate the report.

Users by Workgroup All The list shows user accounts for each
workgroup so you can easily see how
many users there are in each
workgroup and who they are.

Search and sort on account name, full
name, and account type.

The interactive bar chart offers one-
click filtering to view users in each
workgroup.

This report displays all users and
workgroups in your Type Server as of
the time that you generate the report.

Fonts by Workgroup All The list shows fonts assigned to each
workgroup so you can easily see how
many fonts there are in each
workgroup, and which ones they are.

Search and sort by PostScript Name,
Foundry, Version, and Font Type.

The interactive bar chart offers one-
click filtering to view in each
workgroup.

This report displays all fonts and
workgroups in your Type Server as of
the time that you generate the report.

Client Connections All The list shows current connections for
the selected account type so you can
monitor user activity and client
currency.

Search and sort on account name, full
name, IP address, Machine ID, Login
Date, and Active status.

The interactive pie chart offers one-
click filtering to view client connections
by account type.

This report displays all clients
connected to the Type Server as of the
time that you generate the report.

User Settings All The list shows user accounts and their
settings so that you can monitor user
settings across your entire font
environment.

Search and sort on account name, full
name, Client Replication Mode,
Synchronization Interval, System Font
Policy status, and Personal Workgroup
setting.

This report displays settings for all
users in your Type Server as of the time
that you generate the report.

See Settings on page 34 for details
about the available settings and
possible values.
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REPORT EDITIONS PURPOSE SEARCHING AND SORTING DATA DETAILS

Out of Compliance Enterprise The list shows which fonts have been
out of compliance by how many
“seats” over the available license count
within the past 90 days so that you
can maintain the necessary number of
licenses at all times.

Search and sort on Postscript Name,
Version, Font Type, Font ID, License
Count, and License Usage.

This report shows data accumulated
over the previous 90 days.

See Additional report information
on the next page for more information
about compliance

Duplicate Fonts Enterprise The list shows fonts that have multiple
copies or versions stored on the Type
Server so that you can remove
unwanted versions.

Search and sort on Postscript Name,
Foundry, Version, Font Type, and Font
ID.

See Additional report information
on the next page.

Fonts by License Enterprise The list shows fonts assigned to
licenses so that you can track how
fonts are being licensed in your
organization.

Search and sort on Postscript Name,
Foundry, Version, and Font Type.

The interactive bar chart offers one-
click filtering to see the fonts assigned
to a particular license.

This report shows all fonts and licenses
in your Type Server as of the time that
you generate the report.

NOTE: A font may be assigned to
multiple licenses.

Font Usage Enterprise The list shows fonts in all workgroups
or a selected workgroup, with out-of-
compliance fonts emphasized to
provide an at-a-glance usage report
that will help you keep your fonts in
compliance and ensure that your users
do not overuse their allocated licenses.

Search and sort on Font Name,
Postscript Name, Family, Foundry,
Version, and License. The interactive
bar chart offers one-click filtering to
see the fonts assigned to a shared set
in the selected workgroup.

This report provides a current font
usage snapshot as of the time that you
generate the report.
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Additional report information
Out of Compliance report
Compliance is determined by font usage based on the licenses that you create and assign in the
User Management application.

When a font is considered “in use” depends on the type of client replication being used:
l On Demand: Connected clients tell the Type Server when a font is activated or deactivated.
l On Demand with Cache: Connected clients tell the Type Server when a font is activated or
deactivated. Fonts are cached, so activation may occur faster than on a non-cached client
(which may have to download the font again).

l All: The client tells the server that all fonts are in use, assuming them to be active or able to
be activated if the system goes offline.

l Go Offline: Similar to the All mode; if the user does not wait for fonts to synch after invoking
the “Go Offline” command, only those fonts that have been downloaded will be considered
“in use.”

Each font license includes a list of licensed fonts and the number of “seats” that can actively use
the font simultaneously.

A font is in compliance if the number of seats where the font is “in use” does not exceed the total
number of seats licensed for that font.

A font goes out of compliance if it is in use at more seats than the total number of licensed seats.

The Out of Compliance report shows fonts that have been out of compliance at some point in the
past 90 days. It’s important to understand that fonts listed in this report may not be out of
compliance at the time that you generate the report.

Use the compliance report to determine if you need to acquire more licenses for a font that is
routinely out of compliance.

NOTE: A font can only go out of compliance if one or more of the licenses that include it has its
Enforcement mode set to Notify only. Strict enforced licenses will not go out of compliance, but
you may have content creators unable to work because they are denied access to fonts that are in
use by the maximum number of allowed seats.

See Font Licenses on the next page for details about creating and assigning fonts to licenses.

Duplicate Fonts report
Duplicate fonts will typically have the same PostScript name and Display name, but different
versions and/or foundries, and different Font Sense IDs.

Depending on your workflow, it may be important to keep these different versions available; subtle
differences in glyph shape, kerning, and other elements may be important to maintaining the look
of a specific client’s documents.
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Font Licenses
Universal Type Server allows you to associate fonts with information about their respective license
agreements.

l The Font License is the instrument that allows Type Server to manage and report on font
license compliance. Fonts that are not assigned to a license cannot be monitored for
compliance.

l You create and edit license information in the User Management application.
l You can apply font licenses from either the Universal Type Client or User Management.
l Since you might purchase a font multiple times, a font can be assigned to multiple licenses.
l Since you might purchase multiple fonts at one time from the same supplier, multiple fonts
can be assigned to a single license.

l Font licenses are added globally so the same license will apply to the font across all
workgroups.

l Only Full Administrator users can create or edit licenses.

Developing a Font License Strategy
To create effective licenses, you will need to carry out the following tasks:

1. Locate all of your End User License Agreements for the fonts you own.
If you are unable to locate them, contact the foundries directly to receive a copy.

2. Verify which fonts each license applies to.
3. Consider an identifiable name for each license you will store in your Type Server.
4. Consider who will manage your licenses.

n Will it be a shared task, or will one person be responsible?
n Who will create licenses, who will apply them to fonts, and when will they do this?
n How do you intend to handle unlicensed fonts and who will be responsible for

monitoring this?

NOTE: You should always keep a hard copy or digital version of original End User License
Agreements as proof of your license ownership.

For consistency and maximum efficiency, consider the following:
l Use standard naming conventions for licenses. If you have three different types of licenses
from Adobe, you may need to be able to distinguish them from each other.

l Standard use of the Comments field, which lets you store additional information with
licenses. For example, you might use this field to indicate which department licensed the
font.
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Creating, Editing, and Deleting Licenses
To access licenses, choose Window > Fonts and Licenses.

To add a license:
1. Click + in the Licenses pane.
2. Enter the license information.

License name: Enter a descriptive and unambiguous name for the license.
Number of seats: How many computers each font in the license can be installed on.
Enforcement mode: Strict to have Universal Type Server automatically decline to allow
more computers than the number of seats to activate the font, or Notify only to be notified
if a font is activated more times than there are seats available.

Other information is generally optional, but consider using it as part of your licensing
strategy and compliance plan. See Other Parts of a License below for details.

3. When you have finished entering the license information, click the Save button.

To edit a license:
1. Select a license in the Licenses pane.
2. Click the Edit button.
3. Modify the license information.

See Other Parts of a License below for details about optional information you can add to
your font licenses.

4. Click the Save button.

To delete a license:
1. Select a license in the Licenses pane.
2. Click -.
3. In the confirmation dialog, click the OK button to delete the license or click the Cancel

button to keep it.

Other Parts of a License
You can add more information to the license that you store in Universal Type Server to aid in your
compliance goals, record keeping, and purchasing. The categories available are:

l Terms of Use: Add information about how the fonts covered by the license are allowed to be
used.

l Purchase Information: Add information about when and how you purchased the fonts
associated with the license.

l License Details: This displays when the Type Server License entry was created and who
created it, and when it was last modified and who modified it.

l License Agreement Documents: You can upload files related to your license, such as a scan of
an invoice or an email that includes license information.

To view any of these information categories, click on the category header. Click on the header again
to hide the information.



- 55 -

Terms of Use
The Terms of Use consists of a list of up to 10 uses that your font license allows.

l To add a term to the list, choose one from the pop-up menu below the list and click the +
button.

l To remove a term from the list, select it in the list and click the - button.
l To add terms to the pop-up menu, choose Edit Terms of Use list from the menu, then click +
in the resulting dialog, type your new term, press the ENTER key, then click the Save button.

l You can also add comments below the list of terms.

Purchase Information
You can add information related to your purchase records for your font license.

To enter dates, click the date field or the calendar icon , then choose the month, year, and day of
the month from the calendar graphic.

License Agreement Documents
Universal Type Server can store digital copies of important documents related to your font license.

l To add a document to the list of License Agreement Documents, click the + button, enter a
name for the document, browse for a file to upload or enter an URL to the document, then
click the Save button.

l To remove a document from the list, select it in the list and click the - button.
l To view an URL or download a copy of an attached document, select it in the list and click the
View/Download button.

Applying and Removing Licenses
To apply licenses to fonts, choose Window > Fonts and Licenses.

You can also apply and remove licenses in the Universal Type Client. See the Type Client User Guide
or help system for details.

To apply a license to a font:
1. Select one or more fonts in the list.
2. Check the box next to the license you want to apply to the selected fonts.

NOTE: A checkbox that looks like this indicates that some of the selected fonts have
the license applied, and some do not.

To remove a license from a font:
1. Select one or more fonts in the list.
2. Clear the checkbox next to the license you want to remove.
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Finding Unlicensed Fonts
There are several ways you can identify fonts that do not have licenses assigned.

l In the Fonts and Licenses window, choose Filter By > Compliance Status and click Not
Licensed.

l In the Fonts and Licenses window, choose Filter By > All Fonts, then select individual fonts
to inspect the licenses assigned to them.

l In the Reports window:
a. Click + to create a new report.
b. Choose Report Type > Font Usage
c. Choose Filter By > All Fonts
d. Click the Generate Report button.
e. Select the generated report in the list at the left.
f. In the Report Data pane, click the License column to sort the data by font license.

Unlicensed fonts are shown with a license “0” (zero).
g. Use one of the Export buttons to export the data.

l In the Universal Type Client, you can create a Smart Set to show unlicensed fonts in any
workgroup. See the Type Client User Guide or help system for details.

Viewing Font and License Infomation
To view font and license information, choose Window > Fonts and Licenses.

NOTE: You can view licenses assigned to individual fonts in version 4 of the Universal Type Client.

The Fonts and Licenses window allows you to view information about individual fonts, create and
edit licenses, and assign fonts to licenses.

You can also view the list of installed fonts and filter it by a number of useful criteria.

Filters
Apply a filter from the drop-down menu in the Filter By panel to display only fonts that meet
certain criteria.

The filtered list gives a snapshot of the current state of your installed fonts.

All Fonts: Shows all fonts installed on your Type Server.

Workgroup: Shows a list of all workgroups and sets within each workgroup. Select a workgroup or
set to show only the fonts that are assigned to it.

User/Machine: Shows a list of users and the IP address of each computer that each user logged in to
Universal Type Server from. Select a user/computer combination from the list to see the fonts that
user has activated on that computer. (A user can be listed more than once if they use more than
one computer, and a computer can be listed more than once if several people use it.)

Compliance Status:
l Select Licensed to show the fonts that are assigned to at least one license
l Select Not Licensed to show the fonts that are not assigned to any license
l Select At Maximum Usage to show the fonts that are currently activated for the maximum
number of seats allowed (the total number of seats available for all licenses assigned to the
font)

l Select Out of Compliance to list fonts that are currently activated for more seats than the total
allowed by the assigned licenses.
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Font Inspector
When you click a font in the list, the Font Inspector panel on the right shows you details about the
font, including its name, type, and version information.

Click the triangle next to a section to display more information about the font.

Workgroups and Sets shows you the workgroups and sets in each workgroup that the font belongs
to.

Licenses and Usage shows you how many total seats the font is licensed for, its compliance status,
the licenses that the font is assigned to, and individual machine usage information. (The Licenses
pane at the left also shows the licenses assigned to the selected font.)
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Enterprise Features
Universal Type Server Enterprise provides extended capabilities for organizations with large font
management and compliance needs. The additional and enhanced features of Enterprise are:

l Font license compliance enforcement
l Font usage and compliance reporting
l External SQL database connection
l Proxy failover support

External databases and failover support are described in the Server Administration Guide.

Differences in the Enterprise edition
Universal Type Server Enterprise users have access to additional features beyond those offered by
Universal Type Server Professional.

Fonts and Licenses
In the Fonts and Licenses window, Enterprise users have access to additional filters:

l The Workgroup filter includes the ability to display fonts by the sets they belong to.
l The User/Machine filter allows you to focus on fonts consumed by a particular user on a
particular computer.

l The Compliance Status filter allows you to display fonts according to their current license
status:
Licensed - The font is licensed and there are usage licenses available.
Not-Licensed - The font is not licensed.
At Maximum Usage - The font is licensed and all usage licenses are consumed.
Out of Compliance - The font is licensed and more usage licenses are consumed than are
available.

Enterprise users can also assign an Enforcement Mode to font licenses.

Enforcement Modes
There are two levels of enforcing compliance in Universal Type Server: Notify only and Strict.

In both cases, Universal Type Server tracks font activation and deactivation against the number of
available licenses for a font. (The number of licenses available for a font is the total of the License
Counts for each license that is applied to the font.)

If the enforcement mode is Notify only, then the Server Administrator will be notified that a font is
out of compliance. It is then up to the Server Administrator to determine a course of action; if
compliance is frequently exceeded, for example, it could be a sign that either people are activating
a font that don’t actually need it, or that it is time to buy additional licenses for the font.

If the enforcement mode for a font is Strict, then once all of a font’s licenses are in use, nobody
else will be able to activate a copy of that font, until someone who is using the font deactivates it
on their computer. Users attempting to activate a font that is at the maximum usage level will be
alerted that all licenses are in use.
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License Example
Organizations buy fonts at different times for different reasons. You may purchase the same font
several times from several vendors, perhaps as part of different bundles. In a case like this, you
could have a font that has multiple End User License Agreements.

Universal Type Server allows you to apply multiple licenses to a single font to accommodate this
situation.

When it comes to determining compliance for a single font, Universal Type Server takes into
account all of the licenses that are applied to the font. This has two important consequences: first,
the number of available usage licenses for a font is the total of the License Counts for all licenses
applied to the font; second, the enforcement mode for any given font is always the most restrictive
that is assigned in any license.

For this example, assume the font Helvetica has three licenses applied, License A, License B, and
License C.

l License A has a License Count of 10 and has Notify only enforcement.
l License B has a License Count of 5 and has Notify only enforcement.
l License C has a License Count of 10 and has Strict enforcement.

Helvetica has a total of 25 usage licenses, all of which will be treated with Strict enforcement.

If another font has License A and License B applied, it will have a total of 15 usage licenses and be
treated with Notify only enforcement.
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Connect Using Directory Services
Overview
Universal Type Server can connect with your network’s Directory Service, either Active Directory on
Windows or Open Directory on macOS. This means that you can:

l Allow users to log in to your Type Server using their network login credentials.
l Create Type Server users and workgroups based on your Directory Service users and groups.
l Use Kerberos Single Sign-On to automatically connect users to your Type Server once they
have logged in to their workstation.

l Automatically manage Type Server workgroup membership based on Directory Service group
membership.

l Automatically remove a Type Server account when a user is removed from the Directory
Service.

Authentication Methods
By default, Universal Type Server will authenticate users in your Directory Service using LDAP
authentication. You can instead choose to use Kerberos for single sign-on authentication.

LDAP Bind
Users enter their network login credentials into Universal Type Client. Universal Type Server passes
the authentication request to the Directory Service.

Kerberos
A user logs in to his workstation with his network username and password. When he starts
Universal Type Client, Kerberos passes the authentication request to the Directory Service.

Universal Type Server can store the login credentials for the Service Principal Name (SPN) in one of
two ways. Which authentication method you choose will depend on your needs.

Kerberos SSO with Password: Universal Type Server stores the SPN and password in its internal
database.

Kerberos SSO with Keytab: Universal Type Server stores the SPN in its internal database and uses an
encrypted keytab file to store the password.

Both Kerberos options require the use of a client-side configuration file to provide the Universal
Type Client with the server address and port number so that the user connects automatically.

If you choose to use one of the Kerberos authentication methods, see the following:
Configuring Kerberos for Active Directory on page 66
Configuring Kerberos for Open Directory on page 69
The Client Configuration file on page 71

Connecting to Your Directory Service
Universal Type Server can authenticate users and map users and groups to workgroups using the
same Directory Service that you use for network log-ins and other authentication. You need to bind
your Type Server to your Directory Service by entering its connection information.
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To bind to a Directory Service:
1. Open the User Management application and choose Window > Directory Service.
2. In the Connection panel of the Configure Directory Service dialog, enter the connection

settings of your Directory Service.
Hostname: The IP address or DNS name of your Directory Service.
Port: The LDAP connection port; the default port is 389.
If SSL is required, check the Use SSL option and update the port. (The default SSL port is
636).

Type: Choose either Active Directory (Windows) or Open Directory (macOS).

User: Enter a username in the Directory Service that has permission to query the Directory
Service.

How you enter the user name varies by the type of Directory Service you are using.

For Active Directory, enter the user name as one of:
n domain\user, such as mycompany\jsmith
n user@realm, such as jsmith@mycompany.com
n The fully qualified LDAP distinguished name (DN), such as

uid=jsmith,cn=users,dc=MARR,dc=MYCOMPANY,dc=COM

For Open Directory, enter the user name as either:
n The domain username only, such as jsmith.

This requires that anonymous directory authentication be enabled. (This is the default
setting for Open Directory.)

n The fully qualified LDAP distinguished name (DN), such as
uid=jsmith,cn=users,dc=MARR,dc=MYCOMPANY,dc=COM

Password: The password for the username that you entered.
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3. Specify update policies.
n Synchronize: Choose whether UTS should continually monitor Active Directory for

changes, or whether it should refresh all Active Directory mappings once daily. The
daily option is suitable if you have changed your Active Directory server to update
user modification dates frequently.
This option has no effect on changes you make to mappings within the User
Management application; those changes will be updated immediately.

n Delete UTS users when removed from directory service: If you enable this option,
then when you remove a Directory Service user account, that user’s Type Server
account is also removed. This keeps your Type Server users in sync with your
Directory Service users.
When this option is disabled, then when you delete a user from the Directory Service,
that user’s Type Server account is retained.

4. Click the Client Authentication tab and choose the Authentication Type from the pop-up
menu.

n LDAP Bind: You don't need to enter any additional information.
Directory Service users log in with their Directory Service username and password.

n Single Sign-On with Password: You will need to enter the Service Principal Name and
the password that you set up earlier.
Directory Service users log in with their Directory Service username.

n Single Sign-On with Keytab: You need to enter the Service Principal Name and copy
the keytab file to your Type Server. See Creating a keytab file for Active Directory on
page 68 or Creating a keytab file for Open Directory on page 70.
This option also allows users to log in with just their Directory Service username.
NOTE: For Single Sign-On options, click the Test button to confirm that your
configuration works.

5. Specify a password option.
n Disable UTS passwords for directory users: If you specify this option, a Directory

Service user must log in using their Directory Service username and password; their
Type Server native account password will be rejected. See Passwords for Directory
Service Users on page 73 for more information on accounts and passwords.
If you have Directory Service users that connect to your Type Server from outside
your domain (such as users working from home or while traveling) you should leave
this box unchecked.
Older versions of Universal Type Client do not support Kerberos Single Sign-On. If you
have users with an older Type Client, you should leave this box unchecked.

See Kerberos Single Sign-On on page 66 for information on configuring and using Kerberos
Single Sign-On.

6. Click the Save button to bind your Directory Service to Universal Type Server.
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Mapping Directory Service Groups to
Workgroups
You can map a group from your Directory Service to a workgroup with the same name in your
Universal Type Server.

After you connect your Type Server to your Directory Service (see Connecting to Your Directory
Service on page 60), the Group Mapping panel is displayed.

To map a Directory Service group to a Type Server workgroup:
1. Locate the Directory Service group in the Group Mapping panel.

Use the search field at the bottom of the panel to quickly locate a desired group.
2. Check the box to the left of the group name.
3. Choose a default role for the group from the pop-up list to the right of the group name.
4. Click the save mapping button to map the Directory Service group to a Type Server

workgroup with the same name.

If a workgroup with that name already exists, the users in the LDAP group will be added to it,
otherwise, a new workgroup will be created.

You can map as many groups as you like at any time.

To remove a mapping, uncheck the box next to the group and click the save mapping button.

Advanced LDAP Mapping
You may find that you need finer account control than that provided by mapping Directory Service
groups to Type Server workgroups. Using Advanced LDAP Mapping, you can map multiple groups,
users, and organizational units (OUs) to a single workgroup. You can even exclude specific users
from a workgroup, so that if their Directory Service group membership changes they can still be
automatically excluded from accessing certain workgroups.

To access this feature, choose Window > Directory Service then click the Advanced LDAP Mapping
tab.

Advanced LDAP Mapping can be done in a few simple steps:
1. Select a search base and query in the Service Browser (see Using the Service Browser below).
2. Select resources (users, groups, or OUs) in the Service Browser.
3. Select a workgroup to map the resources to.
4. Create and save the mapping.

You can also use the Advanced LDAP Mapping panel to exclude users from a workgroup (see
Excluding Directory Service Users on page 65) or remove a previously saved mapping (Removing a
Directory Service Mapping on page 65).

Using the Service Browser
The Service Browser pane of the Advanced LDAP Mapping panel allows you to query your Directory
Service to locate users, distribution groups, organizational units (OUs), and security groups.

The directory listings in the Query Results panel are used to create mappings between the Directory
Service and Universal Type Server workgroups.

The Directory Service query uses standard LDAP query syntax. If you are unfamiliar with this query
syntax, we have provided a number of common queries from which you can choose. If you would
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like to know more about LDAP queries please read “The String Representation of LDAP Search
Filters” at http://www.ietf.org/rfc/rfc2254.txt

The Search Base
A query is basically the combination of a search base and query filter. The search base can be used
to restrict your search to just one part of the LDAP directory. This can be especially handy if your
Directory Service is configured to include discrete branches of users and groups by location or
department.

Your company may have already created organizational units (OUs) or containers in your Directory
Service. Organizational units are like folders and can contain any combination of users, groups, and
other OUs. Creating a search base that is limited to an OU is a quick way to narrow your search.

For example, if the default (root) search base for your LDAP tree is DC=acme,DC=com, but you only
want to search for items included in an organizational unit (OU) named NYC, you would enter that
OU as your search base: OU=NYC,DC=acme,DC=com.

The Query Filter
The query filter helps you locate users, groups and OUs within the search base.

The Service Browser contains a number of pre-built query filters for your convenience from a drop-
down menu.

l All Groups: Displays all groups within the search base.
l All: Displays all users, groups, and OUs in the LDAP tree. Use this if you want to navigate to a
specific resource manually.

l Distribution Groups: Displays all distribution groups within the search base.
l Security Groups: Displays all security groups within the search base.
l Search: Use this query filter to locate users by name. This filter includes the options to search
if a name contains, starts with, or equals the entered text.

l Users: Lists all users; excludes all groups.

Mapping Resources to a Workgroup
You can map any combination of users, groups, and organizational units (OUs) in a Directory
Service to Universal Type Server workgroups.

To create a Directory Service mapping:
1. Open your web browser and start the User Management application.
2. Choose Window > Directory Service.
3. Click the Advanced LDAP Mappings tab.
4. Use the Service Browser (see Using the Service Browser on the previous page) to query the

Directory Service.
5. In the Mappings pane, choose a workgroup from the Target Font Workgroup drop-down

menu.
You can also create a workgroup using this menu if you need to.

6. Drag a user, group or OU from the Query Results of the Service Browser into the Mappings
pane, or click the create mapping >> button.

7. Choose a role for mapped users from the drop-down menu in the Role column. This sets
the initial role for all of the users in a workgroup.
You can change a user’s role in a workgroup by editing his or her entry in the workgroup.
See Creating and Editing Users on page 30 for more information.

8. Click the save mapping button.

http://www.ietf.org/rfc/rfc2254.txt
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Excluding Directory Service Users
When mapping users from a Directory Service to a Universal Type Server workgroup, there may be
some users who shouldn’t have access to the workgroup, no matter how their Directory Service
group membership may change.

As an administrator, you can still map the entire Directory Service entry to a Type Server
workgroup, and then exclude the selected users from that workgroup.

There are two ways in which you can exclude users.

To exclude users from the Directory Service window:
1. Map a Directory Service resource to a workgroup (see Mapping Resources to a Workgroup on

the previous page).
2. In the Mappings pane, select the Directory Service mapping.
3. In the Service Browser pane, select the user to exclude from the directory mapping.
4. Click the Exclude user >> button at the bottom of the Service Browser pane.

The user will be excluded from the Directory Service mapping, and is listed below the
directory mapping in the Mappings pane.

To exclude users from the main User Management interface:
1. In the Workgroups pane, select a workgroup.
2. In the Users pane, select a Directory Service user.
3. Click the - button at the bottom of the Users pane. For Directory Service users, this

automatically creates an exclusion in the Directory Service mapping that excludes the user
from the workgroup.

Removing a Directory Service Mapping
Removing a Directory Service mapping entry removes only that mapping from the Universal Type
Server. Universal Type Server is still bound to the Directory Service.

To remove a mapping entry:
1. Open your web browser and start the User Management application.
2. Choose Window > Directory Service.
3. In the Mapping pane on the right, choose the Type Server workgroup from the Target Font

Workgroup drop-down menu that contains the mapping entry to remove.
4. In the Import Source column, select the mapping entry to remove and click the delete

source button.
5. Click the save mapping button to save your changes.

Any users who were added by this directory mapping are automatically converted into regular
Universal Type Server users with the same settings and permissions, yet no longer linked to the
Directory Service. If the user never had a Type Server password, their password will be set to their
username.

Deleting a Directory Service Connection
You may need to delete your Directory Service connection. If you do so, user accounts that were
mapped using the service are automatically converted into native Type Server accounts. If your
Directory Service mapping was using Kerberos Single Sign-On authentication, each converted
account’s password will be set to the account’s username.
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To delete a Directory Service configuration:
1. Open your web browser and start the User Management application.
2. Choose Window > Directory Service.
3. Choose Options > Delete Service.

Kerberos Single Sign-On
Kerberos is a secure protocol for authenticating users. With Kerberos, a user’s password is never
transmitted.

Single Sign-On allows a user to log in once and gain access to multiple unrelated services. A familiar
example is when a user logs in to a network workstation and can access shared network drives,
email, and a corporate intranet without additional login prompts.

Universal Type Server can utilize Kerberos Single Sign-On to make user connections simple and
secure. With Kerberos Single Sign-On in place, users can log in to their workstation and start
interacting with Universal Type Server without any additional steps required.

While the details of the process will vary depending on your Directory Service implementation, the
basic steps to configure Kerberos Single Sign-On with Universal Type Server are as follows:

1. Create a Service Principal for your Type Server in your Directory Service.
2. Optionally export a keytab file from your Directory Service and store it on your Universal

Type Server.
3. Specify your Single Sign-On method of Client Authentication when you connect your Type

Server to your Directory Service.
4. Optionally provide end users with a configuration file that allows Universal Type Client to

identify your Universal Type Server and connect automatically without input from the user.

The keytab option
The keytab file is an encrypted file that is stored on the Universal Type Server. This file, which is
created by your Directory Service, allows Universal Type Server to perform Kerberos authentication
without the need to store a password locally.

The keytab file provides the strongest security available under Kerberos authentication.

The config file option
To enable Universal Type Client users to connect quickly with Universal Type Server, administrators
can create and deploy a configuration file that contains connection information for the Type Client.
When this file is placed on each Universal Type Client computer, the login dialog is pre-filled with
the correct server address and port.

When used in conjunction with Kerberos authentication, this can provide hands-off login to
Universal Type Server.

This can be especially useful on workstations that are shared by multiple users with unique log-ins;
Universal Type Client will connect automatically using the network login credentials for each user.

Configuring Kerberos for Active Directory
Even though Active Directory is Windows-based, both Mac-based and Windows-based Universal
Type Servers can connect to an Active Directory service. Mac and Windows Universal Type Clients
can also utilize Kerberos Single Sign-On under Active Directory.
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Creating the Service Principal Name (SPN)
Because Universal Type Server is a Java enterprise service, Active Directory treats it as a Unix
service, not a Windows service. In order for Single Sign-On clients to connect to a non-Windows
service like Universal Type Server, Active Directory requires a Service Principal Name associated
with a user account representing the service.

At its simplest, a Service Principal Name is of the form <service_type>/<host_address>. For
Universal Type Server, the <service_type>must match the name of the Active Directory user
account. <host_address> can be the IP address or fully-qualified domain address of your Universal
Type Server.

Create a user account:
1. Click Start > Programs > Administrative Tools > Active Directory Users and Computers.

The account name can be anything but must be unique. It will also be used as part of the
Service Principal Name that your Type Server uses to authenticate domain users.

2. Give the account a non-expiring password.

Map the account to the Service Principal Name:
1. Open a command prompt window.
2. Enter the following command. Replace the parameters enclosed in <angle brackets> with

information appropriate to your environment.
ktpass -princ <service_account>/<host_address>@<REALM> -mapUser <service_account> -pass

<service_account_password> -ptype KRB5_NT_PRINCIPAL
n <service_account>: The Active Directory user account you created previously.
n <host_address>: The IP address or fully-qualified domain name of your Universal

Type Server.
n <REALM>: The realm where your Kerberos database is stored, in ALL CAPS.
n <service_account_password>: The password for the Active Directory user account.

The command output will indicate whether the mapping was successful.
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Creating a keytab file for Active Directory
This step is only necessary for configurations using Kerberos Single Sign-On with Keytab
authentication.

Create the keytab file:
1. Open a command prompt window.
2. Enter the following command. Replace the parameters enclosed in <angle brackets> with

information appropriate to your environment.
ktpass -out <keytab_file_path> -princ <service_principal_name>@<REALM> -mapUser

<service_account> -pass <service_account_password> -ptype KRB5_NT_PRINCIPAL
-crypto ALL
n <keytab_file_path>: The complete path where the keytab file will be generated. You

will eventually move the file from this location so it can be anywhere that you have
write access. The keytab file must be named universaltype.keytab.

n <service_principal_name>: This must be the <service_account> followed by a slash /
character, followed by the <host_address> of your Universal Type Server. For
example, MyTypeServer/196.0.10.123

The command output should indicate that the keytab file was successfully created in the
location specified.

Example:

In this example, the service account is MyTypeServer and its password is agent86smart.

ktpass -out C:\temp\universaltype.keytab -princ
MyTypeServer/196.0.10.123@EXAMPLE.COM -mapUser MyTypeServer -pass agent86smart
-pType KRB5_NT_PRINCIPAL -crypto ALL

3. Move the universaltype.keytab file to your Universal Type Server, in one of the following
locations:

n For Windows servers, move the keytab file to
C:\Program Files\Extensis\Universal Type Server\data\sso\universaltype.keytab

n For macOS servers, move the keytab file to
/Applications/Extensis/Universal Type Server/data/sso/universaltype.keytab

Information for the Type Server Connection
When you connect your Universal Type Server to your Active Directory server (see Connecting to
Your Directory Service on page 60), you will need to provide some of the information used in the
previous sections.

l If you are using Single Sign-On with Password, you will need the <service_principal_name>
and the <service_account_password>.

l If you are using Single Sign-On with Keytab, you will just need the <service_principal_
name>.



- 69 -

Active Directory and failover servers
If your Universal Type Server installation includes a failover configuration, there are some specific
issues to consider when using an Active Directory service.

l You will need to create two service accounts, one for each Type Server. The names of these
accounts cannot be the same.
This means that the Service Principal Name for each server will have different service types as
well as different host addresses.
Examples: uts_primary/198.0.2.10@LDAP.EXAMPLE.COM and
uts_secondary/198.0.2.11@LDAP.EXAMPLE.COM.

l Since the service account password is stored in the shared Type Server database, the service
accounts for the Primary and Secondary servers, while having unique account names, must
use the same password if your connection does not use a keytab file.

Configuring Kerberos for Open Directory
Even though Open Directory is Macintosh-based, Universal Type Server running on either macOS or
Windows can connect to an Open Directory service. Both Mac and Windows Universal Type Clients
can utilize Kerberos Single Sign-On under Open Directory.

Registering the Service Principal
The Service Principal is created from the Service Principal Name (SPN) and your Open Directory
realm. The realm must always be specified in uppercase.

At its simplest, a Service Principal Name is of the form <service_type>/<host_address>. For
Universal Type Server, the <service_type> is always universaltype. <host_address> can be the IP
address or fully-qualified domain address of your Universal Type Server.

The form for the Service Principal is <service_type>/<host_address>@REALM; for example:
universaltype/198.0.2.10@LDAP.EXAMPLE.COM.

Create the Service Principal:
1. Log in to your Open Directory server with a system administrator account.
2. Start the Terminal application, type sudo kadmin --local, and press ENTER.

When prompted, enter the system administrator password. This starts the Kerberos
administration utility.

3. At the kadmin> prompt, type add -p <service_principal_password> <service_principal>,
where <service_principal> is as described above, and <service_principal_password> is
the password that the service will use to connect to Open Directory.
The command output will indicate if the Service Principal was added successfully.

4. Type exit to exit kadmin, then quit the Terminal application.
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Creating a keytab file for Open Directory
This step is only necessary for configurations using Kerberos Single Sign-On with Keytab
authentication.

Create the keytab file:
1. Start the Terminal application, then type sudo kadmin --local and press ENTER.

When prompted, enter the system administrator password.
2. At the kadmin> prompt, enter the following command:

ext_keytab -k <keytab_file_path> <service_principal>
n <keytab_file_path>: The complete path where the keytab file will be generated. You

will eventually move the file from this location so it can be anywhere that you have
write access. The keytab file must be named universaltype.keytab.

n <service_principal>: The service principal that you registered in the previous
section.

3. Type exit to exit the kadmin utility.
4. Enter the following command to modify the permissions on the keytab file.

sudo chmod a+r <keytab_file_path>
When you are prompted for a password, enter the computer administrator’s password.

5. Move the universaltype.keytab file to your Universal Type Server, in one of the following
locations:

n For Windows servers, move the keytab file to
C:\Program Files\Extensis\Universal Type Server\data\sso\universaltype.keytab

n For macOS servers, move the keytab file to
/Applications/Extensis/Universal Type Server/data/sso/universaltype.keytab

Information for the Type Server Connection
When you connect your Universal Type Server to your Open Directory server (see Connecting to
Your Directory Service on page 60), you will need to provide some of the information used in the
previous sections.

l If you are using Single Sign-On with Password, you will need the <service_principal_name>
and the <service_account_password>.

l If you are using Single Sign-On with Keytab, you will just need the <service_principal_
name>.
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Open Directory and failover servers
If your Universal Type Server installation includes Primary and Secondary Type Servers in a failover
configuration, then you will need to make these changes to your Open Directory configuration:

l You will need to create two Service Principals, one for each Universal Type Server.
Under Open Directory, these two Service Principals can use the same service type, but each
must include the address of a unique server.
Examples: universaltype/198.0.2.10@LDAP.EXAMPLE.COM and
universaltype/198.0.2.11@LDAP.EXAMPLE.COM.

l You can create separate keytab files for each server, or you can create one keytab file that can
be copied to both servers.
To create a separate keytab file for each server, issue the kadmin command twice, using the
two Service Prinicpals. Be sure to save the two files to different locations or to move the first
file before creating the second.
To create a single keytab file for both servers, append the second Service Principal to the ext_
keytab command, as in:

kadmin> ext_keytab -k Server\ HD/universaltype.keytab
universaltype/198.0.2.10@LDAP.EXAMPLE.COM
universaltype/198.0.2.11@LDAP.EXAMPLE.COM

This will create the keytab file at the root of the volume Server HD.

Configuring Clients
You can add a configuration file to systems with Universal Type Client or Core Client installed. This
file contains the network address of your Universal Type Server. By installing this file, users do not
need to enter the server connection information when they start Universal Type Client or Core
Client. If you also have Kerberos Single Sign-On configured, users will not be presented with a login
dialog; they will be automatically connected using the credentials they used to log on to their
workstation.

It is also important to know the differences between Directory Service and native Universal Type
Server accounts, and when a user might need to use one instead of the other.

The Client Configuration file
To enable Universal Type Client and Core Client users to connect quickly with Universal Type
Server, administrators can create and deploy a configuration file that contains Type Server
connection information. When this file is placed on each Universal Type Client or Core Client
computer, the login dialog is pre-filled with the correct server address and port. When used in
conjunction with Kerberos authentication, this can provide a seamless login (Single Sign-On) to
Universal Type Server.

The configuration file follows the basic format of parameter=value. The following parameters can
be set:
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PARAMETER DESCRIPTION

server.address The Universal Type Server address. This can either be a DNS name or an IP
address. If using this parameter, a server.port parameter must also be
specified.

server.port The port number of Universal Type Server. If using this parameter, a
server.address parameter must also be specified.

server.bonjour The Bonjour name of the server, if one exists. If this parameter is declared, it
takes precedence over any server.address and server.port parameters.

For example, if your Universal Type Server is at the IP address 10.1.2.34 using the default port, your
configuration file would contain the following parameters:

server.address=10.1.2.34
server.port=8080

If you choose a Bonjour name for your server instead, the file only needs to contain a single
parameter. For example, if you gave your Type Server the Bonjour name “FontServer” the
configuration file would contain the following parameter:

server.bonjour=FontServer

The configuration file must be saved in UTF-8 format.

For Universal Type Client:

The configuration file must be named com.extensis.UniversalTypeClient.conf.

Place it in the following location on the computers where you have installed Universal Type Client:
l 64-bit Windows: C:\Program Files (x86)\Extensis\Universal Type Client\
l 32-bit Windows: C:\Program Files\Extensis\Universal Type Client\
l Macintosh: /Library/Preferences/

For Core Client:

The configuration file must be named com.extensis.TypeServerCoreClient.conf.

Place it in the following location on the computers where you have installed the Core Client:
l 64-bit Windows: C:\Program Files (x86)\Extensis\Type Server Core Client\
l 32-bit Windows: C:\Program Files\Extensis\Type Server Core Client\
l Macintosh: /Library/Preferences/

Saving a file in UTF-8 format
The UTF-8 file format is a common standard; however, you may experience difficulty with your
config file depending on the program you use to create it.

Windows
You can use either Notepad or WordPad to create your config file.

In Notepad, save the file using the ANSI encoding (do not use UTF-8 from Notepad; this adds a byte
border marker, or BOM, which is not recognized by Universal Type Client.)

In WordPad, save the file as an MS-DOS format text document. (WordPad’s Unicode is UTF-16 Little
Endian fomat, which is not recognized by Universal Type Client.)

To create your configuration file using an alternative editor to either Notepad or WordPad, we
suggest using the excellent and free text editor, Notepad++, available for download from
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http://notepad-plus-plus.org/. Before saving, be sure to select Encoding > Encode in UTF-8 without
BOM.

Macintosh
You can use TextEdit to save your config file in the proper format.

First, make sure the file is formatted as plain text. Choose Format > Make Plain Text. (If the menu
reads Make Rich Text, then the file is already in plain text format.)

In the Save As dialog, choose Plain Text Encoding > Unicode (UTF-8). (If this option is not
available, choose Plain Text Encoding > Customize Encodings List , check the box for Unicode 
(UTF-8) near the top of the Custom Encoding List, then choose the correct encoding from the pop-
up menu.)

Finally, click Save.

A worthwhile free text editor for Macintosh, TextWrangler, is available from Bare Bones Software at
http://www.barebones.com/products/textwrangler/. Set the encoding to Unicode (UTF-8) in the
Save As dialog when you save your file.

Passwords for Directory Service Users
The Universal Type Server account
There are two types of Universal Type Server accounts: native accounts, created directly in the User
Management application, and Directory Service accounts, created by mapping a Directory Service
user to your Type Server.

Native account
When you create a user in the User Management application, you give the user a username and a
password. They use these credentials to connect to your Type Server using the Universal Type
Client.

Directory Service account
The advantage of a Directory Service account is that the user can connect to your Type Server using
the same credentials that they use for other network operations. If they change their network login
password, it will automatically work with Universal Type Client.

When you map a Directory Service user to Universal Type Server, a Type Server account is
automatically created. The Type Server username is the same as the Directory Service username,
and the Type Server account’s native password is set to be the same as the username. (The user’s
Directory Service password is not changed.)

l A Type Server user can log in using either set of credentials: his Directory Service username
and password, or his Type Server username and password. (The Type Server username is the
same as the Directory Service username.)

l If you map a Directory Service user to your Type Server, and a native account with that
username already exists, the account is changed to a Directory Service account and the
original password is retained.

l If you checked the option to Disable UTS passwords for directory users when you connected
your Type Server to your Directory Service, then Directory Service users must use their
Directory Service credentials with Universal Type Server.

Changing the native account password
The administrator can allow individual users to change their native account password. Do this in
Universal Type Client by choosing Server > Change Password.

http://notepad-plus-plus.org/
http://www.barebones.com/products/textwrangler/


- 74 -

Users with a Directory Service account should change their native account password as soon as
possible.

Using a Directory Service without Single Sign-On
When you connect your Type Server to a Directory Service without using Kerberos Single Sign-On,
there are two ways that a user can log in: using their Directory Service credentials or their native
Type Server credentials. (Native Type Server login is not allowed if you checked the box Disable
UTS passwords for directory users when you connected your Type Server to your Directory
Service.)

In either case, the user must always enter both a username and password.

Using a Directory Service with Single Sign-On
When Type Server is configured with Kerberos Single Sign-On authentication, there are several
options for user log-in.

l Users can still log in using their Universal Type Server native credentials (unless this option
was disabled), or by typing in their Directory Service username and password.

l With Kerberos Single Sign-On enabled, Directory Service users can log in to your Type Server
using only their username. Authentication is provided automatically in the background by
Kerberos.

l With a configuration file installed and Single Sign-On enabled, the user is automatically
logged in to your Universal Type Server when they start the Universal Type Client. For details,
see The Client Configuration file on page 71.
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Contacting Extensis
Extensis
1800 SW First Avenue, Suite 500
Portland, OR 97201
Toll Free: (800) 796-9798
Phone: (503) 274-2020
Fax: (503) 274-0530
Web: http://www.extensis.com

Extensis Europe
Suite 18, Newton House
Kings Park Road, Moulton Park
Northampton NN3 6LG, United Kingdom
Phone: +44 (0)1604 654 270
Fax: +44 (0)1604 654 268
Email: info@extensis.co.uk

Customer Service
Phone: (800) 796-9798
Email: info@extensis.com
Web: http://www.extensis.com/
customerservice/

Celartem, Inc.
Phone: +81 3 5574 7236
Email: sales_ap@celartem.com
Web: http://www.celartem.com/en/

Corporate Buying
Phone: (503) 274-4492
Email: NA_sales@extensis.com (North America)
Web: http://www.extensis.com/store/corporate-buying/ (all regions)

http://www.extensis.com/
mailto:info@extensis.co.uk
mailto:info@extensis.com
http://www.extensis.com/customerservice/
mailto:sales_ap@celartem.com
http://www.celartem.com/en/
mailto:NA_sales@extensis.com
http://www.extensis.com/store/corporate-buying/
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Technical Support
Technical support for current products is available by phone or through the Extensis website.

l North America: (800) 796-9798 , select option 3 (8:00 am–4:00 pm Pacific time, Monday–
Friday)

l US: (503) 274-7030
l Europe: +44 (0)1604 654 270
l Web: http://www.extensis.com/support/
l Web Support Form: http://www.extensis.com/support/contact-technical-support/ (requires
login)

When contacting technical support, please have the following information available:
l Your product name and serial numbers;
l Your computer configuration, including operating system, memory, and hard drive
configuration;

l Your question, or a description of the difficulty you’re experiencing: what specifically occurs
and when;

l Any error numbers or messages that display and other information you think may be
relevant;

l Your phone number if you want to have a representative call you.

Answers to frequently asked questions, troubleshooting tips, and more can also be found at the
Extensis support page (http://www.extensis.com/support/).

Extensis also maintains a searchable Knowledge Base
(http://support.extensis.com/Support/58278/58411/en-US/Portal/Index) of in-depth articles on
various technical topics.

Support Policy
Extensis provides full support for the current version of all shipping products. In addition, Extensis
provides limited support for older products up to one year after the product version is no longer
offered for sale. For complete details see the Extensis Product Support Policy
(http://www.extensis.com/support/support-policy-support-extensis/).

For details on currently supported products, see:
l Portfolio Support Guide (http://www.extensis.com/downloads/compatibility-
guides/portfolio-support-guide/)

l Universal Type Server Support Guide (http://www.extensis.com/downloads/compatibility-
guides/universal-type-server-compatibility-guide/)

l Universal Type Client Support Guide (http://www.extensis.com/downloads/compatibility-
guides/universal-type-client-compatibility-guide/)

l Suitcase Fusion Support Guide (http://www.extensis.com/downloads/compatibility-
guides/suitcase-fusion-compatibility-guide/)

Priority Support
If you have a current Annual Service Agreement, you are entitled to priority support.

If you are in North or South America or the Caribbean:
l Email: p1support@extensis.com

If you are in Europe, Africa, the Middle East, India, Australasia, or Asia (except Japan):
l Email: EuroASASupport@extensis.com

http://www.extensis.com/support
http://www.extensis.com/support/contact-technical-support/
http://www.extensis.com/support/
http://www.extensis.com/support/
http://support.extensis.com/Support/58278/58411/en-US/Portal/Index
http://support.extensis.com/Support/58278/58411/en-US/Portal/Index
http://www.extensis.com/support/support-policy-support-extensis/
http://www.extensis.com/support/support-policy-support-extensis/
http://www.extensis.com/downloads/compatibility-guides/portfolio-support-guide/
http://www.extensis.com/downloads/compatibility-guides/portfolio-support-guide/
http://www.extensis.com/downloads/compatibility-guides/portfolio-support-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-server-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-server-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-server-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-client-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-client-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/universal-type-client-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/suitcase-fusion-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/suitcase-fusion-compatibility-guide/
http://www.extensis.com/downloads/compatibility-guides/suitcase-fusion-compatibility-guide/
mailto:p1support@extensis.com
mailto:EuroASASupport@extensis.com
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If you are evaluating a demo copy of the product, please contact your sales representative for
assistance.

Community Support
Extensis maintains community forums on all current and many older products. Often, problems
you may be experiencing have been discovered and answered here. In addition, suggestions you
have may help others resolve issues.

The forums also serve as a way for Extensis to take the pulse of our user community so that we can
identify bugs and other issues and gather suggestions for improving our software.

Please visit the Extensis Forums (http://forums.extensis.com/) and bookmark the page.

http://forums.extensis.com/
http://forums.extensis.com/
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