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Part I: 
Introduction

Let Rego be your guide. 
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• Installing the Interface
• Options and Settings
• Organizer
• Improving Settings

Agenda



• Take 5 Minutes

• Turn to a Person Near You

• Introduce Yourself

• Business Cards

Let Rego be your guide. 
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Introductions



• Full bidirectional connection between CA PPM and MSP

• Stop relying on multiple spreadsheets and applications for data

• Real-time progress updates on MSP project schedule through CA PPM 
Timesheets

• Repeatable processes and centralized data are essential in providing 
accurate reports and actionable metrics

• MSP is an industry standard and widely used by most Project Managers

Let Rego be your guide.
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Why Integrate MSP with CA PPM?



CA PPM Scheduling Options



1. CA PPM – Job or via Gantt on Project – Autoschedule

2. Microsoft Project 2010/2013/2016 (15.1)

3. Open Workbench

• Organizations should select ONE CA PPM scheduling option or at the very 
least, ONE scheduling option per project

• Each option uses a different scheduling algorithm, so if a project schedule is 
opened in one and then another, it will calculate on top of a calculation

Let Rego be your guide.
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CA PPM Scheduling Options



Simple Project Schedules can be updated in CA PPM from the Project > Tasks > 
Gantt view

Autoschedule can be used to updated the project schedule after making changes.  
You can also review your changes before publishing them as the Plan of Record 
(POR)

Autoschedule will:
• Use availability as early in the project as possible
• Set start and finish dates based on task constraints
• Minimize the duration of the critical path, which will determine the earlies finish 

date for the project

Let Rego be your guide.
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CA PPM: Autoschedule



Let Rego be your guide.
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Open Workbench

Open Workbench will update the project schedule based 
on the number of hours each resource will work per 
week to cover the total number of hours on the task

• Algorithm is same as CA PPM

• Fully integrated with CA PPM

• Training may be required



Microsoft Project will update the project schedule based on task duration

• Algorithm is date driven

• Custom fields need to be mapped through the CA PPM User Interface

• MSP license required for each user

• Additional CA PPM / MSP training may be necessary

Let Rego be your guide. 
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Microsoft Project



XML vs. Legacy Driver



• Before CA PPM Release 14.1, there was one MSP Interface driver which 
was OLE-based

• In CA PPM Release 14.1, a new XML-based driver option was introduced to 
improve performance by opening the project schedule in one large block.

• During the installation process, you can choose to install the Legacy “OLE-
based” driver or the New “XML-based” driver

• Both options are available for 32-bit and 64-bit MSP versions.

Let Rego be your guide.
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New XML Driver



• Resource Pools are no longer available for Master Projects; all Resources will be on the Master Resource 
Sheet

• If a Task is created in CA PPM and NOT pinned through a dependency and does NOT start on the Project 
Start Date, MSP will NOT automatically put a Constraint on the Task

• “Number1” and “Number2” fields are no longer mapped to the “Proposed ETC” and “Pending Actuals” 
Fields

• Custom Views are no longer saved in the MPP file and should be saved in the Global.mpt file*

• “Save As” is not available when trying to save a schedule to an EXISTING CA PPM Project

• Elapsed Duration values are now preserved between CA PPM and MSP

Let Rego be your guide.
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New XML Driver vs. Legacy OLE Driver



Installing the MSP Interface



The following third-party software must be installed on the workstation:

• MSP 2010 or MSP 2013 or MSP 2016 (15.1)

• Microsoft .NET Framework 4*
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-
b21f31ab88b7&displaylang=en

• Microsoft Visual Studio 2010 Tools for Office Runtime*
https://www.microsoft.com/en-us/download/details.aspx?id=48217

Java JRE is now included in the CA PPM download and is copied to the MSP Interface Installation directory on the 
workstation’s hard drive, eliminating all of the prior issues related to the JRE version incompatibility

Let Rego be your guide.
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Installation Prerequisites

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=en
https://www.microsoft.com/en-us/download/details.aspx?id=48217


The MSP Interface and Schedule Connect need to be installed on each user’s 
workstation

To determine if you should install Microsoft Project Interface (x86) or 
Microsoft Project Interface (x64), you need to determine if MSP was 
installed as 32-bit or 64-bit, REGARDLESS of the workstation

Let Rego be your guide.
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Which MSP Interface Do You Download

In Office 2013:
1. Open MSP
2. Click File > Account > About > 

Program Name

You should see the version and whether 
you are running 32-bit or 64-bit

In Office 2010:
1. Open MSP
2. Click File > Help

You should see the version and whether 
you are running 32-bit or 64-bit under 
“About Microsoft Project”



Options and Settings



MSP Related Settings In CA PPM: Admin

Let Rego be your guide.
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Default Load Pattern:  This should be set to 
“Uniform” which will be the default and map to the MSP 
“Work Contour” field

Only Export Current Baselines When Opening 
Investments in a Scheduler: This should be checked to 
improve performance*

MSP Assignment Units Mapping with PPM 
Assignment “Max % Load”: This should be checked to 
ensure that the MSP Assignment Unit % does not get 
overwritten by the Resource’s Allocation % on the 
project

CA PPM > Administration > Project Management > Settings:



MSP Related Settings In CA PPM: Project

Let Rego be your guide.
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CA PPM: Project > Properties > Settings:
Scheduler: This must be set to “Microsoft 

Project”

% Complete Calculation Method: This should 
be set to “Manual” if MSP is being used with CA 
PPM or if you are using an external job to 
calculate % Complete. The % Complete field 
appears on the task properties page

Track Mode: This should be set to “Clarity” if CA 
PPM Timesheets are being used to record time



From the MSP Tools menu, select File > Options and refer to the following 
guidelines so MSP and CA PPM will effectively work together

Let Rego be your guide.
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MSP Options

Date Format: The storage of dates and 
timestamps are not consistent between tables in 
CA PPM. Some dates, like Task Start and Finish 
Dates, are recorded with specific timestamps. 
Some dates are recorded as the correct date with 
a timestamp of midnight. Some dates are 
recorded as a “plus 1” date, which means that the 
date stored in the table is one day later with a 
midnight timestamp. To avoid discrepancies, it is 
NOT recommended to use a date format with a 
timestamp

General Tab:



MSP Options

Let Rego be your guide.
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Schedule Tab:

Calendar Options: The “Week starts on” and 

“Fiscal year starts in” calendar fields should match 

your calendar settings in CA PPM. The other MSP 

calendar fields will map through the integration

Scheduling Options for this Project: This should 

be set to “All New Projects” in order for the settings 

to be effective for all new projects and not just the 

one that is open

New Tasks Created: Automatic calculation is the 

preferred setting, but it is not required. If you select 

Manual Calculation, you must manually calculate the 

project before saving it to CA PPM (more info on 

next slide)

Duration is entered in: Duration should be 

tracked in days since this is the lowest level that CA 

PPM is able to track

Split in-progress Tasks: Helps fill in the work 

gaps while using Resource Leveling



Manually Scheduled Tasks

Let Rego be your guide.
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Tasks can be set to “Manually Scheduled” from MSP Options.  This allows you to enter data like you would in Excel 
where tasks are not calculated.

Save to 
CA PPM:

Open 
back up 
in MSP:



MSP Options

Let Rego be your guide.
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Scroll Down on Schedule Tab…..
Calculation Options for this Project: This 

should be set to “All New Projects” in order for 
the settings to be effective for all new projects 
and not just the one that is open.

Updating Task status updates Resource 
Status: If checked, resource actuals, remaining 
work (ETC), and costs are automatically updated 
when percent complete, actual duration, or 
remaining duration is updated. This open should 
ONLY be checked when Actual hours are NOT 
being tracked through CA PPM timesheets. 
(more info on next slides)

Inserted Projects are calculated like 
Summary Tasks: If checked, on a master project, 
project will display a single critical path for the 
Master Project and all of its sub-projects. 

Schedule Alerts Options: This should be set to “All New 
Projects” in order for the settings to be effective for all 
new projects and not just the one that is open.

Calculate Project after each Edit: If “On” is selected, 
the project will automatically calculate after each edit. If 
set to “Off”, task scheduling that occurs as a result of task 
dependencies (predecessors) will be turned off within 
MSP as well as when a project schedule is re-opened from 
CA PPM to MSP (more info on next slides).



Calculation Mode: Off (Manually Scheduled)

Let Rego be your guide.
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If the MSP Calculation Mode is set to “Off” (manual), tasks will NOT be adjusted based on their 
dependencies and the project schedule will stay as it was last saved in CA PPM, if you don’t have any 
Actuals from Timesheets.

Save the Project Schedule to CA PPM:

Open Project Schedule from CA PPM to MSP:



The following are exceptions that apply with Manual Calculation:

• CA PPM Timesheet Actuals can shift Task Dates

• Resource Leveling will still recalculate the project schedule

• Task Constraints may shift Task Dates

Let Rego be your guide.
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Calculation Mode: Off (Manually Scheduled)



Let Rego be your guide.
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Updating Task Status Updates Resource Status
If the CA PPM Track Mode is set to “Clarity” or “CA PPM”, this option should be UNCHECKED in 
MSP > File > Options > Schedule:

The “Updating Task status updates resource status” feature in MSP automatically updates the status of projects when the “% Complete” field is 
updated

If 25% is entered as the “% Complete” on a 40 hour task, MSP will automatically update Actuals with 10 hours and change Remaining Work to 30 
hours

When the project schedule is saved back to CA PPM, those Actuals will get dropped (not saved to CA PPM) without an error message, so the PM 
will be unaware

When the schedule is re-opened from CA PPM to MSP, the following may happen:

• Actual Hours disappeared
• The Remaining Work field shows the reduced value, and therefore Work will be reduced
• Task Dates may be rescheduled



MSP Options

Let Rego be your guide.
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Save Tab:

Save Files in this Format: This option can be changed if you want to save the MPP file in a 
format that’s compatible with an older version of MSP

Default File Location: When saving the MPP file outside of CA PPM, you can change the default 
location where the file gets saved*



MSP Options

Let Rego be your guide.
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Advanced Tab:Allow Cell Drag and Drop: If checked, 
you can move cells by using the “drag and 
drop” functionality, moving the task ids 
with the task. Don’t use the “cut and 
paste” functionality to move tasks 
because MSP will change the task unique 
id which will affect the integration 
mapping

Automatically add new views, tables, 
filters, and groups to the global: (New in 
MSP 2010): If checked, any changes made 
to views, tables, filters and groups will 
automatically be available across your 
projects. In previous MSP versions, 
changes needed to be manually copied to 
the Global.mpt file through the 
Organizer*



MSP Options

Let Rego be your guide.
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Scroll Down on Advanced Tab…

Show “Links between Projects” dialog 
box on open: This feature is incompatible 
with CA PPM external dependencies, and 
is ignored when selected.



Organizer



• When customizing views in MSP by rearranging columns or adding and 
removing fields, the changes are only visible in the project you’re currently 
working on

• You can copy your customization to the Global Template so all the changes 
are available in future projects, as well as projects that were created in the 
past

• To create a global template, open an empty project or the project that has 
the customization directly from MSP, go to File > Info > Organizer

Let Rego be your guide.
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MSP Organizer



• Once the changes are made, you can see the active project’s 
customizations on the right-side panel of the Organizer
• From the “Views” tab, highlight all of the views from the right-side panel and then 

click “<<Copy”
• Do the same for the “Tables” tab

Let Rego be your guide.
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MSP Organizer



• In Microsoft Project 2010, the organizer behaves a bit differently
• By default, new views are automatically saved to the global template file and are made available to 

future projects (as are new tables associated with the view)
• To change this setting, on the File tab, click Options, and then click Advanced. Find the setting in the 

Display section
• Changes to existing view elements are not automatically saved to the Global template with this 

setting. This only applies to NEW views, tables, filters and groups

Let Rego be your guide.
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MSP Organizer



Improving Settings



• How can you decrease the amount of time it takes to export a project 
schedule from CA PPM to MSP?
• Set the CA PPM default loading pattern to “Uniform” – which will map to a “Flat” 

work contour in MSP
• Select Only Export Current Baselines When Opening Investments in a Scheduler in CA 

PPM Administration > Project Management > Settings – Only for Legacy Driver

• Remove unnecessary assignments
• Increase the memory on the workstation to at least 8GB

Let Rego be your guide.
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Improving Performance



Let Rego be your guide. 
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Questions?



Instructions for PMI credits 
• Access your account at pmi.org
• Click on Certifications
• Click on Maintain My Certification
• Click on Visit CCR’s button under the Report PDU’s
• Click on Report PDU’s
• Click on Course or Training
• Class Name = regoUniversity
• Course Number = Session Number
• Date Started = Today’s Date
• Date Completed = Today’s Date
• Hours Completed = 1 PDU per hour of class time
• Training classes = Technical
• Click on I agree and Submit

Let Rego be your guide. 
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Thank You For Attending regoUniversity

Phone
888.813.0444

Email
info@regouniversity.com

Website
www.regouniversity.com

Let us know how we can improve! 
Don’t forget to fill out the class survey.

mailto:info@regoconsulting.com
http://www.regoconsulting.com/

