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Analyzing and Improving an Inbound Call Center 
 
 
 

Objective 
The purpose of this exercise is to increase customer satisfaction of an inbound call center. iGrafx® 
Process™ or iGrafx Process™ for Six Sigma modeling and simulation is used to identify the best 
alternatives for achieving the objective. 

 
Background 
IGX Bank is an imaginary company specializing in residential home loans. Recent interest rate drops 
have increased business dramatically. The added helpline call volume is decreasing customer 
satisfaction due to long wait times to reach company representatives. 

 
Follow this step-by-step process to perform an analysis and simulation project: 

 

 
 

Step 1: Establish goals and constraints 
 

The bank's goal is to reduce abandoned calls below industry norms (5%) at the lowest possible cost. 
The bank wants to use their in-house employees and the existing automated call answering system 
(although this can be modified). Hiring additional workers is an option but outsourcing is not. 

 
Step 2: Gather and summarize data 

 
For this tutorial, data from the process is already gathered and entered into the process model. To 
learn how to create iGrafx diagrams, choose iGrafx Tutorial on the Help menu. 



Inbound Call Center Tutorial 

© iGrafx® Page 2 of 23 

 

 

 
 

Step 3: Build an accurate model 
 

This step is also already completed. An iGrafx file is provided which models the IGX Bank inbound 
call center. 

 
1) iGrafx files intended for simulation consist of process maps, scenarios (data describing the 

simulation environment), and reports (the results of simulation). The following steps give you an 
overview of the file content. 

 
a) Before continuing this improvement project, save "Inbound Call Center.igx" as a different file 

name or in a different directory so you can refer to the original later. 
 

b) Open the file "Inbound Call Center.igx". 
 

c) From the File menu, choose Components to display components in the document. From the 
drop-down list, select All Components as shown below. 

 

 
The Explorer bar showing components 

 
The .igx file contains two processes (AVS System and Call Center) and one scenario 
(Scenario1). In this model, the Call Center process is reviewed first, and the AVS System 
process is used later in a simulation experiment. 

 
d) Double-click Call Center in the Explorer Bar. The inbound call center process appears in the 

main window. 
 

e) Change the Zoom Control drop-down (Standard Toolbar) to All. This brings the complete 
process into view. 

 

 
The Zoom Control 
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The complete process map 

 
2) For the two activities where call center employees talk to customers, review the duration times 

gathered and summarized to build the model. 
 

a) Move your cursor over the note icon  icon) on "6 Call route if Rep available" to view the 
note. You can insert or edit a note by clicking to select a shape and pressing F6 (or, from the 
View menu, choose Note). 

 
b) In the Helpline department, double-click the activity represented by the shape "8 Customer 

and Rep Discuss Issue". In the Properties dialob box, click the Task tab to view the Duration 
values which specifiy a task time with a normal distribution curve between four and eight 
minutes. 

 

 
The duration time to discuss an issue between and customer and representative 
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c) Without closing the Properties dialog, click the activity "16 Loan Officer resolves issue" and 
note its Duration time. Also inspect the Duration time for "10 Rep logs issue resolved". 

 
3) Review how resources are acquired and released by activities that process calls. 

 
a) Double-click the activity "6 Call route if Rep available" and click the Resources tab in the 

Properties dialog box. Note that one worker is acquired and will work on a call through 
multiple activities until released (at activity #10 or #11). Later, this document describes how 
callers hang up when no representatives are available. 

 
 

 
This Resources tab shows workers acquired 

 
b) Click the activity "10 Rep logs issue resolved". This is where the earlier acquired worker 

completes the call. Depending on the routing, the worker might also be released by activity 
"11 Pass call to Loan Office queue". 

 

 
This Resources tab shows workers released 

 
A worker is also acquired by activity "15 Call route if Loan Officer available" and released 
by "16 Loan Officer resolves issue". 
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4) Review how calls are routed at decision points. 
 

a) Double-click each diamond shape (representing decision activities) and choose the Outputs 
tab to view how calls are routed. All decisions are currently routed by percentage based on 
data collected from the process. 

 

 
Routing calls by statistical percentage 

 
b) Click Cancel to close the Properties dialog box 

 
 

5) Review how calls "renege" or hang-up after waiting too long. 
 

There are two places where callers may renege. Both involve three shapes highlighted by a tan 
background rectangle. 

 

 
One of two sections where reneging is modeled 

 
Two connection lines leave activity "4 Call Enters". For each transaction representing a call that 
enters this shape, one transaction exits per output connection line. Both transactions are related 
to the same call. These related transactions are referred to as "family members." 
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a) Double-click the activity "5 Call route if wait too long for Rep." On the Properties dialog 
box, click the Task tab. The Delay Duration defines the amount of time a caller is willing to 
wait for a representative. Instead of defining the time as a constant number (e.g. 5 minutes), 
the time varies for each call. 

 
A function allows you to fluctuate the duration of a time. In this example, 
AssignAbandonRate() varies the duration of time a caller is willing to wait. Functions are 
discussed in more detail later in this tutorial. 

 

 
Using a function to define how long a caller will wait 

 
b) Inspect the Outputs tab of this activity. If the caller waits too long (specified by the Duration 

on the Properties dialog box Task tab), the caller hangs up and the transaction family 
member waiting for a worker at the activity "6 Call route if Rep available" is discarded. 

 

 
Reneging from the wait queue by discarding the related transaction 

 
c) Click the activity "6 Call route if Rep available" and choose the Resources tab. Recall that 

this activity attempts to acquire a worker (e.g. a Helpline Representative). 
 

 
This Resources tab shows workers acquired 
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d) Look at the Outputs tab. If a worker takes the call, the transaction family member at activity "5 
Call route if wait too long for Rep" is discarded (e.g. the caller will no longer consider 
reneging). 

 

 
Stop the ability to renege by discarding the related transaction 

 
6) Review attributes used to collect statistics. 

 
a) Double-click the activity "10 Rep logs issue resolved" and click the Attributes tab. The 

attribute named Resolution with a value set to resolved_helpline is used to count calls that 
have been resolved by Helpline Representatives. Attributes are discussed later in this tutorial. 

 

 
Setting the Resolution attribute 

 
b) Double-click the following activities and review the value given the Resolution attribute at 

these steps. 
 

• "20 Customer leaves message" 
• "16 Loan Officer resolves issue" 
• "19 Auto log that no message was left" 

 
 

c) Click the Cancel button on the Properties dialog box. 
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Step 4: Define the "as is" scenario 
 

Resource allocations, schedules, and transaction generators are some examples of scenario 
characteristics. 

 
1) Review the allocation of resources. 

 
Earlier, we inspected activities that acquire workers to process calls. Here we describe the 
workers available to perform the activities. If more calls enter activities than can be handled by 
the available workers, more callers will hang-up without talking to a representative. 

 

a) On the Model toolbar, click the Resources  tool. Three workers are available for each of 
the two departments in the process. 

 

 
The allocation of resources 

 
b) Double-click the Helpline resource. The Pool Name describes this set of workers in 

simulation reports. The worker calendar and pay rate are also defined here. 
 

 
The Helpline Representatives description 

 
c) Click the Close button on the Edit Cost/Count dialog box. 
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d) Double-click the Lending office resource. They have a higher hourly rate than Helpline 
workers. 

 

 
The Lending Officers description 

 
e) Click the Close button on the Edit Cost/Count dialog box. 

 
f) Click the Cancel button on the Define Resources dialog box. 

 
2) Review the rate of incoming calls. 

 

a) On the Model toolbar, click the Generators  tool. The Call Center As Is generator creates 
one call every one to two minutes. Calls enter the process at the shape with the Start Point 
named Start. 

 

 
Generating a call every one to two minutes 

 
b) Click the Cancel button on the Define Generators dialog box. 

 
c) Double-click the activity "1 Call starts." In the Properties dialog box, click the Inputs tab. 

Because the Start Point named Start is defined here and matches the generator, calls from 
the generator will enter this activity. 

 
Defining a start point 

 
d) Click the Cancel button on the Properties dialog box. 
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3) Review attributes used in the process. 
 

a) On the Model toolbar, click the Attributes  tool. Two attributes are defined for the model. 
The LoanIssue attribute is used during our second "what if" scenario analysis. The Resolution 
attribute is used to report why callers hang up or complete calls. 

 

 
Two attributes are defined 

 
b) Double-click the attribute LoanIssue. Its value can be either Yes or No. 

 

 
The Loanlssue attribute type 

 
c) Click the Cancel button on the Modify Attribute dialog box. 

 
d) View the reasons callers hang up. 

i) In the Define Attributes dialog, double-click Resolution. 
ii) Click the Define Types button. 
iii) Click reason_hang_up under the Existing section of the Define Types dialog. 
iv) Click the Close button on the Define Types dialog box. 
v) Click the Cancel button on the Modify Attribute dialog box. 
vi) Click the Cancel button on the Define Attribute dialog box. 
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4) Review the simulation run parameters. 
 

a) On the Model toolbar, click the Run Setup  tool. Click the Simulation Time tab. The 
simulation will run a one-month experiment using the Call_Center_Schedule. 

 

 
Defining the simulating length 

 
b) Click the Cancel button on the Run Setup dialog box. 

 
5) Review the schedule. 

 
a) On the Model toolbar, click the Schedules  tool. Scroll the existing schedules list to the 

bottom and click Call_Center_Schedule. Then click any of the green boxes under the day of 
the week indictors. The time span for the shift is displayed. Workers and the call generator 
are assigned this custom schedule. 

 

 
The Call-Center-Schedule 

 
b) Click the Cancel button on the Define Schedule dialog box. 
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6) Review the function that models the duration callers are willing to wait. 
 

a) On the Model toolbar, click the Functions  tool. 
 

 
The AssignAbandonRate function 

 
The AssignAbandonRate function appears in the Properties dialog box Task tab. It sets the 
duration of time in seconds for activity "5 Call route if wait too long for Rep". The function 
varies how long a caller will wait before hanging up. Interpret the dialog this way: 

 
For every 100 calls simulated: 

• 1 (0 - 1 interval) caller will wait between 0 and 3 seconds before abandoning the call 
(reneging). 

• 49 (1 - 50 interval) callers will wait between 3 and 20 seconds before abandoning. 
• 25 (50 - 75 interval) callers will wait between 20 and 40 seconds before abandoning. 
• 25 (85 - 100 interval) callers will wait between 40 and 120 seconds before 

abandoning. 
 

b) Click the Cancel button on the Define Functions dialog box. 
 

7) Review the Monitors. 
 

Monitors are data collectors that assist process analysis. They are placed on activities in the 
process diagram where data should be collected. The types of data collected by monitors include 
basic transaction (call) statistics or the value of attributes at certain points. For example, a  
monitor can tabulate the number of calls that reach an activity. After a simulation completes, data 
collected by monitors are available in the Report window. 
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a) On the Model toolbar, click the Monitors tool. Monitors are displayed in the Modeling Bar. 
 

 
Monitors tab of the Modeling Bar 

 
b) For example, the monitor "Renege_at_Helpline" (highlighted above) gathers statistics every 

time a transaction reaches the activity "7 Auto log call abandon." A table in the report 
window uses this monitor to display the number of calls that entered the "7 Auto log call 
abandon" activity. 

 
c) Four monitors are placed on the activity "21 Call ends". These monitors also gather statistics 

when transactions reach the activities they are place on. 
 

These monitors, however, only report transactions that meet a specified condition. For 
example, the Leave_Message_for_Loan_Office monitor only gathers statistics on   
transactions with the Resolution attribute equal to lv_msg. The condition appears in the When 
column in the above figure. 

d) Close the Modeling bar by clicking the Close button  on the upper-right corner of the 
Modeling bar. 

 
 

Step 5: Conduct simulation experiments 
 

Mapping processes is a valuable way to identify areas for process improvement. The greatest value 
of iGrafx, however, is realized by using process models to run "what if" scenarios to validate 
improvement ideas before implementing them. 

 
Before doing "what if" analysis, it's important to simulate the "as is" model to verify that the model 
represents the real-life process. Validate the model by comparing simulation report statistics to real- 
life statistics for cycle-time, abandoned calls, and so on. 

 
1) On the Model toolbar, click the Start/Resume  Tool. One month of real time is simulated in a 

few seconds. When the simulation completes, a report appears. 
 

 
Available Report tabs 

 
The report is divided into Time, Cost, Resource, Queue, and Custom tabs. Each table or graph 
within the report is considered a "Report Element". Report elements appear in a default format 
when a simulation completes. 

 
a) Click the Custom tab to view user-defined elements. From the Report menu, choose Add 

Element to create additional elements on any report page. Click Cancel on the Statistic 
Dialog box. 
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The "Counts" element of the Custom tab summarizes the number of calls taken and how they 
were resolved (or abandoned). 

 

 
 

Note: For all report elements, your results may vary slightly from those shown in this document. 
 

b) All report elements can be customized. Double-click the "Counts" element to review its 
definition. 
• The Statistics tab defines the element to report on Monitors. 
• The Structure tab defines that all monitors are reported. 
• The Filters tab is not active for this particular element. 
• The Format tab sets the display to Tabular or Graph. 

 
c) Click Cancel on the Edit Report Element dialog box. 

 
If this were a real simulation, you would verify the simulation results against "real-life" data at this 
point. If the simulation results are unreasonable (for example, the model cycle time is several 
times greater than known cycle time), you would review the activity and scenario settings in the 
model for accuracy. An additional method for examining models is the Trace command. 

 
2) Run a simulation Trace. 

 
So far we've simulated the Call Center process without any interaction. To help verify and 
analyze the process map during simulation, we can use the Trace view. This provides a visual 
way to check the simulation, and to inspect the process while it is running. As a transaction 
(which is a call in this tutorial example) follows the process flow, shapes change color to signify 
what is happening with each individual call. 

 
a) Before running a Trace, use the Component Explorer to display the Call Center process map 

(if not already visible). Next, on the Model toolbar, click the Trace  Tool. The process map 
background is grayed to indicate being in Trace mode. 

 
b) Click the Start/Resume  icon on the Trace toolbar to start the simulation. 

 

 
The Trace toolbar 
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The number "3" on shape 8 indicates three calls being worked on 

 
A generator sends transactions through the process until the end of the simulation. Activities 
are colored to indicate the status of calls at those activities. 

 
Color Status Meaning for this model 
Green Moving An activity has been completed on a call which now 

  moves to the next activity. 
 Blue Working An activity of some duration is being performed on a 
  call. 

 

 
 

 
 

 
 

c) During the trace simulation, it's possible to step through the simulation one activity at a time 
with these commands: 

 

To pause the simulation, click the Pause icon. 

To step through the simulation, click the Step icon. 
 

The numbers that appear on activity statements during a Trace indicate the number of 
transactions being worked on or waiting at the activity (depending on the color displayed). 

 

d) To stop the simulation, click the Stop  icon. 

Gray Waiting 
schedule 

This should not occur in this model. It is common in 
other models when resources are unavailable (for 
example, for lunch or day end) and overtime is not 
allowed. 

Yellow Waiting for 
resource 

A call is waiting for a worker because all workers are 
busy with other calls. 

Red Blocked In this model, activity #5 and #14 are red when a caller 
is waiting (because the wait time is defined as a 
"Delay" on the Task tab of the Properties dialog). 
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e) View additional transaction information in the Trace view. 
 

I. Start a trace for at least a few seconds and then pause it. If the Transactions window is not 
visible (see below), choose the View > Transactions command. 

 
Current transactions being simulated are listed in the lower section of the iGrafx window. To 
view more information about a call, click the call (transaction) in the list. Any acquired workers 
(obtained at activities #6 and #15), are displayed to the right of the transaction list. 

 

 
A highlighted call that has acquired a worker 

 
Selected transactions are also highlighted (with a fill pattern) in the process map. 

 
II. To close the Transactions window, choose the View > Transactions command. 

 
3) Stopping the simulation trace. 

 
If desired, a simulation can be run to completion in the Trace view. Non-animated simulations, 
however, run much faster. 

 
We will run subsequent simulations without the Trace view. 

a) If the simulation is not already stopped, click the Stop  icon. 

b) To exit the Trace view, on the Model toolbar, click the Trace  tool. 

 
Step 6: Run the first "what if" scenario 

 
1) Because we stopped the trace simulation before completing, we need to run a full simulation 

again (to rebuild the simulation report). 
a) On the Model toolbar, click the Start/Resume  Tool. 

Our goal is to increase customer satisfaction by reducing the number of abandoned calls. Under 
the existing "as is" process, almost 1500 calls per month are abandoned. This level is 
unacceptable. 

 
b) Scroll down the Custom tab of the report to the element shown below. 

 
The Helpline Representatives are highly utilized (over 80% utilization). When considering the 
many times during the day when call volume is low enough to idle some workers, this level of 
resource utilization is quite high and probably the source of our high level of abandoned calls. 
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2) Run an experiment to analyze the impact of increasing the number of Helpline Representatives. 
We believe this will reduce the number of reneged calls. Instead of testing this idea by hiring an 
additional Helpline Representative, we will first analyze the impact this new worker should have 
on the process. 

a) On the Model toolbar, click the Resources  tool. 

b) Double-click the "Helpline" resource. Change the Resource Count from 3 to 4. 
 

c) Click the OK button on the Edit Cost/Count dialog box. 
 

d) Click the OK button on the Define Resources dialog box. 

e) On the Model toolbar, click the Run Setup  tool. In the Run Setup dialog box, click the 
Initialization/Reports tab, and select the Append to Report option. 

 

 
Choosing to append simulation results 

 
By using the Append setting, statistics from the next simulation are affixed to the previous 
simulation results in the report. This provides an excellent way to compare multiple 
experiments quickly and easily. 

 
f) Click the OK button on the Run Setup dialog box. 

 
g) On the Model toolbar, click the Start/Resume  Tool. 

h) Click the Custom tab of the report that appears. Notice that total abandoned calls are 
dramatically reduced: 

 

 
Report elements showing abandoned calls 



© iGrafx® Page 18 of 23 

Inbound Call Center Tutorial 
 

 

 
 

This reduction, however, comes at a price. The report element below also shows that total 
worker costs have increased by over $5,000 - the monthly cost of hiring an additional worker. 

 

 
Report element showing Worker costs 

 
Perhaps there's a more effective way to reduce abandoned calls without raising resource 
costs. 

 
 

Step 7 continued: Run the second "what if" scenario 
 

One IGX Bank team member suggests improving the process by using the "AVS System" option 
available with the automatic call routing software. This option qualifies calls before they are forwarded 
to Helpline Representatives. 

 
We test this idea with our model before considering any change to our existing process. 

 
1) First, return the number of Helpline Representatives from 4 back to 3. 

a) On the Model toolbar, click the Resources  tool. 

b) Double-click the "Helpline" resource. Change the Resource Count from 4 to 3. 
 

c) Click the OK button on the Edit Cost/Count dialog box. 
 

d) Click the OK button on the Define Resources dialog box. 
 

2) Use the Component Explorer to display the Call Center process map. 
 

3) Add a diamond (decision) shape to the process map. 
 

a) In the Explorer bar, double-click "Call Center" to view the Call Center process. 
 

b) Click the diamond shape in the Toolbox toolbar (the frame on the left). 
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c) As shown below, position the cursor at the corner of the connection line between shapes #3 
and #4. 

 

 
 

d) Click the connection line. A new shape is added to the connectivity as shown: 
 

 
 

e) With the new shape highlighted, type "Loan Issue?" Click empty space (to reset the cursor). 
 

f) Double-click the new shape and choose the Task tab. Change the Work drop-down to 
Process. If not set already, set the adjacent drop-down to "AVS System" as shown below. 

 

 
 

The AVS System process map was defined earlier and included in this file. Until referenced 
by an activity or generator, however, the AVS System process is not part of any simulation. 

 
g) Choose the Outputs tab. Change the Statistical drop-down to Expression. Then either: 

 
• Type "LoanIssue" into the adjacent field or 
• Click the  icon in the Expression toolbar at the bottom of the window. 

 

 

Then choose LoanIssue. 
 

• Click the OK button on the Paste Attribute dialog box. 
 

h) The Outputs tab now looks like this: 
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i) Click the OK button on the Properties dialog box. 
 

j) The border of "22 Loan Issue?" is highlighted to indicate a link to a sub-process. To change 
the link indicator style, choose Diagram on the Format menu. 

 
k) Draw a connection line to create the Yes path from "22 Loan Issue?" to "13 Call enters" as 

shown below. To draw the line: 
 

I. Place your cursor inside the right elbow of the "22 Loan Issue?" shape. 
II. Click and hold the left mouse button. 

III. Drag your cursor from the source shape to the top face of the "13 Call enters" shape. 
IV. Release the mouse button. 

 

 
 

4) By routing loan issues directly to Loan Officers, Helpline Representatives should require less time 
with customers because they are not trying to solve problems they are unqualified to handle. 
Therefore it's reasonable to reduce the task time for that activity. 

 
a) Double-click the activity "8 Customer and Rep discuss issue". Change the Duration in the 

Task tab from 4 - 8 minutes to 3 - 6 minutes with a normal distribution. Click OK. 
 

5) It's also reasonable to assume that with better qualified calls, Helpline Representatives will 
resolve a higher percentage of calls. 

 
a) Double-click the activity "9 Issue resolved?". Change the "Yes" percentage in the Outputs 

tab to 90% (wait two seconds and the "No" percentage is changed to 10%). Click OK. 
 

6) Review activities in the AVS System sub process. 
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a) Right-click the activity "22 Loan Issue?" and choose AVS System from the context menu. 
Alternatively, while holding the shift key down, double-click the activity "22 Loan Issue?" 

 
The AVS System sub process is now visible. 

 
b) Double-click the activity "Set attribute to route call to Loan Officer" and click the Attributes 

tab. The LoanIssue attribute is set True to enable routing calls properly by the activity "22 
Loan Issue?" 

 
Setting the Loanlssue attribute 

 
c) Click the Cancel button on the Properties dialog box. 

 
d) Double-click the activity "Have account #" and choose the Outputs tab. The data gathered 

indicates that 50% of callers have an account number. 
 

e) Double-click the activity "If Loan issue press 1" and choose the Outputs tab. Twenty five 
percent of callers with account numbers have loan issues. 

 
f) Click the Cancel button on the Properties dialog box. 

 
g) In the Explorer bar, double-click "Call Center" to view the Call Center process. 

 
7) Simulate and review the report 

a) On the Model toolbar, click the Start/Resume  Tool. 

Note the significant reduction to abandoned calls while total worker cost is returned to nearly its 
original level (it's slightly different due to resources working different amounts of overtime). 

 
Of the two scenarios examined, using the AVS System appears to be the best alternative 
to reach our goal of less than 5% abandoned calls at the least additional cost. 
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Step 8: Additional "what if" experiments 
 

1) What if the rate of incoming calls increases? 
 

From the Model menu, choose Generators. In the Define Generators dialog box, change the rate 
of incoming calls from between 1 and 2 minutes to between 1 and 1.5 minutes. Simulate and 
analyze the results. 

 
2) What if the Helpline Representatives don't resolve calls any more quickly in the improved 

process? 
 

In the activity "8 Customer and Rep discuss issue", change the Duration in the Task tab back 
to "4 to 8" minutes with a normal distribution. Simulate and analyze the results. 

 
3) What if a Helpline Representative takes a leave-of-absence for one month and there is no back- 

up for this person? 
 

From the Model menu, choose Resources. Double-click the Helpline Representative resource 
and change the number of resources from three to two. Simulate and analyze the results. 

 
4) Design your own experiments. Have fun with the model! 
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Step 10: Document and present results 
 

Generally, the last step in a simulation project is to make recommendations on how the actual system 
may be changed to improve performance. The results of simulation may be used to justify the cost  
and benefits of the improvements. 

 
If IGX Bank decides to move forward with changing the process, the process model and simulation 
results represent a high level functional specification for the new process. 

 
iGrafx publishing methods: 

 
• From the File menu, choose Print. 
• From the File menu, choose Publish as. 
• From the Tools menu, choose Publish Web Project. 
• From the Tools menu, choose Export Table. 
• From the Tools menu, choose Export Diagram. 
• With one or more objects selected, from the Edit menu, choose Copy. Paste into another 

program. 
• A separate product, iGrafx Process Central, provides automatic publishing capabilities with its Web 

Central technology. 
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