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Dashboards 
This document describes how to create dashboards for SAP Business One using SAP Crystal 
Dashboard Design 2008, formerly known as Xcelsius Engage 2008. This is document is relevant for 
SAP Business One 8.8, patch level 12 (PL12) and higher. For more information on the components 
and software required to create dashboards, see Software Prerequisites. 
Dashboards are a visualization element of the cockpit that is delivered as part of SAP Business One. 
Dashboards present transactional data from the SAP Business One database in easy-to-understand 
visualizations that use graphical elements such as bar charts or pie charts. 
SAP delivers predefined dashboards for financials, sales, and service. Partners and customers can 
use these dashboards as delivered. In addition, you can change SAP-defined dashboards, use an 
SAP-defined dashboard as a template, or create dashboards from scratch. 

 Recommendation 
Before you change SAP-defined dashboards or begin to design and develop your own 
dashboards, review the following documents and resources: 

• Xcelsius 2008 User Guide 
• Xcelsius 2008 Installation Guide 

These two documents are available at http://help.sap.com

• SAP Business One UI Design Guidelines for Dashboards by following the link 
at 

. Under What’s New, click 
Update: SAP BusinessObjects Solution Portfolio Knowledge Center. At the top of the 
window, from the first dropdown list showing all products as the selection criterion, select 
Xcelsius. 

• Crystal Reports, Dashboard and Presentation Design (Xcelsius) and Interactive 
Analysis forum on SAP Developer Network 
at 

http://service.sap.com/smb/sbo/innovations 

http://forums.sdn.sap.com/category.jspa?categoryID=54
• Xcelsius 2008 video tutorials at 

  
http://www.youtube.com/Xcelsius2008

• Xcelsius 2008 – General Best Practices Guide 
at 

  

Glossary 

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/a084a11c-
6564-2b10-79ac-cc1eb3f017ac 

Term Description 

component Chart, map, art, and other visualization element of 
SAP Crystal Dashboard Design 

dashboard A type of widget that displays data in a cockpit 

dashboard package Zip file that contains one or more folders and an 
info.xml file that provides information about the 
package and dashboards. The info.xml file also 
includes all dashboard queries. 

folder Container in a dashboard package that holds a 
dashboard definition file (Adobe Flash file [SWF]) 
and an HTML file 

query Predefined SQL query against data tables in an 
SAP Business One company database 
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Term Description 

visualization Set of components in SAP Crystal Dashboard 
Design that display data in a dashboard 

widget Reusable element of a graphical user interface that 
displays an information arrangement and provides 
standardized data manipulation 

 
See also: 
For information about cockpits in SAP Business One, see the online help for SAP Business One. 
For information about using dashboards and maintaining dashboards, see Working with Dashboards 
in the Integration Component in the documentation area of SAP Business One Customer Portal 
at http://service.sap.com/smb/sbocustomer/documentation.  

http://service.sap.com/smb/sbocustomer/documentation�
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Getting Ready to Create Dashboards 
SAP Business One 8.8, PL12 and higher include predefined dashboards in the area of finance, sales, 
and services, which partners and customers can modify or use as templates. In addition to these 
dashboards, you can create industry- and company-specific dashboards to meet your needs. 

Software Prerequisites 
To enable the creation of dashboards, the SAP Business One key user or administrator must ensure 
that the following software has been installed with the appropriate configuration and settings. 

What Purpose For More Information 

SAP Business One 8.8 PL 
12 and higher 
 

Provides company database for 
queries; storage of dashboard 
definitions. 
Supports integration component, 
cockpits, and dashboards. 
By default, one company 
database is specified during 
installation. To use dashboards in 
another company, you must 
configure this company in the 
integration component. 

“Add a New Company Database” 
in B1i Service Package Xcelsius. 
To access this document, choose 
Start → All Programs → 
Integration solution for SAP 
Business One → Integration 
framework, and then choose 
Scenarios → Scenario Package 
Control → Report. Within the 
Selection Criteria area, in the 
Report dropdown list, select 
Scenario List, and in the Status 
dropdown list, select All. Choose 
the Report button, and then select 
the Docu button after the sap. 
Xcelsius scenario to view the 
documentation. 

Integration component Provides services to deploy 
dashboard packages, available in 
the SAP Business company 
database. 
Provides services to process 
queries, retrieve data from SAP 
Business One using queries, and 
returning data to map to 
spreadsheet cells. 
Supports the viewing of 
dashboards at runtime. 

For the latest information, see SAP 
Note 1477984. 
Administrator’s Guide for SAP 
Business One 8.8 in the 
documentation area of SAP 
Business One Customer Portal 
at 

B1i Service Package Xcelsius (To 
access this document, see the 
path in the row above.) 

http://service.sap.com/smb/sboc
ustomer/documentation 

 

Cockpit and dashboard 
settings at the company 
level in SAP Business One 

Enable development, testing, and 
use of dashboards. 

Working with Dashboards in the 
Integration Component in the 
documentation area of SAP 
Business One Customer Portal 
at http://service.sap.com/smb/sboc
ustomer/documentation 

https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/smb_searchnotes/display2.htm?note_langu=E&note_numm=1477984�
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What Purpose For More Information 

SAP Crystal Dashboard 
Design 2008, departmental 
edition or personal edition 
(formerly Xcelsius Engage 
2008), including Data 
Manager 

 Note 

Adobe Flash Player with 
Active X is installed when 
you install SAP Crystal 
Dashboard Design. 

 Recommendation 
Because SAP dashboards 
use multiple connections 
(on average 10 live XML 
data connections and 2 
fscommand data 
connections), we 
recommend you install the 
departmental edition. 
The personal edition allows 
only 2 live data connections 
to external sources, which 
makes it more difficult to 
work with SAP dashboards. 
 

Provides functionality to develop 
visualizations (dashboards) using 
charts. 
Enables you to manage and 
configure connectivity options 
with Data Manager 
(see Connectivity Options for 
Dashboards). 
Runs the SWF file format in which 
a visualization is saved. SWF is 
the vector-based graphics format 
designed to run in Adobe Flash 
Player. 
 

Xcelsius 2008 Installation Guide 
at http://help.sap.com. Under 
What’s New, click Update: SAP 
BusinessObjects Solution Portfolio 
Knowledge Center. At the top of 
the window, from the first 
dropdown list showing all products 
as the selection criterion, select 
Xcelsius. 

Microsoft Excel 2003 or 
2007 

Supports spreadsheet that holds 
results of data query. 

Xcelsius 2008 User Guide 
at http://help.sap.com. Under 
What’s New, click Update: SAP 
BusinessObjects Solution Portfolio 
Knowledge Center. At the top of 
the window, from the first 
dropdown list showing all products 
as the selection criterion, select 
Xcelsius. 

Connectivity Options for Dashboards 
Data Manager in SAP Crystal Dashboard Design provides a central location where you can manage 
and configure the following external connectivity options:  

• Flash variables  
• SAP Crystal Reports data consumer  
• XML data connection 
• Web service connection 

http://help.sap.com/�
http://help.sap.com/�


How to Develop Your Own Dashboards for SAP Business One  

© SAP AG 2011 7 

Dashboards in SAP Business One use only XML data connections. An XML data connection connects 
to an external source through HTTP or HTTPS. When added to a dashboard, a connection can send 
live data to an external source to request specific information. 
SAP-defined dashboards use an average of 10 live XML data connections and 2 fscommand data 
connections. 
To access the Data Manager, from the SAP Crystal Dashboard Design main menu choose Data → 
Connections. Alternatively, you can click an XLF file, which opens SAP Crystal Dashboard Design. 
For information about configuring XML data connections, see: 

• Building and Testing the Visualization 
• “To configure XML Data connections” in online help for SAP Crystal Dashboard Design 

See also: 
For additional documentation about operations, choose Start → All Programs → Integration solution 
for SAP Business One → Integration framework, and then choose Help → Ref 04 – Operations. 
For information about dashboard services in the integration component, see B1i Service Package 
Xcelsius. To access this document, choose Start → All Programs → Integration solution for SAP 
Business One → Integration framework, and then choose Scenarios → Scenario Package Control → 
Report. Within the Selection Criteria area, in the Report dropdown list, select Scenario List, and in the 
Status dropdown list, select All. Choose the Report button, and then select the Docu button after the 
sap. Xcelsius scenario to view the documentation. 
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Developing and Publishing Dashboards for 
SAP Business One 
C...  

Prerequisites 
Before you start creating or modifying dashboards for SAP Business One: 

• Review the documents listed in the recommendation note in Dashboards. 
• Ensure that your software landscape meets the requirements in Getting Ready to Create 

Dashboards. 
If you are modifying an SAP-defined dashboard or using an SAP-defined dashboard as a template, 
export the dashboard package from SAP Business One. For information about exporting dashboard 
packages, see Working with Dashboards in the Integration Component in the documentation area of 
SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation. 

 Note 
For SAP-defined dashboards, SAP does not provide the source code (XLF file generated 
by SAP Crystal Dashboard Design) in the dashboard package. The source code file is 
available in the SAP Business One software download area 
at http://service.sap.com/sbo-swcenter. 
In the software download area, from the navigation tree on the left, choose SAP 
Business One Products → Archive for Support Packages and Patches → SAP Business 
One → SAP Business One 8.8 → Comprised Software Component Versions → B1 8.8 
Integration Component → # OS independent. The file, named Sample Code for SAP 
Crystal Dashboard - SAP B1 8.8, contains the sample code of the three SAP-defined 
dashboards. 

Procedures 
To create or modify a dashboard and make it available to users, you need to: 

1. Create or modify queries in SAP Business One. 
2. Build and test the visualization in SAP Crystal Dashboard Design. 
3. Manually create the dashboard package. 
4. Import the dashboard package into your production SAP Business One environment (see 

Working with Dashboards in the Integration Component). 
 

Creating and Modifying Queries 
C...  

Charts in dashboards display transactional data retrieved by queries from an SAP Business One 
company database. To define and update queries in SAP Business One to run against the company 
database, use the same tools that you use when creating queries for SAP Business One reports: 
Query Generator, Query Wizard, and Query Manager. 

 Recommendations 
• Create a separate query category for each dashboard with the following naming 

convention: <PackageID>_<DashboardID>. 
• Use indexes to access the database. 
• Use as few SQL statements as possible. 
• Use one function call with stored procedures instead of multiple single calls. 

SQL query statements are stored in the SAP Business One company database. If the identifier does 
not start with b1i_, the SQL statement is stored in the OUQR table in the SAP Business One 
company database. 

http://service.sap.com/sbo-swcenter�
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See also: 
For information about creating queries, see the online help for SAP Business One. 
For more information about queries in the integration component, see B1i Service Package Xcelsius. 
To access this document, choose Start → All Programs → Integration solution for SAP Business One 
→ Integration framework, and then choose Scenarios → Scenario Package Control → Report. Within 
the Selection Criteria area, in the Report dropdown list, select Scenario List, and in the Status 
dropdown list, select All. Choose the Report button, and then select the Docu button after the sap. 
Xcelsius scenario to view the documentation. 

Building and Testing the Visualization 
Prerequisites 
You have created queries in SAP Business One. 
You have reviewed the relevant documentation for SAP Crystal Dashboard Design. For a list of 
documents, see the recommendation note in Dashboards. 

 Note 
If you want to modify an SAP-defined dashboard or use an SAP-defined dashboard as a 
template, you need the XLF file, which is not provided in the dashboard package. For 
more information, see the note in Developing and Publishing Dashboards for SAP 
Business One. 

 
Procedure 
...  
...  

1. To create a visualization using SAP Crystal Dashboard Design, you have to add spreadsheet 
data to support your visualization. There are three ways to do this: 

 Import a spreadsheet from Microsoft Excel. 
 Copy and paste cells from a Microsoft Excel file or an SAP Crystal Dashboard Design 

embedded spreadsheet. 
 Manually enter information into the embedded spreadsheet. 

You can add, modify, and delete data in the embedded spreadsheet. If you have linked cells to 
components, the components automatically update when you change the data in linked cells. 

2. Select the data sources linked to the components. In this step, you assign one or more cells 
from your embedded spreadsheet to one or more SAP Crystal Dashboard Design components. 

3. Make the data connection to B1i with Data Manager by specifying the runtime URL, which is a 
relative URL. Map the following parameters to B1i: send query category, query name, and query 
parameters. 

 Recommendation 
To use the preview functionality during the design of a dashboard, you have to use the 
absolute URL. To simplify the switch between design time and runtime, specify both the 
absolute URL and the relative URL in two separate cells. 

a. Absolute URL – used for design time: 
<protocol>://<ipaddress>:<port>/B1iXcellerator/exec/ipo/vP.001sap
0004.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT/I
NB_HT_CALL_SYNC_XPT.ipo/proc?bpm.pltype=xml&bpm.encoding=utf-8   

 Example 
http://10.58.0.190:8080/B1iXcellerator/exec/ipo/vP.001sap000
4.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT

http://10.58.0.190:8080/B1iXcellerator/exec/ipo/vP.001sap0004.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT/INB_HT_CALL_SYNC_XPT.ipo/proc?bpm.pltype=xml&bpm.encoding=utf-8�
http://10.58.0.190:8080/B1iXcellerator/exec/ipo/vP.001sap0004.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT/INB_HT_CALL_SYNC_XPT.ipo/proc?bpm.pltype=xml&bpm.encoding=utf-8�
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/INB_HT_CALL_SYNC_XPT.ipo/proc?bpm.pltype=xml&bpm.encoding=u
tf-8 

b. Relative URL – used for runtime: proc  
4. To enable a dashboard to detect the current SAP Business One language and display user 

interface strings in that language, do the following: 
a. Add a GetLanguage data connection: Proc?action=GetLanguage. 
b. Use the Microsoft Excel lookup function to replace UI strings at runtime. 

 
5. To enable a user to access master data or documents in SAP Business One from a dashboard, 

add a link button in a dashboard using an Adobe Flash fscommand. 
fscommand has the following structure: fscommand(“command” , “parameters” ) 
To configure an fscommand connection, do the following: 

a. In the Name field, specify a name for the connection. 
b. In the Command field, specify a command or click the Cell Selector button and choose a 

command in the spreadsheet. 
c. In the Parameter field, enter a parameter value for the command or click the Cell 

Selector button and choose a command in the spreadsheet. 
SAP Crystal Dashboard Design calls a Visual Basic script, which calls a Java script. The Java 
script invokes the SAP Business One link button. For more information about these two scripts, 
see step 3 in Modifying the default.html File. 
For more information about fscommand, see the Adobe Flash support 
at http://www.adobe.com/support/flash/action_scripts/actionscript_dictionary/actionscript_diction
ary372.html. 

http://www.adobe.com/support/flash/action_scripts/actionscript_dictionary/actionscript_dictionary372.html�
http://www.adobe.com/support/flash/action_scripts/actionscript_dictionary/actionscript_dictionary372.html�
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6. To make sure your visualization functions according to your specifications, test your 

visualization as many times as you need.  
How to configur e FS Command, what is the syntax of Parameters?  

a. To preview the visualization in SAP Crystal Dashboard Design, do one of the following: 
 Toggle between the design view and preview by choosing File → Preview or the 

Preview button. 
 View the visualization in your default Web browser by choosing File → Export → 

Preview. 
A dialog box form appears in which you identify the company that you want to connect to 
and against which to run queries. 

b. To identify the company, specify a username and a password for the company. 
The Username must be in the form of <language\company user\company 
database>; for example, en-US\manager\OEC Computers. 

 Note 
The language must be in the format xx-XX. Use one of the following language-country 
pairs: cs-CZ, da-DK, de-DE, el-GR, en-CY, en-GB, en-US, en-SG, es-AR, es-CO, es-ES, 
es-PA, fi-FI, fr-FR, he-IL, hu-HU, it-IT, ja-JP, ko-KR, nl-NL, no-NO, pl-PL, pt-BR, pt-PT, 
ru-RU, sk-SK, sr-YU, sv-SE, zh-CN, zh-TW). 

Result 
SAP Crystal Dashboard Design creates the XLF source file. The XLF file contains the visualization 
information and the associated embedded spreadsheet file. 

 CAUTION 
After testing and before creating a dashboard package, replace the absolute URL with 
the relative URL. 

You can now create the dashboard package. 
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Creating the Dashboard Package 
Once you are satisfied with the results of your visualizations, they are ready to be published. To 
publish dashboards in SAP Business One, you manually create the dashboard package zip file that 
contains the following items: 

• Dashboard folders that contain HTML files and Adobe Flash (SWF) files 
• Info.xml file that contains nodes, descriptors, and attributes for the package, dashboards, 

and queries 
 
 
 
 

Prerequisite 
You have replaced the absolute URL with the relative URL. 
Procedure 

1. To create the SWF and HTML files that are needed for publication, do one of the following: 
 Export the visualization from SAP Crystal Dashboard Design as an HTML file. The 

Adobe Flash (SWF) file is generated automatically. To enable the visualization to run in 
SAP Business One, you have to edit the HTML file in a text editor such as Notepad. For 
more information, see Modifying the default.html File. 

 Export the visualization from SAP Crystal Dashboard Design as Adobe Flash (SWF) and 
then create the HTML file. 

 Recommendation 
Use the first option. 

2. Create or modify the HTML file. 
3. Manually create the folder structure, including the info.xml file. 

For information about the info.xml file, see Example: Dashboard Folder and Dashboard 
Package. 

4. Create the zip file. 
Result 
The dashboard package zip file contains one or more dashboard folders and an info.xml file with 
nodes, descriptors, and attributes for the package, dashboards, and queries. 
The resulting SWF file can be executed locally with the stand-alone Adobe Flash player, opened in a 
browser, used as part of a Web site, or imported into a number of different programs. 
For more thorough user testing, import the dashboard package into a separate test system running 
SAP Business One with the integration component. After testing, export the package from the test to 
the productive SAP Business One company. For more information about importing and exporting 
dashboards, see Working with Dashboards in the Integration Component in the documentation area of 
SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation

Modifying the default.html File 

. 

As described in the Creating the Dashboard Package section, you created the files that are needed for 
publication by exporting the visualization from SAP Crystal Dashboard Design as an HTML file. The 
Adobe Flash (SWF) file is generated automatically.  
The following shows an excerpt of the default.html file.  

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 

codebase="http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash
.cab#version=9,0,0,0"  

WIDTH="620" HEIGHT="460" id="myMovieName"> 

<PARAM NAME="movie" VALUE="default.swf">  
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<PARAM NAME="quality" VALUE="high"> 

<PARAM NAME="bgcolor" VALUE="#FFFFFF"> 

<PARAM NAME="play" VALUE="true"> 

<PARAM NAME="loop" VALUE="true"> 

<PARAM NAME=bgcolor VALUE="#FFFFFF"> 

<EMBED src="default.swf" quality=high bgcolor=#FFFFFF WIDTH="620" 
HEIGHT="460"  

NAME="myMovieName" ALIGN="" TYPE="application/x-shockwave-flash"  

play="true" loop="true"  

PLUGINSPAGE="http://www.adobe.com/shockwave/download/index.cgi?P1_Prod
_Version=ShockwaveFlash"> 

</EMBED> 

</OBJECT> 

To enable the visualization to run in SAP Business One, you have to edit the default.html file in a 
text editor such as Notepad. 
... 

1. For <PARAM NAME="movie", modify VALUE by adding a package name (p), dashboard name 
(d), and Adobe Flash file name (f), as shown in the following example. 
Example: VALUE="proc?p=SAP_DASHBOARD_001&d=DAB003&f=default.swf"> 

2. For <EMBED, modify src by adding the same information as in step 1, as shown in the following 
example. 
Example: <EMBED src="proc?p=SAP_DASHBOARD_001&d=DAB003&f=default.swf"  

3. To support different browsers for the fscommand (see step 5 in Building and Testing the 
Visualization), you create and add two scripts: a Java script and a Visual Basic script. You can 
add the scripts anywhere in the default.html file. 

a. Java Script: Change the command to the name you defined in SAP Crystal Dashboard 
Design. In the following example, b1link_OCRD is the fscommand defined in SAP 
Crystal Dashboard Design; OCRD is the name of the object you want to link with; args is 
the primary key passed from fscommand. 
<SCRIPT LANGUAGE="javascript"> 

function myMovieName_DoFSCommand(command,args)  

{  

 if (command == "b1link_OCRD") 

 {  

  window.external.b1link("OCRD", args);   

 }  

 else if (command == "b1link_OITM") 

 { 

  window.external.b1link("OITM", args); 

 } 

}  

</SCRIPT> 

b. Visual Basic script: 
<SCRIPT LANGUAGE="VBScript">  

Sub myMovieName_FSCommand(ByVal command, ByVal args)  

call myMovieName_DoFSCommand(command, args)  

end sub  

</SCRIPT> 
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Result 
You can now create the dashboard folder and package. 

 Note 
The example below is an excerpt of the default.html file. For both codebase and 
PLUGINSPAGE, http is removed at the beginning of the parameter. This enables the 
dashboard to be deployed in both HTTP and HTTPS environments without modification. 

 
<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 

codebase="//fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#
version=9,0,0,0"  

WIDTH="620" HEIGHT="460" id="myMovieName"> 

<PARAM NAME="movie" 
VALUE="proc?p=SAP_DASHBOARD_001&d=DAB003&f=default.swf">  

<PARAM NAME="quality" VALUE="high"> 

<PARAM NAME="bgcolor" VALUE="#FFFFFF"> 

<PARAM NAME="play" VALUE="true"> 

<PARAM NAME="loop" VALUE="true"> 

<PARAM NAME=bgcolor VALUE="#FFFFFF"> 

<EMBED src=”proc?p=SAP_DASHBOARD_001&d=DAB003&f=default.swf” 
quality=high bgcolor=#FFFFFF WIDTH="620" HEIGHT="460"  

NAME="myMovieName" ALIGN="" TYPE="application/x-shockwave-flash"  

play="true" loop="true"  

PLUGINSPAGE="//www.adobe.com/shockwave/download/index.cgi?P1_Prod_Vers
ion=ShockwaveFlash"> 

</EMBED> 

</OBJECT> 

See also: 
For more information about scripts that make HTML pages interactive, 
see http://www.w3.org/TR/REC-html40/interact/scripts.html#h-18.2.1

Dashboard Folder and Dashboard Package 

. 

A dashboard folder, shown below, contains an HMTL file and a SWF file. A dashboard folder must 
contain a default.html file, which displays the dashboard to users.  
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A dashboard package, shown below, is a zip file that contains one or more dashboard folders and a 
configuration file (the info.xml file).  

 Recommendation 
Export the SAP-defined dashboard package and use the SAP-defined default.html 
and info.xml files as templates for your own dashboards. 

 

 
 
Example: info.xml Structure 

<?xml version="1.0" encoding="utf-8" ?>  

<Package> 

  <Code>SAP_DASHBOARD_001</Code>  

  <Name>SAP Dashboard Package 1</Name>  

  <Description>SAP Dashboard Package 1</Description>  

  <Author>SAP</Author>  

  <Version>1.0</Version>  

<DashboardGroup> 

<Dashboard code="DAB001" name="Service Call" note="The Service Call Status 
Dashboard"> 

 <Query category="SAP_DASHBOARD_001_DAB001_QUERY" name="Queues" />  

 <Query category="SAP_DASHBOARD_001_DAB001_QUERY" 
name="IncomingCallsToday" /> 

  </Dashboard> 

<Dashboard code="DAB002" name="Customer Aging" note="SAP Customer Aging" 
status="I"> 

   <Query category="SAP_DASHBOARD_001_DAB002_QUERY" name="MainCurrency" 
/>  

   <Query category="SAP_DASHBOARD_001_DAB002_QUERY" name="AgeTotalToday" 
/>  

   <Query category="SAP_DASHBOARD_001_DAB002_QUERY" 
name="FutureRemitToday" />  

   <Query category="SAP_DASHBOARD_001_DAB002_QUERY" name="BPRevenueMonth" 
/>  

  </Dashboard> 

</DashboardGroup> 
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<UserQueryGroup> 

  <Query category="SAP_DASHBOARD_001_DAB001_QUERY" name="Queues">SELECT 
QueueID,Descript FROM OQUE WHERE Inactive='N' ORDER BY 
Descript</Query>  

  <Query category="SAP_DASHBOARD_001_DAB001_QUERY" 
name="IncomingCallsToday">SELECT . . . .</Query>  

  <Query category="SAP_DASHBOARD_001_DAB002_QUERY" 
name="MainCurrency">SELECT MainCurncy FROM OADM</Query>  

  <Query category="SAP_DASHBOARD_001_DAB002_QUERY" name="AgeTotalToday"> 
SELECT . . . .</Query>  

</UserQueryGroup> 

</Package> 

 
The info.xml file contains the following information: 

Node Description Validation 

<Package> Top node   

<Code> 

<Name> 

<Description> 

<Author> 

<Version> 

Descriptors of a 
dashboard package 

Code: 
• Cannot start with SAP_. 
• Must be a valid file name. 
• Cannot contain the following 

characters: \/ : * ? \ " < > | . 
• Must be 32 characters or less. 

Name must be 100 characters or less. 
Version must be 13 characters or less. 

<Dashboard Group> Group node  

<Dashboard> Attributes of a dashboard 
code 

name 

note 

status 

code 

• Is the folder name for a dashboard in 
the package. 

• Must be a valid file name. 
• Cannot contain the following 

characters: \/ : * ? \ " < > | . 
• Must be 32 characters or less. 

name must be 100 characters or less. 
status can have one of two values: 

• A for active 
• I for inactive 

 

<UserQueryGroup>  Query strings Every query used by a dashboard must be 
defined in the <UserQueryGroup> node with 
a <Query> subnode. 
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Node Description Validation 

<Query> subnode Query used by the 
dashboard 
Attributes of a query: 
category 

name 

SELECT statement 

The pair of attributes for a query, category 
and name, identify the <Query>. The 
combination of these two attributes must be 
unique for the info.xml. 
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Copyrights, Trademarks, and Disclaimers 
© Copyright 2010 SAP AG. All rights reserved. 
 
The current version of the copyrights, trademarks, and disclaimers 
at http://service.sap.com/smb/sbocustomer/documentation is valid for this document. 
 

http://service.sap.com/smb/sbocustomer/documentation�
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