Rigid Jointed Frame Analysis

Title

Statically determinate structural analysis for a Rigid Jointed Frame

Description
A pitched-roof portal frame is pinned at supports A and H and members CD and DEF are
pinned at the ridge as shown in Figure below. For the loading indicated:
i) Determine the support reactions and
ii) Sketch the axial load, shear force and bending moment diagrams.
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Structural geometry and analysis model



Finite Element Modelling:

e Analysis Type: 2-D static analysis (X-Z plane)
Step 1: Go to File>New Project and then go to File>Save to save the project with any name
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Step 2: Go to Model>Structure Type to set the analysis mode to 2D (X-Z plane)
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Check Structure Data

e Unit System: kN,m
Step 3: Go to Tools>Unit System and change the units to kN and m.
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Geometry generation:

Step 4: Go to Model>Nodes>Create Nodes and type in (0,0,0) in the Coordinates box. Press
Apply. Switch to the Front view by clicking on @ as shown below. Switch on node number
from the option =". Node number 1 will be point A.
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Step 5: Go to Model>Element>Extrude Elements. Select type as Node->Line. Use select
single button £ 1o highlight the node number 1 by clicking on it. Type in (0,0,2.5) in the
Equal Distances dx,dy,dz box and enter number of times=2 and click Apply to generate the
column.
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Step 6: Similar to Step 5, select this time node number 3 and enter dx,dy,dz as (4,0,2) m,
number of times=1 and click Apply to generate the pitched roof.
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Step 7: Select node 4 and extrude using dx,dy,dz= (3,0,-1) and number of times = 2 and
Apply to generate the other half of the pitched roof.
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Step 8: Finally Select node 6 and extrude using dx,dy,dz= (0,0,-3) and number of times=2
and click Apply and Close to generate the other column.
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Material: Modulus of elasticity, E = 2.0 x 108 kN/m?

Step 9: Go to Properties>Material Properties>Add. Select User defined in the Type of

Design and Enter E=2.0 x 108 kN/m2. Enter a name for the material

and click OK and Close.
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Step 10: Go to Properties>Section Properties>Add. Select DB/User tab and select |
section type. Select BS4-93 from section DB and select the section UC 305x305x158 from

the dropdown. Click OK and Close.
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You can see the shape of the section in the model generated. Go to the Works Tree to check

the information for your model.
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Boundary Condition: Pinned Supports at A and H and a pinned connection between
members CD and DEF at point D.

Step 11: Use select single £ to select or highlight nodes 1 and 8 as shown in figure below.
Go to Model>Boundaries>Supports and check on Dx and Dz and Apply.
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This becomes the Pinned support at A and H. DX and DZ provide horizontal and vertical
restraint simultaneously. No rotational restraint has been provided.

Step 12: Select and display element numbers by clicking on <2. Again use Select Single £
this time to highlight or select element 3. Go to Model>Boundaries>Beam End Release.
Select Fixed-Pinned and Apply and Close.
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This applies a moment release or a pinned connection at point D.

Load Case:

Concentrated Loads:

-Vertically downward loads of 15 kN, 25 kN, 35 kN and 20 kN at points C, D, E and F
respectively applied in (-Z) direction.

-Horizontal Loads of 12kN, 8kN, 5kN and 8kN at points B, C, F and G respectively applied
in (+X) direction.

Step 13: Go to Load>Static Load Cases and define static load case ‘P’. Select Load type as
User defined for both of them. Click Close after adding the load case.
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Step 13: Go to Load>Nodal Loads and select load case P. Select the node 2 using £ and
enter FX=12 kN and press Apply. Select Node 3 and enter FX=8 kN and FZ = -15 kN and
Apply. Select Node 4 and enter FZ=-25 kN and Apply. Select Node 5 and enter FZ=-35 kN
and Apply. Select Node 6 and Apply FX=5 kN and FZ= -20 kN. Select node 7 and Apply

FX=8 kN.

Fle Edit View Model Load Analysis Resuts Design Mode Query Tools Window Help

= Gﬂd/Snaol ucslecs | View C... |Amvamn| i Wizard | Node Element| Property | BC/Mass | Stage | Load | Buiding | Mesh | Settlement | Result | Query |

|w¢mk¢anmx@xaﬁw>v |

Tree Menu

Y BREAG ¢ 52 -imGla i Heh

&

Node | Element | Boundary | Mass Load |

B

[~Nodal Loads

Options
@ Add (" Replace (" Delete




You can display the values from the Works Tree by Right clicking on Nodal Loads and click
Display.

Uniform Loads: A uniformly distributed load, UDL of 12 kN/m is applied vertically
downward on the member CD.

Step 14: Go to Loads>Element Beam Loads and select load case P. Select the element
number 3 and enter w=-12 KN/m in the Global Z direction and select Projection as Yes and
press Apply and Close.
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From the display, the UDL looks as if it has been applied over the length of the element 3
but internally it has been applied only on the projected length i.e. X direction length of that
element since the Projection ‘Yes’ was selected while applying the load.

The analysis results for forces and moments in the frame are generated in the finite element
software with respect to each element’s local axis or centroidal axis. So before running the
analysis, we must make sure that the local axes of all elements are aligned properly. Turn on
the isometric view using B 10 display the local axis, go to View>Display and select
Element tab and check on Local axis and click OK. You will find that the members Ato C
or the element numbers 1 and 2 have their local y axis inclined in the opposite direction to

the rest of the model’s y local axis. This may result in opposite signs for bending moments,
My.
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Check off node numbers ﬂand element numbers 01-10. Also display only wireframe by

clicking on b 3 for clarity.
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Now to align the local axis properly, go to Model>Elements>Change Element
Parameters and go to Element Local Axis and select the 2 elements 1 and 2 that need to be
changed and enter the change in beta angle (local axis angle)=180 degrees in the Change
Mode.
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You can now undisplay the local axis by going back to View>Display and checking off

Local Axis in the Element tab and click Apply. Switch to front view by clicking on &
from right.

Analysis:
Step 15: Go to Analysis>Perform Analysis

Results

Reaction Forces:

Step 16: Click on Results>Reactions>Reaction Forces/Moments and select the load case

P. Select FXYZ. Check on Values and click on the box = next to Values to change number
of decimal points to 2 and click OK to see reactions graphically.
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Beam forces/moment diagrams:

Step 17: Click on Results>Forces>Beam Diagrams and select the load Case P. Select Fx
and Click OK to display the axial force diagram in the members. Note that the ‘+’ sign
indicates Tension and ‘-* indicates Compression.
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Step 18: Change to Fz to view the shear force diagram and click Apply.
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Step 19: Change to My to calculate the Bending Moment Diagram.
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Hand Calculations:

12 kN/m — 25kN
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(1) To determine support reactions
Taking vertical force sum:
V=0
V, —15.0 — (12.0 X 4.0) — 25.0 —35.0 —20.0+ V5 =0
V,+Vy =143 Equation (1)
Taking horizontal force sum:
SH=0
+H,+12+80+50+H; =0
H, + Hy = —25.0 Equation (2)

Taking sum of moments about A:
IM, =0
(12 x 2.5) + (8.0 X 5.0) + (12.0 x 4.0)(2.0) + (25.0 x 4.0) + (35.0 x 7.0)
+(20.0 x 10.0) + (5.0 x 5.0) + (8.0 X 2.0) — (Hy x 1.0) — (V4 x 10.0) =0
Hy +10.0Vy = 752 Equation (3)
Taking sum of moments about the Pin D:
My, =0
+(35.0 x 3.0) + (20.0 x 6.0) — (5.0 X 2.0) — (8.0 X 5.0) — (Hy X 8.0) — (V4 X 6.0) =0
8.0H, + 6.0Vy = 175 Equation (4)
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From Equations (1),(2),(3) and (4) we obtain:

H, = +4.30 kN

V, = +64.07 kN
Hy = —37.30 kN
Vy = +78.93 kN

12 kN/m 25 kN
[IZIII]I[IELHIIIH e
15 kN -
5 KN ~
o =
E| v =
H Lo}
= B 8 kN =
- =
£ o
wy £
= | o =
= 4.30 kN o
=
= 7 37.30 KN
64.07 & | 4.0m J 30m | 3.0m S ’
* “78.93 KN

x
10.0m

A

(2) To determine member forces:

Assuming anticlockwise bending moments to be positive:

My,=0 (Pinned Support — No moments)

My = —(4.30 x 2.5) = —10.75 kNm

M; = —(4.30 X 5.0) — (12.0 x 2.5) = —=51.50 kNm

M, =0 (Pin — No Moments)

Mz = —(20.0 x 3.0) + (5.0 X 1.0) + (8.0 x 4.0) — (37.3 x 7.0) + (78.93 x 3.0)
—47.31 kNm
+(8.0 X 3.0) — (37.30 x 6.0) = —199.80 kNm
—(37.30 x 3.0) = —111.90 kNm

EE
I
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12 KNim - 1 D
EARRRF I ETARARRRETTARRETHE i }-""
Fs 194,80 kNm

S5 kNm

F, Fu
Fy
F T
F,+jC Fia™J
i ) L 1950 KNm
£1.5 kNm
BOLM
1200 kN |
Member Forces
130kN 1A IR
64.07 kN - w’ I
A0 RE

The values of the end-forces F1 to F12 can be determined by considering the equilibrium of each
member and joint in turn.
Consider Member ABC:
@V =0)
—F +64.07=0
~ F, = 64.07kN
(ZH=0
+430+120-F, =0
~ F, =16.30 kN
Consider Joint C:
(ZV = 0) There is an applied vertical load at joint C=15kN
—F, + F; =—-15.0

~ Fy = 49.07 kN
(ZH = 0) There is an applied horizontal load at joint C=8 kN
—F, + F, = +8.0
~ F, = 2430 kN
Consider Member CD:
ZV =0)
4+49.07 — (120X 4.0) + Fs =0
~ Fg =—1.07kN
(ZH =0)
-F,+F,=+80
. Fg = 2430 kN

Consider Member FGH:

ZV =0)
+7893 —-F;; =0
~ F;; = 7893 kN
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(ZH =0)
—37.30+80+F,=0
« F;, = 29.30 kN
Consider joint F:
(ZV = 0) There is an applied vertical load at joint F=20 kN
Fy + Fy = —20.0
-~ Fy = 58.93 kN
(ZH = 0) There is an applied horizontal load at joint F=5 kN
+Fy, — Fip = 45.0

. Fiy = 2430 kN
Consider member DF:
VvV =0)
+5893—-35.0+F, =0
~ F, = 23.93kN
(ZH = 0)

—24.30+ F3 = 0.0
. Fg = 2430 kN
The calculated values can be checked by considering the equilibrium at joint D.

12 kN/m — D 2430 kN MIKN D
RRARARI AT TT T T PEPRREO] o —_— J5EN
SL5ENm 155 R0 KN
- kN 2303 kN F

2430 kN ] 19,07

&V =0)
—1.07 — 23.93 = —25.0 kN (equal to the applied vertical load at D)

(ZH =0)
—24.30 + 24.30 = 0.0

The axial force and shear force in member CD can be found from:

Axial load = +/—(Horizontal force X Cosa) +/—(Vertical force X Sina)

Shear force = +

+
—(Horizontal force x Sina) —(Vertical force X Cosa)

The signs are dependent on the directions of the respective forces.

a =tan"1(2.0/4.0) = 26.565°
cosa = 0.894;sina = 0.447
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Member CD:

2430kN C

T L0
-

49,07 KN

2430 kN

Member DEF:

Assume axial compression to be positive.

At joint C

Axial force = +(24.30 X cos a) + (49.07 X sina) = +43.66 kN
Shear force = —(24.30 X sina) + (49.07 X cosa) = +33.01 kN

At joint D
Axial force = +(24.30 X cosa) + (1.07 X sina) = +22.20 kN
Shear force = —(24.30 X sina) + (1.07 X cosa) = —9.91 kN

0 = tan"1(2.0/6.0) = 18.435°
cosd = 0.947;sin8 = 0.316

ALY 2303 LN

HI0KN

Assume axial compression to be positive.

At joint D

Axial force = +(24.30 X cos ) + (23.93 X sinf) = +30.57 kN
Shear force = +(24.30 X sin6) — (23.93 X cos ) = +14.98 kN

At joint F

Axial force = +(24.30 X cos §) + (58.93 x sinf) = +41.63 kN
Shear force = —(24.30 X sin6) + (58.93 X cos 8) = +48.13 kN
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43,66 kN
compression
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Axial Load Diagram

991 kN

14.98 kN >
INOLKN
C 16,30 kN 4813 kN
B |~ 16,30 kN
Shear Foree Diagram
A | 430 kN

10.75 kNm § B

Bending Moment Diagram
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compression

48.13 kN
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2930 kN
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Comparison of Results

Unit : KN,m
Reactions Node Number | Theoretical | Midas Gen
Ha 1 4.32 4.32
Va 1 64.07 64.07
Hu 8 -37.32 -37.32
VH 8 78.93 78.93
Theoretical Force Diagrams Midas Civil Force Diagrams
2220 kN 3057 kN pPode,
Sompeession compression 41,63 kKN o = —
43.66 kKN l) \ e tomprr:swn ! b7y S
comprcsswn(’/ \ \ ;Eff‘ﬁ ::1;7
\‘\\F‘. 2 =
Zg B Axial Load Diagram | = P
SE e £ B s
NN NNHI- =
SN s €| 13 =
Fon S=
991kN_ D ot 0
1498 kN = B
. g .25
33.01 k\( F_ e ]
16.30 kN 48.13 kN H\\\f 12930 kN o o o
48,13 KN = &
B |~ 1630 kN P 8
G| Jaraown | & 2
Shear Foree Diagram 5
Al430kx
Hl |37.30kN 8
o %o
>
V’ . — e 47:_4‘7_47 199,
199.80 kNm “® By, )
Sl.ﬂ)kNmC\ e i " \%
E ——
| — g 5
— P ;:
10.75kNm § B Bending Moment Diagram . %’l ; =
S mswksm | = £
zero | A =
B
H fzero g
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