Statically Indeterminate Frame Analysis

Title

Statically indeterminate structural analysis for a No-Sway Rigid Jointed Frame

Description
A rigid-jointed, two-bay rectangular frame is pinned at supports A, D and E and carries
loading as indicated in Figure below. Given that supports D and E settle by 3 mm and 2
mm respectively and that EI=102.5x10% KNm?;
i) sketch the bending moment diagram and determine the support reactions,
ii) sketch the deflected shape (assuming axially rigid members) and compare with the
shape of the bending moment diagram (the reader should check the answer using a
computer analysis solution).

16 kN 20 kN

v
-

s
= =
-
G
Hp & 6 kN/m -
J20m ) 20m (Mo 40m | 20m
H -E =

Support D settles by 3 mm; Support E settles by 2 mm
EI=102.5 = 10° kNm®

Structural geometry and analysis model



Finite Element Modelling:

e Analysis Type: 2-D static analysis (X-Z plane)
Step 1: Go to File>New Project and then go to File>Save to save the project with any name

Anabss Results Desgn Mode Query Tools Winc
Cer+N - Fivation| i Wizard | Node Elemen
@ho |2 HLEESE
o EBAEIIHKKEIGIBY B
Tred Project Information... _/W

& Open Project...
Close Project

meifed save ctils.
=2 Save As...
Save Current Stage As...
Import 4
Export '
Data Conversion ,
Merge Dat Fie...
Export to STF

Model Data Text Output...

& pnt.. Curisp
[B Print Preview
Print Setup...

)

Graphic Fles

Print Meta Fies...

1 After import

2 C:\Users\owner\Desktop\frame
3 C:\Users\...\flat slab_final

4 C:\Users\...\flat slab_final

Exit

Step 2: Go to Model>Structure Type to set the analysis mode to 2D (X-Z plane)
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Check Structure Data

e Unit System: kN,m
Step 3: Go to Tools>Unit System and change the units to kN and m.
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Geometry generation:

Step 4: Go to Model>Structure Wizard>Beam and type 2.0,2.0,4.0,2.0 in the Distances
box. Press Apply. Switch to the Front view by clicking on @& as shown below. Switch on
node number from the option -". Node number 1 will be point A.
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Step 5: Go to Model>Elements>Extrude Elements. Select type as Node->Line. Use select
single button £ 1o highlight the node number 3 by clicking on it. Type in (0,0,-4) in the
Equal Distances dx,dy,dz box and enter number of times=1 and click Apply to generate the
column BD.
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Step 6: Similar to Step 5, select this time node number 5 and enter dx,dy,dz as (0,0,-6) m,
number of times=1 and click Apply to generate the second column CE.
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Material: El= 102.5*10% kNm?2. Let us consider Modulus of elasticity, E = 102.5 x 103
KN/m?. Then | will be 1.0 m*.

Step 7: Go to Model>Properties>Material>Add. Select User defined in the Type of Design
and Enter E=102.5 x 10% kN/m?2. Enter a name for the material and click OK and Close.



Material Data @

General
Material ID MName Material 1
Elasticity Data
i User Defined
Type of Design
Standard  |Mone -
DB
Concrete
Standard
Type of Material Code
{+ Isotropic " Orthotropic DB

|~ User Defined i3

Modulus of Elasticity : 102,52 +003  khfm~2

Poisson's Ratio o 1 0

Thermal Coefficient : 0.0000e+4000  1/[F]
Weiaht Density : 0 kNfm~3

[ Use Mass Density: 0 kNfm~3fq
Concrete
Modulus of Elasticity : 0.0000e+000  kNjmaz

Poisson's Ratio 2 o
Thermal Coefficient : 0.0000e+000 1]
Weight Density : 0 kNjm~3

= 0 kNfm~3fq
Flasticity Data
Plastic Material Name MNOMNE hd
Thermal Transfer
Spedfic Heat 3 0 Btu/kN={F]
Heat Conduction ~ : 0 Btu/m=hr=[F1
Damping Ratio : 0

i

Section Property: 2 Section properties will be defined. One for members with stiffness=El
with an lyy value of 1.0 m* and a second section property for stiffness= 1.5EI with an lyy
value of 1.5 m*

Step 8: Go to Model>Properties>Section>Add. Select Value tab and select Rectangle
section type. Enter Section Name as El. Enter Area, A=100 m* and lyy=1.0 m*. Click Apply.
Change Section name to 1.5EI and change lyy to 1.5 m*.Click OK and Close.



Section Data @ Section Data @
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Now in the Works Tree you will see that 1 section is seen as black and 1 is seen in Blue
colour. The Section number 1 is by default assigned to all elements. All assigned section
properties are shown in Black whereas the sections that are yet to be assigned are always in
Blue.
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Display the element numbers by clicking on = and select the elements 3,4 and 6 using the
select single option &/,
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Boundary Condition: Pinned Supports at A, D and E.
Step 9: Use select single 2. to select or highlight nodes 1,6 and 7 as shown in figure below.
Go to Model>Boundaries>Supports and check on Dx and Dz and Apply.
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These become the Pinned supports at A,D and E. DX and DZ provide horizontal and
vertical restraint simultaneously. No rotational restraint has been provided.

Load Case:

Concentrated Loads:

-Vertically downward loads of 16 kN and 20 kN on the members AB and BC respectively
applied in (-Z) direction.

-Horizontally applied uniformly distributed load (UDL) of 6kN/m applied on the member
CE in the (-X) direction.

-Settlements of 3mm and 2mm applied at the supports D and E respectively in the (-Z)
direction.

Step 10: Go to Load>Static Load Cases and define static load case ‘P’. Select Load type as
User defined for both of them. Click Close after adding the load case.
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Step 11: Go to Load>Nodal Loads and select load case P. Select the node 2 using £ and
enter FZ=-16 kN and press Apply. Select Node 4 and enter FZ=-20 kN and Apply.
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You can display the values from the Works Tree by Right clicking on Nodal Loads and click
Display.

Uniform Loads: A uniformly distributed load, UDL of 12 kN/m is applied vertically
downward on the member CD.

Step 12: Go to Loads>Element Beam Loads and select load case P. Select the element
number 6 and enter w=-6 kN/m in the Global X direction and press Apply and Close.
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Step 13: Go to Loads>Specified Displacements and select load case P. Select the node 6
and apply settlement, DZ=-3mm (-.003m). Select the node 7 and apply settlement, DZ=
-.002m.
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Analysis:
Step 14: Check off node numbers =" and element numbers 2 for clarity. Check off Hidden

View t Go to Analysis>Perform Analysis
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Results

e Reaction Forces:

Step 15: Click on Results>Reactions>Reaction Forces/Moments and select the load case
P. Select FXYYZ. Check on Values and click on the box = next to Values to change number
of decimal points to 2 and click OK to see reactions graphically.
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Load Cases/ inations.

e Deformations:

Step 16: Go to Results>Deformations>Deformed Shape. Select load case P. Select DXYZ.
Check on Values and Undeformed. Click on the box next to Deform and increase scale
factor to 3 and set to real deformation and click OK.
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Beam forces/moment diagrams:

Step 17: Click on Results>Forces>Beam Diagrams and select the load Case P. Select My
and Click Apply to display the bending moment diagram in the members. Select Min/Max
to display the minimum and maximum bending moment values on the members.
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Hand Calculations:

20kN

16 kN

i Mas g

4.00m

G0 m

.i‘—

6 kNm
support L) settles by 3 mm L
support E settles by 2 mm
EF= 1025 = 10° kNm'

l. 20m | 20m | 4.0m | 2.0m 3
’ ‘ ’ 11

Moment Distribution Method will be used to calculate the bending moments.

Fixed-end Moments:
The final fixed-end moments are due to the combined effects of the applied member

loads and the settlement; consider the member loads,

Member AB:
Fixed end moments

PL 16x4
Map = =5 ="
PL  16x4
Mga = +§ =+ 8

Since support A is pinned, the fixed-end moments are (Mga—0.5Mag) at B and zero at A.
(Mg, —Myp/2) = [+8 4 (0.5 X +8)] = +12kNm

= —8 kNm

= +8 kNm

Member BC:

Pab2
—8.9 kNm

(200><40><20)
Mg

—17.8 kNm

Mcg

(e
| (mers).
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Member CE:

Mic = + 25 = 00X g okn
ECT T Tt T TeTm

Since support E is pinned, the fixed-end moments are (MCE—0.5MEC) at C and zero at E.
(Mg — 0.5Mge) = —18.0 — (0.5 X +18.0) = —27.0 kNm

Consider the settlement of supports D and E: §4g=3.0 mm and 6gc=1.0 mm
A B C

3.0 mm

+

) E
| 2.0m 2.0m 4.0m

A A F 4 a!‘ : i ; LZ.U mm
%

3(EIS 3(102.5 x 103 x 0.003
_3CEIo) 3 )=—57.6kNm

BAT T2 4.02

Note: the relative displacement between B and C i.e. dgc=(3.0-2.0)=1.0 mm

6(E15185c) _ , 6(1.5 X 102.5 x 103 x 0.001)

MBC =+ LZBC 602 = +256 kNm
Final Fixed End Moments:
Member AB: My =0 Mg, = +12.0 — 57.6 = —45.6 kNm
Member BC: My, = —89 + 25.6 = +16.7kNm Mgy = +17.8 4+ 25.6 = +43.4 kNm
Member CE: Mcp = —27.0 kNm Mge =0
Distribution Factors: Joint B
k —(3>< 1)—0191 Dgy =24 =210 _ 5
BAT\4740) " B4 kiotw  0.63
1.51 k = 0.63] kge 0.25
kge = (—) = 0.25/ total DFge =——=—==104
BE™\6.0 BC ™ kot 0.63
k —(le)—owl Dy =22 =20 _ g3
BD = \4"40) " B0 kyotar  0.63
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Distribution Factors: Joint C

k —(1'51 = 0.25] DFy =2 = 02° _ 57
B~ H) e e o4l 7 Keotar 044
kop = (> 1'51>—0191 e DFy = et 019 43
CE_(ZXE e T Kpotar 044
Moment Distribution Table:
Joint A[D B C E
AB | DB BA BD BC CB CE EC
Distribution |, 5|, 0.3 0.3 0.4 0.57 0.43 1.0
Factors
Fixed End -45.60 +16.70 +434 | -27.0
Moments
Balance +8.67 +8.67 +11.56\\/f -9.35 -7.05
Carry-over -4.67 & M +5.78
Balance +1.40 +1.40 +1.87 \3(' -3.29 -2.49
Carry-over -1.65 4 A 093
Balance +0.49 +0.49 +0.66 \\// -0.53 -0.4
Carry-over -0.27 & A +0.33
Balance 0.08 +.08 +0.11 -0.19 -0.14
Total oo -34.96 | +10.65 | +24.31 +37.08 | -37.08 0
Continuity Moments:
IO 3406kNm _ B 24.31 kNm 308 kNm -~
S ¥
K J7.08 kNm
10.65 KNm
=
'_‘r: -
&
e
ZETD
—;

| 20m

20m

|

A

A
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37.08 kNm

il ¢ o PesKNm

——
10.65 kNm —
24.31 KNm é
MIEKNM = = =
=]
B i
Fixed Bending Moment Diagrams o
Free Bending Moments:
Member AB: Member BC:
PL 16x4 Pab 20x4x2
Mfree :T: 2 =16 kNm Mfree =T=T= 26.67 kNm
Member CE:
C
18.0kN 3 é
. === wl? 6% 6.0

M =—= = 27 kN

6.0m 6 kN/m E free 3 ) m

wi? %
18.0kN 4 8
E
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10L65 KNm

37.08 kNm

16,62 kNm o~ 2]
A B I €
T g =
) Fl “24.31 kNm M= - 1662 + 26,67
3496 kNm 'F_ M=+ 10.05 KNm
Maximem bending moment E
Ao+ iS5« 3496+ 160 E
M=+ 3348 kNm i|
Maximum bending moment *
n M=10L64 kNm =¥

Bending Moment Diagram

The maximum value along the length of member CE can be found by identifying the point of

zero shear as follows:

C 2418 kN
% 3708 kKNm

6,0 kN'm

6.0 m

Hy ~— =
I1LE2KN

Shear Force Diagram

4.0 m

ZMC =0
+(6.0 X 6.0 X 3.0) — 37.08 — (Hy X 6) = 0
Hy = +11.82 kN

x =(11.82/6.0) = 1.97 m
Mpaximum = (0.5 X 1.97 X 11.82) = 11.64 kNm

Consider Member BD

ZMB =0
+10.65 — (Hp X 4.0) = 0

#Hp =2.66kN
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24.31 kNm

H0m

6.0 kN/m

J".'.Drn b £
. 3

16 kN

3496 kNm

20m

'

¥y 0m |

For the Complete Frame:
W=0

My =0
+24.31 4 (20.0 x 4.0) — (11.82 X 6.0)

Consider a section B:

+ (6.0 X 6.0%3.0) — (Vg X6.0) =0

~Vg=+23.57kN

Consider Member AB:
s IMg=0

—34.96 — (16.0 x 2.0) + (V;, X 4.0) =0

~V4=+4+16.74 kN

+16.74 — 16.0 — 20.0 + 2357+ V, = 0
2 Vp=—4.31kN

IH=0

H, +11.82+2.66 — (6.0 X 6.0) =0

~Hy =+21.52kN

tension underside !

lensmon

undersiche

"

1ension

D fension

%i-
= m
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Comparison of Results

Reactions Node Number | Theoretical | Midas Gen
Ha 1 +21.52 +21.40
Va 1 +16.74 +16.72
Hp 6 +2.66 +2.73

Vb 6 -4.31 -4.18

He 7 +11.82 +11.87
Ve 7 +23.57 +23.46

Unit : KN,m

Theoretical Diagrams

10.65 kKNm = 16,62 KNm

g Ep T

Fl “2431kNm M= - 1662+ 26,67
q M=+ 1005 kNm

Maximum bending moment

Midas Gen Diagrams

3+ +(05 x 34.96) + 160
M=+ 3348 KNm
Maximum bending moment * ,‘
M= 1164 KNm —EpM
/
Bending Moment Diagram E
Reference

William M.C. McKenzie, “Examples in Structural Analysis”, 1st Edition, Taylor &
Francis 2 Park Square, Milton Park, Abingdon, Oxon OX14 4RN, 2006, 5.2.1 Example 5.3,

Page 383.
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