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• Pseudostatic Analysis 
- Limit Equilibrium Method

+MIDAS Soilworks
+Slide

• Numerically Based Analysis
- Finite Element Method 

+ MIDAS GTS NX 
+ Quake/W 
+ Plaxis

- Finite Difference Method
+ FLAC

Introduction

• Soil liquefaction is a phenomenon in which the strength and stiffness of a saturated 

soil/sand is reduced by earthquake shaking or other rapid loading.

• The pressures generated during large earthquake shaking can cause the liquefied 

sand and excess water to force its way to the ground surface.  

• Soil particles can no longer support all the weight.

• Bridges and large buildings constructed on pile foundations may lose support from the 

adjacent soil and come to rest at a tilt after shaking.

• Sloping ground and ground next to rivers and lakes may slide on a liquefied soil layer 

('lateral spreading’).

2D Seismic Analysis Methods 

http://www.cti.co.jp/en/solution/cae/cae2/
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Pseudostatic Analysis 

• Representation of the complex, transient, dynamics of earthquake shaking by a 

single, constant, unidirectional load is crude. 

• Method has been shown to be unreliable for soils with significant pore pressure 

buildup during cycling (i.e., not valid for liquefaction). 

• Cannot predict deformation. 

• Is only a relative index of slope stability

• Outdated and should only be used for screening purposes. 

• More elaborate techniques are generally warranted and are rather easy to do 

with modern computing software.
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• Based on finite difference or finite element techniques 

• Full dynamics modeled

• Deformation can be estimated using elasto-plastic or other constitutive models  

• Required advanced training and Coding for FLAC models

Advanced Numerical Methods 

FEMFDM
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1. Plane strain elements are used to 
model both the ground conditions 
and Abutment. 

2. Pile elements are modeled as beam 
elements and embedded in 
Embankment, UBC Sand, and Soft 
Rock layers. 

3. Model the load in surrounding 
ground generated by earthquake and 
evaluate dynamic behavior and 
vibration effect of ground and 
abutment. 

4. Check the eigenvalue of ground 
through Eigenvalue analysis, Analyze 
ground dynamic behavior affected by 
earthquake. 

5. Starting Files Required: GTS NX 2D 
liquefaction tutorial_start.gtb

6. Check Liquefied Layers

Objectives

Liquefaction Layer

2D Liquefaction Analysis of Bridge Abutment
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1. Main Menu > 
File>Open… 

2. Double click ‘GTS NX 
2D 
liquefaction_start.gtb

3. Main Menu > 
Analysis > Setting > 
Unit System> 
kN>m>s

4. Click [OK]. 

Procedure 

Step 01 File > Open 
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ID Name Type

Modulus of 
Elasticity(E) 
[kN/m2]

Poisson’s 
Ratio(ν)

Unit 
Weight(Y) 
[kN/m3]

Unit Weight
(Saturated)

[kN/m3]

Cohesion
(c)

[kN/m2]

Friction 
Angle

[Φ] K0

1 Embankment
Mohr

Coulomb
40,000 0.35 18 19 15 25 1

2
Liquefaction 

Layer
UBC 

SAND
60,000 0.02 20 21 - - -

3
Weathered 

Rock
Mohr

Coulomb
100,000 0.3 20 21 35 33 1

4 Soft Rock
Mohr

Coulomb
900,000 0.25 24 25 150 37 1

5 Abutment
Mohr

Coulomb
21,000,000 0.18 25 - - - -

6 Pile Elastic 210,000,000 0.3 78 - - - -

Materials

Step 02: Mesh> Material
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Step 02: Mesh> Material > UBC

In elastic region, nonlinear elastic behavior can be simulated, elastic modulus 

changes according to the effective pressure applied. In plastic region, the behavior 

is defined by three types of yield functions : shear (shear hardening), 

compression (cap hardening), and pressure cut-off. In case of shear hardening, 

soil densification effect can be taken into account by cyclic loading.

* Note - Implicit Method : Explicit methods calculate the state of a system at a later time from the state of the system at the 

current time, while implicit methods find a solution by solving an equation involving both the current state of the system and the 

later one.

The Modified UBCSAND model is developed to simulate liquefaction phenomenon 

using plastic theory based on explicit method for 2D effective stress state. It is 

extended to enable implicit nonlinear analysis for 3D stress state based on the 

constitutive model9, 10

9 Beaty, M. and Byrne, PM., “An effective stress model for predicting liquefaction behaviour of sand,” In Geotechnical earthquake engineering and soil dynamics III, 

Americal Society of Civil Engineers, Geotechnical Special Publication 75(1), 1998, pp. 766-777. 

10 Puebla, H., Byrne, PM., and Phillips, R., “Analysis of CANLEX liquefaction embankments: protype and centrifuge models,” Canadian Geotechnical Journal, 34, 

1997, pp 641-657. 
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Drainage parameters

The pore water pressure in stress analysis can be divided into 
normal state pore water pressure and abnormal state pore water 
pressure - the excess pore water pressure generated between soil 
particles due to external loading under undrained conditions. An 
excess pore water pressure of nearly 0 is called the drainage 
condition. 

Undrained Material Type: Effective stiffness/effective 
strength

This is the most general case where the input stiffness parameters 
and strength parameters are the parameters of the ground skeleton. 
Like drained analysis, GTS NX uses the input stiffness/strength 
parameters for undrained analysis. The disadvantage is that the 
effective strength parameters in the undrained state are hard to 
obtain through experimentation.

Undrained Poisson’s ratio and Skempton (B) coefficient are 
parameters used to calculate the bulk modulus of elasticity for 
water. The undrained Poisson’s ratio has a standard value of 0.495 
with a compressibility of nearly ‘0 (zero)’ and the Skempton
coefficient expresses the saturation, with 1 meaning full saturation.

Step 02: Mesh> Material > UBC
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Step 02: Mesh> Material > UBC
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1. Main Menu Model > 
materials

2. [Create]>Select Isotropic. 
3. ID ‘1’, Name ‘Embankment’, 

Model Type [Mohr 
Coulomb]. 

4. Enter the material 
properties as shown. 

5. Click [OK]. 
6. Click [Apply]. 
7. Similarly create the 

materials for all the soil 
layers – Weathered Rock, 
Liquefaction, Soft Rock, and 
Abutment. 

Procedure 
2

4

1

3

2

Step 02: Mesh> Materials

7
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ID Name Type Subtype

1 Embankment 2D
Plane 
Strain

2
Liquefaction 

Layer
2D

Plane 
Strain

3
Weathered 

Rock
2D

Plane 
Strain

4 Soft Rock 2D
Plane 
Strain

5 Abutment 2D
Plane 
Strain

6 Pile 1D Beam

Properties

Step 03: Mesh> Property
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1. Main Menu Model > 
Property

2. Click on [Add] > Select 
[1D]. 

3. ID ‘7’, Name ‘Pile’. 
4. Element Type > [Beam]. 
5. Material > Steel’
6. Spacing 1.5m 
7. Click-on ‘Sectional Library’ 
8. Select [Pipe], D > Enter 

‘0.5’m, tw > enter ‘0.01’m.
9. Click [OK], Click [OK]. 
10. Repeat for 2D Plane Strain

soil layers

Procedure
2

4

6

Step 03: Mesh> Property

1

8

7

10
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1. Main Menu > Mesh > 
Generate> 2D> Auto Area 

2. Select Object Edges > 
Select the edges as shown. 

3. Mesh Size > Element Size 
‘1’, 

4. Property > Select 
‘Embankment’ Name > 
‘Embankment’. 

5. Click [Advanced Option]. 
6. Type [Triangle], Check-off 

[Register Each Area 
Independently].Click [OK]. 

7. Click [Apply]. 
8. Similarly create the mesh 

sets for Liquefaction, 
Weathered Rock, Soft 
Rock, & Abutment. 

Procedure
2

5

1

3

6

Step 04 Mesh > 2D Mesh 
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1. Main Menu > 
Mesh > Element
>Extract Element

2. From Geometry > 
Select [Edge]. 

3. Select the 20 
edges of the Pile 
as shown. 

4. Property ID > ‘ 7 : 
Pile ’. 

5. Mesh Set > Enter 
name ‘Piles’. 

6. Click [OK] 

Procedure

2

4

1

3

Step 05 Mesh > Element>Extract 
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1. Main Menu Display > 
Element Csys. 

2. As can be seen the Element 
Csys are not aligned in the 
same direction. This will 
result in wrong display of 
results. 

3. Main Menu > Mesh > 
Element > Change Element
Parameter.

4. In Selection filter select 
[1D]>> Change Cys. 

5. “Base Element” select any 
element whose Z axis is 
parallel to Global X-axis 

6. Select the “Pile” mesh set 
from the works tree. 

7. Click [OK]. 

Procedure

4

1 3

5

2

Step 06 Mesh >Element > Parameter 

1
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1. Main Menu >Mesh > 
Element > Other>  
Ground Surface Spring

2. Select the 4 bottom 
ground layers as shown

3. Type the value of ‘’2’’ for 
modulus of elasticity 
coefficient

4. Click [Apply]. 

Procedure

3

5

1

4

2

3

Step 07 Mesh >Element > Create 
Ground Surface Spring  
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The ‘Create Ground Surface Spring’ feature can generate automatically for dynamic analysis.  

The modulus of subgrade reaction is calculated by equations in the ‘Create Ground Surface Spring’ 

feature. 

Modulus of Subgrade Reaction 
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1. Main Menu > 
Analysis > General

2. Name ‘Eigen Value’, 
Analysis Type > 
Select [Eigenvalue]. 

3. Click-on Analysis 
Control [ ]. 

4. Water Level 2m
Number of   
Frequencies ’30’. 

5. Check ON:           
Sturm Sequence 
Check,                 
Max Negative Pore 
Pressure (0), and 
Allow Undrained 
Behavior

Click [OK], Click [OK]. 

Procedure 

2

4

3

Step 08 Analysis > General

5
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1. Main Menu > Analysis > 
Perform… 

2. Check –on ‘EigenValue’. 
3. Click [OK]. 
4. All the messages during the 

analysis will be shown in the 
Output Window. Especially, one 
needs to be very cautious about 
warning messages, because 
these messages indicate that the 
analysis results may not be 
correct. The model is 
automatically saved before the 
analysis. The result is saved as 
binary file(*.TA*) in the same 
folder as the model. The detail 
analysis information is also 
saved in a text file(*.OUT). 

Procedure

2

1

3

Step 9 Analysis > Perform
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1. Main Menu > 
Result > Vibration 
Mode Shape… 

2. Check the periods 
of 1st and 6th 
modes where 
mass participation 
is the largest. 

3. Keep the record of 
periods of 0.407 
sec and 0.188 sec. 

Procedure

2

1

3

Step 10 Results > Vibration Mode
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For the seismic analysis, users need to model infinite ground to eliminate the boundary effect 

caused by reflection wave. Since it is not possible to model infinite ground, users can apply 

Free Field Element at the boundary.

Absorbent Boundary : Enable to eliminate reflection wave at the ground boundary
Width Factor (Penalty Parameter) : In order to minimize the size effect of the model, 
users have to input more than 104, This value will be multiplied by model width (In case 
of 2D, this is plain strain thickness (unit width).

Free Field (Infinite boundary, Absorbent boundary)

Step 11 Mesh > Element > Free Field
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1. Main Menu >Mesh > 
Element > Free Field > 

2. Select the 2 side 
boundary nodes

3. Select Property as 
Absorbent 

4. Width Factor 1+e16
5. Click [Apply]. 

Procedure
1

2

Step 11 Mesh > Element > Free Field

2
2

4

3
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1. Tree Menu > Analysis 
> Boundary 
Conditions >Bottom 
Fix > Constraint > Edit

2. Select the 2 Free Field 
Elements

3. Delete the Ground 
Surface Spring 

Procedure

2

Step 11 Boundary for Free Field

2

2

4

3

1
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1. Return to the Pre Mode 
2. Main Menu > Dynamic 

Analysis> Load > 
Ground Acceleration

3. Activate X direction 
and click icon

4. Add Time Functions 
Copy Paste function 
from Excel

5. Type Hachinohe in 
Name

6. Click OK OK. 

Procedure 2

1

3

4

6

5

7

Step 12 Dynamic Analysis > Ground Acceleration

7
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1. Main Menu > Static / 
Slope Analysis > 
Construction Stage > 
Stage Set 

2. Name: Liquefaction
3. Stage Type > Stress –

Nonlinear Time History 
4. Click > Add 
5. Select ‘’Liquefaction 

Set’’ from Table
6. Click > Define CS

Procedure 2

3

5

2

Step 13 Construction Stage

1

4

6



GTS NX

27

1. Stage name: Initial
2. Stage Type: Stress
3. Drag and Drop all data 

sets except Ground 
Surface Springs from Set 
Data to Activated Data

4. Set Water Level to 2m
5. Clear Displacement
6. Save > New

Procedure

2

3

4

5

1

Step 13 Construction Stage

6

6
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1. Stage name: Time History 
2. Stage Type: Time History
3. Drag and Drop Dynamic Load 

‘’Artificial’’ to Activated Data
4. Time Step > Define Time 

Step > Time Duration: 15s > 
Time Increment > 0.062 
>Add

5. Analysis Control > General > 
Activate Undrained Behavior

6. Analysis Control > General > 
Dynamic > Damping Method

7. Select Calculate from Modal 
Damping, and Select Period 
[sec] 

Enter the periods for 0.407s and 
0.188s from previous eigenvalue 
analysis. 
Enter 0.05 in Damping Ratio for 
both Mode 1 and 2 
Click [OK] > [Save] > [OK] 

Procedure

4

Step 13 Construction Stage

1

2

3

4

4

5

5

6

7
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1. Analysis > Case > General
2. Title: Liquefaction CS 
3. Solution Type: Construction 

Stage > Liquefaction
4. Analysis Control > 
5. General > Set as shown
6. Ok > Ok

Procedure

2

Step 14 Analysis Stage

1

3

4

4

6

7

5
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1. Main Menu > Analysis > 
Perform… 

2. Check –on ‘CS’ only. 
3. Click [OK]. 

All the messages during the analysis will 
be shown in the Output Window. 
Especially, one needs to be very 
cautious about warning messages, 
because these messages indicate that 
the analysis results may not be correct. 
The model is automatically saved 
before the analysis. The result is saved 
as binary file(*.TA*) in the same folder 
as the model. The detail analysis 
information is also saved in a text 
file(*.OUT). 

Procedure
2

Step 15 Analysis > Perform
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1. Post Works Tree > Time 
History> Absolute Max > 
Relative Displacement > 
Total

Procedure

Step 16 Results > Displacements
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1. Post Works Tree > Time 
History > Absolute Max 
> Beam Force Element> 
Axial Force 

Procedure

Step 16 Results > Beam Element Forces
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Post Works Tree > 
Time History > 
Absolute Max > 
Relative Accelerations 
>  Total
Results > Extract > 
Relative Acc TX > 
nodes 19, 129, 849  > 
Table > Graph

Procedure

Step 16 Results > Accelerations
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Step 16 Results > Excessive Pore Stress

Post Works Tree > Time 
History > Absolute Max >   
Plane Strain Stresses > 
Excessive Pore Stress
Results > Extract > Excess 
Pore Stress > Abs Max > 
Table > Graph

Procedure
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Step 16 Results > UBC Sand Results
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End

Questions?

Global Help Desk
http://globalsupport.midasuser.com/helpdesk/


