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1. Show link between midas 

Civil, specialized structural 

software and midas GTS 

NX, specialized 

geotechnical software. 

 

2. Show preparation and 

Export from Civil.  

 

3. Show import and ground 

modeling in GTS NX.  

 

4. Run a consolidation 

analysis.  

 

5. Check for settlement of 

bridge foundation.  

 

 

Objectives 

Overview 
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1. In midas Civil: 

 

2. Main Menu > File > 

Open…  

 

3. Double click Arch 

Bridge.mcb 

Step 1.  File > Open  

Procedure 
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Step 5.  Export  

1. Start Menu > Export > MXT 

 

2. Save file  

 

3. Text file opens 

Procedure 

1 

2 

3 
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Step 6.  Import  

1. Open GTS NX 
 

2. Start Menu > Import > 

midas MXT 
 

3. Select mxt file 
 

4. Click Open 

Procedure 

3 
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Step 7.  Deactivate sets 

1. Go to Works Tree Menu > 

Analysis 

 

2. Delete the BC Constraint 

set. Deactivate Boundary 

conditions, Static and 

Dynamic loads 

 

3. Go to Works Tree Menu > 

Model 

 

4. Deactivate the End 

Realease 
 

5. Change units to kN, m , s 

Procedure 

4 

1 

2 

3 
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Step 8.  Move imported mesh set  

 

Structure is imported into  

Defualt Mesh Set, which does  

not permit editing. We must 

move the structure into a new  

mesh set that will allow for 

modifications. 
 

1. Create new mesh set by 

right clicking over Mesh tab 

in Work Tree 
 

2. Change name of new mesh 

in the property window 

Name tab. Click apply. 

 

3. Right click over the building 

mesh set and select Inlcude 

/ Exclude Elements option. 

 

4. Select Default Mesh Set and 

Include all 1452 Elements. 

Click apply 

 

You can now edit the structure 

and delete sections if needed. 

 

Procedure 
1 

2 

3 

4 
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Step 9.  Import CAD  

 

1. Start Menu > Import > 

CAD File 
 

2. Select X_T file 
 

3. Click Open 

 

In this case we are importing 

CAD file of ground geometry  

From Abutment Foundation 

Tutorial. 

However, GTS NX also has  

commands to  create  

geometry directly in  

software similar to other  

CAD software. 

Procedure 

1 

2 
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Step 10.  Move CAD 

1. Main Menu > Geometry > 

Translate 

 

2. Select all the geometries 

 

3. Select 2 Points Vector as 

Direction 

 

4. Select the middle point on 

the base of the abutment 

as the 1st point 

 

5. Select the middle node of 

the right end of the bridge 

as the 2nd point 

 

6. Click the Distance button. 

Program will calculate 

distance automatically.  

 

7. Click Preview, then Apply 

 

This command translates the  

selected geometries and lines 

up the points. 

 

 

Procedure 1 

3 

4 
5 

2 

2 
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Step 11.  Scale CAD 

1. Main Menu > Geometry > 

Scale 

 

2. Select the 6 solid and the 

20 pile geometries 

 

3. Select the center of the 

right end of ten bridge as 

Scale Center 

 

4. Select Non-Uniform under 

type 

 

5. Type in 1 for Factor X 

 

6. Type in 1.5 for Factor Y 

 

7. Select Preview then Apply 

 

8. You can activate the 1D 

strucutral element 

properties for easier 

visualization 

 

This feature allows you easily  

scale your geometries to  

match any structure. 

 

Procedure 

6 

7 

1 
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3 
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3 
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Step 12.  Mirror CAD 

1. Main Menu > Geometry > 

Transform > Mirror 

 

2. Select the 6 solids and 

the 20 lines as target 

object. 

 

3. Select Plane as Mirror 

type 

 

4. Select the YZ-Plane from 

the Tree Menu or the 

Model 

 

5. Activate Copy Object Box 

 

6. Press Preview, then Apply 

 

 

 

 

Procedure 

3 

1 

4 

5 

4 

6 
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Step 13.  Translate CAD 

1. Main Menu > Geometry > 

Transform > Translate 

 

2. Select the 6 solid and 20 

lines as target object. 

 

3. Select 2 Points Vector 

 

4. The mid point on the top 

of the abutment. 

 

5. Select the mid point on 

the left end of the bridge. 

 

6. Press the < arrow to 

calculate the distance 

 

7. Press Preview, then Apply 

 

 

Procedure 

3 

1 

4 

5 
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Step 14.  Fuse solids 

1. Change the view to Front 

 

2. Select Boolean > Solid 

 

3. Select Fuse 

 

4. Select the 2 top ground 

layer geometries 

 

5. Select Merge Faces and 

Delete Tool. 

 

6. Press Apply 

 

7. Repeat for the mid 

ground layers 

 

8. Repeat for bottom ground 

layers 

 

9. Check the duplicate faces 

of the new geometries 

 

The faces shared by the  

geometries should light up  

orange. 

Procedure 
3 

1 

5 

4 

4 
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8 

7 

6 



GTS NX 

14 

Step 15. Mesh > Material >  Import   

1. Main Menu > Mesh > 

Material 

 

2. Select Import from Excel 

 

3. Select Excel File: 

Materials 

 

4. Press Close; 6 new 

materials were imported. 

 

Procedure 

1 2 

3 

4 

2 
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Step 16.  Mesh > Property> 3D 

  

1. Main Menu > Mesh > 

Property 

 

2. Select Create > 3D 

 

3. Name: Abutment 

 

4. Material: Select Abutment 

 

5. Repeat for Embankment, 

Clay and Soft Rock 

 

 

Procedure 

1 2 

3 

4 
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Step 17.  Mesh > Property>1D 

  

1. Main Menu > Mesh > 

Property 

 

2. Select Create > 1D 

 

3. Select Beam 

 

4. Name: Pile 

 

5. Material: PHC Pile 

 

6. Activate Section Box 

 

7. Section > Pipe : 

 

8. D: 0.6m 

 Tw: 0.012m 

 

Program will automatically fill  

in the section properties after  

giving dimensions. 

 

9. Press OK twice to close 

 

  

 

 

 

 

Procedure 
1 

2 

3 

4 

6 

5 
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Step 18.  Mesh > Property  

1. Main Menu > Mesh > 

Property 

 

2. Select Create > 1D 

 

3. Select Pile 

 

4. Insert information shown 

 

5. Repeat for creating 

material under 2D for 

Gauging Shell  

 

6. Repeat for creating 

material under OTHER 

 

7. Select Pile Tip 

 

8. Type in infomration 

shown: 

 

Bearing capacity: 400kN 

Spring Stiffness: 16000kN/m 

 

9. Press OK 

 

 

  

 

Procedure 
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Step 19.  Mesh 

1. Mesh>Generate>3D 

 

2. Select the right abutment 

only 

 

3. Type in 0.5 in Size 

 

4. Select Abutment from 

Property 

 

5. Press the >> button to 

open advanced mesh 

options 

 

6. Set the tolerance for 

Merge Nodes at 0.1 

 

7. Press Preview and verify 

that the nodes of the 

abutment match up with 

the 3 points of the bridge. 

 

8. Click apply 

 

9. Repeat for left abutment 

 

Procedure 
1 
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Step 20.  Mesh 

1. Mesh>Generate>3D 

 

2. Select the right and left 

abutment bases 

 

3. Type in 1 in Size 

 

4. Use Default Tetra Mesher 

 

5. Select Abutment in 

properties 

 

6. Type Abutment in Mesh 

Set name then Click 

Apply 

 

7. Select the left and right 

embankments 

 

8. Type 2 for size 

 

9. Select Embankement in 

property 

 

10. Type Embankment in 

Mest set then Click Apply 

Procedure 
1 
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Step 21.  Mesh 

1. Mesh>Generate>3D 

 

2. Select the top ground 

layer 

 

3. Type in 3 in Size 

 

4. Use Default Tetra Mesher 

 

5. Select Weathering soil in 

properties 

 

6. Click Apply 

 

7. Repeat for Clay middle 

layer and Soft Rock 

bottom gound layer 

Procedure 
1 

4 

5 

2 

3 

6 
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Step 22.  Mesh 

1. Mesh>Generate>1D 

 

2. Select the 40 lines 

 

3. Type in 10 in Division 

 

4. Select Pile from 

Properties 

 

5. Type Piles in Mesh Set 

 

6. Click Apply 

 

Procedure 
1 

4 

5 
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Step 23. Pile Interface and Tips 

1. Mesh>Element>Pile 

/PileTip 

 

2. Select the 400 elements 

of the piles 

 

3. In property select Pile 

Interface 

 

4. Click Apply 

 

5. Select the Pile Tip Tab 

 

6. Select the 20 pile tip 

nodes from the left pile 

sets 

 

7. In property select the Pile 

Tip  

 

8. Click Apply 

 

9. Repeat for the right piles 

 

 

 

Procedure 
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Step 24.  Gauging Shell 

1. Mesh > Element > Create 

 

2. Select the Other Tab 

 

3. Select Gauging Shell from 

the drop down menu 

 

4. Select the 2 soild 

geometries of the base of 

the abutment 

 

5. Select the 6 top faces 

 

6. In property tab select 

Gauging Shell 

 

7. Click Apply 

 

 

Gauging Shells allow you to  

obtain strucutral results like  

forces and moments on a solid  

object. 

Procedure 
1 

2 

4 

5 
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Step 25.  Boundary Conditions 

1. Seepage Consolidation 

Analysis > Boundary > 

Constrain 

 

2. Select the Advanced Tab 

 

3. Select the Pile Elements 

 

4. Activate Rz, to restrict 

rotation about Z axis 

 

5. Click Apply 

 

Procedure 
1 

3 

4 
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Step 26. Ground surface spring (Modulus of 

subgrade reaction)  

Create ground surface spring  

(Boundary for eigenvalue 

analysis)  

 

1. Mesh > Element > Create  

 - Other > Ground Surface 

Spring  

 - Select all solid elements 

(Mesh set 9 total)  

 - Modulus of elasticity 

coeff. a = 2  

- Check “Fixed Bottom” 

 

 (* Modulus of subgrade  

reaction will be auto calculated  

based on the following 

equation(next slide)) 

 

 

 

Procedure 

1 
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Step 27. Ground surface spring  
(Modulus of subgrade reaction)  
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Step 28. Ground surface spring  
(Modulus of subgrade reaction)  
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Step 29: Eigen Value Analysis 

Perform eigenvalue analysis to  

get the natural modes which  

are related to the max. mass  

participation. 

 

1.  Analysis > Analysis Case > 

General  

 - Solution Type : Eigenvalue 

analysis  

 - Activate all mesh sets and 

boundaries  

 - Select Analysis Control  

 - Number of Modes : 30  

 - Check ‘Sturm Sequence 

Check’  

 

2. Analysis > Analysis > Perform 

  

The Lanczos resampling method  

is used for eigenvalue analysis,  

and this method is appropriate  

for soil-structure interaction  

problems. Since this method can  

cause omission of eigenvalue,  

using “Sturm sequence check”  

option is recommended.  

 

Procedure 

1 

2 
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Step 30: Eigen Value Analysis 

Check the first and second mode  

which have a high mass  

participation factor must be  

considered in the seismic analysis  

These two modes will be used to  

calculate Damping effect in  

analysis. 

 

1. Double click on the “Eigenvalue 

Analysis Result Table“  
     - Check the Mode number    
     with the first and second   
     mass participation along the  
     direction of seismic wave  
     which will be applied.  
     - Check Period corresponding  
     each mode number  
(Period) – (0.951982, 0.6373990)  
 

  

In case that the model does not  

include bedrock, it is required to  

apply fixed boundary at the bottom  

to represent it. If not, it could not be  

possible to check Natural period. 

Procedure 

1 
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Step 31. Ground surface spring  
(Damping Constant)  

In order to simulate the  

radiation damping phenomena  

at the ground boundary, apply  

damping boundary. 

 

1. Mesh > Element > Create  

 - Other > Ground Surface 

Spring  

 - Select all solid elements 

(Mesh set 9 total)  

 - Selecting Damping 

Constant / Area 

 

 (* Damping Constant will be  

auto calculated  

based on the following 

equation(next slide)) 

 

 

 

Procedure 

1 
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Step 32: Ground surface spring  
(Damping Constant)  
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Step 33: Ground acceleration  

with Direction  

Define ground acceleration 

with direction 

 

1.  Dynamic analysis > Load > 

Ground Acceleration  

 - Check Y - direction  

 - Select (     ) button to add 

time history function   
     - Add Time Function  

 

 2. Copy Paste the columns 

from the excel file with tab 

named “Offunato” in the 

 Name  

 - Select Normalized 

Acceleration  

 

In general, three types of  

seismic wave such as  

Offunato, Hachinohe and  

artificial (or historical  

earthquake) are used to check  

the stability to find out the most  

critical case 

 

 

 

Procedure 

• Seismic wave can be classified by direction such as Primary, Secondary and Love wave. Y-
direction in this example represent Primary wave which cause a compression and expansion 
of ground repeatedly.  
• In case of defining specified direction in the plane (ex) x-y plane), input scale factor for 
each direction like below.  

Ex) Check X and Y 
direction Input scale factor 
by following relation X : a · 
cos θ, y : a · sin θ  

1 
2 
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Step 34: Analysis Case (Time Step)  

Create Case for Time History 

 

1.  Analysis > Analysis Case > 

General  

 - Solution Type : Non 

Linear Time History   

 - Activate all sets excluding 

‘Ground Surface Spring’  

 

 2. Time Step  

    - Define Time Step  
    - Time Duration :   
       15.872sec  
    - Time Increment :    
        0.062sec  
    - Intermediate Output :   
      10 (Required to set time   
      step depending on the   
      Time History Load  
      Function(Duration &   
      Increment)  
 

 

 

 

Procedure 

1 

2 
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Step 35: Analysis Case (Analysis Control)  
 

 

1.  Analysis Control   
     - Dynamic : Damping    
     Method  
 
     - Select “Calculate from    
     Modal Damping”  
     -Select “Period” - Input    
     First and Second mode  
     (0.951982, 0.637399) 
    -Damping Ratio : 0.05  
 

 

 2. Analysis > Analysis > 

Perform  

 

  
 

 

 

Procedure 

1 
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Step 36.  Results  
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Step 37.  Results  
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Thank you 

Angel Francisco Martinez 
a.martinez@midasuser.com 


