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Audience and Purpose

This guide is written for NetSuite developers and technical resources who are look-
ing for documentation and step-by-step process guides for the SuiteCloud Developer
Framework (SDF). After reading this ebook a user should have a good understanding of
the framework, its advantages and shortcomings as a BEVOPS tool. The readeris guided
through the process of setting up and configuring an SDF project for ongoing develop-
ment and support of NetSuite customizations. Techfino has also included a sample SDF
project to walk the user through a real-world deployment for demonstration purposes.

Introduction

Over the past few years NetSuite has been hard at work adding exciting features to
the NetSuite development process with the introduction of the SuiteCloud Develop-
er Framework or “SDF” as it's most commonly abbreviated. SDF is in essence a plat-
form-agnostic big brother to the Eclipse SuiteCloud IDE many developers are already
quite familiar with. However, SDF is a much more mature and established tool that can
deploy an entire NetSuite customization project or suiteapp instead of just the source
code. Adoption of SOF has been quite slow to the NetSuite developer community due
to its added complexity and lack of guides and documentation. This document is meant
as a guide to help a developer understand what SDF is, its advantages and how to start
using SDF through the examples below.

The precursor to SOF, SuiteCloud IDE, allows a developer to directly upload their Suite-
Script source code files into the NetSuite File Cabinet. This streamlines ongoing devel-
opment by allowing a developer to quickly push code changes to NetSuite without con-
text /window switching to anotherapp. However, itis far fromideal as a deployment tool
for NetSuite developers and pales in comparison to other platforms’ deployment tools.
NetSuite projects are more than just suitescript source code and require customization
and configuration in the account to be setup and run. SuiteScripts are reliant on cus-
tom records, custom fields, saved searches, workflows etc. which are not supported by
SuiteCloud IDE and require manual creation or another tool working in tandem.

Most NetSuite partners utilize SuiteBundler to fill this deployment gap. While it may
bridge this gap, in practice SuiteBundler can be incredibly obtuse and difficult to use at
times. It often leaves a heavy reliance on documentation and manual process. Suite-
Bundler doesn't have version control support and components aren't linked to specific
file versions which can lead to conflicting code and deployment issues.



SDF aims to address the gaps and pain points of the alternatives by giving a holistic de-
ployment tool that can be used to create and deploy projects seamlessly. To start off,
SDF is available for a few supported IDE's (Eclipse, Webstorm) just like its predecessor
but can also be used as a command line interface (CLI). This addition allows SDF to be
adapted for community plugins and deployment pipelines such as Jenkins. This allows
it to be used for small agile projects or full blown application development. SDF also
supports account configuration and customization by serializing definitions into xml. In
practice, this allows entire projects to be updated and installed to new accounts by a
single user without having to leave their IDE. SDF centralizes the code, customization
and configuration which eliminates the tedious documentation necessary to keep ev-
erything in sync. This also allows for entire projects to be version controlled as opposed
to only its source code.

SuiteCloud IDE SuiteBundle SDF
Supports SuiteScript J v v
Supports Configuration v J
Centralized Project J J
Can be deployed from s s
an IDE / External Tool
Can be paired with
version control / /
Typical time spent Instant (code out of i .
validating deployment sync is marked in IDE) 30 min -5 hours <5min
Typlca!t|me spent <5min <20 min <5min
deploying

NetSuite Customization Deployment Tool Comparison

The biggest drawback to SDF is that itis a bigupgrade. NetSuite has added a lot recently
to amostly barren deployment landscape. It's early stages have been buggy with lacking
support and documentation. However, since SDF's release, a large number of these is-
sues have been addressed. At Techfino, we are now using SDF for all new development
projects and encourage other NetSuite Partners and Customers to do the same.



Guide to Account Customization with SDF

As presented in the Techfino Guide to SuiteBundling in NetSuite by Nick Klug, we assist
customers with NetSuite deployments involving the transfer of both configuration and
customizations created in one NetSuite account to another. We have been shifting into
utilizing the SuiteCloud Development Framework (SDF for short) to help with this pro-
cess for a variety of reasons which are outlined below. In the following section, we will
investigate SDF for managing customizations in multiple environments and deployment.
We will also be discussing how SDF differs from SuiteBundling and some of the things
we have learned over the past year.

For those not familiar with SDF, it can best be thought of as a new framework in which
both configurations and customization objects are represented in XML format. Some of
the benefits of this new process include:

« Greater Control - the files have a much more precise state with SDF. The XML that is
present in the SDF project is exactly what is imported into the target system.

« Version Control - the XML files can also be stored in a version control system, such as
Github or bitbucket. This allows for analysis of changes in the life cycle of a project
and can allow for reverting to a previous customization.

- Build-Automation - while this is not fully baked as of now, Techfino has discovered
a technology stack leveraging SDF that allowed us to successfully automate the de-
ployment of versioned changes from one account to another. SDF is an exciting, en-
abling technology that will allow NetSuite to advance into more of a mature develop-
ment and automated build deployment platform allowing for Continuous Integration
and Test Automation to follow.

When starting to utilize the SDF platform, an easy way to start is to simply create a few
basic scripts and fields within NetSuite. Then, import them into SDF and examine the
new entries in the SOF project. This gives a good starting point for your customization
project. See the Sample Mass Delete Script Deployment section for a “Hello World” ex-
ample of deploying a simple development package via SDF.


https://www.techfino.com/blog/guide-to-suitebundling-in-netsuite

Understanding Customization XMLs
Customization Object XML

SDF works by representing a customization record in NetSuite with an XML file. This
works both ways - extracting an existing customization from an account and creating an
XML, and pushing the XML into a target account, creating the customization there. The
below example shows the XML object for a User Event script. It contains references to
all the fields on that customization record within NetSuite. This includes the scriptlD,
description, what functions it executes on, and whether or not it is active.

Mode Content

v [e] usereventscript
scriptid custoemscript]
[e] aftersubmitfunction saveReview

[e] beforeloadfunction
[e] beforesubmitfunction
[e] description

[e] isinactive F

(8] name Link Product Review to Inventory tem
[e] notifyadmins F

[e] notifyemails

[8] notifyowner T

[e] notifyuser F

[e] scriptfile [/SuiteScripts/linkReviewToltern_v3.js]

w [g] scriptdeployments
[e] scriptdeployment

Additionally, it also details script deployments at the parameters it uses and what their
values are set to.

v [e] scriptdeployments
v [e] scriptdeployment

scriptid customdeployl
(] allemployees F

[e] allpartners F

[e] allroles T

[e] audslctrole

[e] eventtype

[e] executeinwebstore T

[e] isdeployed T

(] loglevel DEBUG

[e] recordtype [scriptid=customrecord_product_review]
[e] runasrole ADMIMISTRATOR

[e] status RELEASED



Manifest XML

12 <manifest projecttype="ACCOUNTCUSTOMIZATION>

2 <projectname>Test Project</projectname>
<frameworkversion>l.0</frameworkversion>
4r <dependencies>
= <features>
5 <feature required="truse">SERVERSIDESCEIPTING</ feature>
T <feature required="fals=s">CREATESUITEBUNDLES</feature>
i <feature required="false">CRM</ feature>
</features>
10E€ £files>
11 <file>/SuiteScripts/script core lib.js</filex
12 cffiles>
dependencies
nc';fe=:|

The manifest for the project contains the requirements for the manifest to be deployed
inan environment. For example, if you want to use SDF to deploy SuiteScripts to the tar-
get account, then the target account is required to have Server Side Scripting enabled.

One of the greatest strengths of SDF compared to SuiteBundling is allowing for the de-
ployment of objects with dependencies without having to include those dependencies.
Thisisassuming they may have already been deployed via another SuiteBundle. In prac-
tice, workflows are some of the most difficult objects to move with a SuiteBundle. This
is because workflows often reference multiple customizations and with a SuiteBundle,
each related customization will be included automatically. With each migration to an en-
vironment, there is a possibility of unintentionally changing the customizations in the
target environment with the bundled customizations.

SDF Development Environment Setup
IDE Integrations

SDF officially integrates with Eclipse and WebStorm, with Eclipse being the more mature
of the two options. In the following sections, we will be using Eclipse for demonstration
purposes. Below you will find the detailed instructions to setup Eclipse with SDF. You
can also follow NetSuite provided instructions (See SuiteAnswers ID #10315 for Setting
Up SuiteCloud IDE Plug-in for Eclipse).



Install Eclipse

To get started with SDF, you will have to download Eclipse first. NetSuite recommends
using Eclipse Mars. (02/26/2016 package. Link: https://www.eclipse.org/downloads/
packages/release/mars/2/eclipse-ide-java-ee-developers.) Although, we haven't ex-
perienced any issues with the latest version of Eclipse IDE. J2EE or Javascript/Web
Developer version both works. Link: https://www.eclipse.org/downloads/packages/.
Once installed, you can change the workspace to a different path. This will make access
to the folder easier.

& Eclipse IDE Launcher ot

Select a directory as workspace

Eclipse IDE uses the workspace directory to sk:-:ure its preferences and development artifacts.

Workspace: | D:\SDF Demo w Browse...

[ Use this as the default and do not ask again

b Recent Workspaces

Launch Cancel



https://www.eclipse.org/downloads/packages/release/mars/2/eclipse-ide-java-ee-developers
https://www.eclipse.org/downloads/packages/release/mars/2/eclipse-ide-java-ee-developers
https://www.eclipse.org/downloads/packages/

Install SDF Plugin

1. Run Eclipse, Under Window tab, find Preferences

DF - Eclipse IDE

Edit Mavigate Search Project Run  Window Help

(&%) Welcome &3 MNew Window
Editor ¥
Appearance » -
i se IDE for JavaScript and Web [
Show View »
Perspective »
Mavigation >
Preferences

Review the IDE's most fiercely contested preferences

2. Inthe opened window go to Install/Update > Available Software Site

& Preferences | X
type filter text Available Software Sites =l >
General [
Help |ty|:|e filter text |
w Install/Update
Automatic Updates Mame & Locatic Add...
Available Software Sites -P:] 2019-06 http://:

E Edit
t:nlguage servers 9:] Latest Eclipse Release http:/ -
O;rr'::lh %] The Eclipse Project Updates http:/i Bemmene
Remuote Systems
Run/Debug Beloed
Server Enable
Team
Terminal Import...
TextMate
YAML Export...

?\ @ |Q, @ Apply and Close Cancel




Click Add and enter the following information

« Name: SuiteCloud IDE

« Location: https://system.NetSuite.com/download/suitecloud-sdk/ideplugin/
eclipse/19.1(This address changes with releases, so if you are using a builder
later than 2019.1you might need to lookup the address)

& Add Site x

Mame: SuiteCloud IDE Local...

Lecation: | te.com/download/suitecloud-sdk/ideplugin/eclipse/19.1 Archive...
? Add Cancel

Apply and Close
Go to Help tab, click Install New Software

& SDF - Eclipse IDE

File Edit Mavigate Search Preject Run  Window Help
E- I:.;\.?.::I Welcome I3 'ﬁ?.' Welcome
(%) Help Contents

4 Search

Show Contextual Help

Show Active Keybindings... Ctrl+Shift+L
Tip of the Day
Tips and Tricks...

#

Report Bug or Enhancement...

Review the | Cheat Sheets...

Eclipse User Storage »
Perform Setup Tasks...

P

Checkout Ec "g_- Check for Updates
Install New Software...
Eclipse Marketplace...

0 &=

About Eclipse IDE
Contribute

Import exist

ol

Enhance your IDE with additional plugins and install your Marketplace fa


https://system.NetSuite.com/download/suitecloud-sdk/ideplugin/eclipse/19.1
https://system.NetSuite.com/download/suitecloud-sdk/ideplugin/eclipse/19.1

In the opened window, select SuiteCloud under Work with field and verify the
address. Check the SuiteCloud IDE checkbox in the list and follow the Eclipse
wizard to complete installation.

£ Install O X
Available Software |

Check the items that you wish te install. 1 )‘
Work with: !SuiteCIoud IDE - https://system.MNetSuite.com/download/suitecloud-sdk/ideplugin/eclipse/19.1 w Add... Manage...
type filter text Select All

Mame Version Decelect All

[ 000 SuiteCloud IDE

1 item selected

Details
Show only the latest versions of available sottware [/ Hide temns that are already installed
|v| Group items by category What is already installed?

[[]Show only software applicable to target environment
Contact all update sites during install to find required software

P
@ < Back Finich Cancel

When prompted, restart Eclipse
If installation is successful, user will see the following dialog after restart

- .
SuiteCloud IDE Setup Wizard
Welcome to the SuiteCloud IDE setup wizard.

This setup wizard walks you through the creation of your master password and addition of your MetSuite account
information.

| Impertant: You need Internet access in order to complete this setup.

Click "Mext" to continue or "Cancel” to defer setup. If you choose to defer, you can run the setup wizard later from the MetSuite
menu.

@' < Back Finish Cancel



9. Setup master password for SuiteCloud IDE. Once the password is set up, user
will have to use the master password to enable SuiteCloud plugin functions for all
SuiteCloud projects

Enable SDF and Create Custom Role for SDF in NetSuite

Because NetSuite doesn't come with the SDF feature enabled by default, an Adminis-
trator will have to manually enable the feature. A new custom role should be created for
SDF since the Administrator role and Developer role will encounter an issue with 2FA
when using SDF. The new SDF role should be created from the Developer role for SDF
purposes.

1. Login to NetSuite using Administrator role and go to Setup > Company > Enable

Features
Q _'ﬁv g Help E Feedback lv
ocuments @-1-(0-M Support SuiteSocial Fixed Assets Demo Framework Sales Knowledge Bas
R DETETE Viewing: Portlet date seti
Company Company Information
Accounting Enable Features
Sales Rename Records/Transactions
Aark ine to-G Q’Si I
Marketing Auto-Generated Numbers | Welcome to
Support States/Provinces/Counties i Release 2019.2
s5ues Countries ' {aliys el
Site Builder Application Publishers E Release Preview: 7/29/2019 9:30 PM |
£ 10/18/2019 2:30 PM IST'
e & Upgrade: 10/12/2019 12:30 PM IST - 1
mport/Export i PuisT
Users/Roles General Preterences i_ —
ntegration SuiteCloud Processors F

Supply Chain Managemen SuiteAnalytics

Better visibility and control witt CETtifcates Gain business insights faster acrc
Improve customer service leve intuitive SuiteAnalytics user interfi
warehouse efficiencies with ne Printing & Fax SuiteCloud plattorm to leverage a
delivering improved performan ! Give your employees instant visib
both revenue and customer sa WS, workbooks for SuiteCommerce, S

revenue and reduce costs by high
issues and providing insight to eff

LEARN MORE

LEARN MORE
Outbound Request List

Seem
Email Preferences

System Email Templates )

ites Rel=as Release Preview Login
SMTP Servers



In the new page, click on SuiteCloud tab

Enable Features

m Cancel Reset

Company Accounting Tax Transactions Items & Inventory Employees CRM Analytice Web Presence SuiteCloud

VIEW SUITECLOUD JERMS OF SERVICE

Scroll all the way to the bottom and check SDF option, agree to the terms and save
the change

SuiteCloud Development Framework

¥ SUTECLOUD DEVELOPMENT F

CREATE SUITECLOUD PROJECTS C

Once the change is saved, go to Setup > Users/Roles > Manage Roles

Q 5 0

m GV Support  SuiteSocial Fixed Assets Demo Framework

Setup Manager

Company
Accounting
Sales
Marketing JMISTANDARD CENTEI
Support n Classic
n Executi
Issues n Engines
n Sales C
Site Builder
n Sales C
Import/Export n Shippin
™ Shippin
Users/Roles USER MANAGEMENT Shippin
: Shippin
Integration Manage Users e
| Shippin
Custor Manage Roles New Shippin
Custor Cost At
Show Role Differences Search
Custor Accoun
Custol vsiew Login Audit Trail giceoun
Custor Accoun
Stand: Access Tokens Accoun
Stampde =~ S Accoun
Stand: : o et - Accoun
Stand: Two-Factor Authentication Roles Accoun
Custor Advanc
Stands Two-Factor Reset Tool v

Stamdard Arrmon



5. User should now see the Developer role. (This role won't be available until user en-
ables SDF feature.) Click Customize

Eat 03
Dot T0ze
Cuslomize 55
Eat nar

Custom Support Cants:
Custom Sales Center

6. Intherole creation page, update the name to SDF Role. Set Access Subsidiaries
to All.

Role

m Cancel Reset Change ID

General

MNAME *
SOF Role

ID

CENTER TYPE
Classic Center

EMPLOYEE RESTRICTIONS

none - no default - ALLOW VIEWING

ISSUE ROLE

Subsidiary Restrictions

ACCESSIBLE SUBSIDIARIES
o ALL
Y ACTIVE
"/ USER SUBSIDIARY
& SELECTED
ALLOW CROSS-5UBSIDIARY RECORD VIEWING

7.  Add Find Transaction under Permissions > Transactions

Permissions  Restrictions Forms  Searches  Users  Preferences  Dashboard  Translation  History

Transactions+ Reporis+ Lisis» Setups Custom Record

PERMISSION * LEVEL

Find Transaction Full

+ Add _ ¥ Cancel . Insert Remove




Add Publish Search under Permissions > Lists (If there is a custom search needs
to be set as public for custom objects to use, this permission is required.)

Permissions Restrictions Forms Searches Preferences Dashboard Translation

Transactions Reporis+ Listse Setupe Custom Record

PERMISSION * LEVEL
Custom Record Entries Full
Documents and Files Full
Email Template Full
Marketing Template Full
PDF Template Full
Il - Full
‘ . * Cancel . + Insert W Remove .

Publish Search Full
Website (External) publisher Full
+ Add Row

Remove Integration Applications from Permissions > Lists (Not needed for 2019.2)

Permissions  Besircions  Fooms Searches Profeences  Dashboard Transtabon

Transactions  Reponses  Listss  Selype  Custom Record

PERMISSION® LEVEL

Custom Record Entries Ful
Documents and Fies Ful
Email Templato Ful

Full

Ful

Full
Full
Website (Extemal) publisher Ful

+ Add Row

Remove Access Token Management from Permissions > Setup (This option is only
available when the Token-Based Authentication feature is enabled)(Not needed
for 2019.2)

Permissions  Hesiclons  Borms Searches Prgfeences Dashbcard Transkiation

Trgnsactions  Repoiss  Lislses  Setyps  Cuslom Record

PEMMNISEION LEVEL
|| AT - | Ful
I m ® Cancal +insert | Remove




1. Remove Integration Applications from Permissions > Setup (Not needed for 2019.2)

e e+
| [rtegration Apglicaton -] Ful
® Cancel +insert | W Remove

12. Save the Customized role.

Configure Accounts for SDF Project in Eclipse
Change Project Settings

The ‘Change Project Settings’ menu option shown in the figure below is accessible from
the SDF Project in Eclipse and allows the user to select which account and role combi-
nations SDF will point to by default.

e % Te_stpr;J_J_L_I e e

=i, Javal New 2 ot ;
(= setti Go Into v (¢ mamfe;t
= Acca i i pmJ,ECtt}'pe
& Filed Open in New Window [8] projectname .
= Obje Show In Alt+Shift+W » [e] frameworkversion
il -proj = Copy Ctrl+C
'f' ?HE:: Copy Qualified Name
- P Paste Cirl+V
#H Delete Delete
Remove from Context Ctrl+ Alt+5Shift+ Down
Refactor >
ryy Import...
g Export..
Qé,h Refresh F5
Close Project
Close Unrelated Projects
Assign Working Sets...
"L NetSuite > Change Project Settings [

Right-click the parent project folder and navigate to NetSuite > Change Project Settings.



T Change Project Settings

x
Account: ~
Role:
SuiteScript Version: 2.0 ~
Action on Account-Specific Values: | ERROR ~
OK Cancel
To add environments at roles to a project, click on the ellipsis in the top-right.
7L Manage Accounts O *
Account ID Company Name - Domain Email Add
TSTDRV1G10419 CleanSweep Archive Demo Production nick.klug@techfino.com
TSTDRV1680326 CleanSweep Demo 3 Production nick klug@techfino.com [z
Remove All
Manage Authentication

Select and Close Close

Select "Add” at the top right.

ﬂ Add Account(s)

Add Account(s)

Email must be specified.

Comain: Production

Email; | |

Password: | |

@ < Back Next > Finish Cancel

Now, select which environments you wish to add account logins for. With the reconfig-

uration of NetSuite's account specific logins, these will all be under “Production” or “Re-
lease Preview.” Enter your credentials and click “Next.”



1 E Add Account(s)

Select Accounts

Select the account(s) you want to work with in the IDE. Mote: Accounts that no
longer exist are automatically remowved.

Account D

Company Name )
TSTDRV1610419

CleanSweep Archive Demo
TSTDRV1680326

CleanSweep Demo 3
TSTDRV1697009 CleanSweep OA 4 (Leading)
P g

Select All Deselect All

Cancel

You will then see a’Manage Accounts’ window allowing you to check all the accounts you
wish to use your SDF project with.

Tl Ma nage Accounts [N} >
Account ID Company Mame Demain Email Add
TSTDRV1610419 CleanSweep Archive Demo Production nick.klug@techfinc.com
TSTDRV1680326 CleanSweep Demo 3 Production nickklug@techfino.com femeve

Remove All
Manage Authentication
Sclect and Close Close

Press“Select and Close”to select one of the environments as a default or “Close” to leave
the dialog window.



"W Change Project Settings x

Account: TSTDRV1680326 CleanSweep Demo 3 ~
Role: Adrministrator (User Credentials) -
SuiteScript Version: 2.0 ~
Action on Account-5Specific Values: | ERROR ~

The‘Change Project Settings’ window shown in the figure above allows the user to select
which account and role combination SDF will default to for its operations. This process
can be repeated at any point and it is recommended to start with it set to your Source
environment as you develop, then switching to your target environment as you validate
and deploy.

Add Customizations to SDF
Import by ScriptiD

In this section, the flexibility to pull pre-existing customizations into your SDF project
from a target NetSuite Account is on full display.

& SUF Demo - Echpse IDE
File Edit Mavigate Search Preject Run  MetSuite Windaw Help
3~ Bit-iH-0-Q-ic V-2
12 NS Explorer 57 | = Outline R o0
~ E » SDF-Deme [sdf-demo master]

=i Javascript Resources

By settings

v i > becountConfiguration
it featuressml

[ » FileCabinet

= Obje

¥y prog

i deple Open in New Window

omani o At Shift W >

MNew ¥

Copy Chrle

T} Paste Ctrls ¥
¥ Delete Delete

Fefactor 3
v Impert.
i Ewport...

i Refresh E5
Besagn Working Sebs... f B Console 11
NetSuite H Deploy

Pun As N Depley ta Accaunt...

xFQ e

Debug As 4 Validate Project against Account...

Profile As ) Add Dependency References to Manifest -
Restore from Local History... Import Custom Objects from Account... in
New Custom Object in Account... > E'E
im

Team
Compare With
Replace With

Creerwrite Custom Objects with Account Version

Save Project as Zip File

Source Login ko Project Account

o Validdate
Revolke Master Password
Properties AlteEnter



Right-click on the Objects folder in Eclipse and select “Import Custom Objects from
Account.”

&} Import Custom Objects from Account O >

Import Custom Objects from Account

Select the account that contains the custom objects you want to import.

Account: | TSTORV1610419 Clean5weep Archive Demo ~
Role: Administrator (User Credentials) i

(®) Search and Select Objects

?\' < Back Met = Finish Cancel

Select the account and role needed to access the object, then click “Next”

@ mport Custorn Objects from Account O

Search and Import Custom Objects from Account

Select or enter search criteria to find the customn objects you want to import.

Search Criteria

Object Types: Add/Remove

Script 1d Contains: || customscript

Search Reset
Search Results
Select All Deselect All Total Custom Objects Found: 229
Object Type - Script Id =

[] bundleinstallationscript customscript_2663_bundle_in...
[] bundleinstallationscript customscript_bi_ss
[] bundleinstallationscript customscript_ep_license_upd...
[] bundleinstallationscript customscript_ncfar_bundlein...
[] bundleinstallationscript customscript_netsuite_rm_bu...
[] bundleinstallationscript customscript_suitesecial_bun...
[] clientscript customscript379
[] clientscript customscript_2663_bank_deta...
[ clientscript customscript_2663_entity_ba...
[ clientscript customscript_2663_field_valid...
] clientscript customscript_2663_file_forma... "

@ < Back Next > ek e



Enter the script ID in the above pane and then click “search.” After the search finds
all matches for the Script ID, check the checkboxes to select the objects you want to
import into the project. Take careful note of the “Select All”and “Deselect All” buttons.
Click “Finish” to begin importing the selected objects.

i@ NetSuite e

Iﬁl Import custom objects done.

_

(2 Problems @ Documentation & Progress | & Console &3
Test Project

The following object(s) were imported successfully:
customscriptl

The objects will begin the import process. If there are any errors during the import
process, the console will display error messages detailing why the import failed. The
majority of the issues that occur during the import process are due to permissions.
Ensure the role you are using to import has the proper permissions for the objects
being imported.

Import by Bundle ID

Another nice feature is the ability to import objects into your project by SuiteBundle
ID. This can be accomplished by right-clicking on the parent project name in Eclipse
and select “Import Bundle Components.”



% [ E

Go Into

Open in New Window

Show In

Copy

Copy Qualified Name
Paste

Delete

Remove from Context

Refactor

Import...
Export...

Refresh

Close Project

Close Unrelated Projects
Assign Working Sets...
NetSuite

Validate

Show in Remote Systems view

Run As
Debug As
Profile As

Team

Alt+Shift+W »

Ctrl+C

Ctrl+V
Delete

Ctrl+ Alt+Shift+ Down
3

F5

o

Node

w [e] manifest
projecttype
[e] projectname
[e] frameworkversion

Change Project Settings

Deploy

Deploy to Account...

Validate Project against Account...

Add Dependency References to Manifest

Import Bundle Components... I

Another nice feature is the ability to import objects into your project by SuiteBundle
ID. This can be accomplished by right-clicking on the parent project name in Eclipse

and select “Import Bundle Components.”

"W Import Bundle Components

Account: | TSTDRV1680326 CleanSweep Demo 3
Role: Administrator (User Credentials)
Bundles:

241868:Techfino Mass Deletion Script

263417:50F Dev Raole

List Bundles

<
‘ < <
pod

Cancel

Next, select “List Bundles”, select the bundle you wish to import into SDF, then click
OK. SDF will automatically import the objects in the bundle into your SDF project.



Manually Create Customizations

|&] trameworkverson [15)
v s Oibaects .
b >

X Gor Into
F3
¥ Qpen in Mew Window
Show In AR=Shilt- W >
I Crle
I ClibeV
x Delete
Remaove from Contet Cirl+ Alt+ Shift+ Down
Retactor »
fa Impart...
Iy Export.
St Retresh 5
Assign Working Sers...
adat Dieploy to Account...
Show in Bemote Systems view Validate Project against Account..
e 5 Add Dependency Reterences to Manidest
Debug A5 H Impast Custam Ohjects from Aecount... .
Frafile As * | New Custom Dbgect in Account.. I ¥ Lusts, Records, & Felds » Lest
L Z Ovenwiite Custom Objects with Account Version Scripting B Recard Type
Compare With » Save Project as Zip File Plug-ins » Tranzaction Type
Restore from Lo<al History... Log In 4o Project Account Centers and Tabs ) Entity Freld
Source » Forms ) e, Beld
Revoke Master Pazsward
Propesties AltsEnter 1 g e Sar % CMS Content Type
The following chiect (s} were impo) Impart/Export H] M Field
SEEECE AR Users/Roles i Transaction Body Ficld
Documents B 1 tion Column Freld
Transactian tern Optian
Tern Musmbes Freld
Custorn Segment
Orther Custorn Fiekd

Right-click on the Objects folder in the SDF project. Navigate to NetSuite > New Object
In Account, then select the customization object you want to add.



Adding Dependencies in SDF

With SuiteBundler, you often times run into deployment issues using SuiteBundles to
deploy Customizations especially when they automatically include referenced objects
from other SuiteBundles. This leads to some SuiteBundles including fields or records
from other SuiteApps or SuiteBundles unintentionally because they were referenced in
a Workflow for example. But thisis one of the areas where SDF provides greater control
and flexibility to either automatically include referenced objects or not in your Project.

& SOF Demo - Eclipse IDE

File Edt Nawgete Sesch Propect Run  NetSule Window Help

0o~ Bt 0% @

1 TF_MR_MassDeletionScnpt20gs
(= Templates
(= Web Site Hosting Files

“ iy > Objects

COpen

Open With >
Show In AleShift i > | B Contie
Copy culec |

. o

[ Paste CtrleV
M Delete Delete

MetSuite » Deploy
Run &s 3 Deploy to Account..

# 0 |t

Debug As i Valislate Praject against Account
2l Deperdency Relerences o Mandet

Team > Save Project as Zip File

Compare With » Login te Projest Account

Revoke Master Passworn d
Saurce

bl Validate

manifestaml - 50F-De Properties AR=Enter

Updating the manifest can be done two ways. The simplest method is to right-click any-
where in the project, navigate to NetSuite > Add Dependency References to Manifest.
This will add all required dependencies for the objects currently in the project and add
them to the project.

Alternatively, you can manually add dependencies to the project for the objects you know
you will be working with as you go.

For the first few SDF projects, we highly recommend using the automatic addition of
dependencies and paring back as you discover objects that you need to be included for
the project to deploy.



Validation and Deploying SDF Project
Validate Project Against Account

Before deploying your SDF Project to a target account you can first validate the Project
has all the prerequisites for installation. To do so, right-click anywhere in the project,
navigate to NetSuite > Validate Project Against Account.

& SOF Demo - SDF-Demo/Objects/customscript_mr_mass_deletexml - Eclipse IDE
File Edit Mavigate Search Project Run MetSuite Decign Window Help

[~ RQDIT-i -0 Q- OA-DIBFH-F oD
=

153 NS Explorer 53 | 2= Outline | €

~ E!f‘} = SDF-Demeo [sdf-demo maskarl %_1= ¢manradiucsccript soriptid="customscript_mr mass deleta™
=) JavaScript Resources New » p<fd n
(£ «settings Gu Intw
2 AccountConfiguration
v (& > FileCabinet Open in New Window
~ [£3 > SuiteScripts Show In Alts Shift+ W > BT«
w [ > Uliliy
3 = wallibules Copy CULES
[ TF_LIB_MassDelet Copy Qualified Name
& TF_MR_MassDeler [T Paste Ctrl+Y
= Templates o Delete Delete
= Web Site Hosting Files
v {3 > Objects Remove from Context Ctrl+ Alt+Shift+ Down
s customscnpt_mr_mass_ Refactor > ki
\¥i customsearch_mr_delet |
¥} project g Import.. [y
1} deploy.xml 3 Bxort.. W
\¥) > manifest.yml & Refrach = F
Cluse Project ,'.1 & "
paz F< ular
Assign Working Sets... i
= NetSuite ¥ Change Project Setlings
Q) HRunAs > Deploy
%% DebugAs > Deplay to Account...
Protile As 2 Valhdate Project against Account...
Restore from Local History... Add Dependency References to Manifest
leam z Import Bundle Components...
Compare With »
Replace With N melil.s t'urdnr.n r}.hjprlc with Account Version
Configure ' S-nu-e_ Pruject ‘-15 Zip File
Source N Log in to Project Account
~|  Validate Revoke Master Password
Properties Alt+Enter
TL Validate Project Against Account >
Account: TSTORV1E10419 CleanSweep Archive Demo ~
Role: Administrator (User Credentials) w
Action on Account-5Specific Values: | ERROR w

Next, select the account and role that you wish to use in order to validate the SDF proj-
ect. Click validate and the process will begin.



Test Project
Walidatc account acttinga Failed

#+ ERROR ***

ject, but it is not in the account.

1 v3.ja file, but it is not in the account.

The validation process will check against the account to see if the project contains the
settings and objects necessary to support the deployment - for example, if your SDF
project requires Server Side Scripting in the manifest, and the target account does not
have it, it will throw the related error. If the SDF project contains a reference in the man-
ifest to customrecord_product_review, then customrecord_product_review needs to
already be present in the target account. If it is not present, you will receive a warning
similar to the above.

Deploy SDF Project to Account

After successfully validating your project against the target account, you are then set to
perform the deployment. To initiate the deployment start by right-clicking anywhere in
the project and navigate to NetSuite > Deploy to Account.

Mew . Nodf ,
: oot v (g manlfe.st
] projecttype
F Open in New Window [e] projectname
Show In Alt+Shift+W > [e] frameworkversion
] v [g] dependencies
’ B Copy Ctrl+C [e] features
. Copy Qualified Name v [e] objects
5 Paste Ctrl+V ] I.i] object
v [g] files
K Delete Delete & file
Remowve from Context Ctrl+Alt+ Shift+Down [e] applications
Refactor ¥
fxg Import..
0y Export...
Q-éh Refresh F5
Close Project
Close Unrelated Projects
Assign Working Sets...

¥ Change Project Settings

Validate Deploy

Show in Remote Systems view I Deploy to Account... I

Run As > Validate Project against Account...

Debug As ¥ Add Dependency References to Manifest

Profile As i’ Import Bundle Components...

Team >

Compare With , Owerwrite Custormn Objects with Account Version

Restore from Local History... 2o Brmpd &= fip filc

Srnr > Log in to Project Account

Source ¥ Revoke Master Password



Next, select the account and role for project deployment. Click Deploy, and the process
will beqgin. If the target Account is a Production environment, then there will be an addi-
tional confirmation window as shown below:

T Deploy SuiteCloud Project *
Account: TSTDRY161041%9 CleanSweep Archive Demo w
Role: Administrator (User Credentials) R
Action on Account-Specific Values: | ERROR w

Deploy Cancel

If the project deployment is not successful, you will see error messages similar to what
was contained in the validation section. Sometimes, there are additional issues in an
environment that cannot be caught during the validation stage. This typically relates
to data conflicts in the target Account.or example, duplicate script IDs, values used in
things such as a script parameter or workflows that are not contained in the target Ac-
count.

Sample: Mass Delete Script Deployment
Background

Previously,we posted NetSuite Mass Delete Tool, developed and documented by Luke.
Today, we are going to use this solution for a quick example for using SDF as a deploy-
ment tool. Below are the steps for what's involved in the customization.

- Mass Delete Search - A saved search created to identify the records to be deleted.

« Inthis case, we don't actually want to delete any transactions. As a result, we
added Date Created after today as a criteria for this search

« Search columns doesn't really matter. We kept as is and didn't change anything

« The search must be set to public to be allowed to be selected under script
deployment


https://www.techfino.com/blog/netsuite-mass-delete-tool

Saved Transaction Search List Search Copy to Account (Beta) More  Export
Mass Delete Search

Reset | Cancel | Preview | New Template Pivot Report Change ID Actions =
SEARGH TITLE * AVAILABLE A3 DASHEOARD VIEW

Mass Dslots Search AVAILABLE AS SUBLIST VIEW

D AVAILABLE FOR REMINDERS
customsearch_mr_delete_search SHOW IN MENU

OWNER

RenHong Zhu -

¥| PUBLIC

AVAILABLE AS LIST VIEW

Resulls  Highlighting  Available Filters

Criteria

Use this tab fo specify criferia that namow down your
search.

USLC CXMROSGIONS

Audience

Roles

Email

Audit Trail Execution Log  Search Title Trg

Standard» Summary
rLCR™* DCSCRIPTION™ FORMULA
Main Line is true
Date Created is on today
Type is Journal
| -
l ® Cancel Insert | Remove | I
i Reset | Cancel ‘ Preview | New Template Pivot Report Change ID Actions v

Critena Hignighting ~ Avallable Hiters  Audience  Rokes  Emal  Audit ral  EXecution

Resuns
r

Use thiz tab fo indicate columns fo be included in the search resulis as well as sort
nrder

JORT BY OUTPUT TYPE
Order Type v DESCENDING Normal v
THEN BY CONSOLIDATED EXCHANGE RATE
A 4 DESCENDING Per-Account -
THEN BY SHOW TOTALS
¥ DESCENDING MAX RESULTS
RUN UNRESTRICTED DS
MY PREFERRED SEARCH RESULTS
Columns+  [rill Down Fields «
Remove all Add Muiltiple
WHEN
SUMMARY ORDERED BY CUSTOM CUSTOM LABEL
FIELD* TYPE FUNCTION  FORMULA  FIELD LABEL TRANSLATION
Order Type
*
Date
As Of Date
Perivd
lax Period
Type
Document Numbar
Name
Account
Memao
Amount
{1 v
m | W Cancal Incnrt Damararn a Mo lln & Maoven N | | X Maiin Ta Tan -




 Utility | Mass Delete (MR) - The Map/Reduce script record

m | Back | | Deploy Script | Actions v

TYPE
Map/Reduce

NAME
Utility | Mass Delete (MR)

ID
customscript_mr_mass_delets

APl VERSION
20

Scripts  Parameters  Unhandled Errors  Execution Log  Deployments  System Notes

SCRIPT FILE
preview TF_MR_MassDelstionScript2.0.js download Edit

¥| GET INPUT DATA
¥ Map

¥'| REDUCE

¥| SUMMARIZE

Custom Plug-In Types

CUSTOM PLUG-IN TYPE

Mo records to show.

« Script parameter: Saved Search for Delete - this parameter is passed to the
script to identify what is going to be deleted

Scripts  Parameters  Unhandled Emors  ExecutionlLog  Deployments  Sysiem Notes

' New Parameter

DESCRIPTION [} TYPE LIST/RECORD

Saved Search for Dalete custecript_tf_saved_search List/Record Saved Search

m Back Deploy Script Actions »



« Script Deployment

o Set Parameter value to Mass Delete Search

Script Deployment

E Back Actions »

SCRIPT STATUS

Utllity | Mass Delate (MR) Mot Scheduled
il SEE INSTANCES
Litility | Mass Delete (MR) Status Page

D LOG LEVEL
customdeploy_mr_mass_delete Debug

¥ DEPLOYEL EXECUTE AS ROLE
Adminlstrator

PRIORIT
Standard

Schedules Paramseterses ExeculionLog  Syslem Noles

SAVED SEARCH FOR DELETE
Mass Delete Search

We are going to use Eclipse for this example to pull above customization from our
CleanSweep Archives & Purge Dev and deploy to QA account. We will show you each step,
hope this will be useful to you. We are assuming you already have Eclipse and NetSuite
setup according to our SOF Development Environment Setup section which includes
custom role setup, assigned to user and SDF plugin for Eclipse. This example is using
Eclipse IDE 2019-03 R for Javascript and Web Developers edition.

Project and Git setup in Eclipse

For demonstration purposes, we are using Eclipse git plugin for all repository interaction
because it doesn't require any other installations. You can use your choice of repository
and tool (SVN, GitKraken,etc.). An empty git repository sdf-demo has also been created
via bitbucket for this example.



Add Git Perspective and Add Repository

1. Click on Open Perspective located at the top right corner

Quick Access i | & L

| Open Perspective

2. Select Git from the list and Click Open. Now the Git Perspective is opened, you
should be able to see Git Repository section (Shown below)

™ Git Repositories 3 = | ey &5 i_i{‘l’| i <}='=l>| sl Y 5 O
Select one of the following to add a repository to this view:

l1‘|\_'_| Add an existing local Git repositony

e Clone a Git repository

I_j{h Create a new local Git repository

3. Click on Clone a Git repository, enter the URI and required information and click

next
& Clone Git Repositor O
Source Git Repository GIT
Enter the location of the source repository. =] .J
Location
URI: | http5:;',-"“bitbucket.Urgftechfino,.l‘sdf-demo.gi Local File...
Haost: |bitbucket.u:|rg |

Repository path: |ftechfino;‘sdf-demn.git |

Connection

Protocol: | https  ~

Authentication

User: [ |

Password: |ooooooooo |

Store in Secure Store

@' < Back Mext = Finish Cancel



Setup path and click Finish. Please be aware sdf-demo here is the name of the
repository instead of SDF-Demo which is the name of the project.

& Clone Git Repository O x
Local Destination GIT
Configure the local storage location for sdf-demo. _}A
Destination
Directory: Digithsdf-demo | Browse
Initial branch: | master w

[]€Clone submedules

Configuration

Remote name: | sdf-demao]

Projects
[ Import all existing Eclipse projects after clone finishes
Working sets

[] Add project to working sets Mew...

Select...

@' < Back Mext = Cancel

Now the bitbucket repository is added to your repository list

o Git Repositories §3 = | '-FLT_| e I_Fl -::;.'3:' {—E&| g Y = 8
|| sdf-demo [master] - D:\git\sdf-demo.git



Create New SuiteCloud Customization Project

1.

3.

Click on SuiteCloud perspective at the top right corner

(Quekrcees] | 2 | & [

= HF

MetSuite

Go to File > New > SuiteCloud Project...

& SDF Demo - Eclipse IDE

File

=l

PLTTy

Edit Mavigate Search Project Run

Mew

Open File...

Open Projects from File System...

Recent Files

Close

Close All

ave

oL

ave As..
Save All
Revert
Move...
Rename...

Refresh

Convert Line Delimiters To
Print...

Impert...
Export...
Properties

Switch Workspace
Restart
Exit

Ctrl+W

Ctrl+Shift+W

Ctrl+5

Ctrl+5hift+5

F5

Ctrl+P

Alt+Enter

MetSuite  Window Help
Alt+Shift+M >

SuiteCloud Project...

Project...

SuiteScript File

Custom Object File
Installation Preference File
Folder

File

Untitled Text File

Example...

Other... Ctrl+N

Select Account Customization and click Next




4. Enter Project Name: SDF-Demo and Click Finish

& MNew SuiteCloud Project O

Create an Account Customization Project

Create an Account Customization project in the workspace or in an external
location.

Project Name: SDF-Demo

Framework Version: | 1.0

SuiteScript Version: | 2.0 ~

Use default location
DASDF Demo\SDF-Demo Browse...

5. You will see your new SuiteCloud project in NS Explorer

IS NS Explorer 52 | 8% Outline Sy e m

v b= SDF-Demo
B\ JavaScript Resources
[= .settings
= AccountConfiguration
= FileCabinet
= Objects

Jproject

deploy.xml

LY
I
4% manifest.xml



Link SuiteCloud Project to Repository

1. Right Click on SDF-Demo project and find Team > Share Project
£ SDF Demo - SDF-Demo/manifestxml - Eclipse IDE
File Edit Mavigate Search Project Run  NetSuite Design Window Help
H-HRIZDIDIN-4-0-A- B -2BRB-F-0e-
[E NS Explorer 32 | o= Outline i | H% ¥ = O [X manifestaml 52
v F& SDF-Demc
=i, JavaScr Mew £
(= setting G Intny i
= Accour et
'_tb FileCab Open in New Window @ projecttype
Z:, Objects Show In Alt+Shift+W > |[€] projectname
et [] frameworkversion
W] proje E; Cupy Cll+C
:X| deploy. £
T et Copy Qualified Mame
. & Paste Ctrl=V
#  Delete Delete
Remowe from Context Ctrl+ Alt+Shift= Down
Refactor >
Import...
&3 Bport..
&5 Refrech s
Close Project
Assign Working Sets...
T MetSuite »
Q Runis >
15 DebugAs »
Profile As »
Restore from Local History...
Team > Apply Patch...
Comparc With > Srervz st
Configure >
Source >
W Validate
Properties Alt+Enter
2. Select sdf-demo under Repository field and click Finish
O *
| Configure Git Repository GIT
Select an existing repository or create a new one :_’j:l
| [JUse or create repository in parent folder of project
| Repository: sdf-demo - Di\git\sdf-demoa’.git ~| | Create...
| Working tres: |D:\git\sdf—demo |
| Path within repository: | | Browse...
Project Current Location Target Location
1= SDF-De...  D:/SDF Demo/SDF-Demo O:/git/sdf-demo/SDF-Deme




3. Now the Project is linked to our sdf-demo repository. If you go to Git perspective

and expand sdf-memo repository. You will be able to find all the folders and files
there.

13 Git Repositories 53 = | 3 &5 :_P| oo <}='=l>| -l Y = O
w || = sdf-demo [master] - Di\git\sdf-dema.git
&5 Branches
= Tags
= References
[0 Remuotes
v [= Working Tree - D\githsdf-demo
(= .git
w = S5DF-Demo
[= .settings
= AccountConfiguration
= FileCabinet
[= Objects
|X] .project
|%] deploy.xml
|%] manifest.xml
[%] README.md

Commit Empty SuiteCloud Project

At this point, we can commit and push the empty project to Git. It would help us to
identify what are changed in later stage.

1. Right click on the SDF-Demo project and go to Team > Commit, the move all files to
Staged Changes

| Problems | @ Documentation = Progress B Conscle &Git Staging &3

> sdf-demo [master]

Unstaged Changes (0) ; =

Staged Changes (6)

¥ Jsdtscope - SUF-Uemo/.settings
%. .project - 50F-Demo
¥ deployxmi - SDF-Uemo
Y. manifestaml - SOF-Demo
2. org.eclipse.wst.jsdt.ui.superType.container - SDF-Demo/.settings
% org.eclipse.wst.jsdt.ui.superType.name - SDF-Demo/ settings



2. Enter Commit Message and click Commit and Push

3. Now the empty SuiteCloud project has been committed and pushed to our bit-
bucket hosted git repository

Setup SuiteCloud Project Access

Now we need to set up the project access.

1. Right click SDF-Demo project and go to NetSuite > Authenticate Master Password
and enter your master password. This password is the one you entered when you
installed the SDF plugin for the first time.

& SOF Demo - Eclipse IDE
File Edit Mavigate Search Project Run MetSuite Window Help

W BiMviftrQO QiS4 - - S -
NS Explorer 23 | H= Outline L 7
o .
v 173 SDF-Demo [sdi-demo master]
=, JavaSeript Recources New }
(=4 settings Go Into
(£ AccountConfiguratior
., FileC ahinget Open in New Window
= Objects Show In Alts Shift W >
¥l .project p Cilc
o B =
4 deploy.aml opy X
¥, manifestaxml Copy Qualified F
7 Paste Crl+V
K Delete Delete
Refactor »
gy Impor..
7 Export..
s Refresh F3

Close Project

Assign Werking Sets...

= MetSuite H

O RunhAs

{F DebugAs ?
Profile As ]

Restore from Local History..

Team 5

Compare With »

Replace With >
r
>

Configure

Save Project as Zip File

Source

~| Vahdate Authenticate Master Passwiord Crri+Al+ 4

Properties Alt+ Enter

2. 0Once entered, all NetSuite related functions are enabled.



3. Right Click on the project and find NetSuite > Change Project Settings

& SOF Demn - Felipse IDF

File Fuit  Mavigate Seasch  Praject Run NetSuite Window  Help

-

IS NS Explorer 22 | B Outline
w ;'-5 SDF-Demnun [sdf-dem macted
=, JavaScript Resourc New
» [y Jsettings Golnto
= AccountConfigura

- [ HleCabinet Open in Mew Window

(= Objects Show In
¥} «project
4} deploy.ml .
¥, manifest.oml

Copy

Lopy Qualitied Name
Paste

Delete

x &

Remeove from Context
Retactor

lnpord...

Export...

< Refresh

Close Project

Assign Winrking Sefs.
MNetSuite

Run As

Debug As

Punfile As

# 0 !

Restore fram Local History....
Team
Compare With
Replace With
Configure
Source
] Validate

Propertics

BB Qin F

by g - =
e W

0% V=0

Alt+ Shift+\W »

Ctrl«C

Ctrd+V
Delete

Crl+ At Shift+ Down
5

F3

Altr Enter

Change Project Settings

Deploy
Deploy to Account...
Valiclate Project against Account...

Add Dependency References to Manifest
Impert Bundle Components...

Owerwrite Customn Objects with Account Viersion
Sawe Project as Zip File

Log in to Project Account

Revoke Master Password

4. Click Add, enter your NetSuite username and password, then click Next

L _ | £ Add Account(s)
age Accounts

Add Account(s)

Domain: | Production

Account ID C{ Import your account information by connecting to your desired NetSuite server
and entering your Met5uite login credentials.

Email: | renhong.zhu@techfino.com

Passwuond: | 4"""""""""""‘I

< Back

Mext = Finich | Cancel

O X
Add
Remove
Remnove All

Manage Authentication

Close



If the credential you entered is correct, you will see a list of account your have
access to in the next page. In this case, we are moving customization from Clean-
Sweep Archives & Purge Dev to QA. We are selecting those 2 accounts and Click
finish.

TsToRV CleanSweep Archive & Purge DEV
TSTORV I CleanSweep OA 4 (Leading)

Now we need to setup Token access using SDF Role. Otherwise, NetSuite will kick
you out of your Ul session every time you import a customization object. Click on
the first account in the list and click Manage Authentication on the right side. Then
click Issue Token. You should see Token Issued messaged after a couple seconds.
Do the same for the other account.

-
-

Account D Company Name E Domain Email Add

TsToRV I CleanSweep Archive & Purge DEV Production renhong.zhu@techfino....
TsToRV CleanSweep QA 4 (Leading) Pruduction renhong.chu@techlinu..., Remove
| i Manage Authentication et Remove All
| Account ID: TSTDRVI- Manage Authentication

| Company Mame: CleanSweep Archive Purge DEV
|
| Domain: Production

| Email: renhong.zhu@techfino.com

| | Role Authentication Type Issue Token
| | Administrator User Credentials -
| | SDF Role Uszer Credentials
Save loken
ind Close Close

Next, select Dev account and Click Select and Close. In the future, when we need
to import data, the Dev account will be the default account.



8. Onthe next page, change role to SDF Role

TL Change Project Settings X
Account: TSTORV 1 CleanSweep Archive 8 Purge DEV v
Role: SOF Role (Token Based Authentication) w
SuiteScript Version: 2.0 v
Action on Account-5pecific Values: |ERROR ~

At this Point, access has been captured in Eclipse. For the next project, if you are using
the same accounts, you don't have to do this again.

Import Customizations and Validate before Deployment

Finally it's time to import customization from Dev to Eclipse. Keep in mind, the script
contains two parts. The script record under Objects folder and the actual script file
under File Cabinet > SuiteScripts folder alone with all the libraries.

1. Right click the AccountConfiguration and find NetSuite > Import Configuration

& 50F Demw - Eclipse IDE
Hile Edt Mawigate Scarch Project Hun  Metiwite Window Help

T Dilrif O Avid A @B H O

[ NS Explorer 32 Be Outline = - S
w }r—', SOF-Demo [cdf-demo master]
B\ Javabenpt Resources

% scttings

(= AccountConfigur—--
w (= FileCabinet A /
& SuitefSeripls Cipen in Mew Windomw
L emp e Show | AlL+ShifleW
(= Web Site Hosti ww In L+ Shill+ W >
(= Ubjects B Copy Clrl+C
¥ project Foov OualiFed |
2% deployaaml =5 i
. s Paste Ctro V
oYy manifestaml
H  Delete Delete
Refacter ¥
; Impoert...
; Export...
#  Refresh F5
Assign Working Sets...
"L NetSuite » Deploy
|
O FRunks 3 Deploy to Account.. }
% Debug As 3 Validate Project against Account...
3
Profile As s HAdd Dependency Keferences to Manitest
Restore trem Local History.. Import Configuration...
Tearn 4 Uverwnte Custern Ubjects with Account Version
£ompare With Save Project as Zip Hile
i
Reploce With g Login to Project Account
Source >
A Volidat Revoke Master Password
alidate

Properties Alt+Enter



2.

3.

Click Get Configuration List, select Enable Features then OK

T Import Configuration ol
Account: | TSTDRY1632436 CleanSweep Archive & Purge DEV ~
Roles SOF Role (Token Based Authentication) w

Get Configuration List

Configuration

Enable Features

Right click the FileCabinet and find NetSuite > Import Files from Account

I2 NS Diplorer 52 | B= Outline =S TS
v L2 > SDF-Demo [sdf-derno master]
=i JavaScript Resources
E% settings
~ b4 » AccountConfiguration
sfs Teaturesxml
w = hileCabir
:)b Sute, ?
= Temp Go Into
: & ‘_Nph( Oprenn in New Winduw
;t ?J:’ij:f Show In Alt+Shifts W >
oY deployar =) Copy Ctrl=C
£} manifest Copy Qualified Name
[[§ Paste Ctrl=V
3 Delete Delete
Remove from Context Ctrl+Aft+ Shift+ Down
Refactor 3
g Impor..
&3 Bxport..
\.-/.:3 Relresh F3 |
Assign Working Sets... ; e D nentatio Progress & Console 33
"L MetSuite » Deploy L
O Runas : Deploy to Account...
%5 Debug As o Validate Project against Account...
Profile As ) Add Dependency References to Manifest
Restore from Local | listory... Irmport Tiles from Account..
et 7 Owerwrite Custom Objects with Account Version
S ? Save Project as Zip File
REplac it 2 I ng into Project Account
Source ¥
& Validate Revoke Master Password

Properties Alt+Cnter




Click Get File List and select the target folder. In this case, we only need files from

the Utility folder. Click OK. Then NetSuite will start importing the script files from
File Cabinet. Once done, you should see the script files under FileCabinet folder.
Also, it's important to pay attention to the logs in the console. Should an error
occur, you will see details highlighted in red. You will want to pay attention to logs

whenever you import or deploy anything.

Role: SDF Role (Token Based Authentication)

File(s) to download

Get File List

~ [] (= File Cabinet
v [] = SuiteScripts
[] = CreateRecordRestlet
[] = Heneycomb Mfg
[ = HeneycombMfg
[ 5 SystemStatus.js
[1 & TF_MR_MassDeletionScript2.0js
[ &= TestHarness
v [ = Utility
|=| TF_LIB_MassDeletionScript2.0.js
| TF_MR_MassDeletionScript2.0.js

ishList_Ramsey.js
|Z| linkReviewToltem.js

U
O
[ 5 linkReviewToltem_v3.js
[ & massdeletejs

[ 2 testPortletjs

[z

|=| testS5_Processor.js
[ &= Templates
e

1

[ Exclude File and Folder Properties

5. Import the Saved Search object by right clicking Objects folder and go to NetSuite

> |mport Custom Objects from Account

= Objects
|¥] .projed MNew
X| deploy

] manif Open in New Window

Show In
[E Copy
Copy Qualified Name
Paste
#  Delete

Remove frem Context

Refactor

E

Impert...
Export...

Refresh
Assign Working Sets...
I "L NetSuite

o

Validate

Show in Remote Systems view
Run As

Debug As

Alt+Shift+W >

Ctrl+C

Ctrl+V
Delete

Ctrl+Alt+Shift+Down
*

F3

|e] trameworkversion

Deploy

Deploy to Account...

Validate Project against Account...

Add Dependency References to Manifest

Import Custom Objects from Account.., I




6. Click Next, put the NetSuite id for saved search in Script ID Contains field and
click search. Find the check the correct search in the list and click Finish. Once
imported, you should see the search object under Objects folder

& Import Custorn Objects from Account O x
Search and Import Custom Objects from Account
Select or enter search criteria to find the customn objects you want to import.
Search Criteria
Object Types: Add/Remove
Script Id Contains: |kustomsearch_mr
Search Reset
Scarch Results
Select All Deselect All Total Custom Objects Found: 1
Object Type Script d
B savedsearch customsearch_mr_delete_sear...
[:?:' < Back Next > Cancel

7. Now we need to import the script object by right clicking Objects folder and go to
NetSuite > Import Custom Objects from Account again



8. Enterand Select the correct object in the window and click finish.

S Import Customn Objects from Account O s
Search and Import Custom Objects from Account
Select or enter search criteria to find the custom objects you want to import.
Search Criteria
Object Types: Add/Remove
Script Id Contains: | customscript_mr
Search Reset
Search Results
Select All Deselect All Total Customn Objects Found: 1
Object Type Script Id
mapreducescript customscript_mr_mass_delete
® < Back Next > Cancel

9. Now everythingisimported. Your NS Explorer should look like the below image.

[= NS Explorer 32 | 8= Outline shRIE = e

v 5% > SDF-Demo [sdf-demo master]
=l lavaScript Resources
(= .settings
w 73 » AccountConfiguration
4y features.xml
w [3 > FileCabinet
W [F3 » SuiteScripts
w (B3 > Utility
[#3 = .attributes
[} TF_LIE_MassDeletionScript2.0.js
[23 TF_MPR_MassDeletionScript2.0.js
= Templates
[= Web 5ite Hosting Files
v fz3 » Objects
g7 customscript_mr_mass_delete.xml
g7 customsearch_mr_delete_searchxml
(¥ .project
¥ deploy.xml
4 manifestxml



Last step for import, we need to update the dependency list. To do this, right

click on the manifest.xml file and go to NetSuite > Add Dependency References to
Manifest. This will automatically update your manifest.xml to eliminate some of
the dependency issue. (In this example, there are not really any dependencies. In a
different scenario, you might have to manually update manifest.xml.)

S SDF Demo - chipse 10k
File Edit MNavigate Search Project Run NetSuite Window Help
el L H- R IR T B R =D R LI 0 SRS S
IS ns Bplorer £t | 32 Outline el ==
w &-'; = Sk-Demn [sdt-demn master]
=, JavaScript Resources
(7 settings
w L > Aceountlanhiqurationn
ity featuressaml
w [#4 > FileCabinet
w 53 > SuteSenpte
~ (3 > Utility
(74 > .attributes
[y TF_LIB_MassDelebionScnptl Us
123 TF_MPR_MassDeletionScript2.0.)s
(= Templates
(= Web ite Hosting Files
~ 33 * Objects
g customscript mr mass deletesml
g7 customsearch_mr_delete_cearch.xmi
¥ project
«r4 deployxml
¥} manitestan®

New >
Open
Open With »
|
Show In Alt+Shift+W > | B Console i3
Copy Chrd+( l
o jalifie owing object(s) were imported successfully:

{*ALL_FEATURES

T Pasle Cul+V  owing object(s) were imported successfully:
:ALL_FEATURES
& Delete Delete ripts/utility/.attributes/TF_LIB_MassDeleti
Rernove frorn Conbet Ctri+Alt+Shift+Down ripts/utility/.attributes/. folder.attr.xml
o pipts/ULility/TF LIB MassDeletiuvnScript2.@.
Al A LANd Shift+Up ripts/Utility/.attributes/TF MR MassDeletic
Refactor y [Fipts/utility/.attributes/.folder.attr.oml
ripts/Utility/TF_MR_MassDeletionScript2.e.j
«3 Import... ewing object(s) were imported successfully:
arch_mr_delete_scarch
Expoit... o ki

owing object(c) were imported succescfully:

i Refreih Es ript_mr_mass_delete
Aszign Working Sete...

T MetSuite > Ueploy

O FRunés > Deploy to Account...

5 Debug As ;) Validate Project against Account...
Profile As y Add Dependency References Lo Manifest
Team - Save Project as Zip File
Compare With ] Log in to Project Account
Replace With 4 Revoke Master Password
Source > p

v Validate |

manifestxml - SDF-De Properlies AltrEntes

Before we deploy the customization to targeted QA account, we want to make
sure the deployment would be successful and is not going to cause any errors. To
do this, right click on the SDF-Demo project and go to NetSuite > Validate Project
against Account



MNew »
Go Into

Open in New Window
Show In Alt+Shift+W »

B Copy Ctrl+C
Copy Qualified Mame

5 Paste Ctrl+V

& Delete Lelete
Remove from Context Ctrl+Alt+Shift+ Down
Refactor >

gy Import...

Export...

[l |

& Refresh F5

Assign Working Sels...
" NetSuite N Deploy

Deploy to Account...

Validate Project against Account... I
Add Dependency References to Manifest

Validate

Show in Remote Systems view I
Run As »

In the pop up dialog, select QA account and SDF Role. Since we will deploy this
customization to QA, we need to ensure it passes validation. Again, you should
check the validation message in console.

T Validate Project Against Account *
Account: TSTDRV1697099 CleanSweep QA 4 (Leading) ~
Role: SDF Role (Token Based Authentication) ~
Action on Account-5pecific Values: | ERROR ~

Eﬁ'_ Problems @& Documentation & Progress & Console 2 &Gitﬂtﬂging

SDF-Demo

Falidating using account (TSTDRV1GI7899).

Validate manifest -- Success

Validate deploy file -- Success

Validate configuration -- Success

Validate chbjects -- Success

Validate files -- Success

Validate folders -- Success

Validate preferences -- Success

Validate flags -- Success

Validate account settings -- Success

Validate Custom Objects against the Account -- Success
Validate file cabinet items against the account -- Success
Validation COMPLETE



Deploy to Target Account

We are finally at the point to deploy this change to our QA account now that the
validation is complete.

1. Right click on SDF-Demo project and go to NetSuite > Deploy to Account

© 5DF Demo - SOF-Demo/Objects/customscript_rme_mass_ delebeml - Eclipse IDE

File Edit MNewgste Search Progect Fun NetSute Design Window  Help

o BN O Qo A il - oo -
I8 NS Explocer 2 | B2 Outline = w0 ¥ customscript_mr_mass_delstexml 11
- SDF-Dy df-des
g emo I e ma e :
B JaveSenpt Resowices
Go Inte

[ weltings

coountConfiguration
FileCabine
» SuiteScripts

Open in New Window
Shew In

AlesShifes W > | E

Ly > Lility Copy Ctrle €
{: '}f:jlt.:g_bhl::;ml Capy Cualified Mame = "custasript_vf saved_search™
3 TFMR Massbel [0 Paste Y
& Templates ® Deete [elete
% Wb Site Hosting Files 7
w gy » Objects T
o eustamseript_mi_mas Refactor 4
e customsearch me del - jmoon
¥, project A
¥ deplayami i
i > manifest.cml Refresh Fs
Clase Praject |
Bssign Weding Sets_. ' ;
L MetSuite 3 Chenge Project Settings I
3 FRunhs H Depluy |
ks Debug As > Deploy to Account...
Prafile As » Validate Praject against Accaunti.
Ristare from Laeal Histary.. Add Dependency References to Manifest
et 2 Import Bundle Companents...
Compare With »
Replace With i Overwrite Custom Dbjects with Account Versien
R . Save Project as Zip File
A X Leg in bo Project Account :
7| Validate Revoke Master Pacsword |
[ETTTENE AgAIATT tHE ACCOONT -- SOCCELT
Properies AiEnver e

2. Change Account to QA and Role to SDF Role and Click Deploy.

"L Deploy SuiteCloud Project x
Account: TSTDRVY - CleanSweep QA 4 (Leading) ~
Role: SDF Role (Token Based Authentication) E
Action on Account-Specific Values: | ERROR ~

Cancel

Deploy




Validate customization has been successfully deployed to target account from
console logs.

E} Problems @ Documentation & Progress & Consale i3 |g¥%; Git Staging
SDF-Demeo

helg-es-es 23:59:48 (PST) Installation started

Info -- Account [(PRODUCTION} CleanSweep QA 4 (Leading)]

Info -- Account Customization Project [SDF-Demo]

Info -- Framework Version [1.8]

validate manifest -- Success

validate deploy file -- Success

validate configuration -- Success

Validate objects -- Success

Validate files -- Success

Validate folders -- Success

Validate preferences -- Success

Validate flags -- Success

validate account settings -- Success

Validate Custom Objects against the Account -- Success

Validate file cabinet items against the account -- Success

Begin deployment

Create object -- customscript_mr_mass_delete (mapreducescript)
Create object -- customsearch_mr_delete_search (savedsearch)

Create object -- customscript_mr_mass_delete.custscript_tf_saved_search (scriptcustomfield)
Create object -- customscript_mr_mass_delete.customdeploy_mr_mass_delete (scriptdeployment)
2019-85-85 23:59:55 (PST) Installation COMPLETE (@ minutes 7 seconds)

Log into NetSuite and verify all changes has been deployed

ORACLE netsuire o > sea Q B @re B reaa -
D % & Activities BoxFies Payments Transactions Lists Reports Analytics Customization Documents Setup Support DemoFramework Fixed Assets SuiteSocial Sakes Knowledge Base
Scripts View £
= FLTERS
TP AP VERSION PT FILE FROM BUNDLE
MapFiaduss " mow TF_MR_MasaDeleSonScrpl2 0 jo - -
SHOW INACTIVES TOTA
£t viEw e o Pt suntnE o s vERsion scaws sy scawr

e | v Uity | M Doty (MR Cutpmacrpt_me_mass_deee 20

(IR ——

Script Deployment

m Back Actions =

SCRIPT STATUS

Utility | Mass Delete (MR} Mot Scheduled

TITLC SCLC INSTANCLS

Utility | Mass Delete (MIR) Status Mage

D LOG LEVEL

customdeploy_mr_mass_delste Debug

v DEFLOYED EXECUTE A3 ROLE
Adiminislalon
PRIORITY
Standard

CONCURRENCY LIMIT
2

SURMIT All STAGFS AT ONCF
YIELD AFTER MINUTES

10
RLIFFFR SI7F
1
Schedules Parameterss Fxecufionl og  System Notes
SAVED SEARCH FOR DELETE
Mass Delete Search
INLE FRUM BUNULE i7] 1YPE UWNER AUCESS

Maszs Delete Scarch customsearch_mr_delete_search Tranzaction RenHong Zhu Public



5. Don't forget Commit and push all the changes to Git

That concludes this example for deploying Mass Delete Customization from our Dev
account to QA account. We hope that you found this example helpful.

Additional Notes for This Example

1. Some of the steps only apply to Account Customization. The process for SuiteApp
will be slightly different for the initial project setup, and you will need to supply your
Publisher ID.

2. Import AccountConfiguration may not be necessary if the settings are the same
between accounts. Using SDF role may cause error due to permission issues. If
that's the case, switch to Administrator role for AccountConfiguration for import and
export.

3. Validate against Account action is more for dependency check. It does not
guarantee deployment will be successful.

4. Always log into NetSuite and check deployment result after SDF deployment.

5. This demo does not follow git best practices and uses only the master branch for
demo simplicity

6. There are other ways to import/export project to Git. This is just the writer’s way of
setting things up.

7. We recommend committing the .project since the recent release of Eclipse requires
this file for a project. If this particular file is missing, you will run into errors while
initializing the SuiteCloud project in Eclipse.

8. To create a new project out of existing Git repository, you can first clone the
repository from Git perspective. Then go to File > Open Projects from File System
and select the correct root. If the correct root is selected, you will see a SuiteCloud
project added to your Explorer. (You must have the .project file in the root folder.)



SDF Gotchas & Our Experience

NetSuite has worked to address many of the issues that we discovered on different
projects. They continue to improve upon SDF and we are thankful that many of these
challenges have been addressed. Below are some of the remaining issues that you may
experience :

« Workflows

« Permissions - Importing Workflows from an environment or deploying to a target
environment requires permissions for your deployment role for all transaction
types that are involved in the workflow.

« Workflow Action Script return types - Issue deploying workflows with workflow
actions with “List/Record” return types when the value is a List. Netsuite
expects arecord type and rejects the list. The workaround for this is to remove
any return type, deploy, then manually reconfigure the return type.

« Account Specific Values - Be aware that Account Specific Values could result
inunintended behavior for workflows. For example, in an Expense Approval
workflow, if the chart of accounts does not match between environments, it
may use a seemingly random account for approved expenses.

« Roles - All roles centers are not supported and not all sublists are supported. Most
notably, employee and custom center are not supported and the following sublists
are not supported:

« Subsidiaries field
« Formssublist

« Searches sublist
« Dashboard sublist

NOT RECOMMENDED - The workaround for role center types that are incompatible is
to create the role in the target environment with the same ID and make sure the role
center type is the intended type. Next, use the console to set the role center type to
“BASIC”, then save the role. Edit the XML of the imported role and set the role type in
the XML to "BASIC". After deployment, set the role center type back to the intended
value. We still encountered difficulties with this process, but it was the most consis-
tent solution available.



Deployment Roles - When deploying with SDF the user deploying will need a role with
permissions to various records and objects and their dependencies as well as the
ability to authenticate and make web service calls to NetSuite preferably using Token
Based Authentication. When deploying this creates a Chicken and Egg paradox as
you can't deploy the role needed to deploy to the account without deploying. A native
or pre-existing role must be created for an SDF deployment to solve this issue. Previ-
ously the Administrator role could be used for convenience or as a last resort but with
Two Factor Authentication mandatory for any highly privileged roles now this disal-
lows the role from being used. There are a few options and none are very streamlined

1. Manually create arole in the target account. While the most tedious option it is
also the most straightforward

2. Install an SDF developer role from a suitebundle. There are many pre-existing
bundles for an SDF friendly role. Installing one of these or creating your own SDF
developer role bundle can save you a lot of time and headache in the future

3. Create a custom role based on the Native Developer role. The native developer
role contains highly privileged permissions and has the same issues as the
Administrator role. However you can strip out a few permissions and create a
custom role pretty easily that doesn't have mandatory two-factor authentication

« Access Token Management
- Integration Application

This role will likely need to be altered with additional permissions but works for
simple projects and as a good starting point

Error Messages - When an SDF operation fails, it can and will be vague, confusing,
unintuitive, or a combination of all three. Focus on resolving any and all small issues
with the project being deployed and work through each issue.

Ensure Uniqueness of script IDs - One issue encountered was a nebulous error
message whiletryingtodeployascript-“Invalidrecordtypereference key CUSTOMER".
However, we found that the underlying issue was that there was a script deployment
with the ID “customdeployl” that would not be unique in the target environment,
resolving the issue. In general, validate that the |IDs used for your customizations are
not default IDs, such as “custbody?”.

Forms - The difficulty of migrating forms scales with the level of customization in
the source account. As they are currently implemented, an SDF Form XML contains
a reference to every customization available to be associated with the form in the
account, regardless of whether the form uses the field or not. In more complex
accounts, this can lead to an extremely large and dependency heavy XML.



- Saved Searches - Saved Searches deployed without a “Publish Search” permission
definedinthe deploymentrole will be automatically switched from “Public” to “Private”
during deployment. This can break a lot of functionality so it is highly recommended
that this permission always be included for a deployment role.

Validate Against Account: As we mentioned, you should always use Validate against
Account before deployment. However, this feature does not guarantee successful
deploymentevenifitreturnedapositiveresult sinceitonly checksagainstdependencies
within project. For example, if there is an issue with permissions, the feature will be
unlikely to return an error. We hope that NetSuite could improve the Validate against
Account feature so that it can give users warnings as if the change/customization were
deployed-especially consideringthisisthelastline of defense before actual deployment.

Closing Remarks

Be sure to check back from time-to-time as we continue to update this guide with new
contentandinformation. NetSuiteiscontinuingtobuilduponthisSuiteCloud Development
Framework and adding new exciting features you will want to take advantage of. As of
this writing, NetSuite is continuing to add more capabilities to round out some of the
gaps we have discovered and pain-points we have raised. We at Techfino eagerly look
forward to the day where all changes in an account can be managed in version control,
deployed via SDF, and automatically validated unit tests and end-to-end integration and
functional test cases ensuring quality from end-to-end.

If you are considering using SDF and would like our assistance, we would be more than
happy to assist you. Or, if you have any questions, corrections or comments, please
send us a note at contact@techfino.com We love hearing from NetSuite customers,
practitioners and partners alike!



mailto:contact%40techfino.com?subject=

Who is Techfino?

Techfino LLC is a passionate group of techno-functional NetSuite
experts with an innate desire to help companies of all sizes scale
and grow. Headquartered in Philadelphia, this national consultancy
specializes in designing, implementing, and managing best-in-
class cloud solutions. From NetSuite licensing, to training, to
support, to integrations and optimizations, Techfino is hyper-
focused on solving the demanding challenges of ever-changing
business models, bringing specialized expertise in retail, wholesale,
manufacturing, professional services, non-profit, commerce and
beyond. Techfinoisalso proudtohave developed several proprietary
data management products for NetSuite including Cleansweep File
Manager and Archive tools.

For more information about Techfino, their products and service
offerings, visit www.techfino.com
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