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1. Introduction  
nQuery Advisor assists you in choosing an appropriate sample size for your research 
studies. nQuery Advisor also helps you to provide the standard deviation and effect 
size information which you need to make sample size and power computations. 

The nQuery Advisor program was designed by professional statisticians with many 
years of experience in study design. They have created the nQuery Advisor program 
so that research investigators can compute appropriate sample sizes easily. 

Running nQuery Advisor for the First Time  

 

1. When you first run the nQuery Advisor software, a dialog box informing you that 
you have not registered nQuery Advisor will be displayed. Click on Register… to 
enter the license key that you have received from Statistical Solutions Ltd or to 
view your license number before contacting Statistical Solutions so that they can 
issue a license key. 
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2. The Register Product dialog allows you enter the license key that you have 
received from Statistical Solutions Ltd. Enter the license key and click Continue 
to unlock nQuery Advisor. 

 
 

 

3.   Perpetual License. If you have 
purchased a perpetual license, the 
Thank you for registering your 
perpetual licensed copy of nQuery 
Advisor message will be displayed 
before you can run nQuery Advisor. 

3.  Annual License. If you have 
purchased an annual license, a 
message containing the expiration date 
of your license will be displayed 
before you can run nQuery Advisor. 

Uninstalling nQuery Advisor  
from Standalone Computer  
Go to Add/Remove Programs in the Control Panel, click on nQuery Advisor 
(Standalone Installation) and then click on the Add/Remove button. Alternatively, 
you can run setup.exe again from either your CD or the web page, and setup will 
uninstall nQuery Advisor. 

Uninstalling nQuery Advisor  
from Client Computer 
Go to Add/Remove Programs in the Control Panel, click on nQuery Advisor 
(Network - Client Installation) and then click on the Add/Remove button. 
Alternatively, contact your administrator to find out the directory where the server 
version of nQuery Advisor has been installed and execute setup.exe from the 
\NetSetup folder off this directory. 
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Getting Started with nQuery Advisor 
You have installed the nQuery Advisor program. Now you can spend a few minutes 
getting acquainted with the program.  

You should start by doing the tutorial in Chapter 2. If you use the program to follow 
the tutorial, you can learn the basics of nQuery Advisor in a short period of time. 
The Chapter 2 tutorial may provide enough information for many users, but if you 
still have questions, you should follow the Analysis of Variance Tutorial in Chapter 
12 while using nQuery Advisor.  

As questions arise, you can use the other chapters of this manual for reference. 
However, you have more than just this manual to help you understand nQuery 
Advisor. Each sample size table screen provides four different aids to understanding 
the workings and requirements of the program: 

The guide card for each row of each sample size table and many side tables.  

 When you open a sample size table (and many of the side tables), the guide 
card for that table displays a short description of the type of entry expected 
for the row. 

 The tag for each icon.   

 When your cursor remains on an nQuery Advisor icon briefly, a tag 
appears with a description of that icon. For example, when you depress the 
File menu New option, you get the tag shown above. 

 The status line description for each menu item.  

 When your cursor lies on an icon or a  menu item, a short description of 
that item appears on the left end of the status bar at the bottom of the 
screen. 

The Help system. 

 When you choose the Help menu, you can access the Help Topics option to 
use the Contents, Index, or Find options. 
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New Features and Tables in nQuery Advisor 5 
The nQuery Advisor 5.0 program delivers 32 bit Windows architecture for Windows 
98/NT/2000/XP. 

New features: 

• References  
References for every sample size table are shown in a separate pane 
below the table and can be copied and pasted into reports. 

• Column names  
You can assign names (e.g. Outcome A, Outcome B, or Low SD, High 
SD, etc.) to each column in a table.  These names will display on the 
screen and in the plot legends, as well as in the printed or pasted tables. 

• RTF Copy and Paste with user font choice for tables and side-tables 
You can copy and paste tables from nQuery Advisor into user 
documents in the user-selected font using Rich Text Format.  The table 
structure, formatting, and Greek symbols are preserved (without use of 
the Dixon font.) 

• RTF Copy and Paste with user font choice for statements, user notes, 
references and guides 

You can copy nQuery Advisor statements, user notes, references, and 
guides. Then you can paste them into user documents in your selected 
font using Rich Text Format. This process preserves formatting and 
Greek symbols (without use of the Dixon font.) 
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New Sample Size Tables: 

• t-tests 
New table to compute power and sample size for the two group t-test 
with unequal variances (Satterthwaite’s t-test)  

Two group Satterthwaite t-test of equal means (unequal variances) 
(equal and unequal n’s) (MTT0uv, MTT0uvU) 

New table to compute power for detection of specified fold-change 
when the CV is specified (especially useful for planning DNA 
microarray studies) 

Two group t-test for fold change assuming log-normal distribution 
(equal and unequal n’s) (MTT0cv, MTT0cvU) 

New table to compute probability of detection of specified fold-change 
when the CV is specified and the result must exceed a specified fold-
change threshold (especially useful for planning DNA microarray 
studies) 

Two group t-test of equal fold change with fold change threshold 
(equal and unequal n’s) (MTT0fct, MTT0fct) 

• Proportions 
For the two group Chi-square, and continuity corrected Chi-square, 
you can now solve for the proportion which is detectably different 
from a specified proportion. 

 Two group χ2 test of equal proportions – Compute one of two 
proportions  (PTT0p) 

Two group continuity corrected χ2 test of equal proportions – 
Compute one of two proportions (PTT1p) 
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• Equivalence 
Separate tables are available for two-group and crossover designs 

Two-group t-tests (TOST) of equivalence in means (equal n's) 
(MTE1tg, the same table structure as the former MTE1) 

t-tests (TOST) of equivalence in means for crossover design 
(MTE1co) 

Two-group t-tests (TOST) for ratio of means (using log scale) (equal 
n's) (MTE2tg, the same table structure as the former MTE2) 

t-tests (TOST) of equivalence in ratio of means for crossover 
design (natural log scale) (MTE2co) 

• Survival 
The total number of required events is now calculated for these 
survival tables: 

Log-rank test for equality of survival curves (STT0) 

Test based on exponential survival, accrual period (STT1) 

Test based on exponential survival, accrual period, dropouts 
(STT2) 

• Standard Deviation Calculator 
A new table has been added to the Assistants menu, Estimate SD 
option, to calculate the pooled standard deviation from two 
independent samples. 
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Customizing Regional Settings 
You can change Windows settings to suit your locale, and if you tell Windows 
98/2000/NT/XT that you want to use commas instead of periods for the decimal 
point, nQuery Advisor will honor your request. This is called internationalization or 
localization. 

You do this in one of two ways:  

1. From the Start menu, choose Control Panel. Within Control Panel, double 
click to activate Regional Settings. Choose the Regional  Settings tab and 
choose a language/region in the drop-down box. 

or 

2. From the Start menu, choose Control Panel. Within Control Panel, double 
click to activate Regional Settings. Choose the Number tab. When you see the 
dialog box under the Number tab, enter your preferred decimal symbol in the 
Decimal symbol field. 

Considerations: 
a) If you use option 2 above, your edits change the system’s configuration for that 

language. That is, if you're working in English (United States) and you change 
the decimal symbol to &, then change the language to French (France) and then 
back to English (United States), your decimal symbol will remain &. You can, 
however, return to the Number tab dialog box to change the Decimal symbol 
again. 

b) The remaining settings in the dialog box under the Number tab have no 
apparent effect on the displays in the nQuery Advisor program. These are: No. 
of digits after decimal, Digit grouping symbol, No of digits in group, Negative 
sign symbol, Negative number format, Display leading zeroes, Measurement 
system, and List separator.  

c) Files saved by nQuery Advisor should be entirely independent of the regional 
settings. This means that when you use commas as your decimal symbol, and 
you send a saved file to someone who uses periods, when he opens the file on 
his computer, the numbers will have periods. 

d) Testing has uncovered no problems, but if you are changing the decimal symbol 
to any symbol other than the period or the comma, you may run into 
complications. 

e) The printed date in the lower right corner of printed nQuery output respects the 
choices you make in Regional settings. As with decimal points, you can change 
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the style in which the date is presented either by changing the language in the 
Regional Settings tab, or by making the change on the Date tab dialog box. 

Please see Chapter 3, The File and Options Menus, to read about the Preferences 
menu and its effect on your regional settings. 

Troubleshooting 
Some users experienced installation or runtime problems with the previous version 
of nQuery Advisor. Those problems were traced to particular versions of support 
DLLs and OCXs on their system. In order to resolve any future such problems 
quickly and effectively, we have provided a tool which determines the exact 
versions of all such files which nQuery Advisor is using on your system.  

To use the troubleshooting tool: 

Choose the Help menu About nQuery option. 

In the About nQuery Advisor dialog box, click on the Advanced Version 
Information button.  

The Advanced Version Information box will appear. This box lists the paths, 
versions and dates of the files which nQuery Advisor needs as those files exist 
on your computer. 

Click on the Save button to save this information to a text file. 

Send the saved text file to us so that we can advise you on any necessary 
updates to the files. 

For this tool to work, you must have a particular file in the same folder as the 
executable file, nQuery50.exe. The file you need depends on the operating system 
you are using. 

 
Operating System File Required 

Windows 98 AdvVer.exe 

Windows NT AdvVerNT.exe  

Windows 2000 AdvVer.exe or AdvVerNT.exe 

Windows XP AdvVer.exe or AdvVerNT.exe 
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2.  Tutorial 
Determination of the appropriate sample size is a crucial part of study design. We 
must choose sample size correctly to allow a study to arrive at valid conclusions for 
the scientific question. A study which is too small may produce inconclusive results, 
while a study which is too large will waste scarce resources. 

Answering the question “What sample size do I need?” requires six steps. Using an 
actual example of determining sample size for the two-sample t test, this chapter 
takes you through a step-by-step tutorial demonstrating some of the nQuery Advisor 
features. This chapter is not meant to be an exhaustive demonstration of nQuery 
Advisor options. Rather, the tutorial demonstrates the general methods of nQuery 
Advisor through one complete example. For a tutorial illustrating the use of the 
Compute Effect Size side tables, see Chapter 12, Side Table & Compute Effect Size. 

Ideally, evaluations of obtainable power or interval width are made prior to the start 
of a study. This is done to ensure that the chosen sample size is neither too small to 
be likely to detect important effects nor so large that the study is longer and more 
costly than necessary.  However, evaluation of the power of a completed study 
which failed to find significance can be useful in deciding whether the intervention 
is ineffective or whether further study may be justified.  The results of the completed 
study can provide information about variance. Nevertheless, the “effect size” used in 
retrospective power analyses should not be the effect size observed in the study, but 
should be an effect size that would be important to detect.    

Step 1. Formulate the study  
The study question is: Does the new drug reduce anemia in elderly women after hip 
fracture? 

Detail the study design 
A two-group, randomized, parallel, double-blind study is planned. Patients will be 
studied for two weeks; each patient will be randomly assigned to receive either new 
drug or placebo 3 times per week. The sample sizes in the two groups will be equal. 
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Choose the outcome summary 
The primary outcome measure will be the mean change in hematocrit level from 
pre-treatment to post-treatment. These changes will be compared between the two 
groups. 

Specify the analysis method 
The mean change in hematocrit level will be compared between the two groups of 
patients using the two-sample t test. The null hypothesis states that the mean change in 
hematocrit is the same in both groups. 

Select File menu New option or click on the New button . In the Study Goal and 
Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 
Under Analysis method, select Test.  
In the Study Goal and Design box below, the selections result initially in seven choices 
in the lower half of the Study Goal and Design dialog box.  

 

Different selections under “Goal” or “Number of Groups” or “Analysis Methods” bring 
up different lists of available sample size tables. 
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Note:  This manual uses the ordering of the analyses within the Study Goal 
and Design box to determine an abbreviation for each analysis type. In 
this example, you are choosing analysis type MTT0. For a detailed 
explanation of the table abbreviation codes, please read the Contents of 
the Study Goal and Design Dialog Box section of Chapter 7, The View 
and Windows Menus.  

(If you have set your screen resolution to a setting which is less than optimal for your 
monitor, some of the words in your display of the following figure may be cut off. The 
solution is to set the video display settings to the optimum for your monitor.) 

Note that the Two-sample t test listing has a - sign beside it. To hide the listings 
under Two-sample t test, click on the – sign.  

Select the Student’s t test (equal variances) and click on the OK button to accept the 
choice. You will see the following screen: 

 

This is the sample size table for the two group t test of equal means with equal n’s. 
Before continuing with the example, this section discusses the general structure of the 
nQuery Advisor screen. 
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Title Bar 
The title bar on the top of the sample size table window displays the name of the sample 
size table. The default name is the table abbreviation plus the number of the table. If 
you save the table using a different name, the next time you open the table, the title bar 
will display the name you used to save the table. For details on the nQuery table name 
abbreviations, see Chapter 7, The View and Windows  Menus.  

Menu Bar 
The sample size table displays eight menus in the menu bar at the top of the window. 
The menus are: File, Edit, View, Options, Assistants, Plot, Window, Help.  

Icon Bar 
Note that the icon bar beneath the menu bar offers 17 icon buttons. You can click on 
each of those icon buttons to gain direct access to the represented program option, 
rather than selecting the menu option. The icons are: 

 
New 

 

 
Copy 

 
Estimate SD 

 
Open 

 

 
Paste 

 
Specify Sigma 

 
Save 

 

 
Paste Unformatted 

 
Statement 

 
Print 

 

 
Fresh Table 

 
Plot Power vs n 

 
Auto Recalculation 

 

 
Unequal n’s 

 
Plot user-selected rows 

 
Cut 

     
Compute Effect Size 
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If you rest the cursor on one of the icons, you will see a tag with a short description of 
the icon. A description of each icon also appears in the status line on the bottom of the 
window. 

Table Title 
Just below the icon buttons, the screen displays the title for this table: Two group t test 
of equal means (equal n’s). 

Column Numbers 
Each column in the sample size table is labeled with a column number. You can 
change these default column names by using the Edit Column Names option from 
the Edit menu. Each table allows up to 20 columns for use.  See Chapter 4 The Edit 
Menu for details. 

Row Names 
Below the table title, the screen displays nine row names. Each row name specifies 
the type of value to be found in the row, whether you enter the value, or the program 
calculates the value for you.  

Changing Row Names or Labels 
You can change the row labels to replace Group 1 and Group 2 with the specific 
names for your groups. This option allows you to enter customized row labels for the 
groups. Your new row labels will appear both on the screen and in the saved and 
printed versions of your sample size table.  

To edit row names: 

Click on the Edit menu Edit Row Names option. The Edit Row Name dialog 
box will appear. 

 

Click on Group 1 mean, µµµµ1 and Group 1 will appear in the white rectangle in the 
center of the dialog box. Note that mean, µµµµ1 appears to the right of the white 
rectangle so that you always know which mean you are specifying. 
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In the white rectangle, type New drug to replace Group 1, then click on the 
Accept Edit Row button. 

Click on Group 2 mean, µµµµ2, enter Placebo in the white rectangle, and click on 
the Accept Edit Row button. The dialog box will show your new row name 
entries. 

 

Click on the Update Table Row Name button to update the table, and the 
sample size table will appear with the new row names. You will see those 
names in the next figure, as you specify parameters in Step 2. 

Note:  You can use up to a maximum of 20 characters for the editable part of 
the row name. 

Status Bar 
The Status Bar lies at the bottom of your nQuery Advisor window. The Status Bar 
toggle in the View menu controls the display of the Status Bar. The bar presents a 
short description of each icon button as your cursor goes over the icon button. The 
status bar also presents the on/off status of the automatic recalculation option, along 
with the exact contents of any cell selected by the cursor.  

Note:  The status bar may show more significant figures than you can see in 
the cell, depending on the number in the cell. 



    
 

Tutorial — 2-7 

Colors in the Sample Size Table 
The rows for power, sample size, effect size, interval width which provide the 
answers to your sample size queries are highlighted with yellow on the screen.  In 
the sample size tables shown in grayscale in this manual, the yellow highlighting 
shows as a pale gray.  

For example, Effect size, Power, and n per group are yellow when you have the 
table for the Two group t test on your screen. If you enter all required information in 
the white rows, you can fill in any two of the three yellow rows, and nQuery will 
compute the third. For this example, enter the group means and the common 
standard deviation, nQuery will compute the corresponding effect size. Then enter 
either power or n per group, and nQuery Advisor will calculate the other. 

Any rows appearing white on your screen are the rows you can ignore, if you wish. 

When you set the Auto Recalc option to On, the row(s) to be automatically 
recalculated will display green. For details on the Options menu Auto Recalc option, 
see Chapter 3, The File and Options Menus. 

Guide Cards 
The guide cards in the right pane of the nQuery Advisor window provide statistical 
information on the row in which your cursor lies.  If you are unfamiliar with the 
analytic procedure or with doing sample size computations, or you want some help 
with how to proceed while filling in values for the table, refer to the guide cards.  

The default Guide toggle is set to On when you have an open sample size table. 
Thus, every new table appears with its guide card on. You can toggle the guide card 
to Off by choosing the View menu Guide option.  

To view the guide card:  

Click on any spreadsheet cell in the first row. 

The guide card for the first row will appear in the upper right of the window. 
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Note that the guide card corresponding to the top row provides general information 
about how to use the table. As you move the cursor from row to row, the guide cards 
display information appropriate for each row.  You also get suggestions for row 
values, details on limits for the values you can enter, and reminders about other 
helpful nQuery Advisor features. 

To bring up the guide card for a different row: 

Click on a cell in the second row, and the guide card will change to the card for 
the second row. 

 

Every new table appears on the screen with its guide card On unless you turn off the 
guide card in the View menu.  

To turn off the guide card: 

Click on the View menu Guide option. The guide card pane will disappear from 
the window.  (The guide card has been turned off for the rest of this example.) 

To turn on the guide card after you have turned it off: 

Click on the View menu Guide option. The guide card pane will appear in the 
window. 
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For details on copying, pasting and printing the Guide cards, please see the Guide 
section of Chapter 7, The View and Windows Menus.  

References 
The References pane is directly below the Guide Card pane of the nQuery Advisor 
window. There you will find the references for the current sample size table. 

Statements 
The Statements pane is directly below the References pane of the nQuery Advisor 
window. That pane is available for storing sample size justification statements 
generated by nQuery;  these stored statements will be saved with the sample size 
table. This tutorial will demonstrate how to request Statements and store, print, or 
copy them to clipboard for pasting into other Windows applications. 

Notes 
The Notes pane is directly below the sample size table pane of the nQuery Advisor 
window. In the Notes pane you can enter all necessary notes to be saved with the 
sample size table.  

Step 2. Specify Parameters for Planned Analysis 
For the two group t test example (MTT0), the parameters you must specify for the 
analysis method being planned are: 

• the significance level for the test 
• whether the test procedure is to be one or two-sided. 

Plans call for a 5% (α = .05) significance level and a two-sided test.  

To enter the values: 

Click on the first cell of column 1. Enter .05 into that cell. 

Press <Enter> or the down arrow to register your entry. Your cursor will move 
to the cell in the second row.   

Type 2 and press <Enter>. 

The next screen shows the new values entered into the table after we have 
turned the Guide card option to Off. Note that the center section of the status 
bar at the bottom of the screen shows the exact contents of the chosen cell. The 
status bar will usually show more decimal places than appear in the table. 
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In preparation for the next step, repeat your row entries of .05 and 2 for 
columns 2 and 3. The next section will use the three columns. 

To copy the values: 

Use your cursor to select the first two rows of the first column. 

Click on the Edit menu Copy option or use the Copy icon, , in the icon 
bar, or use the <Ctrl><C> keyboard shortcut.  

Select column two and use the Paste icon, , in the icon bar, or click on the 
Edit menu Paste option, or use the <Ctrl><V> keyboard shortcut. 

Select column three and use the Paste icon, , in the icon bar, or click on 
the Edit menu Paste option, or use the <Ctrl><V> keyboard shortcut. 

The row entries will display in columns two and three. 

Using Mouse Buttons in Data Entry 
When you are entering data into a sample size table, you can select the cell in two 
ways: 

• Use the left mouse button to single click on the cell. You can immediately 
start entering a value. Your new value will replace any existing cell 
contents. 
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• Use the left button to double click on the cell. Any existing number will be 
selected. You can press <Delete> to remove the number, or simply start 
typing the new number. In either case, the original number in the cell will 
disappear. 

Right-click Menus 
If you right click within the sample size table (or within other panes or views,) you 
will get a right-click menu. These menus provide another way to access the Undo, 
Copy, Cut, Paste, Paste Unformatted, Print, Print Table to Clipboard, Create 
Statement, and Edit Row Name, and Edit Column Names options.  

 

These Edit options function in the same way whether you access them from the Edit 
menu or through the right-click menu for the sample size table. 

Note that the right-click menus for the Guide Card, Statement, References, and User 
Notes panes differ from the menu shown above. Those right-click menu options 
include pane-specific options, such as Special Characters in the User Notes pane, 
Hide in the Guide Card pane, and Create Statement in the Stored Statements pane. 
See Chapter 4, The Edit Menu for details on the options available in the right-click 
menus. 

Step 3.  Specify Effect Size for Test  
Specifying the effect size is often the hardest part of study planning. 

For the two-sample t test, specifying the effect size has two parts: specifying the 
expected difference in means you would like to detect, and specifying the standard 
deviation expected within each group. 
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Specifying the difference in means expected for 
the two groups 

You should specify the expected mean changes, the worthwhile mean changes, or the 
important mean changes. People often say, “This study has never been done before, so 
how do I know what will happen?” However, previous use of the intervention is not the 
important question.  

The important question is what is known about the outcome measure. What would be 
an important effect of treatment? What kinds of effects might be expected, given other 
information?  

In this example, there was information on hematocrit from four prior studies:  

1.  From a small pilot study in six elderly females after hip fracture, the mean 
hematocrit was 32.3%. In the same institution, in 32 healthy elderly females, the 
mean hematocrit was 33.5%.  

2. Two previous studies tested different doses of the new drug in other patient groups. 
In those studies, the placebo group showed no change in hematocrit. The treated 
group showed changes of 2.5% to 5%. 

These data taken together suggest that we can expect a change of 0% in the placebo 
treated group, with treatment group changes lying in the range 2.5 to 5%. Thus, a 
conservative estimate of the possible effect of the new drug in elderly females might 
be in the range 2.0% to 2.4%. Such increases would be of real value to the patient. 

To enter means: 

Click on the cell in the first column of the New drug mean row and enter 2.0. 

Press the right arrow to move to the second column of the New drug row. 

Enter 2.2. 

Press the right arrow to move to the third column of the New drug row. 

Enter 2.4 and press <Enter>.  

You have entered the treatment means. 

Click on the first column of the Placebo mean row and type 0. 

Press the right arrow to move to the second column of the Placebo row. 

Type 0 in the second and third columns of the Placebo row. 

Note that nQuery Advisor automatically calculates the difference in means, as 
you can see in the next screen. 
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Specifying the common standard deviation 
The next row in the table is Common standard deviation, so we must obtain 
information about variability between individuals within a group. The two-sample t test 
assumes that variability in the two groups is the same, so you enter a single value.  

In determining the value of the common standard deviation, we again refer to previous 
studies. Standard deviations for hematocrit values were 3.2% in elderly females, and 3 
to 6% for other groups.  

The current study, however, requires the standard deviation for change in hematocrit, 
and less information is available. The information reported here required some 
additional calculations from the values given in the references. The standard deviation 
of change in hematocrit in the various placebo and treated groups ranged from about 
1.5% to 2.5%. These data suggest that we can reasonably expect a standard deviation 
for change in hematocrit of about 2%. 

The nQuery Advisor program helps you to utilize information from a variety of formats 
to obtain an estimate of the standard deviation. For details, see Chapter 9, Determining 
a Value for the Standard Deviation. 

To enter Common standard deviation: 

Click on the cell in the first column of the Common standard deviation row 
and enter 2.0. 

Type 2.0 in the second and third columns of the Common standard deviation 
row. 

Note that nQuery Advisor automatically calculates the Effect size. 

At this point, you may wish to enter notes concerning the origin of these values for the 
mean and standard deviation so that you can document them in your report. You can 
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save any notes with the table, then print them out or copy them to the clipboard for 
future reference. 

To add a note to the table: 

Click in the white rectangle in the lower left of your screen below the title, 
USER NOTES for MTT0-1 

Type: References 1-5 suggest change in hematocrit due to the new drug 
treatment of 2% to 5% and standard deviations of change from 1.5 to 
2.5%. 

Your nQuery Advisor table should look like the following screen. 

 

Step 4.  Compute: Sample Size or Power  
Choose the value of power required for the study. The power is the probability that 
the results of your study will be statistically significant at the specified significance 
level if your assumptions about means, standard deviations, and effect size are true. 
The significance level is 5% for this example, and we are assuming that the values 
you have entered for means and standard deviation are the true values (not 
necessarily those observed in your study). 
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Investigators typically request study powers between 80% and 95%. The higher the 
required power, the larger the required sample size. Here, we assume that the 
investigator chooses 90% power. 

To enter a value for Power: 

Click on the cell in the first column of the Power row and type 90. 

Press the right arrow to move to the second column. 

Type 90 into the second and third columns of the Power row. 

Note that, when you type the value 90 into the power row and press <Enter> or 
the right arrow, nQuery Advisor computes the necessary sample size and 
completes the column. 

 

For the range of hypothesized changes in the new drug group, a sample size per 
group of 16 to 23 would be required (total study sample sizes of 32 to 46.)  In the 
next section we illustrate easy ways to evaluate a variety of possibilities for other 
scenarios and sets of analysis parameters. 
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Step 5.  Sensitivity Analysis  
A sensitivity analysis allows you to assess variability as in required sample size or in 
resulting power or interval width for a range of plausible parameter values. This 
section will discuss three approaches to sensitivity analysis. 

a. Edit Values in Filled-in Column 
You might use this method after you have filled a sample size table and reviewed 
the results. For example, you might look at the screen above and wonder how the 
answer would change if the New drug mean were only 1.8. You can quickly get the 
answer to that question. 

To edit a value in a filled-in column: 

Click on the cell in the first column at the New drug row, type 1.8 and press 
<Enter>. 

The Edit/Recalculation dialog box will appear. 

 

Because you have edited the New drug row, either the value for Power or the 
value for n per group must change. The choice is yours. In this example, we 
want to keep the power at 90%. 

Click on n per group. The OK button and the Set Auto button will be enabled.  

You could click on Set Auto to cause nQuery Advisor to automatically 
recalculate n per group every time you edit a row value. See Chapter 3, The File 
and Options Menus, for more details on that feature. 
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Click on OK to finish selecting the n per group row for recalculation. You can 
see the recalculated screen in the next figure. A New drug mean of 1.8 would 
require 27 per group to achieve 90% power. 

 

b. Edit a Column Name 
Before you use the Plot options, you may want to edit a column name so that 
the column name will appear in the plot legend. 

To change a column name: 

Select the Edit menu Edit Column Names option or the right-click menu Edit 
Column Names option. 

The Edit Column Name dialog box will appear. This box lists the column 
names that you can change in your sample size table. Column names are 
restricted to a maximum of 25 characters each; the names will not wrap. 
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Click on the second column name and type in the desired name. In this case, the 
name is Diff = 2.2, SD= 2.0.  (If you wanted to use Special Characters in the 
column names, you would select the Special Characters box and paste the 
selected character into the notes, then copy it and paste it into the column name 
box.  See Chapter 4, The Edit Menu.) 
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c. Use Plot Options 
To use the Plot option to see n per group for different powers: 

Use the mouse to highlight the entire second column of your sample size table. 

Click on the Plot menu Plot Power vs n option or the Plot Power vs n Plot 

icon . The plot for the chosen column will appear.  

 

To use the Plot option to plot user-selected rows: 

When you prefer more choice in axis parameters, you could choose the Plot 
menu Plot User-selected rows option or the Plot User-selected rows 

icon, . See Chapter 6, The Plot Menu, for details on using the Plot option. 

If you want to re-label your plot axes or title or change the appearance of the 
plotted lines or the background, read Chapter 6, The Plot Menu, for details. 
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d. Fill Table Rows  
 Using Fill Right and Specify Multi-Factor Table  
If you have been following this tutorial, you now have a table with three filled 
columns. Since we want an empty table for the next demonstration, you can open a 
New table, open a Fresh Table, or Clear the present table. 

To open a new table using the File menu New option: 

Choose the File menu New option or click on the New icon . The Study 
Goal and Design box will appear.  

Select your analysis and click OK. The new table will appear. 

To open a new table using the Fresh Table option: 

Choose the File menu Fresh Table option or click on , the Fresh Table 
icon to get a new table for the same type of analysis as the current table. The 
new table window will appear; the table will contain no entries.  

To clear the existing table: 

Click on the Edit menu Clear option. A box will appear, prompting you to 
confirm that you want to clear the table. 

Click on the No button if you want to refrain from clearing the table before you 
save it. 

Click on the Yes button, and nQuery Advisor will clear your table.  

The sample sizes necessary to detect differences in mean hematocrit change of 2.0, 
2.2, 2.4 with a standard deviation of 2.0 were 23, 19, 16, respectively. Based on 
these values, the investigator decided to enroll 20 subjects per group. The 
investigator now wants to confirm that 20 subjects per group will give adequate 
power for these expected differences even for standard deviations larger or smaller 
than 2.0. The Edit options, Fill Right and Specify Multi-Factor Table, provide 
shortcuts for obtaining power or sample size for multiple sets of values. 

Fill Right will quickly enter your chosen values in specified rows when you want to 
enter identical values in every column of any given row. The Specify Multi-Factor 
Table option accepts one-time entry of row values to be combined, then creates one 
column in your table for every combination of row values. These two options can 
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substantially reduce the typing necessary to evaluate many sets of parameters or 
effect size values. 

To use the Fill Right option: 

Enter .05 in the cell in the first row of the first column. 

Enter 2 in the second row of the first column. 

Enter 20 in the bottom row of the first column, n per group. 

Select the first column. 

Choose the Edit menu Fill Right option, and nQuery Advisor will enter the 
value from each of the three rows into every column of the table. 

To use the Specify Multi-factor Table option: 

Choose the Edit menu Specify Multi-factor Table option. The Specify Multi-
factor Table dialog box will appear. 

 

This option allows you to specify several values for one or more rows. The 
program will enter the values into your table in all possible combinations. 

Click on New drug mean, and the cursor will blink in the value entry field in 
the second column. 

Enter 2 and press <Enter>. The program will write the 2 to the column below 
the entry box. 

Enter 2.2 and press <Enter>. 

Enter 2.4 and press <Enter>. 
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Now that you have entered all three values, click on the Save Row button, and 
the three entries will be recorded in the bottom of the dialog box. 

Click on Placebo mean. 

Type 0 and press <Enter>. 

Click on Save Row. 

Click on Common standard deviation. 

Type 1.8 and press <Enter>. The dialog box will be similar to the following 
figure. The bottom section displays the values entered for New Drug mean and 
Placebo mean. 

 

Type 2.2 and press <Enter>. 

Click on the Save Row button. 

Click on OK to finish the entries and send them to the table. Your sample size 
table will appear with the columns filled as you have specified. Note that the 
nQuery Advisor Specify Multi-Factor Table option fills only as many columns 
as necessary to form all combinations. 

Note:  Values for the last row specified will change in the fastest moving 
fashion while values for the first row specified will change in the 
slowest moving fashion as they fill in the columns. See the screen 
below. 
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Now that your table is almost completely filled in, you can see how the power varies 
with the changes in the mean difference and standard deviation. 

Use the scroll bar to display columns lying to the right. Note that columns 7-20 
contain the significance level, test sidedness, and n per group. That’s because we 
used the Fill Right option for ease of filling the table. Since the Specify Multi-Factor 
Table option only filled columns 1-6, we should clean up the table. 

To clean up the table: 

Use the mouse to select columns 7-20.  

Choose the Edit menu Cut option. The entries in columns 7-20 will be cut, and 
your table will contain only the columns necessary for the full multi-factor 
combinations. 

Step 6. Choose Sample Size, Write Statement 
The nQuery Advisor program writes up the sample size decision for any chosen 
column. This feature makes it easy for you to report your sample size decisions in 
correct language. 

To create a sample size justification statement: 

Select any single completed column in your sample size table. For this example, 
select the first column. 

Click on , the Create statement button, or the Edit menu Create 
Statement option. The statement will appear in the Statement dialog box. 
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Buttons in the Statement Dialog Box 

Store 

To store the statement with the sample size table: 

Click on the Store button to send the statement to the Statement pane of the 
sample size table.  

 

Now when you save the sample size table, you will save the statement with the 
table. 

After you have stored the statement with the sample size table, you can choose 
to print the statement or not, whenever you print the table.  
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Note:  A stored statement is permanently associated with the sample size table 
and cannot be erased from the Stored Statements pane. For more 
information, see the Create Statements section of Chapter 4, The Edit 
Menu. 

Print 

To print the statement from the Statement dialog box: 

Click on the Print button to bring up the Print dialog box. 

Click OK to print the statement.  

To print the stored statement and the table: 

Choose the File menu Print option, and you will see the following dialog box. 
Note that the nQuery Advisor statements, notes, and side tables options will be 
grayed out when you have no statements, notes, or side tables for the current 
table. 

 

Click in the appropriate check box to select nQuery Advisor table and nQuery 
Advisor statements for printing. 

Click on OK to bring up the Print dialog box. 

Click OK to print the statement and table.  
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To Clipboard 

To use the statement in the statement dialog box with another Windows 
application: 

Click on the To Clipboard button to send the statement to the clipboard for 
pasting into another Windows application. 

To use the statement stored in the Statement pane with another Windows 
application: 

Click on the right mouse button in the Statement pane to bring up the right-
click menu.  

 

Click on the Copy option to send the statement to the clipboard. The Font 
selection for pasting dialog box will appear. This box contains instructions on 
how to switch fonts. For details on this option, see Chapter 4, The Edit Menu. 

Click on the OK, Complete Copy button to save the fully formatted statement 
to the Clipboard.  

Move to Microsoft Word or another word processing program, then paste the 
statement into the Windows word processing document. (Note that you can also 
paste to your sample size table from Windows applications. For details, see 
Chapter 4, The Edit Menu.) 

The following figure shows the printed table.  

        nQuery Advisor 
    
Two-group t test of equal means (equal n’s) 
 
Column    1 2 3 4 5 6 
 
Test significance level, α    0.050   0.050   0.050   0.050   0.050   0.050 
 1 or 2 sided test?      2   2   2   2   2   2 

    New Drug mean, µ1  2.00   2.00   2.20   2.20   2.40   2.40 

    Placebo mean, µ2        0.00   0.00   0.00   0.00   0.00   
0.00 

   Difference in means, µ1 − µ2 2.00   2.00   2.20   2.20   2.40   2.40 
   Common standard deviation, s 1.80   2.20   1.80   2.20   1.80   2.20 
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Effect size, δ=|µ1−µ2|/σ  1.11   0.91   1.22   1.00   1.33   1.09 
Power ( % )        92   79    96   86   98   91 
n per group    20   20    20   20   20   20 
 
 
STORED STATEMENTS for MTT0-1 
__________________________________________________ 
 
A sample size of 20 in each group will have 92% power to detect a difference in means of 2.000 (the 

difference between a New Drug mean, µ1, of 2.000 and a Placebo mean, µ2,of 0.000) assuming that 
the common standard deviation is 1.800 using a two group t-test with a 0.050 two-sided significance 
level. 
 
       MTT0-1 9/09/02 Page 1 

Cancel 

To exit from the statement dialog box: 

Click on Cancel to discard the statement. 

Summary 
This tutorial has introduced you to several of the nQuery Advisor features by using 
one complete example. You should now have a good overview of the nQuery 
Advisor program and its mode of operation. However, please keep in mind that 
nQuery Advisor offers many features not discussed in detail or even mentioned in 
this chapter. See the other chapters of this manual for details and examples of the 
other available options. 

 



 

    
 

2-28 — Tutorial 



The File and Options Menus — 3-1 

 

3. The File and Options Menus 
The first nQuery Advisor screen contains a menu bar with five choices: File, View, 
Options, Assistants, and Help. The File, and View menus on this first screen are the 
initial menus. These initial menus are shorter than the File and View menus 
available after you open a table. The next figure shows the first nQuery Advisor 
screen, excluding the Tips dialog box. See Chapter 5 for a description of the 
Assistants menu and Chapter 7 for a description of the View menu. 

 

File Menu — Initial 
The initial File menu allows you to start a new sample size table, open an existing 
sample size table, perform print setup, or exit from the nQuery Advisor program.  
After you have saved a table, the File menu lists recent saved files. 

 

New   
The New option on the File menu allows you to start a new sample size table by 
selecting from the Study Goal and Design dialog box.  
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The Study Goal and Design dialog box provides an organized index to the 
available sample size tables.   

Choosing an analysis type in the Study Goal and Design Dialog Box: 

Note that this dialog box contains three columns. For each sample size table, 
you will click on one radio button in each column to make your selection of 
analysis type.  

Click on one of the five Goal radio buttons. You can decide to base your 
conclusions on Means, Proportions, Survival, Agreement, or Regression. 

Click on the radio button specifying the Number of Groups as One, Two, or 
Greater than Two.  

Click on the radio button specifying the Analysis Method, Tests, Confidence 
Interval, or Equivalence. 

The list box at the bottom of the dialog box will display types of analyses for 
which nQuery sample size tables are available for each combination of radio 
button choices.   

When you see an analysis type listed with a + sign to the left, click on the + sign 
to display the selections available under that analysis type.  

Click on the name of the preferred analysis method to select it.  
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Note the two checkboxes in the lower left corner: Unequal n’s and Finite 
Population.  

Click on the Unequal n’s checkbox if you want unequal n’s. (If you decide to 
use unequal n’s after opening the sample size table, the analysis types which 
accept unequal n’s offer an unequal n’s button in the sample size table for later 
selection.) 

Some goal and analysis combinations for one-group designs can be modified for 
sampling from a finite population. When the Finite Population checkbox is 
active, you can check the box to modify your one-group design. Click on the 
Finite Population checkbox to specify a finite population. 

Click OK. Your chosen sample size table will appear. 

To get details on your choices in the Study Goal and Design dialog box: 

Read the Contents of the Study Goal and Design Dialog Box in Chapter 7, The 
View and Windows Menus. 

Going Beyond the Study Goal and Design Box 
The Study Goal and Design dialog box offers you a wide range of analysis designs. 
However, statistically sophisticated users may be planning a design or analysis not 
considered here. If you have a formula for some sample size problem that nQuery 
Advisor does not automatically cover, you can go beyond the default designs. You 
can obtain distribution function values to insert in your own sample size equation. 
For details, see the Distribution Function Menu section in Chapter 5, The 
Assistants Menu, and see examples of its use in Chapter 20, Distribution Function 
Tables. 

Open   
The File menu Open option allows you to open any sample size table created and 
saved by nQuery Advisor.  

To use the Open option: 

Choose the File menu Open option or the Open icon to bring up the File Open 
dialog box.   

In the File Open dialog box, select the appropriate drive and directory.  

Click on the name of the desired file and click on OK. 
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Print Setup 
The Print Setup option brings up the Windows Print Setup dialog box. You can use 
the dialog box to choose the printer and paper orientation, as well as paper size and 
source. 

Recent File     
The File menu will also display the names of recently-saved files. Those names 
will appear in the space above the Exit option.  

To use the Recent File option: 

Click on File menu and review the listed files.  

Click on the name of the desired file to open the file. 

Exit 
The Exit option on the File menu allows you to exit from the nQuery Advisor 
program. When you choose this option, you will be prompted to save any unsaved 
sample size tables or plots.  

File Menu — From a Sample Size Table 
This menu offers you the New, Open, Exit and Recent Files options, as on the 
initial File menu. This menu also offers ways to open a new table of the same type, 
close a table, save or print your table, print it to clipboard, or change the printer 
setup. 
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Fresh Table  
The Fresh Table option on the File menu opens a new, empty copy of the current 
table.  

To use the Fresh Table option: 

Click on the File menu Fresh Table option or click on the Fresh Table icon. 
Your current sample size table will remain open in nQuery, and a new, empty 
version of the current sample size table will appear.  

The new table will be identified with a higher number than the first table. For 
example, if the first table was MTC0U-1, the second table will be MTC0U-2. 

Close 
The Close option on the File menu closes the active sample size table.  

To use the Close option: 

Click on the File menu Close option. The current sample size table will close. 

Save   
The Save option on the File menu saves the active sample size table.  

To use the Save option: 

Click on the File menu Save option or the Save icon. If you have not saved this 
sample size table previously, you will be prompted to give a name and a 
directory for the file.  

After you enter a directory and name for the file, click on OK. 

Save As 
The Save As option on the File menu prompts you for a name for the file and saves 
the active sample size table.  

To use the Save As option: 

Click on the File menu Save As option. You will be prompted to give a name 
and a directory for the file.  
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After you enter a directory and a name for the file, click on OK. 

Print    
The Print option on the File menu will print your sample size table, including its 
title, the row names, and the column values; it also allows printing of attached side 
tables, and any saved notes or sample size justification statements. 

To use the File menu Print option:  

Create a sample size table and enter row values in at least one column of the 
table. 

Click on the File menu Print option or the Print icon. The nQuery Advisor 
Printing dialog box will appear. 

 

The dialog box gives you five check boxes. The table and references options are 
always active. The side table option is active when you have an active side 
table. The notes and statements options are active whenever you have 
information in the Notes and Statements panes. 

You can click in a check box to choose the nQuery Advisor table, the nQuery 
Advisor statements, nQuery Advisor notes, nQuery Advisor sid -tables 
connected with the main table, and/or nQuery Advisor references. Check your 
preferred items and the OK button becomes active. 

Click OK.  
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The Windows Print dialog box will appear.  

Click OK to send your selected items to the printer. 

Print Active View 
The File menu Print Active View option will print whichever pane has the focus, 
whether the table, the notes, the statements, or the guide cards. Thus, this option is 
essentially the same as the Print option in the right-click menu. This option is not 
active for side tables; they have their own Print button.  

Print Table to Clipboard 
The Print Table to Clipboard option on the File menu copies your complete sample 
size table, including Greek letters and equations, to the Clipboard as a table in RTF 
format. The table in the Clipboard will include the table title, the row names and all 
column values with tabs between columns.   
Note:  When the active table is a side table, you can use the Print Table to 

Clipboard option to copy the side table to the Clipboard as a table. 

You can use this option for later pasting into various Windows applications. For 
example, you might want to paste the complete table into Microsoft Word or 
WordPerfect or into a spreadsheet. The table is pasted into a word processing 
document as a table.  

To use the Print Table to Clipboard option: 

If you have more than one sample size table open, use the Window menu to 
make the desired table the current table. 

Select the File menu Print Table to Clipboard option.  

Or, you can right click in the table to bring up the right click menu, then 
click on the Print Table to Clipboard option.  

The Font selection for pasting dialog box will appear. 
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The default font is the Arial font. To select a different font, click on Select font 
for pasting into external documents. The Font for pasting into external 
documents dialog box will appear.  
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The default font, Arial, will be highlighted. Select the font and font size you 
prefer and click on OK.  Symbols will appear in the document in Windows 
symbol font.  

In the Font selection for pasting box, click on the OK, Complete Copy button. 

The current table will be sent to the clipboard for use with other programs. 

Move to a word processing document and paste the contents of the clipboard 
into the document. 

Note:  Print Table to Clipboard will copy the Greek letters and any equations 
used in the table. When you paste the contents of the clipboard into 
Microsoft Word, Word Perfect, or another word processing program, 
your document will display the contents of the table faithfully. If you 
want to paste the table contents into a spreadsheet, you should first 
paste into a word processing document. Then copy from that document 
and paste into the spreadsheet.  

If you are interested in copying Notes, Statements, or References to Clipboard, 
these panes have a right-click menu containing a Copy option. For details, see the 
Copy option described in Chapter 4, The Edit Menu. 
If you want to copy the contents of the Guide card to Clipboard, you can use the 
guide card right-click menu containing a Copy option. For details, see the Guide 
section of Chapter 7, The View and Windows Menus.  

Using the Right-Click Menu to Print the Table 
If you right click within the sample size table (or within other panes or views), you 
will get the right-click menu. The right-clicks menus will differ from each other, but 
all include a Print option. The right-click menu below is the menu for the sample 
size table.  

 

Choose the Print option, and you will see the usual Windows Print dialog box. 
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Printing the Sample Size Justification Statement  
There are several ways to print the customized statement for the selected column in 
the sample size table.  

To print a statement from the statement dialog box: 

Create a sample size table and enter row values in at least one column of the 
table. 

With your cursor in one cell of the filled column of the sample size table, you 
can create a statement in three ways: 

Click on the Create Statement icon . 

Click on the Edit menu Create Statement option. 

Right click within the sample size table to bring up the right-click menu, then 
click on the Create Statement option.  

The customized statement will appear.   

The statement will describe the results in the chosen column. For example: 

 

While you are viewing the statement, click on the Print button on the Statement 
window. 

The Print dialog box will appear. Click on OK to print the statement.  

To print a stored statement from the right-click menu: 

While you are viewing the statement, click on the Store button on the Statement 
window. The statement will be stored in the Statement pane of the sample size 
table window. 

Right click in the Stored Statements pane, and the Statements right-click menu 
will appear. 
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Choose the Print option, and the Windows Print dialog box will appear. 

To print a stored statement using the File menu Print Active View option: 

Left click in the Stored Statements pane. 

Choose the File menu Print Active View option.  

The Windows Print dialog box will appear. 

To print a stored statement and/or its table using File menu Print: 

Choose the File menu Print option, and you will see the following dialog box.  

 

Click on nQuery Advisor statements and click on OK. 

Whenever you have a stored statement, you can use the File menu Print option and 
this dialog box to print that statement. 

Exit 
The Exit option on the File menu shuts down the nQuery Advisor program. It also 
closes any open sample size tables.  
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To use the Exit option: 

Select the File menu Exit option or click in the X in the upper right hand corner 
of the table. 

If you have one or more open tables which have not been saved since the last 
change to the table, you will see the following prompt: 

 

Click on the Yes button to save the table. The Windows Save as dialog box will 
appear.  

Enter a name and directory for the file and click on OK. The nQuery Advisor 
program will shut down and save your file. 

Options Menu  
The Options menu provides three choices: 

 

Change Minimum Expected Cell Count 
The formulas for sample sizes for many of the proportions tables are designed for 
large samples.  The nQuery Advisor program checks that the minimum expected 
cell size (number of counts expected for each of successes and failures in a group) 
is greater than a preprogrammed default value.  

When you see the warning box stating that minimum expected cell size is not large 
enough, you must check that the sample size n which has been computed by Query 
Advisor will really be large enough for your study. For further details, see Example 
for Two group χ2 test (PTT0) and Sample Too Small Warning, in Chapter 15, 
Sample Size Tables for Proportions. In some cases, the minimum expected cell size 
used for the warning box may be too conservative. When that is the case, you may 
wish to customize the minimum cell count for the current session using the Change 
Minimum Expected Cell Count option. 
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To use the Change Minimum Expected Cell Count option for the current 
session: 

Click on Options menu, then on Change Minimum Expected Cell Count. The 
Change Minimum Expected Cell Size dialog box will appear. 

 

Enter the new minimum expected cell size for this proportion sample size 
table. Enter 0 if you do not want nQuery Advisor to check for minimum cell 
size. 

Click on OK. 

To change the Change Minimum Cell Size back to the default for the 
current session: 

Click on Options menu, then on Change Minimum Cell Count. The Change 
Minimum Cell Count dialog box will appear, showing your designated cell size. 

Click on Reset to Default. The dialog box will disappear and the minimum cell 
size will be the default minimum cell size. 

Auto Recalculation   
The Auto Recalculation option specifies the sample size table row to be recalculated 
as you make changes to your entries.  The Auto Recalculation option is a 
particularly handy toggle. You can turn it on when you want to edit or change 
numbers in columns that have been previously filled in.  

When Auto Recalculation is On, the specified row in any sample size table column 
will be recalculated as soon as you edit a number in the column and press <Enter>. 
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You can then see how the new entry will be reflected in the effect size, power, or n 
per group for tests. When you are working with confidence intervals, you will see 
the change in interval width or n per group.  

If you do not have the Auto Recalculation option On, you will be asked to select the 
row to be recalculated every time you change a value in a completed column.  

To use the Auto Recalculation option: 

Use the File menu New option to create a new sample size table or use the 
Open option to open a sample size table.  

Click on the Options menu Auto Recalculation option. The Set Automatic 
Recalculation dialog box for your sample size table will appear. The example 
below is the dialog box for a confidence interval table. 

 

The Click row for automatic recalculation field will display the rows 
available for recalculation for the current sample size table. Click on a row 
description to select it. 

 

The name of the selected row will appear in the Row selected for automatic 
recalculation field. The Auto On button will be enabled. 

Click on Auto On to turn on the auto recalculation and close the dialog box. 
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When Auto Recalc is On, you can use the Auto Recalculation while you are editing 
your sample size table. For example, you might have chosen Distance from mean 
to limit as the row to be automatically recalculated. This means that you can edit 
any other entry in the table, press <Enter> and automatically see the recalculated 
Distance from mean to limit for that column. 
Note: After you choose a row for recalculation and turn on Auto 

Recalculation, the row for the value to be recalculated will display 
green. Thus, you will always be aware of the row selected for Auto 
Recalculation. 

Note: You can view the status of the Auto Recalculation toggle at any time. 
As long as you have the Status Bar on, you can see the words AUTO 
RECALC ON or AUTO RECALC OFF in the lower status bar of your 
nQuery Advisor window. 

 
If the Auto Recalculation option is Off when you change a number in a calculated 
column of a sample size table, you will get a dialog box prompting you to specify 
the row to be recalculated.  You can also turn on the Auto Recalculation option at 
this point. 
Note:  Some unequal n’s tables for two-sample problems will not be as well-

behaved as the equal n’s tables with regard to the automatic 
recalculation of values. That is, some unequal n’s tables may simply 
recalculate one particular row rather than providing you with a choice 
of rows for recalculation. You should avoid setting the Auto 
Recalculation option to On when you have two-sample unequal n’s 
problems.  

Preferences 
When you choose the Options menu Preferences option, you get another menu with 
six options.  

 
Five of the options are toggles, and they are On by default. The sixth option brings 
up a dialog box. 
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Guide on by default 
When Guide on by default is checked (On), nQuery displays the guide card for 
every newly-opened sample size table. When Guide on by default is not checked 
(Off),  the change does not affect the current table. However, all tables opened in 
future will omit the display of the guide cards. 

To turn on the guide card after you have turned it off: 

Click on the View menu Guide option. The guide card pane will appear in the 
window. 

Respect regional settings 
When Respect regional settings is checked (On), nQuery displays numbers and 
dates according to the regional settings which are selected in your computer's 
Control Panel Regional Settings.  

When Respect regional settings is unchecked (Off), nQuery displays numbers and 
dates in standard U.S. English format regardless of any changes you may have made 
in the Control Panel Regional Settings.  That is, nQuery uses the period as the 
decimal symbol in number representations and the abbreviated date 
(month/day/year) in date representations. 

Maximize first table 
When Maximize first table is checked (On), the first table and subsequent tables 
displayed after opening nQuery will be maximized. That is, they will be expanded to 
fill the available space within the nQuery window.  When Maximize first table is 
unchecked (Off), tables will not be maximized.  Changing the toggle does not affect 
the display of tables during the rest of the current session.  

Give advice when program starts 
If Give advice when program starts is checked (On), nQuery displays the nQuery 
Advice window every time the program starts. 

Font for external pasting 
If you click on Font for external pasting, nQuery displays the Font for pasting 
into external documents dialog box. You can choose a font and a font size in that 
box. Your choice will be the default font for external pasting.  
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Display font choice reminder upon copy 
If Display font choice reminder upon copy is checked (On), nQuery displays the 
Font selection for pasting dialog box every time you select the copy option for 
sample size tables, side-tables, notes, statements, references, and guides.  



 

    
 

3-18 — The File and Options Menus 



The Edit Menu — 4-1 

4. The Edit Menu 
This chapter describes the Edit menu and its options. The Edit Menu provides 
eleven options for use in manipulating your sample size table. The options are: 

 

Undo 
The Undo option on the Edit menu allows you to undo your last action in the 
sample size table. 

To use the Undo option: 

Click on the Edit menu Undo option or use the Undo hotkey combination, 
<Ctrl><Z>. The last action will be undone. 

Clear... 
The Clear option on the Edit menu allows you to clear all data from the current 
sample size table. 

To use the Clear option: 

Click on the Clear option in the Edit menu. A message will appear, confirming 
that you want to clear the table. 

Click Yes to clear all data from the table. 
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Cut   
The Cut option on the Edit menu allows you to cut selected values from the current 
sample size table. Note that due to computational relationships among the rows, in 
some cases when you remove a value, the value will automatically be recomputed. 
For example, if your sample size table displays the difference between means, that 
difference will be automatically recalculated after you remove the difference value. 
Thus, it may be necessary to cut two or more values at once. In the case of a 
difference between two means, you must remove one mean along with the 
difference between means. 

To use the Cut option: 

To select cells for cutting, start with your cursor in one corner of the block of  
cells to be cut. Hold down the mouse button and drag the cursor across all cells 
containing values which you want to cut.  

Choose the Edit menu Cut option, the Cut icon, or the Cut hotkeycombination, 
<Ctrl><X>, to remove the cell contents from the table. 

Copy  
The Copy option on the Edit menu and in the right click menu for the table allows 
you to copy the values in selected cells from the current sample size table. Those 
values go into the Clipboard where they are available to be pasted into other 
columns or other tables.  
The Copy option on the Edit menu and in the right click menu for each pane also 
allows you to copy the text from the Guide Cards, User Notes, Statements, or 
References to paste into the notes or into external documents.   
As stated above, the Copy option copies only selected values. You may prefer to 
copy an entire table or side table in order to paste it into an external document. To 
print an entire table or side table, use the Print to Clipboard option in the File menu 
or in the table’s right click menu. 

To use the Copy option for specific values within the sample size table: 

To select cell(s) for copying, start with your cursor in a corner of the block of 
cells to be copied.  Hold down the mouse button and drag the cursor across all 
cells containing values which you want to copy.  

Choose the Copy option, the Copy icon, or the Copy hotkey combination, 
<Ctrl><C>, to copy the cell contents from the table. 
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When copying from a table, you are using a “smart” or formatted copy option. The 
Copy option “knows” the appropriate row for each cell copied. Thus, using the 
Paste option will paste cell values only into the appropriate rows.  To paste values 
into different rows, use the Paste Unformatted option.   

When you use Copy to copy numeric values from Notes, Statements, a sample size 
table with different row names, or another application, Copy is not a “smart” or 
formatted copy option. That is, the Paste option will paste cell values into the 
selected rows unless the values are out of range for the rows. In some cases, it will 
be necessary to use Paste Unformatted to paste in a value from a different table. 

To use the Copy option to copy the entire sample size table or side table: 

Click within the sample size table or side table, then click on the right mouse 
button to bring up the right click menu. Click on the Copy option to copy the 
entire sample size table to the clipboard. 

To use the Copy option within the Notes, Statements, References, or Guide 
Card panes: 

In Statements, References, and Guide Card panes, simply click the mouse in the 
pane. Then choose the Copy option, the Copy icon, the Copy hotkey 
combination, <Ctrl><C>, or the Copy option from the right-click menu to 
copy the selected contents or the entire contents of the pane. 

In Notes, use the cursor to select the text to be copied. Then choose the Copy 
option, the Copy icon, the Copy hotkey combination, <Ctrl><C>, or the Copy 
option from the right-click menu to copy the selected contents or the entire 
contents of the pane. 

Note: When you select the Copy option for the first time, you will see a 
dialog box stating that you can select the font you want to use for 
pasting.  For more details on your font options, see the discussion for 
the Options menu Preferences option in Chapter 3 The File and 
Options Menus. 

Whenever you use the Copy option, you can paste the copied information into 
another Windows application.  
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Rich Text Format 
The text in nQuery panes is in Rich Text Format, so formatting will be preserved 
when it is pasted into external documents.  In addition, you can select a default font 
and font size to be used for pasting. Greek symbols will paste in the symbol format 
in applications like Word. However, such symbols may show up as strange 
characters in Excel. To remedy this problem, paste the selection into Word, then 
copy and paste it into Excel. 

Paste  
The Paste option on the Edit menu allows you to paste cell values into the 
appropriate cells in your sample size table. You can access this option only after 
you have cut or copied the cell(s) containing values of interest. 

To use the Paste option within the sample size table: 

To use the Paste option, you should first use the Copy command to copy the 
contents of one or more sample size table cells to the Clipboard.  

In the current sample size table, select one cell of the column into which you 
want to paste. 

Choose the Edit menu Paste option, the right-click menu Paste option, the 
Paste icon, or the Paste hotkey combination, <Ctrl><V>.  

Note that there is no need to select a specific target cell, because the nQuery 
Advisor Paste option is a “smart” or formatted pasting option. This option 
automatically pastes each cell value into its appropriate row.  

For example, you might copy the Test significance from row 1 and sidedness 
from row 2 of column 1 in a t test sample size table. Then place your cursor in 
the cell in row 4, column 2. When you select Paste, nQuery Advisor pastes the 
number for Test significance into row 1, column 2, and the value for sidedness 
into row 2, column 2, disregarding the row position of the cursor. 

Note that, when you have copied values from your Notes pane or from a 
Windows application, you can paste those values into the cells of the sample 
size table when the values are appropriate.  
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To use the Paste option within the Notes, Statements, References or Guide 
Cards pane: 

Start by using the cursor to select the words or values to be copied, then use the 
Edit menu Copy option. The chosen information can come from an nQuery 
Advisor table, Notes, Statements, References or Guide Cards, or from a 
different program running under Windows. 

Choose the Edit menu  Paste option, the Paste icon, or the Paste hotkey 
combination, <Ctrl><V>, to paste the selected contents within the Notes. 

Paste Unformatted   
The Paste Unformatted option on the Edit menu pastes the contents of the 
clipboard into the selected cell(s). This paste option removes the information about 
the rows from which values were copied and pastes copied values into the current 
cursor position.  

Paste Unformatted vs. Paste 
The Paste option “knows” the correct row for each copied or pasted number. 
Regardless of the position of the cursor in the column, the Paste option pastes the 
cut or copied values into the appropriate rows. 
In contrast, the Paste Unformatted option starts by pasting the first value in the first 
selected cell, the second value in the next cell, etc. As it pastes, the Paste 
Unformatted option evaluates each value and accepts or rejects the value as 
acceptable for the selected cell.  
Since the Paste Unformatted option is simply pasting the number found in the 
clipboard, this option does not “know” where the number belongs. Thus, the 
program tries to paste the number at the selected cell in the sample size table. 
However, if you try to Paste Unformatted an inappropriate number, such as .05 in 
the row for Power, you will get an error message.   

To use the Paste Unformatted option within the sample size table: 

You must first use the Copy option to place some information in the Clipboard. 
That information can come from nQuery Advisor or from a different program 
running under Windows.  

Note that, when you have copied values from your Notes pane or from a 
Windows application, you can paste those values into the cells of the sample 
size table when the values are appropriate.  

Select the cell into which you want to paste the information. 
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Click on the Edit menu Paste Unformatted option, the Paste Unformatted 
icon, or the Paste Unformatted option in the sample size table right click 
menu. The contents of the Clipboard will be pasted into the selected location in 
your table. 

To use the Paste Unformatted option within the Notes pane: 

Start by copying the words or values to be copied. The chosen information can 
come from an nQuery Advisor table, Notes, Statements, References or Guide 
Cards or from a different program running under Windows. 

Click to place the cursor within the Notes or Statements pane. 

Choose the Paste Unformatted option or the Paste Unformatted icon to paste 
the selected contents within the Notes or Statements. 

Fill Right 
The Fill Right option on the Edit menu allows you to duplicate specific row values 
across all columns in the sample size table quickly and easily. You might, for 
example, fill in column 1. You can then select one or more contiguous rows in 
column 1 and use the Fill Right option to fill columns 2-20.  
The Fill Right option will fill only the cells in the same row as the selected cell. For 
example, you might want to set a significance level of .05 and a 2-sided test for all 
columns. Just enter .05 and 2 in the appropriate rows, then select those two rows 
and choose the Edit menu Fill Right option. Every column will display .05 and 2 in 
their respective rows.   

To use the Fill Right option: 

In the column of interest, select each cell to be duplicated across the row. If you 
are selecting more than one cell, drag the cursor across the contiguous cells to 
select them. 

Choose the Edit menu Fill Right option. The sample size table will fill all 
columns to the right with the information from the chosen column rows. 

Specify Multi-factor Table 
The Specify Multi-factor Table option on the Edit menu allows you to fill selected 
rows and columns of your sample size table with a range of specific row values. 
For example, you might want to fill in column rows for every combination of .01 
and .05 significance values, along with 1- and 2-tailed tests.  
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To use the Multi-factor Table option: 

Start with the sample size table of interest as the current table. 

Choose the Edit menu Multi-factor Table option and you get the Specify 
Multi-factor Table dialog box.  

 

In that dialog box, click on the name of one row which you want to propagate. 
The row name will appear in the top left box.  

Your cursor will be in the upper right box. Enter the first value for that row. 

 

Press <Enter>, and the new value will move to the lower box. Enter the second 
value and press <Enter>, etc.  
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When you have finished entering the values for that row, click on the Save Row 
button. Your choices will move to the Saved Rows and Values box. 

You can specify up to four rows. When you have finished entering information 
into this dialog box, click on OK.  

Your sample size table will appear with the designated rows filled in order. For 
example, consider choosing significance levels of .01, .025, and .05, with power 
equal to 80 and 90. The first column would display .01 and 80, the second .01 and 
90, the third .025 and 80, etc.  
When you have created your multi-factor table, you can finish the table by entering 
any remaining information into the sample size table. 

Create Statement 
The Create Statement option on the Edit menu allows you to view the customized 
sample size justification statement created by nQuery Advisor for any completed 
column in your sample size table.  

To use the Create Statement option: 

Fill in one column of a sample size table, letting the program calculate the last 
number.  

Place your cursor in any cell of the completed column on the sample size table. 

Choose the Edit menu Create Statement option, the right click menu Create 

Statement option, click on , the Statement icon, or right click in the Stored 
Statements panel and choose Create Statement.  
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A complete statement will appear in its own panel, describing the contents of 
that column. 

 

The Statement window has four buttons: Store, Print, To Clipboard, and 
Cancel. 

Store 
The Store button on the Statement window stores the statement for the selected 
column with the sample size table. If you click on the Store button on the 
Statement window, your statement will appear in the Stored Statements panel of 
the sample size table. The stored statement is linked to its sample size table.  
Since the statement has been linked to the sample size table, when you save the 
table, you save the statement with it. Thus, when you open the table later, you will 
see the stored statement in the Stored Statements pane. 
Note:  A stored statement is permanently associated with the sample size table 

and cannot be erased from the Stored Statements pane. However, new 
stored statements are appended below statements which have already 
been stored in the Stored Statements pane. If you are testing and 
evaluating different values in the sample size table, you might prefer to 
place your statements in the Notes pane so that you can edit them 
and/or reorder them and delete some. 

 To do that, use the Edit menu Create Statement option, and click on 
the To Clipboard button in the Statement dialog box.  Move to the 
sample size table and place the cursor in the Notes pane. Use the Edit 
menu Paste option to paste the statement into the Notes pane. You can 
compare statements in the Notes pane and later Cut any unnecessary 
statements. 

To print a stored statement: 

You can print your statement any time after you have stored it.  

To quickly print any stored statement, click in the Stored Statements pane and 
right click to bring up the right click menu. Click on the Print option, and you 
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will see the usual Windows Print dialog box. Click on OK to print only the 
contents of the Stored Statements pane. 

To print a stored statement plus the contents of other panes, select the File menu 
Print option, then click on the Print option. The nQuery Advisor Printing 
dialog box will appear. 

The nQuery Advisor Printing dialog box lets you choose to print the sample 
size table, as well as its associated notes and statement(s), along with any 
connected side tables. 

Print  
The Print button on the Statement window prints the customized statement for the 
selected column in the sample size table.  

To print a statement from the Statement window: 

While you are viewing the statement, click on the Print button on the Statement 
window. 

You will see the usual Windows Print dialog box. Click on OK to print only the 
contents of the Statement window. 

To Clipboard 
The To Clipboard button on the Statement window copies the displayed sample 
size justification statement to the Clipboard.  

To send the statement to the Clipboard from the Statement window: 

Click on the To Clipboard button. 

Note: When you select the To Clipboard option for the first time, you will 
see a dialog box stating that you can select the font you want to use for 
pasting.  For more details on your font options, see the discussion for 
the Options menu Preferences option in Chapter 3 The File and 
Options Menus. 

You can then paste the Clipboard contents into an external document document.  
The statements are in RTF (Rich Text Format) and you can choose the font to 
be used when the text is pasted into the document.  For applications like Word, 
formatting will appear as it does on the screen, and Greek symbols will appear 
using the Symbol font.  For some applications like Excel, if you paste a 
statement or table directly from nQuery Advisor, you will see strange symbols 
in place of the Greek symbols.  To remedy this problem, paste the selection into 
Word, then copy and paste it into Excel. 
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Cancel 
The Cancel button on the Statement window closes the Statement window without 
storing, printing, or saving the customized statement for the selected column in the 
sample size table. 

Edit Row Names 
The Edit Row Names option on the Edit menu allows you to change the names of 
particular rows, such as Group 1 and Group 2 in the table for the Two Group 
Student’s t test (MTT0).  This option is available only in certain sample size tables. 

To use the Edit Row Names option: 

Select the Edit menu Edit Row Names option. 

The Edit Row Name dialog box will appear. This box lists the row names that 
you can change in your sample size table.  

Note: The changeable rows will depend on the sample size table chosen. 

Click on a row name to bring the name to the editing field on the right side of 
the dialog box.  

 

Type the new name in the editing field. 

 

Click on the Accept Edit Row button.  

Click on the next row name to be changed, etc.  
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When you have finished changing the row names, click on the Update Table 
Row Name button. You will return to your table, updated with new row names. 
The new names which you see on screen will also appear in the printed version 
of the table and in any statements which you create. 

Note:   The editable section of each row name accepts a maximum of 20 
characters. 

Edit Column Names 
The Edit Column Names option on the Edit menu allows you to change the names 
of particular columns from 1, 2, etc. to names such as Outcome A, Outcome B, 
Low SD, High SD etc. The new names may include special characters. The new 
column names will appear in the printed tables, pasted tables, and plot legends.  

To use the Edit Column Names option: 

Place the cursor anywhere within the sample size table. 

Select the Edit menu Edit Column Names option or the right-click menu Edit 
Column Names option. 

The Edit Column Name dialog box will appear. This box lists the column 
names that you can change in your sample size table. Column names are 
restricted to a maximum of 25 characters each; the names will not wrap. 

 

Enter the new name and press <Enter> to move to the next column field.  
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When you have finished entering column names, click OK. You will return to your 
sample size table, updated with the new column names. 
You can use the Edit Column Name dialog box to copy a column name for 
pasting elsewhere.  

To copy column names and paste into different columns: 

Select the column name(s) to be copied and click on the Copy Name(s) button. 

Select the column(s) to be renamed, and click on the Paste Name(s) button. 

You can also use the Paste Name(s) button to paste names from other Windows 
programs. 

To paste column names from a Windows program: 

Make sure that you have one column name per line. 

Copy the column names in the Windows program. 

In the nQuery Edit Column Names dialog box, select the column(s) to be 
renamed, and click on the Paste Name(s) button. The names will be pasted into 
the column name boxes. 
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Special Characters 
The Special Characters option on the Edit menu provides Greek letters and other 
symbols which you may find useful in writing your notes. 

To use the Special Characters option: 

Start writing your notes in the Notes pane in the lower left area of your sample 
size table screen.  

When you get to a spot in your notes where you need a special character, 
choose the Edit menu Special Characters option or right click within the 
Notes pane to bring up the menu and choose Special Characters.  

The Characters dialog box will appear.  

        

Click on any single character in this box to select it. The Insert button becomes 
active. 

 

Click on the Insert button. The character will appear in your notes. 

You can Copy your Notes and paste the Clipboard contents into a word 
processor document.  

Note:  The notes may lose the Dixon font when pasted into an Excel 
document. Such a loss would change the Greek figures to strange 
characters. To remedy this problem, paste the selection into Word, then 
copy and paste it into Excel. 
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Using Right-Click Menu to Access Edit Options 
If you right click within the sample size table, you will get the right-click menu. The 
following example is the right-click menu for the sample size table. 

 

Choose any of the available Edit menu options: Undo, Copy, Cut, Paste, Paste 
Unformatted, Print, Print Table to Clipboard, Create Statement, Edit Row Names, or 
Edit Column Names. These Edit options function in the same way whether you 
access them from the Edit menu or through the right-click menu for the sample size 
table. 

Note that the right-click menus for the Guide Card, Statement, and User Notes panes 
differ from the menu shown above. Those right-click menu options include pane-
specific options, such as Special Characters in the User Notes pane, Hide in the 
Guide Card pane, and Create Statement in the Stored Statements pane. 
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5. The Assistants Menu 
This chapter describes the Assistants menu and its options.  
When you are in the first nQuery Advisor window, before you open a sample size 
window, the Assistants menu contains only three options. 
  

 
While you are working with a sample size table, the Assistants menu provides nine 
options to help you. 

 

Unequal n’s  
The Unequal n’s option on the Assistants menu allows you to change your chosen 
sample size table from the default equal n’s to unequal n’s. You can select the 
Unequal n’s version of your analysis type in either of two ways: 

• from the Study Goal and Design dialog box 
• from the current sample size table.  

Note that some sample size tables do not allow unequal n’s. When you choose 
those analyses, the Unequal n’s option will not be available. 
 
See Chapter 10, Unequal n’s, for detailed examples using unequal n’s. 



 

    
 

5-2 — The Assistants Menu 

 

To use the Unequal n’s option in the Study Goal and Design dialog box: 

Start in the Study Goal and Design dialog box.  

 

After you select the design for your sample size table, check the Unequal n’s 
box in the lower left corner of the Study Goal and Design dialog box. After you 
click on OK, your sample size table will appear, and it will be set up for 
unequal n’s.  

To use the Unequal n’s option from an existing sample size table: 

Start with your chosen sample size table as the active window.  

Select the Assistants menu Unequal n’s option or  the Unequal n’s icon. 
You will obtain a new unequal n’s sample size table for your goal, design, and 
analysis. 
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Finite Population Adjustment 
The Finite Population Adjustment option on the Assistants menu allows you to 
make inferences to populations with a specified number of subjects. You can select 
the Finite Population version of your analysis type in either of two ways:  

• from the Study Goal and Design dialog box 
• from the current sample size table. 

For full details on the use of this option, see Chapter 19, Sampling from Finite 
Populations. 

Note that most sample size tables do not have a version allowing the use of the 
Finite Population option. When you choose those analyses, the Finite Population 
option will not be active. 

To use the Finite Population Adjustment option in the Study Goal and 
Design dialog box: 

Start in the Study Goal and Design dialog box.  

 

After you select the design for your sample size table, check the Finite Population 
Adjustment box in the lower left corner of the Study Goal and Design dialog box. 
After you click on OK, your sample size table will appear, and it will be set up for 
finite population adjustment.  
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To use the Finite Population Adjustment option from an existing sample 
size table: 

Start with your chosen sample size table as the active window.  

Select the Assistants menu Finite Population Adjustment option. You will 
obtain a new finite population adjustment sample size table for your goal, 
design, and analysis. 

Data Entry 
The Data Entry option on the Assistants menu allows you to enter a small data set 
to compute mean and standard deviation. See the full description of Data Entry in 
Chapter 9, Determining a Value for Standard Deviation and an example of its use 
in Chapter 18, Regression Tables. 
The Estimate SD option provides an alternate route to the Data Entry table. Select 
the Assistants menu Estimate SD option, then select the For specified values 
option, and the Data Entry table will appear.  

Compute Effect Size  
For sample size tables requiring input of multiple outcome parameters, the 
Compute Effect Size option brings up a side table specific to the current sample 
size table. The Compute Effect Size option in the Assistants menu provides 
automatic calculations of effect sizefrom user input of expected outcome 
parameters and design features. For example, Compute Effect size will 
automatically calculate:  

♦  an effect size from the expected group means for one-way and two-way 
analysis of variance, and repeated measures analysis of variance 

♦  an expected contrast value from group means and contrast coefficients for 
analyses of contrasts 

♦  effect sizes from expected proportions for paired and multi-group designs 

♦  effect sizes from the components of agreement measures 

The Compute Effect Size option will incorporate unequal sample size ratios in the 
computation of effect sizes for sample size tables allowing unequal n’s.  In 
addition, the Compute Effect Size option allows user input of accrual, hazard, 
survival, and dropout rates to be used in simulation of power for the log rank test. 
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Side Table Access 
To bring up a side table for the current sample size table, use the Assistants menu 
Compute Effects Size option.   

To use the Compute Effect Size option: 
Create a sample size table and enter the number of groups or factors. If the table 
is one that allows you to compute effect size, the Compute Effect Size option 
will be accessible in the Assistants menu. Both the menu option and the icon 
button will be active. 

Click on the Assistants menu Compute Effect Size option. If you have not yet 
entered the necessary values in your sample size table, you may see a prompt 
reminding you to enter the number of groups or factors. 

 

After you have entered the appropriate values in your sample size table, 
choosing the Compute Effect Size option brings up the Compute Effect Size 
side table. The structure of the side table will be specific to your chosen sample 
size table.  

The example side table below is for the two-way analysis of variance with two 
levels for factor A and three levels for factor B.  

Note:  Side tables for kappa, concordance, and McNemar's test need no 
design parameter; most other tables require specification of the number 
of groups. 
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The title bar of the Compute Effect Size side table displays the name of the 
sample size table. The title bar also specifies the column for which the effect 
size is being computed. 

Use the dialog box to enter the values necessary for computing effect sizes.  

 

When you have finished entering the means, the Compute button will be 
enabled. Click on the Compute button to make the calculation. 

Note:  Some Compute Effect Size dialog boxes do not include a Compute 
button. Those boxes perform the calculation automatically as soon as 
you have entered all necessary values.  

 

After the effect size has been calculated, the Transfer button will be enabled.  

Click on the Transfer button. The effect(s) will be written to the appropriate 
cells of your sample size table, and the focus will return to the main sample size 
table. 



    
 

The Assistants Menu — 5-7 

Note: Side tables with the MTT2, the PTT4, and the STT3 sample size tables 
behave in a different manner. You start with the sample size table and 
enter the number of levels or strata. Select the Assistants menu 
Compute Effect Size menu to bring up the side table. After you fill out 
the side table and click on the Transfer button, the side table name will 
be inserted into the Side table name row in the sample size table. You 
can then copy and paste the Side table name to other columns. Note 
that the information in the side table will be available to the main table, 
but will not be displayed in that sample size table. For details, refer to 
Example for MTT2 in Chapter 14 and Example 7 for PTT4 in Chapter 
15, and Examples 4, 5, and 6 for STT3 in Chapter 16. 

Unless you close the effect size side table, it will remain available. You can 
come back to the side table to edit it, print it alone, or print it with the main 
table. You can also copy the entire side table and paste it into user notes or an 
external document by using the Print Table to Clipboard options in the side-
table right click menu.  When you save the main sample size table, the 
associated side tables will be saved with it.  

Effect size side table tutorial 
In Chapter 12, Side Tables/Compute Effect Size, you will find a detailed tutorial on 
using effect size side tables.  This tutorial explains the functions of the side table 
buttons:  Compute, Transfer, Close, Restore, Clear, Cut, Copy, Paste, and Print.  It 
also explains the functions available in the side table right-click menu options: 
Copy, Cut, Paste, Print, Print Table to Clipboard. 
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Sample Size Tables Offering Side Tables 
The following is a list of nQuery Advisor sample size tables which have a side 
table to assist you in entering parameters describing the effect size in your study.  
A few of these side tables operate like ordinary sample size tables, but most 
operate like the special side tables described in the preceding pages. The following 
list uses the nQuery Advisor shorthand description for each of these sample size 
tables. 

MOT2 Univariate one-way repeated measures analysis of variance 

MOT3 One-way repeated measures contrast 

MOT4 Univariate one-way repeated measures ANOVA (Greenhouse-Geisser) 

MOC4 Confidence interval for one-way repeated measures contrast 

MTT1 Wilcoxon/Mann-Whitney rank sum test (continuous outcome) 

MTT2 Wilcoxon/Mann-Whitney rank sum test (ordered categories) 

MTT3 Two-group univariate repeated measures ANOVA (Greenhouse-Geisser) 

MGT0 One-way analysis of variance (equal or unequal n’s) 

MGT1 Contrast in one-way analysis of variance (equal or unequal n’s) 

MGT2 Two-way analysis of variance (equal n’s) 

MGC0 Confidence interval for one-way contrast (equal or unequal n’s) 

MGC1 Confidence interval for one-way contrast (coverage probability) (equal 
or unequal n’s) 

POT1 McNemar’s test (χχχχ2) of equality of paired proportions 

POT1x Exact sign test of equality of paired proportions 

POT2   Chi-square test of specified proportions in C categories 

POE1   Paired test of equivalence in proportions using confidence interval:  a) 
Lower confidence limit for difference in paired proportions (simulation), 
b) Upper confidence limit for difference in paired proportions 
(simulation), c) Two-sided confidence limits for difference in paired 
proportions (simulation) 

POC1 Confidence interval for odds ratio of paired proportions 

PTT3 Two-group Chi-square test comparing proportions in C categories 

PTT4 Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S strata (with 
and without continuity correction) 

PGT0 χχχχ2 for G x 2 table (equal or unequal n’s) 

PGT1 Test for linear trend in G x 2 table—logistic model (equal or unequal 
n’s) 
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PGT2 G-group Chi-square test comparing proportions in C categories (equal 
or unequal n's) 

STT3 Log-rank test, user-specified survival rates, accrual, dropout 
(simulation) 

AOT0 Agreement between two dichotomous ratings (intraclass Kappa) 

AOT2 Large sample test that Lin’s Concordance Coefficient = ΚΚΚΚ0 

AOC0 Confidence interval for intraclass Kappa 

AOC2 One-sided large sample confidence interval for Lin’s Concordance 
Coefficient 

For details on the side table for each of these sample size tables, see the Side 
Tables topic in the online Help system. 

Conversion between Parameters 
The Conversion between Parameters option on the Assistants menu provides a 
conversion to alternate rates for exponential survival curves. This option is available 
only for the survival tables: STT0, STT1, STT2, STT3. 

Examples 2 and 3 in Chapter 16 Survival Analysis Tables illustrate how to use this 
Conversion between Parameters table in connection with the Survival Analysis 
tables.  

To use the Conversion between Parameters option: 

Create a sample size table for comparison of survival curves. You might use 
STT1, the two-group test of equal exponential survival. 

Select the Assistants menu Conversion between Parameters option. You will 
see the sample size table for Conversion to Alternate Rates for Exponential 
Survival Curves. 
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Suppose you want to find the exponential parameters corresponding to one-year 
survival rates of 90% and of 70%. 

Enter 1 in the Time row and press <Enter>. 

For each group, you can enter proportion, median survival or exponential 
parameter. The table will calculate the remaining two values for the group. For 
example, if you enter .9 for Group 1 proportion, the table will immediately 
show: 

 

If you enter .7 for Group 2 proportion, the table will immediately show: 

 

This table can also be used to convert median survival values to survival 
proportions or exponential rates.  You can also use this table to find out what 
survival proportions or median survival values correspond to specific 
exponential parameters. 

See Examples 2 and 3 in Chapter 16, Survival Analysis Tables, for details of how to 
copy information from this table to the Survival Analysis tables. 
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Estimate SD  
The Estimate SD option on the Assistants menu provides a way to estimate the 
standard deviation of a variable from other information. The Estimate SD options 
allow you to calculate an estimate of the standard deviation from: the standard 
error, SD1 and SD2 (pooled SD), the range, percentiles, coefficient of variation, 
upper confidence limit, pre and post standard deviations and the correlation 
coefficient, or for cluster sampling from between and within cluster variances, for 
specified x values, and for the standard deviation of residuals (errors).  
This section describes the Estimate SD option in general terms.   
Note:  The Estimate SD menu leads to ten different dialog boxes. See Chapter 

9 for details and examples of the use of each of the ten dialog boxes 
used for estimating the standard deviation. 

To use the Estimate SD option: 

Choose Estimate SD on the Assistants menu.  

The Estimate Standard Deviation dialog box will appear.  

 

Click on the radio button beside the method you need, then click on OK. The 
estimation dialog box will appear for your chosen method.  

See Chapter 9, Determining a value for Standard Deviation for examples. 
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Specify SIGMA, Covariance Matrix  
For tables MTT3, Two-group univariate repeated measures ANOVA (Greenhouse-Geisser), 
and MOT4, Univariate one-way repeated measures ANOVA (Greenhouse-Geisser), you 
must specify the covariance matrix for the repeated measures. Use the Specify Covariance 
Matrix button to specify the structure of the covariance matrix and to compute and transfer 
the within-group error term and the Greenhouse-Geisser correction terms. Use of this option 
is described in Chapter 9, Determining a Value for Standard Deviation.  See also Example 
7 in Chapter 13, Repeated Measures and Crossover Designs.  

To use the Specify Covariance Matrix option: 

In MTT3 [Two-group univariate repeated measures ANOVA (Greenhouse-
Geisser correction)] or MOT4 [Univariate one-way repeated measures analysis 
of variance (Greenhouse-Geisser approximation)], choose Specify Covariance 
Matrix on the Assistants menu or click on the Specify Covariance Matrix 
button.  

The Aid (SIGMA) dialog box will appear.  

 

Click in the radio button to choose Specify standard deviations and correlations 
or Specify full covariance matrix. 

For details, see Chapter 9, Determining a Value for Standard Deviation. 
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Distribution Functions 
The Study Goal and Design dialog box offers you a wide range of analysis designs. 
However, statistically sophisticated users may be planning a design or analysis not 
presented in the dialog box. If you have a formula for some sample size problem 
that nQuery Advisor does not automatically cover, you can go beyond the default 
designs. You can obtain distribution function values to insert in your own sample 
size equation by choosing the appropriate distribution function from the 
Distribution Function Menu option in the Assistants menu.  

To use the Distribution Function Menu option: 

Select the Assistants menu Distribution Function Menu option to specify that 
you want to create a distribution function sample size table.  

The Distribution Function Menu dialog box will appear, giving you a choice of 
eight possible distributions. 

 

To use the Distribution Function Menu Dialog Box: 

Click on the radio button beside the distribution name, then click OK to obtain 
the distribution function table. The table specialized for your chosen 
distribution will appear. 

See Chapter 20, Distribution Function Tables, for more details. 
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Windows Calculator 
The Assistants menu includes an easy path to the Microsoft Windows Calculator. 

To call up the Windows Calculator: 

Select the Assistants menu Windows Calculator option. The Windows 
Calculator will appear. 

Use the calculator as necessary. You can copy the result to the Clipboard using 
the Edit menu Copy option, then use the Edit menu Paste option to paste the 
value into your sample size table.  

Note:  The Windows Calculator View menu allows you to choose the 
scientific calculator or the standard calculator. 

When you have finished using the Windows calculator, click on the gray square in 
the upper left corner to close that window. You will return to nQuery Advisor.  
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6. The Plot Menu 
The Plot menu on the sample size table has three options:  

. 

This chapter discusses the first two options in detail. For an example using the Plot 
Survival vs time option, see Chapter 16, Survival Analysis Tables, Example 7. 

To use one of the first two options, highlight one to four completed columns in a 
sample size table and select one of these options from the Plot menu or click on one 
of the two plot buttons on the toolbar.  The first option, Plot Power vs n, provides 
an automatic plot of power on the Y-axis (scaled from 50 to 100%) versus sample 
size (n or N) on the X-axis.  The second option, Plot User-selected rows, allows 
you to select any of the yellow calculable rows (effect size or interval width, power, 
sample size) to plot on the Y-axis and one of the other rows in the table to plot on 
the X-axis.  You must specify the range of values to plot for X. 

You have considerable flexibility in changing the look of the plot. You can change 
the plot legend directly (see Example 1) or by editing the column names in the table 
(see Example 1).  You can change the text or font size or color for the table title or 
axis labels (see Examples 1, 2, 5).  You can change the attributes of the plotted lines 
(see Example 3) and the plot area background (see Example 3).  You can choose the 
way you want your printed plot to look (see Example 4) or paste the plot file into a 
document (see Example 5). 

Example 1 
Plot Power vs. n for MOT1 

To use the Plot Power vs n option:  

We start with the example for the paired t-test  (MOT1) from Chapter 8. We 
have specified one additional column in which α=.01. 
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First we change the column names so that our plot will be appropriately labeled. 

Since we prefer to identify these columns with the significance level, we want 
to use α, a Greek letter, in the column name. To use Greek letters in column 
names, we first build our column names in the Notes panel.  

Right click within the Notes panel to bring up the right click menu. 

 

Select the Special Characters option and click on α. 

 

Click on the Insert button, and the Greek letter α appears in the Notes panel. 
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Finish writing the column name, αααα=0.50 (2) δδδδ=0.5721. 

Copy the first column name in preparation for pasting it into the Edit Column 
Names dialog box. 

Right click on the sample size table to bring up the right click menu.  

Select the Edit Column Names option, and the Edit Column Names dialog box 
appears. 

 

To paste the new column name into the Edit Column Names dialog box, click 
on the first column name, then click on the Paste Name(s) button. 

Click on OK, and the column name appears in the sample size table.  

To use the first column name as the basis for the second, select the first name. 

First, copy the name: click on the Copy Name(s) button. 

Second, paste the name: select the second column name and click on the Paste 
Name(s) button. 

Double click on the second name to edit it. 

To begin the plot, highlight the two adjacent columns in your sample size table, 
then choose the Plot menu Plot Power vs n option or choose the Plot Power vs n 
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icon, . After you select Plot Power vs n, your power versus sample size 
plot will appear on your screen.  

 

To remove the characters “Column:” from the plot legend: 

Double click on the legend. The Legend Parameters dialog box will appear. 

 

Remove the characters you prefer to omit, then click OK to see the updated plot. 

Note:   The plot legend is limited to 40 characters. 
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Note that the Plot Power vs n option used in this example plots your results 
automatically.  In contrast, the Plot User-selected rows option allows you to choose 
the rows to plot, and you must specify a range for the X-axis parameter. 

Note:  For sample size tables in which n cannot be calculated, this automatic 
Plot Power vs n option is not available. However, you can still plot 
power versus n by choosing the Plot User-selected rows option, 
selecting power as the Y-axis, selecting n as the X-axis, and specifying 
a range for n. 

To change the title text or font on the plot: 

Double click on the title. The Text Parameters dialog box will appear.  
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You can use the Text Parameters box to edit the text, change the font, the font 
size, and the color of the text. 

To change text or font for an axis title on the plot: 

Double click on the axis label. The Text Parameters dialog box will appear.  

You can use the Text Parameters box to edit the text, change the font, the font 
size, and the color of the text. Make your changes and click OK to see the 
updated plot. 

To change text or font for an axis label on the plot: 

Double-click on the axis label. The appropriate Axis Labels dialog box will 
appear. 

Click on one of the radio buttons to specify Labels Position. 

Click on one of the radio buttons to specify Format as Decimal, Scientific, or 
Engineering. You can also determine the number of decimal places in each 
label by entering the number in the # Places box. 

Click on a radio button to specify the Last Label as On, Off, or Text. If you 
choose Off, the plot will appear without a label on the last tick mark. If you 
choose Text, you can enter a small amount of text as a label for the last tick 
mark. 

Example 2 
Plot User-selected rows for MOT1 

To use the Plot User-selected rows option to plot power vs. the mean 
difference:  

We use the example for the paired t-test  (MOT1) from Chapter 8. We have 
specified one additional column in which α=.01. See Example 1 above. 

Select the two adjacent columns in your sample size table, then choose the Plot 
menu Plot User-selected rows option or choose the Plot User-selected rows 

icon, . After you select Plot User-selected rows, the Specify Plot dialog 
box will appear. 
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This dialog box allows you to choose your preferred parameters for the Y- and 
X-axes. The Y-axis can be any calculable row highlighted by yellow in the 
table. The X-axis can be any other row with some exceptions.  For example, the 
X-axis cannot be a row such as 1 or 2 sided, number of groups, # of categories, 
side table name, # factors, etc. Also, if Y is an effect size row, then X cannot be 
a component of effect size, such as mean difference, since their relationship is 
unaffected by power or n.  

Note:  Since plots are based on only 7 points, and an automatic method is 
used for connecting points, plots with n on the Y-axis may not always 
appear monotone. 

For this example, click on Power for your Y-axis choice and Mean difference 
for your X-axis choice.  

Specify a range from 2 to 4 in the Plot from and To fields. The dialog box will 
display your choices. 
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Click on the OK button to create the plot. 

 

To edit the X-axis label: 

Since we prefer to include Greek letters in the X-axis label, we first build our 
label in the Notes panel.  

Move to the MOT1 sample size table and right click within the Notes panel to 
bring up the right click menu. 
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Select the Special Characters option and click on µ. 

 

Click on the Insert button, and the Greek letter µ appears in the Notes panel. 

 

Finish writing the X-axis label, µd=µ1-µ2. 

When you have the equation written properly, copy the equation. 

Move to the plot. In the plot, double click on the X-axis label. The Text 
Parameters dialog box will appear. 
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Paste the new equation in the Text field in place of “Mean Difference, Group 1 
minus Group 2.” Click on OK to see the updated plot. 

 

You can easily go back to your nQuery table and request another plot. 

Note:  Additional prompts appear occasionally. 
Sometimes you will see the Edit/Recalculation dialog box after 
selecting the parameters for the X- and Y- axes. If you see that dialog 
box, just click on the OK button to complete the plot.  (It may be 
necessary to click on it several times.) 

You may see a Power too high message as shown in Example 3. Just 
click on the OK button each time to complete the plot. 

Example 3 
Plot User-selected rows for MTT0  

To use the Plot User-selected rows option to plot power vs. effect size:  

We use the example for the group t-test  (MTT0) from Chapter 2.  
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To begin the plot, highlight the first column and choose the Plot menu Plot 

User-selected rows option or choose the Plot User-selected rows icon, . 
After you select Plot User-selected rows, the Specify Plot dialog box will 
appear.  

Select Power for the Y-axis and Effect size for the X-axis. Enter a range of .5 
to 1.5 for the X-axis.  

 

Click on the OK button. When power is very high for X values in the specified 
range, you may see the following power dialog box one or more times; simply 
click on OK each time and the plot will appear on your screen. 
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Click on the OK button, and your power versus effect size plot will appear on 
your screen.  

 

To change the dotted line to a solid line: 

Double click on the line to bring up the Plot Parameters dialog box. 

 

Click on the Line Attributes button to bring up the Line Parameters dialog 
box. 
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In the Style field, choose Solid, and in the Width field choose 2. Click on OK 
in each dialog box to see the plot with the updated line. 

 

To change the plot background to off white: 

Click on the Graphs menu Parameters option to bring up the Graph 
Parameters dialog box. 

 

In the Plotting Area Color field, select Off White. Click OK to view the 
completed plot. 



 

    
 

6-14  —  The Plot Menu 

 

Example 4 
Plot User-selected rows for PTT0  

To use the Plot User-selected rows option to plot n versus the odds ratio:  

We use the example for the two group χ2 test (PTT0) from Example 3 in 
Chapter 15.  

 

Select both columns and choose the Plot menu Plot User-selected rows option 

or the Plot User-selected rows icon, . The Specify Plot dialog box will 
appear. 

Select Power for the Y-axis and Odds ratio for the X-axis.  

Enter an X-axis range from 1.0 to 3.0.  
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Click on the OK button to create the plot. 

 

Note:  Since plots are based on only 7 points and an automatic method is used 
for connecting points, plots with n on the Y-axis may not always 
appear monotone. 

To print the plot: 

Select the File menu Print current page option. Using the default settings, the 
printed plot will be white and will appear similar to the following plot. This is a 
reduced version of an actual landscape printed plot that fills up the entire page. 
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Note:  The default settings cause the plot to print without the plot area 
background.  

To print the plot with the plotting area background: 

Choose the File menu Printing Options option to bring up the Print 
Parameters dialog box. 

Click in the check box Plotting Area Background checkbox. 

Click on OK, and your printed plot will look like the following plot. This is a 
reduced version of an actual landscape printed plot that fills up the entire page. 
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Example 5 
Plot User-selected rows for MTC1 

To use the Plot User-selected rows option to plot interval width versus n:  

We use the example for the two-sample confidence interval (MTC1) from 
Example 2 in Chapter 8.  

 

To plot these columns: 

Select the filled column and choose the Plot menu Plot User-selected rows 

option or the Plot User-selected rows icon, . The Specify Plot dialog box 
will appear. 

Select Distance from difference to limit for the Y-axis and n per group for 
the X-axis.  

Enter a range from 100 to 200 for the X-axis. 

 

Click on the OK button to create the plot. 
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To edit the legend: 

Double click on the legend to bring up the Legend parameters dialog box. 

 

In place of Column: 1, type 95% CI, 90% coverage. 

In place of Column: 2, type 95% CI, 80% coverage. 

Click OK to see the updated plot. 
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Note:   The plot legend is limited to 40 characters. 

To paste this plot into a document in a Windows application: 

Click on the Edit menu Copy option to copy the plot to the clipboard. 

Move to the document in the Windows application and click on the Edit menu 
Paste option. 

If you have the full Adobe Acrobat program, you can print your plots to pdf format 
for use alone or in other Windows applications. 

To print this plot to an Adobe Acrobat pdf document: 

Click on the menu Printer setup option to specify the use of Adobe acrobat 
rather than your usual printer. 

In the Printer Name field, change to Acrobat Distiller. 

 

Click OK. 

Select the File menu Print current page option. When prompted, specify a name 
and location for the file. 
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Plot File Menu 
The Plot File menu displays seven options for use with the plot: 

 

New 
The New option on the Plot window File menu brings up the Study Goal and Design 
box so that you can specify a new sample size table. 

Open 
The Open option on the Plot window File menu brings up the Open dialog box so 
that you can open an existing sample size table file. 

Save as Metafile 
The Save as Metafile option on the Plot window File menu allows you to save your 
plot as a Windows metafile, a file with the .emf extension. The .emf files can be 
inserted into Word documents. 

To use the Save as Metafile option: 

Select the File menu on the Plot window. 

Select the Save as Metafile option. The Save as Metafile dialog box appears. 

The default name will be a numbered plot, such as plot0.emf. Change the file 
name and directory as necessary. 

Click on OK to save the file. 
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Save as Old-style Metafile 
The Save as Old-style Metafile option on the Plot window File menu allows you to 
save your plot as an older type of Windows metafile, a file with the .wmf extension. 
The .wmf files can be inserted into Word documents. The .wmf files can also be 
converted to .jpg, .gif, .bmp, and other formats using a graphics conversion program 
such as Conversions Plus from DataViz. 

To use the Save as Old-style Metafile option: 

Select the File menu on the Plot window. 

Select the Save as Old-style Metafile option. The Save as Metafile dialog box 
appears. 

The default file name will be a numbered plot, such as plot0.wmf. Change the 
file name and directory as necessary. 

Click on OK to save the file. 

Print Current Page 
The Print Current Page option on the Plot window File menu allows you to send the 
current page to the printer.  

To use the Print Current Page option: 

Select the File menu on the Plot window. 

Select the Print Current Page option. The page will start to print, and you will 
see a dialog box allowing you to cancel the printing.  

Printer Setup 
The Printer Setup option on the Plot window File menu brings you to the usual 
Windows Printer Setup dialog box.  

Printing Options 
The Printing Options choice on the Plot window File menu provides a selection of 
printing options for your graph. 
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To use the Printing Options: 

Select the File menu on the Plot window. 

Select the Printing Options. The Print Parameters dialog box appears. 

 

Check the appropriate checkbox to choose backgrounds, border, and whether 
you want to maintain the aspect ratio.  

Click on a radio button to choose the printing style for your graph. 

We suggest that you add a check to the following options:  
• Plotting Area Background to get a background similar to that 

on the screen 
• Maintain Aspect Ratio to retain the ratio of the lengths of the x 

and y axes 
• Exact Size to print at the same size as the plot on the screen.  

Note:  By default, the Plotting Area Background box is not checked. This 
means that the plot will not print the background that you see on the 
screen. If you prefer to print the background, you must check Plotting 
Area Background. 

Then enter 20 in the Left % and Top % boxes. If you have also used the Printer 
Setup to select a Landscape setting, these choices will bring you a plot nicely 
centered in the middle of your page. The printed plot will display a gray 
background in the plotting area if you have kept the default setting for the 
plotting area background. 

Click on OK to finish specifying the printing options for the file. 

Choose Print Current Page to print the graph. 
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Summary of Ways to Print a Plot 
The nQuery Advisor program and the Windows interface offer four ways for you to 
print your plot. 

File Menu Print Option  
The File menu Print Current Page option will print your plot directly. 

File Menu Print Option Printing to PDF  
If you have Adobe Acrobat, and you first choose Acrobat Distiller as your printer, 
the File menu Print Current Page option will print your plot to an Acrobat pdf file. 

File Menu Save as Metafile Option 
The File menu Save as Metafile option  creates an .emf file which you can insert 
into other Windows applications for printing. 

File Menu Save as Old-style Metafile Option 
The File menu Save as Old-style Metafile option  creates a .wmf file which you can 
insert into other Windows applications for printing. 

Plot Edit Menu 
The Plot Edit menu provides one option for use while viewing a plot: 

 

Copy  
The Copy option on the Plot window Edit menu copies the graph to the Clipboard 
for use with other Windows programs.  

Plot Graphs Menu 
The Plot Graphs menu provides one option for use while viewing a plot: 
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Parameters 
The Parameters option on the Plot window Graphs menu offers several ways to 
customize your graph on the screen. 

To use the Parameters option: 

Select the Graphs menu on the Plot window. 

Select the Parameters option. The Graph Parameters dialog box appears. 

 

Enter a number into each of the Graph boxes: Left%, Top%, Width%, and 
Height%. These numbers determine the size and position of the graph in the 
Plot window. 

Enter a number into each of the Plotting Area boxes: Left%, Top%, Width%, 
and Height%. These numbers determine the size and position of the plotting 
area within the graph. 

Note:  The defaults in the figure above, combined with the Printing Options 
recommendations will produce pleasing graphs.  

You can also specify the color for the graph and a different color for the 
plotting area.  

Click on the Border Attributes  button if you want to bring up the Line 
Parameters dialog box.   
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You can use the Line Parameters box to specify the Color and Width for the 
border lines. Click OK when you finish specifying the line parameters. Note 
that the Style option has been disabled.  

Click OK when you have finished choosing your graph parameters. The graph 
will appear with your specifications. 

Plot Assistants Menu 
While viewing a plot, the Assistants menu allows you access to three of the usual 
nine Assistants menu options. For details on these options, see Chapter 5, The 
Assistants Menu. 

 

Editing Within the Plot 
The nQuery Advisor Plot window provides several additional ways to edit the 
contents of your plot. In general, when you want to edit a particular section of the 
plot, double click on that section. 

Edit Plot Text 
You can edit the text on your plot. You can also change the font style, color, and 
size.  

Note:  The default font is the Dixon font. This font will form special 
characters which you may find useful.  
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To edit a section of text, such as a title or axis label: 

Double click on the text on your plot. The Text Parameters dialog box will 
appear. 

 

Edit the words in the text by editing the Text field. If you want to use special 
characters, use the Notes pane of the sample size table to write those characters 
using the Special Characters option. See Example 2 in this chapter for an 
example using Greek characters in an axis title. 

Use the down arrow to choose a font in the Font field. 

Use the down arrow to choose a color for the text in the Color field. 

Use the down arrow to choose a size for the text in the Size field. 

Click to activate Bold, Italics, and/or Underline. 

When you have finished customizing the text, click OK. 

Edit Plot Axis Labels 
You can edit the axis labels on your plot. You can set the position, format, precision, 
as well as the text parameters. 

To edit an axis label: 

Double-click on the axis label. The appropriate Axis Labels dialog box will 
appear. 
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Click on one of the radio buttons to specify Labels Position. 

Click on one of the radio buttons to specify Format as Decimal, Scientific, or 
Engineering. You can also determine the number of decimal places in each 
label by entering the number in the # Places box. 

Click on a radio button to specify the Last Label as On, Off, or Text. If you 
choose Off, the plot will appear without a label on the last tick mark. If you 
choose Text, you can enter a small amount of text as a label for the last tick 
mark. 

To edit the text of the plot axis labels: 

Click on the Text Parameters button. The Text Parameters dialog box will 
appear.  

 

The Text field is disabled.  

Change the font in the Font field. 

Change the color in the Color field. 

Change the size in the Size field. 

Click in the appropriate check box to add bold, italics, and/or underline.  
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Click OK to close the Text Parameters dialog box. 

When you have finished customizing the tick mark labels, click OK. Your plot 
will display the changes. 

Edit Plot Parameters 
You can change the characteristics of the plotted lines in your graph.  

To edit a plotted line: 

Double click on the plotted line. The Plot Parameters dialog box will appear. 

 

Keep the default Spline, which draws a smooth curve through the plotted 
points, or click to remove the check in the Spline box. 

Click on the Fill Area box to change the plot to a fill area plot. 

If you want to change the plotted line itself, click on Line Attributes button to 
bring up the Line Parameters dialog box.  

 

 

You can use this box to change the color, style, and width of the plotted line. 
Click OK to close the Line Parameters dialog box. 

When you have finished customizing the plotted line, click OK. Your plot and 
the legend box will display the changes. 
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Edit Plot Legend Parameters 
You can change the characteristics of the legend in your graph.  

To edit the legend: 

Double click on the legend. The Legend Parameters dialog box will appear. 

 

Click in one or more of the Legend Rectangle fields and enter new numbers to 
change the size of the legend rectangle.  

Click on the down arrow in the Color field, then choose a color. 

Click to specify a border. You can then click on the Border Attributes button 
to bring up the Line Parameters dialog box.  

 

 

In this box, you can change the color, style, and width of the line. Click OK to 
close the Line Parameter box. 

In the lower left of the dialog box, you can see the legends themselves, although 
the special characters may not be recognizable.  You can edit them here; click 
to place your cursor, then edit. However, it is better to edit the legends in the 
Text Parameters dialog box. 
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To edit the text of the legends: 

Click on the Text Parameters button. The Text Parameters dialog box will 
appear.  

 

Edit the text in the Text field. You can then change the font, color, and size, 
adding bold, italics, and/or underline. 

Click OK to close the Text Parameters dialog box. 

When you have finished customizing the legend, click OK. Your plot legend 
box will display the changes. 

Note:   The plot legend is limited to 40 characters. 
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7. The View and Windows Menus 
This chapter describes the View and Windows menus and their options.  
The initial View menu contains only two options. The View menu which appears 
while you have an open sample size table offers three options. 

View Menu—Initial 
The initial View menu offers two toggle options: 

 

Toolbar 
The Toolbar option toggles between displaying and hiding the toolbar directly 
below the menu bar in the nQuery Advisor window. 

To use the Toolbar option: 

Choose the View menu.  

The Toolbar option is a toggle. If the Toolbar option has a check mark beside 
it, the toolbar is On and displayed in the nQuery Advisor window. When you 
select the On Toolbar option, the toolbar will disappear from the nQuery 
Advisor window.  

If the Toolbar option has no check mark beside it, the toolbar is Off and it is 
not displayed in the nQuery Advisor window. When you select the Off Toolbar 
option, the toolbar will appear in the nQuery Advisor window.  

Status Bar 
The Status Bar option toggles between displaying and hiding the status bar. The 
status bar lies at the bottom of your nQuery Advisor window. The bar displays a 
short description of each icon button as you select the icon button. The status bar 
also displays the status of the automatic recalculation option, along with the value of 
any cell selected by the cursor. Generally, the status bar will display more 
significant digits than appear in the sample size table cell. 
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To use the Status Bar option: 

Choose the View menu.  

If the Status Bar option has a check mark beside it, the Status Bar is On and 
displayed in the nQuery Advisor window. When you select the On Status Bar 
option, the status bar will disappear from the nQuery Advisor window.  

If the Status Bar option has no check mark beside it, the status bar is Off and it 
is not displayed in the nQuery Advisor window. When you select the Off Status 
Bar option, the status bar will appear at the bottom of the nQuery Advisor 
window.  

View Menu — From a Sample Size Table 
The View menu which you see while you are working with your sample size 
table is similar to the initial View menu. Both menus include the two toggle 
options, Toolbar and Status Bar. The working version of the View menu, 
however, also includes one additional option, Guide. 

 

Guide  
The Guide card option is a toggle which is available only when you have an open 
sample size table. When the Guide Card option in the View menu is checked 
(default), the guide card appears in the pane on the right side of the sample size 
table.   

The guide cards provide statistical information concerning the row in which your 
cursor lies. For example, the cards include information on limits for the values you 
can enter. Thus, if you have any questions concerning your input into the row of a 
sample size table, the guide card for that row will describe the contents of the row, 
as well as the acceptable entries.  

The guide card pane displays the name of the row in a blue heading, followed by the 
description of the row. The pane will include a Suggestion for appropriate use of the 
row, as well as the Acceptable entries for the row. Some panes include additional 
topics concerning the row, such as a Shortcut or a Special Feature.  
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As you move the cursor from row to row, the guide card displays the information 
appropriate for the designated row. This option is particularly useful if you have any 
question concerning your entry for the selected row. 

 

To use the Guide card option: 

In an open sample size table, click on a spreadsheet cell in the row of interest. 

If the Guide card is on, the sample size table will display the guide card for the 
selected row.  

Use the arrow keys to move the cursor to another row. The guide card will 
change to reflect your choice. 

To turn off the guide card, click on the View menu Guide option or right click 
on the guide card and choose the Hide option in the guide card menu. 

To copy the complete contents of the Guide card, retaining the guide card 
formatting for pasting into Windows applications: 

Right click on the guide card of interest. The guide card right click menu will 
appear. 

 

Click on the guide card menu Copy option. 
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The first time you select the Copy option from the guide card right click menu, 
you will see a message screen telling you how to change the font for the pasted 
text.  

 

Click OK Complete Copy to accept the default Arial font. 

If you prefer to select a different font, click on Select font for pasting into 
external documents. You will see the Font for pasting into external 
documents dialog box. 

 

Select a font and a font size, then click OK to print to the clipboard. 
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After you have selected the font you want, you can choose not to see the 
reminder box again by clicking in the checkbox for Don’t show this 
reminder dialog box again. Note that the symbols will appear in the 
Windows symbol font. 

You can change the selected font at any time by using the Option menu 
Preferences option, and selecting Font for External Pasting. You can choose 
to display the font reminder box again by selecting the Options menu 
Preferences option Display font choice reminder upon copy option. See 
Chapter 3.  The File and Options Menus for full details. 

After copying, move to your word processing program and use the Paste option 
to paste the contents of the clipboard.  The text below shows guide card 
contents pasted using the Arial font. 

Two-sample t-test (equal n's) 
Enter a value for alpha, α, the significance level for the t-test, and select a one or 
two-sided test.  Specify two of effect size, power and sample size and nQuery 
Advisor will compute the third. 
 

Test significance level, αααα 
Alpha is the probability of rejecting the null hypothesis of equal means when it is 
true (the probability of a Type I error). 
 

Suggestion: 
Enter 0.05, a frequent standard 
 

Acceptable entries: 
 0.001 to 0.20 
 

Shortcuts: 
To duplicate values across any row, see the Edit menu. 

 

To print the complete contents of the Guide card: 

Right-click on the guide card of interest. The guide card right click menu will 
appear. 

Click on the guide card menu Print option. The usual Windows Print dialog 
box will appear. Click on OK to print. 

Window Menu 
The Window menu performs the usual Window menu functions for Microsoft 
Windows. You can use it to move among the open sample size table windows. 
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New Window 
The New window option on the Window menu opens an exact duplicate of current 
sample size table complete with entered values. 

Cascade 
The Cascade option on the Window menu displays the open windows in nQuery 
Advisor in a staggered fashion. One window lies on top of the other, slightly offset 
so that you can view the table names. 

Tile 
The Tile option on the Window menu displays as much as possible of every open 
window in nQuery Advisor. This option tiles the nQuery Advisor window with the 
currently-open table windows. 

Arrange Icons 
The Arrange icons option on the Window menu will rearrange the icons for your 
minimized tables. You might use this option if you have several open tables and 
you minimize those tables. You can grab the table icons and move them around on 
the screen. After moving the icons, you can use the Arrange icons option to arrange 
the icons neatly. 

List of Open Tables 
The Window menu lists each table by its abbreviation title or if saved, by its file 
name.   
Note: The tables are initially listed by their table abbreviations. Please read 

the next section to understand the table abbreviations. 

Contents of Study Goal and Design Dialog Box 
The Study Goal and Design dialog box allows you to choose the sample size table 
you want to use.   
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The nQuery Advisor program provides a sample size table for more than 75 
different types of study plans. Codes will help you to find the analyses quickly.  

The first letter of the code represents a goal from the first column:  

 Means, Proportions, Survival, Agreement, or Regression. 

The second letter of the code represents the Number of Groups from the second 
column:  

 One, Two, or Greater than two. 

The third letter of the code represents the analysis method from the third column:  

 Test, Confidence Interval, or Equivalence. 

The fourth character in the code is the sequence number of the listed analyses, 
starting with 0.  

For example, in the screen above, the code for Two-sample t test is MTT0. Most 
combinations of choices offer one or more analysis types for your selection, but a 
few do not.  

Note that the Two-sample t test listing has a + sign beside it. In this case the sub-
listings have already been expanded, but for other such menu items, you can click 
on the + to see the sub-listings. 
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Unequal n’s 
If your chosen analysis type has an unequal n’s option, the Unequal n’s checkbox in 
the lower left of the Study Goal and Design dialog box will be enabled. If you want 
unequal n’s, click on the Unequal n’s checkbox and click OK.  

Finite Population 
If your chosen analysis type has a Finite Population option, the Finite Population 
checkbox in the lower left of the dialog box will be enabled. If you want to specify 
Finite Population, click on the Finite Population checkbox and click OK.  

The following tables have versions allowing for a finite population correction: 
MOT0, MOT1, MOC0, MOC1, MOC2, MOC3, POT0, POC0.  

Abbreviation Codes 
The abbreviation codes are: 

MOT0 One-group t test that a mean equals user-specified value 

MOT1 Paired t test of mean difference equal to zero 

MOT2 Univariate one-way repeated measures analysis of variance 
(constant correlation) 

MOT3 One-way repeated measures contrast (constant correlation) 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser approximation) 

MOC0 Confidence interval for mean based on z (n large) 

MOC1 Confidence interval for mean based on t (with coverage 
correction) 

MOC2 Confidence interval for difference in paired means based on z 
(n large) 

MOC3 Confidence interval for difference in paired means based on t 
(coverage correction) 

MOC4 Confidence interval for one-way repeated measures contrast 
(constant correlation) 

MOC5 Confidence interval for percentile of a normal distribution 

MOE0 Paired t test of equivalence of means 

MTT0 Two group t test of equal means (equal or unequal n’s) 
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MTT0uv Two group Satterthwaite t test of equal means (unequal 
variances) (equal or unequal n’s) 

MTT0cv Two group t test for fold change assuming log-normal 
distribution (equal or unequal n’s) 

MTT0fct Two group t test of equal fold change with fold change 
threshold (equal or unequal n’s) 

MTT1 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y)=.5 
(continuous outcome) 

MTT2 Wilcoxon (Mann-Whitney rank-sum test that P(X<Y)=.5 
(ordered categories) (equal or unequal n’s) 

MTT3 Two-group univariate repeated measures ANOVA 
(Greenhouse-Geisser correction) 

MTC0 Confidence interval for difference of two means based on z 
(large equal or unequal n’s) 

MTC1 Confidence interval for difference of two means (coverage 
probability) (equal or unequal n’s) 

MTE0 Two-group t test of equivalence in means (equal or unequal 
n’s) 

MTE1tg Two-group t test (TOST) of equivalence in means 

MTE1co t-tests (TOST) of equivalence in means for crossover design 

MTE2tg Two-group t-tests (TOST) for ratio of means (using log scale) 

MTE2co t-tests (TOST) of equivalence in ratio of means for crossover 
design (natural log scale) 

MTE3 Two-group t-tests (TOST) for ratio of means (using original 
scale) 

MTE4 Crossover design TOST for ratio of means (using original 
scale) 

MGT0 One-way analysis of variance (equal or unequal n’s) 

MGT1 Single one-way between means contrast (equal or unequal n’s) 

MGT2 Two-way analysis of variance 

MGC0 Confidence interval contrast between means (equal or unequal 
n’s) 

MGC1 Confidence interval for one-way contrast (large equal or 
unequal n’s) 

POT0 One group χχχχ2 2 2 2  test that proportion equals user specified value 
(normal approximation) 
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POT0x Exact test for single proportion. 

POT1 McNemar’s test (χχχχ2) of equality of paired proportions 

POT1x Exact sign test of equality of paired proportions 

POT2 Chi-square test of specified proportions in C categories 

POC0 Confidence interval for proportion using normal 
approximation (n large) 

POC1 Confidence interval for ln(ΨΨΨΨm), odds ratio for paired 
proportions (n large) 

POC2 Confidence interval for probability of observing a rare event. 

POE0 Paired test of equivalence in proportions (n large) 

POE1 Paired test of equivalence in proportions using confidence 
interval:  a) Lower confidence limit for difference in paired 
proportions (simulation), b) Upper confidence limit for 
difference in paired proportions (simulation), c) Two-sided 
confidence limits for difference in paired proportions 
(simulation) 

PTT0 Two-group χχχχ2222 test of equal proportions (odds ratio=1) (equal 
or unequal n’s) 

PTT0p Two-group χχχχ2222 test  of equal proportions (equal or unequal n’s) 

PTT1 Two-group continuity corrected χχχχ2222 test of equal proportions 
(odds ratio=1)  (equal or unequal n’s)))) 

PTT1p Two-group continuity corrected χχχχ2222 test of equal proportions 
(odds ratio=1)  (equal or unequal n’s)))) 

PTT2 Two-group Fisher’s exact test of equal proportions (odds 
ratio=1)(equal or unequal n’s) 

PTT3 Two-group Chi-square test comparing proportions in C 
categories 

PTT4 Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S 
strata 

PTT4cc Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S 
strata  
(continuity corrected) 

PTC0 Confidence interval for difference of two proportions (large 
equal or unequal n’s) 

PTC1 Confidence interval for difference of two proportions 
(continuity corrected) (large equal or unequal n’s) 

PTC2 Confidence interval for ln(ΨΨΨΨ)(large equal n’s) 
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PTE0 Two-group test of equivalence in proportions (large equal or 
unequal n’s) 

PTE1 Two group test of equivalence in proportions using confidence 
interval:  a) Lower confidence limit for difference in 
proportions (simulation), b) Upper confidence limit for 
difference in proportions (simulation), c) Two-sided 
confidence limits for difference in proportions (simulation) 
(equal or unequal n’s) 

PGT0 χχχχ2222 test of equal proportions in G groups (equal or unequal n’s) 

PGT1 Trend across proportions, logistic model (equal or unequal 
n’s) 

PGT2 G-group Chi-square test comparing proportions in C 
categories (equal or unequal n's) 

STT0 Log-rank test of survival in two groups followed for fixed 
time, constant hazard ratio 

STT1 Two-group test of equal exponential survival (n large) no 
dropouts 

STT2 Two-group test of equal exponential survival (n large), 
exponential dropout 

STT3 Log-rank test of survival in two groups, simulation with 
specified rates (equal or unequal n’s) 

AOT0 Agreement between two dichotomous ratings (intraclass 
kappa) 

AOT1 Correlation test that ρρρρ=ρρρρ0 for x and y bivariate normal 

AOT2 Large sample test that Lin’s concordance coefficient =ΚΚΚΚ0 

AOC0 Confidence interval for intraclass Kappa (n large) 

AOC1 One-sided confidence interval for ρρρρ for x and y bivariate 
normal 

AOC2 One-sided large sample confidence interval for concordance 
coefficient   

ROT0 Logistic regression, test that ββββ=0 for one normally distributed 
covariate, x 

ROT1 Logistic regression, test that ββββ=0 for one covariate, x, after 
adjustment for prior covariates 

ROT2 Linear regressiontest that ρ ρ ρ ρ=0 for one normally distributed 
covariate, x 

ROT3 Multiple linear regression, test that R2=0 for k normally 
distributed covariates 
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ROT4 Multiple linear regression, test 0 increase in R2 for B 
covariates adjusting for A covariates 

ROT5 Linear regression test that ββββ=ββββ0 for one x 

ROC0 Linear regression confidence interval for ββββ 

RTT0 Linear regression test that ββββ1=ββββ2 for one x 

RTC0 Linear regression confidence interval for ββββ1 -ββββ2 
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8. Sample Size Tables for Means 
The nQuery Advisor program provides a variety of sample size tables for 
determining sample size in problems where the group mean is the summary measure 
for analysis. To select the appropriate sample size table, you first identify: 

• the study design 

• one, two, or multiple groups 

• the intended analysis, test, confidence interval, or equivalence test.  

Sample size tables for most designs with two or more groups allow sample size 
computations for designs utilizing unequal sample sizes in the groups. For an 
example, see Chapter 10. 

For every sample size table used for analysis of group means, the nQuery Advisor 
program requires an estimate of the within-group standard deviation. If you need 
help in determining an estimate of the standard deviation, refer to Chapter 9. 

1. The most commonly used design for comparison of means is the two-group 
(independent sample) design.  

The most common analysis method is the two-group (two-sample) t test.  The 
nQuery Advisor table choice would be: 

MTT0 Two-group t test of equal means  
See Chapter 2, Tutorial, for a detailed tutorial on this table. 

2. Another common design is one in which each subject is tested under two 
conditions. The usual analysis is the paired t test when each subject is tested 
under two conditions or provides a pre and post measurement.   

MOT1 Paired t test of mean difference equal to zero  
See Example 1 later in this chapter. 

  

Sample Size Tables for Means in  
nQuery Advisor 

This section of the Sample Size Tables for Means chapter briefly outlines all sample 
size tables available for analysis of means and refers you to examples in the manual. 
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One-group Tests and Confidence Intervals 
MOT0 One group t test that a mean equals a user-specified value 

MOC0 Confidence interval for mean based on z (n large) 

MOC1 Confidence interval for mean based on t 
(with coverage probability) 

MOC5 Confidence interval for percentile of a normal distribution 
See Example 3 in this chapter. 

Versions of tables MOT0,  MOC0, MOC1, are available for sampling from finite 
populations. See Chapter 19, Sampling from Finite Populations, for details. 

Two-group Tests and Confidence Intervals 
MTT0 Two group t test of equal means 

See the example in Chapter 2, Tutorial. 
See this table used in a crossover design in Example 1 in 
Chapter 13, Repeated Measures and Crossover Designs. 

MTT0uv Two group Satterthwaite t-test of equal means (unequal 
variances) 

This table is for situations where a comparison between two 
means using the t-test would be applicable, but the variances for 
the two groups are expected to be unequal.   
See Example 4 in this chapter.  

MTT0cv Two group t-test for fold change assuming log-normal 
distribution  

This table is for situations where a comparison between two 
means using the t-test would be applicable, but the distribution 
is expected to be log-normal and the user wants to specify the 
expected fold-change and the CV rather than means and 
standard deviations after log transformation.   
This table is of special interest for planning and interpreting 
DNA microarray studies. 
See Example 5 in this chapter. 
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MTT0fct Two group t-test of equal fold change with fold change 

threshold 
This new table computes the probability of detection of 
specified fold-changes when the CV is specified and the result 
must exceed a specified fold-change threshold.  
This table is of special interest for planning and interpreting 
DNA microarray studies,  see Example 6 in this chapter. 

MTT1 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y)=0.5 
(continuous outcome) 

See example in Chapter 14, Nonparametric Tests 

MTT2 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y)=0.5  
(ordered categories) 

See example in Chapter 14, Nonparametric Tests. 

MTC0 Confidence interval for difference of two means based on z 

MTC1 Confidence interval for difference of two means (coverage 
probability)  

See Example 2 in this chapter. 

One and two group paired, crossover, & repeated 
measures designs, tests and confidence intervals 

MOT1 Paired t test of mean difference equal to zero 
See Example 1 in this chapter 

MOT2 Univariate one-way repeated measures analysis of variance 
(constant correlation) 

MOT3 One-way repeated measures contrast (constant correlation) 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser approximation) 

MOC2 Confidence interval for difference in paired means based on z 
(n large) 

MOC3 Confidence interval for difference in paired means based on t 
(coverage probability) 

MOC4 Confidence interval for one-way repeated measures contrast 
(constant correlation) 

MTT3 Two-group univariate repeated measures analysis of variance 
(Greenhouse-Geisser correction) 

See Example 7 in Chapter 13. 
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Versions of tables MOT1, MOC2, MOC3, are available for sampling from finite 
populations. See Chapter 19, Sampling from Finite Populations, for details. 

One and two group and crossover designs, 
equivalence and bio-equivalence tests 

MOE0 Paired t test of equivalence of means 

MTE0 Two-group t test of equivalence in means 
See Example 1 in Chapter 1, Demonstrating Equivalence. 

MTE1tg Two-group t tests (TOST) of equivalence in means fopr two-
group design 

See Examples 2 and 4 in Chapter 11, Demonstrating 
Equivalence.  

MTE1co t tests (TOST) of equivalence in means for crossover design 
See Example 3 in Chapter 11, Demonstrating Equivalence. 

MTE2tg Two-group t-tests (TOST) for ratio of means (using log scale)  
See Example 5 in Chapter 11, Demonstrating Equivalence. 

MTE2co t-tests (TOST) for ratio of means for crossover design  
(natural log scale)  
See Example 6 in Chapter 11, Demonstrating Equivalence. 

MTE3 Two-group t-tests (TOST) for ratio of means  
(using original scale)  

See Example7 in Chapter 11, Demonstrating Equivalence. 

MTE4 Crossover design TOST for ratio of means (using original scale)  
See Example 8 in Chapter 11, Demonstrating Equivalence. 

Multiple group tests and confidence intervals 
MGT0 One-way analysis of variance 

See Example 1 in Chapter 12, Analysis of Variance Tutorial. 

MGT1 Single One-way between means contrast  
See Example 3 in Chapter 12, Analysis of Variance Tutorial. 

MGT2 Two-way analysis of variance 

MGC0 Confidence interval contrast between means (large n’s) 

MGC1 Confidence interval for one-way contrast (with coverage  
probability) 
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Example 1  
Paired t test (MOT1) 

This chapter provides an example for a paired t test with an expected mean 
difference of zero. The example uses data from a cancer chemotherapy study. 

Patients with cancer receive repeated chemotherapy cycles. During each 
chemotherapy cycle, the number of neutrophils (a type of white blood cell ) 
decreases. “Neutropenia” occurs when the number of neutrophils decreases below a 
fixed cutoff value.  

The study plan is to compare a new therapy intended to reduce the number of days 
of neutropenia with a placebo. Each patient will receive the new therapy during one 
chemotherapy cycle and placebo during another chemotherapy cycle. (Although the 
study is to be a crossover study, we ignore that aspect of the design in the sample 
size planning for this example). 

The study will analyze the data using a 5% level, two-sided, paired t test to test the 
null hypothesis that the mean duration of neutropenia following the drug is the same 
as following the placebo. The investigator thinks it will be feasible to recruit 30 
patients and wants to know if that number of patients will provide adequate power. 

To bring up the correct sample size table: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select One group. 

Under Analysis method, select Test.  

The box in the lower portion of the Study Goal and Design box will display 
several design choices. The highlighted design is Paired t test for difference in 
means. 

Click on OK to accept the highlighted choice. 

You will get the sample size table for the Paired t test for difference in means. 
Your table will appear with no numbers. This example shows a table containing 
.05 in the test significance level row, 2 in the 1 or 2 sided test row, and 30 in the 
n row.  
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Information on duration of neutropenia is available from two sources:  

1)  A published study reported a median of eight days of neutropenia in a control 
chemotherapy period with median durations of three and four days for two 
combination therapies. 

2)  Pilot data from four patients receiving two cycles of chemotherapy with no 
treatment intervention showed median durations of about six days and a 
standard deviation of differences in duration between the two cycles of 7.5.  

Based on these data, the investigator wants to be able to detect a drop in the duration 
of neutropenia from six days for control to three days for the new therapy. The 
investigator decided to use a smaller estimate, 5.25, for the standard deviation of 
differences based on the information about range and standard deviation of 
neutropenia duration for a single period.  

Note: The investigator has customized row titles for the means. See Chapters 
2 and 3 for details on how to customize row names by selecting Edit 
Row Names from the Edit menu or the right click menu. 

 

After the investigator enters the values for the means and for the standard deviation 
of differences, nQuery solves for the effect size and the expected power, 85% in this 
case. 

nQuery Advisor provides automated customized sample size justification 
statements.   
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To obtain this statement and copy it to Notes or another Windows 
application: 

With the cursor in the column of interest, click on , the Create Statement 
button. The Statement dialog box will appear. 

 

When you have the statement for this column, click on the Statement window’s 
To Clipboard button to copy that statement. The Font selection for pasting 
dialog box will appear. 

 

You can use this dialog box to specify the font to be used to copy the Statement 
in Rich text Format. Click on the Select font for pasting into external 
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documents button. After you have selected a font, click on the OK, Complete 
Copy button. 

To paste the newly-copied statement to USER NOTES:  

Place the cursor in the USER NOTES pane and select the Edit menu Paste  
option or the Paste button or <Ctrl><V>.  

To paste to Windows application: Place the cursor in a Windows application 
and use that application’s Edit menu Paste option to paste the statement.  Using 
the default Arial font, the statement will look like this: 

A sample size of 30 will have 85% power to detect a difference in means 
of 3.000 (e.g. a Placebo mean, µ1, of 6.000 and a Treatment mean, µ2, of 
3.000), assuming a standard deviation of differences of 5.250, using a 
paired t-test with a 0.050 two-sided significance level. 

To paste a previously-stored statement into USER Notes for editing: 

Select the text in the Statements pane. 

Click on the Edit menu Copy option or the Copy button or <Ctrl><C>. 

Click to place the cursor in the desired location of the NOTES pane. 

Click on the Edit menu Paste option or the Paste button or <Ctrl><V> to paste 
the copied statement. 

You can print the user notes directly or copy them and paste them into a Windows 
document. Below we give an example showing a statement which has been pasted 
into the user notes and then edited. The user notes also contain information on the 
data from the published study. 

USER NOTES for MOT1-1 
____________________________________ 
A sample size of 30 will have 85% power to detect a difference in mean 
duration of neutropenia of 3 days (e.g. a mean duration of neutropenia 
under placebo of 6 days and a mean duration under the new drug of 3 
days), assuming a standard deviation of differences in duration of 5.250 
days, using a paired t-test with a 0.050 two-sided significance level. 
 
Data on duration of neutrophil count less than 0.5x 109/L in 50 cycles in 
36 patients from Brugger W. et al (1992) Sequential administration of 
interleukin-3 and granulocyte-macrophage colony-stimulating factor 
following standard dose combination chemotherapy with etopside, 
ifosamide, and cisplatin. J. ClinOncology 10:1452-1459. 
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To copy the User Notes for pasting into other Windows applications: 

Highlight the text you want to copy. 

Choose Copy from the Edit menu or the right click menu or click on the Copy 
icon in the toolbar. 

Example 2 
Two-sample Confidence Interval (MTC1) 
The following example illustrates the use of the tables for confidence interval for 
two groups. Consider a trial in which a Placebo, the current Standard drug, and a 
New Drug will all be compared for their ability to reduce blood pressure. The 
standard deviation for reduction in blood pressure is estimated from previous studies 
with the Standard drug as about 6mmHg. In the past, the Placebo has resulted in 
reductions of about 5mmHg, and the Standard drug in reductions of about 12 
mmHg.  

The study as a whole will be analyzed using a one-way analysis of variance. For 
details on analysis of variance, see the tutorial in Chapter 12.  

As one of their goals, the investigators wish to establish that the New Drug and the 
Standard provide essentially the same reduction in blood pressure. Two approaches 
are of interest in this study: 

A.  To obtain a very good estimate of any differences between the New Drug 
and the Standard in blood pressure reduction, and decide whether these 
differences are in the acceptable range.  

B.  To define an upper limit on acceptable differences and use a test of 
equivalence, see Chapter 11, Demonstrating Equivalence, for an example of 
this approach.  

The investigator wants to know the sample size necessary so that a 95% confidence 
interval for the difference in mean blood pressure reduction for the New Drug and 
the Standard  extends no farther than 1.5 mmHg above and below the observed 
difference.  

To bring up the correct sample size table: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 
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Under Number of groups, select Two groups. 

Under Analysis method, select Confidence Interval.  

Select the second analysis type, Confidence interval for difference between two 
means, coverage probability. 

Click on OK. 

The table will come up empty. The following table shows our entries of 0.95 for the 
confidence level, and 2 for a two-sided confidence interval. 

 

The standard deviation actually observed in your planned study may be larger or 
smaller than the expected standard deviation used for study planning. As a result, the 
confidence interval distance which you compute at the end of the study may be 
larger or smaller than the distance specified. Therefore, we must specify how sure 
we want to be that the observed confidence interval will be shorter than the specified 
length.  

Here the investigator chooses 90% for the desired probability that the observed 
confidence interval width will be shorter than that specified, so he enters .90. Then 
he enters the value 6 for the standard deviation. For the confidence width (distance 
from mean to limit), he enters 1.5 to set the desired value to ± 1.5. As soon as you 
enter 1.5 and press <Enter>, nQuery Advisor solves for the required sample size in 
each group. 

 

This example produced the n per group necessary to obtain a good estimate of 
differences between the New Drug and the Standard in blood pressure reduction. 
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Example 3 
Confidence Interval for percentile of a normal 
distribution (MOC5) 

 
Investigators frequently wish to estimate “normal limits” for some new test.  In our 
example, we assume that the investigator wishes to define a cut-point which only 
10% of the normal population will exceed and to use this in identifying those for 
whom further investigation is needed; in this case we want an estimate of the 90th 
percentile.  The Pth  percentile of a normal distribution is estimated as the sample 
mean + k (sd) where sd is the sample standard deviation of the distribution and k is 
chosen to satisfy Prob(z < k) = P.   

We suppose that 100 subjects have been studied and that the sample mean is 143 
and the sample standard deviation is 15. 

To estimate the Pth percentile from the data, we use the observed mean and standard 
deviation of the sample of normals under study, and determine k by using the 
Distribution Functions option. 

To estimate the Pth percentile from the data: 

In the Assistants menu select Distribution Functions.  In the Distribution 
Function menu, select z (Gaussian/Normal) Distribution. 

Click OK. 

The z (Gaussian/Normal) Distribution table appears. 

To get the estimate for the 90th percentile, enter 0.9 for Probability.  

nQuery solves for the value of z.  

 

The value of z is 1.282 in this case. Thus, the estimated upper 90th percentile of 
the distribution of normals is  

mean + 1.282 (sd) = 143 + 1.282(15) =  162.23.   
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To determine the expected width of the confidence interval for the Pth 
percentile 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select One group. 

Under Analysis method, select Confidence Interval.  

Select the sixth analysis type, Confidence interval for percentile of a normal 
distribution. 

Click on OK to bring up the MOC5 sample size table. 

 

To complete all three illustrated columns, enter .95 in the Confidence level row 
of the first three columns of the sample size table. 

Enter 90 in the Percentile row of the first three columns. 

Enter 15 in the Standard deviation row of the first three columns. 

To determine distances from the estimate to the limits, enter 1 in Lower or 
upper limit row of column 1 and –1 in this row for column 2.  Then enter a 
sample size of 100 for both column 1 and column 2. 

We see that with a sample size of 100 and a standard deviation of 15, a 95% 
confidence interval for the 90th percentile of a normal distribution can be 
expected to extend about 3.7 units above and 3.1 units below the estimate.   

Suppose the investigator wants to estimate the 90th percentile to within no more 
than 2 units. 

Enter 1 in Lower or upper limit row of column 3. 

Enter 2 in the Distance from estimate to limit  row of the third column.  
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Then nQuery calculates a required sample size of 309.  

 

Using MOC5, the upper limit of the 95% confidence interval for the 90th percentile 
is 162.23 + 3.677 or 165.9 and the lower limit is 162.23-3.073 or 159.15.  To assure 
that the 90th percentile is known to within ± 2 would require more than 300 subjects. 

Example 4 
Two group Satterthwaite t-test of equal means 
(unequal variances) (MTT0uv) 
One of the assumptions of the ordinary two-group Student’s t-test is that the 
underlying population variances (standard deviations) are equal.  When the sample 
sizes are also equal and reasonably large, the effect of violation of this assumption 
on the probability of Type I error and on power is not large. However, when both 
the variances and the sample sizes are markedly unequal, the effects on the Type I 
error and on power can be large.   

For example, when the ratio of variances is 10 to 1 (ratio of SDs is 3.16), and the 
ratio of sample sizes is also 10 to 1 (the group with the larger variance also has a 
larger sample), then the probability of a Type I error can be less than .001 when the 
nominal alpha level is .05 and the power will also be reduced.  On the other hand, 
when the ratio of variances is 10 to 1 and the ratio of sample sizes is 1 to 10 (the 
group with the larger variance has the smaller sample size), then the probability of a 
Type I error can be as large as .38 when the nominal alpha level is .05 and the power 
is higher than it should be. 

When the variances in the two groups are expected to differ markedly, power and 
sample size should be computed for a version of the t-test (Satterthwaite’s t) which 
will take the expected ratio of variances into account;  this will be especially 
important when sample sizes are also expected to differ.  Alternatively, for many 
outcomes variables, a transformation might be expected to stabilize variances, and 
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therefore sample size and power computations can be based on use of the 
transformed data in the table for ordinary Student’s t-test. 

Suppose that preliminary data on a hormonal measurement suggests that the mean 
for the control group will be about 300 with an SD of 150 and that the mean for the 
intervention group will be about 1200 with an SD of 600.  The investigator wants to 
know if it will be possible to keep the sample size in the control group small. 

To bring up the sample size table for the Satterthwaite t test: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Under Two-sample t-test, select the second analysis type, Satterthwaite’s t 
test (unequal variances). 

Check the Unequal n’s box. 

Click on OK. 

 
 

In column 1, the investigator has specified that 7 subjects will be assigned to each 
group and finds that the power will be about 90%.  With this same total sample size, 
if the investigator assigns only 4 of the 14 subjects to Group 1 and 10 to Group 2, 
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the power will still be high. However, if the investigator were to assign 10 subjects 
to Group 1 and 4 to Group 2, the power would be very low.   

For this example, the CV (coefficient of variation) is about 0.5 for both groups, this 
suggests that a log transform would stabilize the variances and that an ordinary t-test 
could be applied.  The investigator could consider using table MTT0cv to make 
sample size and power computations, see Example 5.  Or the investigator could 
actually transform the pilot data and use the transformed means and SDs in the table 
for Student’s t-test, see tutorial in Chapter 2. 

Example 5 
Two group t-test for fold change assuming log-
normal distribution (MTT0cv)  

 
Suppose preliminary data on a hormonal measurement suggests that the mean for 
the control group will be about 300 with an SD of 150 and the mean for the 
intervention group will be about 1200 with an SD of 600.  The investigator wants to 
know if it will be possible to keep the sample size in the control group small.  The 
coefficient of variation (SD/mean) is about 0.5 in both groups, which suggests that a 
log transform would stabilize the variances so that an ordinary Student’s t-test could 
be used on the log transformed data. The expected fold-change (ratio of means) is 4.  

To bring up the correct sample size table: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Under Two-sample t-test, select the third analysis type, Two group t-test for 
fold change assuming log-normal distribution. 

Check the Unequal n’s box. 

Click on OK. 
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To calculate the Power, enter all values except Power in the following table. 

 
When the calculation finishes, you will see a message box stating that the power 
has been rounded down to 99. 

 

Select the rows from Test Significance level through Coefficient of variation. 
Click on the Edit menu Fill right option to place those values in the remaining 
columns in the table. 
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Enter values of n for columns 2 and 3. 

 

For this example, the expected power using a t-test on log transformed data is 
over 99% for all three cases.  In general, if the data are truly log-normally 
distributed and analysis is done using the log scale, the power can be expected 
to be higher than it will be when the data are analyzed in the original scale and 
adjustments for unequal variances are made in the Satterthwaite t-test, see 
Example 4.   

In the following example, we expect the intervention to produce only a 
doubling of the mean. This example shows us, that even when variances are 
equal and the ordinary Student’s t-test will be used,  the power is lower for the 
same total sample size when the n’s are unequal. See Chapter 10 for further 
details. 
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Example 6 
Two group t-test of equal fold change with fold 
change threshold (MTT0fct) 
 
Planning and interpreting DNA microarray studies is complicated by the fact that 
many different genes are being evaluated in the same study and that the expense of 
the studies tends to keep sample sizes low.  It is typically assumed that data will be 
analyzed in the log scale so that alternative hypotheses are expressed in terms of 
fold changes (ratio of largest to smallest mean) and variability information is 
expressed in terms of the CV (coefficient of variation, SD/mean).   

Because of the multiplicity of testing, alpha levels (significance levels) are kept low 
and investigators may also wish to specify that no change smaller than a specified 
threshold is of interest.  Therefore the planned detection rule is a combination of 
“statistical significance” and “clinical or biological significance”.   

To plan studies not involving a fold-change threshold, you can use the table Two 
group t-test for fold change assuming log-normal distribution (MTT0cv), see 
Example 5. 

For this example, we assume that a gene expression study has already been 
conducted and analyzed, and that results for each gene were compared between two 
groups (with 3 microarrays each) using a two-sided 1% t-test.  Of the genes with 
significant differences, only those genes for which the observed fold-change is 
greater than or equal to 2 will be studied further.  The investigator wants to know 
what the detection rates for genes with various fold-changes would be using these 
detection rules with this sample size assuming a CV of 0.25. 
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To bring up the correct sample size table: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Under Two-sample t-test, select the fourth analysis type, Two group t-test of 
equal fold change with fold change threshold. 

Click on OK. 
The table will come up empty, but we show a table with 0.01 already filled in 
for the significance level and 2 for a two-sided test. 

 

Then enter the fold change threshold of 2, the CV (coefficient of variation) of 
0.25 and the sample size in each group of 3. 

In this first example, we are interested in the detection rate for genes whose 
expected true fold change is 2. 



 

    
 

8-20 — Sample Size Tables for Means 

 

Then you must specify the desired number of simulations and a random seed.  The 
random seed can be any integer greater than or equal to 0.   

The precision of the estimate of the probability of detection depends on the number 
of samples in the simulation.  In the following table, we show the width of the 95% 
confidence interval for the estimated probability. 

Number of samples in simulation Estimate of the probability of detection 

1000 within ± 2% for probabilities near 90%, 

1600 within  ± 2% for probabilities near 80% 

10000 Within ±1% at the widest  

 

For this example, we specify 10000 simulations and a random seed of 24.  
When everything in the column except the Probability of detection is filled in, 
nQuery Advisor will make an estimate of the time required to complete the 
requested number of simulations on your computer.  (This estimate is based on 
making a small number of preliminary simulations.)   

As soon as you enter the last value, the simulations will begin. You will see a 
box like the following.   
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At this point, you can choose to cancel the simulation, run nQuery Advisor 
minimized during computation of the simulations, or take a brief break while 
you wait.  

You can follow or cancel the progress of the simulation in the Progress of 
simulations dialog box. Unless you want to cancel the simulation or minimize 
the dialog box, there are no necessary steps for you to take. Simply watch or 
ignore the simulations until they have finished and the Probability of detection 
appears in the table. (Simulations are reasonably fast; this example took about 
40 seconds on a 600 MHz computer.) 

For genes with an expected fold-change of 2, only 24% are likely to be detected 
as statistically significant at the 1% level as well as having an observed fold 
change greater than 2. 

Note:   When the fold change threshold is set equal to the expected true fold 
change the probability of detection will never be greater than 50% 
since no more than half of experiments are expected to have a mean 
difference greater than the true mean difference. 
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The investigator also wants to know the detection rates for expected fold-
change values of 2.5, 3, 4, 5, and 6.  To replicate to other columns values which 
stay the same in each example, select the rows from Test significance level 
through Fold change threshold. Then click on the Edit menu Fill Right 
option. Select Coefficient of variation and Number of simulations and choose 
Fill Right. Select the n per group row and choose Fill Right again. 

Enter a new value for Random seed for simulations for each column. 

Your sample size table will look like this: 

 

Enter the Expected Fold-Change in each column. When the simulations for the 
last column are complete, you will see a message box: 
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Click OK to complete the sample size table. 

To label the columns using the Edit Column Names option: 

Place the cursor anywhere within the sample size table. 

Select the Edit menu Edit Column Names option or the right-click menu Edit 
Column Names option. 

The Edit Column Name dialog box will appear. This box lists the column 
names that you can change in your sample size table. Column names are 
restricted to a maximum of 25 characters each; the names will not wrap. 

 

Click on the first column name and type the new column name, FC = 2. Click 
on the Copy Name(s) button. 

Click on the second column name and click on the Paste Name(s) button to 
paste the name. Paste the name into the remaining four column name fields. 

For the second column name, double click on the second column name and edit 
it to say FC = 2.5. 

Edit the remaining column names to agree with the following table. 
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The researcher can conclude that for studies of this size, the selection rule in this 
example would have found more than 90% of the genes with a true fold-change of 4 
or more. The rule would have found only 24% of genes with a true fold-change of 2. 

To display this information, you can choose to plot it.  

To bring up the plot: 

Highlight the first column in the table and click on the Plot button, . 

In the Specify Plot screen, the Y-axis is set to Probability of detection (%). 
Under the X-axis choices, select Expected Fold-Change, FC, and specify the 
range 2 to 6. 

 

Click on OK. 

Plots may take some time, as they are based on simulations for seven points. You 
will see the time estimate and progress of simulations boxes for each point. 
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The simulations may take a minute or two to complete. 

Your plot will then appear as follows: 

 

If you double-click on the plot legend, you can edit the text in the legend. See 
Chapter 6 for details. 

To change the look of the line: 

Double click on the line to bring up the Plot parameters dialog box. 
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Click on the Line Attributes button to bring up the Line Parameters dialog 
box. Change the Style to Solid and change the Width to 2. 

 

Click OK in each dialog box to display the changed plot. 

To change from the gray in the plot area background, select the Graphs menu 
Parameters option to get the Graph Parameters dialog box. 

 

If you want a lighter gray when the plot is displayed in grayscale, choose 
Yellow as your Plotting Area Color.  

Click OK to complete the change. 
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9. Determining a Value for 
Standard Deviation 

When you want to estimate the required sample size for tests or confidence intervals 
involving means (or regression slopes), you must provide an estimate of the within-
group standard deviation (or standard deviation of residuals). You can base this 
standard deviation on a pilot study or use reported values of the standard deviation 
from previous studies with the same outcome measure. Typically, it is not necessary 
to have a standard deviation from a group treated with t he planned intervention.  . 

If you can find a direct report of the standard deviation, you can use that value in the 
appropriate sample size table. When you cannot find a reported standard deviation, 
you may have other information which you can use to determine a reasonable value 
for the standard deviation. You can use nQuery Advisor options in the Assistants 
menu to estimate the standard deviation with information in a variety of formats.  

The Assistants menu includes three useful options for estimation of a standard 
deviation: 

• Data Entry (SD calculator) when individual subject values are available 

(or click on , the SD button and choose For Specified x values from 
the Estimate Standard Deviation dialog box)   

 

• Estimate SD to convert information from other formats; these options can 

also be accessed by clicking on , the SD button and choosing one of the 
ten options  from the Estimate Standard Deviation dialog box)   

 

• Specify Covariance Matrix  to specify the covariance matrix for repeated 
measure designs for use with tables MTT3, Two-group univariate repeated 
measures ANOVA (Greenhouse-Geisser correction), and MOT4, 
Univariate one-way repeated measures analysis of variance (Greenhouse-
Geisser approximation.)  This option can also be accessed by clicking on 

the toolbar button marked  , the Specify covariance matrix icon. 
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Data Entry  (SD calculator) 
If you have measurements on several individuals from a pilot study or from a paper 
listing individual data points, use the Assistants menu Data Entry option. The Data 
Entry option on the Assistants menu allows you to enter a small data set to compute 
mean and standard deviation.   This option is also useful in the context of estimating 
SDx for a predictor variable with equally spaced values, see Example 8 later in this 
chapter, and Example 5 in Chapter 18 Regression Tables. 

To use the Data Entry option:  

Start with your chosen sample size table as the active window.  

Select the Assistants menu Data Entry option.  

Or click on , the SD button and choose For Specified x values from the 
Estimate Standard Deviation dialog box. 

The Data Entry spreadsheet will appear with the cursor in the data cell for the 
first row and the first column.  
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You must enter data column-wise. To enter data in one column, type the first data 
point and press the <Enter> key or the down arrow on your keyboard. The cursor 
will move to the second row of the first column. You can use the mouse to move the 
cursor to the first row of the second column to enter a new set of data. 

We will enter six hematocrit values from elderly women with hip fracture: 32, 29, 
31, 30, 33, 38.  

To enter one column of data: 

Type 32 in the Case 1 cell in the first column and press <Enter>. The table will 
display your entry, as well as the N and Mean for that column. As you enter the 
value for each case, nQuery Advisor will update the N, Mean, and Std. Dev. 
values. 

 

Enter the remaining numbers in the first column, pressing <Enter> after each 
value. The table will display N, Mean, and Standard Deviation for the 
column. 

 

Now that nQuery Advisor has calculated the standard deviation for this data set, you 
can use this standard deviation as an estimated standard deviation for the planned 
study. 
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To move the standard deviation from the Data Entry table to the sample 
size table: 

Click on the Std. Dev cell in the first column to select that cell for copying. 

Select the Edit menu Copy option or click on , the Copy button, or 
<Ctrl><C> to copy the cell contents. 

You can use the Window menu list of open tables to select the sample size table 
as the current table. 

Click on the cell in the standard deviation row to which you want to paste the 
standard deviation. Select one of the Edit menu Paste options or one of the 
Paste buttons, or <Ctrl><V>  to paste the standard deviation value into the 
sample size table. 

When a column in the Data Entry (SD calculator) window contains data, you can 
easily find the mean and standard deviation of a transform of that data. 

Transformation in Data Entry 
The Transformation button in the Data Entry window allows you to transform your 
data using square root, log10 or natural log transformations.  Such transforms are 
often helpful for improving homogeneity of variances. In addition, you can 
customize each transformation with an added constant.  

To use the transformation function:  

Click on the title of the column of interest or on any value in the column to 
select the column. 

Click on a Transformation radio button to select the desired transformation.  

If you have selected a transform including an added constant, enter the value for 
that constant in the box marked A=. 

The Add button will become active. 

Click on the Add Transformationbutton. 
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The transformed column of data will appear in blue for square root or green for 
a log transform in the first empty column to the right. The column name will 
reflect the transformation and the name of the original column. The column 
name will not include any information about an added constant. 

To delete a transformation: 

Click on any cell in the column of transformed data.  The Delete button will 
become active.  

Click on the Delete button. 

The column containing the transformed data will be cleared. 

To change a transformation: 

Click on any cell in the column of transformed data and choose a different 
transformation.  The Change button will become active.  

Click on the Change button. 

The column will display the new transformation. 
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Using One of the Estimate SD Options  
The nQuery Advisor program provides methods for converting several different 
kinds of information into an estimate of the standard deviation.  

To estimate standard deviation: 

Select the Assistants menu Estimate SD option, or click on , the SD 
button. The Estimate Standard Deviation dialog box will appear.  

 

Click on the radio button for the information you want to use to compute the 
standard deviation. 

1. From Standard Error 
To estimate standard deviation from standard error: 

Click on the From Standard Error radio button. 



    
 

Determining a Value for Standard Deviation — 9-7 

 

Click OK to bring up the standard error table. 

 

The Tutorial in Chapter 2 discussed a study to evaluate a new drug to raise 
hematocrit; one group of 24 patients showed a pre-donation hematocrit of 35.2% 
with a standard deviation of 4.4%. If that report had provided only the standard error 
of the mean, .898, we could have converted that standard error to the standard 
deviation. The formula is: 

S D n S E. . . .====  

To calculate the estimated standard deviation for this study: 

Enter 24 in the n row and press <Enter>. 

Enter .898 in the Standard error row and press <Enter>. The nQuery Advisor 
program will calculate the estimated standard deviation. 
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Click on the cell containing the estimated standard deviation. 

Select the Edit menu Copy option or the Copy button. 

Use the Windows menu to switch to the sample size table. 

Click on a cell in the standard deviation row. 

Select the Edit menu Paste Unformatted option or the Paste Unformatted 
button. The estimated standard deviation will appear in your sample size table. 

2. From SD1 and SD2 (pooled SD) 
To estimate the common standard deviation by pooling  estimates of 
standard deviations from two independent groups, s1 and s2:  

Click on the From SD1 and SD2 (pooled SD) radio button. 

 

Click OK to bring up the pooled standard deviation table. 
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You can use this table if you have estimated standard deviations from two 
independent groups and wish to pool them to provide an estimate of the common 
standard deviation. The formula is: 
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In the study of anemia in elderly women after hip fracture covered in the Tutorial, 
we had estimates of the standard deviation in the two groups from pilot studies. In a 
small pilot study of six elderly females after hip fracture, the standard deviation of 
hematocrit level was 3.2%, and in a treated group of 10 females, the standard 
deviation was 5%. 

To calculate the pooled standard deviation for this study: 

Enter 6 in the n1 row and press <Enter>. 

Enter 10 in the n2 row and press <Enter>. 

Enter 3.2 in the Standard deviation of Group 1, s1 row and press <Enter>. 

Enter 5 in the Standard deviation of Group 2, s2 row and press <Enter>. The 
nQuery Advisor program will calculate the common standard deviation. 

 

Click on the cell containing the common standard deviation. 

Select the Edit menu Copy option or the Copy button. 

Use the Windows menu to switch to the sample size table. 

Click on a cell in the standard deviation row. 
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Select the Edit menu Paste Unformatted option or the Paste Unformatted 
button. The estimated common standard deviation will appear in your sample 
size table. 

3. From Range 
To estimate standard deviation from range:  

Click on the From Range radio button. 

 

Click OK to bring up the range table. 

 

As a demonstration of the use of the range in estimating the standard deviation, we 
will use the results of a pilot study. That study measured impaired glucose tolerance 
using the glucose infusion rate in mg/kg/min. The study reported a range of 1.8 to 
9.1 in 19 individuals, but the standard deviation was not reported. When you enter 
the values, you can enter the minimum and maximum and let nQuery Advisor 
compute the range, or you can enter the range directly.  

Note that this procedure assumes that the data have a normal (Gaussian) distribution. 
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To calculate the estimated standard deviation for this study: 

Enter 19 in the n row and press <Enter>. 

Enter 1.8 in the Minimum observed value row and press <Enter>. 

Enter 9.1 in the Maximum observed value row and press <Enter>. The nQuery 
Advisor program will calculate the range and the estimated standard deviation. 

 

Click on the cell containing the estimated standard deviation. 

Select the Edit menu Copy option or the Copy button. 

Use the Windows menu to switch to the sample size table. 

Click on a cell in the standard deviation row. 

Select the Edit menu Paste Unformatted option or the Paste Unformatted 
button. The estimated standard deviation will appear in your sample size table. 

4. From Percentile 
To estimate standard deviation from percentile:  

Click on the From Percentile radio button. 
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Click on OK to bring up the percentile table. 

 

In some cases, there may be no direct information available about the standard 
deviation for an outcome measure, but for variables such as SAT scores or for 
medical laboratory measurements percentile values may be available. To provide an 
example, we consider data for cholesterol from a large screening trial. The 10th 
percentile for cholesterol was reported as 167 and the 90th percentile as 263. We can 
use these values to determine an estimate of standard deviation provided the data 
come from a normal (Gaussian) distribution. When we have more than one set of 
percentiles available, we expect the estimated standard deviation to be the same 
whichever set is used when the normality assumption is satisfied.  

To calculate the estimated standard deviation for this study: 

Enter 10 in the Percentile row and press <Enter>. 

Enter 167, the 10th percentile, in the Lower observed value row and press 
<Enter>.  

Enter 263, the 90th percentile (or upper 10th percentile), in the Upper observed 
value row and press <Enter>.  

The nQuery Advisor program will calculate the difference of upper and lower 
values and the estimated standard deviation. 
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Click on the cell containing the estimated standard deviation. 

Select the Edit menu Copy option or the Copy button. 

Use the Windows menu to switch to the sample size table. 

Click on a cell in the standard deviation row. 

Select the Edit menu Paste Unformatted option or the Paste Unformatted 
button. The estimated standard deviation will appear in your sample size table. 

5. From Coefficient of Variation 
To estimate standard deviation from coefficient of variation:  

Click on the From Coefficient of Variationradio button. 

Click on OK to bring up the coefficient of variation table. 

 

Click on OK to bring up the coefficient of variation table. 
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To demonstrate using the coefficient of variation in estimating the standard 
deviation, we will use information on a diagnostic test as reported in an abstract. 
Eighteen hypertensive Mexican/American males had a mean of 3.3 and a reported 
standard deviation of 1.3. The 75 non-hypertensive males had a mean of 5.2 and 
standard deviation of 2.5.  

Note that many biological measurements show a pattern in which groups with a 
larger mean response also have a larger standard deviation. That is, larger 
measurements are more variable. When the standard deviation is proportional to the 
mean across groups, we also typically see measurements in each group skewed 
toward larger values and the log transformed measurements appear to have a nearly 
normal distribution within groups. Also, the standard deviations of the transformed 
values are nearly constant across groups. 

Standard tests and confidence intervals for group means are based on the assumption 
that the standard deviation is constant. Thus, we must make sample size 
computations on the transformed data. 

When the original data from a previous or pilot study are available, you can use 
Data Entry to enter the individual values. That option will then compute mean and 
standard deviation for log transformed values.  

If the original data are not available, but means and standard deviations are reported, 
you can compute the coefficient of variation, SD/mean. You can then use that 
coefficient of variation to estimate the standard deviation for the log transformed 
scale. (Sometimes you may have a direct estimate of the coefficient of variation.) 

In this example, the coefficient of variation is .394 for hypertensives and .48 for 
non-hypertensives. If we used an in-between value such as .45, we could get an 
estimate of the standard deviation. We could also estimate the possible value for 
each mean in the log scale. We can then copy those values to the appropriate sample 
size table to be used in computing sample size. 

To calculate the estimated standard deviation from  coefficient of variation 
(assuming log-normality):  

Enter .45 in the first column of the Coefficient of variation row and press 
<Enter>. The program will calculate the Estimated σ σ σ σ in log scale. 
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Enter 3.30 in the first column of the Observed mean row and press <Enter>. 
The program will calculate the Estimated mean, µµµµ, in log scale for that 
column. 

Enter .45 in the second column of the Coefficient of variation row and press 
<Enter>. The program will calculate the Estimated σ σ σ σ in log scale. 

Enter 5.20 in the second column of the Observed mean row and press <Enter>. 
The program will calculate the Estimated mean, µµµµ, in log scale for that 
column. 

 

Use the Edit menu Copy option and the Paste Unformatted option to copy the 
estimated standard deviation to your sample size table. See details in sections 1 
through 3 of this chapter. 

6. From Upper Confidence Limit 
When we estimate the standard deviation based on only a few cases, the standard 
deviation may not be very precise. This is a special concern in sample size 
estimation, because the standard deviation used might be too small, leading to a 
sample size that is too small for the study.  

If you select an upper confidence limit, you have a way to take the uncertainty in the 
estimation of the standard deviation into account and determine a conservative 
estimate. 

Note:  For other approaches to taking uncertainty in estimates of the standard 
deviation into account in computing power or sample size, see Taylor, 
D. J. and Muller, K. E. (1995) Computing confidence bounds for 
power and sample size of the general linear univariate model. 
American Statistician, 49, 43-47. Taylor, D. J. and Muller, K. E. 
(1996) Bias in linear model power and sample size calculations due to 
estimating noncentrality. Communications in Statistics: Theory and 
Methods, 25, 1595-1610. Muller, K. E., and Pasour, V. B. (1997) Bias 
in linear model power and sample size due to estimating variance. 
Communications in Statistics: Theory and Methods, 26, 839-851. 
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To estimate the upper confidence limit for a standard deviation estimated 
from a small sample: 

Click on the From Upper Confidence Limit radio button. 

 

Click on OK to bring up the Estimating upper limit for standard deviation table. 

 

To demonstrate the estimation of the standard deviation from a confidence interval, 
refer back to the data entry example using pilot data on hematocrit values in elderly 
women with hip fractures. The standard deviation of those six values was 3.19. For a 
conservative estimate of the population standard deviation, you might want to use 
the upper 80% confidence limit.  

This procedure assumes that the data have a normal (Gaussian) distribution. 

To calculate the estimated standard deviation from confidence interval: 

Enter 6 in the n row and press <Enter>. 

Enter 3.19 in the Observed standard deviation row and press <Enter>. 

Enter .8 in the Confidence level row and press <Enter>. the nQuery Advisor 
program will calculate the upper limit for σ. 
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Use the Edit menu Copy option and the Paste Unformatted option to copy the 
estimated standard deviation to your sample size table. See details in sections 1 
through 3 of the Using One of the Estimate SD Options section of this chapter. 

7. From SD1, SD2, Correlation 
Frequently, the outcome measure is a change from pre-treatment to post-treatment. 
Alternatively, for studies in which each subject is tested under two conditions, the 
outcome measure is the difference in response between the two conditions. To plan 
the necessary sample size for such studies, we need the standard deviation of 
differences between the two measures.  

Unfortunately, many such studies reported in the literature provide means and 
standard deviations for each condition, but do not report the standard deviation of 
differences. In such cases, we can make an estimate of the standard deviation of 
differences using the standard deviation for each condition with an estimate of the 
correlation coefficient. 

To estimate standard deviation from SD1, SD2, and Correlation: 

Click on the From SD1, SD2, Correlation radio button. 

 

Click on OK to bring up the Estimating Standard Deviation table. 
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For this example, consider a study of triglyceride level with men tested under a 
regular diet and a low fat diet. The mean and standard deviation were 106 and 38.5 
under the low fat diet and 79 and 24.5 under the high fat diet.  

The planned study will use a paired t-test to test whether the effect of dietary fat on 
triglyceride level is significant. No estimate of the correlation between triglyceride 
levels under the two diets was provided in the abstract, but a study carried out with 
identical twins reported correlations between members of a twin pair in three twin 
groups as: .41, .48, .68. Time-to-time correlations within an individual are probably 
higher than those found in the twin study. However, since larger values of ρ give 
smaller values for the standard deviation of differences, the investigator decided to 
be somewhat conservative and use ρ=.6. 

To calculate the estimated standard deviation from SD1, SD2, and 
correlation for this study: 

In the first column of the σ1 row, enter 38.5 and press <Enter>. 

In the first column of the σ2 row, enter 24.5 and press <Enter>. 

In the first column of the ρ row, enter .6 and press <Enter>. The program will 
calculate the estimated σd, the estimated standard deviation of the differences. 

 

Use the Edit menu Copy option and the Paste Unformatted option to copy the 
estimated standard deviation to your sample size table. See details in sections 1 
through 3 of this chapter. 

Standard deviation of differences 
ANOVA Mean Squared Error 

For pre and post measurements, xi and yi, the differences are di = yi - xi. The standard 
deviation of the differences is the standard deviation of the di; SD(di) is the square 
root of the variance of the di.  
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Var(di) = Var(xi) + Var(yi) -2 r SD(xi) SD(yi) where r is the correlation coefficient.  

To test H0: µx = µy using a paired t test, the standard deviation of the differences must 
be computed. When H0 is tested using a Repeated Measures ANOVA (or a crossover 
ANOVA), the within-group error mean square will be equal to Var(di)/2. If an 

estimate of this mean square is available, then use MSE2 as an estimate of the 
standard deviation of differences. 

8. For Cluster Sampling 
Cluster randomization, or  randomization of intact groups, is often used in the 
design of community intervention studies. The cluster constitutes the unit of 
randomizationit may be a household, classroom, school, clinic, worksite, city, or 
other natural unit. Cluster randomization is often much simpler logistically than 
other methods, but it is less efficient from a statistical point of view. That is, when 
using cluster randomization, more individuals must be studied to obtain the same 
power. 

Standard sample size formulas and nQuery Advisor tables can be used to compute 
necessary sample size, power, or interval widths for designs in which the unit being 
randomized is a cluster. However, a value for the cluster standard deviation must be 
used in place of the ordinary within group standard deviation. 

Our first example is taken from a paper by David M. Murray and Peter J. Hannan 
(1990) Planning for the Appropriate Analysis in School-Based Drug-Use Prevention 
Studies. J. Consulting and Clinical Psychology. 53:458-468.   

The study to be planned involves the evaluation of a school-based drug-use 
prevention program. Schools will be randomized to intervention or control groups, 
and the prevention program will be applied to 7th and 8th grade students over a two-
year period. There are approximately 100 students in each grade in each school.  

The outcome is smoking prevalence among 9th grade students.  Previous studies 
have indicated a 15% smoking prevalence among 9th graders; the intervention will 
be considered a success if the smoking prevalence is reduced to 10%.  

How many schools must be randomized to each of the intervention and control 
programs to obtain 80% power for a two-sided 5% level test? Although the outcome 
measure is dichotomous, we can analyze such a study by using a two-sample t-test 
where the school level outcome is the proportion of 9th graders who smoke. 

To run this example: 

Open the nQuery Advisor table for the two-sample t test; see Chapter 2, 
Tutorial, for details.  
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To make values for means and standard deviations easier to read, we enter 
number of smokers per 100 students, instead of the proportion of smokers.  

Use the Edit menu Edit Row Names option. Fill in the information about test 
parameters and expected smoking prevalence to obtain the table shown in the 
following screen.  

 

We want to obtain the cluster standard deviation appropriate for school-based clusters of 
100 students. 

To estimate standard deviation from Cluster Sampling: 

Select the Assistants menu Estimate SD option, or click on , the SD 
button.  

 

Click on the For Cluster Sampling radio button. 
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Click on OK to bring up the table for computing the cluster standard deviation. 
We have already filled in the number of 9th grade students per cluster (school).  

 

Specify the between and within cluster variances, or the intraclass correlation and 
either one of these variances, along with the number of subjects within each cluster. 
With that information, nQuery Advisor will compute the cluster standard deviation. 

The average proportion of students expected to be smokers is .125 (the average of 
.15 and .10.) Thus, the expected within school per student variance is (pq) or 
(.125)(.875) = 0.109375 (based on the binomial.)  

When we use prevalence per 100 students, the variance is multiplied by 10,000 to 
obtain 1093.75. We enter this value in the row marked Within-cluster variance.  

Murray and Hannan report that values of the intraclass correlation for previous 
studies involving smoking prevalence ranged from 0 to 0.05. Therefore, we estimate 
the cluster standard deviation for the three values of the intraclass correlation 
evaluated in their paper, 0.0, 0.02, 0.05.  

The standard deviation for clusters is the square root of the sum of the within cluster 
variance and the between cluster variance divided by m.  

When the intraclass correlation is 0.0, the cluster standard deviation is the within-
cluster standard deviation divided by the square root of the number of subjects per 
cluster, in this case, 33.07 divided by 10, or 3.307.  

Having calculated the first cluster standard deviation, we will use nQuery to 
estimate the cluster standard deviation only for the remaining two values of the 
intraclass correlation, 0.02 and 0.05. To make our estimates, we use Murray and 
Hannan’s between-cluster variances of 22.321 and 57.566. 
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Use the cluster standard deviations computed here in the standard deviation row of 
the appropriate sample size table.  

To copy the calculated standard deviations to the sample size table: 

Highlight the Estimate of standard deviation in column 1, and select the Edit 
Menu Copy Option.  

Use the Window menu to make the sample size table active.  

Use the Edit menu Paste Unformatted option to paste the Estimate of standard 
deviation value in the Common standard deviation row of column 1 in the two-
sample t-test table.   

Use the Window menu to make the Estimating standard deviation for cluster 
sample table active.  

Highlight the Estimate of standard deviation in column 2, and select the Edit 
Menu Copy Option. 

Use the Window menu to make the sample size table active.  

Use the Edit menu Paste Unformatted option to paste the Estimate of standard 
deviation value in the Common standard deviation row of column 2 in the two-
sample t-test table.   

Fill in the rest of column2 as shown below. 
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As we can see, very small values of the intraclass correlation can have a large 
impact on the required sample size. For realistic values of the intraclass correlation 
such as 0.02, we must assign 22 schools to the control group and 22 to the 
intervention group.  

9. For Specified x-values 
To estimate standard deviation for specified x-values: 

Click on the From Specified x-values button. 

 

Click on OK to bring up the Data Entry (standard deviation calculator) table. 
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As described in the Data Entry section of this chapter, you enter the actual data 
values column-by-column.  As you enter the values, nQuery will calculate the 
standard deviation.    

You can select a transform for the data; see discussion at the beginning of this 
chapter and see Example 5 in Chapter 18 Regression Tables. 

Equally-spaced x values 
There are easy options for entering equally spaced x values. 

To enter equally-spaced x values, specifying number of values: 

For example, to specify five equally spaced values from 10 to 50, enter 10 in 
the From box. 

Enter 50 in the To box. 

Select Specify num. values. 

Enter 5 in the Specify num. values box to specify that you want 5 values. 

 

Click on Execute.  
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To enter equally-spaced x values, specifying the increment: 

For example, to specify the equally spaced values 6,12,18,...36, enter 6 in the 
From box.  

Enter 36 in the To box. 

Select Specify increment. 

Enter 6 in the Specify increment box to specify that you want values 
incremented by 6. 

Click on Execute. 
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10. Of Residuals  
For regression problems, it will be necessary to specify the standard deviation of 
residuals (also called the root mean square error, or the standard deviation around 
the line.)  When a direct estimate of this value is not available, it is possible to 
estimate it, using other information about the regression line. 

To estimate standard deviation of residuals: 

Click on the of residuals (errors) button.  

 

Click on the OK button, and the Residual Standard Deviation around the line 
for one predictor table will appear. 

 

Enter values into any three of the first four rows. The nQuery program will 
calculate the fourth and the standard deviation of residuals.  For a detailed 
example, see Example 4 in Chapter 18 Regression Tables. 
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Using the Specify Covariance Matrix Option 
For analysis of repeated measures designs, users must specify the within group 
covariance matrix for the M levels of the repeated measures factor. Remember, the 
repeated measures tables are: 

MTT3 Two-group univariate repeated measures ANOVA (Greenhouse-
Geisser correction) 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser approximation 

When a repeated measures sample size table is open, and the number of levels, M, 
has been specified select Specify Covariance Matrix from the Assistants menu or 
click on the ΣΣΣΣ icon.  

The resulting side table will be attached to the active column in the main sample size 
table and will transfer summary values for the covariance matrix back to the main 
table.  

The Specify Covariance Matrix side table offers two main options for specifying 
information about the covariance matrix: 

• specify standard deviations and correlations 

• specify full covariance matrix 

If you select the first option to specify standard deviations and correlations, you can 
specify standard deviations in one of two ways: 

• specify a standard deviation for each level 

• fill in a constant standard deviation for each level. 

If you select the first option to specify standard deviations and correlations, you can 
specify correlations in one of two ways: 

• specify each correlation,  

• specify a correlation pattern in which all correlations are equal, correlations 
follow an autoregressive pattern, or correlations follow an intermediate 
pattern. 

Whichever option you choose, all standard deviations and correlations, and all 
variances and covariances are available for editing. 

In the following example, you will see examples of several of these options, using the side-
table which appears when invoked from the main sample size table MTT3, Two-group 
univariate repeated measures ANOVA (Greenhouse-Geisser correction). 
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1. Specify Full Covariance Matrix 
For this example, there are three repeated measures levels.  

To bring up the specify the covariance matrix side table: 

Open the MTT3 repeated measures sample size table.  

In the Number of levels, M row, enter 3. 

Click on , the Specify covariance matrix icon, or select the Assistants menu 
Specify Covariance Matrix option.  

The following table appears. 

 

The figure above shows tables as they appear using Print Table to Clipboard 
from the File menu. Within the side table, click the radio button for Specify 
Full Covariance Matrix to obtain the alternate version of the table. 
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Enter the variances 25, 64, 36 in the diagonal cells of the table.  

Enter the covariances (16, 12) of the first measure with the two subsequent measures 
into columns 2 and 3 for the Level 1 row. 

Enter 30 in column 3 for the Level 2 row. This value is the covariance of the second 
and third measures. 

Select Compute to obtain the summary values. 

 

Click on the Transfer button to return the required summary values to the main table 
for sample size computation. 
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2. Specify Standard Deviations 
If you select the first option to specify standard deviations and correlations, you can 
specify standard deviations in one of two ways: 

• specify a standard deviation for each level 

• fill in a constant standard deviation for each level. 

You can simply enter the standard deviations for each level as shown: 

 

Alternatively, you can fill in a constant value for the standard deviations for each 
level. To do that, enter a single value in the box marked Constant σσσσ and click on the 
button marked Fill immediately below it. 
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3. Specify Correlations 
If you select the first option to specify standard deviations and correlations, you may specify 
correlations in one of two ways: 

• specify each correlation  
• specify a correlation pattern in which all correlations are equal, correlations 

follow an autoregressive pattern, or correlations follow an intermediate 
pattern. 

For this example, we will go to the second column and specify that there are seven 
levels: basal, and six doses of a drug given in increasing order to each animal. You can 
specify each individual correlation or specify a patterned correlation matrix. 

nQuery Advisor provides a choice of patterned correlation matrices defined by: 

ρij = l - γ + γ| i - j | 

Note:  This patterned correlation model was recommended by Keith Muller. 
The model is discussed in Murray SC, Helms RW (1990) Linear 
Models with Generalized AR(1) Covariance Structure for Irregularly-
Timed Data. Department of Biostatistics, University of North Carolina 
at Chapel Hill. Institute of Statistics Mimeo Series No. 1876. 

To bring up the specify the covariance matrix side table: 

Open the MTT3 repeated measures sample size table.  

In the Number of levels, M row, enter 7. 
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Click on , the Specify covariance matrix icon, or select the Assistants menu 
Specify Covariance Matrix option.  

The following table appears. 

 

To specify the standard deviations for each repeated measures level, enter the 
desired values in the sigmai column; for example, enter the values 3, 5, 7, 7, 7, 
and 8 for levels 1 through 7 respectively. 

To obtain a patterned correlation matrix in which all correlations are 
equal: 

Enter the desired constant correlation in the box marked ρρρρ, say 0.9. 

Leave the 0.0 value in the box marked γγγγ. 

Click on the button marked Fill immediately below. 
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To obtain a patterned correlation matrix in which correlations follow a 
first-order autoregressive pattern: 

Enter the desired constant correlation in the box marked ρρρρ, say 0.9. 

Enter 1 in the box marked γγγγ. 

Click on the button marked Fill immediately below. 

 

We see that correlations decrease from .9 to .534 as observations get farther apart in 
time. 
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To obtain a patterned correlation matrix in which correlations follow a 
pattern in which they do not decrease as fast as for a first-order 
autorgressive pattern: 

Enter the desired constant correlation in the box marked ρρρρ, say 0.9. 

In the box marked γγγγ, enter a value between 0 and 1.  

Click on the button marked Fill immediately below. 

The two figures below use values of .2 and .5 for γγγγ. 
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Summary 
Sample size calculations for tests and confidence intervals for means require an 
estimate of the within-group standard deviation. The nQuery Advisor program 
provides several ways to estimate the standard deviation from available information. 
You can use the Data Entry option or one of the Estimate SD options in the 
Assistants menu to determine a reasonable estimate for standard deviation from the 
information you have. You can use the Specify Covariance Matrix option to specify 
the covariance matrix, standard deviations, or correlations.  
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10. Unequal n’s 
Generally speaking, one prefers designs with equal sample sizes in each group.  For 
tests on means, assuming that the standard deviation is the same in each group, for a 
specified total sample size the power will be maximized for designs in which the 
sample sizes are equal.  Achieving the same power with unequal n's will require a 
larger total sample size.    

In some cases, however, a design with unequal sample size may be unavailable or 
even undesirable. For example, considerable information may already be available 
about the control group. In a study comparing placebo, new drug, and standard drug, 
comparisons with the placebo group will have high power anyway. Thus, it may be 
undesirable to treat too many patients with a placebo when a known effective drug is 
available.   

The nQuery Advisor program provides sample size computations for designs with 
unequal n’s for: 

• most of the Means tables for two or more groups, 
• ♦  most of the Proportions tables for two or more groups 
• ♦  one of the Survival Analysis tables—Log-rank test, user-

specified survival rates, accrual, dropouts (simulation) 

To access a sample size table with unequal n’s when you are initially 
selecting a sample size table: 

Check the Unequal n’s box in the Study Goal and Design dialog box.   

To access the unequal n’s version of the current appropriate table with 
equal n’s: 

Select the Assistants menu Unequal n’s option or click on , the Unequal 
n’s icon. 
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Finding Sample Size for Unequal n’s Design 
To illustrate finding a sample size for a design planned with unequal n’s, we use the 
example from the tutorial in Chapter 2.   

To reiterate the Chapter 2 example: 

Select the File menu New option. 

In the Study Goal and Design box, Select the MTT0 design: Means, Two 
groups, Test, first listed method. 

In the sample size table, use the Edit menu Edit Row Labels option to change 
Group 1 and Group 2 to New drug and Placebo, respectively. 

Enter .05 for significance level and 2 for 1 or 2 sided test. 

Enter 2.2 for New drug mean. 

Enter 0 for Placebo mean. 

Enter 2 for Common standard deviation and 85 for Power. Press <Enter> and 
nQuery Advisor will calculate the n per group. 

 
 

The total sample size required is 32. 

Since we want to see the effect of using unequal n’s, we will open an unequal n’s 
table. First, copy part of the current table. 
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To copy several rows: 

Use the mouse to select the first seven rows of the first column. 

Choose the Edit menu Copy option or click on the Copy icon, or use the 
keyboard shortcut Ctrl-C. 

To create the unequal n’s version of the current table: 

Click on the Assistants menu Unequal n’s option or click on the Unequal n’s 
icon. 

The unequal n’s table will appear. 

Click on the first cell of the first column. 

Choose the Edit menu Paste option or click on the Paste icon, or use the 
keyboard shortcut Ctrl-V. The first seven rows of the unequal n’s table will fill.  
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At this point, you can fill in power and the desired ratio between the sample sizes of 
the two groups, then nQuery Advisor will solve for the n’s. Alternatively, you can 
fill in any two of the four n rows and nQuery Advisor will solve for power.    

In the first column, suppose that we want 85% power and twice as many cases in the 
new drug group as in the placebo group. Type in 85 for power and .5 for ratio and 
see the solution below. 

 
 

With these unequal n’s, the total sample size required has increased from 32 to 36. 

If you wanted to have 20 in the first group and 15 in the second group, what power 
would be obtained?  

To calculate power for group sizes of 20 and 15: 

Copy the first 7 rows to the second column. 

Enter 20 and 15 in the n1 and n2 rows, respectively. 
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By making the sample sizes in the two groups somewhat closer in size, we were able 
to get slightly higher power with a slightly lower total sample size. 

Caveat 
When you want to see the effect of changing values in the more complex tables 
allowing unequal n’s for two groups, you must avoid editing the filled-in values. 
Rather, you should copy the rows to be retained. Then paste the rows into another 
column. Using the new column, you can enter the new values.  

This methodical approach provides you with an audit trail, so that you can compare 
the effects of your differing choices. This method also avoids the possibility of:  

• deleting values other than values you intended to delete 
• recalculating a row other than the row you intended to recalculate. 
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11.  Demonstrating Equivalence  
In this chapter we provide an introduction to sample size issues in equivalence 
testing, and give examples for sample size tables for equivalence testing for means .  
. At the end of the chapter we review the interrelationships between tests, confidence 
intervals, and equivalence demonstrations.  Examples for equivalence tests for 
differences in proportions are given in Chapter 15 Sample Size Tables for 
Proportions; see examples 9, 10, 11 in that chapter. 

nQuery Advisor provides sample size tables for the following equivalence testing 
situations. 

One-sided (non-inferiority) tests for difference  
of means 

MTE0 Two-group t test of equivalence in means  
See Example 1 in this chapter. 

MOE0  Paired t test of equivalence of means 

Two one-sided tests (TOST) for difference or 
ratio of means  

MTE1tg Two-group t tests (TOST) of equivalence in means  
See Examples 2 and 4 in this chapter. 

MTE2tg Two-group t tests (TOST) for ratio of means (using log scale)  
See Example 5 in this chapter. 

MTE3 Two-group t tests (TOST) for ratio of means (using original scale) 
See Example 7 in this chapter. 

MTE1co t tests (TOST) of equivalence in means for crossover design  
See Example 3 in this chapter. 

MTE2co t-tests (TOST) of equivalence in ratio of means for crossover design  
(natural log scale)   

See Example 6 in this chapter. 

MTE4 Crossover design TOST for ratio of means (using original scale) 
See Example 8 in this chapter. 
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One-sided non-inferiority tests for difference of 
proportions  

PTE0  Two-group test of equivalence in proportions (large n) 
See Examples 10 and 11 in Chapter 15.  

PTE1 Two group test of equivalence in proportions using confidence 
interval:   
  a) Lower confidence limit for difference in proportions (simulation) 

See Example 10 in Chapter 15. 
  b) Upper confidence limit for difference in proportions (simulation) 

POE0  Paired test of equivalence of proportions (n large) 
See Example 9 in Chapter 15. 

POE1  Paired test of equivalence in proportions using confidence interval:   
  a) Lower confidence limit for difference in paired proportions 
(simulation) 

See Example 9 in Chapter 15. 
  b) Upper confidence limit for difference in paired proportions 
(simulation)  

Difference of proportions in paired or two-group 
design 

PTE1 Two group test of equivalence in proportions using confidence 
interval:   
c) Two-sided confidence limits for difference in proportions 
(simulation)  

See Example 11 in Chapter 15. 

POE1  Paired test of equivalence in proportions using confidence interval:   
c) Two-sided confidence limits for difference in paired proportions  
(simulation) 

Equivalence testing 
We distinguish between two types of equivalence demonstration: 

1) one-sided the intent is to demonstrate that the new drug is not inferior to the 
standard, a typical clinical equivalence goal 

2) two-sided the intent is to demonstrate that the dose delivered by the new drug 
is close to that delivered by the standard, a typical quality control, 
equi-potency, or bioequivalence goal 
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Equivalence testing hypotheses may be specified in terms of differences in means, 
ratios of means, or in terms of differences, ratios, or odds ratios of proportions. 

The most commonly used designs for equivalence testing are two independent 
groups and the 2 x 2 crossover design. 

One-sided, non-inferiority equivalence testing for 
difference in means 
To simplify the following discussion, we assume that higher means are more 
desirable. Consider a trial comparing new test drug (T), and a standard (reference ) 
drug (S). We want to demonstrate that the test drug is as least as good as the 
standard (reference) (T ≥ S ).  

For example, consider a clinical trial comparing a standard drug and a new test drug 
designed to reduce blood pressure. Previous studies suggest that the average 
reduction in resting diastolic blood pressure in a four-week study is 12 mmHg for 
the standard drug, with standard deviations for these reductions of about 6 mmHg.  

We want to demonstrate that the new drug is not inferior to the standard: 
Specifically, we want to demonstrate that the average reduction of blood pressure 
for the test drug is no more than 1.5 mmHg less than for the standard.  

Note:  Selection of an equivalence limit difference may be aided by 
considering the difference between the expected reduction in blood 
pressure for the standard drug and that for the placebo.  For this 
example, the reduction in blood pressure for the standard drug is 
expected to be 12 mmHg, and the reduction for placebo treated 
patients is expected to be 5 mmHg. This is a difference in reduction of 
7 mmHg. Here we have stated that the test and standard drugs will be 
considered equivalent if the difference in their means is less than a 
quarter of the difference between standard and placebo means. 

Define: 

 µS = standard, reference (control) drug mean 
 µT = test, new, (experimental) drug mean 

Then 

   H0: µT - µS ≤ ∆0  or H0: µT ≤  µS + ∆0  or H0: µT - µS - ∆0 ≤ 0  
  
   HA: µT - µS > ∆0 

In the context of our example ∆0 = -1.5 and we would write the null hypothesis as: 

H0: µT - µS ≤ - 1.5  or µT ≤ µS - 1.5 or µT - µS + 1.5 ≤ 0 
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In other words, the null hypothesis states that the standard (reference) is better than 
the test treatment by some stated amount ∆0. That is, the new drug is inferior to the 
standard. We wish to test the null hypothesis that there is an important difference 
between the two drugs (they are not equivalent) and reject the null hypothesis in 
favor of the alternative hypothesis that the new drug is not inferior to the standard.  

The specific alternative value of µT - µS usually used in power and sample size 
calculations for equivalence testing is µT - µS = 0. 

This formulation of the hypotheses for equivalence testing leads back to the same 
power and sample size calculations as for classical testing approach of H0 = 0 with a 
one-sided alternative HA: µT - µS = ∆0 with Type I and Type II errors reversed. See 
discussion in a later section in this chapter, Relationships between sample size 
methods for standard tests, confidence intervals, and equivalence tests. 

This equivalence testing approach can also be put in the context of confidence 
interval estimation. We reject the null hypothesis of non-equivalence at the 5% level 
when the one-sided 95% confidence interval for µT - µS does not include the value - 
1.5, that is, when its lower bound is > -1.5. For further discussion, see Relationships 
between sample size methods for standard tests, confidence intervals, and 
equivalence tests. 

Note:  We should note here that even if equivalence between treatments is 
accepted, we cannot directly conclude the effectiveness of the test 
treatment. Even if the standard (reference) was shown to be superior to 
placebo in previous trials, there is no guarantee that either treatment 
would have out-performed placebo in the current study, had there been 
a placebo group. Inferring efficacy on the basis of equivalence to a 
treatment previously shown to be superior to placebo should be done 
cautiously. A placebo group from a previous trial is now only an 
historical control. 

Example 1 
One-sided, non-inferiority test for difference in means 

Two group t test of equivalence in means (MTE0)  
In this example, we assume that the null hypothesis of non-inferiority is to be tested 
for a new drug versus the standard using a two group design with equal sample sizes 
in the two groups.  If sample sizes will be unequal, select the Unequal n’s option on 
the Goal and Design box before clicking OK. If you decide on unequal n’s after 
opening the table you can click on the unequal n’s button in the toolbar for the equal 
n’s sample size table. 
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We wish to demonstrate that the standard drug does not reduce blood pressure by 
1.5 mmHg more than the test drug (see previous section.) We fix the one-sided 
alpha level at 0.05 and desire a power of 80% when the true means of the two drugs 
are the same. 

To bring up a table appropriate for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Select the first choice among the listed analyses, Equivalence of two means, 
and click on OK. 

The table will come up empty. The following table shows the entries for the desired 
significance level and the expected value of the standard deviation. 

 

The null hypothesis for a one-sided equivalence test for a difference in means is 
generally the one-sided hypothesis that the two treatments are not equivalent, i.e. 
that the test drug is worse than the standard (reference) by some specified amount.  

In this case, the null hypothesis states that the mean reduction in blood pressure 
produced by the test drug minus the mean reduction produced by the standard drug 
is less than  -1.5 mmHg. Therefore, the equivalence limit difference is -1.5.  

The manufacturers of the test drug believe that it will, in fact, produce exactly the 
same reduction in blood pressure as the standard drug, so the expected difference is 
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0.0. The investigators want 80% power to reject the null hypothesis of lack of 
equivalence if the two drugs do in fact have the same effect on blood pressure. 

 

For this example, a sample size of about 200 per group (400 total) would be 
necessary to have 80% power to demonstrate that the new drug is not inferior to the 
standard when their true means are in fact equal.   

The nQuery Advisor statement for this sample size calculation has been copied to 
clipboard and pasted into this document: 

When the sample size in each group is 199, a two group 0.050 one-sided t-test will 
have 80% power to reject the null hypothesis that the test and standard are not 
equivalent (the difference in means, µT - µS, is -1.500 or farther from zero in the 
same direction) in favor of the alternative hypothesis that the means of the two 
groups are equivalent, assuming that the expected difference in means is 0.000 and 
the common standard deviation is 6.000.  
 
See Chapter 2 Tutorial and Chapter 4 The Edit Menu for details on using nQuery 
Advisor’s automated sample size justification statements. 

Two-sided, “neither better nor worse”, bio-
equivalence testing 

TOST for difference in means 
This type of equivalence testing occurs when there is a requirement to have enough 
but not too much. For example, one might be testing a generic drug versus a 
standard (reference) drug to be sure that the drug blood levels achieved are the same 
with both formulations. 
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For example, suppose that we want to make sure that the test drug produces the 
same blood levels at steady state as the standard. Published results for the standard 
show steady state levels about 16 with a standard deviation of 2.8.  

We want to demonstrate that the steady state blood levels are essentially the same, 
that the test drug produces blood levels which are neither markedly higher nor 
markedly lower. 

The standard strategy for showing equivalence of two means is to demonstrate that 
the difference is within acceptable limits. To test for equivalence, we must first 
specify a range of differences that we consider small enough for the treatments or 
drugs to be considered essentially the same.  

Equivalence is concluded if the confidence interval for the difference in means is 
contained completely within the equivalence limits. To compute required sample 
size in this situation, we must: 

♦ establish two hypotheses 

♦ compute the sample size required to have specified power to reject both 
hypotheses when equivalence is true 

Difference in means 
We first discuss the situation in which the equivalence limits are expressed in terms 
of a difference in means, and we believe in exact equivalence. That is, we want to 
establish that the difference in means is within the interval ( ∆L , ∆U ).  

The hypotheses are stated as: 

 H01: µT - µS  ≤ ∆L  or  H01: µT - µS - ∆L ≤ 0  

 H02: µT - µS  ≥ ∆U  or  H02: µT - µS - ∆U  ≥ 0  

 HA:  µT - µS = 0 

The two one-sided tests (TOST) procedure for differences in means tests the null 
hypotheses for the upper and lower limits separately, each with a one-sided α level t 
test. Only when both hypotheses are rejected may one conclude that the two means 
are equivalent.  

The resulting TOST procedure is an α level test (see caveat below). The results 
correspond to a 100(1-2α)% confidence interval. If the confidence interval is 
contained completely within ( ∆L , ∆U ), then the alternative hypothesis that the two 
formulations are equivalent is accepted.  

Note:  The Type I error for the TOST procedure may be less than α when the 
sample size per group is not large enough so that the total confidence 
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interval width is less than ∆U - ∆L . In large samples when ∆L = - ∆U , 
this requires that n per group satisfy the inequality 

n
z

U

>>>> −−−−2 1
2 2

2
αααα σσσσ

∆∆∆∆
 

See Examples 2 and 3 for sample sizes for TOST procedures for differences in 
means for two-group and crossover designs. 

Example 2   
TOST for difference in means 

Two-group t tests (TOST) of equivalence in means 
(MTE1tg) 

In this example we assume that the null hypothesis of non equivalence is to be tested 
for a new drug versus the standard using a two group design with equal sample sizes 
in the two groups. We want to demonstrate that the standard drug and the test drug 
have similar steady state blood levels.  In a published study evaluating the standard, 
the mean steady state blood level was about 16, and its standard deviation was 2.8.  
We must specify values for ∆L and ∆U. For example we might specify that the 
difference in means should be within 15% of the mean for the standard (in this case, 
16 (.15) = 2.4). We would then rewrite the two null hypotheses as 

 H01: µT - µS  ≤ -2.4 or  H01: µT - µS + 2.4 ≤ 0  

 H02: µT - µS  ≥ 2.4  or  H02: µT - µS - 2.4 ≥ 0  

The composite null hypothesis is that the two formulations produce doses of unequal 
strength (differing steady state blood levels). The alternative hypothesis is that the 
delivered dose is equivalent for the test and standard. 

Reject H01 if the observed difference in the two means is too large. That is, reject if 
the lower bound for two-sided 100(1-2α)% confidence interval for µT - µS is greater 
than -2.4.  

Reject H02 if the observed difference in means is too small. That is, reject if the 
upper bound for the two-sided 100(1-2α)% confidence interval for µT - µS is less 
than 2.4.   

We fix the one-sided alpha levels at 0.05 for each of the two one-sided tests and 
desire a power of 80% when the two drugs produce the same true mean blood levels. 
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To use TOST for difference in means using MTE1tg: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Click on the + sign next to the second choice among the listed analyses, Two 
one-sided equivalence tests (TOST) for two-group or crossover designs, and 
then select Two one-sided equivalence tests (TOST) for two group design. 

Click on OK. 

 

The table will come up empty.  

In column 1, enter .05 in the Test significance levels row. 

Enter -2.4 in the Lower equivalence limit row. 

Enter 2.4 in the Upper equivalence limit row. 

Enter 0 in the Expected difference row. 

Enter 2.8 in the Common standard deviation row. 

Enter 80 in the Power row, and nQuery calculates the n per group. 
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Now, if the test drug were actually a bit more potent than the standard, the n 
required per group would be greater than 25. 

To choose sample size to demonstrate equivalence for a test drug which is 
more potent than the standard: 

Select the first three rows of column 1 and choose the Edit menu Copy option 
or press <Ctrl><C> or choose the Copy icon. 

To paste the contents of the three rows of column 1 into column 2, place the 
cursor in column 2 and choose the Edit menu Paste option or press <Ctrl><V> 
or choose the Paste icon. The “smart” Paste will paste the values into the 
appropriate rows. 

Enter .5 in the Expected difference row. 

Enter 2.8 in the Common standard deviation row. 

Enter 80 in the Power row, and nQuery calculates the n per group. 
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When we have an expected difference of .5, we need a group size of 29.   

Note that for this example, we have used the Edit Column Names option to 
label the columns in the table. See Chapter 4 The Edit Menu for details on the 
this option. 

Example 3   
TOST for difference in means crossover 

t-tests (TOST) of equivalence in means for a crossover 
design (MTE1co) 

For the study discussed in Example 2 above, suppose that a crossover design were 
planned instead of a two-group design.  

If a balanced 2 x 2 crossover design is to be used instead of a two-group design, and 
it can be assumed that there are no carryover effects, table MTE1co can be used to 
determine the necessary sample size.  

For a 2 x 2 crossover design, n per group is the number of subjects in each sequence 
group (AB and BA), so the total sample size is 2n. 

To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 
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Under Analysis method, select Equivalence.  

Click on the + sign next to the second choice among the listed analyses, Two 
one-sided equivalence tests (TOST) for two-group or crossover designs, and 
then select Two one-sided equivalence tests (TOST) for crossover design. 

Click on OK. 

 

In column 1, enter .05 in the Test significance levels row. 

Enter -2.4 in the Lower equivalence limit row. 

Enter 2.4 in the Upper equivalence limit row. 

Enter 0 in the Expected difference row. 

Then enter either the square root of the Mean Squared Error from the crossover 
Analysis of Variance or the standard deviation of differences depending on the 
information you have available. Whichever value is entered, nQuery will compute 
the other. 

For this example, we assume that the investigator does not have information on the 
crossover ANOVA MSE, but has performed a small, paired pilot study of two 
different doses of the new drug. In that study, the standard deviation for each dose 
was about 2.8 and the correlation between blood levels during the two different 
periods was observed to be 0.55.  

To calculate the standard deviation of differences: 

Select Estimate SD from the Assistants menu, or click on the σ button to get 
the Estimate Standard deviation dialog box. 
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Select From SD1, SD2, Correlation and click OK to bring up the side table. 

 

Enter the value 2.8 for the First and Second condition standard deviations. 

Enter 0.55 for the Correlation coefficient.  

 

We find that the expected standard deviation of differences would be 2.656. 

To copy the estimated the standard deviation differences calculated in this side 
table, click on 2.656 and use the Copy option. Then switch to the sample size 
table. Use the Edit menu Paste Unformatted option to paste the value 2.656 
into the Standard deviation of differences row in the crossover equivalence 
table. 

Note: Chow and Liu (1992, pages 52 and 53) define the period differences as 
(1/2) (y1i - y2i), so that their "standard deviation of differences" is σd/2. 
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Enter 80 in the Power row, and nQuery calculates the n per sequence group. 
Since there are two sequence groups in a standard 2x2 crossover, the total 
sample size required would be 14. 

 

If a crossover design is appropriate, and our assumptions about the correlation 
between results for the two periods are correct, this crossover design could use 
14 instead of the 50 subjects required for the two-group design. 

Note that other references for sample size for differences in means for the crossover design 
may use the coefficient of variation, CV = σε /µS , where σε = √MSE  from the crossover 
analysis of variance, for table and figure entry.  Some references may provide total sample 
size instead of sample size per sequence group.  The following table shows how to 
reproduce three examples from Phillips' Table 1 (see reference pane for table MTE1co) .  
Test and standard are considered equivalent if the mean difference is within 20% of the 
standard; the crossover ANOVA  √MSE is 20% or 30%.  The total sample sizes are 24, 70, 
20.  

 
    t-tests (TOST) of equivalence in means for crossover design (MTE1co) 

 1 2 3 
  Test significance levels, αααα (one-sided)   0.050   0.050   0.050 
      Lower equivalence limit for µµµµT - µµµµS, ∆∆∆∆L    -0.200    -0.200    -0.200 
      Upper equivalence limit for µµµµT - µµµµS, ∆∆∆∆U     0.200     0.200     0.200 
  Expected difference, µµµµT - µµµµS     0.000     0.100     0.000 
  Crossover ANOVA sqrt(MSE)     0.200     0.200     0.300 
  Standard deviation of differences, σσσσd     0.283     0.283     0.424 
  Power ( % )      90      90      80 
  n per sequence group  12  35  20 

 
To paste an entire nQuery table into a document as we have done here, select Print Table 
to Clipboard in the Edit menu or the right click menu for the table. The table formatting 
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and Greek symbols will be preserved, and you can select the font and font size for the table.  
See Chapter 4 The Edit Menu for details. 

Two-sided, “neither better nor worse”, bio-
equivalence testing 

TOST for Ratio of means (analysis in log scale) 
Investigators may prefer to express equivalence bounds in terms of the ratio of test 
to standard means. When the data in their original scale have a log-normal 
distribution, it will make sense to make a log transformation  and to analyze the data 
in the log scale. (We assume throughout that natural logs have been taken).  

Hypotheses about the ratio of means in the original scale can then be expressed in 
terms of hypotheses about the difference of means in the log scale. 

The hypotheses are stated as: 

 H01: µT / µS  ≤ ∆L  

 H02: µT / µS  ≥ ∆U  

which correspond to:  

 H01: ln(µT /µS ) = ln(µT ) - ln(µS ) ≤ ln(∆L )  

 H02: ln(µT /µS ) = ln(µT ) - ln(µS ) ≥ ln(∆U )  

These hypotheses are tested using two one-sided t tests for data in the log scale. 

For two group designs, when information on the value of the relevant standard 
deviation is available in the log scale, use table MTE1tg Two-group t tests (TOST) 
of equivalence in means. See Example 4 in this chapter.  

When information about variability is only available in the original scale (the CV for 
the original scale is known), use Table MTE2tg Two-group t-tests (TOST) for ratio 
of means (using log scale.) See Example 5 in this chapter. 

For crossover designs, use MTE2co Crossover t tests (TOST) for ratio of means 
(using logscale). See Example 6 in this chapter. 
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Example 4 
Two-group t tests TOST for ratio of means using log scale 
(MTE1tg) 

You can use MTE1tg to obtain sample size or power for a two group TOST 
equivalence test for the ratio of means when the analysis will be in the log scale and 
a standard deviation of differences is available for the log transformed data. 

To evaluate whether the blood level profile for two different dosage forms is 
equivalent, a two group design with equal n’s is to be conducted.  

The dosage forms are: 
1. two capsules of 250 mg  
2. one capsule of 500 mg plus one capsule of placebo 

The outcome measure is AUC (area under the curve) for 48 hours after 
administration of the dose. Previous studies with the standard (two 250 mg capsules) 
gave a mean ln(AUC) of 5.4 with a standard deviation of ln(AUC) of 0.20.  

The investigator wants to establish that the ratio of means (in the original scale) is 
within the interval (.8, 1.25) which corresponds to an interval for the difference of 
means in the natural log scale of (-.223, .223). 

To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Click on the + sign next to the second choice among the listed analyses, Two 
one-sided equivalence tests (TOST) for two-group or crossover designs, and 
then select Two one-sided equivalence tests (TOST) for two group design. 

Click on OK. 
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Enter .05 for the test significance levels. 

Enter lower and upper and lower equivalence limits of  -.223 and +.223. 

Enter expected difference of 0 (ln(1) = 0) since we assume that the two dosage 
forms do in fact have the same mean blood levels. 

 

Enter common standard deviation of .2, and Power equal to 90. 
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Then nQuery calculates the n per group to be 19. 

Example 5   
TOST for ratio of means using log scale 

Two-group t-tests TOST for ratio of means (using log 
scale) (MTE2tg) 

Returning to the study under discussion in Example 4, we now suppose that the 
original data were not available so that the standard deviation in the log scale could 
not be estimated directly. However, the mean and standard deviation for AUC in the 
original scale had been reported as 230 and 45, respectively, yielding a coefficient 
of variation for the standard (CV = σS /µS) of 45/230 = 0.196. 

When the standard deviation in log scale is not known, table MTE2tg uses the fact 
that when data are log-normally distributed, the variance in the log scale equals the 
ln(1+CV2) where CV=σ/µ.   

Note:  In some references on computing sample size for this situation, the 
approximation σ ≈ CV is used, since for small CV, ln(1+CV2) ≈ CV. 

(If you wished to express everything in the natural log scale you could use table 
MTE1tg as in Example 4.  To convert the CV to an estimate of the standard 
deviation in the log scale, you could select Estimate SD from the Assistants menu 
or click on the icon [σ] and select From Coefficient of Variation.  Then enter the 
CV and nQuery will compute an estimate of the standard deviation in the log scale; 
see Chapter 9 Determining a Value for Standard Deviation, Example 5 for details.) 
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To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Click on the + sign next to the third choice among the listed analyses, (TOST) 
for ratio of means (log scale) for two-group or crossover designs, and then 
select TOST for equivalence for ratio of means (logscale) for two-group 
design. 

Click on OK. 

 

Enter .05 for the test significance level. 

Enter Lower equivalence limit of .8, upper equivalence limit 1.25. 

Enter Expected ratio of 1 since we assume that the two drugs are in fact 
equivalent, and enter Coefficient of variation of .196. 

Finally, enter 90 for Power, and nQuery calculates an n per group equal to 18. 
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Example 6   
TOST for ratio of means using log scale 

t-tests (TOST) of equivalence in ratio of means for 
crossover design (natural log scale) (MTE2co) 

The investigator wishes to demonstrate that the ratio of the test mean to the standard 
means is no lower than 0.8 and no higher than 1.25.  Data are assumed to be log 
normally distributed.  Based on a pilot crossover study, the MSE for the log 
transformed data was observed to be 0.03922, its square root is 0.198.   

To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Click on the + sign next to the third choice among the listed analyses, (TOST) 
for ratio of means (log scale) for two-group or crossover designs, and then 
select TOST for equivalence for ratio of means (logscale) for crossover 
design. 

Click on OK. 
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Enter .05 for the test significance level. 

Enter Lower equivalence limit of .8, upper equivalence limit 1.25. 

Enter Expected ratio of 1 since we assume that the two drugs are in fact 
equivalent, and enter the square root of Crossover ANOVA  Mean Squared 
Error,  .198.  nQuery will compute the SD differences of .280. 

Finally, enter 90 for Power, and nQuery calculates an n per sequence group 
equal to 10, so the total sample size for this crossover design will need to be 20. 

In the second column, we use a larger value for the squareroot MSE, 0.2934.  

To start filling column 2, select the first four rows in column 1, and choose the 
Edit menu Copy option.  

Place your cursor in  column 2 and choose the Edit menu Paste option to fill 
the first four rows.. 

Enter .294 for the square root of the crossover ANOVA MSE.  nQuery will 
compute the SD differences of .416. 

Finally, enter 90 for Power, and nQuery calculates an n per sequence group 
equal to 20.  So a total of 40 subjects would be required for this 2x2 crossover 
design. 
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This example is taken from the paper by Diletti, E., Hauschke, D., Steinijans, V.W. 
(1991)  (See References pane.)  To compare these results to those in the Diletti, 
Hauschke, Steinijans paper, note that these authors transform MSE to "CV" for table 
entry using the formula "CV" = √[exp(MSE)-1].  

Two-sided, “neither better nor worse”, bio-
equivalence testing 

Ratio of means (analysis in original scale) 
Investigators may prefer to express equivalence bounds in terms of the ratio of test 
to standard means.  

Hypotheses about the ratio of means in the original scale can be expressed as: 

 H01: µT / µS  ≤ ∆L  

 H02: µT / µS  ≥ ∆U  

When the data in their original scale have a normal distribution, the two one-sided t 
tests differ somewhat from the standard form of the t test. See the Appendix and the 
reference panes for the relevant tables for references.  

The (Sasabuchi) t-statistic of H01 is given by: 
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The corresponding confidence interval is given by use of Fieller’s approach. 
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Example 7 shows sample size computations for a two-group design, while Example 
8 shows sample size computations for a crossover design. 

Example 7 
TOST for ratio of means using original scale for two-group 
design (MTE3) 

We return to the study discussed in Example 2, but we now state the hypotheses 
directly in terms of the ratio of means 

 H01: µT / µS  ≤ .85  

 H02: µT / µS  ≥ 1/.85 = 1.1765 

The coefficient of variation for the standard is assumed to be CV = 2.8/16 = 0.175. 

To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Select the fourth choice among the listed analyses, TOST for ratio of means 
for two-group design (original scale). 

Click on OK. 

 

Enter .05 for the test significance level. 
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Enter Lower equivalence limit of .85, upper equivalence limit 1.1765. 

Enter Expected ratio of 1, and Coefficient of variation of .175. 

Finally, enter 80 for Power, and nQuery calculates an n per group equal to 21. 

 

Note that the sample size required for this formulation of the problem is a bit smaller 
than that seen in Example 2, since the upper limit here is a bit wider than the 2.4 
used for the upper limit there ((1.1765) 16 = 18.824, so 18.824-16 = 2.824). 

Example 8 
TOST for ratio of means using original scale for crossover 
design (MTE4) 

For this example we use the data from Table 3.6.1 in Chow SC, Liu JP (1992) 
Design and Analysis of Bioavailability and Bioequivalence Studies, Marcel Dekker, 
Inc in which a tablet form of the dose (test) was to be compared to an oral form 
(standard or reference) using a crossover design with the AUC for the first 32 hours 
as the outcome of interest. In this case, the data were felt to be reasonably normal in 
the original scale.  

The mean for the standard was about 82, the intra-subject MSE was 167.25, which 
yields an intra-subject CV of 12.9/82 = .158, and the inter-subject MSE was 736.89, 
so that 2σS

2 is estimated as 736.89-167.25 and σS

2 = 284.82 (see Table 3.5.1 in Chow 
and Liu), and the between-subject CV as 16.88/82 = .206.  We are planning a new 
study of the oral form (standard) in comparison with a different tablet formulation. 
How many subjects will be required for a crossover design to establish that the ratio 
of means is in the interval (.90, 1.111)? 
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To use the appropriate table for this example: 

Choose the File menu New option or click on the New icon button .  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Equivalence.  

Select the fifth choice among the listed analyses, TOST for ratio of means for 
crossover design (original scale). 

Click on OK. 

 

Enter .05 for significance level. 

Enter Lower equivalence limit of .90, upper equivalence limit 1.111. 

Enter Expected ratio of 1, and Coefficient of variation between subjects of .206. 

Enter Coefficient of variation intra-subject of .158. 

Finally, enter 90 for Power, and nQuery calculates an n per sequence group 
equal to 26.  So the 2x2 crossover design will require a total of 52 subjects. 
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Note that sample size and power will be more sensitive to changes in the 
intrasubject CV than in the intersubject CV. 

Relationships between sample size methods for 
standard tests, confidence intervals, and 
equivalence tests 

What are the interrelationships between tests, confidence intervalsand equivalence 
demonstrations? How do required sample sizes differ, depending on the method of 
analysis planned for the study? We discuss these questions in the context of a two-
group design with equal sample sizes where means are to be compared.  

Investigators sometimes ask why the sample size required for a test of equivalence 
between two means is markedly larger than that required for a confidence interval 
for the difference in means when the parameters used in the calculations appear to 
be the same. The explanation lies in the fact that the confidence interval approach 
does not take into account the observed value of the difference in means but only the 
interval width. In contrast, the equivalence test takes into account both the observed 
value of the difference in means and the interval width. To simplify the presentation, 
we will use mainly large sample formulas, but the logic is the same for large or 
small samples. 

Test for equality of two means 
The standard test for comparison of means is the two-sample t test. 

The usual null hypothesis is that the means in the two groups are the same:  

 H0: µ1 - µ2 = 0. 
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An alternative hypothesis for a one-sided level α test is H1: µ1 - µ2 = δσ. 

The null hypothesis will be rejected if the observed difference in means is greater 
than or equal to  

( ) n
st pn

2
12,1 −− α

 

The probability that the observed difference in means will be greater than the value 
stated above is: 

α  when the null hypothesis is true 
1-β  the power of the test, when the specified alternative hypothesis is true.  

We choose the sample size n so that 1-β will equal a desired power, such as 0.90.  
For example, for α = .05, and 1-β = 0.9, and σ = 6 and δ = 0.5, then the required 
sample size is 70 per group.  For α = .10, and 1-β = 0.95, and σ = 6 and δ = 0.5, 
then the required sample size is 69 per group.   See nQuery table (MTT0) below. 

Note:  When n is large, reversal of the values for α and β will not change the 
required sample size.   

For the rest of this chapter, we will display sample size table results as they appear 
in Print Table to Clipboard output, since we are interested in demonstrating the 
relationships between methods rather than the operation of the program.  (For details 
on the Print Table to Clipboard option, see Chapter 4, The Edit Menu. That chapter 
also discusses how to select the font for the output.) 

       Two group t-test of equal means (equal n's) 
 α = .05, β =.10 α = .10, β =.05 

  Test significance level, α   0.050   0.100 
  1 or 2 sided test?    1    1 
      Difference in means, µ1 - µ2     3.000     3.000 
      Common standard deviation, σ     6.000     6.000 
  Effect size, δ = |µ1 - µ2| / σ     0.500     0.500 
  Power ( % )      90      95 
  n per group  70  69 

If the alternative hypothesis were H1: µ1 - µ 2 = -δσ, then the one-sided level α test 
would reject when the observed difference in means is less than or equal to 

( ) n
st pn

2
12,1 −−

−
α

 

For a two-sided level α test, we commonly divide the α level in half and reject the 
null hypothesis if the observed difference in means is less than or equal to  
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 ( ) n
st pn

2
12,2/1 −−

−
α  

or greater than or equal to 

 
( ) n

st p
n

2
12,

2
1 −−

α  

Confidence interval for difference in two means 
The 100(1-α)% one-sided confidence interval for µ1 - µ2 will have lower bound 

  ( ) n
stxx pn

2
12,121 −−−− α

 

If this confidence interval does not include the value 0.0, then the null hypothesis 
that the difference in means is 0.0, would be rejected at the 100 α% level. 

A two-sided 100(1-α/2)% confidence interval for µ1 - µ2 will typically have upper 
and lower limits given by 

 
( ) n

stxx p
n

2
12,

2
1

21 −−
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Sample size methods for confidence intervals focus only on the size of the distance 
between the observed mean difference and the end of the confidence interval; for the 
one-sided interval case, this difference is 

 
( ) n

st pn

2
12,1 −−α

 

In the large sample case where we can substitute a z value for the t value and assume 
that the standard deviation is known so we can substitute σ for sp and this distance 
becomes 

 
n

z
2

1 σα−
 

The sample size required to obtain an interval for which this distance is ω is 

 
2

22
12

ω
σα−=

z
n  
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For the example above, we use table MTC0 to request a 95% one-sided confidence 
interval to have width 3.0 when σ = 6; this will require a sample size of 22 per 
group. The MTC0 table below uses the large sample formula. 

Confidence interval for difference of two means based on z (large equal n's) 
 1 

  Confidence level, 1-α   0.950 
  1 or 2 sided interval?    1 
      Common standard deviation, σ     6.000 
  Distance from mean to limit, ω     3.000 
  n per group  22 

 
When the standard deviation σ is not known and must be estimated from the data, 
the distance from the observed mean difference to the end of the confidence interval 
will vary, depending on the observed value of sp. About half of the confidence 
interval widths will be shorter, and about half will be longer than required. To obtain 
the sample size necessary to ensure an interval which will be shorter than required 
with a specified probability requires an iterative method rather than a simple 
formula. 

The next table, MTC1, utilizes coverage probability. For the interval width to be 
shorter than 3 with 85% probability, it would be necessary to have a sample size of 
27 per group.  

Confidence interval for difference of two means (coverage probability) (equal n's) 
 1 2 

  Confidence level, 1-α   0.950   0.950 
  1 or 2 sided interval?    1    1 
  Coverage probability, 1-γ     0.500     0.850 
      Common standard deviation, σ     6.000     6.000 
  Distance from difference to limit, ω     3.000     3.000 
  n per group  23  27 

What do these results mean in terms of power? We can use the Two-group t test of 
equal means (MTT0) to estimate the power of this design.  (Note that we have 
edited out the unused rows for the two group means.) 
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Two group t-test of equal means (equal n's) 
 1 2 3 4 

  Test significance level, α   0.050   0.050   0.050   0.050 
  1 or 2 sided test?    1    1    1    1 
      Difference in means, µ1 - µ2     3.000     3.000     3.000     3.000 
      Common standard deviation, σ     6.000     6.000     6.000     6.000 
  Effect size, δ = |µ1 - µ2| / σ     0.500     0.500     0.500     0.500 
  Power ( % )      90      49      50      56 
  n per group  70  22  23  27 

With 22 per group, the test would have 49% power, and with 27 per group, the test 
would have 56% power. The power is near 50% in both cases, because half the time 
the observed difference in means will be less than 3, even when the true difference 
is equal to 3.  

An interval which corresponds to the test situation is an interval which has chance 1-
β of excluding the null hypothesis value for µ1 - µ2 when a specified alternative is 
true. To obtain such an interval, we would need the same sample size as for the test. 
That is, we are requiring that, when the true difference in means is 3, the lower limit 
of the one-sided 95% confidence interval will be greater than 0.0 with probability 1-
β.  

Using MTC1 again for a sample size of 70, we get the following table. For this 
example, a sample size of 70 results in a confidence interval which extends no more 
than 1.675 below the observed difference in means in 50% of studies and no more 
than 1.781 below in 85% of studies.  

Confidence interval for difference of two means (coverage probability) (equal n's) 
 1 2 

  Confidence level, 1-α   0.950   0.950 
  1 or 2 sided interval?    1    1 
  Coverage probability, 1-γ     0.500     0.850 
      Common standard deviation, σ     6.000     6.000 
  Distance from difference to limit, ω     1.675     1.781 
  n per group  70  70 
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12. Side Tables/Compute Effect Size 

This advanced tutorial uses analysis of variance examples to illustrate use of the side 
tables which are designed to help you compute the effect sizes required for more 
complex sample size tables. 

You can get specific Compute Effect Size tables when you are using nQuery 
Advisor tables for more than two groups, as well as several other sample size tables. 
To access the Compute Effect Size tables, use either the Assistants menu Compute 
Effect Size option or the icon: 

 

Compute Effect Size 
Compute Effect Size side tables allow you to enter details of the alternative 
hypothesis and have nQuery compute the necessary summary values for you. 

This tutorial illustrates the simplest type of Compute Effect Size side table for an 
example using the analysis of variance. See examples for other tables in the relevant 
chapters in the manual.  

Side Table Name 
For side tables requiring specification of a Side table name, see examples in 
Chapters 14, 15, and 16. 

Example 1 
One-way analysis of variance (MGT0) 

This chapter uses a blood pressure example to illustrate the nQuery Advisor One-
way analysis of variance (MGT0) table and its effect size side table. Note that 
Chapter 8 also used this blood pressure example to illustrate the determination of 
necessary sample sizes for two-group confidence intervals and equivalence testing.  

In this trial, we are comparing the reduction in blood pressure resulting from use of 
a Placebo, the current Standard drug, and a New Drug. From previous studies with 
the Standard drug, we have an estimate of about 6mmHg for the standard deviation 
for reduction in blood pressure. In the past, the Placebo has resulted in reductions of 
about 5mmHg, and the Standard drug in reductions of about 12mmHg.  
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The study as a whole will be analyzed using a one-way analysis of variance at the 
.05 significance level. 

To access the one-way analysis of variance sample size table: 

Select the File menu New option or click on the New button .  

In the Study Goal and Design Box, you will see three columns of options. You 
will select analysis MGT0: 

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select >Two groups. 

Under Analysis method, select Test.  

Select One-way analysis of variance. 

Click on the OK button to accept your choice. The empty analysis of variance 
table will appear. 

To use the one-way analysis of variance sample size table: 

Enter .05 in the Test significance level row and press <Enter> or the down 
arrow. 

Enter 3 in the Number of groups row and press <Enter> or the down arrow. 
Your sample size table will look like the following table. 

 

This figure does not show the yellow highlighting that appears on your screen.  
nQuery Advisor can provide answers for any of the highlighted yellow rows. For 
example, Effect size, Power, and n per group are yellow when you have the One-
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way analysis of variance table on your screen. The nQuery Advisor program can 
calculate any of the three rows: Power, n per group, or Effect size when you enter 
values for the other two after entering values for all other required rows. 

The analysis of variance tests the null hypothesis that the means in all G groups are 
equal. The alternative hypothesis is that the means in the G groups are not all equal.  

In general, you will know what means you expect for each group, but you will not 
have computed the variance of these means, the measure of how far apart the three 
means are. The nQuery Advisor program offers the Compute Effect Size option to 
compute the variance of means for you. In a two-step procedure, you bring up the 
Compute Effect Size side table, then you enter the expected mean for each group 
and the variance of means is computed automatically.  

To calculate the variance of means by using the Compute Effect Size 
option: 

Select the Assistants menu, Compute Effect Size option, or click on , the 
Compute Effect Size icon.  You will see the Compute Effect Size table for the 
One-way analysis of variance. 

 

The Compute Effect Size side table appears in the lower right of the nQuery 
Advisor window. If your table is not expanded to its full size, you may find it 
necessary to expand the window in order to see the Compute Effect Size table. 

Note that the table shows three groups. Your entry of 3 in the Number of groups 
row of the sample size table determined the number of groups in this side table. 

To record the expected mean for the Placebo group, enter 5 in the Group 1 row 
and press <Enter> or the down arrow. 

To record the expected mean for the Standard group, enter 12 in the Group 2 
row and press <Enter> or the down arrow. 

Here we expect the New Drug to produce about the same changes as the 
Standard. 
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To record the expected mean for the New Drug group, enter 12 in the Group 3 
row and press <Enter> or the down arrow. The  side table will calculate the 
variance of the means automatically. 

 

Note that the side table is fully labeled with the abbreviation name of the 
sample size table, the full name of the sample size table, and the number of the 
column being calculated. Thus, you can have one Compute Effect Size side 
table for each column in the sample size table. 

You can clear, cut, copy, paste, and print the contents of the side table. See the 
next section of this chapter, Side Table Buttons, for details. This example 
continues on page 12-7. 

When you save the sample size table, any open Compute Effect Size side table 
associated with the sample size table will also be saved. This is true even when 
you have multiple side tables, one for each of several columns.  

Side Table Buttons 
Although the table in the example above calculates the result automatically, some 
Compute Effect Size side tables display a Compute button. When you are using a 
table with a Compute button, click on Compute after you have made your entries. 

The Compute Effect Size side table displays eight buttons: Transfer, Close, Restore, 
Clear, Cut, Copy, Paste, and Print. 

Transfer Button 
The Transfer button copies required values back to the main sample size table and 
returns the focus to the main table.  When you save the sample size table, nQuery 
saves the contents of the side tables for each column  That information will 
reappear if you call the table again with the same design parameter values.  

Note:  The Transfer button becomes active only when the side table is complete. 
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Close Button 
Close will close the side table without transferring the computed values. It does save 
the entries, so that you can see them the next time you open the side table. 

Restore Button 
The Restore button is active after effect size results have been transferred to the 
main table.  If you clear all the data from the table using the Clear button, or if you 
change some entries in the table (with or without clicking on Compute), clicking on 
the Restore button will restore all the data in the side table to the values which were 
transferred. 

Clear Button 
Deletes all the entries and computed values from the side table.  A dialog box will 
appear to confirm that you want to clear the data. 

Cut Button 
Deletes any highlighted data. The data will be available for pasting within the side 
table and to other Windows applications. 

Copy Button 
Copy will copy selected entries to the clipboard for use in an nQuery Advisor 
sample size table or a side table or any other Windows program.  

To use the values from one side table within the next side table: 

If you open a side table from another column and want to use the same values 
as the earlier table, you can copy the values from the first side table and paste 
them into the new one.  

In the first side table, select the entered values and click on the Copy button. 

In the second side table, place the cursor in the topmost cell, and click on the 
Paste button. The values will be pasted into the side table. (Note that 
<Ctrl><V> does not work here.) 

The Paste button on the side table does not act like a “smart” Paste. Thus, when 
copying and pasting the values from several cells, be sure to place the cursor in 
the topmost cell, corresponding to the topmost cell selected for copying. 

If you want to copy the entire side table for use in a Windows application, you can 
do that in either of two ways. You can use the  menu Print Table to Clipboard 
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option, or you can use the right click menu Print Table to Clipboard option.. Then 
you can paste the contents of the side table into another document. 

Paste Button 
Pastes data which has been Copied to the Clipboard from a Windows application. The 
Paste button pastes the data into the upper portion of the side table starting from the 
cursor position.  You can not paste into the lower section of a side table. 

Print Button 
Prints the side table.  Clicking on this button will produce the Windows Print dialog 
box. 

When the main sample size table is active you can print the attached side tables without 
returning the focus to them by selecting Print in the File menu.  The nQuery Advisor 
Printing checklist will appear and you can select printing of the side tables.  After you 
specify which items are to be printed, press OK,. The Windows Print dialog box will 
appear. 

Right-click Menu Options 
The right-click menu for the side tables offers the same Edit functions (Copy, Cut, and 
Paste) as the side table buttons.  It also offers the functions Print and Print Table to 
Clipboard options from the File menu.   The Copy, Cut, Paste, and Print options work 
just the same as described above for the Side Table Buttons. 

Copy Entire Side Table to Clipboard for Pasting into 
External Documents using Print Table to Clipboard option 

You can copy side tables from nQuery Advisor and paste them into your Windows 
application documents. You select the font to be used in the Rich Text Format.  The 
tabular structure, formatting, and Greek symbols are preserved even when you do 
not retain the Dixon font.  

Use the Print Table to Clipboard option to print the entire side table to the Clipboard 
for pasting into Windows applications, such as Word 
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To export the side table with its values to Word or to a different Windows 
application: 

You will use the Print Table to Clipboard option in the Right Click menu. 

To use the Right Click menu from the side table, place the cursor anywhere 
within the side table. Click on the right button on your mouse. The Right Click 
menu appears.  

Select Print Table to Clipboard.  

The first time you select the Print Table to Clipboard option, you will see a 
message screen telling you how to change the font for the pasted text.  

 

Click OK Complete Copy to accept the default Arial font. 

If you prefer to select a different font, click on Select font for pasting into 
external documents. You will see the Font for pasting into external 
documents dialog box. 
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Select a font and a font size, then click OK to print to the clipboard. 

After you have selected the font you want, you can choose not to see the 
reminder box again by clicking in the checkbox for that option.  You can 
change the selected font at any time by using the Option menu Preferences 
option, and selecting Font for External Pasting.  You can choose to display 
the font reminder box again by selecting the Options menu Preferences option 
Display font choice reminder upon copy option.   See Chapter 3.  The File 
and Options Menus for full details. 

Move to your word processing program and use the Paste option to paste the 
contents of the clipboard.  The panel below shows the pasted side table using 
the Ariel 9 font. 

MGT0-1: Aid for col  1 -- One-way analysis of variance (equal n's) 
Group Mean 

1  5.000 
2 12.000 
3 12.000 

  
Variance of means, V = Σ(µi-µ)2 / G 10.889 

 
(This Print Table to Clipboard option is also available for the main sample size 
tables. From a sample size table, you can access the option in two ways: from 
the File menu Print Table to Clipboard option or from the Right Click menu 
Print File to Clipboard option.) 
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Continuing Example 1 
To transfer the Variance of the means back to the analysis of variance 
sample size table: 

Click on the Transfer button. The sample size table will display the calculated 
variance. The sample size table will become the active table, while the side 
table becomes inactive. 

 
We have an estimated standard deviation of 6 and we want 90% power. 

To compute the effect size and the sample size: 

Enter 6 in the Common standard deviation row and press <Enter>. The 
nQuery Advisor program will compute the Effect Size. 
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Enter 90 in the Power row and press <Enter> or press the down arrow. The 
program will compute the n per group. 

 

This study would require a sample size of 15 in each group, for a total of 45 
patients. 

Example 2 
A different set of means 

What if the New Drug does not work as well as the Standard? The means 5, 12, and 
10 for Groups 1, 2, and 3, respectively, will give the required sample size if the New 
Drug does not work quite as well as the Standard.  

To try a different set of means in the second column: 

In the second column of the sample size table, enter .05 for the Test 
significance level and 3 for the Number of groups. 

Click on the Compute Effect Size icon to bring up the side table. 

To use the values from the first side table within the second side table: 

Use the Window menu to select the first side table, labeled Aid for Col 1.  

In the first side table, select the first two values and click on the Copy button. 



    
 

Side Tables/Compute Effect Size  — 12-11 

In the second side table, place the cursor in the topmost cell, and click on the 
Paste button. The values will be pasted into the side table. (Note that this is not 
a “smart” paste, so you must select the appropriate topmost cell for pasting, and 
<Ctrl><V> does not work here.) 

Enter 10 as the mean for Group 3, and the table will calculate the new Variance 
of means. 

 

Click on the Transfer button to bring the variance of means to the second 
column of the sample size table. 

Enter 6 for Common standard deviation. The nQuery Advisor program will 
calculate the Effect size. 

Enter 90 for Power. The program will calculate the sample size. 

 
To be on the safe side, an investigator may decide to enter 20 patients in each group.  

To determine the power of this study with 20 per group in the third 
column: 

Use the mouse to select the first five rows of the second column. 

Click on the Edit menu Copy option or , the Copy icon, or <Ctrl><C>.  

Click on the first cell of the third column. 



 

    
 

12-12 —  Side Tables/Compute Effect Size 

Click on the Edit menu Paste option or the Paste icon , or <Ctrl><V>. 
The third column will contain the pasted values for the first five rows. 

Enter 20 in the n per group row and press <Enter>. The nQuery Advisor 
program will calculate the power for this study. 

To create and customize the statement: 

With the cursor in the third column of the sample size table, click on , the 
Create Statement button or right click to bring up the right-click menu and 
choose the Create Statement option. The statement will appear. 

 
Click on the Store button to store the statement with the sample size table. The 
statement will remain ready for later use, and the Statement box will close. 

You are ready to customize the statement, but you cannot edit the statement 
while it lies in the statement pane. However, you can copy the statement and 
paste it into the editable Notes section. 

Use your cursor to select the statement in the Statement pane. 

Click on the Edit menu Copy option or , the Copy icon, or <Ctrl><C>.  

Click in the USER NOTES for MGT0-1 pane to designate the position for the 
information about to be pasted. 

Click on the Edit menu Paste option or the Paste icon , or <Ctrl><V>. 
The statement will appear in the User Notes pane. 
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Edit the statement as shown in the following figure. 

 

When you edit the statement within the User Notes section, not only can you edit 
while viewing the sample size table, but you can also keep the edited statement with 
the sample size table. When you save the table, you save the edited statement in the 
Notes section too.   

To print Notes or Statements directly: 

Right click on the Notes pane or the Statements pane. The right-click menu will 
appear. 

 

Choose the Print option and you will see the Print dialog box. 

To print Notes or Statements Using the File Menu Print Option: 

Click on the File menu Print option. 

The nQuery Advisor Printing dialog box will appear.  

Click to select the Notes and/or the Statement. 

Click on OK, and the Print dialog box will appear. 
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You can, of course, copy and paste the statement into any other program running 
under Windows. This option allows you to use the statement in wordprocessing, 
desktop publishing, or presentation software. 

Example 3 
One-way analysis of variance contrast (MGT1) 

Consider a trial similar to the one described earlier in this chapter, but in which we 
compare a Placebo, a low dose of the new drug, and a high dose of the new drug 
with the Standard drug in their ability to reduce blood pressure. We expect that the 
Placebo will result in a reduction of 5mmHg, the Standard in a reduction of 12 
mmHg, and the low and high doses of the new drug in reductions of 10.5 and 13.5 
mmHg respectively.   

Again, we assume that the standard deviation of blood pressure reduction is about 6 
mmHg. We want to make sure that the group sizes will be large enough that analysis 
of variance contrasts can detect differences between Placebo and low dose of the 
new drug and also between low and high dose of the new drug. The test of a contrast 
uses an estimate of standard deviation pooled from all the groups studied. 

To access the single one-way contrast table: 

Select the File menu New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options. You will select 
analysis MGT1: 

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select >Two groups. 

Under Analysis method, select Test.  

Select Single one-way contrast. 

Click on the OK button to accept your choice. The empty contrast table will 
appear. 

You will get the sample size table for the Single one-way between means contrast. 
Your table will come up with no numbers. This example shows a table containing 
.05 in the test significance level row, 2 in the 1 or 2 sided test row, 4 in the Number 
of groups, G row, and 90 in the power row.  
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To compute effect size: 

Click on , the Compute Effect Size icon to bring up the effect size side 
table. 

In the Means column, enter 5, 10.5, 13.5, 12 for groups 1 through 4, the 
placebo group, the low dose of the new drug group, the high dose of the new 
drug group, and the standard drug group, respectively. 

In the Coefficient column, enter contrast coefficients of 0, -1, 1, 0 for groups 1 
through 4, respectively. This set of coefficients will allow us to contrast the low 
dose and high dose groups. 

Press the Compute button in the side table to calculate the Contrast and Scale. 
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Press the Transfer button in the side table to transfer the Contrast and Scale 
values to the Single one-way between means contrast table. 

Enter 6 in the Common standard deviation row and press <Enter>. 

The program will calculate the n per group. 

 

A sample size of 85 per group would be required to distinguish between the low and 
high doses (which differ by 3.0) with 90% power (a total of 340 subjects).   

Example 4 
One-way analysis of variance contrast (MGT1)  
(unequal n’s) 

In Example 3, the placebo and low dose differ by 5.5. We’d like to contrast the 
placebo group to the low dose group. What sample size would be required if we 
assigned only half as many subjects to the placebo group? We will use the unequal 
n’s version of the table to answer that question. 

To access the single one-way contrast table for unequal n’s: 

Select the File menu New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options. You will select 
analysis MGT1U: 

Under Goal: Make conclusion using, select Means. 

Under Number of groups, select >Two groups. 

Under Analysis method, select Test.  

Select Single one-way contrast.  

Click on the Unequal n’s box to select it. 
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Click on the OK button to accept your choice. The empty analysis of variance 
table will appear. 

(If you had the MGT1 sample size table open, and you decided to use  MGT1U for 
unequal n’s, it is not necessary to use the File menu New option. You can choose 
the Assistants menu Unequal n’s option to bring up the MGT1U sample size table.) 
You will get the MGT1U sample size table for the Single one-way between 
means contrast (unequal n’s). Your table will come up with no numbers. The 
following figure shows a table containing .05 in the test significance level row, 
2 in the 1 or 2 sided test row, 4 in the Number of groups, G row, and 90 in the 
power row.  

 

To compute effect size: 

Click on , the Compute Effect Size icon to bring up the effect size side 
table. 

In the Means column, enter 5, 10.5, 13.5, 12 for groups 1 through 4, 
respectively. 

In the Coefficient column, enter contrast coefficients of -1, 1, 0, 0 for groups 1 
through 4, respectively. This set of coefficients will allow us to contrast the 
placebo group to the low dose group. 

In the ri column, enter 1, 2, 2, 2 for groups 1 through 4, respectively, to specify 
that the placebo group will have half the sample size of the experimental 
groups. 

Press the Compute button in the side table to calculate the Contrast and Scale 
values. 



 

    
 

12-18 —  Side Tables/Compute Effect Size 

 

Press the Transfer button to send the Contrast mean and the Scale value to the 
Simple one-way between means table. 

Enter 6 in the Common standard deviation row and press <Enter>. 

 

A total of 134 subjects would be required if we want to have 90% power for this 
specific contrast; using 20 in the placebo group and 40 in each of the other three 
groups (140 total) would be adequate for the comparison of placebo to low 
dose.    
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Example 5 
One-way analysis of variance contrast (MGT1)  
(unequal n’s) 

Using 140 subjects and allowing for unequal sample sizes, what power would be 
obtained for the comparison between low and high doses?  

To determine power for the low and high dose comparison: 

In the second column of the MGT1 table from Example 4, enter .05 in the test 
significance level row, 2 in the 1 or 2 sided test row, 4 in the Number of 
groups, G row, and 90 in the power row. 

To compute effect size: 

Click on , the Compute Effect Size icon to bring up the effect size side 
table. 

In the Means  column, enter 5, 10.5, 13.5, 12 for groups 1 through 4, 
respectively. 

In the Coefficient column, enter contrast coefficients of 0, -1, 1, 0 for groups 1 
through 4, respectively. This set of coefficients will allow us to contrast the low 
dose group to the high dose group. 

In the ni column, enter 20, 40, 40, 40 for groups 1 through 4, respectively, to 
specify that the placebo group will have half the sample size of the 
experimental groups. 

Press the Compute button in the side table to calculate the Contrast and Scale. 
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Press the Transfer button to send the Contrast Mean and Scale values to the 
Single one-way between means contrast table, unequal n’s. 

Enter 6 in the Common standard deviation row and press <Enter>. 

We get a power of 60%.  

 
Although a total sample size of 140 was adequate for the comparison between 
placebo and low dose, it would not have sufficient power for the comparison 
between low and high doses. 
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Remember that you can print the sample size table, the side tables, notes, or  
statements. You can also copy the contents of the sample size table, the side tables, 
notes, or statements for use in other Windows applications. 

Summary 
This chapter has led you through a complete tutorial based on a one-way analysis of 
variance, together with contrasts. You learned how to calculate the variance of the 
means by using the Compute Effect Size side table, then transfer the calculated 
value back to the sample size table. You saw that cutting and pasting cell contents 
can cut down on the number of keystrokes required for additional calculations. 
Finally, you created and edited the statement for the chosen sample size.  

After following this tutorial and the tutorial in Chapter 2, you should have a good 
grounding in the use of the nQuery Advisor program. As questions arise, you can 
use the Help system and the other chapters of this manual as references. Remember, 
the sample size table screen provides four different aids to understanding: 

1.  The guide card for each row of each table. When you access the guide cards 
through the View menu Guide option, you can view a short description of 
the type of entry expected for the row. 

2.  The name tags for each icon. When your cursor remains on an icon briefly, 
the name tag appears with a description of the icon. 

3.  The status line description for each menu item. When your cursor lies on a 
menu item, a short description of that item appears on the left end of the 
status bar at the bottom of the screen. 

4.  The Help system. When you choose the Help menu, you can access the 
Contents option to get to the Full Index, or you can use the Search option to  
search the system by keyword. 

Note that you will find additional descriptions of the use of side tables in Chapter 5, 
Chapter 13, Chapter 14, Chapter 15, Chapter 16, and Chapter 17. 
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13. Repeated Measures and 
Crossover Designs  

In this chapter, we discuss computing sample size and power for designs involving 
one or more groups of subjects in which the same continuous outcome variable is 
measured more than once. This is often called a repeated measures study. The 
simplest example of this type of study is a design with two measurements per 
subject where the two measurements occur sequentially in time as in a pre-post 
design, in which subjects are measured before and after an intervention. Other 
examples of repeated measures designs are: 

• measurements are made at multiple sites in the same individual, such as 
measurements of visual acuity in both right and left eyes, 

• a case-control study with individually pair-matched cases and controls, 
• acid output is evaluated after a low dose of an acid suppressing drug and then 

after a high dose,  
• subjects have been paired on background variables and then randomized so 

that one receives intervention A and one receives intervention B, or subjects 
have been surgically paired, such as in studies of pair-fed rats, 

• measurements can be geographically contiguous as in split-plot designs, 
• crossover studies in which each subject receives all interventions, but different 

groups of subjects receive the interventions in different orders. 

nQuery Advisor has a number of sample size tables applicable for planning sample 
size for repeated measures designs. 

The following categorization of repeated measures tables reflects their most 
common usage. However, it should be noted that tables for two or more repeated 
measures can also be used for power calculations for crossover designs, and some 
problems might properly be approached with any one of several different sample 
size tables. When based on the same underlying model, all of these approaches will 
give the same required sample size. The correspondences between approaches are 
illustrated in the examples in this chapter and in Chapter 11, Demonstrating 
Equivalence. 
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Paired Designs, Tests, Confidence Intervals, and 
Equivalence Tests 

MOT1 Paired t test of mean difference equal to zero  
See Example 4 in this chapter and Example 1 in  Chapter 8, Sample 
Size Tables for Means. 

MOC2 Confidence interval for interval in paired means based on z (n large) 

MOC3 Confidence interval for difference in paired means based on t 
(coverage probability) 

MOE0 Paired t test of equivalence of means 

POT1 McNemar’s test (χχχχ2) of equality of paired proportions 

POT1x Exact sign test of equality of paired proportions 

POC1 Confidence interval for ln(ΨΨΨΨM), odds ratio for paired proportions (n 
large)   

POE0 Paired test of equivalence in proportions (n large) 

POE1abc Paired test of equivalence in proportions using confidence interval:  a) 
Lower confidence limit for difference in paired proportions 
(simulation), b) Upper confidence limit for difference in paired 
proportions (simulation), c) Two-sided confidence limits for difference 
in paired proportions (simulation 

2x2 Crossover Designs, Tests and  
Equivalence Tests 

MTT0 Two group t test of equal means   
See Example 1 in this chapter. See also examples in Chapter 2, 
Tutorial, and Chapter 18, Regression Tables. 

MTE0 Two-group t test of equivalence in means  
 See example in Chapter 11, Demonstrating Equivalence. 

MTE1co Two-group or crossover t test (TOST) of equivalence in means  
See example in Chapter 11, Demonstrating Equivalence. 

MTE2co Two-group or crossover t tests (TOST) for ratio of means (using log 
scale)  

 See example in Chapter 11, Demonstrating Equivalence. 
MTE4 Crossover design TOST for ratio of means (using original scale)  

      See example in Chapter 11, Demonstrating Equivalence. 
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Designs with Two or More  
Repeated Measures  

MOT2 Univariate one-way repeated measures analysis of variance (constant 
correlation)  

See Examples 2 and 5 in this chapter.  

MOT3 One-way repeated measures contrast  (constant correlation)  
See Examples 2, 3 and 6 in this chapter. 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser correction) 

MOC4 Confidence interval for one-way repeated measures contrast 
(constant correlation)  

MTT3 Two-group univariate repeated measures ANOVA (Greenhouse-
Geisser correction) 

See Example 7 in this chapter 

Crossover Designs 
nQuery Advisor can easily provide sample size information for common crossover 
designs where outcome means will be compared. In Example 1, we show how to use 
the nQuery Advisor table for the two-sample t test (MTT0) to compute sample size 
for the 2 x 2 crossover (AB,BA) design. For equivalence testing for the 2 x2 
crossover design, see Chapter 11. Examples 2,3,4 show how to use nQuery for 
crossover designs with more than two periods (a three period three treatment design 
with all possible sequences, and an ABB, BAA crossover design). Example 7 
illustrates the use the sample size table for the two-group repeated measures analysis 
of variance (MTT3) which can also be used for the 2 x2 crossover.  

Crossover studies are studies in which each subject receives two or more treatments 
in sequence. Thus, crossover studies are a type of repeated measures study. For 
example, consider a study to compare the effects of a heartburn relieving drug (Drug 
A) with a placebo (Drug B). In such a study, we might ask patients with regular 
heartburn to take the study medication when they have an attack of heartburn and to 
record their degree of relief using a continuous scale.  

Week 1: Patients will take the first study medication for their first heartburn attack.  

Week 2: Patients will take no medication to avoid any possible carryover or residual 
effects of the first drug.  

Week 3: Patients will take the second study medication for their first heartburn 
attack.  
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Week 1 is the first period in the design and week 3 is the second period in the 
design. Half the patients will be randomly assigned to receive drug A first and drug 
B second (sequence AB), while the other half of the patients will receive drug B first 
and drug A second (sequence BA). We would refer to this study design as a two-
treatment, two-period crossover design with sequences AB and BA.  

You can use nQuery Advisor to compute sample sizes for crossover designs in 
which the following assumptions are satisfied.  

• The design is uniform with respect to period effects. This means that period 
effects do not appear in the contrasts estimating treatment effects. 

• No carryover or residual effects. It will usually make no sense to plan a 
crossover study if carryover or residual effects are expected. In any case, the 
testing of such effects would seldom be the basis for powering the study. 

• Error variance. It is assumed that the within-subject covariance matrix 
satisfies the conditions in which the between subject standard deviation is the 
same for each treatment/period and that the correlation between pairs of 
treatments/periods is constant. Under these conditions, the within-subject 
standard deviation is given by σε= σB√(1-ρ). You must provide an estimate of 
the within-subject standard deviation, σε , or the between subject standard 
deviation, σB , and the between period/treatment correlation, ρ, or of the 
standard deviation of differences,  σd = √2 σε= √2 σB√(1-ρ).    

• Note that the standard deviation of differences equals MSE2  where 
MSE is the within-group mean squared error from the crossover ANOVA. 

Example 1 
2 x2 crossover (two-period, two treatment AB,BA) 
crossover using table for two-sample t (MTT0)  

The study design has a total sample size of 2n with n subjects receiving sequence 
AB, and n receiving BA. Thus, the A-B contrast is free of period effects on the 
average. The basis for the test of treatment effects will be the difference between 
treatments within each subject, ydiff = y1 - y2 where y1 is the period 1 response and y2 
is the period 2 response. 

The table for the two-sample t is used to compare the mean difference between the 
periods for sequence group 1 to the mean difference between the periods for 
sequence group 2.  

Note that, in this context, you must provide an estimate of the standard deviation of 
differences, σd = √2 σε = √2σB√(1-ρ) where  σε is the square root of the mean 
squared error from the crossover ANOVA. 
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Patients with cancer receive repeated chemotherapy cycles during which the number 
of neutrophils (a type of white blood cell ) decreases. Neutropenia occurs when the 
number of neutrophils decreases below a fixed cut-off.  

The study plan is to compare a new therapy to reduce the mean number of days of 
neutropenia with a placebo, using a 5% level two-sided t test appropriate for a 
crossover design. Each patient will get the new therapy during one chemotherapy 
cycle and placebo during another chemotherapy cycle. A new cycle of 
chemotherapy is not instituted until any previous neutropenia has resolved, and we 
assume that there are no carryover or residual effects.  

The investigator asks whether 30 patients will provide adequate power to detect a 
drop of 3 days in the duration of neutropenia due to the new therapy. A previous 
study reported a median of 8 days of neutropenia in a control chemotherapy period 
with median durations of 3 and 4 days for two combination therapies. A small pilot 
study for patients receiving two cycles of chemotherapy with no treatment 
intervention showed median durations of about 6 days and a standard deviation of 
differences in neutropenia duration between the two cycles of 5.2.  

To run this example: 

In nQuery Advisor, choose the File menu New option or click on the New Icon 
button to obtain the Study Goal and Design dialog box.   

Click on Means, Two group, and Test and select Two-sample t test.  

The sample size window for two-group t test of equal means appears. 

 

In the significance level row, enter .05. 

Enter 2 for a two-sided test. 
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In sequence group 1, with order “New, Placebo”, we expect that the difference 
between days of neutropenia for the two periods (Period 1 - Period 2 =New - 
Placebo) will average -3.0.  

In sequence group 2, with order “Placebo, New” we expect that the difference 
between days of neutropenia for the two periods (Period 1 - Period 2 = Placebo - 
New) will average +3.0.  

Enter -3 in Group 1 mean row. 

Enter 3 in Group 2 mean row. 

The difference in means will be calculated. 

The relevant standard deviation is the standard deviation of differences estimated to 
be 5.2. We want to assess power for a total sample size of 30, so the sample size per 
sequence group would be 15.  

Enter 5.2 in Common standard deviation row, and Effect size will be calculated. 

Enter 15 in the n per group row, and  we find a power of 86%. 

 

Alternatively, you can use the same approach as used in the sample size tables for 
equivalence testing for crossover designs.  

To do this: 

Select the first two rows of column 1. 

Use the Edit menu Copy option or the Copy icon or <Ctrl><V> to copy the 
row values. 

Place the cursor in the second row. 
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Use the Edit menu Paste option or the Paste icon or <Ctrl><V> to paste the 
row values into column 2. 

Enter the mean duration of neutropenia expected for the New treatment (3 days) 
and the mean for the Placebo (6 days), then input σd/2 for the common standard 
deviation to obtain the same effect size. See results in Column 2 of the sample 
size table below. 

 

Required sample size for this crossover design can also be obtained using table 
MTT3, Two-group univariate repeated measures ANOVA (Greenhouse-Geisser 
correction). See example 7. 

If an estimate of the standard deviation of the differences is not directly available, 
but estimates of the between subject standard deviation and the between 
treatment/period correlation are available: 

• Click on the Assistants menu item Estimate S.D. or the button labeled σσσσ and 
select the item Estimate Standard Deviation from SD1, SD2, Correlation. 
nQuery Advisor will do the calculations for you. See Chapter 9, Determining a 
Value for Standard Deviation, Example 6. 

If an estimate of the within group mean squared error from the crossover (or 
repeated measures) ANOVA is available: 

• Use the equation, σd = √2 σε = √2σB√(1-ρ) where σε is the square root of the 
mean squared error from the crossover ANOVA. 
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Example 2  
M period, M treatment crossover (2 ≤≤≤≤ M ≤≤≤≤ 8) (MOT2) 

In an M period, M treatment crossover design, treatments are given in all possible 
sequences or balanced as in a Latin square. All sequences have the same number of 
replicates, and sequences are chosen so that no confounding occurs between 
treatment and period effects.  

Use the nQuery Advisor table for one group repeated measures analysis of variance 
to obtain power or sample size for the treatment effect. As an alternative, you can 
use the nQuery Advisor table for repeated measures contrasts to obtain power or 
sample size for contrasts between treatments. 

The current standard drug and two doses of a new drug will be compared for their 
ability to reduce blood pressure in a three-treatment three-period crossover design 
with an adequate washout period. An equal number of subjects will be assigned to 
each of the 6 possible drug sequences, ABC, ACB, BAC, BCA, CAB, CBA.  

The standard deviation for reduction in blood pressure is estimated from previous 
studies with the standard drug as about 6 mmHg. The correlation between reductions 
observed in successive time periods is small, since baselines have been removed, 
about 0.20 and is expected to be the same for all pairs of periods.  

In the past, the standard drug has resulted in reductions of about 12 mmHg. 
Investigators expect the lower dose of the new drug to be about the same as the 
standard, and the high dose to reduce blood pressure by about 14 mmHg. They plan 
a repeated measures analysis of variance with testing at the 5% level, and wish to 
obtain 90% power. 

To obtain the required sample size for the overall main effect treatment 
comparison between all three treatments: 

Open the Study Goal and Design box. 

Click on Means, One group, Test, and select Univariate one-way repeated 
measures analysis of variance.   

Enter the values for significance level, number of treatments (levels), the 
standard deviation and correlation, and the desired power into the table. (If 
between subject standard deviation and between period correlation are not 
available, the within-subject standard deviation must be estimated directly and 
entered into the row for σ, with the value zero entered for ρ.)  
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To enter the expected means for each treatment and have nQuery Advisor 
compute the variance of means: 

Click on Assistants menu item Compute Effect Size or the button labeled δδδδ .  

Enter the expected means, 12, 12, 14, into the side table (only one sequence 
need be entered). 
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Click on the Transfer button to copy the computed variance of means back to 
the main sample size table.  

 

Then nQuery finishes the calculation in this table.  

The figure above shows that a total of 139 subjects would be required for 90% 
power. Since all 6 sequences will be assigned with equal sample sizes, a total of 144 
subjects (6 x 24) must be planned.  

To obtain power for the specific contrast between high dose and low dose of 
the new drug: 

Open the Study Goal and Design box. 

Click on Means, One group, Test, and select One-way repeated measures 
contrast.  

Enter the values for significance level and M into the sample size table. 

Choose the Assistants menu  Compute Effect Size option to bring up the side 
table as seen in the next figure.  
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Enter the values for means and for the coefficients for the contrast of interest. 
Click on Compute. 

 

Click on the Transfer button to move the result to the sample size table. 

Enter the remaining values to obtain the power for the specific contrast, as 
shown in the next table. A power of 90% will require an n of 153. 
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Example 3  
M period crossover (MOT3) 

The design can require each treatment to appear the same number of times in each 
sequence, (AABB, for example) or can use sequences such as ABA. It is assumed 
that sequences are chosen so that no confounding occurs between treatment and 
period effects (the design is balanced.) In such cases, the table for repeated measures 
contrasts can be used to compute power for specific treatment contrasts.  

Return to Example 1 in which a new drug for reduction in neutropenia is to be 
evaluated. Now assume that the investigator plans to use the three period, two 
treatment design ABB and BAA.  

To obtain the required sample size for the overall main effect treatment 
comparison in the three period two treatment design: 

Open the Study Goal and Design box. 

Click on Means, One group, Test, and select One-way repeated measures 
contrast.  

Enter the Test significance level and the Number of levels, as shown in the 
following sample size table. Then choose the Assistants menu Compute Effect 
Size option. 

Enter the means and coefficients as shown below and click on Compute. 
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Click on Transfer to transfer the calculated value for Contrast and Scale to the 
sample size table. 

Enter the values for the Standard deviation and the Between level correlation. 
The program will calculate the Effect size.  

Note that in Example 1 we were given the standard deviation of differences 
which we have converted to the within standard deviation, 3.677. (We have 
divided σd by √2 to get an estimate of σε = σB√(1-ρ). We have also substituted 0 
for ρ and σd /√2 = 5.2/√2 = 3.677 for σ.) 

Enter 30 for the requested sample and nQuery will compute the power, in this 
case 94%. 
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Example 4 
M period crossover second approach (MOT1) 

As an alternative to the one-way repeated measures contrast in Example 3, we can 
use the table for the paired t test to obtain power or sample size for contrasts 
between pairs of treatments. Also, we can adjust the value entered for σd based on 
the design. Let σC = √f σε be the standard deviation for the contrast using an estimate 
of the within subject standard deviation, σε , or σC = √f σΒ √(1-ρ) if estimates of the 
between subject standard deviation and the correlation are available. Table 1 
provides the multiplier f for a variety of designs. 

Table 1. Multiplier f in σσσσc = √√√√f σσσσεεεε or σσσσc = √√√√f σσσσΒΒΒΒ √√√√(1-ρρρρ) for crossover designs for 
contrasts between pairs of treatments 

Number of periods, M Number of 
treatments, t 

Design sequences f 

2 2 AB, BA 2 

2 2 ABB, BAA 4.5/3 = 1.5 

3 3 ABC, ACB, BAC, 
BCA, CAB, CBA 

2 

3 2 AABB, BBAA, 
ABBA, BAAB 

1 

4 4 ABCD, BDAC, 
CADB, DCBA 

2 
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To obtain sample size for the Example 3 design using the paired t test 
sample size table: 

Open the Study Goal and Design box.  

Click on Means, One group, Test, and select Paired t test.  

Enter the same values into the table as for Example 1, except that the value 
entered for the standard deviation of differences should be √f σd /√2 or, in this 
case, √(1.5) [5.2] /√2 = 4.5.  

 

This design will have a power near 94% for a sample of size 30. 

Repeated Measures Designs 
The general repeated measures design may have one, two, or more than two groups, 
and may have one or more factors defining the levels of the repeated measures. Such 
designs may be analyzed using univariate analysis of variance or multivariate 
ANOVA methods. 

Univariate analysis of variance methods are appropriate when the covariance matrix 
of the repeated measures responses satisfies the sufficient (but not necessary) 
condition of compound symmetry (that is, all response variances are equal and all 
response intercorrelations are equal).  nQuery Advisor provides three sample size 
tables appropriate for situations where the covariance matrix satisfies conditions of 
compound symmetry. 

MOT2 Univariate one-way repeated measures analysis of variance 
(constant correlation)  

MOT3 One-way repeated measures contrast (constant correlation) 

MOC4 Confidence interval for one-way repeated measures contrast 
(constant correlation) 

See Examples 5 and 6 in this chapter. 
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Univariate analysis of variance methods may still be approximately correct when the 
covariance matrix is not restricted to be compound symmetric if the degrees of 
freedom for tests involving the repeated measures factor are multiplied by a 
correction factor before assessing significance.  

 nQuery Advisor provides two sample size tables appropriate for situations where 
the covariance matrix need not be compound symmetric and the Greenhouse-
Geisser correction is to be used. See Muller, KE, Barton CN (1989) Approximate 
Power for Repeated-Measures ANOVA lacking Sphericity, Journal of the American 
Statistical Association 84:549-555 for details of the methods used. 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser correction) 

MTT3 Two-group univariate repeated measures ANOVA (Greenhouse-
Geisser correction)  

See Example 7 in this chapter 

Example 5 
One-way repeated measures analysis of variance 
(MOT2)  

A psychologist plans to conduct a study of a three month intervention aimed at 
raising self-esteem in children. Self-esteem will be measured before, after 1 month, 
after 2 months, and after 3 months of the intervention, using a 100 point scale.  

In a small pilot study of 10 children who had self-esteem measured once and again a 
week later with no intervention, the correlation between measures was 0.7, and 
standard deviation across children at times 1 and 2 was about 10. The beginning 
score was 55. The investigator hopes to raise the initial score to 59.5 over the course 
of the unit.  

To run the one-way repeated measures analysis of variance example: 

Open the Study Goal and Design box.  

Click on Means, One group, Test, and select Univariate one-way repeated 
measures analysis of variance. 

Enter 0.05 for a 5% significance level.  

Measurements will be made at 4 time points so enter 4 in the Number of levels 
row.  
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After you have entered the number of levels, click on , the Compute 
effect size button to obtain the side table shown below.  

 

Enter 55 for the pre-test self-esteem score, and 59.5 for the post test self-esteem 
score. 

Enter sensible intermediate values for the results you expect to see at the one 
and two month tests. Then nQuery Advisor will compute the Variance of 
means.  

 

Click on the Transfer button to transfer this value to the main table.  

Enter 10 for the Standard deviation at each level and 0.7 for the correlation 
between successive tests.  
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Enter the required power, and nQuery Advisor will solve for the necessary 
sample size. The resulting table is shown below.  

 

To have 90% power to obtain a significant result in the one-way repeated 
measures analysis of variance when self-esteem scores are expected to rise 
gradually from 55 to 59.5, would require 40 children. 

Example 6 
One-way repeated measures contrast (MOT3) 

The investigator expects that self-esteem scores will increase monotonically 
over time. Thus, she will probably wish to test the linear contrast following the 
repeated measures analysis of variance and assess what sample size will be 
necessary for the contrast to have 90% power. 

To run the one-way repeated measures contrast example: 

Open the Study Goal and Design box.  

Click on Means, One group, Test, and select One-way repeated measures 
contrast. 

Enter the numbers as shown in the following table. 
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Click on the Assistants menu Compute Effect Size option and enter the Means 
and Coefficients as shown in the above table. These coefficients are appropriate 
to test for a linear trend in self-esteem. 

Click on Compute to calculate the Contrast and Scale parameters. 

Click on Transfer to transfer the Contrast and Scale values to the sample size 
table. 

Enter the Standard deviation and Between level correlation. The program will 
calculate the Effect Size. 

Enter the Power of 90, and the program calculates the required sample size.  
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For the test of the linear contrast to have 90% power the study design requires 
only 29 children. 

Example 7 
Two-group repeated measures ANOVA (Greenhouse-
Geisser correction) (MTT3)  

We return to the study outlined in Examples 5 and 6, and we now suppose that 
the investigator believes that correlations will decrease over time and wants to 
design a study comparing the intervention group to a no treatment control 
group.   The investigator plans to analyze the data using univariate analysis of 
variance with the Greenhouse-Geisser correction.  That is, an ordinary 
univariate analysis of variance will be computed.  Then the Greenhouse-Geisser 
correction factor (an estimate of the measure of lack of sphericity ε) will be 
computed.   (When the assumption of compound symmetry is satisfied ε equals 
1.0; its minimum value is 1/(M-1) where M is the number of repeated measures 
levels.)  The F statistics for the significance tests for levels or levels by groups 
will be compared to critical values of F with degrees of freedom obtained by 
multiplying the nominal degrees of freedom by the Greenhouse-Geisser 
correction factor. 
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To run the two-group repeated measures analysis of variance example: 

Open the Study Goal and Design box.  

Click on Means, Two group, Test, and select Two-group univariate repeated 
measures ANOVA. 

Enter 0.05 for a 5% significance level.  

Measurements will be made at 4 time points so enter 4 in the Number of levels 
row.  

After you have entered the number of levels, click on the Compute effect size 
button to obtain the side table shown below.  

For group 1, we enter the same means across the four time levels as we used in 
Example 5 and assume that the control group will show no change over time. 

 

Click on Compute to get the numbers shown in the figure above. 

Click on the Transfer button to transfer the “Variances” back to the main table. 
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Click on the  button, or click on the Assistants menu Specify covariance 
matrix option to bring up the Specify Covariance side table. (You will find 
details on using the Specify Covariance option in Chapter 9, Determining a 
Value for Standard Deviation.) 

Enter 10 for Constant σσσσ and click on Fill.  

Enter .7 for ρρρρ and .5 for γ to get a pattern of correlations which decrease with 
distance between measurements. 

Click on Fill. 

Click on Compute to get the result. 
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Click on Transfer and enter the required power, say 85% for the levels by 
groups interaction, and have nQuery compute n. 
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For this study, the effect sizes for the between levels and levels by group interaction 
are equal, but this will not generally be the case. 

Note:  Due to use of the estimated Greenhouse-Geisser correction, the actual 
significance level of the test may be somewhat lower than the nominal 
level which can affect the computed power. 
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14. Nonparametric Tests  
A nonparametric approach to analysis of a two-group design uses the 
Wilcoxon/Mann-Whitney rank-sum test.  The rank-sum test is a test of the null 
hypothesis that P(X<Y) = 0.5, where X is an observation from Group 1 and Y an 
observation from Group 2.   It is equivalent to a test of equality of means when the 
two distributions have the same shape and equal variances.  When the two 
distributions are normally distributed with equal variances, the rank-sum test will 
require about 5% more observations than the two-sample t-test to provide the same 
power against the same alternative.  

For nonnormal populations, especially those with long tails, the rank-sum test may 
not require as many observations as the two-sample t-test.  For example, the rank-
sum test requires only about 80% of the sample size required by the t-test when the 
data are distributed like a t with 5 degrees of freedom. 

Two nQuery Advisor tables are available for nonparametric tests, depending on 
whether the outcome variable is continuous or ordered categorical.  

Example 1 
Wilcoxon/Mann-Whitney rank-sum test (continuous 
outcome) (MTT1) 

To illustrate finding a sample size for a two-group design to be analyzed using the 
Wilcoxon/Mann-Whitney rank-sum test, we use the example from the tutorial in 
Chapter 2. 

A two-group, randomized, parallel, double-blind study is planned.  Patients will be 
studied for two weeks; each patient will be randomly assigned to receive either new 
drug or placebo 3 times per week.  The sample sizes in the two groups will be equal. 
A two-sided 5% level rank-sum test will be used to analyze the outcome measure, 
the change in hematocrit level from pre-treatment to post-treatment.   

One hypothesized outcome scenario is that the difference in means between the two 
groups would be 2.2, while the standard deviation of change within groups would be 
2.0. Using the table for the two-sample t-test, we found that 19 subjects per group 
would be required to obtain 90% power. 
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To bring up the sample size table: 

Choose the File menu New option or click on , the New icon button. 

In the Study Goal and Design Box, you will see three columns of options. 

Under Goal:  Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test. 

Select Wilcoxon/Mann-Whitney rank-sum test (continuous outcome) in the 
selection box. 

Click on OK. 

The table will come up empty.  The following table shows the entries for the test 
parameters and the desired power.     

 

You may have a value for p1 = P(X<Y) from pilot data or other information.  Or, 
you might wish to select a value for p1 using Cohen’s definition of small (δ = 0.2, p1 
= 0.556), medium (δ = 0.5, p1 = 0.638), and large effect sizes (δ= 0.8, p1 = 0.714) for 
sampling from a normal distribution.  Or, you may wish to compute p1 from the 
values expected for the means and standard deviation using the Compute Effect 
Size option. 

Select the Assistants menu, Compute Effect Size option, or click on the  
icon. You will see the side table shown below.  The table will come up empty, 
but we have entered the values for means and standard deviations and nQuery 
Advisor has already computed p1. 
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Select the value for p1. 

Use the Edit menu Copy option or the Copy icon, , or the Copy keyboard 
shortcut, <Ctrl><C>, to copy to clipboard. 

Return to the main table by using the list of open tables in the Windows menu 
or by using the <Ctrl>-<Tab> keys on your keyboard to toggle between the 
table displays. 

Use the Edit menu Paste option or the Paste icon, , or the Paste keyboard 
shortcut, <Ctrl><V>,  to paste the value in the appropriate row.  nQuery 
Advisor will compute the required sample size. 

 

The large sample approximation  used for computing power and sample size for the 
rank-sum test is based only on the value of p1 and does not take into account 
knowledge you have about the shape of the underlying distribution.   
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Example 2 
Wilcoxon/Mann-Whitney rank-sum test (ordered 
categories) (MTT2)  

For this table, nQuery Advisor computes power based on approximating the 
unconditional distribution of the Wilcoxon rank-sum test statistic under the null and 
alternative hypotheses using the first four moments of the distribution. See an 
outline of the method in the Appendix. 

To illustrate finding a sample size for a two-group design with an ordered 
categorical outcome which will be analyzed using the Wilcoxon/Mann-Whitney 
rank-sum test, we use an example from a paper by E.I. Lesaffre, I. Scheys, J. 
Frohlich, E. Bluhmki (1993) Calculation of Power and Sample Size with Bounded 
Outcome Scores. Statistics in Medicine 12:1063-1078. 

A two-group, randomized, parallel, double-blind study is planned.  Patients will be 
randomly assigned to receive either a placebo or a new drug.  The sample sizes in 
the two groups will be equal.  A two-sided 5% level rank-sum test will be used to 
analyze the outcome measure, a coded version of a quality of life scale.  The 
expected proportions in each of five categories: 0, 5-30, 35-65, 70-95, 100 are 
approximately .23, .08, .10, .14, .45 for Group 1, and .13, .06, .10, .16, .55 for 
Group 2.  Researchers evaluated power for a sample size in each group of 150. 

To bring up the sample size table: 

Choose the File menu New option or click on , the New icon button 

In the Study Goal and Design Box, you will see three columns of options. 

Under Goal:  Make conclusion using, select Means. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test. 

Select Wilcoxon/Mann-Whitney rank-sum test (ordered categories) in the 
selection box. 

Click on OK. 

The table will come up empty.  The following table shows the entries for the test 
parameters, the number of categories and the desired sample size in column 1.     
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Enter the values shown in the table below, and leave your cursor in the first 
column.  

 

You must specify the proportions expected under the alternative hypothesis in each 
of the k categories for each group in order for nQuery to compute power.  To do 
this, you must use the Assistants menu Compute Effect Size option.   

Select the Assistants menu Compute Effect Size option, or click on the  
icon.   

You will see an empty side table associated with column 1 of the main table.   

 

Enter the proportions expected in each category for each group in the table. 
Note that nQuery updates the sum of the pi as you enter a proportion value for 
each category. 

Click on the Compute button to calculate the p1 value and the other information 
necessary for the approximation, see reference in the Appendix. 
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For this example, we have entered the values for the proportions expected in 
each category under the alternative hypothesis in the Lesaffre et al example, and 
clicked on the Compute button. 

 

Click on the Transfer button.  The main MTT2 table will reappear and the side 
table name and the value for p1 will display in the appropriate cells in the first 
column of the sample size table. The program will compute the power for an n 
per group of 150—here the computed power is 62%.  When the number of 
categories is large, it may require a few seconds to complete the computation.  

 

The “exact” power computed in the Lesaffre paper using all 21 categories and a 
smoothed alternative was 55% for an n per group of 150.  nQuery uses an 
approximation to the conditional power based on the first four moments, see 
reference in the Appendix and the guide card for the first row. 

Since a power of 62% is not sufficient, we use the second column to calculate the 
power for a larger sample.  
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To use the side table from the first column also for the second column: 

Use the Edit menu Copy option to copy the first four rows in the first column. 

Click on the first row of the second column and use the Edit menu Paste option 
to paste the values into the second column. Using the contents of side table E1, 
nQuery will enter the p1 value and provide the other necessary values for the 
second column.  

Enter 300 into the n per group row in the second column. nQuery will 
calculate the power of 89%. 

 

To use a new side table for the third column: 

To create a new side table similar to E1 but with some changes in the 
proportions, use the Edit menu Copy option to copy the first three rows in the 
first column. 

Click on the first row of the third column and use the Edit menu Paste option to 
paste the values into the third column. 

To bring up a side table for the third column, select the Assistants menu 

Compute Effect Size option, or click on the  icon.   

Enter the proportions into this side table by hand, or use the Window menu to 
select E1, the side table for column 1, Copy those values, return to E2, and 
Paste the values into E2, the side table for column 3. You can then edit these 
proportions as desired. 

Click on Compute. 

Click on Transfer to transfer the computed value to the third column. 

Enter the desired sample size into the n per group row in the third column, and 
nQuery will compute the power. 
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15. Sample Size Tables for 
Proportions  

Sample size tables for proportions assist you in determining the necessary sample 
size for studies in which: 

• the outcome variable measure is dichotomous (success/failure, alive/dead, 
yes/no) 

• you want to estimate or make tests on the proportion of “successes.” 

A number of sample size tables for proportions provide power using exact 
computations or simulation.  However formulas used by nQuery Advisor for sample 
sizes for many of the proportions tables use a normal approximation and are thus 
designed for large samples. For these, nQuery Advisor checks that the minimum 
expected cell size for the 2x2 or Gx2 table is greater than a preprogrammed default 
value. You will see a warning box if the minimum cell size falls below this value. If 
you see this box, you must check that the sample size computed by nQuery Advisor 
will be adequate; see Example 4 for the two-group χ2 test later in this chapter. In 
some cases, the default value used by nQuery may be too conservative and lead to 
an unnecessarily large sample size. You may want to use the Change Minimum 
Expected Cell Count option from the Options menu to reduce the required minimum 
cell count for your nQuery Advisor session. 

The nQuery Advisor program provides the following tables appropriate to studies in 
which the outcomes are proportions. Some of these tables have a version appropriate 
for sampling from finite populations. Those tables are denoted by an F at the end of 
the table code; see Chapter 19, Sampling from Finite Populations, for further details. 

Note that for exact tests, the actual probability of rejecting the null hypothesis when 
it is true is less than or equal to alpha, and in some cases may be markedly less than 
the specified nominal level.  For a two-sided test, nQuery uses the highest possible 
actual significance level for which the probability is less than or equal to α/2 in both 
tails.  Due to the fact that the attainable alpha level depends on the specified sample 
size, note that computed power may not increase monotonically with sample size for 
exact tests. See references for specific tables for details and advice. 
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Tests, Confidence intervals, and Equivalence 
Tests for single proportions or for differences  in 
paired proportions in a single sample: 

POT0 One group χχχχ2 test that proportion equals user specified value 
(normal approximation) 

POT0x Exact test for single proportion 

POT1 McNemar’s Test (χχχχ2) of equality of paired proportions  
 See Example 2 in this chapter. 

POT1x Exact sign test of equality of paired proportions 
See Example 2 in this chapter. 

POT2 Chi-square test of specified proportions in C categories 

POC0 Confidence interval for proportion using normal approximation 
(n large)  

See Example 1 in this chapter and example in Chapter 19. 

POC1 Confidence interval for ln(ΨΨΨΨΜΜΜΜ), odds ratio for paired proportions 
(n large) 

POC2 Confidence interval for probability of observing a rare event 

POE0 Paired test of equivalence in proportions (n large)  
See Example 9 in this chapter. 

POE1 Paired test of equivalence in proportions using confidence 
interval:  a) Lower confidence limit for difference in paired 
proportions (simulation), b) Upper confidence limit for difference 
in paired proportions (simulation), c) Two-sided confidence 
limits for difference in paired proportions (simulation) 

See Example 9 in this chapter. 

See Chapter 19 Sampling from Finite Populations for details for versions POT0F 
and POC0F.  
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Tests, Confidence Intervals, and Equivalence 
tests for comparisons of proportions in two 
independent groups: 

PTT0 Two group χχχχ2222 test of equal proportions (odds ratio = 1) 
(Compute power or sample size)  

See Examples 3 and 4 in this chapter.  

PTT0p Two group χχχχ2222    test of equal proportions  (Compute one of two 
proportions) 

  See Example 3 in this chapter. 

PTT1 Two group continuity corrected •2 test of equal proportions   
(odds ratio = 1) (Compute power or sample size)  

See Example 4 in this chapter. 

PTT1p Two group continuity corrected χχχχ2222 test of equal proportions    
(Compute one of two proportions) 

PTT2 Two-group Fisher’s exact test of equal proportions (odds ratio=1) 
 See Example 4 in this chapter. 

Sample size and power for PTT0 are derived using the large sample normal 
approximation. Those obtained from PTT1 use a correction factor designed to 
approximate results for Fisher’s Exact Test, and sample sizes will be larger and 
power lower than obtained using PTT0. Answers given by PTT2 are obtained using 
exact methods and will typically lie between those for PTT0 and PTT1. 

PTT3 Two-group Chi-square test comparing proportions in C 
categories 

 See Example 6 in this chapter. 

PTT4 Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S strata 
 See Example 7 in this chapter. 

PTT4cc Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S strata 
(Continuity Corrected) 

PTC0 Confidence interval for difference of two proportions 

PTC1 Confidence interval for difference of two proportions (continuity 
corrected) 

PTC2 Confidence interval for ln(odds ratio)  
See Example 5 in this chapter. 

PTE0 Two group test of equivalence in proportions (large n) 
      See Examples 10 and 11 in this chapter. 
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PTE1 Two group test of equivalence in proportions using confidence 
interval:   
a) Lower confidence limit for difference in proportions (simulation),  
b) Upper confidence limit for difference in proportions (simulation),  
c) Two-sided confidence limits for difference in proportions (simulation)  

See Examples 10 and 11 in this chapter.  

MTT2 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y) = 0.5 
(ordered categories)  

See Example 2 in Chapter 14, Nonparametric Methods. 

Tests for more than two groups 
PGT0 χχχχ2222 test of equal proportions in G groups 

PGT1 Trend across proportions, logistic model  
See Example 8 in this chapter. 

PGT2 G group Chi-square test comparing proportions in C 
categories 

All the proportions tables for two or more groups have versions allowing for 
unequal sample sizes. 

Example 1 
Confidence interval for proportion normal approximation 
(n large) (POC0)   

In educational institutions, administrators frequently need to estimate the percent of 
students satisfied with some aspect of the institutional program, for example, “What 
percent of eligible students plan to return next year?” To address this question, a 
sample survey will be mounted in which a random sample of students is selected 
from the undergraduate study body and asked about their intentions. Each student 
will be asked to answer the question (and others) with either a yes or a no.  

The estimated proportion of students who plan to return will be reported, together 
with a 95% confidence interval. The investigators want to know how many students 
must be questioned to estimate the retention rate to within ± 5%. It is hoped that the 
retention rate will be 60%.  

For this example, we assume that the student body is very large. See Chapter 19 for 
the solution to this same question when the size of the undergraduate student body is 
small and a finite sampling correction is required. 
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To bring up the sample size table for a confidence interval for a single 
proportion:  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, One group, Confidence Interval. 

Select the top entry from the choices in the lower half of the box. 

Click OK. The sample size table for Confidence interval for proportion using 
normal approximation (n large) will appear. 

The following table shows the confidence level, and two-sided interval all filled 
in. 

 

To complete the table, enter the expected proportion and the desired 
precision of the estimate: 

Enter .60 as the expected proportion. 

Enter 0.05 for the distance from the estimated proportion to the end of the 
confidence interval.  

nQuery Advisor will compute the required sample size. 
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For this example, a sample of 369 students would be necessary. 

To get the statement for this column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear and can be 
saved to clipboard, printed directly, or stored in the Stored Statements panel of 
your screen. Note that you can select the font to be used for the statement in 
Windows applications. See Chapter 3, The File and Options Menus for details. 

When the sample size is 369, a two-sided 95.0% confidence interval for a 
single proportion using the large sample normal approximation will extend 
0.050 from the observed proportion for an expected proportion of 0.600.  

Frequently, the investigator really doesn’t know what proportion of students are 
likely to express satisfaction, or the survey instrument will contain a variety of 
questions, and the investigator wants to have precision of at least ± 5% for every 
question. Since the required sample size for a specified confidence interval width is 
largest when the expected proportion is 0.50, the investigator can solve for the 
required sample size using an expected proportion of 0.5. 

 

The required sample size will be 385 for precision of ± 5% for a 95% two-sided 
confidence interval.  

Note:  This has given rise to the rule of thumb that a sample survey should 
have a sample size of 400. 

Example 2 
McNemar's test of equality of paired proportions (POT1) 
Exact sign test of equality of paired proportions (POT1x) 

To address the question of whether taking a certain diet drug combination increased 
the likelihood of requiring valve surgery, investigators wanted to design a 
retrospective case-control study.    
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The cases would be patients who had had valve surgery in a defined two-year 
period, and the controls would be pair-matched using age, gender, and body-mass 
index.  Cases and controls would be asked to fill out a survey to determine whether 
they had taken the diet drugs in question.   

It was expected that about 5% of controls would have taken the diet drugs.  What 
sample size would be necessary to have 90% power to detect an increase to 10% 
among the cases? 

We start by using the table for McNemar’s test. 

To bring up the sample size table for McNemar’s test:  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, One group, Test. 

Double click on the entry Paired responses, or click on the + sign to the left of 
that entry. 

Then select the top entry Paired responses: McNemar’s Chi-square test from 
the two choices below the heading Paired responses. 

 

Click OK. The sample size table for McNemar's test of equality of paired 
proportions will appear. 

The following table shows two rows filled in: significance level, and one or 
two-sided test. 
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To obtain a side table to allow you to enter the proportions of paired cases and 
controls expected to show each response pattern, select the Assistants menu 
Compute Effect Size option or click on the δδδδ button in the toolbar.  

You will see the following side table: 

 

Since the cases and controls are paired, you must specify: 

• the proportion of pairs in which both case and control are expected to use 
the diet drugs  

• the proportions in which only the case or only the control would be 
expected to be using the diet drugs.   

We postulate that 3% of pairs will have both case and control using the drug, and 
that a total of 5% of the controls and 10% of the cases are users of the diet drug.  So 
we will:  

1. enter .03 in the upper control-yes, case-yes cell of the 2x2 table 
2. enter .02 in the control-yes, case-no cell  
3. enter .07 in the control-no, case-yes cell.   

Then click on the button marked Compute, and nQuery will fill in the rest of the 
table.   
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The actual hypothesis being tested is that among discordant pairs, half are expected 
to be in the control-yes, case-no and half in the control-no, case-yes cells. Thus, the 
required sample size depends only on the proportions entered for the discordant 
cells. 

Click on the Transfer button to transfer these values back to the main table.  

 

Since the investigator wanted 80% power, enter 80 as the required power.  
nQuery reports that 262 case-control pairs would be required. 
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However, since only 9% (an expected number of 24 in a sample of 262) of the 
case-control pairs are relevant to the test of equality of paired proportions, the 
investigator wants to re-compute the required sample size, assuming that the 
exact sign test will be used for testing. 

To get the Exact sign test of equality of paired proportions table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, One group, Test. 

Double click on the entry Paired responses, or click on the + sign to the left of 
that entry. 

Then select the second entry Paired responses: Exact sign test from the two 
choices below the heading Paired responses. 

Click OK. The sample size table for Exact sign test of equality of paired 
proportions will appear. 

This table will look the same as the previous table, except that only one row is 
highlighted in yellow. Note that you cannot solve for n in this table, but only for 
power given n. Therefore you cannot type in a value for power.  

In this new table, enter the same values which were used in the first four rows 
of the table above. Enter 262 as the number of pairs.  nQuery reports that the 
power for the exact sign test is only expected to be 73%. The sign test is an 
exact binomial test that the proportions in the two discordant cells of the 2 x 2 
table are equal with a sample size equal to the observed number of discordant 
pairs. 
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After trying several values for n in the second column, we find that 305 case-
control pairs would provide 80% for an exact test.   

Note that for exact tests, the actual probability of rejecting the null hypothesis 
when it is true is less than or equal to alpha. As a consequence, the attainable 
alpha level depends on the specified sample size.  Therefore, computed power 
may not increase monotonically with sample size. For details and advice, see 
the references for this table as listed in the references pane. 

 

To get the statement for this column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear, and you can 
save it to clipboard, print the statement directly, or store the statement in the 
Stored Statements panel of your screen.  Note that you can select the font that 
you want the statement to appear in, see Chapter 3.  The File and Options 
Menus for details. 

A sample size of 305 pairs will have 80% power to detect a difference in 
proportions of 0.050 when the proportion of discordant pairs is expected 
to be 0.090 and the method of analysis is a sign test of equality of paired 
proportions with a 0.050 two-sided significance level. (The sign test is an 
exact binomial test that the proportions in the two discordant cells of the 
2 x 2 table are equal with a sample size equal to the observed number of 
discordant pairs.) 
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Example 3 
Two group χχχχ2 test (PTT0) – Compute power or sample size  
Two group χχχχ2 test (PTT0p) – Compute one of two 
proportions 

An investigator is planning a four-week clinical trial. He wants to compare a new 
drug to a placebo for effectiveness in healing duodenal ulcers.  The proportion 
healed after four weeks of treatment will be compared between the two treatment 
groups using a Chi-square test at the 5% level.  

Many previous trials suggest that 45% of those receiving the placebo will be healed 
at four weeks, and 75% of patients receiving standard H2 blockers will heal by four 
weeks. The investigator wants to have 95% power for the trial even if the new drug 
results in the healing of only 65% of patients. 

There are three appropriate tables for this design: 

• Two group χ2 test of equal proportions (odds ratio = 1)  

• Two group continuity corrected χ2 test of equal proportions  
(odds ratio = 1).  

• Fisher’s exact test.  

See Example 4 for illustrations of the latter two tables. 

To bring up the PTT0 sample size table for the Two group χχχχ2 test of equal 
proportions: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Test. 

Click on the + sign next to Chi-square test to compare two proportions and 
select the first option, Compute power or sample size. 

Click OK. The Two group χχχχ2 test of equal proportions (odds ratio=1) table 
will appear. 

The following table shows the significance level, 2-sided test, and power already 
filled in. 

Note: The standard χ2 test is, of course, automatically two-sided, and you 
should select a two-sided test in sample size tables for χ2. If you 
selected a one-sided test, you would get approximate sample sizes for 
the normal approximation test, rather than the χ2. 
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To customize and complete: 

Select the Edit menu Edit Row Names option. 

Rename Group 1 as Placebo and Group 2 as New drug. 

Click on the Update Row Name button. 

In the spreadsheet, enter .45 for the Placebo proportion. 

Enter .65 for the New drug proportion. The nQuery Advisor program will 
calculate the odds ratio and n per group. 

 

To complete the second column using one proportion and the odds ratio: 

Select the first three rows of column 1. 

Use the Edit menu Copy option or <Ctrl><C> or the Copy button to copy 
those rows. 

Click in the second column and use the Edit menu Paste option or the Paste 
icon in the toolbar or <Ctrl><V> to paste the values into column 2. 
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Enter the odds ratio and press <Enter>. The nQuery Advisor program will 
calculate the proportion for the second group. 

Enter the Power and press <Enter>. 

Then nQuery will calculate n per group. 

 

Whether you enter two proportions or one proportion and the odds ratio, you can see 
that this study will require 158 subjects per group to achieve 95% power.  

To get the statement for this column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear. 

 

To get a plot of power versus sample size for this column: 

Select the calculated column. 

Click on the Plot menu Plot power vs n option or use the left-most of the two 
Plot icon buttons. The following plot will appear.  For other plot options, select 
Plot user-selected rows or the right-most of the two Plot icon buttons. 
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Note that the plot above displays Greek characters. See Chapter 6, The Plot 
Menu for details on including Greek characters in the legend. 

Compute one of two proportions 
If you want to solve for the detectable difference between two proportions, rather 
than for power or sample size, then you can use table PTT0p 

For example, say that the investigator had only 90 patients available per group for 
this clinical trial. Given that the previous trials suggested that 45% of those 
receiving the placebo would be healed at four weeks, he wants to find the difference 
detectable with a power of 95%. 

To bring up the PTT0p sample size table for the Two group χχχχ2 test of equal 
proportions: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Test. 

Click on the + sign next to Chi-square test to compare two proportions and 
select the second option, Compute one of two proportions. 

Click OK. The Two group χχχχ2 test of equal proportions table will appear. 

The following table shows the significance level, 2-sided test, and power already 
filled in. 
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Enter .45 for the Smaller proportion, and enter 90 for n per group. The nQuery 
Advisor program will calculate the larger proportion, which for this example 
turns out to be .711.  That is, with a sample size of 90 in each group, the power 
will be 95% to detect the difference between a proportion of .45 and one of .711 
using a 5% level Chi-square test. 
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Example 4 
Two group χχχχ2 test (PTT0) and  
Sample Size Too Small Warning 
Two group continuity corrected χχχχ2 test  
of equal proportions (PTT1)   
Two-group Fisher’s exact test (PTT2) 

This example illustrates the relationship between the three sample size tables for 
comparison of two independent proportions.  Suppose an investigator thinks that one 
group will have almost all successes and another group almost all failures, and he 
enters the values shown into PTT0. 

 

When the investigator now wants to solve for the sample size per group giving 80% 
power, the warning box titled Sample Size Too Small will appear.  
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When you click on OK, PTT0 shows a required sample size of 3 per group. 

 

However, when the sample size is 3 in each group, the expected values in each cell 
under the null hypothesis are 1.5 successes and 1.5 failures in each group. Under the 
alternative hypothesis, the expected values of successes and failures in group 1 are 
0.075, and 2.925, respectively. In group 2 these expected values are 2.925 and 
0.075.  

Note:  A common rule of thumb in computing a χ2 test is that the minimum 
expected value in a cell is at least 5. Clearly, neither under the null 
hypothesis nor under the alternative can such a large cell size be 
expected. 

The minimum cell size computed by nQuery Advisor depends on the significance 
level chosen for the test. For a 5% two-sided test, the minimum cell size is 3.8, as 
shown in the warning box. When you see this warning box, you should evaluate 
whether the sample size computed is large enough to be adequate.  

For this example, the Fisher’s exact test cannot reject the null hypothesis at the two-
sided 5% level for any possible outcome if the sample sizes are as small as 3, so the 
computed sample size is far too small. In some other instances, however, you may 
see the warning box when the computed sample size is, in fact, adequate. 

The table PTT1 is designed to provide the sample size which would be required for 
the continuity corrected Chi-square test which serves as an approximation for the 
sample size required for Fisher’s exact test. 

Filling in the PTT1 table with the same numbers, we obtain the following results. 
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The same Sample Size Too Small warning box is seen, and the required sample size 
is shown as 5 per group. 

Let us now turn to the table (PTT2) which makes exact calculations of power for 
Fisher’s exact test. We enter the same information but now instead of entering 
power and solving for sample size, we enter values 3, 4, and 5 for sample size and 
have nQuery compute the actual power for Fisher’s exact test. Results are shown in 
the following table. 

 

When n is 3 in each group, it is impossible to reject the null hypothesis at the two-
sided 5% level and nQuery returns a power of 1%. For a sample size of 4 in each 
group the power is 81%, and for a sample size of 5 in each group, the power is 97%. 
Exact results will frequently lie between results from the PTT0 and PTT1 tables. 

In the following example, the Sample Size Too Small warning box is seen, but the 
sample size obtained using PTT0 is, in fact, adequate. The tables below are obtained 
by using Print Table to Clipboard from the File menu.   

The Print Table to Clipboard option uses RTF format to preserve the table 
structure. This means that you can use your own font choice for the text and 
numbers, along with the symbol font for the Greek symbols.  For details, see 
Chapter 4, The Edit Menu. 
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  Two group χχχχ2 test of equal proportions (odds ratio = 1) (equal n's) 
 1 

  Test significance level, α   0.025 
  1 or 2 sided test?    1 
          Group 1 proportion, π1  0.025 
          Group 2 proportion, π2  0.500 
      Odds ratio, ψ = π2 (1 - π1) / [π1 (1 - π2)]    39.000 
  Power ( % )      90 
  n per group  16 

 

  Two group continuity corrected χχχχ2 test of equal proportions  
  (odds ratio = 1) (equal n's) 

 1 
  Test significance level, α   0.025 
  1 or 2 sided test?    1 
          Group 1 proportion, π1  0.025 
          Group 2 proportion, π2  0.500 
      Odds ratio, ψ = π2 (1 - π1) / [π1 (1 - π2)]    39.000 
  Power ( % )      90 
  n per group  20 

 

Two group Fisher's-exact test of equal proportions  (equal n's) 
 1 2 3 4 5 

  Test significance level, α   0.025   0.025   0.025   0.025   0.025 
  1 or 2 sided test?    1    1    1    1    1 
          Group 1 proportion, π1  0.025  0.025  0.025  0.025  0.025 
          Group 2 proportion, π2  0.500  0.500  0.500  0.500  0.500 
  Power ( % )      87      90      92      94      95 
  n per group  16  17  18  19  20 

Note that the power cannot be expected to increase monotonically for all parameter 
choices. 

For this example, the sample size given by PTT0 is adequate and gives almost the 
desired power, while the sample size given by PTT1 is larger than necessary. 

Under the null hypothesis, the expected value in each cell is 8, perfectly adequate 
for a two-sided 5% level test. Under the alternative hypothesis, the expected values 
for group 1 are 8 and 8, and for group 2 are 0.4 and 15.6. However, the expected 
values per cell which are relevant to the validity of Type I error are the expected 
values conditioned on the margins of the observed table. Those expected values are 
expected to be 4.2 in the smallest cells, a value which should be adequate for 
validity of the χ2 test.  
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Example 5 
Confidence interval for ln)(PTC2) 

In many epidemiologic applications, the investigator wishes to estimate the odds 
ratio and a confidence interval for it. 

In this example, the investigators plan to evaluate an educational program for 
expectant mothers. The educational program attempts to reduce the risk of preterm 
birth among expectant mothers who are seen in county prenatal clinics.  

Previous studies have found preterm birth rates of 7-9% in similar populations. The 
intervention would be of interest if it reduced the rate of preterm births enough to 
produce an odds ratio of 0.5.  

The investigator tentatively plans to assign 500 pregnant women to a control group 
and 500 to an educational intervention group. The question is: how wide is the 95% 
two-sided confidence interval for the odds ratio likely to be? 

The appropriate table for this design is Confidence interval for ln(odds ratio.  

To bring up the PTC2 sample size table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two, Confidence. 

Select the third analysis method from the list of analysis methods. 

Click OK. The Confidence interval for ln(odds ratio) table will appear with no 
values entered. The following table shows the table with values for confidence 
level and 2-sided interval already filled in. 
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To complete the table using one proportion and the odds ratio: 

Enter .08 for the proportion of preterm births expected in the Control group.  

Type 0.5 for the Odds ratio and 500 for the n per group to get the following 
completed column. nQuery Advisor will calculate the proportion expected in 
the Education group, the natural log of the odds ratio and the expected distance 
from the log odds ratio to the upper or lower limit of the confidence interval. 

 

To get the statement for this column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear. 

 

The statement gives the actual lower and upper confidence limits expected for an 
odds ratio of 0.5 when 500 patients are studied in each group; here, they are 0.290 
and 0.862. 



    
 

Sample Size Tables for Proportions — 15-23  

Example 6  
Two-group Chi-square test comparing proportions  
in C categories (PTT3) 

Investigators want to evaluate whether the combination of two genetic markers has a 
relationship to the type of inflammatory bowel disease.  Two groups of patients will 
be studied, those with Crohn’s disease and those with Ulcerative Colitis.    

The proportions who have both markers, only marker A, only marker B, or neither 
marker will be compared using a Chi-square test.  The same number of patients will 
be recruited from each of the two diagnostic groups, so we will use a two-group 
Chi-square test with equal n's.  

(Please note that there is no unequal n’s version of this table. If you have unequal 
n's, you must use a different table to find sample size or power for a two-group 
design with C response categories and unequal n’s in the two groups. In the Study 
Goal and Design box, select Proportion, >Two groups, Test, and select the third 
item in the list, G group Chi-square test comparing proportions in C categories, 
and mark the box for Unequal n’s.  When the table appears, enter 2 for the number 
of groups.) 

To bring up the sample size table for a 2 x C Chi-square:  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Test. 

Select the fourth entry in the list, Two-group Chi-square test comparing 
proportions in C categories. 

Click OK. The sample size table will appear. 

The following table shows the significance level, and the number of response 
categories already filled in. 
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To obtain a side table to allow you to enter the expected proportions in each 
category in each of the two groups, select the Assistants menu Compute Effect 
Size option or click on the δδδδ button in the toolbar.  

You will see the following side table: 

 

For Group 1, enter the proportions of subjects expected in each of the four 
categories: 

Cat. 1 - both markers 
Cat. 2 - marker A only 
Cat. 3 - marker B only 
Cat. 4 - neither marker 

For Group 2, enter the proportions expected in the four categories.  

When you have finished entering the proportions into the category cells, the 
Compute button will activate. Click on the Compute button.  nQuery will fill in 
the rest of the table, and the Transfer button will activate.  
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Click on Transfer to transfer the effect size back to the main table. 

 

The investigator hopes that 40 subjects in each group will provide reasonable 
power.  So enter 40 in the bottom row for n per group.  nQuery calculates the 
power as 92%, so the planned study size is adequate.  

  

You can print out the table and side table, or you can save the tables. 

Example 7  
Mantel-Haenszel (Cochran) test of OR=1  
for 2x2 tables in S strata (PTT4) 

Investigators plan a clinical trial in which a new drug for prevention of nighttime 
heartburn will be compared to a placebo.  It is felt that body mass index may 
influence the response rates, so patients will be assigned to three strata based on 
BMI.  In the target population, it is expected that 35% will have a BMI less than 25, 
45% will have a BMI from 25 to less than 30, and 20% a BMI of 30 or greater.    

Investigators wish to test whether the odds ratio for comparing the success rate in 
the treated group to that in the placebo group differs from 1.0, assuming that it is not 
affected by the BMI stratum.  The data will be analyzed using the Cochran test 
(closely related to the Mantel-Haenszel test).  
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To bring up the sample size table for Mantel-Haenszel (Cochran) test:  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Test. 

Double click on the entry Mantel-Haenszel (Cochran) test, or click on the + 
sign to the left of this entry. 

Then select the top one of the two choices, Mantel-Haenszel (Cochran) test of 
OR=1 for 2x2 tables in S strata. 

Click OK. The sample size table for Mantel-Haenszel (Cochran) test of 
OR=1 for 2x2 tables in S strata will appear. 

The following table shows the significance level, one or two-sided test, and the 
number of strata filled in. 

 

A side table will allow you to enter the expected proportions of each group in 
each stratum, the OR, and the response rates expected in each stratum for the 
placebo group. To obtain a side table, select the Assistants menu Compute 
Effect Size option or click on the δδδδ button in the toolbar.  

You will see the following side table: 
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Proportion of subjects expected in each stratum, fS  

In the column headed fS enter the proportion of subjects expected in each of the 
three BMI strata.   

Proportion responding in each stratum among Controls,  ππππ1S   

In the column headed Controls, π1S, enter the proportions of placebo-treated 
patients expected to report successful prevention of nighttime heartburn for 
each of the three strata. In this example, we expect that the prevention rates will 
decrease as BMI increases. 

Odds Ratio, OR 
Enter the expected odds ratio and press <Enter>.  Here we are looking for the 
odds ratio of 1.6 or greater. nQuery will automatically calculate the resulting 
proportions reporting successful prevention of heartburn expected for the active 
treatment group in each of the strata.    

After you have entered all necessary values, the Compute button will be 
activated. Click on the button marked Compute. The nQuery program will fill 
in the rest of the table, and the Transfer button will be activated.  
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Click on Transfer to transfer these values back to the main table. For this 
sample size table, the values of the three parameters necessary for computing 
sample size will not be displayed in the main table. However, the name of the 
side table will appear, and you can copy and paste that name to other columns.   

 

Note: Changing the values in this side table will affect all columns in which 
its name appears. 

Since the investigator wants 90% power, enter 90 as the required power and press 
the <Enter> key.  nQuery reports that 90% power requires 393 assigned to the 
placebo group and the same number to the active treatment group, for a total of 
almost 800 subjects needed for the clinical trial. 
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To get the statement for this column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear and can be 
saved to clipboard, printed directly, or stored in the Stored Statements panel of 
your screen 

 

Example 8 
Test for linear trend in G x 2 table (logistic model)(PGT1) 

nQuery Advisor provides sample size computations for a logistic model when the 
response variable is yes/no and the covariate is a discrete ordered variable such as 
fixed dose levels. Suppose the investigator wants to demonstrate a dose response to 
5 doses of a new drug to prevent transplant rejection. The response variable is 
survival to a fixed time post transplant. 

To bring up the PGT1 sample size table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, >Two, Test. 

Select the second analysis method from the list of analysis methods. 
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Click OK. The Trend across proportions, logistic model table will appear 
with no values entered. The following table shows the table with values for 
significance level, 2-sided test, and 5 groups entered.  

 

To obtain a side table to allow you to enter the proportions expected to survive 
at each dose level, select Compute Effect Size from the Assistants menu or 
click on the δδδδ button. 

Enter the proportions expected at each dose level. The coefficients necessary to 
test for linear trend for equally spaced doses have already been entered in the 
table. If your doses are unequally spaced, replace these with the appropriate set 
of coefficients. 

When all values have been entered, click on Compute to see the summary 
values shown. 
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After computing, click on Transfer to transfer these values back to the main 
table. For this study, the investigator wants to have 80% power. At least 19 
animals would be required per dose group. 

 

Note that the side table can be printed to Clipboard for inclusion in other documents, 
printed directly, and/or saved with the main table. 
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Example 9 
Equivalence and Bioequivalence  
for Paired Proportions 

Paired test of equivalence in proportions (n large)  
(POE0) 
Paired test of equivalence in proportions: Lower 
confidence limit for difference in paired proportions 
(simulation), Upper confidence limit for difference in 
paired proportions (simulation), Two-sided confidence 
limits for difference in paired proportions (simulation)  
(POE1abc)  

An investigator wishes to demonstrate that sensitivity for a new cheaper diagnostic 
test is as least as high as that of the standard diagnostic test, about 85%. If the 
investigator wants to demonstrate that sensitivity with the new test is no more than 
5% lower than the older test, how big a sample of patients with the disease must be 
evaluated using both tests?    

She wants to demonstrate non-inferiority for the new diagnostic test.  The null 
hypothesis to be tested is H0:  πT – πS  ≤ -.05 (i.e. sensitivity is not equivalent and is 
inferior) versus the alternative hypothesis that H1:  πT – πS  >  -.05 (sensitivity is not 
inferior).   

The investigator wants a power of 85% when the two tests have equal sensitivity.   
The data will be analyzed using the Blackwelder approach to testing equivalence of 
paired proportions.   

To get a preliminary idea of the required sample size, we use the table Paired test of 
equivalence in proportions (n large)  (POE0).  To bring up this sample size table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, One group, Equivalence. 

Select the first entry Paired responses: Equivalence of Proportions. 

Click OK. The sample size table for Paired test of equivalence in proportions 
(n large) will appear. 

The following table shows the significance level already filled in. 
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The specified equivalence limit difference is -.05 (the null hypothesis of 
inferiority.) The expected difference is 0.0 (the alternative hypothesis of 
equivalence or non-inferiority). We enter those values in their respective rows. 

We must now specify the expected proportion discordant, that is, the proportion 
of patients in whom the two diagnostic tests will disagree under the alternative 
hypothesis.  Since both margins of the 2x2 table are assumed to be .85 for the 
probability of a positive test, if the results on the two tests were independent, we 
would expect: 

• both to be positive in 72.35% of patients 
• standard to be positive and test negative in 12.75% of cases 
• standard to be negative and test positive in 12.75% of patients 
• both to be negative in 2.25% of patients.   

For this scenario, the proportion of discordant results would be .255.   However, 
we would expect a positive correlation between test results; that is that the 
outcomes “both positive” and “both negative” would be more likely than under 
the independence scenario. So, let us postulate that the values in the four cells 
are 80%, 5%, 5%, and 10% respectively, with a total of 10% discordant.  So, we 
enter 0.10 for the proportion discordant.  We then enter 85 for the requested 
power.  nQuery reports that a sample size of  288 patients with the disease will 
be required. 
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Now we want to compare the number of pairs required for 85% power versus 
90% power. To calculate 90% power, we use the Edit menu Copy option to 
copy the entries in the first four rows of column 1. We use the Edit menu Paste 
option to paste those entries into the first four rows of column 2. 

Type 90 in the Power row for column 2, and nQuery computes 343 pairs for 
90% power. 

 

Results for this sample size table are based on a normal approximation.   

Since the equivalence test is essentially based only on the number of patients in 
which there is discordance (expected to be about 34 when 343 are enrolled), we 
want to check that the 343 cases will really be enough.  To do this, we use 
another sample size table in nQuery which computes power for a test of non-
equivalence based on the observed lower limit of the confidence interval for the 
difference in proportions. 
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To bring up the sample size table for Lower confidence limit for difference 
in paired proportions:  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, One group, Equivalence. 

Double click on the entry Paired responses: Equivalence of proportions 
(using Confidence Interval), or click on the + sign to the left of that entry. 

Then select the top of the three choices, Lower limit for confidence interval 
for ππππT-ππππS (paired responses). 

Click OK. The sample size table for Lower confidence limit for difference in 
paired proportions (simulation) will appear. 

The following table shows the confidence level, and the expected difference 
filled in. 

 

This table has a side table to help you fill in the expected proportions.  

To obtain a side table to allow you to enter the expected proportions of patients 
in each cell of the 2x2 table, select the Assistants menu Compute Effect Size 
option, or click on the δδδδ button in the toolbar.  

You will see the following table.  We have already filled in the postulated 
proportions described above. 
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Click on the Compute button, and nQuery computes the summary values. 

 

Note that the values we have postulated correspond to an assumed correlation of 
.608 between the results of the two tests, see bottom row of the side table.  Click 
on the Transfer button, and nQuery will transfer the necessary summary values 
back to the main table. 
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Enter the value -.05  for the lower limit of the confidence interval for πT – πS .   

At this point, you must select a number of simulated experiments. Here we enter 
3600 to get an estimate of power accurate to within about ± 1% for powers near 
90%.  Next you specify a random seed for the simulation (any integer greater 
than or equal to 0), along with n, number of pairs, then nQuery Advisor will 
provide an estimate of the power. We enter 12 for the random seed for the 
simulations, enter the sample size 343 and press the <Enter> key.  

nQuery Advisor will first give an estimate of how long the calculations will take 
on your computer; you can choose to cancel, or run minimized. If you do not 
run minimized, when nQuery starts the 3600 simulations to calculate the Power, 
you can watch the progress of the calculation or cancel the process. 
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If you click on the Cancel button, you will see a dialog box outlining the 
calculations performed so far. 

 

Using this dialog box, you can continue the simulations or confirm the 
cancellation. (This simulation takes about 20 seconds on a 600 MHz computer.) 

For details on the simulation method used, see Methods of Computation for 
Each Table in Section 1 of the Appendix.  

 

The computed power is a little less than 90%, so in the next column we re-
compute power with an n of 355.  
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To get the statement for the second column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear, and you can 
save the statement to clipboard, print it out directly, or store the statement in the 
Stored Statements panel of your screen. Note that you can select the font to be 
used for your statement, see Chapter 4, The Edit Menu for details. 

With 355 subjects, the lower limit of the observed one-sided 95.0% 
confidence interval will be expected to exceed -0.050 with 90% power 
when the Expected difference, πT - πS, ∆1, is 0.000 and the Proportion 
discordant, η = π10 + π01, is 0.100 and the Proportion both yes, π11, is 
0.800;  results are based on 3600 simulations using the Newcombe-
Wilson score method to construct the confidence interval. (Newcombe 
RG (1988) Improved confidence intervals for the difference between 
binomial proportions based on paired data.  Statistics in Medicine 
17:2635-2650.) 

If the investigator wanted to demonstrate that sensitivity for the new test was neither 
higher nor lower than that for the standard, she could use the table Two-sided 
confidence limits for difference in paired proportions (simulation)  (POE1c).  

Example 11 shows how to use the two one-sided test (TOST) approach to 
demonstrating equivalence in the context of independent proportions. 
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Example 10 
Equivalence and Bioequivalence for Independent 
Proportions  

Two group test of equivalence in proportions (PTE0) 
Two group test of equivalence in proportions:  
Lower confidence limit for difference in proportions 
(simulation),  
Upper confidence limit for difference in proportions 
(simulation),  
Two-sided confidence limits for difference in proportions 
(simulation) (PTE1abc) 

What sample size is required for a study comparing a new type of dental implant to 
a reference standard?  Outcome variables are five-year implant success rate, pocket 
depth, gingival health scores and rate of bone loss.  Previous results with the 
standard implant show success rates varying from 90% to 95%.   

We pose the question as one of demonstrating non-inferiority.  The null hypothesis 
to be tested is H0:  πT – πS  ≤ -.05 (i.e. five-year success rate with the new implant is 
not equivalent and is inferior to that with the standard) versus the alternative 
hypothesis that H1:  πT – πS  >  -.05 (success rate is not inferior).   

The investigator wants a power of 85% when the two types of implants have the 
same success rate.   The data will be analyzed using the Blackwelder approach to 
testing equivalence of independent proportions.   

To get a preliminary idea of the required sample size, we use the table Two group 
test of equivalence in proportions (PTE0).  To bring up this sample size table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Equivalence. 

Select the first entry Two group test of equivalence in proportions. 

Click OK. The sample size table for Two group test of equivalence in 
proportions (large equal n’s) will appear. 

The following table shows the significance level already filled in. 
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In the first column, we will compute sample size assuming that the success rate 
for the standard implant is 90%, so enter 0.90 in the Standard proportion row of 
the table. The specified equivalence limit difference is -.05 (the null hypothesis 
of inferiority), and the expected value for the proportion of successes for the 
new implant is 0.90, so the difference is 0.0 (the alternative hypothesis of 
equivalence or non-inferiority).    

The investigator wants 85% power, so enter  85 for the requested power and 
press <Enter>.  nQuery reports that a sample size of  518 patients must be 
studied with the new implant type, and the same number with the reference 
implant, for a total of 1036 patients needed in the trial. 

 

We will use the second column to see what sample size will be needed if both 
standard and test success rates are 95%.   
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We see that the assumptions made about the expected success rates have a large 
influence on the required sample size.   

Results for this sample size table are based on a normal approximation.   

Since the expected proportions are 90% and 95%, we want to check that these 
sample sizes are adequate.  To do this, we use another sample size table in 
nQuery, the table which computes power for a test of non-equivalence based on 
the observed lower limit of the confidence interval for the difference in 
proportions. 

To bring up the sample size table for Lower confidence limit for difference 
in proportions (simulation):  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Equivalence. 

Double click on the second entry Two group test of equivalence in 
proportions (using Confidence Interval), or click on the + sign to the left of 
this entry. 

Then select the upper of the three choices, Lower limit of confidence interval 
for ππππT – ππππS .  

 Click OK. The sample size table for PTE1a will appear. 

The following table shows the confidence level, and the expected proportions 
for standard and test already filled in. 
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Enter the value -.05  for the lower limit of the confidence interval for πT – πS .   

At this point, you must select a number of simulated experiments. Here we enter 
5100 to get an estimate of power accurate to within about ± 1% for powers near 
85%.  

(The confidence interval for a proportion, p, extends about  ± 2sqrt(p(1-p)/n) 
using the normal approximation to the binomial, so when p=.85 and n=5100, 
this value is ±.01.) 

Next you specify a random seed for the simulation (any integer greater than or 
equal to 0), along with n, number of pairs, then nQuery Advisor will provide an 
estimate of the power. We enter 35 for the random seed for the simulations, 
enter the sample size 518 obtained using the previous table PTE0 and press the 
<Enter> key. You will see dialog boxes showing the progress of the simulation, 
see Example 9 for details. (The simulation for this example takes about 40 
seconds on a 266 MHz computer.) 

For details on the simulation method used, see Methods of Computation for 
Each Table in Section 1 of the Appendix. 
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The computed power is a little less than 85%;  in the second column we 
compute power under the assumption that the success rates are higher, using an 
n of 274 per group, the sample size obtained using the previous table, PTE0.  

 

To get a statement for the second column: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear and can be 
saved to clipboard, printed directly, or stored in the Stored Statements panel of 
your screen. Note that you can select the font to be used for your statement. See 
Chapter 4, The Edit Menu for details. 

With 274 subjects in each group, the lower limit of the observed one-
sided 95.0% confidence interval will be expected to exceed -0.050 with 
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82% power when the Standard proportion, πS, is 0.950 and the Test 
expected proportion, πT, is 0.950;  results are based on 5100 simulations 
using the Newcombe-Wilson score method to construct the confidence 
interval. (Newcombe RG (1988) Interval estimation for the difference 
between independent proportions: comparison of eleven methods.  
Statistics in Medicine 17:873-890.) 

Unequal n's 
If the investigator wanted to study fewer patients in the group receiving the standard 
implants, sample size could be determined for unequal n’s. The PTE1 tables are 
available for unequal n's.  

You can access the unequal n's version of a table in two ways:  

• Request unequal n's version of the current table 
• Use Study Goal and Design box to request new table for unequal n's 

To get the Unequal n's version of the current table: 

Click on the Unequal n's button, . 

Or, click on the File menu New option or , the New icon. The Study Goal 
and Design dialog box will appear. 

Select Proportions, Two group, Equivalence. 

Double click on the second entry Two group test of equivalence in 
proportions (using Confidence Interval), or click on the + sign to the left of 
that entry. 

Then select the top one of the three choices, Lower limit of confidence 
interval for ππππT – ππππS .  

Check the Unequal n's field in the lower left of the Study Goal and Design box.  

Click OK. The sample size table for PTE1aU will appear. 
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You work with this table in the same way as the previous, equal n's table, except that 
now you must enter the sample sizes for each group. 

Bioequivalence – Test results are neither higher nor lower 
For studies in which you want to demonstrate that results for the new test are neither 
higher nor lower than the results for the standard, you could use the table Two-sided 
confidence limits for difference in proportions (simulation)  (PTE1c).  For an 
example of finding the sample size for a two one-sided test (TOST) approach to 
demonstrating equivalence, see Example 11, the next example in this chapter. 

Example 11 
Equivalence and Bioequivalence  
for Independent Proportions (TOST procedure) 

Two group test of equivalence in proportions (PTE0)) 
Lower confidence limit for difference in proportions 
(simulation), Upper confidence limit for difference in 
proportions (simulation), Two-sided confidence limits for 
difference in proportions (simulation) (PTE1)abc)  

What sample size is required for a study to demonstrate that the proposed ED50 of a 
new drug is comparable to the ED50 of the standard?  Rats will be randomly 
assigned to either the new or the standard drug, and the proportion of rats showing 
the required response will be recorded.   
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The ED50 of the new drug should be neither more nor less potent than that of the 
standard; that is both should produce a 50% response rate.   The two doses will be 
considered equivalent if we can reject both: 

• the null hypothesis that H0L:  πT – πS  ≤ -.10    
and  

• the null hypothesis that H0U:  πT – πS  ≥ +.10 each at a one-sided 5% level.    

Alternatively, one requires that a 90% confidence interval for πT – πS has lower limit 
above -0.10 and upper limit below +0.10.  The investigator wants a power of 90% when 
the ED50 does have the same 50% response rate.   The data will be analyzed using the 
Newcombe-Wilson score method to construct the confidence interval. 

To get a preliminary idea of the required sample size, we use the table Two group 
test of equivalence in proportions (PTE0).   

To bring up the PTE0 sample size table: 

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Equivalence. 

Select the first entry Two group test of equivalence in proportions. 

Click OK. The sample size table for Two group test of equivalence in 
proportions (large equal n’s) will appear. 

The following table shows the significance level already filled in. 

 

We compute sample size for a test of the single null hypothesis H0L by assuming 
that the response rate for the standard drug is 50%, so enter 0.50 in the second 
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row of the table. The specified equivalence limit difference is -.10 (the null 
hypothesis of less effectiveness.)  

The expected value for the proportion of successes for the new drug is 0.50, so 
the difference is 0.0 (the alternative hypothesis of equivalence).   The 
investigator wants 90% power for the two tests, so enter  95 for the requested 
power for this single test. Power for the combined tests is obtained as 100 times 
(1-2β) where β is the probability of a Type II error for a single test under the 
alternative of equality of the two proportions. nQuery reports that a sample size 
of 542 rats must be studied with each drug, for a total of 1084 rats needed in the 
study. 

 

Although we expect that a sample size sufficient for 95% power for each of the 
single tests will provide 90% power for both when the two drugs are, in fact 
equivalent, we can check this by using another sample size table in nQuery.  
This table computes power for a test of non-equivalence based on the observed 
upper and lower limits of the confidence interval for the difference in 
proportions. 

To bring up the sample size table for Two-sided confidence limit for 
difference in proportions (simulation):  

Click on the File menu New option or , the New icon. The Study Goal and 
Design dialog box will appear. 

Select Proportions, Two group, Equivalence. 

Double click on the second entry Two group test of equivalence in 
proportions (using Confidence Interval), or click on the + sign to the left of 
the entry. 
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Then select the third of the three choices: 
 Two sided confidence interval for ππππT – ππππS.  

Click OK. The sample size table for Two-sided confidence interval for 
difference in proportions (simulation) will appear. 

The following table shows the confidence level, and the expected proportions 
for standard and test already filled in. 

 

Enter the value -.10  for the lower limit of the confidence interval for πT – πS  
and +0.10 for the upper limit.  Request the desired number of simulations;  here 
we enter 3600 to get an estimate of power accurate to within about ± 1% for 
powers near 90%.   We also enter a value for the random seed for the 
simulations, and enter the sample size 542.  

As discussed in Example 9 in this chapter, nQuery Advisor will first give an 
estimate of how long the calculations will take on your computer; you can 
choose to cancel, or run minimized. If you do not run minimized, when nQuery 
starts the 3600 simulations to calculate the Power, the Progress of Simulations 
dialog box appears. You can use that dialog box to watch the progress of the 
calculation or cancel the process. 
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The computed power is 90% as expected.  

 

To get a statement for this result: 

Click on any cell in the calculated column. 

Click on the Create Statement button. The statement will appear and can be 
saved to clipboard, printed directly, or stored in the Stored Statements panel of 
your screen. Note that you can select the font to be used for your statement, 
while preserving Greek symbols. For details, see Chapter 4, The Edit Menu. 

With 542 subjects in each group, the observed two-sided 90.0% confidence 
interval will be expected to lie between -0.100 and 0.100 with 90% power 
when the Standard proportion, πS, is 0.500 and the Test expected 
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proportion, πT, is 0.500;  results are based on 3600 simulations using the 
Newcombe-Wilson score method to construct the confidence interval. 
(Newcombe RG (1988) Interval estimation for the difference between 
independent proportions: comparison of eleven methods.  Statistics in 
Medicine 17:873-890.) 

Unequal n's 
If the investigator wanted to study fewer patients in the group receiving the standard 
drug, sample size could be determined for unequal n’s. You can access the unequal n's 
version of a table in two ways:  

• Request unequal n's version of the current table by clicking on , the 
Unequal n's button. 

• Use the Study Goal and Design box to request a new table for unequal n's. 
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16.  Survival Analysis Tables 
Survival analysis methods are designed for studies in which patients are entered into 
a trial and followed until a specified event occurs, they are lost to followup, or the 
study ends. For example, researchers might follow patients until death, hospital 
discharge, cancer recurrence, or heart attack.  

The essential difference between survival analysis methods and the methods 
appropriate for comparing means or proportions has to do with the outcome 
measure. For some patients in a survival study, the outcome measure, time to the 
event of interest, is known only to be larger than some followup interval.  

For example, in a five year study, one patient who entered the trial 18 months before 
its termination is known not to have had a heart attack during the 18 months before 
the study ended. Another patient was followed only 3 months before he left the state 
and could not be contacted further. In the first case, time to heart attack is known to 
be longer than 18 months. In the second case, time to heart attack is known to be 
longer than 3 months. This type of data is called right censored. 

If all patients are followed for the same fixed time period, say 3 years, we could 
simply analyze the proportion of patients surviving (not having the event of interest) 
during that time. We could use sample size methods based on comparison of 
proportions. However, even when the data are not censored at different time points, 
we may lose information by ignoring the time to the event. For example, survival 
under two treatment regimens might look much the same by three years when most 
of the patients have suffered a recurrence, but might differ considerably during the 
first year. 

If the researchers followed all patients until the event of interest occurred, recording 
time to the event, we could analyze these continuous measurements of time to event 
by comparing groups on mean time to event. Thus, we could determine sample sizes 
by using methods for comparisons of means, although time to event data typically 
have distributions which are skewed to the right. For example, length of hospital 
stay is generally only 3-5 days, but some patients are hospitalized for weeks. In 
addition, following all subjects until the event of interest occurs is often not feasible. 
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We can base sample size computations for survival studies on:  

• an estimate of the surviving proportions at some fixed time 

• a model for the entire survival curve.  

To open a survival sample size table:  

Select File menu New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Survival. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

 

These selections bring up the four sample size tables for survival analysis. From 
each of the survival sample size tables, you can access a table which helps you to 
convert between different parameters characterizing expected survival times. See 
Example 2 in this chapter for details on using the parameter conversion table. 

Log-rank test for equality of survival curves 
This sample size table provides sample size estimates for an analysis based on the 
nonparametric log-rank test. It is assumed that all patients are followed for a fixed 
length of time, and that the hazard ratio is constant over time. 
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Test based on exponential survival,  
accrual period STT0 

This sample size table provides sample size estimates for an analysis based on the 
assumption that the survival curves are exponential in shape. This restrictive 
assumption may lead to smaller sample size estimates than given by the sample size 
table based on the log-rank test.  

Test based on exponential survival,  
accrual period, dropouts STT2 

This sample size table is the same as the preceding one, except that it provides for 
dropouts which follow an exponential model. 

Log-rank test with user specified survival,  
hazard, accrual, dropout rates, simulation STT3 

This table allows user specification of survival curves which are not exponential in 
shape, or hazard ratios which are not constant throughout, and more complex 
patterns of accrual or dropout.   The table provides a simulation solution for power 
given sample size.   There are two versions of this table, one requiring equal sample 
sizes in the two groups and one which allows unequal sample sizes in the two 
groups. 

See references for these sample size methods in Section 1 of the Appendix or in the 
Help menu under Methods of Computation for each table.  

Example 1 
Computing Sample Size Based on the Log-rank Test 
(STT0) 

To illustrate this procedure, we use an example involving the study question: Does 
TIPS surgery for bleeding esophageal varices prolong life over shunt surgery? The 
study design calls for randomization to one of two parallel groups; in group 1 
patients will receive shunt surgery, and in group 2 patients will receive the TIPS 
procedure. 



 

    
 

16-4 —  Survival Analysis Tables 

The primary outcome measure is time to death due to any cause. All patients will be 
followed for a minimum of one year; in prior studies no patients were lost to 
followup. Data will be analyzed using the survival analysis log-rank test with a two-
sided 5% significance level. Based on results in previous studies, it is expected that 
65% of patients will survive one year following shunt surgery. TIPS surgery would 
be considered to be markedly worse if only 45% of patients survived one year; the 
investigator wants 85% power for this alternative. 

To calculate n for this example based on log-rank test, open the survival 
sample size table for log-rank: 

Select File menu  New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Survival. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Choose the first option, Log-rank test for equality of survival curves.  You 
will see the following table. 

 

In the Test significance level row, enter .05 and press <Enter>. 
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In the 1 or 2 sided test row, enter 2 and press <Enter>. 

In the Group 1 proportion row, enter .65 and press <Enter>. 

In the Group 2 proportion row, enter .45 and press <Enter>. The program will 
calculate the Hazard ratio. 

 

In the Power row, enter 85 and press <Enter>. The program will calculate the n 
per group, and the total number of required events. 

 

In the context of this example, the total number of required events would be the 
number of deaths that must be observed (in the two groups combined) to 
achieve the specified power. 

Total number of events required 
The total number of events required, E, is the number of events that must be 
observed in the two groups combined to achieve the specified power for the test 
comparing survival in the two groups. Note that this does not depend on accrual or 
dropout rates but only on specified significance level, power, and the natural log of 
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the hazard ratio; see Help or Appendix for formula. The derivation of the number 
of required events includes an approximation, so the calculated number of required 
events may be an underestimate. To compensate for this, some rounding up of the 
calculated value is suggested. 

 
Now that you have the required n per group, click on the Create Statement 
button to create the statement which fully describes the results in this column. 

 

Example 2 
Conversion Between Parameters Assistants table to 
obtain Alternate Rates for Exponential Survival Curves 
 

When any of the four survival tables are active, you can access the conversion table. 
The conversion table lets you convert between:  

• survival rates expressed as median survival (time by which half of the 
patients entering the trial at time 0 have died and half still survive) 

• proportion surviving at specified time t 

• parameter of exponential survival curve.  

These conversions are based on the assumption that the survival curve is exponential 
in shape. 

To get the conversion to alternate rates table: 

Retaining the sample size table from Example 1, select the Assistants menu. 

Select the Conversion Between Parameters option. The conversion table will 
appear. 
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Enter the time t in the first column of the first row; here we are interested in 
survival at one year, so enter 1.0 for time t with the time units understood to be 
years. 

For Group 1, make an entry in the proportion row, median survival row, or 
exponential parameter row. Press <Enter>. The program will calculate the other 
two values for Group 1. 

 

For Group 2, make an entry in the proportion row, median survival row, or 
exponential parameter row. Press <Enter>. The program will calculate the other 
two values for Group 2. 

The program will calculate the hazard ratio.  Here we have entered the 
proportions expected to survive to one year from Example 1. nQuery calculates 
the median survival, exponential parameter, and hazard ratio. 
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You can then copy required values to the survival sample size table you are 
using. See Example 3 for details of how to copy these values to the main 
survival analysis sample size table or side table you are using. 

Note that the values obtained for the exponential parameters depend on the time 
scale used.  If we enter time as 12 months instead of 1 year, we get different 
values for the exponential parameters. Even though the scale has changed, the 
hazard ratio remains constant. 
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Example 3 
Test based on exponential survival, accrual period, 
dropouts (STT2) 

Now let us reconsider Example 1 under different possible design scenarios.  
First, we'll evaluate the effect of continuing accrual on the sample size required 
for the study. 

To get the table for the two-group test of equal exponential survival: 

Select File menu  New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Survival. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Select the third option, Test based on exponential survival, accrual period, 
dropouts. 

Fill in the significance level and 1 or 2 sided test as before. You will see the 
following table. 

 

It will be easier to specify varying lengths of accrual if we change to a time scale of 
12 months for the study.  In the first column let us specify that the total followup 
period will be 12 months as in our first example.  

Enter 1 in the Length of accrual period row. 
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Enter 12 in the Maximum length of followup row.  

Then we will consider the difference in sample size required for the study if: 

• all patients are accrued in the first month (enter 1 month for length of 
accrual period)  

versus  
• accrual is continued throughout the study period (enter 12 months for 

length of accrual period.)    

Copy the contents of the first two rows of column 1. Paste them into column 2. 

In the second column, enter 12 in the Length of accrual period row. 

Enter 12 in the Maximum length of followup row.  

For the time being, we assume that there are no dropouts, so the exponential dropout 
rate is 0.   

Enter 0 in the Common exponential dropout rate row for both columns. 

 

Now we need the exponential parameters for the 12 month survival percentages.  

Choose the Assistants menu Conversions Between Parameters option. The 
Conversion between parameters window will appear. 

Enter 12 in the Time row. 

Enter .65 in the Group 1 proportion and .45 in the Group 2 proportion. nQuery 
will calculate the exponential parameters for the proportions. 
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Use the Edit menu Copy  or Copy button, , or <Ctrl><C>  to copy the 
exponential parameter corresponding to 12 month survival of 65%.   

Use the Window menu to return to the main table Two-group test of equal 
exponential survival.  

Use the Edit  menu Paste Unformatted or , the Paste Unformatted 
button, to paste the value into the Group 1 exponential parameter row in the 
main table.   

Repeat the copy and paste steps above to copy the exponential parameter 
corresponding to 12 month survival of 45% to the Two-group table. 

Request 85% power and find a required sample size of 114 per group when all 
patients are accrued within the first month. Remember that 112 was the answer 
given by sample size table STT0 when all accrual was prior to the 12 month 
study period. 

You get a required sample size of 202 when accrual will be continuous 
throughout the 12 month study. 
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Total number of events required 
The total number of events required, E, is the number of events that must be 
observed in the two groups combined to achieve the specified power for the test 
comparing survival in the two groups. Note that this does not depend on accrual or 
dropout rates but only on specified significance level, power, and the natural log of 
the hazard ratio; see Help or Appendix for formula. The derivation of the number of 
required events includes an approximation, so the calculated number of required 
events may be an underestimate. To compensate for this, some rounding up of the 
calculated value is suggested. 

Returning to the example, suppose we expect that about 5% of subjects entering the 
trial will drop out within 6 months of their entry.   

To use columns 3 and 4 to determine the n per group for 1 and 12 month 
accrual periods when we expect 5% to drop out:  

Select the first 4 rows of columns 1 and 2. 

Use the Edit menu Copy option to copy the contents of the rows. 

Place the cursor in column 3. 

Use the Edit menu Paste, Paste icon, or <Ctrl><V> to paste the values into 
columns 3 and 4. 

Use Windows menu to return to the Conversion to alternate rates table, 
STT00. 

This time, we will use the table to compute the exponential dropout rate.  Enter 
6 months and proportion 95% (remaining in the study without dropping out) to 
obtain the exponential dropout parameter, .0085.    
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Use the Edit menu Copy option to copy .0085.  

Use the Windows menu to return to the Two-group test of exponential 
survival table, STT2. 

Use the Edit menu Paste Unformatted option or , the Paste Unformatted 
icon, to paste the exponential parameter into the Common exponential 
dropout rate row in columns 3 and 4.  

Use the Edit menu Copy option to copy the Group 1 and 2 exponential 
parameters from columns 1 and 2. Use the Edit menu Paste option to paste into 
columns 3 and 4. 

Enter 85 into the Power row for columns 3 and 4. The nQuery program 
calculates the n per group. 

Although the required total number of events is unchanged, we see that accounting 
for dropouts will require about 5-6 more patients per group.   
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Example 4 
Log-rank test with user specified survival, hazard, 
accrual, dropout rates (simulation) (STT3) 

Sample size tables STT1 and STT2 allow evaluation of the effect of early versus 
continuous accrual, and constant dropout rates. However, these sample size tables 
don’t allow specification of survival curves which are not exponential in shape, or 
hazard ratios which are not constant throughout, or of more complex patterns of 
accrual or dropout. For these purposes, we have provided a simulation solution for 
power given sample size which allows considerable flexibility in specification of 
survival, accrual, and dropout parameters. We will demonstrate the use of this table 
for the examples evaluated above. Later, we discuss an example concerning survival 
curves which are not exponential in shape. 

To use the log-rank test for survival in two groups, simulation: 

Select File menu  New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Survival. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  

Select the fourth option, Log-rank test, user-specified survival rates, accrual, 
dropouts (simulation). 
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Fill in the significance level and 1 or 2 sided test as before, and you will see the 
following table. 

 

We then choose to specify the survival curve in each of 12 one month periods, 
so enter 12 in the Number of periods row. 

Select Compute effect size from the Assistants menu or click on the Compute 
effect size button marked [δ] to bring up a special side table.  

 

Note that the first column has already been filled in. If you wanted to specify that all 
accrual takes place before the start of the study, you would simply fill in zeros for 
the rest of the accrual row. None of the values in this first column can be edited, 
although they will change as you enter values for the other columns.   

Enter the time at the end of each period. In this case, each period specified in the 
side table is one month (they need not be the same length.)   

In the End of period, time t row, enter 1 in the second column, 2 in the third 
column, etc., until you have entered all 12 periods. 
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For the first example, 100% of the accrual will take place in the period ending at one 
month.  The percent of total accrual entered in the first column with end of period at 
time 0, will contain a value equal to 100 minus the sum of percent accrual specified 
in the rest of the time periods.  

Enter 100 in the Accrual row of the second column. 

Enter 0 in the Accrual row of the remaining columns. 

Copy the ameters from Example 3 and paste them into the exponential hazard 
rate rows. Be sure to use the Paste Unformatted option, so that you can simply 
copy the exponential parameters from one sample size table and paste them into 
another type of sample size table. 

Select the filled exponential hazard rate cells, and use the Edit menu Fill 
Right option to repeat those values across the table. nQuery Advisor fills in the 
expected survival at the end of each period. Or you can enter the expected 
survival at the end of each period and nQuery Advisor will fill in the 
exponential parameters.   

For the first example, no dropouts are expected, so we enter 0 in the Common 
exponential dropout rate row. 

Select the filled Common exponential dropout rate row and use the Edit, Fill 
Right option to complete the row.   

Note that this table will have 13 columns, one for each period specified in the main 
table and one for the period ending at time 0.  In these views of the screen, we can 
see only 4 columns at a time. The first four and last five columns of the filled-in side 
table are shown in the next two figures. 

 



    
 

Survival Analysis Tables  — 16-17  

 

Save the side table. See Example 7 for instructions on how to obtain a plot of these 
survival curves and how to use this plot to change the specified survival proportions 
and within period exponential rates to obtain the survival curves you want. 

When the side table is completed and saved, we return to the main table using 
<Ctrl><Tab> or the Window menu The name under which we saved the side table 
will appear in black in the row titled Side table name.  If the side table is still 
incomplete, the name will appear in blue, and you should complete the side table.  

 

At this point, you must choose how many simulated experiments to request, specify 
a random seed for the simulation (any integer greater than or equal to 0) and a 
preliminary choice of the sample size planned for each group, then nQuery Advisor 
will provide an estimate of the power. 

If your computer is slow, we suggest that you begin by requesting 100 simulations 
for each choice of sample size in order to settle on a sample size giving you close to 
the power you want.   Simulations with 100 samples should provide an estimate of 
power to within ± 10%.  Otherwise, simulations with 1000 samples should provide 
an estimate of power to within ± 2% for powers near 90%, simulations with 1600 
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samples, should provide an estimate of power to within  ± 2% for powers near 80%, 
and simulations with 10,000 samples will provide estimates for power to within 
±1%. 

Note:  These figures are based on a 95% confidence interval for an estimated 
proportion. 

If you want to plot power versus sample size, be sure to request at least 1000 
samples to stabilize the estimates of power. Plots may take some time, as they are 
based on simulations for seven points; you will see the time estimate and progress of 
simulations boxes for each point. 

For this example, we specify 100 simulations and a random seed of 25.  Based on 
the sample sizes computed using STT2, we specify a sample size of 114.  

Enter 100 in the Number of simulations row. 

Enter 25 in the Random seed for simulations row. 

Enter 114 in the n per group row. 

When everything in the column except power is filled in, nQuery Advisor will make 
an estimate of the time required to complete the simulations you have requested on 
your computer.  (This estimate is based on making a small number of preliminary 
simulations.)   

You will see a box like the following.  At that point, you can choose to cancel the 
simulation, run nQuery Advisor minimized during computation of the simulations, 
or take a brief break while you wait.  The following example took only 1 second to 
compute on this particular computer, but when we specify more simulations, the 
computation takes longer. 

 

If you want to cancel the calculation of power after it has begun, click on the Cancel 
button within the Progress of Survival Simulations dialog box. 
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If you prefer to minimize the window for the calculation of power after it has begun, 
click on the Minimize button within the Progress of Survival Simulations dialog 
box. 

 

We show the results of two estimates of power based on 100 simulations each with 
different random seeds, and an estimate of power based on 1600 simulations.   

When preparing the sample size table below: 

Use the Edit menu Copy option or , the Copy icon, or the Copy keyboard 
shortcut, <Ctrl><C>, to copy the Side table name from the first column.  

Use the Edit menu Paste unformatted option or , the Paste unformatted 
icon, to paste the side table name into columns 2 and 3. 
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When nQuery Advisor starts the 1600 simulations to calculate the Power, you 
can watch the progress of the calculation or cancel the process. 

 

If you click on the Cancel button, you will see a dialog box outlining the 
calculations performed so far. 

 

Using this dialog box, you can continue the simulations or confirm the 
cancellation. 
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Example 5 
Log-rank test for survival in two groups (simulation)(STT3)  

In this example, we repeat sample size computations for the study in example 4, 
using the same survival patterns, but considering the case where accrual is uniform 
across the 12 months of the study.  

To repeat the computations of power for Example 4 with 1/12 of the 
accrual during each month of the study and retain both the current side 
table and a new edited table:  

Start with the current side table. Use the File menu Save as option to change its 
name to STT3S-X.nqa.   

 

Select the Accrual row in columns 2 through 13 and use the Edit menu Cut 
option or <Ctrl><X> to remove the cell contents.  

Edit the side table to specify 1/12 of the accrual in each period: 8.33% in 
periods 2-12 and 8.37% in period ending at month 1.  Remember, we are 
editing starting at column 2, time period 1. We cannot edit column 1 directly, 
but the contents of column 1 change as we edit the succeeding columns. We 
show only the first four columns of the table below. 
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Use <Ctrl><Tab> or the Window menu to move back to the main Log rank 
test of survival table, STT3. 

The nQuery program will automatically calculate the Power for each column in 
the sample size table. 

To change the sample sizes, use the Edit menu Cut option or <Ctrl><X> to cut 
the Power and n per group. 

Enter the n per group. 

The program computes the power for each column. 

Log-rank test of survival in two groups, simulation with specified rates 
 1 2 3 

  Test significance level, αααα   0.050   0.050   0.050 
  1 or 2 sided test?    2    2    2 
  Number of periods  12  12  12 
  Side table name STT3S-X.nqa STT3S-X.nqa STT3S-X.nqa 
  Number of simulations  100  100  1600 
  Random seed for simulations  25  35  35 
  Power ( % )      71      68      62 
  n per group  114  114  114 

With the sample size of 114 per group, and accrual stretched over the 12 months, the 
power is now too low.  Referring back to Example 3 earlier in this chapter, we see that 
to obtain 85% power, survival table STT2 showed that a sample size of 202 per group 
would be necessary.  We copy rows 1-6 to column 4 and enter a sample size of 202. 



    
 

Survival Analysis Tables  — 16-23  

Log-rank test of survival in two groups, simulation with specified rates 
 1 2 3 4 

  Test significance level, αααα   0.050   0.050   0.050   0.050 
  1 or 2 sided test?    2    2    2    2 
  Number of periods  12  12  12  12 
  Side table name STT3S-X.nqa STT3S-X.nqa STT3S-X.nqa STT3S-X.nqa 
  Number of simulations  100  100  1600  1600 
  Random seed for simulations  25  35  35  35 
  Power ( % )      71      68    62      85 
  n per group  114  114 114  202 

We see essentially the same results as were obtained using the survival table STT2 
in Example 3 earlier in this chapter. 

Note:  To copy and paste a side table name from one column of the sample 
size table to another, the side table name must appear in black.  Then 
you can Copy the side table name using the Edit menu Copy option or 

, the Copy icon, or the Copy keyboard shortcut, <Ctrl><C>. 
You can paste the side table name to another column by using the Edit 

menu Paste option or , the Paste icon, or the Paste keyboard 
shortcut, <Ctrl><V>. 

Example 6 
Log-rank test for survival in two groups, simulation, 
unequal n’s 

We return to the study discussed in Example 5 and now ask what happens to power 
if we study 130 patients in Group 1, the shunt group, and 260 patients in Group 2, 
the TIPS group. 

If you have the main survival table open, click on , the unequal n’s icon. If you 
do not, follow the procedure below. 

To use the log-rank test for survival in two groups, simulation, unequal n’s: 

Select File menu  New option or click on the New button . In the Study 
Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Survival. 

Under Number of groups, select Two groups. 

Under Analysis method, select Test.  
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Select the fourth option, Log-rank test, user-specified survival rates, accrual, 
dropouts (simulation) 

Check the Unequal n’s box in the lower left corner of the Study Goal and 
Design Dialog box. 

Click OK. 

In the sample size table, fill in the significance level and 1 or 2 sided test as 
before. You will see the following table. 

 

We then choose to specify the survival curve in each of 12 one month periods, 
so enter 12 in the Number of periods row. 

Open the side-table used in Example 5, STT3S-X.nqa, and enter the name of the 
side-table, STT3S-X.nqa.  

Note:  To avoid having to retype long side table names in the main table, 
open the side table, and select the name by double clicking on the side 
table name in the Notes pane. Click on Copy or use <Ctl><C> to copy 
the name to clipboard. Then return to the main table, and select the 
appropriate cell in the Side table name row. Click on Paste or 
<Ctrl><V> to paste the side table name into the appropriate row. 
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Entering the sample sizes we obtained in Example 5 and a different random 
seed, we find an estimated power of 86%.   

Log-rank test of survival in two groups, simulation with specified rates (unequal n's) 
 1 

  Test significance level, α   0.050 
  1 or 2 sided test?    2 
  Number of periods  12 
  Side table name STT3S-X.nqa 
  Number of simulations  1600 
  Random seed for simulations  30 
  Power ( % )      86 
  n1  200 
  n2  200 

 
Entering the sample sizes 130 and 260, we find an estimated power of only 79%.   

Log-rank test of survival in two groups, simulation with specified rates (unequal n's) 
 1 2 

  Test significance level, α   0.050   0.050 
  1 or 2 sided test?    2    2 
  Number of periods  12  12 
  Side table name STT3S-X.nqa STT3S-X.nqa 
  Number of simulations  1600  1600 
  Random seed for simulations  30  30 
  Power ( % )      86      79 
  n1  200  130 
  n2  200  260 

 

Noting that for the two-sample t in large samples, the total sample size required 
when n’s are unequal is (1+r)2/4r times the total sample size required for equal n’s (r 
= n2/n1), we would expect that it would take about (9/8)400 = 450 cases total to get 
the same power when r=2 as we got with 400 cases with r=1.  Trying sample sizes 
of 150 and 300, we get an estimated power of 84%. 
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Note that to change both n's in a column, you need to highlight power and both n's 
and use the Edit menu Cut or the toolbar button for cut or the Cut keyboard 
shortcut, <Ctrl><X>, to remove these values. Then enter the new sample sizes. 

Log-rank test of survival in two groups, simulation with specified rates (unequal n's) 
 1 2 3 

  Test significance level, α   0.050   0.050   0.050 
  1 or 2 sided test?    2    2    2 
  Number of periods  12  12  12 
  Side table name STT3S-X.nqa STT3S-X.nqa STT3S-X.nqa 
  Number of simulations  1600  1600  1600 
  Random seed for simulations  30  30  30 
  Power ( % )      86      79      84 
  n1  200  130  150 
  n2  200  260  300 

Example 7 
Plotting Survival Curves 

We specify the survival rates observed in a previous trial of shunt surgery instead of 
using the exponential model, but for this example we consider a three year trial and 
specify survival at only 5 time points.  

We open a new table STT3, enter 5 for the number of periods and select the 
Assistants menu Compute effect size option. The group 1 survival is that seen in the 
previous trial for shunt surgery, a little over 79% at 2 months, 69% at 12 months, 
60% at 24 months, 59% at 30 months, and 57% at 36 months, and the group 2 
exponential parameters are computed as 1.5 times the group 1 exponential 
parameters.  We then save this table with a new name TIPS.nqa to avoid confusion 
with previous examples.  The next two screen shots show the first three and last 
three columns of this table 
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To edit the row names for the expected % surviving rows: 

Choose the Edit menu Edit row names option. The Edit row names dialog box 
appears, displaying the two rows to be changed. 

 

Click on the Group 1 row. Group 1 will appear in the white editing field in the 
middle of the dialog box.  Click on Group 1 in the editing field and enter 
Shunt.  Click on the Accept Edit Row button. 

Click on the Group 2 row. The dialog box will show the edited Shunt row, and 
Group 2 will appear in the editing field. 

 

Click on Group 2 in the editing field and enter TIPS. Click on the Accept Edit 
Row button. 
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Click on the Update Table Row Names button to update the table. 

 

To see the plot of these survival curves: 

In the side table, select all six columns. 

Select Plot menu Plot survival vs time option.   

The plot will appear. Neither of the Plot buttons on the toolbar can be used to 
produce this plot. 

 

You can adjust the values for survival at the ends of each period. Click and hold on 
the plot symbol. After a rectangle appears and disappears, drag the plotted point to 
the new position. In the following plot, we have lowered the three circles on the 
right in the lower curve. 
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These changes will be reflected in the side table.  You can change values in the 
side table, and they will be reflected in the plot, or change values in the plot, 
and they will be reflected in the side table.  The altered side table has been 
resaved as TIPS2.nqa.  

 

Note the changes in the Group 2 hazard rates and survival values for the last 3 
columns. 

You can double click on the legend to move or edit the legend. The Legend 
Parameters dialog box appears, and you can enter new values. 
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For each curve, you can change the plot type, along with the point marker 
shape, color and size. To edit the curve, double click on one point in the curve 
to bring up the Plot Parameters dialog box. 

 

Using the Multi-period Side Tables with 
Simulation Survival Table (STT3)  

While you are using a survival table, as soon as you have entered a number of 

periods, you can click on the  button to get an almost blank side table. Only the 
first column is filled in, and you cannot edit that column of values. However, the 
accrual value in the first column will change as you make entries in the accrual row 
in other columns. 

When you return to the main table, the main table will display the name of the 
attached side table in black letters. When you start from the survival table and use 
the delta button or the Assistants menu Compute Effect size option, your side table 
will be automatically attached and its contents used in further calculations. There 
will be no need to manually enter the side table name. 
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Opening a Survival Table and its Side Table 
When you open a survival table and its side table at a later time, the side table may 
not be attached to the main table. To force the survival table to recognize its 
previously-attached side table, open the side table first. Then open the survival table.  

If the related side table is not open when viewing the main table, the side table name 
will appear in red.  You must then double click on the side table name in the 
survival table and type the side table name to attach the table.  nQuery will decide 
whether to recalculate power for the column. 

Colors for Side Table Names 
The color of the side table name signals the attachment status of the side table. 

Name in Red 
The side table is not attached, so its contents cannot contribute to any calculations.  

• If the side table is open, simply double click on the side table name in the 
survival table and type the side table name again.  

• If the side table is not open, open it. Then double click on the side table name in 
the survival table and type the side table name again. 

Name in Blue 
When the side table is still incomplete, the name will appear in blue. You should 
complete the side table and save it. 

Name in Black 
The side table is attached, and its values will contribute to the survival table 
calculations. 

Changing a Side Table Name 
Double click on the existing Side table name and type the side table name. If you 
change the side table name in a completed column in a survival table, nQuery will 
decide whether to recalculate power.  Of course, there will be no recalculation if you 
have reattached the side table used to compute the current values. 
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17.  Agreement Tables 
Measures of agreement are designed to assess how closely two different 
measurement methods or two different raters agree on the values for an outcome 
measure. Often, one method is the “gold standard,” and an investigator wants to 
study whether a new, cheaper method of measurement agrees well enough with the 
gold standard to warrant its use. The nQuery Advisor program provides sample size 
tables for tests or confidence intervals for three methods of measuring agreement. 
These are all one-sample problems.  

Dichotomous outcome methods using 
Intraclass Kappa 

AOT0  Agreement between two dichotomous ratings (intraclass kappa) 

AOC0  Confidence interval for intraclass kappa (n large) 

These sample size tables are applicable when two conditions hold:   

• both the proposed version of the outcome/response variable and the 
gold standard version have only two possible categories (yes/no, 
success/failure, normal/abnormal)  

• the intraclass version of the measure of agreement κ is to be used.  

This version of κ is an index of the degree to which we can simply substitute one 
measure for the other. To assist you in computing values of kappa from proportions 
entered into a two-way table, nQuery Advisor provides a side table accessible from 
the Assistants menu Compute Effect Size option or from the Compute Effect Size 
icon; see example later in this chapter. 

Continuous outcome methods using Pearson r 
AOT1  Correlation test that ρρρρ = ρρρρ0  for x and y bivariate normal 

AOC1  One-sided confidence interval for • for x and y bivariate normal 
 

These sample size tables are applicable when two conditions hold:  

• both the proposed version of the outcome/response variable and the 
gold standard version are continuous measurements  

• we can assume that their distributions are bivariate normal. 
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When those two assumptions are true, the Pearson correlation coefficient provides 
an index of the degree to which a linear relationship fits the data. Note that, even if 
the correlation coefficient is very close to 1.0, a scale change might be necessary 
before substituting one measure for the other. 

Continuous outcome methods using Lin’s 
concordance coefficient 

AOT2  Large sample test that Lin's concordance coefficient = ΚΚΚΚ0 

AOC2  One-sided large sample confidence interval for concordance 
coefficient 

Lin’s concordance coefficient is a modification of the Pearson correlation 
coefficient. Lin’s concordance coefficient indexes the degree to which the proposed 
version of the outcome/response variable and the gold standard can be substituted 
for each other. Thus, it indexes how well the bivariate measurements fall on the line 
of identity.  

The nQuery Advisor program provides a side table accessible from the Assistants 
menu Compute Effect Size option or from the Compute Effect Size icon. The side 
table computes values of the concordance coefficient from values for the Pearson 
correlation coefficient, the scaled difference in means, and the ratio of standard 
deviations. 

Example  
 Confidence Interval for Intraclass kappa (AOC0)  

This example pertains to a study planned to assess regional wall motion in the heart 
using a new test. Researchers want to validate the new test with measurements made 
using a test called echocardiography. Patients will undergo both tests and each test 
will be scored as 0=abnormal or 1=normal.  

The goal of the study is to estimate the agreement as measured by κ between the two 
methods of classifying heart studies as normal or abnormal. We want to estimate the 
value of κ to within a value of ± 0.1. The researcher plans to compute a two-sided 
95% confidence interval.  

Prior small studies comparing another measurement method to echocardiography 
found that the proportion of patients assessed as abnormal was between 0.65 and 
0.70. The estimated values of κ were between 0.70 and 0.80.  
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To bring up the AOC0 sample size table: 

Click on the File menu New option or the New icon. The Study Goal and 
Design dialog box will appear. 

Select Agreement, One, Confidence interval. 

Select the first analysis from the list of analyses. 

Click OK. The Confidence interval for intraclass kappa (n large) table will 
appear. 

The following table shows the significance level, 2-sided test, and desired 
distance, ω, to the confidence limit already filled in. 

 

To compute the expected value of  from proportions in a 2x2 table: 

Select the Assistants menu Compute Effect Size option, or click on , the 
Compute Effect Size icon, to get the side table.  

The blank side table for the intraclass kappa Confidence interval will appear. 
For details concerning the side table buttons, see Chapter 12. 

 

We expect the proportion of patients with abnormal wall motion to be about 65%.  
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To use this side table to calculate κκκκ: 

Enter 0.6 in the cell representing Rater 1 (+) and Rater 2 (+). Both of these 
measurements are abnormal.  

To represent the expected variation in raters, enter 0.05 for Rater 1 (-) and 
Rater 2 (+) or for Rater 1 (+) and Rater 2 (-). Under the model for intraclass 
kappa, the two discordant cells are expected to have equal proportions; see 
reference for this table in the Appendix or Help. 

Click on the Compute button.  

 

The program calculates the rest of the values for the table. These values give 0.65 as 
the proportion of patients with abnormal wall motion. The value of κ is 0.78 which 
is close to the value we expect based on other studies. We decide to use these values. 

To send the new values to the sample size table: 

Click on the Transfer button.  

The computed values appear in the sample size table. 

The sample size table automatically solves for n. 

 

To get the statement for this solution: 

Click on any cell in the computed column. 
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Click on the Create Statement icon, . The statement will appear, and you 
may copy it to clipboard for pasting in another document, print it, or store it in 
the store statements panel on your screen. 

 
 



 

    
 

17-6 — Agreement Tables 



Regression Tables — 18-1 

18.  Regression Tables 
nQuery Advisor can help determine the required sample size for research studies 
involving correlation or  regression analyses of the relationship between x variables 
(predictor variables, covariates, independent variables) and a y variable or 
dependent variable.  

Choosing a Regression Table 
Your choice of sample size table depends on: 

• the nature of the y variable — whether it is a yes/no (dichotomous or two-
level variable) or a continuous variable, such as cholesterol level 

• the number and characteristics of the x variables — whether you have one 
or multiple x variables, and whether they are dichotomous, ordered, or 
continuous. 

Dichotomous y (Logistic Regression) 
When the y variable, the variable you wish to predict, has only two levels, success 
versus failure, alive versus dead, yes versus no, a logistic regression model is often 
used to assess the predictive value of covariates. nQuery Advisor provides several 
options for computing sample size for studies where logistic regression will be used. 

For a single dichotomous covariate use: 
PTT0U  Two-group χχχχ2 test of equal proportions (odds ratio = 1)   

(unequal n’s)  
See Example 1a in this chapter. 

 

For a single dichotomous covariate adjusted for p 
multiple covariates already in the model use: 

PTT0U  Two-group χχχχ2 test of equal proportions  (odds ratio = 1)  
(unequal n’s) and apply the variance inflation factor.  

See Example 1b in this chapter. 
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For a single ordered covariate, that is for studies in which 
the predictor variable has several ordered levels (as for 
three dose levels), use:  

PGT1 Trend across proportions (logistic model)  
See Example 8 in Chapter 15, Sample Size Tables for Proportions. 

For a single continuous covariate, use: 
ROT0 Logistic regression test that ββββ = 0 for one normally distributed 

covariate, x  
See Example 2 in this chapter. 

 

MTT0U Two group t test of equal means (unequal n’s)  
See Example 3 in this chapter 

For a single continuous covariate adjusted for p multiple 
covariates already in the model use:  

ROT1 or use MTT0U and apply the variance inflation factor. 

ROT1 Logistic regression test that ββββ = 0 for one normal covariate x, 
adjusting for prior covariates 

See Example 3 in this chapter. 
or  
MTT0U Two group t test of equal means (unequal n’s) 

See Example 4 in this chapter. 

Continuous y 
When the variable to be predicted is continuous, and its relationship to the 
continuous predictor variable is expected to be linear, use linear regression models 
to determine the sample size necessary to assess the predictive value of continuous 
covariates. 
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For a single continuous covariate, use: 
ROT2  Linear regression test that ρρρρ = 0 for one normally distributed 

covariate, x 
This table provides sample size or power for the t test of the null hypothesis that the 
Pearson correlation coefficient, ρ, equals 0. That is, the t test tests a null hypothesis 
that there is no linear relationship between x and y.  

To obtain the sample size required for a test of the null hypothesis that ρ is some 
value other than 0, or for a confidence interval of specified width for ρ, see sample 
size tables listed under Agreement: 

AOT1 Correlation test that ρρρρ=ρρρρ0 for x and y bivariate normal 
AOC1 One-sided confidence interval for ρρρρ for x and y bivariate normal 

nQuery Advisor also provides sample size tables for tests and confidence intervals 
for regression slopes in one and two sample designs. 

ROT5 Linear regression test that ββββ=ββββ0 for one x 
See Example 4 in this chapter. . 

ROC0 Linear regression confidence interval for ββββ 
RTT0 Linear regression test that ββββ1=ββββ2 for one x 

See Example 5 in this chapter. 
RTC0
  

Linear regression confidence interval for  ββββ1 -ββββ2 

For  multiple covariates, use:  
ROT3  Multiple linear regression test that R2 = 0 for k normally 

distributed  covariates.  

This table provides sample size or power for the F-test which tests the null 
hypothesis that a set of k predictor variables have no linear predictive relationship 
with y. That is, the F-test tests the null hypothesis that the squared multiple 
correlation between y and the x variables is 0. 

For two sets of covariates, use: 
ROT4
  

Multiple regression, test 0 increase in R2 for B covariates 
adjusted for A covariates. 

This table provides sample size or power for the F-test of the null hypothesis that a 
set of B predictor variables have no linear predictive relationship with y, after y has 
been adjusted for A prior covariates. That is, the F-test will test the null hypothesis 
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that the squared multiple correlation between y and the combined sets of A and B 
predictor variables is no larger than the squared multiple correlation between y and 
the initial set of A covariates. 

Logistic Regression 
The model for logistic regression with one covariate is 
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Example 1 
Logistic regression with a dichotomous covariate (PTT0U)  

Hsieh, Bloch, Larsen (1998) Statistics in Medicine 17:1623-1634 recommend using the 
following method to obtain sample sizes for logistic regression with a dichotomous 
covariate. Let the covariate X define two groups; group 1 contains cases in which x = 1 and 
the probability that y=1 is π1 while group 2 contains cases in which x = 0 and the probability 
that y=1 is π2.  

Example 1a 
Single covariate 

As an example, we suppose that about 1% of the population is expected to have a particular 
adverse reaction to a certain drug used to treat a severe illness. It is thought that those with a 
specific pre-existing condition (expected to be about 20% of the population) will be much 
more likely to have such a reaction; it will be important to detect an odds ratio of four for 
the likelihood of a reaction in this group using a 5% two-sided logistic regression test. 

To select the PTT0U table for this logistic regression example: 

Choose the File menu New option or click on the New icon button . The 
Study Goal and Design dialog box will appear. 

Select Proportions, Two, Test. 

Five choices will appear in the list box in the lower part of the dialog box.  

Select the first analysis type and click on Unequal n’s. 
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Double click on the first choice , select Compute Power or sample size and 
select Unequal n’s.  Then press OK, and the sample size table appears. Note 
that we have already turned off the guide cards. 

 

Use the Edit menu Edit Row Names option to change the Group 1 and Group 2 
row names to No condition and Pre-existing condition, respectively. 
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Enter .05 in the Test significance level row. 

Enter 2 in the 1 or 2 sided test row. 

Enter .01 in the No condition proportion. 

Enter 4 in the Odds ratio row, and the Pre-existing proportion row value will be 
calculated. 

Enter 90 in the Power row for a power of 90%. 

Enter .25 in the Ratio n2/n1 row. This is a ratio of 20/80=.25. 

The remaining row values will be calculated. 

 

This study would require a total sample size of almost 1700 patients. 
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Example 1b  
Variance inflation factor for p prior covariates 

For example 1a, the total sample size was computed as N for testing the significance 
of one dichotomous covariate, The sample size, Np required to test for the 
significance of this dichotomous covariate after prior inclusion of p other covariates 
in the model, is given by 

N Np ====
−−−−









1
1 2ρρρρ

 

where the factor 1/(1-ρ2) is called the “variance inflation factor”, 

VIF ====
−−−−









1
1 2ρρρρ

   

and ρ2 is the squared multiple correlation of the covariate of interest with the 
covariates already included in the model. 

For example 1a above, if four patient demographic variables will be entered into the 
logistic regression model prior to testing the covariate indicating presence or 
absence of the pre-existing condition (x1 say), and these demographic variables have 
a squared multiple correlation with x1 of 0.2, then a total sample size of at least 
2,100 patients would be required. 

N p ====
−−−−







 ====1681

1
1 0 2

2101
.

 

Example 2 
Logistic regression with a continuous covariate (ROT0)  

Patients with blocked or narrowed coronary arteries may undergo interventions 
designed to increase blood flow. Typically, about 30% of patients followed for a 
year will have renewed blockage, or restenosis, of the artery.  

A study is to be planned to use logistic regression to assess factors related to the 
likelihood of restenosis. One such factor is serum cholesterol level. Based on the 
results of a large screening trial, mean serum cholesterol in middle-aged males is 
about 210 mg/dL; one standard deviation above the mean (which corresponds to 
about the 85th percentile) is about 250 mg/dL.  

In the screening study, the odds ratio for six-year death rate for these two cholesterol 
levels was about 1.5. Consider that you want to design a study large enough to 
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detect an effect of serum cholesterol on arterial restenosis of a size similar to that 
seen for death rate.  

To select the ROT0 logistic regression table: 

Choose the File menu New option or click on the New icon, . 

In the Study Goal and Design dialog box, click on the radio buttons for 
Regression, One, and Test. The list box will display the six regression analysis 
choices. 

 

Click on Logistic regression one normal covariate, then click on OK. The 
following table will appear. 

 

  



    
 

Regression Tables — 18-9 

Since you plan to use a logistic regression test at the two-sided 5% level:  

Enter .05 in the Test significance level row.  

Enter 2 in the 1 or 2 sided test row.  

You must now specify the response rate at the mean of the covariate; for this 
example, we don't know the response rate at the mean of the covariate and so we use 
the overall restenosis rate of 30% as an initial guess. 

Enter .3 in the Proportion row. 

When you enter a value in any one of the next three rows, the nQuery Advisor 
program will compute the values for the other two rows. In this case, we do not 
know what response proportion to expect for cholesterol levels one standard 
deviation above the mean. However, we would be interested in detecting an odds 
ratio of 1.5.  

Enter 1.5 in the Odds ratio row, and nQuery Advisor will compute the 
Proportion, pT =.391, and Coefficient, Β= .405.  

You want 90% power, so enter 90 in the Power row. The nQuery Advisor 
program solves for a sample size of 360 cases. The next screen shows the filled-
in table.  

 

Note that for this sample size table for logistic regression, the odds ratio must be 
between 0.40 and 2.50 (and not equal to 1.0.) This is because the approximate method 
on which computations are based (Hsieh, F.Y. (1989) Sample size tables for logistic 
regression. Statistics in Medicine 8:795-802) is derived using the assumption that the 
odds ratio is small. For studies designed to detect a more extreme odds ratio, see 
Example 3. 

To get the statement for the completed column: 

Select one or more rows in the column. 

Click on the Create Statement button. The full statement will appear. 
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At this point, you can click on the Store button to store the statement with the 
sample size table. You can click on the Print button to print the statement directly, 
or click on the To Clipboard button to copy the statement to the clipboard using the 
font of your choice. 

The sample size required to evaluate the significance of cholesterol level in 
predicting the likelihood of restenosis is 360.  

Adjusting for Prior Covariates  
(ROT1 or Variance Inflation Factor) 

If two other covariates whose squared multiple correlation with cholesterol is .15 are 
to be entered into the logistic regression first, you have two choices. First, you can 
multiply the sample size obtained for a single covariate by the variance inflation 
factor, 1/(1-ρ2), to increase the required sample size to 424. The alternative is to use 
table ROT1, the sample size table for logistic regression for one covariate after 
adjustment for prior covariates. 
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ROT1, the sample size table for logistic regression for one covariate after 
adjustment for prior covariates, requires the same input as the logistic regression 
sample size table for a single covariate. 

Enter .05 in the Test significance level row.  

Enter 2 in the 1 or 2 sided test row.  

Enter .3 in the Proportion row. 

Enter 1.5 in the Odds ratio row, and nQuery Advisor will compute the 
Proportion, pT =.391. 

Enter Coefficient, ΒΒΒΒ= .405.  

You want 90% power, so enter 90 in the Power row. The nQuery Advisor program 
solves for a sample size of 360 cases. The next screen shows the filled-in table. 
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The only difference is that we must provide an estimate of the squared multiple 
correlation of x with the covariates already in the model. 

Example 3 
Logistic regression with a continuous covariate (MTT0U)  

Hsieh, Bloch, Larsen (1998) Statistics in Medicine 17:1623-1634 recommend using 
the following method to obtain sample sizes for logistic regression with a 
continuous covariate. Let the response Y define two groups; group 1 contains cases 
in which Y = 1 with Nπ1 cases expected, while group 2 contains cases in which Y = 
0 with N(1-π1) cases expected. (The probability π1 is labeled pM in the sample size 
tables ROT0 and ROT1.) The ratio of the expected sample size in group 2 to the 
expected sample size in group 1, r, is (1-π1)/ π1. The natural log of the odds ratio, the 
coefficient B of the covariate, x, is equal to the difference between the mean of the 
covariate in group 1 and the mean of the covariate in group 2 divided by the within-
group standard deviation of x. Therefore, a sample size table for the two group t test 
with unequal n’s can be used to estimate sample size for logistic regression with one 
continuous covariate. 

To select the table MTT0U to use for logistic regression: 

Choose the File menu New option or click on the New icon, . 

In the Study Goal and Design dialog box, click on the radio buttons for Means, 
Two, and Test. The list box will display four main means test choices. Under 
the first choice Two-sample t-test, select the highlighted choice, Student’s t test, 
and click on Unequal n’s. 
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Click on OK to bring up the sample size table. 

 

Referring back to Example 2 in which the predictive effect of cholesterol level 
on the probability of restenosis is to be studied, we enter .05 for significance 
level, 2 for a two-sided test.  

The sample size necessary to detect an odds ratio of 1.5 for values of 
cholesterol of 250 mg/dL versus 210 mg/DL with 90% was requested.  We 
enter the value of the natural log of the odds ratio of 1.5, 0.405, into the effect 
size row. The ratio of sample sizes expected to be in the no-restenosis and the 
restenosis groups, r, equals .7/.3 = 2.333  

Enter 90 in the Power row. 
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To obtain a power of 90%, we find that a total sample size of 310 is required. 
Hsieh, Bloch, and Larsen (1998) demonstrate that the approximate formula 
recommended earlier by Hsieh (1989) and used in ROT0 and ROT1 gives larger 
than required sample sizes. 

 

If two other covariates with a squared multiple correlation with cholesterol of .15 
are to be entered into the logistic regression first, multiply the sample size obtained 
for a single covariate by the variance inflation factor, 1/(1-ρ2), to increase the 
required sample size to 365. 

Linear Regression 

Example 4 
 Linear regression test that ββββ=ββββ0 for one x (ROT5) . 

A quick test for measuring cholesterol is to be assessed in comparison with the 
current gold standard.  To ensure that the new test is calibrated properly and agrees 
well with the gold standard in one of the target populations, 300 middle-aged males 
will be tested using both methods.   

To ensure that there is no bias in the new test, the researcher will fit a regression line 
and run tests to see whether the slope differs from its expected value of 1 and 
whether the intercept differs from its expected value of 0.  To make sure that sample 
size will be adequate for the test on slope, the investigator wants to know the 
expected power for deviations of 10% from a slope of 1.0.  The standard deviation 
of cholesterol values for this population is expected to be 40 mg/dL and previous 
results suggest that the correlation between new test and gold standard results will 
be 0.90.  
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To select the ROT5 table for a test of the regression slope: 

Choose the File menu New option or click on the New icon, . 

In the Study Goal and Design dialog box, click on the radio buttons for 
Regression, One, and Test. The list box will display the six regression analysis 
choices. 

 

Click on Linear regression, test of coefficient, then click on OK. The 
following table will appear; we have already filled in .05 for test significance 
level, and 2 for a two-sided test. 
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The investigator wishes to test the null hypothesis that the slope equals 1.0 versus 
the alternative that the slope equals 1.1. 

Enter 1.0 for the Null hypothesis coefficient and 1.1 for the Alternative hypothesis 
coefficient. 

Enter 40 for Standard deviation of x’s, and 300 for n, the planned sample size. 

 

The investigator does not know what to enter for the standard deviation of the 
residuals. To estimate the standard deviation of the residuals from the information 
already available, use a side-table available by selecting the Assistants menu 
Estimate SD option or the toolbar icon marked σσσσ.    

 

Select the last entry Of residuals (errors).   You will see the following table. 
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Enter the values for the regression coefficient (the slope), the expected correlation 
coefficient, and the expected standard deviation of the x’s, and nQuery will compute 
the expected standard deviation of the residuals. 

 

Copy the value 19.373 and paste it into the main table in the SD of residuals row.  
Then nQuery will compute the power. 

 

The power is computed as 94%, so the planned sample size is adequate for this aspect 
of the assessment of the calibration of the new test. 
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To get the statement for the completed column: 

Select one or more rows in the column. 

Click on the Create Statement button. The full statement will appear. 

At this point, you can click on the Store button to store the statement with the 
sample size table. You can click on the Print button to print the statement directly, 
or click on the To Clipboard button to copy the statement to the clipboard.  The 
statement, as it appears below, can be pasted into your document. 

A sample size of 300 will have 94% power to detect a difference between a null 
hypothesis regression slope of 1.000 and an alternative regression slope of 1.100, 
assuming that the standard deviation of the predictor variable, x, is 40.000 and the 
standard deviation of the residuals is 19.373 using a t-test with a 0.050 two-sided 
significance level. 

 

Example 5 
 Linear regression test that ββββ1=ββββ2 for one x (RTT0)  

To evaluate whether drug A has a synergistic effect on the dose response to drug B, 
an investigator plans a trial in which 10 rats will be assigned at random to each of 6 
doses of drug B. Half of the 10 animals receiving each dose of drug B will also 
receive drug A, and half will receive a control substance.   

The investigator has evaluated the dose response under control conditions in the 
past.  When the doses of drug B were 2, 4, 8, 16, 32, 64, the slope of the regression 
of the response variable on the log to the base 10 of the dose was 6.9 with a residual 
mean squared error of 25.  The researcher wants to know whether the power will be 
adequate to detect a doubling in the slope of the regression line?  

To select the RTT0 table for a test of equality of the regression slopes: 

Choose the File menu New option or click on the New icon, . 

In the Study Goal and Design dialog box, click on the radio buttons for 
Regression, Two, and Test. The list box will display a single analysis choice. 

Click on Test of equality for equality of slopes for one x, then click on OK. 
The following table will appear; we have already filled in .05 for Test 
significance level, and 2 for a 2 sided test. 
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The investigator wishes to test the null hypothesis that the slopes are equal 
versus the alternative hypothesis that the slope under control conditions is 6.9 
and that under drug A is 13.8. Thus, in the Group 1 coefficient row, enter 6.9; 
in Group 2, enter 13.8. 

In the SD of residuals row, enter 5, the square root of the residual mean square 
error.  (To get the table with customized row names shown below, we used the 
Edit menu Edit row names option.) 

 

Now the investigator still needs to provide the standard deviation of the x’s. To 
compute this from the doses of drug B, we use a table from the Assistants menu.   

To compute the standard deviation for specified x values: 

Select the Assistants menu Estimate SD option, or click on the toolbar icon 
marked σσσσ.  
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The Estimate Standard Deviation dialog box will appear. This dialog box is 
explained in detail in Chapter 9. 

 

Select the next to last entry For specified x values.   You will see the following 
table. 

 

We have already entered six dose levels in the side table.  To get the log dose 
values, we click on the radio button beside log_10(x), then click on the Add button. 
The nQuery program calculates the log values and enters those values in the 
adjacent column. 
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Select the population standard deviation of the logs of the doses in the row 
labeled σ(x).  (This standard deviation divides the sum of squared deviations 
about the mean by n instead of n-1.) 

Use the Edit menu Copy option to copy that value.  

Use the Windows menu to select RTT0 again. 

Use the Edit menu Paste option to paste the standard deviation of the log doses 
into the row labeled Standard deviation of x’s, σ(x).  Note that more digits are 
now visible. 

Then nQuery will calculate the Effect size.  

Enter 30 for the n per group, because the study will have five rats at each of six 
doses. 
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nQuery computes the power as 77%, so the planned sample size is not adequate for 
detection of the effects of drug A.   

 

In the next column we have recalculated power using 6 rats per dose for each of the 
six doses of drug B in the control group and the same number in the drug A group 
(36 per group).  Using 72 rats total will provide 84% power, which the investigator 
considers to be adequate. 

To get the statement for the completed column: 

Select one or more rows in the column. 

Click on the Create Statement button. The full statement will appear. 

At this point, you can click on the Store button to store the statement with the 
sample size table. You can click on the Print button to print the statement directly, 
or click on the To Clipboard button to copy the statement to the clipboard.   

A sample size of 36 per group will have 84% power to detect a difference between a 
Group 1 coefficient, β1 regression slope of 6.900 and a Group 2 coefficient, β2 slope 
of 13.800, assuming that the standard deviation of the predictor variable, x, is 0.514 
and the standard deviation of the residuals is 5.000 using a t-test with a 0.050 two-
sided significance level. 
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19. Sampling from Finite 
Populations  

Most nQuery Advisor sample size tables are based on the assumption that inferences 
will be made to a very large population. Consider samples selected from a finite 
populationof 1000 subjects, for example.  Inferences will be made only about 
those 1000 subjects. In such a situation, you can use nQuery Advisor tables designed 
for finite populations to select the required sample size. 

Define the required sample size for sampling from a finite population of size N as 
nA; the sampling fraction is then nA/N.  In the context of estimating a single mean 
from a finite population, the variance of the sample mean is reduced from 

σσσσ 2

n
 to 

A

A

nN

nN 2σ





 −

.    

Thus, a sample from a finite population can be somewhat smaller than a sample 
from a very large population. 

nQuery Advisor provides sample size tables with a finite population correction for 
the following situations. 

Means, One group, Test 
MOT0F  One group t test that a mean equals a user-specified value 

MOT1F  Paired t test of mean difference equal to zero 

Means, One group, Confidence Interval 
MOC0F  Confidence interval for mean based on z (n large) 

MOC1F  Confidence interval for mean based on t (with coverage 
probability) 

MOC2F  Confidence interval for interval in paired means based on z (n 
large) 

MOC3F  Confidence interval for difference in paired means based on t 
(coverage probability) 
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Proportions, One Group, Test 
POT0F  One group  χ2 test that proportion equals user-specified value 

(normal approximation) 

Proportions, One Group, Confidence Interval 
POC0 Confidence interval for proportions using normal approximation (n 

large) 

Example  
Proportions, One Group, Test (POC0F)  

These adjustments to the required sample size won’t result in a large reduction in the 
required sample size unless the sampling fraction is greater than about 5%.  We 
must remember that the normality assumption underlying the tests and confidence 
intervals for means cannot literally hold for finite populations.  In addition, these 
nQuery Advisor tables are intended for finite populations which are reasonably large 
so that the sampling fraction is not near 100%.   

If the outcome measure is a proportion, and the population size is small and/or the 
sampling fraction larger than 50%, exact or simulation methods should be used to 
establish the required sample size. 

In a survey sampling setting, one may wish to estimate a mean or a proportion from 
a finite population of size N.  For example, one might wish to estimate the 
proportion of students who would return the following year if a proposed increase in 
student tuition and fees takes place.  In the past three years, retention rates have been 
close to 60%.   There would be considerable concern if the retention rates could be 
expected to drop markedly as a result of the fee increases.  If there are 8,534 
students who would be eligible to return the following year, how many must be 
surveyed to assess the retention rate to be expected to within ±5% if fees increase? 

To bring up the correct sample size table: 

Choose the File menu New option or click on , the New icon button.  

In the Study Goal and Design Box, you will see three columns of options.  

Under Goal: Make conclusion using, select Proportions. 

Under Number of groups, select One group. 
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Under Analysis method, select Confidence Interval.  

Select Confidence interval for proportion. 

Select Finite Population box at the bottom of the Study Goal and Design Box.   

Click on OK.  

You will see the following table.  It looks like the standard table for a confidence 
interval for a proportion, except that there is an additional row for population size. 

 

Fill in the table as shown below. 

 

After filling in the table, we see in the first column that the sample size required 
when the population was very large is 369. The second column uses the number of 
returning students as the Population size. For a population of 8534 returning 
students, it would be necessary to survey only 354 students for the same precision of 
estimate, a sampling fraction of 3.6%.  
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If the investigator wanted to estimate retention rate with the same precision for the 
2010 students who are currently freshman, it would be necessary to survey 312 
students (a sampling fraction of 15.5%). 
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20. Distribution Function Tables 
For the advanced user who wants to make sample size calculations for formulas not 
included in nQuery Advisor, the program provides access to central and non-central 
distribution functions 

To access the distribution functions: 

♦ Select Distribution Functions from the Assistants menu.  

The Distribution Function Menu provides the following choices: 

 

Example 
The Non-central t Distribution  

This example uses the non-central t distribution to compute power for the paired t 
test. We want to know the power for a two-sided 5% level paired t test, for which 
the expected difference in means is 5.0, the standard deviation of differences is 10.0, 
and the planned sample size is 25.    

In this case, we can answer the question directly. 

To calculate the power using the paired t-test sample size table: 

Click on the File menu New option or the New icon. The Study Goal and 
Design dialog box will appear. 

Select Means, One, Test. 

Select the second analysis. 
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Click OK. The Paired t-test for differences in means table will appear. 

Enter .05 for significance level, 2 for a two-sided test, 5.0 for expected 
difference in means, 10.0 for standard deviation of differences, and 25 for 
sample size. The nQuery Advisor program will calculate the power. 

 

This table gives the answer 66%. Note that the status bar gives a more exact value, 
66.97.   

To calculate the power using the Distribution Function Menu option: 

Select Distribution Functions from the Assistants menu. 
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Select t (Non-central) to obtain the following table. 

 

In this example, the paired t-test which has n-1 degrees of freedom will have 24 degrees of 
freedom. The formula for the non-centrality parameter for the non-central t distribution in 
the case of the paired t-test is  

δ√n = [(µ1 - µ2 )/σ]√n.    

Thus, for our example, the non-centrality parameter is 0.5(5)= 2.5.   

With a sample size of 25, the critical value of t will be 2.064 for a two-sided 5% 
level t-test (obtained either from a table or by using t (Central)).  

To calculate the probability, Prob(t<t_p): 

Enter 24 in the Degrees of freedom row. 

Enter 2.5 in the Non-centrality parameter row. 

Enter 2.064 in the t_p row. The program will calculate the Probability. 

 

The probability that t < t_p is given as .330. Thus, the probability that t > t_p, the 
power of the t-test, is 1-.33 = .67. This value is the same as that achieved with the 
sample size table for the paired t-test (MOT1). 
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21.  Appendix — References and 
Formulas 

Every nQuery Advisor sample size table, distribution function table, standard 
deviation table, and table-specific side table has been tested for computational 
accuracy across table-specific ranges of parameters. Also, each table has been tested 
for full functionality of editing options and menu items (side tables, plots, 
statements) for one or more table-specific parameter sets.  

You can review the methods used for testing. See the descriptions on the Statistical 
Solutions Ltd. Internet site, http://www.statsol.ie/valid.htm.  

The first section of this appendix provides a brief description of the method used for 
computations in each table. These descriptions specify degrees of freedom and non-
centrality parameters for each test based on non-central t, F, or χ2. Definitions of the 
non-centrality parameters use the values for δ, ∆, or ∆2 shown in the relevant row 
title of the specific table.  Tables grouped together are tables for which nQuery uses 
the same computational method.  

The second section provides details on methods used for computing statistical 
distribution functions.  

Section 1 
The nQuery program provides an inquiry table for more than 100 different types of 
analyses. To simplify table identification, nQuery uses abbreviations for each table 
name. These abbreviations create a unique abbreviation or code for each table 
without spelling out the table name in detail. 

The first letter of the code represents the selection in the first column of the Study 
Goal and Design Box: 
 Means, Proportions, Survival, Agreement, or Regression 

The second letter of the code represents the selection in the second column of the 
Goal and Design Box, denoting the number of groups in the design: 
 One, Two, or G (>2 groups) 

The third letter of the code represents the selected type of analysis from the third 
column:  
 Test, Confidence Interval, or Equivalence 

The fourth character in the code represents the number of the selection in the list 
box. The numbers start with 0 at the top of the list box.  
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For unequal n’s tables, the code ends with the letter U.  For example, the code for 
Two-sample t test with unequal n’s is MTT0U.  

Methods of computation for each table 

Note:   s=1 for a one-sided test and s=2 for a two-sided test. We define z1-α as 
the 100(1-α) percentile of the normal (Gaussian) distribution. 

MOT0 One-sample t test 
MOT1 Paired t test for difference in means 

Power, sample size, or effect size are computed using central and non-central t 
where the non-centrality parameter is √n δ and δ is defined in the table row title. 
See, for example, O’Brien, R.G., Muller, K.E. (1993) “Unified Power Analysis 
for t-tests through Multivariate Hypotheses”, in Edwards, L.K. (Ed.), Applied 
Analysis of Variance in Behavioral Science, Marcel Dekker, New York.  
Chapter 8 (pp 297-344). 

MOE0 Paired t test for equivalence of means 
Power, sample size, or effect size are computed using central and non-central t 
where the non-centrality parameter is √n δ and δ is defined in the table row title. 
See, for example, Machin, D., Campbell, M.J. (1987) Statistical Tables for 
Design of Clinical Trials, Blackwell Scientific Publications, Oxford. 

MOT2 Univariate one-way repeated measures analysis of variance  
MOT3 One-way repeated measures contrast 

Power, sample size, or effect size are computed using central and non-central F.  
For MOT2, the numerator and denominator degrees of freedom are (M-1) and 
(M-1)(n-1), and the non-centrality parameter is  nM times the effect size. For 
MOT3,  the numerator and denominator degrees of freedom are 1 and   (M-
1)(n-1), and the non-centrality parameter is n times the square of the effect size. 
The effect sizes are defined in the row titles in the respective tables.  For 
MOT2, see Dixon, W.J., Massey, F.J. (1983) Introduction to Statistical 
Analysis. 4th Edition. McGraw-Hill. Chapter 14.  For MOT3, see Overall, J.E., 
Doyle, S.R. (1994) Estimating Sample Sizes for Repeated Measures Designs, 
Controlled Clinical Trials 15:100-123. 

MOT4 Univariate one-way repeated measures analysis of variance 
(Greenhouse-Geisser) 

Power, sample size, or effect size are computed using methods taken from 
Muller, KE, Barton CN (1989) Approximate Power for Repeated-Measures 
ANOVA lacking Sphericity, Journal of the American Statistical Association 
84:549-555. 
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MOC0 Confidence interval for mean based on z (n large) 
MOC2 Confidence interval for difference in paired means (n large)  

for 
MOC4 Confidence interval for repeated measures con trast for 

Sample size or confidence interval width are computed using the large sample 
normal approximation, where the equations for interval width are given in the 
guide cards for the interval width row. See Dixon, W.J., Massey, F.J. (1983) 
Introduction to Statistical Analysis. 4th Edition. McGraw-Hill. Pages 80-85. For 
MOC4 see also Overall, J.E., Doyle, S.R. (1994) Estimating Sample Sizes for 
Repeated Measures Designs, Controlled Clinical Trials 15:100-123. 

For MOC0 and MOC2, the formula for n is 
2

22
/1

ω
σα sz

n −= .   

For MOC4, the formula for n is n
z Ds=

−−1
2 2 2

2

1α σ ρ
ω

/ ( )
. 

MOC1 Confidence interval for mean based on t (with coverage 
probability)  for 

MOC3 Confidence interval for difference in paired means 
(coverage probability)  for 

Sample size or confidence interval width are computed using iterative tolerance 
interval routines requiring central and non-central t and chi-square.  See 
Kupper, L.L. and Hafner, K.B. (1989)  How appropriate are popular sample 
size formulas?  The American Statistician  43:101-105. 

MOC5 Confidence interval for percentile of a normal distribution 
for 

Sample size or confidence interval width are computed based on  section 4.4 in 
Hahn GJ, Meeker WQ (1991) Statistical Intervals.  A guide for practitioners.  
John Wiley & Sons, Inc. New York. The Pth  percentile of a normal distribution 
is estimated as the sample mean + k (sd) where sd is the sample standard 
deviation of the distribution and k is chosen to satisfy Prob(z < k) = P. The 
distance from the estimated percentile to the lower limit of the confidence 
interval is given by  - t1-α σ /√(n)  + kσ  where t1-α is non-central t with n-1 
degrees of freedom and non-centrality parameter k √(n). The distance from the 
estimated percentile to the upper limit of the confidence interval is given by   

+ t1-α σ /√(n)  - kσ. 
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MOT0F One group t-test that a mean equals user-specified value in 

finite population 
MOT1F Paired t-test of mean difference equal to zero in finite 

population 
MOC0F Confidence interval for mean based on z (n large) adjusted 

for finite population for 
MOC1F Confidence interval for mean based on t (with coverage 

probability) finite population for 
MOC2F Confidence interval for difference in paired means based 

on z (n large) adjusted for finite population for 
MOC3F Confidence interval for difference in paired means based 

on t (with coverage probability) finite population for 
Computations for these tables are made in the same way as for the 
corresponding tables without the finite population correction except that the 
standard deviation is multiplied by the square root of one minus the sampling 
fraction.  For explanation of the effects of finite sampling see Cochran, G. 
(1977) Sampling Techniques 3rd Edition. John Wiley & Sons Inc. New York. 
Pages 23-28. 

MTT0 Two-sample t-test 
MTE0 Equivalence of two means 

Power, sample size, or effect size are computed using central and non-central t 
where the non-centrality parameter is √n δ/√2and δ is defined in the table row 
title.  See Dixon, W.J., Massey, F.J. (1983) Introduction to Statistical Analysis. 
4th Edition. McGraw-Hill or O’Brien, R.G., Muller, K.E. (1993) “Unified Power 
Analysis for t-tests through Multivariate Hypotheses”, in Edwards, L.K. (Ed.), 
Applied Analysis of Variance in Behavioral Science, Marcel Dekker, New York.  
Chapter 8 (pp 297-344). 

MTT0cv Two group t-test for fold change assuming log-normal 
distribution 

After taking ln(FC) as the difference in means and setting σ = ( )[ ]21ln CV+  , 

the methods used for computing power and sample size are the same as for 
MTT0.  See also Diletti, E., Hauschke D., Steinijans, V.W. "Sample size 
determination for bioequivalence assessment by means of confidence intervals" 
Int. Journal of Clinical Pharmacology 29(1991) p. 7. 
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MTT0fct Two group t-test of equal fold change with fold change 

threshold 
After taking ln(FC) as the difference in means and setting σ = ( )[ ]21ln CV+  , 

nQuery uses simulation methods based on the assumption of normally 
distributed independent samples to estimate the probability of detection. The 
probability of detection is the percent of simulations in which two conditions 
are both satisfied:  the result is significant at the specified alpha level and the 
observed fold change exceeds the fold change threshold.  It is assumed that the 
original distributions are log-normal and that the two groups have equal 
variances in the log scale (that is the CV is constant across groups).  Michael 
Elashoff, personal communication.  See also Diletti, E., Hauschke D., 
Steinijans, V.W. "Sample size determination for bioequivalence assessment by 
means of confidence intervals" Int. Journal of Clinical Pharmacology 29(1991) 
p. 7. 

MTT0uv Two group Satterthwaite t-test of equal means (unequal 
variances)  

Power and sample are computed using numerical integration methods based on 
the formulas from Moser, B.K., Stevens, G.R., Watts, C.L. "The two-sample t 
test versus Satterthwaite’s approximate F test" Commun. Statist.-Theory Meth. 
18(1989) pp. 3963-3975. 

MTE1tg Two one-sided equivalence tests (TOST) for two-group 
design 

Power or sample size are computed based on the bivariate non-central t-
distribution with degrees of freedom 2(n-1) and non-centrality parameters  
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using an algorithm due to Owen. When n per group > 5000, a large sample 
normal approximation is used.  See Chow, S.C, Liu, J.P. Design and Analysis of 
Bioavailability and Bioequivalence Studies, Marcel Dekker, Inc. (1992), 
Schuirmann DJ (1987) A comparison of the two one-sided tests procedure and 
the power approach for assessing the equivalence of average bioavailability, J. 
Pharmacokinet Biopharm 15:657-680, Phillips KE (1990) Power of the two 
one-sided tests procedure in bioequivalence, J. Pharmacokinet Biopharm 
18:137-143 and Owen DB (1965)  A special case of a bivariate non-central t-
distribution.  Biometrika 52:437- 446. 
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MTE1co Two one-sided equivalence tests (TOST) for crossover 
design 

After defining σ =  σd/2 = •MSE/•2, the same methods are used as for MTE1tg. 

MTE2tg TOST for ratio of means (log scale) for two-group design 
Power or sample size are computed using the same methods as for MTE1 
except that the entered values for the ratio of means and the upper and lower 
limits are replaced by their natural logs, and the value  

( )[ ]21ln CV+  

is substituted for σ before computing the non-centrality parameters. 

MTE2co TOST for ratio of means  (log scale) for crossover design 
After defining σ =  σd/2 = •MSE/•2, the same methods are used as for MTE1tg. 

MTE3 TOST for ratio of means for two-group design (original 
scale)  

Power or sample size are computed using the same methods as for MTE1 with 
non-centrality parameters 
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In this case however this involves an approximation since the value 1 is 
substituted for the actual correlation between the two tests 
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See Hauschke D, Kieser M, Diletti E, Burke M (1999) Sample size 
determination for proving equivalence based on the ratio of two means for 
normally distributed data.  Statistics in Medicine 18: 93-105. 

 
MTE4 TOST for ratio of means for crossover design  (original 

scale) 
The exact methods for power and sample size computation are given in 
Hauschke D, Kieser M, Diletti E, Burke M (1999) Sample size determination 
for proving equivalence based on the ratio of two means for normally 
distributed data.  Statistics in Medicine 18: 93-105.   Here, we compute power 
or sample size using the same methods as for MTE1 with non-centrality 
parameters: 
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In this case, however, this involves an approximation, since the value 1.0 is 
substituted for the actual correlation between the two tests.  

MTT1 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y) = .5 
(continuous outcome)  

Power, sample size, or p1 are computed using a normal approximation formula 
from Noether GE (1987) Sample size determination for some common 
nonparametric statistics.  J. Am Stat. Assn 82:645-647. 

MTT2 Wilcoxon (Mann-Whitney) rank-sum test that P(X<Y) = .5 
(ordered categories)  

Power is computed based on approximating the unconditional distribution of 
the test statistic under the null and alternative hypotheses using the first four 
moments of the distribution; these approximation methods were developed by 
Kolassa J (1995) A comparison of size and power calculations for the Wilcoxon 
statistic for ordered categorical data. Statistics in Medicine 14: 1577-1581. A 
Cornish-Fisher approximation is used to approximate the critical value for a test 
of size alpha (equation 5 in Kolassa 1995); a continuity correction is made to 
this critical value—integer part of computed value +0.5 (or -0.5 if the critical 
value is negative) (Kolassa personal communication). An Edgeworth series 
approximation is used to approximate the power under the alternative 
distribution (equation 6 in Kolassa 1995). 

MTT3 Two-group univariate repeated measures analysis of 
variance (Greenhouse-Geisser)  

Power and sample size are computed using methods taken from Muller, KE, 
Barton CN (1989) Approximate Power for Repeated-Measures ANOVA 
lacking Sphericity. Journal of the American Statistical Association 84:549-555. 

MTC0 Confidence interval for difference of two means (N large)   
MGC0 Confidence interval width for one-way contrast  

Sample size or confidence interval width are computed using the large sample 
normal approximation, where the equations for interval width are given in the 
guide cards for the interval width row.  See Dixon, W.J., Massey, F.J. (1983) 
Introduction to Statistical Analysis. 4th Edition. McGraw-Hill.  Pages 80-85 and 
130-131. 
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For MTC0 and MTC0U, the formula for the total sample size, N = n1 + n2, is

 N
z r

r
s=

+−1
2 2 2

2

1α σ
ω

/ ( )
 

 where r = n2/n1 is the ratio of the sample sizes in the two groups.  For MGC0, 

the total sample size is N

z
c

r
rs

i

i
i

=
− ∑ ∑1

2 2
2

2

α σ

ω

/

  

where ri  = ni /n1 and the ci are the contrast coefficients.  

MTC1 Confidence interval for difference of two means (coverage 
probability)  

Sample size or confidence interval width are computed using central and non-
central t and chi-square with coverage probability constraints, see Kupper, L.L. 
and Hafner, K.B. (1989) How appropriate are popular sample size formulas?  
The American Statistician, 43:101-105. 
 

MGT0 One-way analysis of variance 
MGT1 Single one-way contrast 

Power, sample size, or effect size are computed using central and non-central F.  
For MGT0, the numerator and denominator degrees of freedom are (G-1) and 
(N-G), and the non-centrality parameter is N times the effect size (for equal n’s 
N=nG). For MGT1, the numerator and denominator degrees of freedom are 1 
and (N-G), and the non-centrality parameter is the number of cases in group 1 
times the square of the effect size. The effect sizes are defined in the row titles 
in the respective tables.  See O’Brien, R.G., Muller, K.E. (1993) “Unified 
Power Analysis for t-tests through Multivariate Hypotheses”, in Edwards, L.K. 
(Ed.), Applied Analysis of Variance in Behavioral Science, Marcel Dekker, New 
York.  Pages 297-344. 

MGT2 Two-way analysis of variance 
Power and sample size for the two main effects and the interaction effect are 
computed using central and non-central F. The numerator degrees of freedom 
are (a-1), (b-1), and (a-1)(b-1), respectively, and the denominator degrees of 
freedom are ab(n-1). The non-centrality parameters are nab times the respective 
effect sizes for factor A, factor B, and the interaction. The formulas for the 
effect sizes are defined in the guide cards for the table.  See O’Brien, R.G., 
Muller, K.E. (1993) “Unified Power Analysis for t-tests through Multivariate 
Hypotheses”, in Edwards, L.K. (Ed.), Applied Analysis of Variance in 
Behavioral Science, Marcel Dekker, New York.  Pages 297-344. 
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MGC1 Confidence interval for one-way contrast (with coverage 
probability)   

Sample size or confidence interval width are computed using central and non-
central t and Chi-square with coverage probability constraints, see Kupper, L.L. 
and Hafner, K.B. (1989) How appropriate are popular sample size formulas?  
The American Statistician, 43:101-105. 

POT0 One sample Chi-square (normal approximation) 
Power or sample size are computed using the normal approximation to the 
binomial, see Dixon, WJ and Massey, F.J. (1983)  Introduction to Statistical 
Analysis.  4th edition.  McGraw-Hill.  The sample size is given by 

[[[[ ]]]]
n

z zs
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2
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POT0x Exact test for single proportion 
Power is computed using the cumulative binomial distribution. The cut-point 
for rejection is computed as the largest k for which the probability of observing 
k or fewer successes is ≤ α when π = π0 for a one-sided test in which πA < π0.  
For a one-sided test in which πA > π0 , we choose the smallest k for which the 
probability of observing k or more successes is ≤ α.  For a two-sided test we 
require both probabilities to be ≤ α/2.   Power is computed for the rejection 
regions for π = πA.  See Dixon, W.J., Massey, F.J. (1983) Introduction to 
Statistical Analysis. 4th Edition. McGraw-Hill. Pages 281-284 and Chernick, 
M.R., Liu, C. Y. “The saw-toothed behavior of power versus sample size and 
software solutions: single binomial proportion using exact methods.”  The 
American Statistician 56(2002) pp 149-155. 

POT1 McNemar’s  test of equality of paired proportions 

Power or sample size are computed using equation (5.6) from Miettinen, O.S. 
(1968). On the matched-pairs design in the case of all-or-none responses. 
Biometrics, 24: 339-352. For POT1, the formula for n is 
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where δ and η are defined in the row titles and the effect size side table. 
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POT1x Exact sign test of equality of paired proportions 

For each sample size n, we generate the distribution of m, the number of 
discordant pairs, using the binomial distribution with parameters n, and 
proportion η = π10 + π01.  For each value of m the rejection region is computed 
for a test of the null hypothesis that the probability of a success =0.50 (see 
paragraph on methods for POT0x).   Then the power of the test is computed 
based on the binomial for a sample size of m and a probability of success of 
(1/2)(1+δ/η).   The powers are added up over the possible values of m 
weighting by their probabilities, except that we do not consider values of m less 
than m0 or greater than m1, where m0 is such that P(m<m0) ≤  10-7 and m1 is such 
that P(m>m1) ≥ 10-7.  See Dixon, W.J., Massey, F.J. (1983) Introduction to 
Statistical Analysis. 4th Edition. McGraw-Hill. Pages 388-389 and Chernick, 
M.R., Liu, C. Y. “The saw-toothed behavior of power versus sample size and 
software solutions: single binomial proportion using exact methods.”  The 
American Statistician 56(2002) pp 149-155. 
 

POT2 Chi-square test of specified proportions in C categories 
Power, sample size, or effect size are computed based on central and non-
central chi-square, see Lachin, J. M.  (1977). Sample size determinations for rxc 
comparative trials. Biometrics, 33: 315-324.  The non-centrality parameter is n 
∆2 where the effect size ∆2 is defined in the side table and row title. 

POC0 Confidence interval for proportions (n large) 
Interval width or sample size are computed using the normal approximation to 
the binomial where the equation for interval width is given in the guide card for 
the interval width row.  See Dixon, W.J., Massey, F.J. (1983) Introduction to 
Statistical Analysis. 4th Edition. McGraw-Hill. Pages 105-107.  For POC0, the 
formula for n is 

[[[[ ]]]]n
z s==== 
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ωωωω
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POC1 Confidence interval for odds ratio for paired proportions (n 
large)  

Confidence limit or sample size computed based on normal approximation from  
Smith, J., Connett, J., McHugh, R. (1985). Planning the size of a matched case-
control study for estimation of the odds ratio. American Journal of 
Epidemiology 122:345-347 where the equation for interval width is given in the 
guide card for the interval width row. For POC1, the sample size is given by 
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n
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  where the terms are defined in the row titles and the  effect 

size side table. 

 
POC2 Confidence interval for probability of observing a rare event 

for 
The relationship between probability of an event, π, sample size, and the 
probability of observing one or more events, P, is given by  

 (((( ))))P
n==== −−−− −−−−1 1 ππππ  

See Machin, D., Campbell, M.J. (1987) Statistical Tables for Design of Clinical 
Trials, Blackwell Scientific Publications, Oxford. Section 6.2 

 

POT0F One group test for proportion (normal approximation) 
adjusted for finite population 

POC0F Confidence interval for proportion using normal 
approximation (n large) adjusted for finite population 

Computations for these tables are made in the same way as for the 
corresponding tables without the finite population correction except that the 
adjusted sample size is nN/(n+N) where n is the unadjusted sample size.  For 
explanation of the effects of finite sampling see Cochran, G. (1977) Sampling 
Techniques 3rd Edition. John Wiley & Sons Inc. New York. Pages 23-28. 

POE0 Paired responses: equivalence of ππππ1 and ππππ2   
Power or sample size are computed using the normal approximation given in 
the guide card for the first row in the table.  This is obtained by noting that the 
maximum value of the variance of the difference in proportions under the null 
or alternative hypotheses is η. For POE0, the formula for n is 
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  where the terms are defined in the row titles and the 

effect size side table.  These methods were developed based on personal 
communication with Gary G. Koch. See also Tango, T. (1998): Equivalence test 
and confidence interval for the difference in proportions for the paired-sample 
design. Statistics in Medicine 17:891-908. 
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POE1 Paired test of equivalence in proportions using confidence 

interval 
The power is calculated as the percentage of randomly-generated 2x2 tables for 
which the null hypothesis is rejected.  The cells of the 2x2 table are filled in 
using the specified probabilities π11 (control yes, case yes), π10 (control yes, 
case no), π01 (control no, case yes),  π00 (control no, case no).  For each 
simulation the 2x2 table is generated using a number of trials equal to the 
sample size (to give the sum of the "control yes" entries) and choosing a 
random binomial variate with probability π11 + π10. The sum of the "control no" 
entries is obtained by subtracting this value from the total sample size.  The 
"yes, yes" cell is obtained as a random binomial variate with number of trials 
equal to the previously-computed sum of the first row and probability equal to 
π11 /( π11 + π10).  The "no, yes" cell is obtained similarly, and the other two cells 
are obtained by subtracting from the known row sums.  

The Newcombe-Wilson score method (continuity corrected Method 10) is used 
for the confidence interval limits. (Newcombe RG (1988) Improved confidence 
intervals for the difference between binomial proportions based on paired data.  
Statistics in Medicine 17:2635-2650.)   The power is computed as the 
proportion of simulations in which the observed confidence limits are within the 
specified equivalence range. 

PTT0 Two group χχχχ2 test of equal proportions (odds ratio = 1) 
PTT0p Two group χχχχ2 test of equal proportions 

Power or sample size are computed using the normal approximation, see for 
example Machin, D, and Campbell M.J. (1987) Statistical Tables for the Design 
of Clinical Trials, Blackwell Scientific Publications, Oxford, or Fleiss, J.L., 
Tytun, A., and Ury, S.H.K. (1980)  A simple approximation for calculating 
sample sizes for comparing independent proportions. Biometrics 36:343-346. 
For PTT0, the formula for n is 
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PTT1 Two group continuity corrected χχχχ2 test of equal proportions 
(odds ratio = 1)  

PTT1p Two group continuity corrected χχχχ2 test of equal proportions 
Power or sample size are computed starting with the answer from PTT0 and 
modifying n as shown in Fleiss, J.L., Tytun, A., and Ury, S.H.K. (1980)  A 
simple approximation for calculating sample sizes for comparing independent 
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proportions. Biometrics, 36:343-346. For PTT1, the sample size is given by 

24
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n
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PTT2 Fisher’s Exact Test 
The computed power is the expected power, obtained by summing the products 
of the conditional power given a particular first-column sum times the 
probability of that sum. The conditional powers are obtained by summing the 
bivariate binomial probability density over the critical region, where, to speed 
computation, all terms less than one-millionth of the estimated maximum term 
are dropped.  See Fleiss, J.L. (1981) Statistical Methods for Rates and 
Proportions. 2nd Edition. Wiley, New York. Pages 24-26 and Chernick, M.R., 
Liu, C. Y. “The saw-toothed behavior of power versus sample size and software 
solutions: single binomial proportion using exact methods.”  The American 
Statistician, 56(2002) pp 149-155. 

 

PTT3 Two-group Chi-square test comparing proportions in C 
categories 

Power, sample size, or effect size are computed based on central and non-
central chi-square, see Lachin, J. M.  (1977) Sample size determinations for rxc 
comparative trials. Biometrics, 33: 315-324.  The non-centrality parameter is 2n 
∆2 where the effect size ∆2 is defined in the side-table and row title. 

PTT4 Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S 
strata 

PTT4cc Mantel-Haenszel (Cochran) test of OR=1 for 2x2 tables in S 
strata (continuity corrected)  (Cochran) 

Power and sample size are computed using approximate formulas from Nam, 
Jun-Mo (1992) Sample size determination for case-control studies and the 
comparison of stratified and unstratified analyses. Biometrics, 38: 389-395.   
The terms used in the formulas are defined in the side-table row names. 

PTC0 Confidence interval for ππππ1−−−−ππππ2 (n large)  for 
Interval width or sample size are computed based on the normal approximation 
where the equations for interval width are given in the guide cards for the 
interval width rows. For PTC0, the formula for n is 
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See Dixon, W.J., Massey, F.J. (1983) Introduction to Statistical Analysis. 4th 
Edition. McGraw-Hill. Pages 286-288. 

PTC1 Confidence interval for ππππ1111−−−−ππππ2222 (continuity corrected) for 
Interval width or sample size are computed based on the normal approximation 
for a continuity corrected interval given in Fleiss, J.L. (1981) Statistical 
Methods for Rates and Proportions 2nd edition.  Wiley, New York . 

PTC2 Confidence interval for ln(odds ratio) (n large)  for 
Interval width or sample size are computed based on the normal approximation 
from O’Neill, R.T. (1984) Sample size for estimation of the odds ratio in 
unmatched case-control studies.  American Journal of Epidemiology 120:145-
153. For  PTC2, the formula for n is 
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PTE0 Two-sample Chi-square test for equivalence 
Power or sample size are computed based on the normal approximation. See for 
example Machin, D., Campbell, M.J. (1987) Statistical Tables for the Design of 
Clinical Trials, Blackwell Scientific Publications, Oxford, for the equal n case, 
and Farrington & Manning (1990) Test statistics and sample size formulae for 
comparative binomial trials with null hypotheses of non-zero risk difference for 
non-unity relative risk.  Statistics in Medicine 9: 1447-1454  for the unequal n 
case. For PTE0, the formula for n is 
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 where the terms are defined in the row titles. 

PTE1 Two-group test of equivalence in proportions using 
confidence interval 

The binomial results are simulated separately for each group. The Newcombe-
Wilson score method (uncorrected) is used for the confidence interval limits. 
(Newcombe RG (1988) Interval estimation for the difference between 
independent proportions: comparison of eleven methods.  Statistics in Medicine 
17:873-890.) The power is computed as the proportion of simulations in which 
the observed confidence limits are within the specified equivalence range. 
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PGT0 Chi-square for Gx2 table 
Power or sample size are computed based on central and non-central chi-square 
using the formulation given as Case 2 in Lachin, J. M.  (1977). Sample size 
determinations for rxc comparative trials. Biometrics, 33: 315-324. 

PGT1 Test for linear trend in Gx2 table (logistic model) 
Power or sample size are computed using the equation from Nam, J. (1987). A 
simple approximation for calculating sample sizes for detecting linear trend in 
proportions. Biometrics, 43: 701-705. For PGT1, the formula for n1 , the sample 
size in group 1 is 

n
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( )
and  

the other terms are defined in the table and the compute effect size side table 

and π
π

= ∑
n

N
i i . 

PGT2 G group Chi-square test comparing proportions in C 
categories 

Power, sample size, or effect size are computed based on central and non-
central chi-square,  see  Lachin, J. M.  (1977)  Sample size determinations for 
rxc comparative trials. Biometrics, 33: 315-324.   The non-centrality parameter 
is N ∆2 where the effect size ∆2 is defined in the side-table and row title and N is 
the total sample size (Gn for the equal n’s case). 

 
STT0 Log-rank test for equality of survival curves in two groups 

Power or sample size are computed based on approximation from Freedman, 
L.S. (1982). Tables of the number of patients required in clinical trials using the 
logrank test. Statistics in Medicine, 1:121-129. For STT0, the sample size 
formula  is 
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STT1 Test based on exponential survival, accrual period 
STT2 Test based on exponential survival, accrual period, 

dropouts 
Power or sample size are computed based on equations from Lakatos, E. and 
Lan, K.K.G.1992. A comparison of sample size methods for the logrank 
statistic. Statistics in Medicine, 11: 179-91. For STT1 and STT2, the sample 
size  is 

n
z z

E P E P
s

E C E C

====
++++

−−−−






 ++++







−−−− −−−−1 1

2
1 1αααα ββββ

λλλλ λλλλ
/

ln( ) ln( ) ( ) ( )
 

where E P
d

e e
di

i

i

d T T d T

i

i i

( )
( )T

( )( ) ( )

====
++++

−−−− −−−−
++++











−−−− ++++ −−−− −−−− ++++λλλλ
λλλλ λλλλ

λλλλ λλλλ

1
0

0

 ,  T0 is the length of the 

accrual period and T the total length of followup, and the other terms are 
defined in the row titles. 

For STT0, STT1, and STT2, The required number of events, E, can be obtained 
approximately from the equation 

2

2
2/

])ln([

)(4

h

zz
E βα +

=  

where 2/αz  and βz  are the upper α/2 and upper β points, respectively, of the 

standard normal distribution and h is the hazard ratio. See Collett, D. (1994) 
Modelling Survival Data in Medical Research, Chapman & Hall, Formula 9.2 

STT3 Log-rank test of survival in two groups, simulation with 
specified rates 

Power is computed by simulating two groups of individuals following the 
course of the experiment and subject to accrual, hazard, and dropout rates 
specified in the corresponding side table. In each simulation, the fate of each  
individual is controlled by the output of the random number generator.  The test 
statistic is computed according to the method specified in Chapter 5, pages 127-
128, of Lee, E.T. (1980)  Statistical Methods for Survival Data  Analysis.  
Lifetime Learning Publications.  Belmont, California.  The number of 
simulations in which the test statistic indicated a significant outcome is  divided 
by the total number of simulations, and the quotient is reported as the power.  If 
a one-sided test is specified, the program tracks separately the simulations that 
are significant in the positive direction and in the negative direction and reports 
the quotient that gives the greater power.  As long as the power is reasonably 
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high, the number of simulations that appear significant in the “wrong” direction 
should be very small. 

The data for each individual are simulated using a deterministic pseudo-random 
number generator, so for the same inputs and the same seed, the computed 
power will always be the same.  The particular generator used is called r250 and 
is described in Journal of Computational Physics v. 40, pp. 517-526 (1981).  
The random number generator r250 is a Tausworthe-style shift-register random 
number generator, based on a primitive trinomial in which the state is initialized 
using some other random number generator, and a trick is then used to make 
certain that the columns are linearly independent.  The cited paper describes 
various statistical tests to validate the output.  

The present implementation differs from that of the authors cited in that we 
initialize the state of r250 using the default random number generator in 
Microsoft Visual C++, which is a mixed linear congruential random number 
generator. In contrast, the authors use GGL, which is a multiplicative 
congruential random number generator. Our approach has the advantage that 
pure-multiplicative random number generators perform very poorly with regard 
to the independence of sequences generated by different seeds.  To test our 
implementation of this generator, we compared the results of simulations done 
with r250 to those done with the default Microsoft generator, and also to the 
Wichmann-Hill generator  (Applied Statistics, v. 31, pp. 188-190).  For several 
examples with 10,000 simulations, all three generators produced values for 
power agreeing to within .005. 

AOT0 Agreement between two dichotomous ratings (intraclass 
kappa) 

AOC0 Confidence interval for intraclass kappa (n large)  
Power or confidence interval width, or sample size are computed using the large 
sample standard error of estimated kappa from Block, D.A. and Kraemer, H.C. 
(1989). 2x2 kappa coefficients: measures of agreement or association. 
Biometrics. 45:269-287. 

AOT1 Test for value of correlation coefficient 
AOC1 Confidence interval for correlation coefficient 

Power or confidence interval width, or sample size are computed based on the 
large sample normal approximation using Fisher’s z transformation;  see Dixon, 
W.J., Massey, F.J. Introduction to Statistical Analysis. 4th Edition McGraw-Hill 
(1983) p. 224.  The sample size for AOT1 is given by 
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AOT2 Lin’s concordance coefficient (continuous outcome)  
AOC2 Confidence interval for Lin’s concordance coefficient 

(continuous outcome)  
Power or interval width, or sample size are computed using normal 
approximation formulas given in Lin, L.I. (1992). Assay validation using the 
concordance correlation coefficient. Biometrics 48:599-604. 

ROT0 Logistic regression (binary outcome), single x 
ROT1 Logistic regression, x1 adjusted for p X’s (binary outcome), 

Power or sample size are computed using normal approximation formulas given 
in Hsieh, F.Y. (1989). Sample size tables for logistic regression. Statistics in 
Medicine 8:795-802. 

The sample size for ROT0 is: 
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where n1 is the sample size obtained in the case of a single covariate. 

ROT2 Linear regression (continuous outcome), single x 
ROT3 Multiple linear regression with k covariates, 
ROT4 Multiple linear regression, x1 adjusted for A covariates 
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Power, sample size, and detectable correlation coefficient are computed using 
central and non-central F with numerator and denominator degrees of freedom 1 
and n-2 for ROT2, k and (n-k-1) for ROT3, and b and (n-a-b-1) for ROT4 based 
on a conditional power viewpoint.  Non-centrality parameters are nf2  where f2 = 
ρ2/ ( 1- ρ2)  for ROT2, f2 = R2/ ( 1- R2) for ROT3, and  

f2 = (RAB

2 - RA

2)/ ( 1- RAB

2) for ROT4.  See Gatsonis, C., Sampson, A.R. (1989) 
Multiple Correlation: Exact Power and Sample Size Calculations. Psychological 
Bulletin 106:516-524. 

ROT5 Linear regression test that ββββ=ββββ0 for one x 
Power, sample size, or effect size are computed based on central and non-
central t, with n-2 degrees of freedom. The non-centrality parameter is the effect 

size, δ, times n , where δ is defined in the guide card for the effect size row.  
See Dupont, W., Plummer, W. (1998) Power and sample size calculations for 
studies involving linear regression. Controlled Clinical Trials 19:589-601. 

ROC0 Linear regression confidence interval for ββββ=ββββ0 for 
Interval width and sample size are computed using the large sample normal 
approximation; the formula for the interval width is shown in the guide card for 
that row.  See Dixon, W.J., Massey, F.J. (1983) Introduction to Statistical 
Analysis. 4th Edition. McGraw-Hill. Pages 214-219. 

RTT0 Linear regression test that ββββ1=ββββ2 for one x 
Power, sample size, or effect size are computed based on central and non-
central t with 2n-4 degrees of freedom. The non-centrality parameter is the 

effect size, δ, times 2
n , where δ is defined in the guide card for the effect 

size row.  See Dupont, W., Plummer, W. (1998) Power and sample size 
calculations for studies involving linear regression. Controlled Clinical Trials 
19:589-601. 

RTC0 Linear regression confidence interval for ββββ1 - ββββ2 for two 
groups 

Interval width and sample size are computed using the large sample normal 
approximation; the formula for the interval width is shown in the guide card for 
that row.  See Dixon, W.J., Massey, F.J. (1983) Introduction to Statistical 
Analysis. 4th Edition. McGraw-Hill. Pages 227-229. 
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Section 2 
Central functions  
 (computing cumulative distribution function) 

Normal distribution z 
The method used to compute the cumulative value of the normal distribution up 
to x will differ, depending on the value of x. Specifically: 

1.  If x is between -1.5 and 3.0, the c.d.f. is computed via the Taylor series 
centered at 0.  

2.  If x is between 3.0 and 10.0 or between -10.0 and -1.5, the program uses a 
continued fraction given by A. G. Adams in his 1969 communication in 
CACM vol. 12 pp. 565-566.  

3.  If x is less than -10.0 or greater than 10.0, the value of the c.d.f. is set as 0.0 
or 1.0, respectively. 

F distribution 
The cumulative value of the F distribution up to x with m numerator degrees of 
freedom and n denominator degrees of freedom is usually calculated by a call to 
the function that computes the incomplete beta function with a equal to m/2 and 
b equal to n/2, integrating up to n/(n +mx), and subtracting the result from 1. 

However, if either n or m is particularly large, the value may be calculated from 
the cumulative χ2distribution function. This will occur when lgamma(m+n) − 
lgamma(m +1) − lgamma(n) + m*log(y) + n*log(1 − y) is greater than or equal 
to 500, where lgamma is the logarithm of the gamma function and y equals n/(n 
+mx), or when the value calculated in the paragraph above is equal to zero and 
at least one of m,n is greater than 100. 

t distribution 
There is no separate computation for the c.d.f of the central t distribution. 
Instead, it is computed from the F distribution with 1 numerator degree of 
freedom, using the square of the t value and distinguishing between positive and 
negative values of t. 

χχχχ2 distribution 
If the degrees of freedom exceed 150, the c.d.f of the χ2 distribution up to x is 
computed via the Wilson-Hilferty approximation (see N.C. Severo and M. 
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Zelen, Biometrika vol. 47 pp. 411-416, 1960); that is, one computes the 
cumulative normal distribution up to: 

( ) ( )( ) ( )x / / /ν ν ν
1

3 1 2 9 2 9− −
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





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Otherwise use is made of a recurrence relation that reduces degrees of freedom 
by 2 (see Abramowitz and Stegun, 1970, equation 26.4.8); this reduces the 
problem to calculating the χ2  distribution with 1 or 2 degrees of freedom 
(according to whether the original degrees of freedom are odd or even); this is 
easily done exactly in terms of the normal distribution function or the 
exponential function. 

Incomplete beta function Ix (a,b ) 

 The incomplete beta function may be computed either by a power series or by a 
continued fraction derived from the power series. The power series is described 
in Numerical Recipes in C 2nd Edition, equation 6.4.4. Equation 6.4.5 describes 
the continued fraction 

nQuery Advisor makes several tests to see if for the given values of x, a and b, 
the value of Ix(a,b) is negligibly close to zero or one; if so, the program returns 
zero or one as appropriate. If not, then nQuery checks to see if the power series 
can be predicted to converge rapidly; if so, nQuery uses the power series. 
Otherwise, nQuery uses the continued fraction. 

Cumulative binomial 
If π is the probability of success on a single trial, then the probability that the 
number of successes is less than or equal to k, given n independent trials, is 
calculated as 1 - Iπ(k+1, n-k), see definition of the incomplete beta function 
above. If k=n, however, the probability is taken to be 1.  
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Non-Central functions     
 (computing cumulative distribution function) 

Non-central F 
In the usual case the c.d.f. of the non-central F distribution is computed via a 
call to the non-central beta function, which is a Poisson mixture of incomplete 
beta values in the same way that non-central F is a Poisson mixture of values of 
the c.d.f for the central F distribution. 

Just as in the central F case, there are approximations for use for large degrees 
of freedom. When numerator degrees of freedom are large, we compute the 
desired value from the c.d.f for central Χ2. When the denominator degrees of 
freedom are large, we use the non-central Χ2. 

Non-central beta  
The non-central beta function Ix (a,b,δ ) is defined as the sum as i ranges from 0 
to infinity of  

Pi (δ ) Ix(a + i, b ),  

where Pi (δ ) is the Poisson probability for i with Poisson parameter δ, and  

Ix(a + i, b )  

is the incomplete beta function as before. This sum is computed from a 
minimum value of i to a maximum value, where the contribution of terms 
outside this range is considered negligible. For this purpose the incomplete beta 
distribution is considered negligible past 100 standard deviations from the 
mean, and the Poisson distribution is considered negligible past 10 standard 
deviations to the left, or 100 standard deviations to the right, of the mean. Also 
the summation is terminated if the value of Ix(a + i, b ) falls below 10-12. 

Non-central t 
Following exercise 23.24 of Stuart and Ord, Advanced Theory of Statistics, vol. 
2, p. 904, it is possible to compute the c.d.f. of the non-central t in a manner 
quite analogous to the computation of non-central beta detailed above. That is, 
you can use a generalized Poisson mixture of values of incomplete beta, where 
for successive terms the value of one of the parameters for incomplete beta 
changes by 1/2 rather than by 1. Similarly for the Poisson factor, the Poisson 
distribution is generalized to non-integer values. We sum until the integer 
Poisson values sum to within 5 * 10-13 of 1. Since the half-odd-integer Poisson 
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values should be about the same, this should be within about 10-12 of the right 
answer. 

The x value for the values of incomplete beta going into the series is the 
reciprocal of  

1 + t 2/ν ,  

where t is the upper value of the c.d.f. and ν is degrees of freedom. If this value 
is too small, i.e. less than 10-8, we risk losing information due to roundoff error. 
Therefore, we approximate our result as the normal c.d.f up to t—δ, and add a 
correction term linear in t. Note that the quadratic term is correct already. 

Non-central χχχχ2 
The c.d.f. of the “non-central χ2 distribution” is a Poisson mixture of central χ2 
c.d.f’s, and much the same considerations apply as for non-central beta. 

Percentage points and non-centrality parameters 

Percentage points of normal distribution 

For probability p < 0.5, one computes y = (log( / ))1 2p . Then the percentage 

point z is computed as y + P(y ) / Q(y ) where P and Q are fourth-degree 
polynomials in y with appropriate coefficients. For p>0.5, the situation is 
symmetrical. This method is due to Odeh and Evans, Applied Statistics v. 
23(1974), pp. 96-97. 

Percentage points of central F distribution 
An initial estimate of the percentage point is obtained via an approximate 
formula. The code then searches for another value that falls on the opposite side 
of the true percentage point from the estimate already obtained (i.e. the two 
estimates bracket the true value). 

Then the Illinois method (more fully described below) is used to find a value of 
F such that the c.d.f. up to F differs from the desired value by at most 0.01. 

Finally, Halley’s method (See Huh, Communications in Statistics--Simulation 
and Computation v. 15(1986).pp.1191-1198) is used until two criteria are met: 

a)  The c.d.f. up to F differs from the desired value by at most 0.0001. 
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b)  Successive estimates of F differ from one another by at most 0.0001 
proportionally, that is to say, by at most 0.0001 times the absolute value of 
the more recent estimate. (In the F case, of course, all estimates are 
nonnegative.) 

It is also worth noting that if numerator degrees of freedom are greater than 
denominator degrees of freedom, we reverse the degrees of freedom and take 
the reciprocal of the percentage point. 

Percentage points of central t distribution 
Again there is no separate computation. We take the square root of the F 
percentage point, first doubling the probability and using 1 numerator degree of 
freedom, and assigning the sign as appropriate. 

Percentage points of central χχχχ2 distribution 
First, an initial estimate is obtained via the Wilson-Hilferty approximation 
referenced above. If degrees of freedom exceed 150, this is used as the answer. 

Otherwise, a modification is used of Halley’s method (referenced above). Again 
the iteration is continued until the c.d.f. up to the estimate differs from the 
desired value by at most 0.0001 and two successive estimates differ 
proportionally by at most 0.0001. 

Percentage points of non-central F distribution 
The Illinois method (see Kennedy and Gentle, Statistical Computing, Marcel 
Dekker: New York(1980) ) is used. That is, two initial estimates are chosen. 
Those estimates ideally should bracket the true solution, but this is usually not 
critical. We then find successive estimates by linear interpolation, splitting the 
interval as appropriate so that our two estimates continue to bracket the true 
solution. The only exception is that if the older of the two estimates remains 
fixed, its corresponding ordinate is adjusted (halved, if we think of ourselves as 
looking for the zero of a function). That is, if we’re looking for the value of the 
monotonic function f , we choose x0 and x1 such that f (x0) and f (x1) have 
opposite sign, then compute x2 as 

  [x0 f (x1) − x1 f (x0) ] /[f (x1) − f (x0)] 

Then if f (x1) and f (x2) have opposite sign we replace x0 by x1 and x1 by x2 and 
continue. If on the other hand they have the same sign we again replace x1 by x2 
but we leave x0 as it is. However on the next round, we shall use a value half as 
large for f (x0). 
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The iteration continues until both f (x1) has absolute value less than 0.0001 and 
x0 and x1 differ proportionally by at most 0.0001 (i.e. they differ by less than 
0.0001 times the arithmetic mean of their absolute values). 

In the case of percentage points of non-central F there seems to be no need for 
subtlety in choosing the initial estimates; they are chosen to be 0.0 and 
100000.0. 

Percentage points of non-central t distribution 
The Illinois method is used as described above. If δ is the non-centrality 
parameter, then the bracketing values are chosen to be δ-100 and δ+100, except 
in the one-degree-of freedom-case, when they are chosen to be δ-1000 and 
δ+1000. 

Percentage points of non-central χχχχ2 distribution 
The Illinois method is used as described above. The initial bracketing values are 
chosen to be 0.0 and 100000.0. 

Non-centrality parameter of the non-central F distribution 
 (given both the probability and the percentage point) 
The Illinois method is used as described above. The bracketing values are 
obtained as follows: The program first tries the upper limit 5000. If this value is 
not large enough, an error message is produced. (An error message is also 
generated if the probability given by central F is larger than the desired value, 
since that indicates the value zero for the non-centrality parameter to be too 
large.) 

Otherwise we start with λ0 = 0.0 and λ1 = 1.0. If the true value is between these, 
we continue with the Illinois method; otherwise we replace  λ0 by λ1 and double 
λ1, and repeat. 

Non-centrality parameter of the non-central t distribution 
The Illinois method is used. The initial estimates are chosen as -100.0 and 
100.0. 

Non-centrality parameter of the non-central χχχχ2 distribution 
The Illinois method is used. The initial values are chosen as for the non-
centrality parameter of non-central F and the same error checking is performed. 
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Use of distribution functions in computing power, 
sample size, and effect size, or interval width and 
sample size 

Power 
We are given the desired significance level of the test, an “effect size” or values 
from which it may be calculated, and the sample size. We wish to determine the 
power of the study to reject the null hypothesis. 

First one determines the appropriate percentage point of the central t, F, or χ2 
distribution, depending on the problem at hand, where the degrees of freedom 
depend on the sample size in a manner that depends on the test being considered 
(see Methods of Computation for each table). The “appropriate” percentage 
point means the 100(1-α)% point, in a one-sided test, or the 100(1- α/2)% point 
in a two-sided test. Then the non-centrality parameter of the distribution of the 
test statistic under the alternative hypothesis is calculated from the effect size in 
a manner depending on the test being considered (see Methods of Computation 
for each table). Finally the power is computed as the c.d.f. of non-central 
distribution with the degrees of freedom and non-centrality parameter as in 
Methods of Computation for each table. 

Sample sizes for tests 
The section above describes how power is computed from effect size and 
sample size. When given power and effect size, one can compute the required 
sample size by searching for the minimum integer value required to produce (at 
least) the requested power. This is done, essentially, via the Illinois method. The 
initial values are obtained by trying the values 100, 10 and 2 in that order. If 
two values are found that bracket the desired value they are used; otherwise (i.e. 
if a sample size of 100 is too small) linear extrapolation is used to find an upper 
bound. 

Another feature to note is that the iteration will terminate under two conditions: 
1.  If the calculated power is within 0.0001 of the requested value. 

2.  If we have two estimates within 1 of each other (since we’re only looking 
for the least integer that is large enough). 
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Effect sizes for tests 
To calculate effect size from power and sample size, one simply reverses the 
procedure given above for computing power. That is, one calculates as before 
the central percentage point corresponding to significance, then the non-
centrality parameter of the t, F , or χ2 that gives a c.d.f. equal to one minus the 
specified power at the calculated percentage point. Then one solves for the 
effect size from the non-centrality parameter in a manner depending on the 
particular test being considered (see Methods of Computation for each table). 

Interval width for means confidence intervals with tolerance probability 
We obtain the half-width of a confidence interval for a mean (or difference 
between means, or means contrast) by multiplying a t—percentage point 
(corresponding to a confidence level) by an estimate for the standard deviation. 
(Also there may be a scaling factor for the difference or contrast case.) 

Since the estimate for the variance is distributed as χ2, the tolerance probability 
is the c.d.f. of the χ2 distribution. Note that the tolerance probability is the 
chance that the confidence interval obtained from the study will be no wider 
than the specified value. 

Therefore, we multiply the relevant t-percentage point by the square root of the 
relevant χ2 -percentage point, and multiply by the standard deviation, the 
scaling factor, and other factors depending on sample size (corresponding to the 
factors necessary to make the distribution of estimated standard deviation be 
χ2). 

Sample size for means confidence intervals with tolerance probability 
As in the case of the means t -tests, we have a quantity that increases with 
sample size, and that we want to be at least a certain value. This quantity is not 
power, but tolerance probability. The same variation on the Illinois method is 
used to determine the minimum necessary sample size. 
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See also agreement tables, 17-1 
See also means, sample size tables, 8-1 
See also proportions tables, 15-4 
See also regression, choosing table, 18-1 
contrast between means, 8-4 
difference of two means, 8-3, 8-9 
example, for intraclass kappa AOC0, 17-2 
estimation, 11-4 
example for MTC1, 8-9 
for correlation coefficient, 21-17 
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for difference in paired means, 8-3,  21-3 
for difference in paired means (coverage 

probability), 21-3 
for difference in paired means based on t 

(with coverage probability) finite 
population, 21-4 

for difference in paired means based on z(n 
large) adjusted for finite population, 21-4 

for difference in two means, 11-28 
 example for MTC1, 8-9 
for difference of two means (coverage 

probability), 21-8 
for difference of two means (n large), 21-7 
for equivalence testing, 11-1, 11-2 
for intraclass kappa, 21-17 
for linear regression (one group), 21-19 
for linear regression (two groups), 21-19 
for Lin's concordance coefficient, 21-18 
for ln(odds ratio), 21-14 
 example PTC2, 15-21 
for mean based on t, 21-3 
 (with coverage probability) finite 

population, 21-4 
for mean based on z, 21-3 
 (n large) adjusted for finite population, 

21-4 
for odds ratio for paired proportions (n 

large), 21-10 
for one-way contrast, 8-4 
 (with coverage probability), 21-9 
for one-way repeated measures contrast, 8-3, 

13-3 
for paired designs, 13-2 
for percentile of a normal distribution, 8-2, 

21-3 
 example for MOC5, 8-11 
for probability of observing a rare event, 

21-11 
for proportion using normal approximation 

(n large) adjusted for finite population, 
21-11 

 for proportions, tables for, 15-2, 15-3, 15-4 
for proportions (n large), 21-10 
 (continuity corrected), 21-14 
 based on normal distribution, 21-13 
for repeated measures contrast, 21-3 

 for simulated probability, 8-20 

for two groups, 8-9 
interval widths, 11-29 
tables for means, 8-2, 8-3, 8-4 
width for one-way contrast, 21-7 

continuity corrected, 15-1 
continuous y 

in regression, 18-2 
contrast, 8-3 

one-way (with coverage probability), 
confidence interval for, 21-9 

single one-way, 21-8 
conversion  
 between parameters, 5-9 
 to alternate rates for exponential 

parameters, 16-6 
copy, 4-2 

choosing font, 4-3 
guide card contents, 7-3 
guide card to clipboard, 4-15 
in right-click menu, 4-15 
notes to clipboard, 4-15 
on plot Edit menu, 6-23 
references to clipboard, 4-15 
rows, 10-3 
statement to clipboard, 2-26, 4-10, 4-15 
table to clipboard, 4-15 

correlation 
 coefficient, estimate SD from, 5-11 

Kappa, 17-1, 17-4 
methods of computation, 21-17 
Pearson's r, 17-1 
specify for covariance matrix, 9-1, 9-26 
tables for, 18-3 

covariance matrix, 13-22 
specify, 5-12, 9-1, 9-27 
specify correlations for, 9-31 
specify standard deviations for, 9-30 

create statement, 2-23, 3-10, 4-8, 8-7, 12-12 
in right-click menu, 4-15 

crossover designs, 13-1, 13-2, 13-3, 13-4 
carryover effects, 13-4 
covariance matrix 

within-subject, 13-4 
error variance, 13-4 
example M period MOT3, 13-12 
example, M period MOT1, 13-14 
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example, M period, M treatment MOT2, 
13-8 

example, two-period, two-treatment 
MTT0, 13-4 

Latin square, 13-8 
means, 8-4 
repeated measures contrasts, 13-12 
period effects, 13-4 
residual effects, 13-4 

cumulative binomial distribution, 5-13, 20-1, 
21-20, 21-21 

customize regional settings, 1-7 
cut, 4-2 

in right-click menu, 4-15 
CV 

See also coefficient of variation 
estimating SD from, 9-14, 9-23, 9-26 

data entry, 5-4 
equally spaced values, 9-24 
SD calculator, 9-2 
transformation in, 9-4 

design 
choosing study design, 2-1 

dichotomous outcome, 15-1 
in regression, 18-1 

display font choice reminder upon copy, 3-17 
distribution function menu, 5-13 

Chi-square (central) distribution, 5-13 
Chi-square (non-central) distribution, 5-13 
cumulative binomial distribution, 5-13 
F (central) distribution, 5-13 
F (non-central) distribution, 5-13 
t (central) distribution, 5-13 
t (non-central) distribution, 5-13 
z (gaussion/Normal) distribution, 5-13 

distribution function tables, 20-1 
dropouts, 16-13 
edit 

See also fill right 
 See also specify multi-factor table  
 column names, 4-12, 6-3, 8-23 
 plot axis, 6-26 
 plot legend, 6-29 
 plot parameters, 6-28 
 plot text, 6-25 

row names, 2-5, 4-11 
values in a column, 2-16 

Edit menu, 4-1 
in right-click menu, 4-15 

effect size 
See also compute effect size 
computational methods for, 21-26 
computing, 5-4, 5-5, 14-2, 14-5 
specifying, 2-11 

equality of two means 
equivalence tests for, 11-1, 11-2 

equivalence 
See also examples for equivalence testing 
See also examples for proportions  
Chi-square test for, 21-14 
example for two groups, 11-4 
for two groups, 11-8, 11-11 
in proportions, 15-2, 15-3, 15-4 
 methods of computation, 21-12 
 two group test using confidence 

interval, 21-14 
of paired responses, 21-11 
of two means, 21-4 
t test for equivalence of means, 21-2 
tables for, 11-1, 11-2 
tests, one-sided, 11-3 
tests, two-sided, 11-6 

estimate SD, 5-11, 9-1 to 9-26 
events 

number of, 16-5, 16-12 
exact tests, 13-2 

See also proportions, tables 
caveat for, 15-11 
exact sign test, 13-2 
example POT1, 15-6 
for single proportion, 21-9 
of equality of paired proportions, 21-10 

exact size of plot, 6-22 
examples for agreement 

confidence interval for intraclass kappa 
AOC0, 17-2 

examples for equivalence testing 
See also examples for proportions 
non-inferiority for difference in means 

MTE0, 11-4 
TOST for difference of means two-group 

MTE1tg, 11-8 
TOST for difference of means in crossover 

MTE1co, 11-11 
TOST for ratio of means in crossover (log 

scale) MTE2co, 11-20 
TOST for ratio of means in crossover 

MTE4, 11-24 
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TOST for ratio of means two group (log 
scale) MTE2tg, 11-18 

TOST for ratio of means two group MTE3, 
11-23 

TOST for ratio of means, two group, using 
logs, MTE1tg, 11-16 

examples for means 
See also examples for equivalence testing 
confidence interval for percentile of 

normal distribution, MOC5, 8-11 
M period crossover MOT1, 13-14 
M period crossover MOT3, 13-12 
M period M treatment crossover MOT2, 

13-8 
MTT0 tutorial, 2-1 
one way ANOVA MGT0, 12-1 
one-way ANOVA contrast MGT1, 12-19 
one-way ANOVA MGT1, 12-14, 12-16 
one-way repeated measures ANOVA 

MOT2, 13-16 
one-way repeated measures contrast 

MOT3, 13-18 
paired t-test for MOT1, 8-5 
two-group repeated measures ANOVA 

Greenhouse-Geisser MTT3, 13-20 
two-group Satterthwaite t-test of equal 

means MTT0uv, 8-13 
two-group t-test for fold change MTT0cv, 

8-15 
two-group t-test of equal fold change 

MTT0fct, 8-18 
two-sample confidence interval MTC1, 8-9 
unequal n's MTT0, 10-2 

examples for proportions 
Chi-square test, comparing, PTT3, 15-23 
Chi-square test, PTT0, 15-17 
confidence interval for, ln PTC2, 15-21 
confidence interval for, POC0, 15-4 
exact sign test, POT1x, 15-6 
linear trend in Gx2 table, PGT1, 15-29 
Mantel-Haenszel test, PTT4, 15-25 
McNemar's test, POT1, 15-6 
paired test for non-inferiority for 

proportions, POE1a, 15-32 
paired test of equivalence in, POE0, 15-32 
proportions one-group test, POC0F, 19-2 

two group test of non-inferiority for, 
PTE0, 15-40 

two-group Chi-Square test (solve for 
proportion) PTT0, 15-12 

two-group Fisher's exact test, PTT2, 15-17 
two-group TOST test of equivalence in, 

PTE0, 15-46 
two-sided confidence limits for non-

inferiority for, PTE1a, 15-40 
two-sided TOST confidence limits for 

difference in , PTE1c, 15-46 
examples for regression 

linear regression for one x, ROT5, 18-14 
linear trend in Gx2 table, logistic model, 

PGT1, 15-29 
logistic regression with continuous 

covariate, MTT0U, 18-12 
logistic regression with continuous 

covariate, ROT0, 18-7 
logistic regression with dichotomous 

covariate, PTT0U, 18-4 
examples for survival analysis 

conversion between parameters assistants 
table to obtain alternate rates, 16-6 

exponential survival, STT2, 16-9 
log-rank test for survival in two groups, 

16-23 
log-rank test, fixed followup, STT0, 16-3 
log rank test, simulation, STT3, 16-14, 16-21 
log-rank test, simulation, survival plots, 

16-26 
test based on exponential survival, STT2, 

16-9 
using side tables with survival, STT3, 16-30 

examples for non-parametric tests 
Wilcoxon/Mann-Whitney rank sum, 

MTT1, 14-1 
Wilcoxon/Mann-Whitney rank sum, 

MTT2, 14-4 
examples of plot 

plot power vs. n for MOT1, 6-1 
plot user-selected rows  
 for MOT1, 6-6 
 for MTC1, 6-17 
 for MTT0, 6-10 
 for PTT0, 6-14 



 

    
 

6 — Index 

Excel 
pasting into, 4-10 

exit, 3-4, 3-11 
from statement dialog box, 2-27 

expected cell count 
changing, 3-13 

 effect of, 15-18 
exponential parameters, 16-6, 16-8, 16-10, 

16-11, 16-13, 16-16, 16-26 
See also conversion 

exponential survival 
See also survival analysis 
example, STT2, 16-9 

export side table to Word, 12-6 
F distribution, 21-20, 21-25 
 central, 5-13, 20-1, 21-23 
 non-central, 5-13, 20-1, 21-22, 21-24 
features of nQuery Advisor 

new in Version 5.0, 1-4 
File menu 

from a sample size table, 3-4 
initial, 3-1 

fill right, 2-20, 2-21, 4-6 
finite population 
 adjustment, 5-3, 19-1 
 checkbox, 3-3 

in Study Goal and Design, 7-8 
sampling from, 19-1 
size of, 19-2 

Fisher’s Exact test, 15-3, 21-13 
See also exact tests, caveat for 
example, two-group PTT2, 15-17 

fold change 
example, two-group t-test for, MTT0cv, 8-15 
two-group t-test for, 8-2 

fold change threshold 
example in MTT0fct, 8-18 
two-group t-test of equal fold change, 8-3 

font, 6-27 
choosing for pasting table contents, 4-4 
editing in plot exis labels, 6-26 
editing in plot legend, 6-30 
editing in plot text, 6-26 
for external pasting, 3-16 
selecting, 3-8 

format plot, 6-6, 6-27 
formulas used in nQuery Advisor, 21-1 
fresh table, 2-20, 3-5 
give advice when program starts, 3-16 

goal, 2-2, 3-2 
choosing in Study Goal and Design, 7-7 

Greek letters and symbols, 3-7 
appearance in Windows application 

documents, 4-4 
using in column names, 6-2 
using in notes, 4-14 

green row 
in sample size table, 3-15 

Greenhouse-Geisser, 8-3, 13-3, 13-20 
guide card, 1-3, 2-7, 2-9, 7-2 

copy to clipboard, 3-9, 7-3 
font for pasting, 3-7 
On by default, 3-16 
option on View menu, 7-2 
paste, 3-9 
print, 3-9, 7-5 
turn Off or On, 2-7, 2-8 

help for nQuery Advisor, 1-3 
from guide cards, 2-7, 2-9, 7-3 

hotkey 
copy from table, 4-2, 4-5 
cut from table, 4-2 
paste within table, 4-4 

icon 
 bar, 2-4 

yellow tags on, 1-3 
incomplete beta function, 21-21 
interval width, 21-27 

computing using distribution functions, 
21-26 

intraclass correlation 
 cluster SD for, 9-21 
intraclass kappa, 17-1, 17-3 

methods of computation, 21-17 
introduction to nQuery Advisor, 1-1 
kappa, 17-1, 17-2, 17-3 

intraclass 
methods of computation, 21-17 

labels  
 position in plot, 6-6, 6-27 
last label in plot, 6-6, 6-27 
legend in plot 

editing, 6-29 
editing column names for, 6-2 

Lin’s concordance coefficient, 17-2, 21-18 
line parameters in plot, 6-24, 6-29 

editing, 6-25 
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linear regression, 18-3 
See also examples for regression 
confidence interval for, 21-19 
confidence interval for (two groups), 21-19 
continuous outcome, single x, 21-18 
example, for one x, ROT5, 18-14 
for one x, 21-19 
model for, 18-14 
one-group, ROT5, 18-14 
one group, RTT0, 18-18 
tables for, 18-3 

linear trend 
in Gx2 table, 15-29, 21-15 
example, PGT1, 15-29 

log transform, 9-2 
See also log-normal data 
See also log-normal distribution 

logistic regression 
See also regression, choosing table 
See also proportions, tables 
adjusting for prior covariates, 18-10 
example, linear trend in Gx2 table, logistic 

model, PGT1, 15-29 
example, with continuous covariate, 

MTT0U, 18-12 
example, with continuous covariate, 

ROT0, 18-7 
example, with dichotomous covariate, 

PTT0U, 18-4 
log-normal data 

CV, 9-14, 9-22, 9-25 
log-normal distribution 

equivalence tables for, MTE2co, tg, 8-4 
tables for fold change, MTT0cv, 8-2, 8-15 
tables for fold change, MTT0fct, 8-3, 8-18 
unequal variance,s MTT0uv, 8-2, 8-13 

log-rank test, 21-15 
example, computing sample size, STT0, 

16-3 
for equality of survival curves, 21-15 
of survival in two groups, simulation with 

specified rates, 21-16 
maintain aspect ratio, 6-22 
Mann-Whitney, 8-3, 14-1 

rank-sum test (continuous outcome), 21-7 
rank-sum test (ordered categories), 21-7 

Mantel-Haenszel, 15-3 

example, PTT4, 15-25 
test of OR=1 for 2x2 tables in S strata, 21-13 
test of OR=1 for 2x2 tables in S strata 

(continuity corrected), 21-13 
maximize first table, 3-16 
McNemar’s test, 13-2 

example, POT1, 15-6 
of equality of paired proportions, 21-9 

means 
See also examples for equivalence testing, 

11-1 
See also examples for means, 8-1 
entering, 2-12 
sample size tables, 8-1 
tests for equivalence of, 11-1 
tests for non-inferiority of, 11-1 

menu bar, 3-1, 2-4 
menus 

right-click, 2-11 
specific to panes, 2-11 

metafile 
save plot as, 6-20 

MGC0, 21-7 
MGC1, 21-9 
MGT0, 21-8 

example, one way ANOVA, 12-1 
MGT1, 21-8 

example, one-way ANOVA, 12-14 
example, one-way ANOVA, 12-16 
example, one-way ANOVA contrast, 12-19 

MGT2, 21-8 
Microsoft Word 

pasting from nQuery, 3-7 
MOC0, 21-3 
MOC0F, 21-4 
MOC1, 21-3 
MOC1F, 21-4 
MOC2, 21-3 
MOC2F, 21-4 
MOC3, 21-3 
MOC3F, 21-4 
MOC4, 21-3 
MOC5, 21-3 

example, 8-11 
MOE0, 21-2 
MOT0, 21-2 
MOT0F, 21-4 
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MOT1, 21-2 
example, 8-5 
example, M period crossover, 13-14 
plot power vs. n example, 6-1 
plot user-selected rows example, 6-6 

MOT1F, 21-4 
MOT2, 21-2 

example, M period M treatment crossover, 
13-8 

example, one-way repeated measures 
ANOVA, 13-16 

MOT3, 21-2 
example, M period crossover, 13-12 
example, one-way repeated measures 

contrast, 13-18 
MOT4, 21-2 
mouse buttons in data entry, 2-10 
MTC0, 21-7 
MTC1, 21-8 

example, 8-9 
plot user-selected rows example, 6-17 

MTE0, 21-4 
MTE1co, 21-6 

example TOST for difference of means in 
crossover, 11-11 

MTE1tg, 21-5 
example TOST for difference of means 

two-group, 11-8 
TOST for ratio of means, two group, using 

logs, 11-16 
MTE2co, 21-6 

example, TOST for ratio of means 
crossover (log scale), 11-20 

MTE2tg, 21-6 
example, TOST for ratio of means two-

group (log scale), 11-18 
MTE3, 21-6 

example, TOST for ratio of means two 
group, 11-23 

MTE4, 21-6 
example, TOST for ratio of means 

crossover, 11-24 
MTT0, 21-4 

example, two-period crossover, 13-4 
example, unequal n's, 10-2 
plot user-selected rows example, 6-10 

MTT0cv, 21-4 
example, 8-15 

MTT0fct, 21-5 
example, 8-18 

MTT0U 
example, logistic regression with 

continuous covariate, 18-12 
MTT0uv, 21-5 

example, 8-13 
MTT1, 21-7 

example, Wilcoxon/Mann-Whitney rank 
sum, 14-1 

MTT2, 21-7 
example, Wilcoxon/Mann-Whitney rank 

sum, ordered categories, 14-4 
MTT3, 21-7 

example, two-group repeated measures 
ANOVA, 13-20 

multi-factor table 
specifying, 2-20, 2-21, 4-6 

multiple correlation 
tables for, 18-3 

multiple linear regression, 18-3 
adjusted for A covariates, 21-18 
with k covariates, 21-18 

n per group 
recalculating, 2-16 

new 
features in Version 5.0, 1-4 

new table, 2-2, 2-20, 3-1 
new window, 7-6 
non-central  
 beta, 21-22 
 Chi-square, 21-23 

 non-centrality parameter, 21-25 
 F distribution, 21-22 

 non-centrality parameter, 21-25 
 percentage points of, 21-24 

 functions, 21-22 
 t distribution, 21-22 

 non-centrality parameter, 21-25 
 percentage points of, 21-25 

non-centrality parameter, 20-3, 21-23 
non-inferiority 

tests for, 11-1, 11-2 
nonparametric tests, 8-3, 14-1 
normal distribution, 5-13, 21-20, 21-23 

percentage points of, 21-23 
normality assumption, 19-2 

and finite populations, 19-2 
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notes, 2-9 
adding to table, 2-14 
pasting statement into, 12-12 
printing, 3-6 

number of groups, 2-2, 3-2 
choosing in Study Goal and Design, 7-7 

odds ratio, 15-2 
 estimation, example, PTC2, 15-21 
one-way analysis of variance, 8-1, 12-1 
one-way repeated measures contrast, 8-1, 13-3, 

13-15 
open a new table, 2-20, 3-3, 6-20 
Options menu, 3-12 

autorecalculation, 3-13 
change minimum expected cell count, 3-12 
preferences, 3-15 

paired designs, 13-2 
See also means, sample size tables, 8-1 
See also proportions, tables, 15-1 

paired t test for MOT1, 13-2 
example, 8-5 

parameters 
specifying, 2-9 

parameters in plot 
editing, 6-24 

paste, 4-4 
choosing font for, 4-10 

 from clipboard, 4-5 
in right-click menu, 4-15 
into Windows applications, 3-7, 3-8 

paste unformatted, 4-5 
in right-click menu, 4-15 

pdf 
printing plot to, 6-19 

Pearson's r 
confidence interval, AOC1, 17-1 
tables for, 18-3 
test, AOT1, 17-1 

percentage points, 21-23 
percentiles 

estimate Pth from data, 8-11 
estimate SD from, 5-11, 9-1, 9-11 

PGT0, 21-15 
PGT1, 21-15 

example, linear trend in Gx2 table, 15-29 
PGT2, 21-15 

plot, 2-19, 6-1 
border attributes, 6-24 
edit, 6-25, 6-26, 6-27 
 axis label text or font, 6-6, 6-8, 6-26 
 line in, 6-12, 6-29 
 legend, 6-18, 6-29 
 legend text, 6-30 
 parameters, 6-28 
 text, 6-27 
 title text or font, 6-5 
expected fold change example, 8-24 
line parameters, 6-24 
paste into Windows application, 6-19 
print, 6-15, 6-23 
 parameters, 6-16 
 to pdf, 6-19 
using Greek letters in axis label, 6-8 

plot menus, 6-1 
 Assistants, 6-25 
 Edit menu, 6-23 
 File menu, 6-20 
 Graphs menu, 6-23 

 parameters on, 6-24 
plot legend 

editing, 6-29 
text editing, 6-30 

plot power vs n, 2-19 
example for MOT1, 6-1 

plot user-selected rows 
example for MOT1, 6-6 
example for MTC1, 6-17 
example for MTT0, 6-10 
example for PTT0, 6-14 

plotting 
 a column, 2-19 
 area background, 6-22 

survival curves 
example, 16-26 

POC0, 21-10 
example, confidence interval for 

proportion, 15-4 
POC0F, 21-11 

example, proportions, one-group test, 19-2 
POC1, 21-10 
POC2, 21-11 
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POE0, 21-11 
example, paired test of equivalence in 

proportions, 15-32 
POE1, 21-12 

example, paired test of equivalence in 
proportions, 15-32 

pooled SD 
estimate from SD1, SD2, 9-1, 9-8 

population size, 19-1, 19-2, 19-3 
POT0, 21-9 
POT0F, 21-11 
POT1, 21-9 

example, McNemar’s test, 15-6 
POT1x, 21-10 

example, exact sign test, 15-6 
POT2, 21-10 
power, 21-26 

computing, 2-14 
computing using distribution functions, 

21-26 
entering a value, 2-15 
evaluating, 2-1 

 rounded down, 8-22 
vs. sample size plot, 6-4, 6-12 

Preferences menu, 3-15 
display font choice reminder upon copy, 3-17 
font for external pasting, 3-16 
give advice when program starts, 3-16 
guide on by default, 3-16 
maximize first table, 3-16 
respect regional esttings, 3-16 

print, 3-6, 3-7, 3-8, 3-9, 3-10, 3-11 
active view, 3-7 
current page, 6-21, 6-22 
dialog box, 3-6 
from right-click menu, 3-9 
guide card contents, 7-5 
in right-click menu, 3-9 
notes, 3-7 
options, 6-21 
parameters dialog box, 6-22 
plot, 6-23 
references, 3-7 
sample size justification statement, 3-10 
sample size table, 2-25 
setup, 3-4, 6-21, 6-22 
side tables, 3-7 
statement, 2-25, 3-7, 4-10 
stored statement, 3-10, 3-11 

tables, 3-7, 3-9 
print table to clipboard, 3-7 
prior covariates 

adjustment for, 18-11 
probability of detection 

MTT0fct example, 8-18 
precision of estimate, 8-20 

proportions 
Chi-square test of specified proportions in 

C categories, 21-10 
confidence interval for (n large), 21-10 
confidence interval for odds ratio for 

paired, 21-10 
equivalence tests for, 11-2 
exact sign test for equality of paired, 21-10 
exact test for single, 21-9 
example, confidence interval for, POC0, 15-4 
example, confidence limits for difference 

in PTE1, 15-46 
example, Exact sign test, POT1x, 15-6 
example, Fisher’s exact test, PTT2, 15-17 
example, Mantel-Haenszel, PTT4, 15-25 
example, McNemar’s test, POT1, 15-6 
example, one-group test, POC0F, 19-2 
example, paired test of equivalence in, 

POE0, 15-32 
example, paired test of equivalence in, 

POE1, 15-32 
example, test for linear trend in G x 2 

table, PGT1, 15-29 
example, test of equivalence in, POE0, 15-

32 
example, test of equivalence in, POE1, 15-

32 
example, two-group Chi-square test 

comparing proportions in C categories, 
PTT3, 15-23 

example, two-group Chi-square test, PTT0, 
15-12 

example, two-group continuity-corrected 
Chi-square test, PTT1, 15-17 

example, two-group test of equivalence of, 
PTE0, 15-40 

example, two-group TOST test of 
quivalence in, PTE0, 15-46 

example, two-sided confidence limits for 
difference in proportions, PTE1, 15-40 

example,confidence interval for ln, PTC2, 
15-21 
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in one group, 15-2 
McNemar's test of equality of paired, 21-9 
non-inferiority tests for, 11-2 
one-group test for, (normal approximation) 

adjusted for finite population, 21-11 
sample size tables for, 15-1 

 tables, 15-1 
PTC0, 21-13 
PTC1, 21-14 
PTC2, 21-14 

example, confidence interval for OR ln, 
15-21 

PTE0, 21-14 
example, two group test of non-inferiority 

in proportions, 15-40 
example, two-group TOST test of 

equivalence in proportions, 15-46 
PTE1, 21-14 

example, confidence limits for equivalence 
of proportions PTE1, 15-46 

example, confidence limits for non-
inferiority for proportions, 15-40 

Pth percentile 
estimating from the data, 8-11 

PTT0, 21-12 
example, Chi-square test, 15-17 
example, two-group Chi-square test (small 

n), 15-12 
plot user-selected rows example, 6-14 

PTT0U 
example, logistic regression with 

dichotomous covariate, 18-4 
PTT1, 21-12 

example, two-group continuity-corrected 
Chi-square test PTT1, 15-17 

PTT1p, 21-12 
PTT2, 21-13 

example, Fisher's exact test, 15-17 
PTT3, 21-13 

example, Chi-square test comparing C 
proportions, 15-23 

PTT4, 21-13 
example, Mantel-Haenszel test, 15-25 

PTT4cc, 21-13 
range 

estimate SD from, 5-11, 9-1, 9-10 
rank-sum test, 8-3, 14-1 

ratio of means, 8-3, 8-4.  
 See also examples for equivalence testing 

equivalence tests for, 11-1 
example, MTT0cv, 8-15 
example, MTT0fct, 8-18 
t-test for, 8-4 

recalculation, 2-17 
automatic, 3-13, 3-14 

recent file, 3-4 
references, 2-9, 21-1 

copying to clipboard, 3-7 
pasting, 3-7 
printing, 3-6 

regional settings, 1-7, 3-16 
register product, 1-2 
regression 

See also examples for regression 
choosing table, 18-1 
linear tables for, 18-3 
linear, confidence interval for, 21-19 
linear, confidence interval for (two 

groups), 21-19 
linear, continuous outcome, single x, 21-18 
linear, for one x, 21-19 
logistic, adjusted for p X’s, 21-18 
logistic, binary outcome, 21-18 
multiple linear, adjusted for A covariates, 

21-18 
multiple linear, with k covariates, 21-18 
multiple tables for, 18-3 

repeated measures, 13-1, 13-3, 13-15 
 ANOVA  

 example, one-way,  MOT2, 13-16 
 example, two group Greenhouse-

Geisser,  MTT3, 13-20 
 one-way contrast, 21-2 
 two-group (Greenhouse-Geisser), 21-7 
 univariate one-way, 21-2 
example, M period, M treatment crossover, 

MOT2, 13-8 
Greenhouse-Geisser, 13-16 
tables for, 13-1, 13-2, 13-3 

repeated measures contrast, 8-3 
example, one-way, MOT3, 13-12, 13-18 

Rich Text Format, 4-4 
right-click menu, 2-11 

for guide cards, 4-15 
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for notes, 4-15 
for references, 4-15 
for sample size table, 4-15 
for side tables, 12-6 
for statements, 4-15 

ROC0, 21-19 
ROT0, 21-18 

example, logistic regression with 
continuous covariate, 18-7 

ROT1, 21-18 
ROT2, 21-18 
ROT3, 21-18 
ROT4, 21-18 
ROT5, 21-19 

example, linear regression for one group, 
18-14 

row names, 2-5 
editing, 2-5, 4-11, 8-23 

row values 
duplicate with fill right, 4-6 
fill with specify multi-factor table, 4-6 

RTC0, 21-19 
RTT0, 21-19 

example, linear regression for one x, 18-18 
running  nQuery Advisor, 1-1 
sample size 

computing, 2-14 
computing using distribution functions, 

21-26 
for means confidence intervals, 21-27 
for tests, 21-26 
justification statement, 2-23 
 creating, 4-8 
 printing, 3-10, 4-10 
 storing, 4-9 
 to clipboard, 4-10 

sample size methods 
relationships between, 11-26 

sample size tables, 2-4 
closing, 3-5 
colors in, 2-7 
computational methods for, 21-1 
finite population adjustment in, 5-4 
for agreement, 17-1 
for means, 8-1 
for proportions, 15-1 
for regression, 18-1 
for survival analysis, 16-1 
how to open, 3-3 

how to select, 3-2 
new in Version 5.0, 1-5 
pasting from clipboard, 3-7 
printing to clipboard, 3-7 
printing, 3-6 
right-click menu, 3-9 
save as, 3-5 
saving, 3-5 
testing methods for, 21-1 

sample size too small warning, 15-17 
sampling fraction, 19-1 
Satterthwaite t test, 8-2 

of equal means (unequal variances), 21-5 
save, 3-5 
save as, 3-5 
save plot as  
 metafile, 6-20, 6-23 
 old-style metafile, 6-21 
saved table 

how to open, 3-3 
SD button, 9-1, 9-2, 9-6 
SD for specified equally spaced x's, 18-20 
SD of residuals, 18-16 
SD1 and SD2 

calculate SD from, 5-11 
SD1, SD2, Correlation 

estimating SD from, 9-17 
sensitivity analysis, 2-16 
set automatic recalculation, 2-16, 3-14 
side tables, 5-8, 12-1 

buttons, 12-4 
changing names, 16-31 
colors for names, 16-31 
compute effect size, 5-4, 5-5, 5-8 
copying to clipboard, 4-3, 12-6 
font for copying, 3-17 
for survival analysis, STT3, 16-15, 16-21, 

16-26 
MTT2, 14-4, 14-6 
printing, 3-6 
right-click menu, 12-6 
sample size tables using, 5-8 

sigma, 9-1, 13-22 
sign test, 13-2, 15-6 
significance test, 2-9 
significant digits, 2-6 
simulations, 15-37, 15-49 

progress of, 8-21, 16-18 
single one-way contrast table, 12-14 
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single proportions 
confidence intervals for, 15-2 
tests for, 15-2 

size of plot, 6-27 
special characters, 4-14 
specify correlations 

for covariance matrix, 9-31 
specify covariance matrix, 5-12, 9-27, 9-28 
specify multi-factor table, 2-20, 2-21, 4-6 
specify SIGMA, 5-12 
specify standard deviations 

for covariance matrix, 9-30 
split-plot designs, 13-1 
spreadsheet like Excel 

pasting table contents into, 3-9 
standard deviation 

and mean response, 9-14 
calculating, 9-1, 9-3 
conservative estimate, 9-15 
estimate for cluster sampling, 9-19 
estimate from coefficient of variation, 9-23, 

9-26 
estimate from CV, 9-13, 9-22, 9-24 
estimate from percentile, 9-11 
estimate from pooled SD, 9-8 
estimate from range, 9-10 
estimate from s.e., 9-6 
estimate from SD1, SD2, correlation, 9-17 
estimate from upper confidence interval, 9-15 
estimate from coefficient of variation, 9-14 
estimating, 5-11, 9-1 
for specified x-values, 9-23 
of differences, 9-18 
of residuals, 9-26 
precision, 9-15 
pre-treatment, post-treatment, 9-17 
using the data entry table, 9-1 

standard error 
calculate SD from, 5-11, 9-7 

starting  nQuery Advisor, 1-1, 1-3 
statement, 2-9, 2-23, 17-4 

copying, 3-7 
copy to clipboard, 3-7, 4-10 
creating, 3-10, 4-8, 8-7, 12-12 
customizing, 12-12 
pasting, 3-7 
pasting into notes, 8-8, 12-12 

pasting to Windows applications, 8-8 
printing, 3-6, 4-10 
storing, 4-9, 12-12 

status bar, 1-3, 2-6, 2-10, 7-1 
store statement, 2-24, 4-9 

printing, 4-9 
STT0 

example for survival analysis, conversion 
between parameters assistants table to 
obtain alternate rates, 16-6 

STT0, 16-3, 21-15 
example, log-rank test of survival, 16-3 

STT1, 21-16 
STT2, 16-3, 21-16 

example, test based on exponential 
survival, 16-9 

STT3, 16-3, 21-16 
example, log rank test for survival in two 

groups, 16-21 
example, log rank test with user-specified 

survival, 16-14 
example, using side tables with survival, 

16-30 
study design 

specify, 2-1 
Study Goal and Design dialog box, 2-2, 3-1, 

7-6 
codes, 21-1 
finite population in, 5-3 
unequal n's in, 5-2 

successes in outcome, 15-1 
survey sampling, 19-2 
survival analysis, 16-1, 16-2, 16-3 

example, log rank test for survival in two 
groups, STT3, 16-21 

example, log rank test with user specified 
survival, STT3, 16-14 

example, log-rank test for survival in two 
groups, 16-23 

example, using side tables, STT3, 16-30 
exponential survival, accrual period, 16-3, 

21-16 
exponential survival, accrual period, 

dropouts, 16-3, 21-16 
log-rank test for equality of survival 

curves, 16-2, 21-15 
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log-rank test, two groups, simulation with 
specified rates, 21-16 

simulation, 16-14 
versus proportions, 16-1 

survival curves 
example, plotting, 16-26 
exponential, conversion to alternate rates, 

5-9 
symbols, 3-7 
t (central) distribution, 5-13, 20-1, 21-24 
t (non-central) distribution, 5-1, 20-1, 21-23, 

21-25 
t distribution, 21-20 
t test, 11-26, 13-2 

 See also examples for equivalence 
testing.  

 See also examples for means  
example, equal means, unequal variances, 

MTT0uv, 8-13 
example for equal fold change, MTT0fct, 

8-18 
example for fold change, MTT0cv, 8-15 
examples for equivalence testing, two-

group TOST for ratio of means, 
MTE1tg, 11-16 

example, TOST for ratio of means, two 
group, MTE2tg, 11-18 

for difference in means (paired), 21-2 
for difference in means equal to 0 (paired), 

21-4 
for equivalence, 11-1 
for equivalence of means (paired), 21-2 
for mean equal specified value (one 

group), 21-4 
for non-inferiority testing, 11-1 
for two-samples, 21-4 
list of means tables, 8-2 
of equal fold change with fold change 

threshold, 21-5 
of equivalence of means, 8-4 
one sample, 21-2 
one-group, 8-2 
paired, 8-1, 8-3, 8-5 
 example, 8-5 
Satterthwaite for two groups, equal means 

(unequal variances), 21-5 
two group for fold change, assuming log-

normal distribution, 21-4 
two-group, 8-1, 8-2, 8-4, 11-1, 11-15, 13-2 

table 
closing, 3-5 
copy to clipboard, 3-7 
how to select, 3-2 
name abbreviation, 21-1 
opening, 3-3 
pasting from clipboard, 3-7 
printing, 3-6 
right-click menu, 3-7 
save as, 3-5 
saving, 3-5 

 title, 2-5 
tests 

for agreement, 17-1 
for crossover, 13-2 
for equivalence, 11-1 
for means, 8-1 
for paired designs, 13-2 
for proportions, 15-1 
for regression, 18-1 
for repeated measures, 13-3 
for survival, 16-1 
specify effect size for, 2-11 

text in plot 
editing, 6-26, 6-27 

tile, 7-6 
title bar, 2-4 
title for table, 2-5 
to clipboard 

statement, 2-24, 2-26, 4-10 
toolbar, 7-1 
TOST 
 bioequivalence testing, two-sided, 11-6 

example, difference of means in crossover, 
MTE1co, 11-11 

example, ratio of means crossover, MTE4, 
11-24 

example, ratio of means crossover (log 
scale), MTE2co, 11-20 

example, ratio of means two group (log 
scale), MTE2tg, 11-18 

example, ratio of means two group, MTE3, 
11-23 

example, ratio of means, two group, using 
logs, MTE1tg, 11-16 

ratio of means, 11-15 
ratio of means for crossover design (log 

scale), 21-6 
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ratio of means for crossover design 
(original scale), 21-6 

ratio of means for two-group design (log 
scale), 21-6 

ratio of means for two-group design 
(original scale), 21-6 

t-test for, 8-4, 11-1 
two one-sided equivalence tests for 

crossover design, 21-6 
two one-sided equivalence tests, 21-5 

TOST tests for proportions 
example, equivalence for independent 

proportions, PTE0, PTE1a, 15-40 
example, equivalence for independent 

proportions, PTE0, PTE1c, 15-46 
example, equivalence for paired 

proportions, POE0, POE1a, 15-32 
transfer, 13-10 
 button in side table, 5-6 
transformation 

in data entry, 9-4 
troubleshooting, 1-8 
tutorial, 2-1 
two group  

See also examples for means  
See also examples for proportions  
See also examples for survival analysis  
See also examples for regression  

 Satterthwaite t-test of equal means, 
MTT0uv example, 8-13 

 t-test example, MTT0, 2-2 
 t-test for fold change, MTT0cv 

example, 8-15 
 t-test of equal fold change, MTT0fct 

example, 8-18 
undo, 4-1 

in right-click menu, 4-15 
unequal n’s, 5-1, 10-1, 15-51 

caveat, 3-15, 10-5 
example, MTT0, 10-2 
from sample size table, 5-2 

from Study Goal and Design, 3-3, 7-8, 10-1 
from the icon, 10-1 
proportions, 15-45 

unequal variances, 8-2 
uninstalling nQuery Advisor, 1-2 
univariate one-way repeated measures 

analysis of variance, 13-3 
update table row name, 2-6 
upper confidence level 

estimating SD from, 5-11, 9-15 
values 

acceptable entries for, 7-2 
changing, caveat, 10-5 

variance 
in means, compute effect size, 12-3 

 inflation factor, 18-7, 18-10 
 of means, computing, 13-9 
View menu 

from sample size menu, 7-2 
initial, 7-1 

white rows, 2-7 
width of plot, 6-25 
Wilcoxon/Mann-Whitney, 8-3, 14-1 

example, ordered categories, MTT2, 14-4 
example, rank sum test, MTT1, 14-1 
rank-sum test (continuous outcome), 21-7 
rank-sum test (ordered categories), 21-7 

Window menu, 7-5 
Windows application 

pasting plot into, 6-19 
pasting from nQuery Advisor, 3-7 

Windows calculator, 5-14 
wmf, 6-21 
Word 

exporting side table to, 12-6 
pasting from nQuery Advisor, 3-7 

x variables, 18-1 
yellow rows, 2-7 
z (Gaussian/normal) distribution, 5-13 
z distribution, 20-1 

 



 

    
 

 


