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Overview
This user guide has been developed to assist users to install and configure Embrava Connect for
the following solutions:

• Availability Display
o
o

Use our devices to let your colleagues know when you are on a call, busy with a
task or available to chat.
This solution has been developed for the following platforms:
▪ Microsoft Teams
▪ Skype for Business / Microsoft Lync
▪ Cisco Jabber
▪ RingCentral
▪ CounterPath Bria

• Contact Center Optimization (CCO)
o
o

Use our devices to streamline the communication between agents and supervisors
to boost the performance of your contact center
This solution has been developed for the following contact center platforms:
▪ Cisco Finesse – see Appendix A for configuration details
▪ Genesys PureCloud – see Appendix B for configuration details
This solution requires the CCO Feature License. Please Contact Us if you
require this Feature License.

• Desk Booking & Workplace Analytics
o
o

Use our devices to book and check into desks and provide workplace analytics in
Hot Desking, Activity-based Working and Office Hoteling work environments.
This solution has been developed for the following platforms:
▪ EMS Software – see Appendix C for configuration details
▪ 3rd party platforms – our devices can send desk booking information to
any platform with a REST API.
This solution requires the Density Feature License. Please Contact Us if you
require this Feature License.

The following sections will illustrate how to install the basic version of Embrava Connect for
availability display with Appendices used to configure the advanced Feature License options.

©2018 Embrava Pty Ltd

4

EMBRAVA CONNECT | USER GUIDE

Embrava Connect for Windows
Installation
The purpose of this section is to describe what is required to successfully install Embrava Connect
on your Windows PC.

Prerequisites
•

•

Microsoft Windows Operating System – supports following versions:
o 10
o 8
o 7
o Vista
o XP
.NET Framework 4.5

Supported Applications for Availability Display
Embrava Connect will synchronize with the following applications to display your availability:
•
•
•
•
•
•
•

Microsoft Teams
Skype for Business 2016, 2015
Microsoft Lync 2013, 2010
Cisco Jabber for Windows 10, 11
Skype v7 and above
RingCentral – see Appendix D for configuration details.
CounterPath Bria 4

Connect your Embrava Device
1. Unpack the device from its packaging.
2. Connect the USB cable from your device into an available USB port on your PC.
3. (Optional) Peel off the protective coating from one side of the mount adhesive and attach
the adhesive to the bottom of the Blynclight device or mount. Ensure surfaces are cleaned
and free of dust before applying adhesive.
4. (Optional) Peel off the protective coating from the other side of the mount adhesive and
place your Blynclight device or mount in an appropriate position in view of your
surrounding colleagues. Ensure surfaces are cleaned and apply approximately 10 seconds
of pressure when attaching mount to a surface.
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Install Software
1. Download the latest Embrava Connect software from http://www.embrava.com/install
2. Extract the Embrava Connect installer from the zip file downloaded in Step 1.

3. Double click the Embrava Connect installer to commence the installation process.

4. After you have read the License Agreement and agree to the terms select ‘I Agree’ and
click ‘Next’.
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5. Select the Installation folder for your Embrava Connect software and if you will be the only
user of the software on this particular machine.

6. Click ‘Next’ and the installation will begin.
a. You may be prompted by a User Access Control dialog to confirm you wish to
install the software. Click ‘Yes’ to confirm the installation.
7. The installation process will now complete and Embrava Connect will run immediately.
a. If you had connected the Embrava devices correctly, as described in the ‘Connect
Device’ section above, and you have your Microsoft Lync client signed in you
should see your status automatically display on the Blync device.
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8. When Embrava Connect first runs you will be asked to select which applications you would
like your Embrava devices to connect to as illustrated below.

Uncheck any applications you do not wish to use. If you are using one device to display
your status from multiple applications, you can set the order of which application should
get priority over the device.
9. Once Embrava Connect is installed and running the application can be configured by
clicking the Embrava icon in your System Tray.
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Features
The Embrava Connect software controls all Embrava devices by configuring Alerts for a set of
defined Activities. This section will describe how these Alerts are configured for each Activity and
provides some example Alert configurations.

Configuring Alerts
The Activities that Embrava Connect can be configured to provide Alerts for depend on the UC
applications you have selected to connect to (Skype for Business, Cisco Jabber etc.). A full list of
Activities include:
•
•
•
•
•
•

Incoming IM – when an Instant Message is received.
Incoming Call – when a Call is incoming
On Call – when you are on a Call.
Available – when your status becomes Available.
Busy – when your status becomes Busy.
Do Not Disturb – when your status becomes Do Not Disturb.

For each Activity, you can define the characteristics of the Alert you would like once that Activity
occurs. The Alert characteristics you can configure are:
•
•
•
•
•
•

Light – the color of the light to be displayed on your Embrava device.
Brightness – if you would like the light to be dimmed (available for v3.0 devices only).
Flash – the speed the light should flash at.
Tone – the ringtone to be played (available for Blynclight Plus and Mini devices only).
Volume – the volume at which the selected ringtone should be played (available for
Blynclight Plus and Mini devices only).
Incoming Caller ID – display the name/number of the caller (for Nameplate only).

To configure Activity Alerts, select the ‘Open Embrava Connect’ menu item when clicking the
Embrava icon in your system tray. The ‘Embrava Connect’ screen is displayed below.
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The functionality of the above interface is described below:
1.
2.
3.
4.
5.
6.

Connection tabs – each tab represents the configuration of your selected UC application
(eg. Skype for Business, Cisco Jabber etc.)
Active checkbox – enable/disable this UC application from connecting to any Embrava
device.
Device dropdown – select the device you would like this UC application to connect to.
Activities – the list of activities supported by your UC application from which you can
configure alerts.
Alert definition – select the characteristics of the alert you wish to invoke for the selected
Activity
Connect button – connect/disconnect this UC application from the selected device.

For example, the configuration above illustrates that the Blynclight Mini device will display a
Medium-paced flashing Red light at full brightness with no sound for Incoming Calls on Skype for
Business.

Configuring the Blynclight Nameplate
The Blynclight Nameplate can display the name of the user from 3 different sources:
1.

Connection – here the Display Name from Skype for Business or Cisco Jabber can be
automatically displayed on the Nameplate.
2. Windows Display Name – when selected, the Nameplate can display the Windows Display
Name of the person logged into the PC.
3. Manual – the Nameplate can display text manually entered into Embrava Connect.
To configure the Name Source of the Nameplate:
1.

Click ‘Devices’ from ‘File’ menu within Embrava Connect. The listing of devices is shown as
below:

2. Select the Nameplate device and click ‘Configure’
3. Choose your Name Source and click ‘Ok’
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4. The Nameplate will now display the name from the selected source.
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Manual operation
Many users who do not have the provided UC applications installed or simply do not wish to have
their Embrava device replicate their UC application status can have their devices controlled
manually. To achieve this simply check the Active box on the Manual connection tab and click
‘Connect’ as shown below:

Note: Checking the Active checkbox will deactivate all other UC application connections.
Unchecking the Active checkbox here will re-activate your previous UC application connections.
From this screen, the user can select any color, flash speed, brightness, ringtone or volume and it
will be displayed on the selected device immediately.
The user can also configure Hotkeys to quickly change the color of their status light to display
their availability. For example, if a user is about to answer the phone they can press Ctrl+Alt+B
and the light will change to the Busy Red color letting colleagues know the user is Busy.
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Embrava Connect for Mac
Installation
The purpose of this section is to describe what is required to successfully install Embrava Connect
for Mac.

Prerequisites
•
•

Mac OS 10.13 – 10.9.
If using Skype for Business Online, please follow the steps outlined in Appendix F –
Configuring Authentication App for Skype for Business Online before proceeding to allow
Embrava Connect to gather status updates from Skype for Business Online.

Supported Applications for Availability Display
Embrava Connect for Mac will connect to the following servers to display your availability:
•
•
•
•

Skype for Business Online
Skype for Business Server 2015 and above
Microsoft Lync Server 2013
Cisco Unified Presence Server (CUPS)

Connect your Embrava Device
1. Unpack the device from its packaging.
2. Connect the USB cable from your device into an available USB port on your PC.
3. (Optional) Peel off the protective coating from one side of the mount adhesive and attach
the adhesive to the bottom of the Blynclight device or mount. Ensure surfaces are cleaned
and free of dust before applying adhesive.
4. (Optional) Peel off the protective coating from the other side of the mount adhesive and
place your Blynclight device or mount in an appropriate position in view of your
surrounding colleagues. Ensure surfaces are cleaned and apply approximately 10 seconds
of pressure when attaching mount to a surface.
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Install Software
1.

Download the latest Embrava Connect for Mac software from
http://www.embrava.com/install

2. Double click the Embrava Connect installer to commence the installation process.

3. After you have read the License Agreement and agree to the terms click ‘Continue’ and
select ‘Agree’.
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4. Select a Destination for your Embrava Connect for Mac software.

5. Click ‘Continue’ and the installation will begin. Once the installation is complete the
following screen will be displayed.
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6. Run the Embrava Connect for Mac application by double-clicking the application icon
within your Launchpad screen.
7. When Embrava Connect first runs you will be asked to select which applications you would
like your Embrava devices to connect.
a. Skype for Business: The following parameters are required for the Skype for
Business Connection:
i. Username – Skype for Business or Lync sign-in address E.g.
jcitizen@acme.net
ii. Password – password of the user account specified by the Username
above.

b. Cisco Jabber:. The following parameters are required for the Cisco Jabber
Connection:
i. Domain – Domain name of the CUPS in format domain.com. E.g.
acme.net
ii. Username – Cisco Jabber Sign-in Name (without @domain.com). E.g. If
Cisco Jabber Sign-in ID is jcitizen@acme.net, the Username field to be
entered is jcitizen.
iii. Password – password of the user account specified by the Username
above.
iv. Http Binding URL - BOSH URL of the CUPS. The BOSH URL is usually in the
format http(s)://server.[domain]:7335/httpbinding. See here for more
information in determining your BOSH URL.
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Uncheck any Connections you do not wish to use and then click ‘Ok’ to begin using the
application.
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Features
The Embrava Connect for Mac software controls all Embrava devices by configuring Alerts for a
set of defined Activities. This section will describe how these Alerts are configured for each Activity
and provides some example Alert configurations.

Configuring Alerts
The Activities that Embrava Connect for Mac can be configured to provide Alerts for depend on
the UC applications you have selected to connect to (Skype for Business, Cisco Jabber etc.). A full
list of Activities includes:
•
•
•
•
•
•

On Call – when you are on a Call.
Available – when your status becomes Available.
Away – when your machine is in Sleep/Standby mode.
In a Meeting – when you are in a Cisco Jabber or WebEx meeting.
Busy – when your status becomes Busy.
Do Not Disturb – when your status becomes Do Not Disturb.

For each Activity, you can define the characteristics of the Alert you would like once that Activity
occurs. The Alert characteristics you can configure are:
•
•
•
•
•

Light – the color of the light to be displayed on your Embrava device.
Brightness – if you would like the light to be dimmed (available for v3.0 devices only).
Flash – the speed the light should flash at.
Tone – the ringtone to be played (available for Blynclight Plus and Mini devices only).
Volume – the volume at which the selected ringtone should be played (available for
Blynclight Plus and Mini devices only).

To configure Activity Alerts, double click the Embrava Connect for Mac icon held in the dock. The
‘Embrava Connect’ screen is displayed below.
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The functionality of the above interface is described below:
1.
2.
3.
4.
5.
6.

Connection tabs – each tab represents the configuration of your selected UC application
(eg. Skype for Business, Cisco Jabber and Manual)
Active checkbox – enable/disable this UC application from connecting to any Embrava
device.
Device dropdown – select the device you would like this UC application to connect to.
Activities – the list of activities supported by your UC application from which you can
configure alerts.
Alert definition – select the characteristics of the alert you wish to invoke for the selected
Activity
Connect button – connect/disconnect this UC application from the selected device.

For example, the configuration above illustrates that the Blynclight Mini device will display a Lowpaced flashing Red light at full brightness with no sound for when on a call using Skype for
Business.
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Manual operation
Many users who do not have the provided UC applications installed or simply do not wish to have
their Embrava device replicate their UC application status can have their devices controlled
manually. To achieve this simply check the Active box on the Manual connection tab and click
‘Connect’ as shown below:

Note: Checking the Active checkbox will deactivate all other UC application connections.
Unchecking the Active checkbox here will re-activate your previous UC application connections.
From this screen, the user can select any color, flash speed, brightness, ringtone or volume and it
will be displayed on the selected device immediately.
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Support
This section details the different areas you can utilize to get help with your implementation of your
Embrava devices.

FAQ
Our Frequently Asked Questions (or FAQ) lists the responses to all of our commonly received
questions.
This should be your first point of support as 9 out of 10 queries are usually resolved by the FAQ.
You can access the FAQ at the URL below:
http://www.embrava.com/faq

Log a Support Call
If you are unable to resolve your query via the FAQ please log a call with our support team.
To log a support call please visit the URL below:
http://www.embrava.com/support-call
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Appendix A - Configuring Contact Center
Optimization (CCO) for Cisco Finesse
Overview
The CCO for Cisco Finesse solution is an advanced feature of Embrava Connect. The following
diagram illustrates the different components that make up the solution.

UCCE
UC UCCX
Platforms
PCCE

Caches contact
center stats

Embrava Connect
displays alerts on
status based on
received events

Embrava
Connector
Service
Requests contact
center statistics (for
Personal Wallboard
only)

Embrava
Connect

Sends agent
status & stats

CCO Feature
Licence

Embrava
Finesse
Gadget

To get started with CCO for Cisco Finesse please contact us using the form below:
https://embrava.com/pages/wants-more-information
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Appendix B - Configuring Contact Center
Optimization (CCO) for Genesys PureCloud
Download and Install Embrava Connect
1.

Download and Install Embrava Connect as described on page 3 of this User Guide.

Activate the Genesys PureCloud Connection within Embrava Connect
1.

Enter your CCO for Genesys PureCloud License key by opening Embrava Connect and
selecting ‘About Embrava Connect’ from the ‘Help’ menu and click ‘Upgrade’ as shown
below:

2. Enter your license key in the dialog displayed and click ‘Add License’. You may be asked to
restart Embrava Connect once the license has been added.
a. Alternatively, you may apply a license key to your version of Embrava Connect by
running the Embrava Connect MSI with the license key contained in a text file
called license.txt. The MSI will pickup and apply the license key from the file during
installation.
3. Once the license has been applied you will see the details of the license within the About
Embrava Connect dialog as shown below:
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4. Now the license has been applied, the Genesys option will now appear within the
Connections dialog. The Connections dialog can be accessed from the ‘File’ menu within
Embrava Connect. Check the Genesys connection option and click ‘Connect’ as shown
below.

5. A Genesys PureCloud authorization screen will now be displayed. Enter your PureCloud
credentials and click ‘Log In’.
©2018 Embrava Pty Ltd
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6. Once authorized, the Genesys PureCloud connection will now be active. You may
configure the alerts for different agent states and call duration as shown below.

7. Embrava Connect is now ready to receive data from Genesys PureCloud and display
alerts.
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Appendix C - Configuring Desk Booking with
EMS Software
Download and Install Embrava Connect
1.

Download and Install Embrava Connect as described on page 3 of this User Guide.

Configure EMS Software Platform Services and Embrava Connect Density Feature
License
1.

View the Desk Booking with EMS Software Configuration Guide for full details.
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Appendix D - Configuring Embrava Connect
for RingCentral
Download and Install Embrava Connect
1.

Download and Install Embrava Connect as described on page 3 of this User Guide.

Configure RingCentral Connection
1.

If you are running Embrava Connect for the first time, the Manage Connections window
will be displayed. If you have configured Embrava Connect previously, please open the
Embrava Connect main panel from the System Tray Embrava icon -> Open Embrava
Connect. Now select from Menu File -> Connections and the Manage Connections
window will be displayed.
2. On the Manage Connections dialog select the connection RingCentral.

3. Now click on the Connect button, a browser window called “RingCentral Authorization”
will be displayed. Sign-in to your production RingCentral account – Enter Phone number,
password (extension is optional but mandatory when using your main company number)
and click the Sign-In button

©2018 Embrava Pty Ltd
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4. The browser window will now go to next page displaying “Access Request” – Embrava
Connect for Windows is requesting access to RingCentral – “View your presence”. Click the
Authorize button.
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5. If you have entered the correct credentials, the browser window will be closed and
authorization completed silently. The Manage Connections window will then be displayed
again with ‘Connect’ button disabled and ‘Disconnect’ button enabled.
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6. Now click on the OK button on the Manage Connections window. Then you should see
RingCentral tab added to the Embrava Connect UI.

7. Please ensure that you have connected your Embrava device to the PC. Now if the
‘Connect’ button is displayed on the RingCentral tab, click on the Connect button and
your Embrava device will display the color as per the status of your RingCentral account.

©2018 Embrava Pty Ltd
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Appendix E - Configuring Embrava Connect
for Broadsoft
Enable API access on Broadsoft Communicator Server
1.

On the Broadsoft Communicator Server, update the config.xml to set the “api-provider”
value to ‘true’ to allow Embrava Connect to access Broadsoft user presence. See Section
10.21 -API for Third-Party Applications in UC-One for Desktop – Configuration Guide for
more details.
NB: The api-provider value should be set to true for v22 and above.
2. Once the “api-provider” value has been set to true, users should restart their
Communicator application.

Download and Install Embrava Connect
3. Download and Install Embrava Connect as described on page 3 of this User Guide.

Configure Broadsoft Connection
1.

If you are running Embrava Connect for the first time, the Manage Connections window
will be displayed. If you have configured Embrava Connect previously, please open the
Embrava Connect main panel from the System Tray Embrava icon -> Open Embrava
Connect. Now select from Menu File -> Connections and the Manage Connections
window will be displayed.
2. On the Manage Connections dialog select the connection Broadsoft connection and click
OK.
3. A ‘New Add-in’ dialog will be displayed on the Communicator application as shown
below:

4. Click ‘Enable’ and your presence and call events will now be displayed on your status light.
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Appendix F - Configuring Authentication
App for Skype for Business Online
Due to limitations on the Skype for Business client on Mac OS, the status updates of a user must
be gathered server-side instead of client-side. This section describes how your environment is to
be configured to allow Embrava Connect to gather status updates from Skype for Business Online.

Register Azure application for authentication
If your organization has user accounts on Office365, you must follow the Microsoft Azure Active
Directory (AD) registration flow as described below to allow your users to authenticate with Azure
AD when gathering status updates from Skype for Business Online.
Registering this application generates a unique application ID and other values that Embrava
Connect uses to authenticate with Azure AD when gathering the users status changes.
1.
2.
3.
4.
5.

Sign into the Microsoft App Registration Portal.
Click ‘Add an app’
Enter a name for the app (e.g. EmbravaConnectAuthApp) and click ‘Create application’.
Under Application Type, select Native Application
Specify a Redirect URL. The redirect URL is the location in the application that the Azure
AD v2.0 endpoint calls when it has processed the authentication request.
Enter "http://localhost"
6. Take note of the application/client ID. This unique identifier will be used in the Embrava
Connect application so that the user can authenticate against Azure when pulling
presence from Skype for Business Online.
7. Choose ‘Save’.
Once the application is registered, go to ‘Overview’ section of the app and ensure the Application
(client) ID as shown below.
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Configure Azure app for Authentication
1.

From the Overview section of the application created above, select the Authentication
item in the left-hand menu as shown below

2. Ensure the Redirect URI is set to http://localhost as shown above.
3. Scrolling down to the Advanced Setting of the Authentication section, ensure both ‘Access
tokens’ and ‘ID tokens’ checkboxes are checked as shown below:
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4. Once done, select the ‘API permissions’ item in the left-hand menu and add permissions
for Skype for Business as shown below.

5. Once the Skype for Business permissions are set, click the ‘Grant admin consent’ button as
shown above.
6. Next, click the ‘Manifest’ item in the left-hand menu as shown below.
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7. Ensure the “oauth2AllowIdTokenImplicitFlow” and “oauth2AllowImplicitFlow” variables are
set to True as shown above.

Your environment is now set for Embrava Connect to gather user status from Skype for Business
Online.
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Appendix G - Configuring Microsoft Teams
Embrava Connect integrates with Microsoft Teams using the Office UC Collaboration interface
when running Microsoft Teams in Teams Only mode. To allow Embrava Connect to subscribe to
status changes from Microsoft Teams please check the ‘Register Teams as the chat app for Office’
checkbox from the Settings menu within Microsoft Teams as shown below:

You may need to restart Embrava Connect or your PC once this change has been made.

END OF DOCUMENT
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